7. IGU QGIS

La interfaz gráfica de usuario (IGU) se muestra en la figura de abajo (los números de 1 a 5 en círculos amarillos indican elementos importantes de la IGU de QGIS, y se discuten abajo).

../../../_images/startup.png

Figura 7.1 Interfaz Gráfica de Usuario de QGIS con datos de muestra de Alaska

Nota

Las decoraciones de las ventanas (barra de título, etc.) pueden ser distintas dependiendo de su sistema operativo y su gestor de ventanas.

La IGU principal de QGIS (Figura 7.1) consta de cinco componentes/tipos de componentes:

  1. Barra de menú

  2. Barras de herramientas

  3. Paneles

  4. Vista de mapa

  5. Barra de estado

Desplazar hacia abajo para explicaciones detalladas de estos.

7.2. Paneles y Barras de Herramientas

Desde el menú Cer (o kde Configuración), puede cambiar widgets de QGIS (Paneles ►) y activar y desactivar barras de herramientas (Barras de Herramientas ►). Para (des)activar alguna de ellas, click-derecho en la barra de menú o barra de herramientas y escoja el elemento que quiera. Paneles y barras de herramientas se puede mover y ubicar donde quiera dentro de la interfaz de QGIS. La lista se puede ampliar con la activación de los Núcleo o complementos externos.

7.2.1. Barras de herramientas

Las barras de herramientas proporcionan acceso a la mayoría de las funciones en los menús, además de herramientas adicionales para interactuar con el mapa. Cada elemento de la barra de herramientas tiene ayuda emergente disponible. Pase el mouse sobre el elemento y se mostrará una breve descripción del propósito de la herramienta.

Cada barra de herramientas se puede mover según sus necesidades. Además, se pueden desactivar utilizando el menú contextual del botón derecho del mouse o manteniendo el mouse sobre las barras de herramientas.

Las barras de herramientas disponibles son:

Nombre

Referencia principal para herramientas

Barra de herramientas de digitalización avanzada

Digitalización avanzada

Barra de herramientas de anotaciones

Atributos

Trabajar con la tabla de atributos, Herramientas generales

Administrador Fuentes Datos

Administrar el origen de datos

Database

Complemento de Administración de BBDD

Digitizing

Digitalizando una capa existente

Ayuda

Etiqueta

La Barra de Herramientas Etiqueta

Administrar Capas

Abriendo Datos

Navegación de Mapa

Trabajando con el lienzo del mapa

Barra de herramientas de digitalización de malla

Plugins

Complementos

Project

Trabajando con Archivos de Proyecto, Diseñando los mapas, La librería Style

Algoritmos de procesamiento

Configurando el marco de procesamiento

Raster

Complementos

Selección

Seleccionando objetos espaciales

Digitalización de formas

Digitalización de formas

Snapping

Setting the snapping tolerance and search radius

Vectorial

Complementos

Web

Complementos, Cliente de Catálogo de metasearch

Nota

Los complementos de terceros pueden ampliar la barra de herramientas predeterminada con sus propias herramientas o proporcionar su propia barra de herramientas.

Truco

Restauración de barras de herramientas

Si accidentalmente ha ocultado una barra de herramientas, puede restaurarla usando View ► Toolbars ► (o kde Settings ► Toolbars ►). Si, por alguna razón, una barra de herramientas (o algún otro widget) desaparece totalmente de la interfaz, encontrará consejos para recuperarlo en restoring initial GUI.

7.2.2. Paneles

QGIS proporciona muchos paneles. Los paneles son widgets especiales con los que puede interactuar (seleccionar opciones, marcar casillas, completar valores …) para realizar tareas más complejas.

A continuación se muestra una lista de los paneles predeterminados proporcionados por QGIS:

7.3. Vista del mapa

7.3.1. Explorando la vista de mapa

La vista de Mapa (tambien llamada lienzo del Mapa) es la «cuestión final» de QGIS — los mapas se muestran en este área, en 2D. El mapa mostrado en esta ventana reflejará la representación (simbología, etiquetado, visibilidades…) que ha aplicado a las capas que cargó. También depende de las capas y el Sistema de Coordenadas de Referencia (SCR).

Cuando añade una capa (ver p.ej. Abriendo Datos), QGIS busca automáticamente su CRS. Si se establece un CRS diferente de forma predeterminada para el proyecto (consulte Sistema de Coordenadas de Referencia del Proyecto) entonces la extensión de la capa es trasladada «on-the-fly» a ese CRS, y la vista de mapa es ampliada a aquella extensión si empezó con un proyecto QGIS en blanco. Si ya hay capas en el proyecto, no se realiza el cambio de tamaño del lienzo del mapa, por lo que solo se verán las entidades que se encuentren dentro de la extensión del lienzo del mapa actual.

Click en la vista de mapa y será capaz de interactuar con él:

  • se puede panoramizar, desplazando la visualización a otra región del mapa: esto se realiza con el botón pan Pan Map tool,las teclas de flecha, moviendo el mouse mientras se mantiene presionada cualquiera de las kbd:Space key, el botón central del mouse o la rueda del mouse. Cuando se usa el mouse, la distancia y la dirección de la acción de desplazamiento se muestran en la barra de estado en la parte inferior.

  • puede acercarse y alejarse, con las herramientas dedicadas zoomIn Zoom In y zoomOut Zoom Out. Mantenga pulsada la tecla Alt para pasar de una herramienta a otra. El zoom también se realiza girando la rueda hacia delante para acercarse y hacia atrás para alejarse. El zoom se centra en la posición del cursor del ratón. Puede personalizar el Factor de zoom en el menú Configuración ► Opciones ► Herramientas del mapa.

  • se puede hacer zoom en toda la extensión de todas las capas cargadas zoomFullExtent Zoom Full), a todas las capas seleccionadas en el Layers panel (zoomToLayer Zoom to Layer(s)) o para extender las características seleccionadas de todas las capas seleccionadas en el Layers panel (zoomToSelected Zoom to Selection)

  • Puede navegar atrás/adelante mediante el visor del historial del canvas con los botones zoomLastZoom Anterior y zoomNextZoom Siguiente o usando los botones del ratón atrás/adelante.

Haga clic derecho sobre el mapa y debería poder editCopy Copy coordinates del punto pinchado en el SRC del mapa, en WGS84 o en un SRC personalizado. La información copiada puede luego pegarse en una expresión, en líneas de código, un editor de texto o una hoja de cálculo…

Por defecto,, QGIS abre una vista de mapa simple (llamada «mapa principal»), que está estrechamente ligado al panel Capas; el mapa principal automáticamente refleja los cambios que hace en el área del panel Capas. Pero también es posible abrir vistas de mapas adicionales cuyos contenidos pueden diverger del estado actual del panel Capas. Pueden ser de tipo 2D o 3D , mostrar diferentes escalas o extensión, o mostrar un conjunto diferente de las capas cargadas gracias a temas de mapa.

7.3.2. Ajustando vistas de mapa adicionales

Para añadir una nueva vista de mapa, vaya a Ver ► newMap Nueva Vista de Mapa. Un nuevo complemento flotante, imitando la representación de la vista del mapa principal, se agrega a QGIS. Puede agregar tantas vistas de mapa como necesite. Se pueden mantener flotando, colocadas una al lado de la otra o apiladas una encima de la otra.

../../../_images/map_views.png

Figura 7.2 Múltiples vistas de mapas con diferentes ajustes

En la parte superior de un lienzo de mapa adicional, hay una barra de herramientas con las siguientes capacidades:

  • zoomFullExtent| Zoom Full, zoomToSelected Zoom to Selection and zoomToLayer Zoom to Layer(s) para navegar dentro de la vista

  • showPresets Ajustar Tema Visual para seleccionar el tema de mapa a mostrar en el visor de mapa. Si se establece a (none), la vista seguirá los cambios del panel Capas.

  • options Configuración de visualización para configurar la vista de mapa:

    • radioButtonOn Sincronizar centro de vista con mapa principal: sincroniza el centro de las vistas del mapa sin cambiar la escala. Esto le permite tener un estilo de vista general o un mapa ampliado que sigue al centro del lienzo principal.

    • radioButtonOff Sincronizar vista a selección: igual que el zoom a la selección

    • Escala

    • Rotación

    • Magnificación

    • unchecked Sincronizar Escala con la escala del mapa principal. Una Factor de Escala puede entonces ser aplicado, permitiéndole tener una vista que es p.ej. siempre 2 veces la escala del lienzo principal.

    • checkbox Mostrar Anotaciones

    • checkbox MOstrar Posición Cursor

    • unchecked MOstrar extensión del lienzo principal

    • checkbox Mostrar Etiquetas: permite ocultar etiquetas independientemente de que estén establecidas en las propiedades de las capas mostradas

    • Cambiar SCR del mapa…

    • Renombrar Vista…

7.3.3. Control basado en el tiempo en el lienzo del mapa

QGIS puede manejar el control temporal en las capas cargadas, es decir, modificar la representación del lienzo del mapa en función de una variación de tiempo. Para lograr esto, necesitas:

  1. Capas que tienen establecidas propiedades temporales dinámicas. QGIS admite control temporal para diferentes proveedores de datos, con configuraciones personalizadas. Se trata principalmente de establecer el rango de tiempo en el que se mostrará la capa:

    • vector layers: las características se filtran en función de los valores de tiempo asociados a sus atributos

    • mesh layers: muestra dinámicamente los valores de los grupos de conjuntos de datos activos

    Cuando las opciones temporales dinámicas están habilitadas para una capa, un |indicadorTemporal| El icono se muestra junto a la capa :guilabel: Layers para recordarle que la capa está controlada temporalmente. Haga clic en el icono para actualizar la configuración temporal.

  2. Habilite la navegación temporal del lienzo del mapa usando el:ref:Temporal controller panel <temporal_controller>. El panel se activa:

    • usando el |temporal Temporal controller panel icon located in the :guilabel:`Barra de herramientas de navegación del mapa

    • desde :menuselection:`Ver –> Paneles –> Menú del panel del controlador temporal

7.3.3.1. El panel del controlador temporal

The :guilabel:`El panel del controlador temporal tiene los siguientes modos:

../../../_images/temporal_controller_panel.png

Figura 7.3 Panel de control temporal en modo de navegación

  • temporalNavigationOff Desactivar la navegación temporal: todas las configuraciones temporales están deshabilitadas y las capas visibles se representan como de costumbre

  • temporalNavigationFixedRange Fixed range temporal navigation: se establece un rango de tiempo y solo se muestran en el mapa las capas (o entidades) cuyo rango temporal se superpone con este rango.

  • temporalNavigationAnimated Animated temporal navigation: se establece un intervalo de tiempo, se divide en pasos y solo se muestran en el mapa las capas (o entidades) cuyo intervalo temporal se superpone con cada cuadro

  • settings Settings para el control general de la animación

    • Frames rate: número de pasos que se muestran por segundo

    • unchecked Rango acumulativo: todos los fotogramas de la animación tendrán la misma fecha-hora de inicio pero diferentes fechas y horas de finalización. Esto es útil si desea acumular datos en su visualización temporal en lugar de mostrar una ‘ventana de tiempo en movimiento’ a través de sus datos.

7.3.3.2. Animando una navegación temporal

Una animación se basa en un conjunto variable de capas visibles en momentos determinados dentro de un intervalo de tiempo. Para crear una animación temporal:

  1. Toggle on the temporalNavigationAnimated Animated temporal navigation, mostrando el widget del reproductor de animación

  2. Introduzca el Rango de tiempo a considerar. Usando el botón refresh, esto puede ser definido como:

    • Set to full range de todas las capas habilitadas en el tiempo

    • Establecido en el rango de proyecto preestablecido como se define en el :ref:`project properties <project_temporal>

    • :guilabel:`Establecido en el rango de una sola capa tomado de una capa habilitada para el tiempo

  3. Llenar in el tiempo Step para separar el rango de tiempo. Se admiten diferentes unidades, desde segundos hasta siglos. También está disponible como paso una opción de marcas de tiempo de origen: cuando se selecciona, hace que la navegación temporal avance entre todos los rangos de tiempo disponibles de las capas en el proyecto. Es útil cuando un proyecto contiene capas con horas disponibles no contiguas, como un servicio WMS-T que proporciona imágenes que están disponibles en fechas irregulares. Esta opción le permitirá pasar solo entre rangos de tiempo donde se muestra la siguiente imagen disponible.

  4. Click al botón play para obtener una vista previa de la animación. QGIS generará escenas utilizando la representación de capas en los tiempos establecidos. La visualización de las capas depende de si se superponen a un marco de tiempo individual.

    ../../../_images/map_navigation.gif

    Figura 7.4 Navegación temporal a través de una capa

    La animación también se puede previsualizar moviendo el control deslizante de tiempo. manteniendo el botón refresh Loop presionado ejecutará repetidamente la animación mientras hace clicen play detiene una animación en ejecución. Se encuentra disponible un conjunto completo de botones del reproductor de video.

    El desplazamiento horizontal con la rueda del mouse (cuando sea compatible) con el cursor en el lienzo del mapa también le permitirá navegar, o «barrer», el control deslizante de navegación temporal hacia adelante y hacia atrás.

  5. Click en el botón fileSave Export animation si desea generar una serie de imágenes que representan la escena. Se pueden combinar más tarde en un software de edición de video:

    ../../../_images/saveTimeAnimation.png

    Figura 7.5 Exportación de escenas de animación de lienzo de mapa a imágenes

    • El nombre del archivo:guilabel:Template: los #### se reemplazan con el número de secuencia del cuadro

    • El Directorio de salida

    • En Configuración del mapa, puedes:

      • redefinir el spatial extent para usar

      • control the Resolución de la imagen (Ancho de salida y Altura de salida)

      • Dibujar decoraciones activas: si está activa:ref:decorations <decorations> debe mantenerse en la salida

    • En Configuración temporal, puede redefinir:

      • El tiempo Range para la animación

      • El Paso (longitud del marco) en la unidad de su elección

7.3.4. Exportando la vista de mapa

Los mapas que hagas se pueden diseñar y exportar a varios formatos utilizando las capacidades avanzadas de imprimir diseño o reportar. También es posible exportar directamente el renderizado actual, sin un diseño. Esta rápida «captura de pantalla» de la vista del mapa tiene algunas características convenientes.

Para exportar el lienzo de mapa con la representación actual:

  1. Vaya a Proyecto ► Importar/Exportar

  2. Dependiendo de su formato de salida, seleccione

    • saveMapAsImage Exportar Mapa a Imagen…

    • or saveAsPDF Exportar Mapa a PDF…

Las dos herramientas le brindan un conjunto común de opciones. En el cuadro de diálogo que se abre:

../../../_images/saveMapAsImage.png

Figura 7.6 El cuadro de diálogo Guardar mapa como imagen

  1. Escoja la Extent a exportar: puede ser la extensión de la vista actual (la predeterminada), la extensión de una capa o una extensión personalizada dibujada sobre el lienzo del mapa. Las coordenadas del área seleccionada se muestran y se pueden editar manualmente.

  2. Introduzca la Escala del mapa o seleccionela desde escalas predefinidas: cambiando la escala cambiará el tamaño de la exportación (desde el centro).

  3. Establezca la Resolución de la salida

  4. Controle la anchura de Salida y altura de Salida en pixels de la imagen: basada por defecto en la resolución y extensión actual, se pueden personalizar y redimensionar la extensión del mapa (desde el centro). La relación de tamaño se puede bloquear, lo que puede ser particularmente conveniente al dibujar la extensión en el lienzo.

  5. checkbox Dibujar decoraciones activas: en uso decoraciones (barra de escala, título, malla, flecha del nortea..) son exportadas con el mapa

  6. checkbox Dibujar anotaciones para exportar alguna anotación

  7. checkbox Agregar información de georreferencia (incrustada o vía archivo de mundo): dependiendo del formato de salida, un archivo mundial con el mismo nombre (con la extensión PNGW para imágenes PNG, JPGW para JPG, …) se guarda en el mismo carpeta como tu imagen. El formato PDF incrusta la información en el archivo PDF.

  8. Al exportar a PDF, están disponibles mas opciones en el Cuadro de diálogo Guardar mapa como PDF… :

    ../../../_images/saveMapAsPDF.png

    Figura 7.7 El diálogo Guardar Mapa como PDF

    • checkbox Export RDF metadata del documento, como el título, autor, fecha, descripción …

    • unchecked Create Geospatial PDF (GeoPDF): Generar una georeferenced PDF file (requiere version GDAL 3 o posterior). Puede:

      • Escoja el Format GeoPDF

      • checkbox Include vector feature information en el archivo GeoPDF: incluirá toda la información de geometría y atributos de las entidades visibles dentro del mapa en el archivo GeoPDF de salida.

      Nota

      Desde QGIS 3.10, con archivos de GDAL 3 un GeoPDF puede además ser usado como una fuente de datos. Para mayor soporte sobre GeoPDF en QGIS, ver https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/.

    • Rasterize map

    • checkbox Simplify geometries to reduce output file size: Las geometrías se simplificarán al exportar el mapa al eliminar los vértices que no son perceptiblemente diferentes en la resolución de exportación (por ejemplo, si la resolución de exportación es 300 dpi, los vértices que estén a menos de 1/600 inch de separación serán borrados). Esto puede reducir el tamaño y la complejidad del archivo de exportación (los archivos muy grandes pueden no cargarse en otras aplicaciones).

    • Establezca los controles Text export: si las etiquetas de texto se exportan como objetos de texto adecuados (Always export texts as text objects) o solo como trayectorias (Always export texts as paths). Si se exportan como objetos de texto, se pueden editar en aplicaciones externas (por ejemplo, Inkscape) como texto normal. PERO el efecto secundario es que la calidad de representación disminuye, Y hay problemas con la representación cuando ciertas configuraciones de texto, como los búferes, están en su lugar. Por eso se recomienda exportar como rutas.

  9. Click Save para seleccionar la ubicación, el nombre y el formato del archivo.

    Al exportar a imagen, también es posible Copy to clipboard el resultado esperado de la configuración anterior y pegue el mapa en otra aplicación como LibreOffice, GIMP …

7.4. Vista de Mapa 3D

El soporte de visualización 3D se ofrece a través de la vista de mapa 3D. Puede crear y abrir una vista de mapa en 3D mediante View ► new3DMap New 3D Map View. Aparecerá un panel QGIS flotante. El panel se puede acoplar.

Para empezar, la vista del mapa 3D tiene la misma extensión y vista que el lienzo del mapa principal 2D. Hay un conjunto de herramientas de navegación disponibles para convertir la vista en 3D.

../../../_images/3dmapview.png

Figura 7.8 El diálogo de Visor de Mapa 3D

Las siguientes herramientas son proporcionadas en la parte superior del panel del Visor de Mapa 3D:

  • pan Camera control: mueve la vista, menteniendo el mismo ángulo y dirección de la cámara

  • zoomFullExtent Zoom Full: resizes the view to the whole layers” extensión

  • 3dNavigation Toggle on-screen notification: muestra/oculta el widget de navegación (para facilitar el control de la vista del mapa)

  • identify Identify: devuelve información sobre el punto del terreno en el que se hizo click o las entidades 3D en las que se hizo click - Más detalles en Identificando entidades

  • measure Measurement line: mide la distancia horizontal entre dos puntos

  • play Animations: muestra/oculta el widget animation player

  • saveMapAsImage Save as image…: exporta la vista actual a un archivo en formato imagen

  • 3d Exportar Escena 3D…: exporta la vista actual como una escena 3D (:file:archivo .obj), permitiendo el postprocesado en aplicaciones como Blender… El Terreno y las entidades vectoriales son exportadas como objetos 3D. La configuración de exportación, suplantando las propiedades de las capas o la configuración de la vista de mapa, incluyendo:

    • nombre de Escena y Carpeta de destino

    • Resolución del Terreno

    • Resolución de la textura del Terreno

    • Escala del Modelo

    • checkbox Suavizar formas

    • checkbox Exportar normales

    • checkbox Exportar texturas

  • showPresets Establecer Tema de Vista: Le permite seleccionar el conjuntod e capas a mostrar en la vista de mapa a partir de unos temas de mapa predefinidos.

  • options Configurar Ajustes de la vista de mapa

7.4.1. Configuración de la escena

El visor de mapa 3D se abre con algunas configuraciones predeterminadas que puede personalizar. Para hacerlo, haga click en el botón options Configure… en la parte superior del panel de lienzo 3D para abrir la ventana 3D configuration .

../../../_images/3dmapconfiguration.png

Figura 7.9 El diálogo de Comfiguración de Mapa 3D

En la ventana de Configuración 3D hay varias opciones para afinar la escena 3D:

7.4.1.1. Terreno

  • Terreno: Antes de entrar en mas detalles, vale la pena señalar que el terreno en una vista 3D está representado por una jerarquía de mosaicos de terreno y, a medida que la cámara se acerca al terreno, los mosaicos existentes que no tienen suficientes detalles son reemplazados por mosaicos más pequeños con más detalles. Cada mosaico tiene una geometría de malla derivada de la capa ráster de elevación y la textura de las capas del mapa 2D.

    • El Tipo de terreno de elevación puede ser:

    • Elevación: Ráster o capa de malla a ser usada para la generación del terreno. La capa ráster puede contener una banda que represente la elevación. Para una capa de malla, se usan los valores Z de los vértices.

    • Escala Vertical: Facto de escala para eje vertical. Incrementando la escala exagerará la altura de los accidentes geográficos.

    • Resolución de Teselas: Cuántas muestras de la capa ráster del terreno se utilizarán para cada mosaico. Un valor de 16 px significa que la geometría de cada mosaico consistirá en 16x16 muestras de elevación. Los números más altos crean mosaicos de terreno más detallados a expensas de una mayor complejidad de representación.

    • Skirt height: A veces es posible ver pequeñas grietas entre las baldosas del terreno. Al aumentar este valor, se agregarán paredes verticales («skirts») alrededor de las baldosas del terreno para ocultar las grietas.

  • :guilabel:`Compensación de elevación del terreno: mueve el terreno hacia arriba o hacia abajo, p. para ajustar su elevación con respecto al nivel del suelo de otros objetos en la escena.

    Esto puede ser útil cuando hay una discrepancia entre la altura del terreno y la altura de las capas en su escena (por ejemplo, nubes de puntos que usan solo una altura vertical relativa). En este caso, ajustar la elevación del terreno manualmente para que coincida con la elevación de los objetos en su escena puede mejorar la experiencia de navegación.

  • Cuando una capa de malla es usada como terreno, puede configurar la Configuración de Triángulos (vista de estructura de alambres, suavizado de triángulos) y la configuración de colores de Renderizado (como uniforme o dependiente del nivel del terreno). Mas detalles en la sección propiedades de capa de Malla .

  • unchecked Sombreado del Terreno: Le permite elegir cómo se debe representar el terreno:

    • Sombreado deshabilitado: el color del terreno se determina solo a partir de la textura del mapa

    • Sombreado habilitado: el color del terreno se determina utilizando el modelo de sombreado de Phong, teniendo en cuenta la textura del mapa, el vector normal del terreno, las luces de la escena y el material del terreno Ambient y color Specular y Shininess

7.4.1.2. Luces

Desde la pestaña Luces, presioneel menú symbologyAdd para añadir

  • hasta ocho luces puntuales: emite luz en todas las direcciones, como una esfera de luz rellenando un área. Los objectos cercanos a la luz serán mas brillantes, y los objetos mas alejados estarán mas oscuros. Una luz puntual tiene una posición establecida (X, Y y Z), un Color, una Intensidad y una Atenuación

  • hasta cuatro Luces Direccionales: imita la iluminación que obtendrías de un flash gigante muy alejado de tus objetos, siempre centrado y que nunca se apaga (por ejemplo, el sol). Emite rayos de luz paralelos en una sola dirección, pero la luz llega al infinito. Una luz direccional se puede girar dado un Azimuth, tiene una Altitud, un Color y una Intensidad.

../../../_images/3dmapconfiguration_lights.png

Figura 7.10 El cuadro de diálogo Configuración de luces de mapa 3D

7.4.1.3. Sombras

Marcar unchecked Mostrar Sombras para visualizar sombras en su escena, ofrecidas:

  • una luz Direccional

  • un distancia máxima de representación de Sombra: para evitar la generación de sombras de objetos demasiado distantes, especialmente cuando la cámara mira hacia el horizonte

  • un Sesgo de sombra: para evitar efectos de auto-sombreado que podrían oscurecer algunas áreas que otras, debido a las diferencias entre los tamaños de los mapas. Cuanto más bajo mejor

  • una resolución de Sombra de mapa: para hacer que las sombras se vean más nítidas. Puede derivar en un menor rendimiento si el parámetro de resolución es demasiado alto.

7.4.1.4. Camera & Skybox

En esta pestaña, puede anular algunos default camera settings hecho en Configuración ► Opciones ► Cuadro de diálogo 3D.

Además, marque unchecked Show skybox para habilitar el renderizado de skybox en la escena. El tipo de palco puede ser:

  • textura Panorámica, con un solo archivo que proporciona visión de 360°

  • Distintas caras, con un archivo de textura para cada una de las seis caras de un cubo que contiene la escena

Los archivos de imagen de textura del skybox pueden ser archivos en el disco, direcciones URL remotas o incrustados en el proyecto (more details).

7.4.1.5. Avanzado

  • resolución de tesela de mapa: Ancho y alto de las imágenes del mapa 2D utilizadas como texturas para los mosaicos del terreno. 256 px significa que cada mosaico se renderizará en una imagen de 256x256 píxeles. Los números más altos crean mosaicos de terreno más detallados a expensas de una mayor complejidad de representación.

  • error de pantalla Max.: Determina el umbral para intercambiar mosaicos de terreno con más detallados (y viceversa), es decir, qué tan pronto la vista 3D utilizará mosaicos de mayor calidad. Los números más bajos significan más detalles en la escena a expensas de una mayor complejidad de representación.

  • Max. ground error: La resolución de los mosaicos de terreno en los que se detendrá la división de mosaicos en otros más detallados (dividirlos no introduciría ningún detalle adicional de todos modos). Este valor limita la profundidad de la jerarquía de mosaicos: los valores más bajos hacen que la jerarquía sea profunda, lo que aumenta la complejidad de la representación.

  • niveles de Zoom: Muestra el número de niveles de zoom (depen de la resolución en el mosaico de mapa y error de tierra max.).

  • unchecked Mostrar etiquetas: Activa/desactiva las etiquetas del mapa

  • unchecked Show map tile info: Incluya números de borde y mosaico para los mosaicos de terreno (útil para solucionar problemas de terreno)

  • unchecked Mostrar cuadros delimitadores: Mostrar cuadros delimitadores 3D de los mosaicos de terreno (útil para solucionar problemas de terreno)

  • unchecked Show camera’s view center

  • unchecked Mostrar fuentes luminosas: muestra una esferea en el origen de la fuente de luz, permitiendo fácilmente el reposicionado y emplazamiento de las fuentes de luz relativas al contenido de la escena

7.4.3. Creando una animación

Una animación está basada en un conjunto de keyframes - posiciones de cámara a tiempos particulares. Para crear una animación:

  1. Alternar en la herramienta play Animations , mostrando el widget del reproductor de animación

  2. Click en el botón symbologyAdd Add keyframe e introduzca en segundos Keyframe time. El Keyframe combo box ahora muestra el tiempo establecido.

  3. Usando las herramientas de navegación, mueva la cámara a la posición a asociar con el tiempo del keyframe actual.

  4. Repita los pasos previos para añadir tantos keyframes (con tiempo y posición) como sea necesario.

  5. Click en el botón play para previsualizar la animación. QGIS generará escenas utilizando las posiciones / rotaciones de la cámara en los tiempos establecidos, y las interpolará entre estos fotogramas clave. Varios modos Interpolation para las animaciones están disponibles (p.ej., linear, inQuad, outQuad, inCirc… – mas detalles en https://doc.qt.io/qt-5/qeasingcurve.html#EasingFunction-typedef).

    La animación también se puede previsualizar moviendo el deslizador de tiempo. Si se mantiene marcada la casilla Ciclo se ejecutará repetidamente la animación mientras que si se pulsa play se detiene una animación en curso.

Click fileSave Export animation frames para generar una serie de imágenes que representan la escena. Aparte del nombre del archivo Template y el Output directory, puede establecer el número de Frames per second, la Output width y Output height.

7.4.4. Capas vectoriales 3D

Se puede mostrar una capa vectorial con valores de elevación en la vista del mapa 3D marcando Enable 3D Renderer en la sección 3D View de las propiedades de la capa vectorial. Hay varias opciones disponibles para controlar la representación de la capa vectorial 3D.

7.5. Barra de Estado

La barra de estado le proporciona información general sobre la vista del mapa y las acciones procesadas o disponibles, y le ofrece herramientas para administrar la vista del mapa.

7.5.1. Barra de Localizador

En el lado izquierdo de la barra de estado, la barra de localizador, un complemento de búsqueda rápida, le ayuda a encontrar y ejecutar cualquier funcionalidad u opción en QGIS:

  1. Click en el complemento de texto para activar la barra de búsqueda de localizador o presionando Ctrl+K.

  2. Escriba un texto asociado al elemento que está buscando (nombre, etiqueta, palabra clave, …). De forma predeterminada, los resultados se devuelven a los filtros de localizadores habilitados, pero puede limitar la búsqueda a un cierto alcance colocando un prefijo en su texto con prefijo filtros de localizador, p.ej. escribiendo l cad devolverá solo las capas cuyo nombre contiene cad.

    El filtro puede también ser seleccionada con un doble-click en el menú mostrado al acceder al complemento del localizador.

  3. Click en un resultado para ejecutar la acción correspondiente, dependiendo del tipo de elemento.

Truco

Limitar la búsqueda a campo(s) particulares de la capa activa

Por defecto, una búsqueda con el filtro «características de la capa activa» (f) recorre la tabla de atributos de la capa entera. Puede limitar la búsqueda a un campo en particular usando el prefijo @. P.Ej. f @name sal o @name sal devuelve solo las entidades cuyo atributo «name» contiene “sal”. El autocompletado de texto está activado al escribir y la sugerencia puede ser aplicada usando la tecla Tab.

Es posible un control más avanzado sobre los campos consultados desde la capa Fields tab. Read Propiedades de campos para mostrar detalles

La búsqueda se maneja mediante hilos, de modo que los resultados siempre estén disponibles lo más rápido posible, incluso si se instalan filtros de búsqueda lentos. También aparecen tan pronto como son detectados por un filtro, lo que significa que, p. Ej. un filtro de búsqueda de archivos mostrará los resultados uno por uno a medida que se escanea el árbol de archivos. Esto garantiza que la interfaz de usuario siempre responda, incluso si hay un filtro de búsqueda muy lento (por ejemplo, uno que utiliza un servicio en línea).

Nota

La herramienta de localización de Nominatim puede comportarse de manera diferente (sin búsqueda de autocompletado, retraso en la obtención de resultados, …) con respecto a la política de uso de OpenStreetMap Nominatim. <https://operations.osmfoundation.org/policies/nominatim/>`_.

Truco

Acceso rápido a los ajustes del localizador

Click en el icono search dentro del complemento del localizador en la barra de estado para mostrar la lista de filtros que puede usar y una entrada Configurar que abre la pestaña Localizador del menú AJustes ► Opciones….

7.5.2. Reporte de acciones

En el área junto a la barra de ubicación, se mostrará un resumen de las acciones que ha llevado a cabo cuando sea necesario (como seleccionar entidades en una capa, eliminar una capa, desplazar la distancia y la dirección) o una descripción larga de la herramienta que está desplazando. over (no disponible para todas las herramientas).

En el caso de operaciones prolongadas, como la recopilación de estadísticas en capas ráster, la ejecución de algoritmos de procesamiento o la representación de varias capas en la vista de mapa, se muestra una barra de progreso en la barra de estado.

7.5.3. Controlar el lienzo del mapa

La opción tracking Coordinate muestra la posición actual del mouse, siguiéndola mientras se mueve por la vista del mapa. Puede configurar las unidades (y la precisión) en la pestaña Project ► Properties… ► General. Click en el botón pequeño a la izquierda del cuadro de texto para alternar entre la opción coordinar y la opción extents Extents que muestra las coordenadas de las esquinas actuales inferior izquierda y superior derecha de la vista de mapa en unidades de mapa.

Junto a la pantalla de coordenadas, encontrará la pantalla Scale. Muestra la escala de la vista del mapa. Hay un selector de escala, que le permite elegir entre predefined and custom scales.

En el lado derecho de la pantalla de la báscula, presione el botón lockedGray para bloquear la escala para usar la lupa para acercar o alejar. La lupa le permite acercar un mapa sin alterar la escala del mapa, lo que facilita ajustar con precisión las posiciones de las etiquetas y los símbolos. El nivel de aumento se expresa como un porcentaje. Sí Magnifier tiene un nivel del 100%, entonces el mapa actual no se amplía, es decir, se representa a una escala precisa en relación con la resolución del monitor (DPI). Se puede definir un valor de ampliación predeterminado dentro de Configuración ► Opciones ► Representación ► Comportamiento de representación, que es muy útil para pantallas de alta resolución para agrandar pequeños símbolos. Además, una configuración en Configuración ► Opciones ► Lienzo y Leyenda ► DPI controla si QGIS respeta el DPI físico de cada monitor o usa el DPI lógico general del sistema.

A la derecha de la herramienta de lupa puede definir una rotación actual en sentido horario para su vista de mapa en grados.

En el lado derecho de la barra de estado, hay una pequeña casilla de verificación que se puede usar temporalmente para evitar que las capas se muestren en la vista del mapa (ver sección Renderizado).

A la derecha de las funciones de renderizado, encontrará el botón projectionEnabled EPSG:code mostrando el proyecto actual CRS. Al hacer clic en esto, se abre el diálogo Project Properties y le permite aplicar otro CRS a la vista de mapa.

Truco

Calcular la escala correcta de su lienzo de mapa

Cuando inicia QGIS, el CRS predeterminado es WGS 84 (EPSG 4326) '' y las unidades son grados. Esto significa que QGIS interpretará cualquier coordenada en su capa como se especifica en grados. Para obtener valores de escala correctos, puede cambiar manualmente esta configuración en la pestaña :guilabel:`General` bajo :menuselection:`Project --> Properties...` (p.ej. a metros), o puede usar el icono |projectionEnabled| :sup:`EPSG:code` mostrado encima. En el último caso, las unidades se configuran según lo que especifica la proyección del proyecto (p. Ej., ``+units=us-ft).

Tenga en cuenta que la opción de CRS en el inicio se puede configurar en Settings ► Options ► CRS.

7.5.4. Mensajería

El botón messageLog Messages al lado de él abre el Log Messages Panel que tiene información sobre procesos subyacentes (inicio de QGIS, carga de complementos, herramientas de procesamiento …)

En función de la configuración del Administrador de Complementos, la barra de estado puede a veces mostrar iconos a la derecha para informarle sobre la disponibilidad de nuevos (pluginNew) o actualizables (pluginUpgrade) complementos. Click en el icono para abrir el diálogo de Administrador de Complementos.