7. QGIS图形用户界面

QGIS图形用户界面 (GUI) 如下图所示 (黄色圆圈中的数字 1 到 5 表示QGIS图形用户界面的重要元素,将在下面讨论)。

../../../_images/startup.png

图 7.1 带阿拉斯加样本数据的QGIS图形用户界面

备注

根据操作系统和窗口管理器的不同,窗口装饰(标题栏等)可能会有所不同。

QGIS主界面 (图 7.1) 由五个组件类型构成:

  1. 菜单栏

  2. 工具栏

  3. 面板

  4. 地图视图

  5. 状态栏

向下滚动,并查看这些内容的详细说明。

7.2. 面板和工具栏

视图 菜单 (或 kde 设置),您可以打开和关闭QGIS控件 (面板 ►) 和工具栏 (工具栏 ►)。要 (取消) 激活其中任何一项,请右键单击菜单栏或工具栏,选择所需项。面板和工具栏可以在QGIS界面中移动和放置在任何你喜欢的地方。该列表还可以通过激活 核心或外部插件 进行扩展。

7.2.1. 工具栏

工具栏提供了对菜单中大多数功能的访问,以及与地图交互的其他工具。每个工具栏项都有可用的弹出帮助。将鼠标悬停在所选项上,将显示工具用途的简短描述。

每个工具栏都可以根据需要移动。此外,可以使用鼠标右键上下文菜单或将鼠标放在工具栏上关闭它们。

可用工具栏包括:

名称

工具主要参考资料

高级数字化工具栏

Advanced digitizing

注记工具栏

属性

属性表操作, 常用工具

数据源管理器

管理数据源

数据库

DB Manager Plugin

数字化

Digitizing an existing layer

帮助

标注

The Label Toolbar

图层管理

Opening Data

地图浏览

Working with the map canvas

网孔数字化工具栏

插件

插件

工程

使用工程文件, Laying out the maps, 样式库

处理算法

Configuring the Processing Framework

栅格

插件

选择

Selecting features

形状数字化

Shape digitizing

捕捉

Setting the snapping tolerance and search radius

矢量

插件

Web

插件, MetaSearch Catalog Client

备注

第三方插件可以使用自己的工具或提供其自己的工具栏扩展默认工具栏。

小技巧

恢复工具栏

如果不小心隐藏了工具栏,您可以使用 视图 ► 工具栏 ► (或 kde 设置 ► 工具栏 ►)将其恢复。如果由于某种原因,工具栏 (或任何其他控件) 完全从界面中消失,您可以在 恢复初始GUI 中找到恢复它的提示。

7.2.2. 面板

QGIS提供了许多面板。面板是特殊控件,可以与之交互的 (选择选项、复选框、填充值…) 执行更复杂的任务。

以下是QGIS提供的默认面板列表:

7.3. 地图视图

7.3.1. 探索地图视图

地图视图 (又称为 地图画布) 是QGIS的 "业务端" --- 地图以2D的形式显示在该区域,此窗口中显示的地图将反映您应用于已加载图层的渲染 (符号化、标注、可见性...),它还取决于图层和工程的坐标参照系 (CRS)。

当您添加图层时 (例如,请参阅 Opening Data),QGIS自动查找其CRS。如果默认情况下为工程设置了不同的CRS (请参阅 Project Coordinate Reference Systems),图层范围将 "动态" 转换为该CRS,如果从空QGIS工程开始,地图视图将缩放到该范围。如果工程中已存在图层,则不会执行地图画布调整,因此只有位于当前地图画布范围内的要素可见。

单击地图视图,您应该能够与之交互:

  • 可以平移,将显示移动到地图的另一个区域:这是使用 pan 平移地图 工具、方向键、按下 空格 键同时移动鼠标、按住鼠标中键或鼠标滚轮等工具执行的。使用鼠标时,平移动作的距离和方向显示在底部的状态栏中。

  • it can be zoomed in and out, with the dedicated zoomIn Zoom In and zoomOut Zoom Out tools. Hold the Alt key to switch from one tool to the other. Zooming is also performed by rolling the wheel forward to zoom in and backwards to zoom out. The zoom is centered on the mouse cursor position. You can customize the Zoom factor under the Settings ► Options ► Map tools menu.

  • 可以缩放到所有加载图层的整个范围 (zoomFullExtent 全图显示)、 图层 面板中所有选中图层的范围 (zoomToLayer 缩放到图层) 或 图层 面板中所有选中图层的选中要素的范围 (zoomToSelected 缩放到选中要素的范围)

  • 您可以使用 zoomLast回到上一视图zoomNext下一视图 按钮或使用后退/前进鼠标按钮在画布视图历史中进行浏览。

右键单击地图,您应该能够在地图的CRS、WGS84或自定义CRS中 editCopy 复制坐标 单击点的坐标,然后可以将复制的信息粘贴到表达式、脚本、文本编辑器或电子表格中...

默认情况下,QGIS打开单个地图视图 (称为 "主地图"),该视图与 图层 面板紧密绑定;主地图会 自动 反映您在 图层 面板区域中所做的更改。但也可以打开其他地图视图,其内容可能与 图层 面板的当前状态不同。它们可以是2D或 3D 类型,显示不同的比例或范围,或者由于 地图主题 而显示不同的加载图层集。

7.3.2. 设置其他地图视图

要添加新的地图视图,请转到 视图 ► newMap 新建地图视图。QGIS中添加了新的浮动控件,模拟主地图视图的渲染。可以根据需要添加任意数量地图视图,它们可以保持浮动,并排放置或堆叠在一起。

../../../_images/map_views.png

图 7.2 具有不同设置的多个地图视图

在新建的地图画布顶部,有一个具有以下功能的工具栏:

  • zoomFullExtent 全图显示, zoomToSelected 缩放到选中要素的范围zoomToLayer 缩放到图层 可在视图中导航

  • showPresets 设置视图主题 以选择要在地图视图中显示的:ref:地图主题 <map_themes>。如果设置为 (无),视图将跟随 图层 面板的变化而变化。

  • options 视图设置 用来配置地图视图:

    • radioButtonOn 视图中心与主地图同步: 在不更改比例的情况下同步地图视图的中心,这允许您在主画布中心有一个鹰眼图样式或放大的地图。

    • radioButtonOff 将视图与所选内容同步: 与 "缩放到选中的区域" 作用相同

    • 比例

    • 旋转角度

    • 放大

    • unchecked 同步比例 与主地图比例一致。然后可以应用 比例因子,使您可以拥有一个例如始终是主画布比例2倍的视图。

    • checkbox 显示注记

    • checkbox 显示指针位置

    • unchecked 显示主要画布范围

    • checkbox 显示标注: 允许隐藏标注,无论它们在显示图层的属性中如何设置

    • 更改地图CRS...

    • 重命名视图...

7.3.3. 地图画布上基于时间的控件

QGIS可以处理加载图层中的时态控制,即根据时间变化修改地图画布渲染。为此,您需要:

  1. Layers that have dynamic temporal properties set. QGIS supports temporal control for different data providers, with custom settings. It's mainly about setting the time range in which the layer would display:

    • vector layers: features are filtered based on time values associated to their attributes

    • mesh layers: displays dynamically the active dataset groups values

    When dynamic temporal options are enabled for a layer, an indicatorTemporal icon is displayed next to the layer in the Layers panel to remind you that the layer is temporally controlled. Click the icon to update the temporal settings.

  2. Enable the temporal navigation of the map canvas using the Temporal controller panel. The panel is activated:

    • using the temporal Temporal controller panel icon located in the Map Navigation toolbar

    • or from the View ► Panels ► Temporal controller panel menu

7.3.3.1. The temporal controller panel

The Temporal controller panel has the following modes:

../../../_images/temporal_controller_panel.png

图 7.3 Temporal Controller Panel in navigation mode

  • temporalNavigationOff Turn off temporal navigation: all the temporal settings are disabled and visible layers are rendered as usual

  • temporalNavigationFixedRange Fixed range temporal navigation: a time range is set and only layers (or features) whose temporal range overlaps with this range are displayed on the map.

  • temporalNavigationAnimated Animated temporal navigation: a time range is set, split into steps, and only layers (or features) whose temporal range overlaps with each frame are displayed on the map

  • settings Settings for general control of the animation

    • Frames rate: number of steps that are shown per second

    • unchecked Cumulative range: all animation frames will have the same start date-time but different end dates and times. This is useful if you wish to accumulate data in your temporal visualisation instead of showing a ‘moving time window’ across your data.

7.3.3.2. Animating a temporal navigation

An animation is based on a varying set of visible layers at particular times within a time range. To create a temporal animation:

  1. Toggle on the temporalNavigationAnimated Animated temporal navigation, displaying the animation player widget

  2. Enter the Time range to consider. Using the refresh button, this can be defined as:

    • Set to full range of all the time enabled layers

    • Set to preset project range as defined in the project properties

    • Set to single layer's range taken from a time-enabled layer

  3. Fill in the time Step to split the time range. Different units are supported, from seconds to centuries. A source timestamps option is also available as step: when selected, this causes the temporal navigation to step between all available time ranges from layers in the project. It’s useful when a project contains layers with non-contiguous available times, such as a WMS-T service which provides images that are available at irregular dates. This option will allow you to only step between time ranges where the next available image is shown.

  4. Click the play button to preview the animation. QGIS will generate scenes using the layers rendering at the set times. Layers display depends on whether they overlap any individual time frame.

    ../../../_images/map_navigation.gif

    图 7.4 Temporal navigation through a layer

    The animation can also be previewed by moving the time slider. Keeping the refresh Loop button pressed will repeatedly run the animation while clicking play stops a running animation. A full set of video player buttons is available.

    Horizontal scrolling using the mouse wheel (where supported) with the cursor on the map canvas will also allow you to navigate, or “scrub”, the temporal navigation slider backwards and forwards.

  5. Click the fileSave Export animation button if you want to generate a series of images representing the scene. They can be later combined in a video editor software:

    ../../../_images/saveTimeAnimation.png

    图 7.5 Exporting map canvas animation scenes to images

    • The filename Template: the #### are replaced with frame sequence number

    • The Output directory

    • Under Map settings, you can:

      • redefine the spatial extent to use

      • control the Resolution of the image (Output width and Output height)

      • Draw active decorations: whether active decorations should be kept in the output

    • Under Temporal settings, you can redefine:

      • the time Range for the animation

      • the Step (frame length) in the unit of your choice

7.3.4. 导出地图视图

使用 打印布局或报告 的高级功能,可以将您制作的地图布局导出为各种格式,也可以不使用布局直接导出当前渲染。这个地图视图的快速 "截图" 有一些方便的功能。

要使用当前渲染导出地图画布,请执行以下操作:

  1. 转到 工程 ► 导入/导出

  2. 根据您的输出格式,选择

    • saveMapAsImage 导出地图为图像...

    • saveAsPDF 导出地图为PDF文件...

这两个工具为您提供了一组通用选项。在打开的对话框中:

../../../_images/saveMapAsImage.png

图 7.6 地图另存为图像对话框

  1. 选择要导出的 范围:可以是当前视图范围 (默认)、图层范围或在地图画布上绘制的自定义范围。将显示所选区域的坐标,并可手动编辑。

  2. 输入地图 比例 或从 预定义比例 选择:更改比例将调整要导出范围的大小 (从中心开始)。

  3. 设置输出的 分辨率

  4. 以像素为单位控制图像的 输出宽度输出高度: 默认是基于当前分辨率和范围,可以自定义并将调整地图范围的大小 (从中心开始)。大小比值可以锁定,这在画布上绘制范围时可能特别方便。

  5. checkbox 绘制活动装饰: 使用中的 装饰 (比例尺、标题、网格、指北针等) 与地图一起导出

  6. checkbox 绘制注记 导出全部 注记

  7. checkbox 附加配准信息 (嵌入或者借助于坐标信息文件): 根据输出格式,一个同名的坐标信息文件 (扩展名为 PNGW 表示 PNG 图像,扩展名为 JPGW 表示 JPG, ...) 与您的图像保存在同一文件夹中。PDF 格式将信息嵌入到PDF文件中。

  8. 导出为PDF时,地图另存为PDF... 对话框提供了更多选项:

    ../../../_images/saveMapAsPDF.png

    图 7.7 地图另存为PDF的对话框

    • 文档的 checkbox 导出RDF元数据,例如标题、作者、日期、描述...

    • unchecked 创建地理空间PDF (GeoPDF): 生成 地理配准信息的PDF文件 (需要 GDAL v3 或更高版本),您可以:

      • 选择GeoPDF 格式

      • 在GeoPDF文件中 checkbox 包含矢量要素信息:将在输出GeoPDF文件中包含地图中可见要素的所有几何图形和属性的信息。

      备注

      从 QGIS 3.10 开始,GDAL 3 还可以使用GeoPDF文件作为数据源。有关QGIS中GeoPDF支持的更多信息,请参阅 https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/

    • 地图栅格化

    • checkbox 简化几何图形以减小输出文件的大小: 导出地图时,几何图形将通过删除在导出分辨率下没有明显差异的顶点进行简化 (例如,如果导出分辨率为 300 dpi,相隔小于 1/600 英寸 的顶点将被删除),这可以减小导出文件的大小和复杂性 (非常大的文件可能无法在其他应用程序中加载)。

    • 设置 文本导出: 控制文本标注是作为正确的文本对象导出 (始终将文本导出为文本对象) 还是仅作为路径导出 (始终将文本导出为路径)。如果作为文本对象导出,可以在外部应用程序 (例如Inkscape) 中作为普通文本进行编辑。但其副作用是渲染质量降低,并且当设置某些文本如描边效果时,渲染会出现问题。这就是为什么建议导出为路径的原因。

  9. 单击 保存 后可以选择文件位置、名称和格式。

    导出到图像时,还可以将上述设置的预期结果 复制到剪贴板,并将地图粘贴到另一应用程序中,如 LibreOffice、GIMP...

7.4. 3D地图视图

通过3D地图视图提供3D可视化支持。可以使用 视图 ► new3DMap 新建3D地图视图 创建并打开3D地图视图,这时将弹出一个浮动QGIS面板,面板可以停靠。

首先,3D地图视图的范围和视图与2D主地图画布相同。可以使用一组浏览工具将视图转换为3D视图。

../../../_images/3dmapview.png

图 7.8 3D地图视图对话框

3D地图视图面板顶部提供了以下工具:

  • pan 相机视角控制: 移动视图,保持相机的角度和方向不变

  • zoomFullExtent 全图显示: 将视图调整为整个图层的范围

  • 3dNavigation 切换导航工具: 显示/隐藏浏览控件 (旨在简化地图视图的控制)

  • identify 识别: 返回有关地形的单击点或单击3D要素的信息 -- 更多详细信息请访问 Identifying Features

  • measure 测量线: 测量点之间的水平距离

  • play 动画: 显示/隐藏 动画播放 控件

  • saveMapAsImage 另存为图像...: 将当前视图导出为图像文件格式

  • 3d 导出3D场景...: 将当前视图导出为3D场景 (.obj 文件),允许在Blender等应用程序中进行后期处理。地形和矢量要素将导出为3D对象,重写图层 属性 或地图视图 配置 的导出设置,包括:

    • 场景名称 和目标 文件夹

    • 地形分辨率

    • 地形纹理分辨率

    • 模型比例

    • checkbox 平滑边

    • checkbox 导出法线

    • checkbox 导出纹理

  • showPresets 设置视图主题: 允许您从预定义的 地图主题 中选择要在地图视图中显示的图层集。

  • options 配置 地图视图 设置

7.4.1. 场景配置

3D地图视图打开后,其中包含一些可自定义的默认设置。要执行此操作,请单击3D画布面板顶部的 options 配置... 按钮,打开 3D配置 窗口。

../../../_images/3dmapconfiguration.png

图 7.9 3D地图配置对话框

在3D配置窗口,有各种选项可微调3D场景:

7.4.1.1. 地形

  • 地形: 在深入研究细节之前,值得注意的是,3D视图中的地形是由地形瓦片的层次结构表示,随着相机靠近地形,没有足够细节的现有瓦片将被具有更多细节的较小瓦片替换。每个瓦片都是源自高程栅格图层的网孔几何图形和2D地图图层的纹理。

    • 高程地形 类型 可以是:

    • 高程: 用于生成地形的栅格或网孔图层。栅格图层必须包含表示高程的波段;对于网孔图层,将使用顶点的Z值。

    • 垂直比例: 垂直轴的比例因子,增加比例会扩大地貌的高度。

    • 瓦片分辨率: 每个瓦片要使用的地形栅格图层中的样本数。16px 的值意味着每个瓦片的几何图形将由 16x16 个高程样本组成。数字越大,生成的地形瓦片越详细,但渲染复杂度就越高。

    • 裙板高度: 有时可能会在地形的瓦片之间看到小裂缝。提高该值将在地形瓦片周围添加垂直墙 ("裙板 - skirts"),以隐藏裂缝。

  • Terrain elevation offset: moves the terrain up or down, e.g. to adjust its elevation with respect to the ground level of other objects in the scene.

    This can be useful when there is a discrepancy between the height of the terrain and the height of layers in your scene (e.g. point clouds which use a relative vertical height only). In this case adjusting the terrain elevation manually to coincide with the elevation of objects in your scene can improve the navigation experience.

  • 当网孔图层用作地形时,可以配置 三角形设置 (线框显示、平滑三角形) 和 渲染颜色设置 (统一或取决于地形层级)。更多详细信息,请参见 网孔图层属性 部分。

  • unchecked 地形晕渲: 允许您选择地形的渲染方式:

    • 禁用晕渲 - 地形颜色仅由地图纹理确定

    • 启用晕渲 - 使用Phong的晕渲模型确定地形颜色,同时考虑地图纹理、地形法线矢量、场景灯光以及地形材质的 周围环境镜面反射 颜色以及 光滑度

7.4.1.2. 灯光

灯光 选项卡中,按 symbologyAdd 菜单添加

  • 最多八个 点光源: 向各个方向发光,就像一个填充区域的光球。离光源越近的对象越亮,而远离光源的对象就越暗。点光源具有设定的位置 (X, YZ)、颜色强度衰减 等属性

  • 最多四个 平行光: :模拟从远离对象的巨型闪光灯中获得的照明,始终居中且永不熄灭 (例如太阳)。它在一个方向上发射平行光线,但光线延伸到无限远。平行光可以在给定 方位角海拔颜色强度 的参数下进行旋转。

../../../_images/3dmapconfiguration_lights.png

图 7.10 3D地图灯光配置对话框

7.4.1.3. 阴影

勾选 unchecked 显示阴影,在场景中显示阴影,前提是:

  • 平行光

  • 阴影渲染最大距离: 避免渲染太远对象的阴影,尤其是当相机沿地平线仰视时

  • 阴影偏移: 避免由于地图大小不同而导致某些区域比其他区域更暗的自阴影效果,越低越好

  • 阴影地图分辨率: 使阴影看起来更清晰。如果分辨率参数太高,可能会导致性能下降。

7.4.1.4. 相机和天空盒

In this tab, you can override some default camera settings made in the Settings ► Options ► 3D dialog.

Furthermore, check unchecked Show skybox to enable skybox rendering in the scene. The skybox type can be:

  • 全景纹理, 单个文件提供 360° 视野

  • 不同表面, 包含场景的盒子的六个面各有一个纹理文件

Texture image files of the skybox can be files on the disk, remote URLs or embedded in the project (more details).

7.4.1.5. 高级

  • 地图瓦片分辨率: 用作地形瓦片纹理的2D地图图像的宽度和高度。256px 意味着每个瓦片被渲染成 256x256 像素的图像。数字越大,生成的地形地形越详细,但渲染复杂度越高。

  • 最大屏幕误差: 确定将地形瓦片与更详细的地形瓦片交换的阈值 (反之亦然) - 即3D视图使用更高质量瓦片的时间。数字越小,场景中的细节越多,但渲染复杂度越高。

  • 最大地面误差: 地形瓦片的分辨率,在该分辨率下,将瓦片拆分为更详细的瓦片将停止 (分割它们不会引入任何额外的细节)。该值限制了瓦片层次结构的深度:值越低,层次结构越深,渲染复杂度越高。

  • 缩放层级: 显示缩放层级的数量 (取决于地图瓦片分辨率和最大地面误差)。

  • unchecked 显示标注: 打开或关闭地图标注

  • unchecked 显示地图瓦片信息: 包括地形瓦片的边界和瓦片编号 (用于解决地形问题)

  • unchecked 显示边界框: 显示地形瓦片的3D边界框 (用于解决地形问题)

  • unchecked 显示相机视图中心

  • unchecked 显示光源: 显示光源原点处的球体,相对于场景内容更容易重新定位和放置光源

7.4.3. 创建动画

动画基于一组关键帧 - 特定时间的相机位置。要创建动画,请执行以下操作:

  1. 切换 play 动画 工具,显示动画播放控件

  2. 单击 symbologyAdd 添加关键帧 按钮并以秒为单位输入 关键帧时间关键帧 组合框现在显示时间设置。

  3. 使用导航工具,将相机移动到与当前关键帧时间相关联的位置。

  4. 重复前面的步骤,根据需要添加若干关键帧 (包括时间和位置)。

  5. 单击 play 按钮预览动画。QGIS将使用相机在设定时间的位置或旋转生成场景,并在这些关键帧之间进行插值。可以使用各种动画 插值 模式 (例如,linear、inQuad、outQuad、inCirc… -- 更多详细信息,请访问 https://doc.qt.io/qt-5/qeasingcurve.html#EasingFunction-typedef)。

    The animation can also be previewed by moving the time slider. Keeping the Loop box checked will repeatedly run the animation while clicking play stops a running animation.

单击 fileSave 导出动画帧 将生成一系列表示场景的图像。除了文件名 模板输出目录,还可以设置 帧率 数、输出宽度输出高度

7.4.4. 3D矢量图层

通过选中矢量图层属性的 3D视图 部分中的 启用3D渲染器,可以在3D地图视图中显示具有高程值的矢量图层。有许多选项可用于控制3D矢量图层的渲染。

7.5. 状态栏

状态栏为您提供有关地图视图和已处理或可用操作的一般信息,并提供管理地图视图的工具。

7.5.1. 搜索栏 - 定位器

在状态栏的左侧,搜索栏是一个快速搜索控件,可帮助您查找并运行QGIS中的任何功能或选项:

  1. 在文本控件中单击以激活搜索栏,或按 Ctrl+K

  2. 键入与您要查找的工程相关联的文本 (名称、标签、关键字等)。默认情况下,将启用搜索过滤的返回结果,但您可以通过在文本前面加上 搜索过滤 前缀,将搜索限制在指定范围内,即键入 l cad 将仅返回名称包含 cad 的图层。

    在访问搜索控件时,还可以双击显示的菜单来选择过滤。

  3. 根据项类型,单击搜索结果执行相应的操作。

小技巧

Limit the lookup to particular field(s) of the active layer

默认情况下,使用 "活动图层要素" 过滤 (f) 的搜索将遍历图层的整个属性表。您可以使用 @ 前缀将搜索限制到特定字段。例如 f @name sal@name sal 只返回其 "name" 属性包含 'sal' 的要素。书写时,文本自动补全处于活动状态,建议使用 Tab 键。

A more advanced control on the queried fields is possible from the layer Fields tab. Read Fields Properties for details.

搜索是使用线程处理的,因此即使安装了慢速搜索过滤器,其结果也始终尽快可用。它们也会在遇到过滤时立即出现,这意味着,例如文件搜索过滤会在扫描文件树时逐个显示结果。这确保了用户界面始终响应,即使存在非常慢的搜索过滤 (例如,使用在线服务的过滤)。

备注

The Nominatim locator tool may behave differently (no autocompletion search, delay of fetching results, ...) with respect to the OpenStreetMap Nominatim usage policy.

小技巧

快速访问搜索的配置

单击状态栏上搜索控件内的 search 图标,以显示可使用的过滤列表,以及打开 设置 ► 选项...搜索 标签页的 配置 条目

7.5.2. 汇报行为

In the area next to the locator bar, a summary of actions you've carried out will be shown when needed (such as selecting features in a layer, removing layer, pan distance and direction) or a long description of the tool you are hovering over (not available for all tools).

如果需要执行较长时间的操作,例如在栅格图层中收集统计信息、执行处理算法或在地图视图中渲染多个图层,状态栏中将显示进度条。

7.5.3. 控制地图画布

tracking 坐标 选项显示鼠标的当前位置,在地图视图中移动时跟随鼠标。可以在 工程 ► 工程属性... ► 常规 选项卡中设置单位 (和精度)。单击文本框右侧的小按钮,可以在坐标选项和 extents 范围 选项之间切换,该选项以地图单位显示地图视图当前左下角和右上角的坐标。

在显示坐标旁边,您会看到 比例 显示,它显示地图视图的比例。有一个比例选择器,允许您在 预定义和自定义比例 之间进行选择。

On the right side of the scale display, press the lockedGray button to lock the scale to use the magnifier to zoom in or out. The magnifier allows you to zoom in to a map without altering the map scale, making it easier to tweak the positions of labels and symbols accurately. The magnification level is expressed as a percentage. If the Magnifier has a level of 100%, then the current map is not magnified, i.e. is rendered at accurate scale relative to the monitor's resolution (DPI). A default magnification value can be defined within Settings ► Options ► Rendering ► Rendering behavior, which is very useful for high-resolution screens to enlarge small symbols. In addition, a setting in Settings ► Options ► Canvas & Legend ► DPI controls whether QGIS respects each monitor's physical DPI or uses the overall system logical DPI.

在放大镜工具右侧,可以为地图视图定义当前顺时针方向旋转角度,单位为度。

在状态栏右侧,有个小复选框,可以临时使用它来阻止图层被渲染到地图视图 (请参见 Rendering 部分)。

在渲染功能右侧,可以找到显示当前工程CRS的 projectionEnabled EPSG:代码 按钮,单击此按钮将打开 工程属性 对话框,并允许您将另一个CRS应用于地图视图。

小技巧

计算地图画布的正确比例

启动QGIS时,默认的CRS为 WGS 84 (EPSG 4326) ,单位为度。这意味着QGIS将按照指定的度数解释图层中的任何坐标。要获得正确的比例值,可以在 工程 ► 工程属性... 下的 常规 选项卡中手动更改此设置 (例如为米),或者您可以使用上面看到的 projectionEnabled EPSG:代码 图标。在后一种情况下,单位设置为工程投影指定的单位 (例如 +units=us-ft)。

请注意,启动时的CRS选项可以在 设置 ► 选项 ► CRS 中设置。

7.5.4. 实时信息

点击 messageLog 信息 按钮打开 日志信息面板,其中包含有关底层进程的信息 (QGIS启动、插件加载、处理工具等)

根据 插件管理器设置,状态栏有时会在右侧显示图标信息,提示您有关新插件 (pluginNew) 或可升级插件 (pluginUpgrade) 的相关信息。单击图标可以打开插件管理器对话框。