7. Interface de QGIS

L’interface graphique de QGIS est présentée dans la figure ci-dessous (les chiffres de 1 à 5 dans les cercles jaunes indiquent des éléments importants de l’interface de QGIS et sont présentés ci-dessous).

../../../_images/startup.png

Fig. 7.1 Interface de QGIS avec les données d’exemple sur l’Alaska

Note

Le style des fenêtres peut apparaître différemment en fonction de votre système d’exploitation et de votre gestionnaire de fenêtres.

L’interface de QGIS (Fig. 7.1) est composée de 5 éléments / types d’élément :

  1. Barre de Menu

  2. Barres d’outils

  3. Panneaux

  4. Vue Cartographique

  5. Barre d’état

Voir ci-dessous pour le détail de chacun de ces éléments.

7.2. Panneaux et barres d’outils

Depuis le menu Vue (ou kde Préférences), vous pouvez afficher ou masquer des éléments d’interface de QGIS (Panneaux ►) et des barres d’outils (Barres d’outils ►). Pour afficher ou masquer l’un d’entre eux, faites un clic-droit sur la barre de menu ou une barre d’outils et choisissez les éléments que vous souhaitez. Les panneaux et barres d’outils peuvent être déplacés comme vous le souhaitez au sein de l’interface de QGIS. La liste de ces éléments peut également être étendue via l’activation d”extensions principales ou externes.

7.2.1. Barres d’outils

Les barres d’outils permettent d’accéder à la plupart des fonctions des menus, ainsi qu’à des outils supplémentaires pour interagir avec la carte. Chaque barre d’outils dispose d’une aide contextuelle. Passez votre souris sur l’élément et une courte description de l’outil s’affichera.

Chaque barre d’outils peut être déplacée selon vos besoins. Vous pouvez les désactiver à partir du menu contextuel qui s’affiche à partir du clic droit de la souris sur la barre d’outils.

Les barres d’outils disponibles sont :

Nom

Main Reference for tools

Advanced Digitizing Toolbar

Numérisation avancée

Annotations Toolbar

Attributs

Travailler avec la table d’attributs, Outils généraux

Gestionnaire source de donnees

Gérer les sources de données

Base de données

Extension DB Manager

Numérisation

Numériser une couche existante

Aide

Étiquette

La barre d’outils Étiquettes

Gestion couche

Ouvrir des données

Navigation cartographique

Travailler avec le canevas de la carte

Mesh Digitizing Toolbar

Extensions

Extensions

Projet

Les fichiers de projet, Mise en page des cartes, La bibliothèque de styles

Processing Algorithms

Configurer le Module de Traitements

Raster

Extensions

Sélection

Sélectionner des entités

Numérisation de forme

Numérisation de formes

Accrochage

Configuration de la tolérance de l’accrochage et du rayon de recherche

Vecteur

Extensions

Internet

Extensions, Client MetaSearch pour les Services de Catalogage

Note

Third-party plugins can extend the default toolbar with their own tools or provide their own toolbar.

Astuce

Restaurer les barres d’outils

Si vous avez accidentellement fermé une barre d’outils, vous pouvez la retrouver via Vue ► Barres d’outils ► (ou kde Préférences ► Barres d’outils ►). Si, pour une raison ou pour une autre, une barre d’outils (ou un autre élément d’interface) disparaît complètement de votre interface, vous trouverez de l’aide pour la retrouver ici : Restaurer l’interface initiale.

7.2.2. Panneaux

QGIS fournit de nombreux panneaux. Les panneaux sont des éléments d’interface avec lesquels vous pouvez interagir (options à sélectionner, cases à cocher, valeur à renseigner…) pour effectuer des opérations plus complexes.

Les panneaux disponibles par défaut dans QGIS sont listés ci-après :

7.3. Vue cartographique

7.3.1. Exploration de la vue cartographique

La vue cartographique (aussi appelée Canevas de carte) est la partie centrale de QGIS puisque les cartes y sont affichées, en 2D. Le contenu qui s’affiche dépend des choix de rendu (symbologie, étiquetage, visibilité…) que vous faites pour chaque couche chargée. Il dépend également du Système de Coordonnées de Référence (SCR) du projet et des couches.

Lorsque vous ajoutez une couche (voir par exemple Ouvrir des données), QGIS recherche automatiquement son Système de Coordonnées de Référence (SCR). Si un SCR différent est définit par défaut pour le projet (voir Systèmes de Coordonnées de Référence d’un projet), la couche est reprojetée « à la volée » dans ce SCR et la vue cartographique zoome sur l’emprise de la couche s’il s’agit d’un projet vide. S’il y a déjà des couches dans le projet, il n’y a pas de recentrage de la vue, seules les entités comprises dans l’emprise courante de la vue seront visibles.

Cliquez sur la carte et vous devriez alors pouvoir interagir avec elle :

  • it can be panned, shifting the display to another region of the map: this is performed using the pan Pan Map tool, the arrow keys, moving the mouse while any of the Space key, the middle mouse button or the mouse wheel is held down. When the mouse is used, the distance and direction of the pan action are shown in the status bar at the bottom.

  • it can be zoomed in and out, with the dedicated zoomIn Zoom In and zoomOut Zoom Out tools. Hold the Alt key to switch from one tool to the other. Zooming is also performed by rolling the wheel forward to zoom in and backwards to zoom out. The zoom is centered on the mouse cursor position. You can customize the Zoom factor under the Settings ► Options ► Map tools menu.

  • it can be zoomed to the full extent of all loaded layers (zoomFullExtent Zoom Full), to the extent of all the selected layers in the Layers panel (zoomToLayer Zoom to Layer(s)) or to the extent of the selected features of all the selected layers in the Layers panel (zoomToSelected Zoom to Selection)

  • vous pouvez naviguer en arrière / en avant dans l’historique des vues de canevas avec les boutons zoomLast Zoom précédent et zoomNext Zoom suivant ou en utilisant les boutons arrière / avant de la souris.

Faites un clic-droit sur la carte et vous pourrez editCopy :guilbel:`Copier les coordonnées` du point cliqué dans le SCR de la carte, en WGS84 ou dans le SCR de votre choix. L’information copiée peut être collée dans une expression, un script, un éditeur de texte ou un tableur…

Par défaut, QGIS ouvre une seule vue cartographique (appelée « carte principale »), qui est étroitement liée au panneau couches ; la carte principale reflète automatiquement les modifications que vous effectuez dans la zone du panneau couches. Mais il est également possible d’ouvrir des vues supplémentaires de la carte dont le contenu pourrait diverger de l’état actuel du panneau couches. Elles peuvent être de type 2D ou 3D, présenter une échelle ou une étendue différente, ou afficher un ensemble différent des couches chargées grâce à map themes.

7.3.2. Définition de vues de carte supplémentaires

Pour ajouter une nouvelle vue cartographique, allez dans Vue -> newMap Nouvelle vue cartographique. Un nouveau widget flottant affichant le même rendu que la vue principale est ajouté à QGIS. Vous pouvez ajouter autant de vues cartographiques que vous le souhaitez. Elles peuvent être maintenues flottantes, placées côte à côte ou empilées les unes sur les autres.

../../../_images/map_views.png

Fig. 7.2 Plusieurs vues de carte avec différents paramètres

En haut de toute vue cartographique supplémentaire, une barre d’outils offre les possibilités suivantes :

  • zoomFullExtent Zoom Full, zoomToSelected Zoom to Selection and zoomToLayer Zoom to Layer(s) to navigate within the view

  • showPresets Définir le thème pour sélectionner le thème de carte à afficher dans la vue de la carte. Si elle est définie sur (aucun), la vue suivra les modifications du panneau Couches.

  • options Paramètres de la vue pour configurer la vue de la carte:

    • radioButtonOn Synchroniser le centre de la vue avec la carte principale: synchronise le centre des vues de la carte sans changer l’échelle. Cela vous permet d’avoir un style de vue d’ensemble ou une carte agrandie qui suit le centre du canevas principal.

    • radioButtonOff Synchroniser la vue avec la sélection: identique au zoom avec la sélection

    • Échelle

    • Rotation

    • Grossissement

    • unchecked Synchroniser l’échelle avec l’échelle de la carte principale. Un facteur echelle peut ensuite être appliqué, vous permettant d’avoir une vue qui est par exemple toujours 2x l’échelle du canevas principal.

    • checkbox Afficher les annotations

    • checkbox Afficher la position du curseur

    • unchecked Afficher l’étendue du canevas principal

    • checkbox Afficher les étiquettes: autorise à masquer les étiquettes telles qu’elles sont définies dans les propriétés des couches affichées

    • Changer le CRS carte …

    • Renommer la vue…

7.3.3. Time-based control on the map canvas

QGIS can handle temporal control on loaded layers, i.e. modify the map canvas rendering based on a time variation. To achieve this, you need:

  1. Layers that have dynamic temporal properties set. QGIS supports temporal control for different data providers, with custom settings. It’s mainly about setting the time range in which the layer would display:

    • vector layers: features are filtered based on time values associated to their attributes

    • mesh layers: displays dynamically the active dataset groups values

    When dynamic temporal options are enabled for a layer, an indicatorTemporal icon is displayed next to the layer in the Layers panel to remind you that the layer is temporally controlled. Click the icon to update the temporal settings.

  2. Enable the temporal navigation of the map canvas using the Temporal controller panel. The panel is activated:

    • using the temporal Temporal controller panel icon located in the Map Navigation toolbar

    • or from the View ► Panels ► Temporal controller panel menu

7.3.3.1. The temporal controller panel

The Temporal controller panel has the following modes:

../../../_images/temporal_controller_panel.png

Fig. 7.3 Temporal Controller Panel in navigation mode

  • temporalNavigationOff Turn off temporal navigation: all the temporal settings are disabled and visible layers are rendered as usual

  • temporalNavigationFixedRange Fixed range temporal navigation: a time range is set and only layers (or features) whose temporal range overlaps with this range are displayed on the map.

  • temporalNavigationAnimated Animated temporal navigation: a time range is set, split into steps, and only layers (or features) whose temporal range overlaps with each frame are displayed on the map

  • settings Settings for general control of the animation

    • Frames rate: number of steps that are shown per second

    • unchecked Cumulative range: all animation frames will have the same start date-time but different end dates and times. This is useful if you wish to accumulate data in your temporal visualisation instead of showing a ‘moving time window’ across your data.

7.3.3.2. Animating a temporal navigation

An animation is based on a varying set of visible layers at particular times within a time range. To create a temporal animation:

  1. Toggle on the temporalNavigationAnimated Animated temporal navigation, displaying the animation player widget

  2. Enter the Time range to consider. Using the refresh button, this can be defined as:

    • Set to full range of all the time enabled layers

    • Set to preset project range as defined in the project properties

    • Set to single layer’s range taken from a time-enabled layer

  3. Fill in the time Step to split the time range. Different units are supported, from seconds to centuries. A source timestamps option is also available as step: when selected, this causes the temporal navigation to step between all available time ranges from layers in the project. It’s useful when a project contains layers with non-contiguous available times, such as a WMS-T service which provides images that are available at irregular dates. This option will allow you to only step between time ranges where the next available image is shown.

  4. Click the play button to preview the animation. QGIS will generate scenes using the layers rendering at the set times. Layers display depends on whether they overlap any individual time frame.

    ../../../_images/map_navigation.gif

    Fig. 7.4 Temporal navigation through a layer

    The animation can also be previewed by moving the time slider. Keeping the refresh Loop button pressed will repeatedly run the animation while clicking play stops a running animation. A full set of video player buttons is available.

    Horizontal scrolling using the mouse wheel (where supported) with the cursor on the map canvas will also allow you to navigate, or “scrub”, the temporal navigation slider backwards and forwards.

  5. Click the fileSave Export animation button if you want to generate a series of images representing the scene. They can be later combined in a video editor software:

    ../../../_images/saveTimeAnimation.png

    Fig. 7.5 Exporting map canvas animation scenes to images

    • The filename Template: the #### are replaced with frame sequence number

    • The Output directory

    • Under Map settings, you can:

      • redefine the spatial extent to use

      • control the Resolution of the image (Output width and Output height)

      • Draw active decorations: whether active decorations should be kept in the output

    • Under Temporal settings, you can redefine:

      • the time Range for the animation

      • the Step (frame length) in the unit of your choice

7.3.4. Exporter la vue cartographique

Les cartes que vous réalisez peuvent être mises en page et exportées dans divers formats via les capacites avancées de la mise en page ou des rapports. Il est également possible d’exporter directement la carte en cours, sans mise en page. Cette « capture d’écran » rapide de la vue cartographique propose quelques fonctionnalités intéressantes.

Pour exporter le canevas de la carte tel quel :

  1. Allez dans Projet ► Importer/Exporter

  2. Selon le format de sortie, sélectionnez

    • saveMapAsImage Exporter la carte au format image…

    • ou saveAsPDF Exporter la carte au format PDF…

Les deux outils proposent les mêmes options. Dans la fenêtre qui s’ouvre :

../../../_images/saveMapAsImage.png

Fig. 7.6 La fenêtre d’export de la carte au format image

  1. Choisissez l” Emprise à exporter : elle peut correspondre à l’emprise actuelle de la vue (par défaut), à l’emprise d’une couche ou à une emprise personnalisée via un rectangle dessiné sur le canevas de la carte. Les coordonnées de la zone sélectionnée sont affichées et éditables.

  2. Entrez l” Échelle de la carte ou sélectionnez la depuis les échelles prédéfinies : changer l’échelle redimensionnera l’emprise à exporter (depuis le centre).

  3. Choisissez une Résolution pour l’export

  4. Contrôlez la Largeur de l’image en sortie et la Hauteur de l’image en sortie en pixels : basées par défaut sur la résolution et l’emprise, elles peuvent être modifiées ce qui changera l’emprise de la carte (depuis le centre). Le ratio de taille peut être verrouillé ce qui peut être particulièrement utile lorsque l’on dessine une emprise sur le canevas de la carte.

  5. checkbox Afficher les décorations actives : les décorations utilisées (barre d’échelle, titre, carroyage, flèche du Nord…) sont exportées avec la carte.

  6. checkbox Afficher les annotations pour exporter toutes les annotations.

  7. checkbox Ajouter les informations de géoréférencement (encapsulées ou via un fichier world) : selon le format de sortie, un fichier world portant le même nom (avec l’extension PNGW pour PNG, JPGW pour JPG…) est sauvegardé dans le même répertoire que l’image. Le format PDF encapsule l’information dans le fichier PDF.

  8. Lorsque vous exportez en PDF, d’autres options sont proposées dans la fenêtre Enregistrer la carte en PDF :

    ../../../_images/saveMapAsPDF.png

    Fig. 7.7 La fenêtre d’export de la carte au format PDF

    • checkbox Exporter les métadonnées RDF du document telles que le titre, l’auteur, la date, la description…

    • unchecked Créer un PDF Géospatial (GeoPDF) : Génère un fichier PDF géoréférencé (nécessite GDAL 3 ou plus). Vous pouvez :

      • Choisir le Format du GeoPDF

      • checkbox Inclure les informations des entités vecteur dans le fichier GeoPDF : inclura toutes les informations de géométrie et des attributs des entités visibles dans la carte exportée dans le fichier GeoPDF.

      Note

      Depuis QGIS 3.10, avec GDAL 3, un fichier GeoPDF peut également être utilisé comme source de données. Pour plus d’informations sur la gestion des GeoPDF dans QGIS, voir https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/.

    • Transformer la carte en raster

    • checkbox Simplifier les géométries pour réduire la taille du fichier de sortie : Les géométries seront simplifiées à l’export de la carte en enlevant des sommets qui ne sont pas différentiables à la résolution de l’export (par ex. si la résolution de l’export est de 300 dpi (ppp), les sommets qui sont espacés de moins de 1/600 pouce seront supprimés). Cela permet de réduire la taille et la complexité du fichier exporté (des fichiers très volumineux peuvent être impossibles à charger dans d’autres applications).

    • Définir l”Export de texte : contrôle si les textes sont exportés en tant que textes (Toujours exporter le texte sous forme d’objets texte) ou en tant que chemins uniquement (Toujours exporter le texte comme des chemins). S’ils sont exportés comme des objets texte, ils seront éditables comme des textes par des applications externes (par ex. Inkscape). MAIS la qualité du rendu est diminuée ET il peut y avoir des problèmes avec certains rendus comme les tampons autour des textes. C’est pour cela que l’export en chemins est recommandé.

  9. Cliquez sur Enregistrer pour choisir l’emplacement, le nom et le format du fichier.

    Quand vous exportez en image, il est également possible de Copier vers le presse-papiers le résultat des paramétrages précédents et de coller la carte dans une autre application telle que LibreOffice, GIMP…

7.4. Vue 3D

La visualisation 3D est prise en charge via la vue de carte 3D. Vous créez et ouvrez une vue de carte 3D via Vue -> new3DMap Nouvelle vue de carte 3D. Un panneau QGIS flottant apparaît. Le panneau peut être ancré.

Pour commencer, la vue de la carte 3D a la même étendue et la même vue que le canevas de la carte principale 2D. Un ensemble d’outils de navigation est disponible pour transformer la vue en 3D.

../../../_images/3dmapview.png

Fig. 7.8 Boîte de dialogue Vue de la carte 3D

Les outils suivants sont fournis en haut du panneau d’affichage de la carte 3D:

  • pan controle camera: déplace la vue en gardant le même angle et la même direction que la caméra

  • zoomFullExtent Zoom complet: redimensionne la vue dans toute l’étendue des couches

  • 3dNavigation Basculer la notification à l’écran: affiche / masque le widget de navigation (destiné à faciliter le contrôle de la vue de la carte)

  • identify Identifier: renvoie des informations sur le point cliqué du terrain ou sur les entités 3D cliquées - Plus de détails sur Identifier les entités

  • measure mesurer une ligne: mesure la distance horizontale entre les points

  • play Animations: affiche / cache le widget du lecteur d’animations

  • saveMapAsImage Sauver image sous …: exporte la vue actuelle dans un format de fichier image

  • 3d Exporter une scène 3D… : exporte la vue courante comme une scène 3D (.obj), permettant un post-traitement dans des applications comme Blender… Le terrain et les entités vectorielles sont exportées comme des objets 3D. Les paramètres d’exportation, qui remplacent les couches properties ou la vue cartographique configuration, incluent :

    • Nom de la scène et destination Dossier.

    • Résolution du terrain

    • Résolution de la texture du terrain

    • Modèle d’échelle

    • checkbox Bords lisses.

    • checkbox Exporter les normales

    • checkbox Exporter les textures

  • showPresets définir thème affichage : Permet de sélectionner l’ensemble des couches à afficher dans la vue cartographique parmi les thèmes prédéfinis map themes.

  • options Configurer les paramètres de la vue cartographique

7.4.1. Configuration d’une vue 3D

La vue de la carte 3D s’ouvre avec certains paramètres par défaut que vous pouvez personnaliser. Pour ce faire, cliquez sur le bouton options Configurer … en haut du panneau de canevas 3D pour ouvrir la fenêtre 3D configuration.

../../../_images/3dmapconfiguration.png

Fig. 7.9 Fenêtre de configuration d’une vue 3D

Dans la fenêtre de configuration 3D, il existe différentes options pour affiner la scène 3D:

7.4.1.1. Terrain

  • Terrain: Avant de plonger dans les détails, il convient de noter que le terrain dans une vue 3D est représenté par une hiérarchie de tuiles de terrain et plus la caméra se rapproche du terrain, plus les tuiles existantes qui n’ont pas suffisamment de détails sont remplacées par des tuiles plus petites mais avec plus de détails. Chaque mosaïque possède une géométrie de maillage dérivée de la couche raster d’élévation et une texture de couches de carte 2D.

    • Le Type d’élévation de terrain peut être :

    • Elevation : Couche raster ou maillée à utiliser pour la génération du terrain. La couche raster doit contenir une bande qui représente l’élévation. Pour une couche maillée, les valeurs Z des sommets sont utilisées.

    • Échelle verticale: Facteur d’échelle pour l’axe vertical. L’augmentation de l’échelle exagérera la hauteur des reliefs.

    • Résolution de tuile: Combien d’échantillons de la couche raster de terrain utiliser pour chaque tuile. Une valeur de 16px signifie que la géométrie de chaque tuile sera constituée d’échantillons d’élévation 16x16. Des nombres plus élevés créent des tuiles de terrain plus détaillées au détriment d’une complexité de rendu accrue.

    • Hauteur mur : Parfois, il est possible de voir de petites fissures entre les tuiles du terrain. En augmentant cette valeur, on ajoutera des murs verticaux (« skirts ») autour des tuiles du terrain pour masquer les fissures.

  • Terrain elevation offset: moves the terrain up or down, e.g. to adjust its elevation with respect to the ground level of other objects in the scene.

    This can be useful when there is a discrepancy between the height of the terrain and the height of layers in your scene (e.g. point clouds which use a relative vertical height only). In this case adjusting the terrain elevation manually to coincide with the elevation of objects in your scene can improve the navigation experience.

  • Lorsqu’une couche de maillage est utilisée comme terrain, vous pouvez configurer les paramètres Triangles (affichage filaire, triangles lisses) et les paramètres Couleurs de rendu (uniformes ou dépendant du niveau du terrain). Plus de détails dans la section Mesh layer properties.

  • unchecked Ombrage du terrain : Vous permet de choisir comment le relief doit être rendu :

    • Ombrage désactivé - la couleur du terrain est déterminée uniquement à partir de la texture de la carte

    • Ombrage activé - la couleur du terrain est déterminée à l’aide du modèle d’ombrage de Phong, en tenant compte de la texture de la carte, du vecteur normal du terrain, des lumières de la scène et du matériau du terrain Ambient et Couleurs spéculaires` et Shininess

7.4.1.2. Lumières

A partir de l’onglet Lumières, appuyez sur le menu symbologyAdd pour ajouter

  • Jusqu’à huit Les lumières ponctuelles : émettent de la lumière dans toutes les directions, comme une sphère de lumière remplissant une zone. Les objets plus proches de la lumière seront plus lumineux, et les objets plus éloignés seront plus sombres. Un point lumineux a une position définie (X, Y et Z), une Couleur, une Intensité et une Atténuation.

  • jusqu’à quatre Lumières directionnelles : imite l’éclairage que vous obtiendriez d’un flash géant très éloigné de vos objets, toujours centré et qui ne s’éteint jamais (par exemple le soleil). Elle émet des rayons lumineux parallèles dans une seule direction mais la lumière s’étend à l’infini. Une lumière directionnelle peut être tournée en fonction d’un Azimuth, une Altitude, une Couleur et une Intensité.

../../../_images/3dmapconfiguration_lights.png

Fig. 7.10 Fenêtre de configuration des lumières dans une vue 3D

7.4.1.3. Ombre

Cochez unchecked Montrer l’ombre pour afficher l’ombre dans votre scène, donnée :

  • une Lumière directionnelle

  • une Distance maximale de rendu de l’ombre : pour éviter de rendre l’ombre d’objets trop éloignés, en particulier lorsque la caméra regarde vers le haut le long de l’horizon.

  • un Biaisement des ombres : pour éviter les effets d’auto-ombrage qui pourraient rendre certaines zones plus sombres que d’autres, en raison des différences entre les tailles de cartes. Plus il est faible, mieux c’est

  • une résolution de la carte des ombres : pour rendre les ombres plus nettes. Il peut en résulter une baisse des performances si le paramètre de résolution est trop élevé.

7.4.1.4. Caméra et Skybox

In this tab, you can override some default camera settings made in the Settings ► Options ► 3D dialog.

Furthermore, check unchecked Show skybox to enable skybox rendering in the scene. The skybox type can be:

  • texture panoramique, avec un seul fichier permettant de voir sur 360°.

  • Faces distinctes, avec un fichier de texture pour chacun des six côtés d’une boîte contenant la scène.

Texture image files of the skybox can be files on the disk, remote URLs or embedded in the project (more details).

7.4.1.5. Avancé

  • Résolution de la tuile de carte: Largeur et hauteur des images cartographiques 2D utilisées comme textures pour les tuiles terrain. 256px signifie que chaque tuile sera rendue en une image de 256x256 pixels. Des nombres plus élevés créent des tuiles de terrain plus détaillées au détriment d’une complexité de rendu accrue.

  • Max. erreur d’écran : Détermine le seuil d’échange des tuiles de terrain avec des tuiles plus détaillées (et vice versa) - c’est-à-dire le moment où la vue 3D utilisera des tuiles de meilleure qualité. Des nombres plus bas signifient plus de détails dans la scène au détriment d’une complexité de rendu accrue.

  • Max. erreur de terrain : Résolution des tuiles du terrain à laquelle la division des tuiles en tuiles plus détaillées s’arrêtera (les diviser n’introduirait de toute façon aucun détail supplémentaire). Cette valeur limite la profondeur de la hiérarchie des tuiles : des valeurs inférieures rendent la hiérarchie plus profonde, augmentant la complexité du rendu.

  • Niveaux de zoom : Indique le nombre de niveaux de zoom (dépend de la résolution des tuiles de la carte et de l’erreur maximale au sol).

  • unchecked Afficher les étiquettes : Activer/désactiver les étiquettes de carte

  • unchecked Afficher l’information de la tuile de carte : Inclure les numéros de bordure et de tuile pour les tuiles de terrain (utile pour le dépannage des problèmes de terrain)

  • unchecked Afficher les zones d’emprise : Afficher les cases de délimitation 3D des tuiles du terrain (utile pour le dépannage des problèmes de terrain)

  • unchecked Montrer le centre de la vue de la caméra.

  • unchecked visualiser les sources de lumière : affiche une sphère à l’origine des sources de lumière, permettant de repositionner et de placer plus facilement les sources de lumière par rapport au contenu de la scène.

7.4.3. Créer une animation

Une animation est basée sur un ensemble d’images clés - les positions des caméras à des moments particuliers. Pour créer une animation:

  1. Activez l’outil play Animations, affichant le widget du lecteur d’animation

  2. Cliquez sur le bouton symbologyAdd ajouter image clé et entrez temps d’image clé en secondes. La zone de liste déroulante imagé clé affiche maintenant le temps défini.

  3. À l’aide des outils de navigation, déplacez la caméra vers la position à associer à l’heure de l’image clé actuelle.

  4. Répétez les étapes précédentes pour ajouter autant d’images clés (avec l’heure et la position) que nécessaire.

  5. Cliquez sur play pour prévisualiser l’animation. QGIS générera des scènes en utilisant les positions / rotations de la caméra à des heures définies et en les interpolant entre ces images clés. Divers modes Interpolation pour les animations sont disponibles (par exemple, linéaire, inQuad, outQuad, inCirc … - plus de détails sur https://doc.qt.io/qt-5/qeasingcurve.html#EasingFunction- typedef).

    The animation can also be previewed by moving the time slider. Keeping the Loop box checked will repeatedly run the animation while clicking play stops a running animation.

Cliquez sur fileSave Exporter les images d’animation pour générer une série d’images représentant la scène. Autre que le nom de fichier Template et le Répertoire de sortie, vous pouvez définir le nombre d” images par seconde, la Largeur de sortie et Hauteur de sortie.

7.4.4. Couches vecteur 3D

Une couche vecteur avec des valeurs d’élévation peut être affichée dans la vue 3D de la carte en cochant Activer le rendu 3D dans la section Vue 3D des propriétés de la couche vecteur. Un certain nombre d’options sont disponibles pour contrôler le rendu de la couche vecteur 3D.

7.5. Barre d’état

La barre d’état vous fournit des informations générales sur le visualiseur de carte et les actions traitées ou disponibles, et vous offre des outils pour gérer le visualiseur de carte.

7.5.1. Barre de localisation

Sur le côté gauche de la barre d’état, la barre de localisation, un widget de recherche rapide, vous aide à trouver et à exécuter n’importe quelle entité ou option dans QGIS :

  1. Cliquez dans le widget de texte pour activer la barre de recherche du localisateur ou appuyez sur Ctrl+K.

  2. Saisissez un texte associé à l’élément que vous recherchez (nom, étiquette, mot-clé, …). Par défaut, les résultats sont renvoyés pour les filtres de localisation activés, mais vous pouvez limiter la recherche à une certaine portée en faisant précéder votre texte d’un préfixe de filtre de localisation, par exemple, si vous tapez l cad, vous obtiendrez uniquement les couches dont le nom contient cad.

    Le filtre peut également être sélectionné par un double-clic dans le menu qui s’affiche lors de l’accès au widget du localisateur.

  3. Cliquez sur un résultat pour exécuter l’action correspondante, en fonction du type d’élément.

Astuce

Limiter la recherche à des champs spécifiques de la couche active

Par défaut, une recherche avec le filtre « entités de la couche active » (f) parcourt l’ensemble de la table attributaire de la couche. Vous pouvez limiter la recherche à un champ particulier en utilisant le préfixe @. Par exemple, f @nom sal ou @nom sal renvoie uniquement les entités dont l’attribut « nom » contient “sal”. L’autocomplétion du texte est actif lors de l’écriture et la suggestion peut être appliquée en utilisant la touche Tab.

A more advanced control on the queried fields is possible from the layer Fields tab. Read Onglet Champs for details.

La recherche est gérée par des threads, de sorte que les résultats sont toujours disponibles aussi rapidement que possible, même si des filtres de recherche lents sont installés. Ils apparaissent également dès qu’ils sont rencontrés par un filtre, ce qui signifie que, par exemple, un filtre de recherche de fichiers affichera les résultats un par un au fur et à mesure de l’analyse de l’arborescence des fichiers. Cela garantit que l’interface utilisateur est toujours réactive, même si un filtre de recherche très lent est présent (par exemple, un filtre qui utilise un service en ligne).

Note

The Nominatim locator tool may behave differently (no autocompletion search, delay of fetching results, …) with respect to the OpenStreetMap Nominatim usage policy.

Astuce

Accès rapide aux configurations du localisateur

Cliquez sur l’icône search à l’intérieur du widget localisateur dans la barre d’état pour afficher la liste des filtres que vous pouvez utiliser et une entrée configurer qui ouvre l’onglet localisateur du menu Paramètres ► Options…

7.5.2. Actions de reporting

In the area next to the locator bar, a summary of actions you’ve carried out will be shown when needed (such as selecting features in a layer, removing layer, pan distance and direction) or a long description of the tool you are hovering over (not available for all tools).

En cas d’opérations de longue durée, telles que la collecte de statistiques de couches raster, l’exécution d’algorithmes de traitement ou le rendu de plusieurs couches dans la vue de carte, une barre de progression est affichée dans la barre d’état.

7.5.3. Contrôler le canevas de carte

L’option tracking Coordonnées affiche la position actuelle de la souris, en suivant les déplacements sur la carte. Vous pouvez définir les unités (et la précision) dans le menu Projet ► Propriétés…. ► Onglet Général. Cliquez sur le petit bouton à gauche de la zone de texte pour basculer entre l’option Coordonnées et l’option extents Emprise qui affiche les coordonnées des coins inférieur gauche et supérieur droit actuels de la vue de carte en unités cartographiques.

A côté de l’affichage des coordonnées se trouve l’affichage Echelle. Il montre l’échelle de la carte. Il y a un sélecteur qui vous permet de choisir des échelles prédéfinies et personnalisées.

On the right side of the scale display, press the lockedGray button to lock the scale to use the magnifier to zoom in or out. The magnifier allows you to zoom in to a map without altering the map scale, making it easier to tweak the positions of labels and symbols accurately. The magnification level is expressed as a percentage. If the Magnifier has a level of 100%, then the current map is not magnified, i.e. is rendered at accurate scale relative to the monitor’s resolution (DPI). A default magnification value can be defined within Settings ► Options ► Rendering ► Rendering behavior, which is very useful for high-resolution screens to enlarge small symbols. In addition, a setting in Settings ► Options ► Canvas & Legend ► DPI controls whether QGIS respects each monitor’s physical DPI or uses the overall system logical DPI.

À droite de la loupe, vous pouvez définir un angle de rotation horaire en degrés à appliquer à la carte.

Sur le côté droit de la barre d’état, il y a une petite case à cocher qui peut être utilisée temporairement pour empêcher le rendu des couches dans le Visualisateur de carte (voir section Rendu).

A droite des fonctions de rendu, vous trouvez le bouton projectionEnabled code EPSG montrant le SCR du projet courant. Cliquer sur ce bouton ouvre la boîte de dialogue Propriétés du projet et vous permet d’appliquer un autre SCR.

Astuce

Calculer l’échelle correcte de la carte

Lorsque vous démarrez QGIS, le SCR par défaut est WGS 84 (EPSG 4326) et les unités sont des degrés. Cela signifie que QGIS interprétera n’importe quelle coordonnée dans votre couche comme étant en degrés. Pour obtenir des valeurs d’échelle correctes, vous pouvez soit modifier manuellement ce paramètre dans l’onglet General dans le menu Projet ► Propriétés… (par exemple pour des mètres), soit utiliser l’icône projectionEnabled code EPSG vue ci-dessus. Dans ce dernier cas, les unités sont réglées sur ce que spécifie la projection du projet (par exemple, +units=m).

Merci de prendre note que le choix du SCR au démarrage peut être configuré dans Préférences ► Options ► SCR.

7.5.4. Messagerie

Le bouton messageLog Messages situé à côté ouvre le journal des messages qui contient des informations sur les processus sous-jacents (démarrage QGIS, chargement des plugins, outils de traitement…).

Selon les paramètres du gestionnaire d’extensions, la barre d’état peut parfois afficher des icônes à droite pour vous informer de la disponibilité de pluginNew nouvelles extensions ou de pluginUpgrade mises à jour. Cliquez sur l’icône pour ouvrir la boîte de dialogue du gestionnaire d’extensions.