` `

Interface de QGIS

Quand QGIS démarre, l’interface se présente à vous sous la forme affichée ci-dessous (les nombres de 1 à 5 dans les cercles jaunes se réfèrent aux cinq zones principales de l’interface décrites ici).

../../../_images/startup.png

Interface de QGIS avec les données d’exemple sur l’Alaska

Note

Le style des fenêtres peut apparaître différemment en fonction de votre système d’exploitation et de votre gestionnaire de fenêtres.

L’interface de QGIS est divisée en 5 parties:

  1. Barre de Menu

  2. Barres d’outils

  3. Panneaux

  4. Affichage de la carte

  5. Barre d’état

Ces cinq composants sont décrits dans les sections suivantes. Deux autres sections présentent les raccourcis clavier et l’aide contextuelle.

Panneaux et barres d’outils

From the View menu (or kde Settings), you can switch on and off QGIS widgets (Panels ‣) or toolbars (Toolbars ‣). You can (de)activate any of them by right-clicking the menu bar or a toolbar and choose the item you want. Each panel or toolbar can be moved and placed wherever you feel comfortable within QGIS interface. The list can also be extended with the activation of Core or external plugins.

Barres d’outils

La barre d’outils fournit un accès à la majorité des fonctions des menus en plus d’outils additionnels destinés à interagir avec la carte. Chaque outil dispose d’une bulle d’aide qui s’affiche lorsque vous placez votre curseur au-dessus. Celle-ci affiche une courte description du rôle de l’outil.

Chaque barre d’outils peut être déplacée selon vos besoins. Vous pouvez les désactiver à partir du menu contextuel qui s’affiche d’un clic droit de la souris sur la barre d’outils.

../../../_images/toolbars1.png

Le menu Barres d’outils

Astuce

Restaurer des barres d’outils

If you have accidentally hidden a toolbar, you can get it back by choosing menu option View ‣ Toolbars ‣ (or kde Settings ‣ Toolbars ‣). If for some reason a toolbar (or any other widget) totally disappears from the interface, you’ll find tips to get it back at restoring initial GUI.

Panneaux

Besides toolbars, QGIS provides by default many panels to work with. Panels are special widgets that you can interact with (selecting options, checking boxes, filling values...) in order to perform a more complex task.

../../../_images/panels.png

Le menu Panneaux

Below are listed default panels provided by QGIS:

Affichage de la carte

Also called Map canvas, this is the “business end” of QGIS — maps are displayed in this area. The map displayed in this window will depend on the vector and raster layers you have chosen to load.

When you add a layer (see e.g. Opening Data), QGIS automatically looks for its Coordinate Reference System (CRS) and zooms to its extent if you work in a blank QGIS project. The layer’s CRS is then applied to the project. If there are already layers in the project, and in the case the new layer has the same CRS as the project, its features falling in the current map canvas extent will be visualized. If the new layer is in a different CRS from the project’s, you must Enable on-the-fly CRS transformation from the Project ‣ Project Properties ‣ CRS (see Define On The Fly (OTF) CRS Transformation). The added layer should now be visible if data are available in the current view extent.

The map view can be panned, shifting the focus of the map display to another region, and it can be zoomed in and out. Various other operations can be performed on the map as described in the Barres d’outils description. The map view and the legend are tightly bound to each other — the maps in view reflect changes you make in the legend area.

Astuce

Zoomer sur la carte avec la molette de la souris

Vous pouvez utiliser la molette de la souris pour changer le niveau de zoom de la carte. Placez votre curseur dans la zone d’affichage de la carte et faites rouler la molette vers l’avant pour augmenter l’échelle, vers vous pour la réduire. La vue sera recentrée sur la position du curseur de la souris. Vous pouvez modifier le comportement de la molette de la souris en utilisant l’onglet Outils cartographiques dans le menu Préférences ‣ Options.

Astuce

Se déplacer sur la carte avec les flèches et la barre espace

Vous pouvez utiliser les flèches du clavier pour vous déplacer sur la carte. Placez le curseur sur la carte et appuyez sur la flèche droite pour décaler la vue vers l’Est, la flèche gauche pour la décaler vers l’Ouest, la flèche supérieure vers le Nord et la flèche inférieure vers le Sud. Vous pouvez aussi déplacer la carte en gardant la touche espace appuyée et en bougeant la souris ou encore simplement en gardant la molette de la souris appuyée.

Barre d’état

La barre d’état fournit des informations génériques sur la carte, les actions traitées ou disponibles et vous offre des outils pour gérer la vue de carte.

Dans le coin gauche de la barre d’état, vous pouvez trouver un résumé des actions que vous avez effectuées (comme sélectionner des entités dans une couche, supprimer une couche) ou une description complète de l’outil que vous survolez (non disponible pour tous les outils). Au démarrage, la barre d’état vous informe également de la disponibilité de nouvelles extensions ou d’extensions qui peuvent être mises à jour (si le paramètre du gestionnaire d’extension est coché).

Dans le cas d’opérations de longue durée comme la récupération de statistiques dans les couches rasters ou le rendu de plusieurs couches dans la vue de carte, une barre de progression est affichée dans la barre d’état pour montrer la progression de l’action en cours.

L’option tracking Coordonnées affiche la position courante de la souris, tout en suivant son déplacement dans la vue de carte. Vous pouvez indiquer l’unité (et la précision) à utiliser dans les propriétés du projet, onglet Général. Cliquez sur le petit bouton situé à gauche de la boîte de texte pour basculer entre l’option de coordonnées et l’option extents Emprise qui affiche les coordonnées, dans les unités de la carte, du coin inférieur gauche et supérieur droit de la vue de la carte, au fur et à mesure que vous vous déplacez et que vous zoomez dedans.

À droite de ces coordonnées se trouve l’affichage de l’Echelle qui affiche l’échelle de la vue de carte. Si vous zoomez ou dé-zoomez, QGIS vous affiche l’échelle courante. Il existe un sélecteur d’échelle qui vous permet de choisir parmi les échelles prédéfinies et personnalisées.

On the right side of the scale display you can define a current magnification level for your map view. This allows to zoom in to a map without altering the map scale, making it easier to accurately tweak the positions of labels and symbols. The magnification level is expressed as a percentage. If the Magnifier has a level of 100%, then the current map is not magnified. Additionally, a default magnification value can be defined within Settings ‣ Options ‣ Rendering ‣ Rendering behaviour, which is very useful for high resolution screen to avoid too small symbols.

To the right of the magnifier tool you can define a current clockwise rotation for your map view in degrees.

Vers le côté droit de la barre d’état, il existe une case à cocher qui peut être utilisée pour temporairement bloquer le rendu des couches dans la vue de la carte (voir la section Rendu).

A la droite des fonctions de rendu, vous trouverez l’icône projectionDisabled du SCR actuel: avec le code EPSG du SCR du projet. Cliquer sur cette icône vous permet d’Activer la reprojection à la volée du SCR pour le projet ainsi que d’appliquer une autre projection à la vue de la carte.

Enfin, le bouton messageLog Messages ouvre le Panneau du gestionnaire de Logs qui vous informe sur les processus en tâche de fond (démarrage de QGIS, chargement des extensions, outils de traitements, etc.).

Astuce

Calculer l’échelle correcte de la carte

Quand vous démarrez QGIS, le SCR par défaut est WGS 84 (epsg 4326) et les unités sont en degrés. Cela signifie que QGIS exprime les coordonnées de vos couches dans cette unité. Pour avoir les valeurs correctes d’échelle, vous pouvez soit changer manuellement ce paramètre en mètres depuis l’onglet Général du menu Préférences ‣ Propriétés du projet..., soit sélectionner un système de projection de référence en cliquant sur l’icône projectionDisabled SCR actuel présentée ci-dessus. Dans ce dernier cas, les unités sont automatiquement choisies selon les spécifications de la projection du projet (par exemple, +units=us-ft).

Merci de prendre note que le choix du SCR au démarrage peut être configuré dans Préférences ‣ Options ‣ SCR.