7. A QGIS felülete

A QGIS grafikus felhasználói felülete (GUI) az alábbi ábrán látható. A sárga körökben lévő 1-től 5-ig terjedő számok a QGIS felületének fontos elemeit jelzik, és az alábbiakban tárgyaljuk.

../../../_images/startup.png

7.1. ábra A QGIS felülete a betöltött Alaszka adathalmazzal

Megjegyzés

Az ablakdekoráció (címsor stb.) az Ön operációs rendszerétől és ablakkezelőjétől függően eltérő lehet.

A QGIS fő felülete (7.1. ábra) öt részre ösztható:

  1. Menüsor

  2. Eszköztárak

  3. Panelek

  4. Térképnézet

  5. Állapotsor

Ezek részletes magyarázatához görgessen lejjebb.

7.2. Panelek és eszköztárak

A Nézet menüből (vagy kde Beállítások) tudja ki-be kapcsolni a QGIS felületi elemeit (Panelek ►) és eszköztárait (Eszköztárak ►). Ezek bármelyikének be- vagy kikapcsolásához kattintson jobb gombbal a menüsorra vagy az eszköztárra, és válassza ki a kívánt elemet. A panelek és eszköztárak a QGIS felületén belül bárhova helyezhetőek. A lista a beépített és külső modulok bekapcsolásával is bővíthető.

7.2.1. Eszköztárak

Az eszköztárak hozzáférést biztosítanak a menük legtöbb funkciójához, valamint további eszközökhöz a térkép kezeléséhez. Minden eszköztár elemhez előugró eszköztipp áll rendelkezésre. Vigye az egeret az elem fölé, és megjelenik az eszköz rövid leírása.

Minden eszköztár az Ön igényei szerint más helyre mozgatható. Ezenkívül kikapcsolhatók a jobb egérgomb helyi menüjével, vagy az egeret az eszköztárak felett tartva.

Az elérhető eszköztárak:

Név

Hivatkozás az eszköz dokumentációjára

Advanced Digitizing Toolbar

Advanced digitizing

Annotations Toolbar

Attribútumok

Working with the Attribute Table, Általános eszközök

Data Source Manager

Adatforrások kezelése

Adatbázis

DB Manager Plugin

Digitalizálás

Digitizing an existing layer

Súgó

Label

The Label Toolbar

Manage Layers

Opening Data

Map Navigation

Munka a térképvásznon

Mesh Digitizing Toolbar

Modulok

Modulok

Projekt

Projektfájlok használata, A térképek elrendezése, A stíluskönyvtár

Processing Algorithms

Configuring the Processing Framework

Raster

Modulok

Kiválasztás

Elemek kiválasztása

Shape digitizing

Shape digitizing

Snapping

Setting the snapping tolerance and search radius

Vector

Modulok

Web

Modulok, MetaSearch Catalog Client

Megjegyzés

A külső fejlesztők moduljai további eszközökkel bővíthetik az alapértelmezett eszköztárakat, vagy saját eszköztárat biztosíthatnak.

Javaslat

Eszköztárak visszaállítása

Ha véletlenül elrejtett egy eszköztárat, visszaállíthatja a Nézet ► Eszköztárak ► (vagy kde Beállítások ► Eszköztárak ►) segítségével. Ha valami okból egy eszköztár (vagy bármely másik felületi elem) teljesen eltűnne a QGIS felületéről, a kezdeti GUI visszaállítása fejezetben talál megoldási ötleteket.

7.2.2. Panelek

A QGIS számos panelt kínál. A panelek olyan felületi elemek, amiken keresztül összetett műveleteket lehet elvégezni (értékek megadása, listaelem kiválasztása, jelölőnégyzet pipálása, stb).

A QGIS által biztosított alapértelmezett panelek:

7.3. Térképnézet

7.3.1. A térképnézet áttekintése

A térképnézet (más szóval térképvászon) a QGIS „veszélyes része” – ezen a területen jelennek meg a térképek, 2 dimenzióban. A rajta megjelenő térképek már azzal a kinézetettel jelennek meg, amit a betöltött rétegekre Ön alkalmazott (jelrendszer, címkék, láthatóság, stb). A kinézet függ a rétegek és a projekt koordináta-rendszerétől (CRS) is.

Amikor a térképhez ad egy réteget (lásd Opening Data), a QGIS automatikusan megkeresi a hozzá való koordináta-rendszert. Ha projekt koordináta-rendszere (lásd Projekt koordináta-rendszerek) ettől eltér, a réteg terjedelmét automatikusan átszámolja ebbe a koordináta-rendszerbe. Ha üres QGIS projekttel indít, a térképnézet automatikusan ráközelít a hozzáadott rétegre. Ha már vannak rétegek a projektben, akkor a térképvászon nem lesz elmozdítva, így csak az aktuális térképvászon terjedelmébe eső elemek lesznek láthatók.

A térképnézetre kattintva az alábbi módokon kezelheti:

  • pásztázással, eltolva a megjelenítést a térkép egy másik régiójába: ezt megteheti a pan Térkép eltolása eszközzel, a nyílbillentyűkkel, vagy az egér mozgatásával, miközben lenyomva tartja a Space billentyűt, a középső egérgombot vagy az egérgörgőt. Pásztázáshoz az egeret használva az alsó állapotsoron látható az elmozdítás távolsága és iránya.

  • ki-be zoomolással az eszköztár zoomIn Nagyítás és zoomOut Kicsinyítés eszközeivel. Az Alt billentyűt nyomva tartva válthat a két eszköz között. Zoomolni az egérgörgővel is lehet, előre fogatva nagyít, visszafelé kicsinyít. A zoomolás az egérkurzor pozíciója körül történik. A Nagyítási tényező a Beállítások ► Beállítások… ► Térképeszközök menüben szabható személyre.

  • ráközelíthet az összes betöltött réteg teljes terjedelmére (zoomFullExtent Nagyítás az egészre), a Rétegek panelen kiválasztott összes rétegre (zoomToLayer Nagyítás a rétegre) vagy a Rétegek panelen kiválasztott rétegek összes kiválasztott elemére (zoomToSelected Nagyítás a kiválasztott elemekre)

  • navigálhat vissza és előre a térképvászon megtekintési előzményeiben az zoomLastElőző nagyítás és zoomNextKövetkező nagyítás gombokkal, vagy a vissza és előre egérgombokkal.

A térképre jobb egérgombbal kattintva a kattintás helyének koordinátáját másolhatja. A editCopy Koordináta másolása környezeti menüben választhat a térkép koordináta-rendszere, WGS84 vagy egyéni koordináta-rendszer között. A másolt koordinátát beillesztheti egy kifejezésbe, scriptbe, jegyzettömbbe vagy munkalapra…

Alapértelmezés szerint a QGIS egyetlen térképnézetet nyit meg (az úgynevezett „fő térképet”), amely szorosan kapcsolódik a Rétegek panelhez – a térképen „automatikusan” megjelennek a Rétegek panelen végzett módosítások. Lehetőség van további térképnézetek megnyitására is, amelyek tartalma eltérhet a Rétegek panel jelenlegi állapotától. Ezek lehetnek 2D vagy 3D típusúak, megjeleníthetnek eltérő méretarányt vagy kiterjedést, vagy térképtémák segítségével a betöltött rétegek eltérő részhalmazát jeleníthetik meg.

7.3.2. További térképnézetek beállítása

Új térképnézet hozzáadásához válassza a Nézet ► newMap Új térképnézet menüpontot. Egy új, a fő térkép megjelenítését utánzó lebegő ablak jelenik meg. Akárhány térképnézetet hozzáadhat. Meghagyhatja őket lebegőnek, helyezheti egymás mellé, vagy egymásra.

../../../_images/map_views.png

7.2. ábra Több térképnézet eltérő beállításokkal

A további térképnézetek tetején egy eszköztár található az alábbi lehetőségekkel:

  • Nézeten belüli navigáció: zoomFullExtent Nagyítás az egészre, zoomToSelected Nagyítás a kiválasztott elemekre és zoomToLayer Nagyítás a rétegre

  • showPresets Nézet térképtémájának beállítása segítségével beállítható, hogy a térképnézet milyen térképtémával jelenjen meg. Ha (egyik sem) van kiválasztva, a nézet követni fogja a Rétegek panel módosításait.

  • options Nézet beállítások a térképnézet finomhangolásához:

    • radioButtonOn Nézet középpontjának szinkronizálása a fő térképpel: összeköti a nézetek középpontját a méretarány módosítása nélkül. This allows you to have an overview style or magnified map which follows the main canvas center. Ez lehetővé teszi egy a fő vászon közepét követő áttekintő stílus vagy nagyított térkép létrehozását.

    • radioButtonOff Nézet szinkronizálása a kijelöléssel: hasonló, mint a kiválasztott elemekre nagyítás

    • Méretarány

    • Forgatás

    • Nagyítás

    • unchecked Méretarány szinkronizálása a fő térkép méretarányával. Hozzá lehet rendelni egy Méretarány szorzót, amivel a nézet a fő térképhez képes például mindig kétszeres nagyítással jelenik meg.

    • checkbox Annotációk megjelenítése

    • checkbox Kurzor helyének megjelenítése

    • unchecked Fő térkép terjedelmének megjelenítése

    • checkbox Címkék megjelenítése: lehetővé teszi a címkék elrejtését, függetlenül attól, hogy be vannak állítva a megjelenített réteg tulajdonságaiban

    • Térkép koordináta-rendszer változtatása…

    • Nézet átnevezése…

7.3.3. Időalapú vezérlés a térképvásznon

QGIS can handle temporal control on loaded layers, i.e. modify the map canvas rendering based on a time variation. To achieve this, you need:

  1. Layers that have dynamic temporal properties set. QGIS supports temporal control for different data providers, with custom settings. It’s mainly about setting the time range in which the layer would display:

    • vector layers: features are filtered based on time values associated to their attributes

    • mesh layers: displays dynamically the active dataset groups values

    When dynamic temporal options are enabled for a layer, an indicatorTemporal icon is displayed next to the layer in the Layers panel to remind you that the layer is temporally controlled. Click the icon to update the temporal settings.

  2. Enable the temporal navigation of the map canvas using the Temporal controller panel. The panel is activated:

    • using the temporal Temporal controller panel icon located in the Map Navigation toolbar

    • or from the View ► Panels ► Temporal controller panel menu

7.3.3.1. The temporal controller panel

The Temporal controller panel has the following modes:

../../../_images/temporal_controller_panel.png

7.3. ábra Temporal Controller Panel in navigation mode

  • temporalNavigationOff Turn off temporal navigation: all the temporal settings are disabled and visible layers are rendered as usual

  • temporalNavigationFixedRange Fixed range temporal navigation: a time range is set and only layers (or features) whose temporal range overlaps with this range are displayed on the map.

  • temporalNavigationAnimated Animated temporal navigation: a time range is set, split into steps, and only layers (or features) whose temporal range overlaps with each frame are displayed on the map

  • settings Settings for general control of the animation

    • Frames rate: number of steps that are shown per second

    • unchecked Cumulative range: all animation frames will have the same start date-time but different end dates and times. This is useful if you wish to accumulate data in your temporal visualisation instead of showing a ‘moving time window’ across your data.

7.3.3.2. Animating a temporal navigation

An animation is based on a varying set of visible layers at particular times within a time range. To create a temporal animation:

  1. Toggle on the temporalNavigationAnimated Animated temporal navigation, displaying the animation player widget

  2. Enter the Time range to consider. Using the refresh button, this can be defined as:

    • Set to full range of all the time enabled layers

    • Set to preset project range as defined in the project properties

    • Set to single layer’s range taken from a time-enabled layer

  3. Fill in the time Step to split the time range. Different units are supported, from seconds to centuries. A source timestamps option is also available as step: when selected, this causes the temporal navigation to step between all available time ranges from layers in the project. It’s useful when a project contains layers with non-contiguous available times, such as a WMS-T service which provides images that are available at irregular dates. This option will allow you to only step between time ranges where the next available image is shown.

  4. Click the play button to preview the animation. QGIS will generate scenes using the layers rendering at the set times. Layers display depends on whether they overlap any individual time frame.

    ../../../_images/map_navigation.gif

    7.4. ábra Temporal navigation through a layer

    The animation can also be previewed by moving the time slider. Keeping the refresh Loop button pressed will repeatedly run the animation while clicking play stops a running animation. A full set of video player buttons is available.

    Horizontal scrolling using the mouse wheel (where supported) with the cursor on the map canvas will also allow you to navigate, or “scrub”, the temporal navigation slider backwards and forwards.

  5. Click the fileSave Export animation button if you want to generate a series of images representing the scene. They can be later combined in a video editor software:

    ../../../_images/saveTimeAnimation.png

    7.5. ábra Exporting map canvas animation scenes to images

    • The filename Template: the #### are replaced with frame sequence number

    • The Output directory

    • Under Map settings, you can:

      • redefine the spatial extent to use

      • control the Resolution of the image (Output width and Output height)

      • Draw active decorations: whether active decorations should be kept in the output

    • Under Temporal settings, you can redefine:

      • the time Range for the animation

      • the Step (frame length) in the unit of your choice

7.3.4. Térképnézet exportálása

Az elkészített térképeket elhelyezheti, és különféle formátumokba exportálhatja a nyomtatási elrendezés vagy jelentés segítségével. Lehetőség van az aktuális megjelenítés közvetlen exportálására is, elrendezés nélkül. A térképnézetnek ez a gyors „képernyőképe” rendelkezik néhány kényelmes funkcióval.

A térképvászon exportálásához az aktuális megjelenítéssel:

  1. Kattintson a Projekt ► Import/Export menüre

  2. Az eredmény formátumtól függően válassza

    • vagy a saveMapAsImage Térkép exportálása képként…

    • vagy a saveAsPDF Térkép exportálása PDF formátumba… menüpontot

A két eszköznek vannak közös beállításai. A megjelenő párbeszédablakban:

../../../_images/saveMapAsImage.png

7.6. ábra A Térkép mentése képként párbeszédablak

  1. Válassza ki az exportálni kívánt Terjedelmet: ez lehet az aktuális nézet terjedelme (alapértelmezett), egy réteg terjedelme, vagy egy egyéni, a térképvásznon megrajzolt terjedelem. A kiválasztott terület koordinátái megjelennek és kézzel szerkeszthetőek.

  2. Adja meg a térkép Méretarányát, vagy válassza ki az előre definiált méretarányok listájából. A méretarány megváltoztatásakor megváltozik az exportálandó terjedelem.

  3. Állítsa be az eredmény Felbontását

  4. Beállíthatja a kép méreteit pixelben az Eredmény szélesség és Eredmény magasság megadásával. Kezdetben az aktuális térképi terjedelem és felbontás alapján van kiszámolva, de szabadon változtatható és módosításkor átméretezi a térképi terjedelmet (a középpontból kiindulva). A méretarány zárolható, ami különösen kényelmes lehet, ha a terjedelmet a vászonra rajzolja.

  5. checkbox Aktív dekorációk megjelenítése: használatakor a dekorációkat (lépték, cím, rács, északjel…) is exportálja a térképre

  6. checkbox Annotációk rajzolása: exportálja a feliratokat

  7. checkbox Georeferencia információ hozzáfűzése (beágyazva vagy world fájllal): a kimeneti formátumtól függően egy megegyező nevű world fájlt ment a kép mellé (PNG képekhez PNGW, JPG képekhez JPGW kiterjesztéssel). PDF esetén az információt magába a PDF fájlba ágyazza be.

  8. PDF-be exportáláskor további lehetőségek érhetőek el a Térkép mentése PDF-ként párbeszédablakban:

    ../../../_images/saveMapAsPDF.png

    7.7. ábra A Térkép mentése PDF-ként párbeszédablak

    • checkbox RDF metaadatok exportálása: a dokumentum metaadatai, mint cím, szerző, dátum, leírás, …

    • unchecked Térinformatikai PDF készítése (GeoPDF): Georeferált PDF fájlt hoz létre (GDAL 3, vagy újabb szükséges hozzá). További lehetőségek:

      • Válasszon GeoPDF Formátumot

      • checkbox Vegye bele a vektoros elem információit a GeoPDF fájlba: az eredmény GeoPDF tartalmazni fogja a térképen látható elemek összes geometria és attribútum információit.

      Megjegyzés

      A GDAL 3-as verziót használó QGIS 3.10 óta a GeoPDF fájlok adatforrásként is használhatóak. Bővebben a QGIS GeoPDF támogatásáról lásd https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/.

    • Térkép raszterizálása

    • checkbox Geometria egyszerűsítése az output fájl méretének csökkentése érdekében: A térkép exportálásakor a geometriák egyszerűsítésre kerülnek az által, hogy az exportálási felbontásban észrevehetetlenül kevéssé eltérő töréspontok el lesznek távolítva. Például ha az exportálási felbontás 300 dpi, akkor az egymástól kevesebb mint 1/600 collra lévő töréspontok lesznek eltávolítva. Ez csökkentheti az exportált fájl méretét és összetettségét (a nagyon nagy fájlok egyes alkalmazásokban nem tölthetők be).

    • Szöveg exportálása: szabályozza, hogy a címkék szövege a megfelelő szöveg objektumként legyenek exportálva (Szövegek exportálása mindig szövegobjektumként), vagy csak útvonalként (Szövegek exportálása mindig útvonalként). Ha útvonalobjektumként exportálja, a szövegek szerkeszthetőek lesznek külső programokban (pl. Inkscape). Ennek az a MELLÉKHATÁSA, hogy csökken a megjelenítési minőség, ÉS problémák vannak egyes szövegbeállítások, például övezetek kirajzolásával is. Emiatt javasolt útvonalként exportálni.

  9. A fájl helyének, nevének és formátumának kiválasztásához nyomja meg a Mentés gombot.

    Kép exportálásakor lehetséges az eredményt Vágólapra másolni, majd beilleszteni más alkalmazásokba (LibreOffice, Gimp, …)

7.4. 3D térképnézet

A 3D-s megjelenítés a 3D-s térképnézeten keresztül érhető el. 3D térképnézetet a Nézet ► new3DMap Új 3D térképnézet menüponttal hozhat létre. Egy lebegő QGIS panel jelenik meg. A panel dokkolható.

Eleinte a 3D-s térképnézet ugyanolyan kiterjedésű és nézetű, mint a 2D-s fő térképvászon. A nézet 3D-ssé alakításához számos navigációs eszköz áll rendelkezésre.

../../../_images/3dmapview.png

7.8. ábra A 3D térképnézet párbeszédablak

A következő eszközök találhatók a 3D-s térképnézet panel tetején:

  • pan Kamera vezérlés: mozgatja a nézetet, miközben megtartja a kamera szögét és irányát

  • zoomFullExtent Teljes nagyítás: átméretezi a nézetet az összes réteg terjedelmére

  • 3dNavigation Navigációs oldalsáv ki-be kapcsolása: megjeleníti/elrejti a navigációs kezelőszerveket (amik megkönnyítik a térképnézet kezelését)

  • identify Azonosítás: információkat ad a terep kattintott pontjáról vagy a kattintott 3D-s elemekről – további információkért lásd Elemek azonosítása

  • measure Mérési vonal: megméri a két pont közti vízszintes távolságot

  • play Animációk: megjeleníti/elrejti az animáció lejátszó kezelőfelületét

  • saveMapAsImage Mentés képként…: exportálja az aktuális nézetet egy képfájl formátumba

  • 3d 3D jelenet exportálása…: exportálja az aktuális nézetet egy 3D jelenet formájában (.obj fájl), lehetővé téve az utófeldolgozást külső alkalmazásokban, mint a Blender. A terep és a vektoros elemek 3D objektumként lesznek exportálva. Az exportálási beállítások, amelyek felülírják a réteg tulajdonságait ás a térképnézet beállításait, a következők:

    • Jelenet neve és a cél Könyvtár

    • Terep felbontás

    • Terep textúra felbontás

    • Modell méretarány

    • checkbox Élsimítás

    • checkbox Normálisok exportálása

    • checkbox Textúrák exportálása

  • showPresets Nézet térképtéma beállítása: Lehetővé teszi a térképnézetben megjelenítendő rétegek egy részének kiválasztását előre definiált térképtémák által.

  • options Beállítások a térképnézet testreszabásához

7.4.1. Jelenet beállításai

A 3D térképnézet alapértelmezett beállításokkal nyílik meg, melyeket személyre szabhat. Ehhez kattintson a 3D vászon panel tetején a options Beállítások… gombra; megnyílik a 3D beállítások ablak.

../../../_images/3dmapconfiguration.png

7.9. ábra A 3D térképbeállítások párbeszédablak

A 3D konfiguráció ablakban többféle lehetőség kínálkozik a 3D jelenet finomhangolására:

7.4.1.1. Terep

  • Terep: Mielőtt belemerülnénk a részletekbe, érdemes megjegyezni, hogy 3D-s nézetben a terepet hierarchikus domborzati csempék ábrázolják. Ahogy a kamera közelít a terephez, a meglévő, nem kellően részletgazdag csempék helyére kisebb, részletesebb csempék kerülnek. A csempének geometriája a magassági raszterrétegből származó háló, míg a textúrája a 2D térképrétegekből származik.

    • A terepmagasság Típusa lehet:

    • Magasság: a terep modellezésére használható raszter- vagy hálóréteg. A raszterréteg egy, a domborzat magassági adatait tartalmazó sávot kell tartalmazzon. Hálóréteg esetében a csomópont Z-értékei lesznek használva.

    • Függőleges szorzó: A függőleges tengely méretezési szorzószáma. Az érték növelésével felszínformák felnagyítódnak.

    • Csempe felbontás: Hány mintát használjon a domborzati rétegből az egyes csempékhez. A 16 képpontos érték azt jelenti, hogy az egyes csempék geometriája 16×16 magassági mintából áll. A nagyobb értékek részletesebb terepcsempéket eredményeznek, az összetettebb megjelenítés rovására.

    • Peremmagasság: A terep csempéi között néha apró repedések láthatóak. Az érték növelésével függőleges falak („szoknyák”) jönnek létre a terepcsempék körül, hogy eltüntessék a repedéseket.

  • Terrain elevation offset: moves the terrain up or down, e.g. to adjust its elevation with respect to the ground level of other objects in the scene.

    This can be useful when there is a discrepancy between the height of the terrain and the height of layers in your scene (e.g. point clouds which use a relative vertical height only). In this case adjusting the terrain elevation manually to coincide with the elevation of objects in your scene can improve the navigation experience.

  • Ha hálóréteget használ terepként, konfigurálhatja Háromszög beállításokat (drótváz megjelenítés, háromszögek simítása) és a Színmegjelenítési beállításokat (egységesen vagy a terepszinttől függően). További részletek a Hálóréteg tulajdonságok fejezetben.

  • unchecked Terepárnyalás: Lehetővé teszi a terepmegjelenítés kiválasztását:

    • Árnyalás letiltva – a terep színe csak a térkép textúrájától függ

    • Árnyalás engedélyezve – a terep színe Phong árnyalási modellje alapján lesz kiszámítva, figyelembe véve a térkép textúráját, a terep normálvektorát, a jelenet megvilágítás(ait) és a terep anyagának Környezeti és Tükröződési színeit, valamint Fényességét

7.4.1.2. Megvilágítás

A Megvilágítás fülön a symbologyAdd jelre kattintva hozzáadhat

  • legfeljebb nyolc Pontszerű fényforrást: minden irányba fényt bocsát ki, úgy mint egy egész területet bevilágító gömb. A fényforráshoz közelebb eső tárgyak fényesebbek, a távolabbiak sötétebbek lesznek. A pontszerű fényforrásnak beállított pozíciója (X, Y, Z), Színe, Intenzitása és Csillapítása van

  • legfeljebb négy Irányított fényforrást: egy óriási vaku fényét utánozza, ami nagyon távol van a tárgyaktól, mindig a középpontban és sosem alszik ki (úgy mint a Nap). Párhuzamos fénysugarakat bocsát ki egyetlen irányba, vagyis a fény a végtelenbe tart. Az irányított fényforrás forgatható egy Irányszög értékkel, van Magasság szöge, Színe és Intenzitása.

../../../_images/3dmapconfiguration_lights.png

7.10. ábra A 3D térkép megvilágítási beállítások párbeszédablaka

7.4.1.3. Árnyék

A jelenetre vetett árnyékok megjelenítéséhez jelölje be az unchecked Árnyékok megjelenítése jelölőnégyzetet. Beállítási lehetőségek:

  • Irányított fényforrás

  • Árnyék megjelenítés maximális távolsága: elkerülhető vele a túl távoli tárgyak árnyékának megjelenítése, elsősorban amikor a kamera felfelé néz a horizont mentén

  • Árnyékolási hajlam: az önmagát árnyékoló hatások elkerülése érdekében, amelyek a térképméretek közötti különbségek miatt egyes területeket másoknál sötétebbé tennének. Minél alacsonyabb, annál jobb

  • Árnyéktérkép felbontása: hogy az árnyékok élesebbek legyenek. Ha a felbontási paraméter túl magas, akkor a teljesítmény csökkenhet.

7.4.1.4. Kamera és égbolt

In this tab, you can override some default camera settings made in the Settings ► Options ► 3D dialog.

Furthermore, check unchecked Show skybox to enable skybox rendering in the scene. The skybox type can be:

  • Panoráma textúra egyetlen 360°-ot lefedő fájlból

  • Különböző homlokzatok, egy-egy textúrafájl a jelenetet tartalmazó doboz mind a hat oldalához

Texture image files of the skybox can be files on the disk, remote URLs or embedded in the project (more details).

7.4.1.5. Bővített

  • Térképcsempe felbontása: A terepcsempék textúrájaként használt 2D térképképek szélessége és magassága. A 256 px azt jelenti, hogy minden csempe 256×256 képpont méretű képként lesz megjelenítve. Nagyobb szám részletgazdagabb terepcsempéket eredményez, az összetettebb megjelenítés rovására.

  • Max. képernyő hiba: Meghatározza a terepcsempék részletesebbre cserélésének küszöbértékét (és fordítva), vagyis hogy a 3D nézet milyen hamar kezdjen nagyobb felbontású csempéket használni. Kisebb szám részletgazdagabb jelenetet eredményez az összetettebb megjelenítés rovására.

  • Max. terepi hiba: Az a felbontás, amelynél megáll a terepcsempék részletesebbre osztása (a felosztásuk amúgy sem jelentene több részletet). Ez az érték korlátozza a csempék hierarchiájának mélységét: az alacsonyabb értékek mélyebbé teszik a hierarchiát, növelve a megjelenítés bonyolultságát.

  • Nagyítási szintek: A nagyítási szintek számát mutatja (függ a térképcsempék felbontásától és a maximális terepi hibától).

  • unchecked Címkék megjelenítése: Be/ki kapcsolja a térképcímkék megjelenítését

  • unchecked Térképcsempe információ: a térképcsempék határának és csempeszámának beágyazása (hasznos a terepproblémák elhárításához)

  • unchecked Befoglaló téglalapok megjelenítése: megjeleníti a terepcsempék 3D-s befoglaló téglalapjait (hasznos a terepproblémák elhárításához)

  • unchecked Kamera nézetközpontjának megjelenítése

  • unchecked Fényforrások megjelenítése: egy gömböt jelenít meg a fényforrás kezdőpontjában, lehetővé téve a fényforrások könnyebb áthelyezését és elhelyezését a jelenet tartalmához képest

7.4.3. Animáció létrehozása

Egy animáció kulcsképkockák (kamerapozíciók bizonyos időpontokban) sorozatából áll. Animáció létrehozásához:

  1. Kapcsolja be az play Animációk eszközt; megjelenik az animáció lejátszó kezelőszerv

  2. Nyomja meg a symbologyAdd Kulcsképkocka hozzáadása gombot, majd adja meg a Kulcsképkocka idejét másodpercben. A beállított idő meg fog jelenni a Kulcsképkocka legördülőlistában.

  3. A navigációs eszközökkel mozgassa a kamerát az aktuális kulcsképkockához rendelendő helyre.

  4. Az előző lépéseket megismételve adjon hozzá annyi kulcsképkockát (idővel és pozícióval), amennyire szüksége van.

  5. QGISKattintson a play gombra az animáció előnézetéhez. A QGIS jeleneteket készít a beállított időpontokhoz az adott kamerapozíciókkal és elforgatásokkal, és interpolálja ezeket a kulcskockák között. Többféle Interpolációs mód áll rendelkezésre az animáláshoz (pl. lineáris, inQuad, outQuad, inCirc… – további részletek: https://doc.qt.io/qt-5/qeasingcurve.html#EasingFunction-typedef).

    The animation can also be previewed by moving the time slider. Keeping the Loop box checked will repeatedly run the animation while clicking play stops a running animation.

A jeleneteket ábrázoló képsorozat elkészítéséhez kattintson az fileSave Animációs képkockák exportálása gombra. A fájlnév Sablonon és az Eredmény könyvtáron, kívül beállíthatja a Másodpercenkénti képkockák számát, a Eredmény szélességet és Eredmény magasságot.

7.4.4. 3D vektorrétegek

A magassági értékekkel rendelkező vektorrétegek megjeleníthetőek a 3D térképnézetben a 3D megjelenítés engedélyezése bejelölésével a vektorréteg tulajdonságainak 3D nézet lapján. Számos lehetőség áll rendelkezésre a 3D vektorréteg megjelenítésének testreszabásához.

7.5. Állapotsor

Az állapotsor általános információt nyújt a térképnézetről és az elvégzett vagy elérhető műveletekről, valamint eszközöket biztosít a térképnézet kezeléséhez.

7.5.1. Keresősáv

Az állapotsor bal szélén található a keresősáv, egy gyorskereső eszköz, amely segít megtalálni és futtatni a QGIS bármely funkcióját vagy beállítását:

  1. A keresősáv használatához kattintson a szövegbeviteli mezőbe, vagy nyomja meg a Ctrl+K billentyűt.

  2. Írjon be egy a keresett elemhez kapcsolódó szöveget (név, címke, kulcsszó, stb). Alapértelmezés szerint az engedélyezett keresőszűrők találatai jelennek meg, de korlátozhatja a keresést egy bizonyos hatókörre, ha a szöveg elé keresőszűrő előtagot ír. Például l cad kifejezést beírva csak a nevében cad szórészletet tartalmazó rétegek jelennek meg találatként.

    A szűrő dupla kattintással is kiválasztható abban a menüben, amely a keresősáv aktiválásakor jelenik meg.

  3. Kattintson egy találatra az adott művelet végrehajtásához, az elem típusától függően.

Javaslat

Limit the lookup to particular field(s) of the active layer

Alapértelmezés szerint a keresés az „aktív réteg elemei”-re (f) az attribútumtábla összes mezőjében keres. A @ előtag használatával korlátozhatja a keresést egy bizonyos mezőre. Például f @name sal vagy @name sal csak olyan elemeket ad vissza, amelyek «»name»» attribútumában megtalálható a «sal» szórészlet. Gépelés közben aktív az automatikus szövegkiegészítés, a javaslatokat a Tab billentyűvel alkalmazhatja.

A more advanced control on the queried fields is possible from the layer Fields tab. Read Fields Properties for details.

A keresés több szálon fut, így az eredmények mindig a lehető leggyorsabban lesznek elérhetőek, még akkor is, ha lassú keresési szűrők vannak beállítva. Az eredmények azonnal megjelennek, amint egy szűrő feltételének megfeleltek, ami azt jelenti, hogy például a fájlkereső szűrő egyesével mutatja az eredményeket a fájlfa vizsgálata közben. Ez biztosítja, a felhasználói felület gyorsaságát, még akkor is, ha nagyon lassú keresési szűrő van használatban (például olyan, amely online szolgáltatást használ).

Megjegyzés

The Nominatim locator tool may behave differently (no autocompletion search, delay of fetching results, …) with respect to the OpenStreetMap Nominatim usage policy.

Javaslat

A keresősáv beállításainak gyors elérése

Kattintson a keresősávban a search ikonra a használható szűrők listájának megjelenítéséhez. A listában látható egy Konfigurálás bejegyzés, amely megnyitja a Keresés lapot a Beállítások ► Beállítások… menüben.

7.5.2. Műveletek kijelzése

In the area next to the locator bar, a summary of actions you’ve carried out will be shown when needed (such as selecting features in a layer, removing layer, pan distance and direction) or a long description of the tool you are hovering over (not available for all tools).

Hosszadalmas műveletek futása közben folyamatjelző sáv látható az állapotsorban. Ilyen művelet például a statisztikagyűjtés egy raszterrétegről, egy Feldolgozás algoritmus futtatása, vagy számos réteg kirajzolása a térképnézetre.

7.5.3. A térképvászon vezérlése

A tracking Koordináta szövegdoboz az egér aktuális pozícióját mutatja, követve annak mozgását a térképnézeten. A mértékegység (és pontosság) a Projekt ► Tulajdonságok… ► Általános lapon állítható. Kattintson a szövegdoboz jobb oldalán található kis gombra, ha váltani szeretné a koordináta kijelzés és a extents Terjedelem kijelzés között. Utóbbi az aktuális térképnézet bal alsó és jobb felső sarkának koordinátáit mutatja térképi egységekben.

A koordináta mellett jelenik meg a Méretarány szövegdoboz, ami a térképnézet méretarányát mutatja. Tartozik hozzá egy legördülő lista, amiből kiválaszthatja az előre definiált és egyéni méretarányokat.

On the right side of the scale display, press the lockedGray button to lock the scale to use the magnifier to zoom in or out. The magnifier allows you to zoom in to a map without altering the map scale, making it easier to tweak the positions of labels and symbols accurately. The magnification level is expressed as a percentage. If the Magnifier has a level of 100%, then the current map is not magnified, i.e. is rendered at accurate scale relative to the monitor’s resolution (DPI). A default magnification value can be defined within Settings ► Options ► Rendering ► Rendering behavior, which is very useful for high-resolution screens to enlarge small symbols. In addition, a setting in Settings ► Options ► Canvas & Legend ► DPI controls whether QGIS respects each monitor’s physical DPI or uses the overall system logical DPI.

A nagyítótól jobbra megadhatja a térképnézet óramutató járása szerinti elforgatását fokban.

Az állapotsor jobb szélén egy apró jelölőnégyzet látható, amivel átmenetileg megakadályozhatja a térképrétegek megjelenítését a térképnézeten. (lásd a Megjelenítés fejezetet).

Ettől jobbra az projectionEnabled EPSG:kód gomb látható, ami a projekt aktuális koordináta-rendszerét mutatja. Rákattintva megnyílik a Projekt tulajdonságok párbeszédablak, ahol a térképnézethez más koordináta-rendszert állíthat be.

Javaslat

A térképvászon megfelelő méretarányának kiszámítása

Amikor elindítja a QGIS-t, az alapértelmezett koordináta-rendszer a WGS 84 (EPSG 4326), a mértékegységek pedig fokban lesznek. Ez azt jelenti, hogy a QGIS a rétegeken lévő bármely koordinátát fokokban fogja értelmezni. Ahhoz, hogy helyes méretarányt kapjon, átállíthatja kézzel a Projekt ► Tulajdonságok… Általános lapján (például méterre), vagy használhatja az projectionEnabled EPSG:kód ikont a fentebb látható módon. Ez utóbbi esetben a mértékegység a projekt vetületében meghatározott lesz (pl, +units=m).

Az indításkor koordináta-rendszer átállítható a Beállítások ► Beállítások… ► Koordináta-rendszer lapon.

7.5.4. Üzenetek

A jobb szélen lévő messageLog Üzenetek gomb megnyitja az Üzenetnaplók panelt, amely a mögöttes folyamatokról ad információt (QGIS indítás, modulbetöltés, feldolgozó eszközök, stb).

A Modulkezelő beállításaitól függően az állapotsorban időnként egy ikont jelenhet meg a jobb szélen, amely új (pluginNew), vagy frissíthető (pluginUpgrade) modulokról értesít. A Modulkezelő megnyitásához kattintson az ikonra.