8. Böngésző panel

A QGIS Böngésző panele egy kiváló eszköz QGIS erőforrások böngészéséhez, kereséséhez, ellenőrzéséhez, másolásához és természetesen betöltéséhez. Csak azok az erőforrások jelennek meg a böngészőben, amiket a QGIS tud kezelni.

A Böngésző panel használatával megkereshet, megvizsgálhat és hozzáadhat adatokat a The Browser Panel fejezetben leírt módon. Továbbá a Böngésző panel támogatja számos QGIS erőforrás, mint például projektfájlok, Python scriptek, Feldolgozó scriptek és Feldolgozó modellek fogd és vidd módszerrel történő kezelését.

A Python scriptek, Feldolgozó scriptek és Feldolgozó modellek külső szerkesztőben és a grafikus modellezőben is megnyithatóak.

A rétegeket áthúzhatja fogd és vidd módszerrel a Rétegek panelről a Böngésző panelre, például egy GeoPackage vagy PostGIS adatbázisba.

../../../_images/browser_panel1.png

8.1. ábra Böngésző panel

A Böngésző panel (8.1. ábra) kinyitható faszerkezetbe van rendezve, pár rögzített felső szintű bejegyzéssel, amik a böngésző által kezelt formátumokat jelzik. A csomópontok a bejegyzés neve melletti browserExpand gombra kattintva nyithatóak le. Az ág a browserCollapse gombbal csukható be. Az collapseTree Összes becsukása gomb összezárja az összes felső szintű elemet.

A Beállítások ► Felület testreszabása… párbeszédablakban van lehetőség egyes erőforrások letiltására. Ha például nem szeretne Python scripteket látni a böngészőben, törölheti a Böngésző ► py bejegyzés jelölőnégyzetét, ha pedig megszabadulna a Saját könyvtárától a böngészőben, vegye ki a pipát a Böngésző ► special:Home bejegyzés elől.

A (filterMap Böngésző szűrő) használható az elemek név szerinti keresésére (a fastruktúra levél- és csomópontelemei közt keres). A kereső szövegbeviteli mezője melletti options Beállítások lenyíló menüjében az alábbi lehetőségek érhetőek el:

  • Kis- és nagybetűérzékeny keresés kapcsolása

  • a Szűrőminta szintaxis beállítása az alábbiak egyikére

    • Normál

    • Helyettesítő karakter(ek)

    • Reguláris kifejezések

A Tulajdonságok ablaktábla hasznos információkat tud megjeleníteni pár bejegyzésről, erőforrásról. Engedélyezni a metadata Tulajdonságok ablaktábla be-/kikapcsolása gombbal lehet. Engedélyezéskor a böngésző panel alján nyílik meg, ahogy a 8.2. ábra képen látható.

../../../_images/browser_p_properties_w.png

8.2. ábra A Tulajdonságok ablaktábla

Egy második böngésző panel nyitható meg a Böngésző (2) panel engedélyezésével a Nézet ► Panelek menüben. Két böngészőpanel használata hasznos lehet a rétegek a böngészőhierarchia különböző ágaiban elhelyezkedő erőforrásainak közti másolásához.

8.1. A Böngészőből megnyitható / futtatható erőforrások

A Böngésző panelen keresztül sok mindent el lehet érni

  • Vektor-, raszter- és hálórétegek hozzáadása a térképhez dupla kattintással, a térképvászonra húzással, vagy rákattintva a addLayer Kiválasztott rétegek hozzáadása gombra (rétegek kiválasztása után)

  • Python scriptek futtatása (beleértve a Feldolgozás algoritmusokat) dupla kattintással, vagy a térképvászonra húzva

  • Modellek futtatása dupla kattintással, vagy a térképvászonra húzva

  • Szimbólumok kibontása… QGIS projektfájlokból a hely menü használatával

  • Fájlok megnyitása az alapértelmezett alkalmazásaikkal (<fájlformátum> megnyitása külső alkalmazásban… a helyi menüben). Például: HTML fájlok, táblázatok, képek, PDF-ek, szövegfájlok, stb.

  • Bejegyzések másolása

  • Rétegek átnevezése és törlése (helyi menü: Kezelés ►)

  • Open a file explorer window and directly select the file Show in Files

A különböző erőforrás-csoportok jellemző műveletei az alább felsorolt ​​legfelső szintű bejegyzések alatt vannak részletezve.

8.2. A Böngésző panel legfelső szintű bejegyzései

8.2.1. Kedvencek

A gyakran használt fájlrendszer útvonalak kedvencként jelölhetők meg. A megcímkézettek itt fognak megjelenni.

A Saját könyvtár alatt részletezett műveleteken felül a helyi menü a Kedvenc átnevezése… és Kedvenc eltávolítása menüpontokat tartalmazza.

8.2.2. Térbeli könyvjelzők

Itt találja a térbeli könyvjelzőit, Projekt könyvjelzők és Felhasználói könyvjelzők alá rendezve.

A legfelső szintű helyi menüből a következő műveleteket érheti el: Új térbeli könyvjelző… hozzáadása, Térbeli könyvjelző kezelő megjelenítése, Térbeli könyvjelzők importálása… és Térbeli könyvjelzők exportálása….

A könyvjelző elemek elérhető műveletei: guilabel:Nagyítás a könyvjelzőre, Térbeli könyvjelző szerkesztése… és Térbeli könyvjelző törlése

8.2.3. Projektkönyvtár

A projektfájl mentése után elérhetővé válik a Projektkönyvtár bejegyzés, egy olyan mappa, amely az aktuális projekten belül használható adatokat és egyéb tartalmakat (szkriptek, modellek, szöveg stb.) tartalmaz. A Böngésző panelről lehetővé teszi a projekt adatainak és egyéb fájljainak gyors elérését.

It defaults to the project file folder but can be changed through the Project ► Properties… ► General ► Project home option, or by right-clicking on the Project Home item of the Browser panel and selecting Set project home…. Customizing that folder is especially useful in contexts where QGIS projects are not stored in the root folder of an organisational «project», along with datasets.

8.2.4. Meghajtók és fájlrendszer

A Böngésző panel következő elemei a használt operációs rendszertől függenek, és a fájlrendszer legfelső szintű elemeire vonatkoznak.

Ezek a következők:

  • A Saját könyvtár, amely az aktuális felhasználó Saját könyvtárára (Home) mutat

  • Unix alapú rendszereken a gyökér / könyvtár

  • a csatlakoztatott meghajtókat, akár helyi, akár hálózati. Az operációs rendszertől függően közvetlenül jelennek meg a listában (pl. C:\, D:\), vagy a /Volumes bejegyzésen keresztül.

Ezen mappák vagy meghajtók helyi menüjéből a következőket teheti:

  • tartalom frissítése

  • Új ► alpont létrehozása, ami lehet Könyvtár, GeoPackage vagy ESRI Shape fájl formátumú adathalmaz

  • könyvtár elrejtése (Elrejtés a Böngészőből)

  • Szín beállítása: testreszabhatja a mappaikon színét, elősegítve a gyors navigációt a bonyolult mappastruktúrákban

  • Beolvasás engedélyezése:

    • checkbox Monitor for changes: allows to manually control whether a particular directory should be monitored and automatically updated. This setting applies to the selected directory and all subdirectories. This means that you can manually opt-in to monitoring of network drives if you know there’s no issue, or manually opt-out of monitoring of large directories which you don’t want monitored for other reasons. By default, remote or network drives are not automatically monitored.

    • unchecked A könyvtár gyors átvizsgálása

  • Könyvtár megnyitása… a fájlkezelőben

  • a könyvtár megnyitása terminálban (Megnyitás terminálban…)

  • ellenőrizze a Tulajdonságokat… vagy a szülő Könyvtár tulajdonságait…

8.2.5. Adatbázisok

Depending on your OS and installed drivers, you might have access to different database types to use in QGIS. Below are listed the different entries of contextual menu at each level of the dataset tree.

Szint

Helyi menü

Adatbázis típusa

geoPackage GeoPackage

spatialite SpatiaLite

postgis PostGIS

hana SAP HANA

mssql MSSQL

oracle Oracle

Főmenü

Create a New Connection… to an existing database

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Create Database…

checkbox

checkbox

Save Connections… details to a file

checkbox

checkbox

checkbox

Load Connections…

checkbox

checkbox

checkbox

Connection / Database

Refresh a connection

checkbox

checkbox

checkbox

Edit Connection… settings

checkbox

checkbox

checkbox

Delete Connection

checkbox

checkbox

checkbox

checkbox

checkbox

Delete <database_name>

checkbox

checkbox

Compact Database (VACUUM)

checkbox

Create a New Schema…

checkbox

checkbox

checkbox

Create a New Table…

checkbox

checkbox

checkbox

checkbox

Execute SQL… query

checkbox

checkbox

checkbox

checkbox

Schema

Refresh a schema

checkbox

checkbox

checkbox

Schema Operations ► Rename Schema…

checkbox

checkbox

checkbox

Schema Operations ► Delete Schema…

checkbox

checkbox

checkbox

Create a New Table…

checkbox

checkbox

Execute SQL… query

checkbox

checkbox

Table / Layer

Table Operations ► Rename Table…

checkbox

checkbox

checkbox

Table Operations ► Truncate Table…

checkbox

checkbox

Execute SQL… query

checkbox

checkbox

checkbox

Export Layer ► To file…

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Rename Layer <layer_name>…

checkbox

checkbox

Manage ► Delete Layer <layer_name>…

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Delete Selected Layers

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Add Layer to Project

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Add Selected Layers to Project

checkbox

checkbox

checkbox

checkbox

checkbox

Open Layer Properties… dialog

checkbox

checkbox

checkbox

checkbox

checkbox

Open File Properties… dialog

checkbox

Fields

Add New Field…

checkbox

checkbox

checkbox

checkbox

Field

Delete Field…

checkbox

checkbox

checkbox

checkbox

8.2.6. Tiles and Web Services

Szint

Helyi menü

Type of services

wms WMS / WMTS

vectorTileLayer Vector Tiles

xyz XYZ Tiles

wcs WCS

wfs WFS / OGC API - Features

afs ArcGIS REST Servers

geonode GeoNode

Főmenü

Create a New Connection…

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Create a New Generic Connection…

checkbox

Create a New ArcGIS Vector Tile Service Connection…

checkbox

Save Connections… details to a file

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Load Connections…

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Connection

Refresh connection

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Edit… connection settings

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Delete connection

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

View Service Info in Web browser

checkbox

Table / Layer

Export Layer ► To File…

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Add layer to Project

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Open Layer properties… dialog

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

View Service Info in Web browser

checkbox

8.3. Erőforrások

  • Projektfájlok. A QGIS projektfájlokat a környezeti menüjükből:

    • megnyithatja (Projekt megnyitása)

    • kibonthatja a szimbólumait (Szimbólumok kibontása…) – megnyitja a stíluskezelőt, amiben a szimbólumokat XML fájlba exportálhatja, hozzáadhat szimbólumokat az alapértelmezett stílushoz, vagy exportálhatja PNG-be és SVG-be.

    • megnézheti a tulajdonságait (Fájl tulajdonságok…)

    Kinyithatja a projektfájlokat, hogy lássa a bennük található rétegeket. A rétegek helyi menüje a böngésző többi részéhez hasonló műveleteket biztosít.

  • QGIS Rétegdefiníciós fájlok (QLR). A helyi menüből:

    • exportálhatja (Réteg exportálása ► Fájlba)

    • hozzáadhatja a projekthez (Réteg hozzáadása a projekthez)

    • megnézheti a tulajdonságokat (Réteg tulajdonságok…)

  • Feldolgozó modellek (.model3). A helyi menüből elérhető műveletek:

    • Modell futattása…)

    • Modell szerkesztése…)

  • QGIS nyomtatás összeállító sablonok (QPT). A helyi menüből elérhető műveletek:

    • (Új elrendezés sablonból)

  • Python szkriptek (.py). A helyi menüből elérhető műveletek:

    • (Szkript futtatása…)

    • (Megnyitás külső szerkesztőben)

  • Felismert raszteres formátumok. A helyi menüből elérhető műveletek:

    • törölheti (<adathalmaz neve> fájl törlése)

    • exportálhatja (Réteg exportálása ► Fájlba)

    • hozzáadhatja a projekthez (Réteg hozzáadása a projekthez)

    • megnézheti a tulajdonságokat (Tulajdonságok…, Fájl tulajdonságok…)

    Néhány formátumnál lehetőség van: <fájlformátum> megnyitása külső alkalmazásban…

  • Felismert vektoros formátumok. A helyi menüből elérhető műveletek:

    • törölheti (<adathalmaz neve> fájl törlése)

    • exportálhatja (Réteg exportálása ► Fájlba)

    • hozzáadhatja a projekthez (Réteg hozzáadása a projekthez)

    • megnézheti a tulajdonságokat (Tulajdonságok…, Fájl tulajdonságok…)

    Néhány formátumnál lehetőség van: <fájlformátum> megnyitása külső alkalmazásban…