8. El panel Navegador

El panel del navegador QGIS es una gran herramienta para navegar, buscar, inspeccionar, copiar y cargar recursos QGIS. Solo los recursos que QGIS sabe cómo manejar se muestran en el navegador.

Usando el panel del Navegador puede localizar, inspeccionar y agregar datos, como se describe en El panel Navegador. Además, el panel del navegador admite la función de arrastrar y soltar muchos recursos de QGIS, como archivos de proyecto, scripts de Python, scripts de procesamiento y modelos de procesamiento.

Los scripts de Python, los scripts de procesamiento y los modelos de procesamiento también se pueden abrir para editarlos en un editor externo y en el modelador gráfico.

Puede arrastrar y soltar capas desde el panel Layers al panel Browser, por ejemplo a un GeoPackage o a una base de datos PostGIS.

../../../_images/browser_panel1.png

Figura 8.1 El panel Navegador

El panel del navegador (Figura 8.1) está organizado como una jerarquía expandible con algunas entradas fijas de nivel superior que organizan los recursos manejados por el navegador. Las entradas de nodo se expanden haciendo click en browserExpand a la izquierda del nombre de la entrada. Una rama se contrae haciendo click en browserCollapse. El botón collapseTree Contraer todo contrae todas las entradas de nivel superior.

En Ajustes ► Personalización de Interface es posible deshabilitar recursos. Si usted, por ejemplo, no desearía mostrar los scripts Python en el navegador, usted puede quitar la selección de la entrada Navegador ► py y si desea deshacerse de su carpeta de inicio en el navegador usted puede quitar la selección de la entrada Navegador ► special:Inicio.

Se puede utilizar un filtro (filterMap Filter Browser) para buscar en función de los nombres de las entradas (tanto las entradas de hoja como las entradas de nodo en la jerarquía). Usando el menú desplegable |opciones| Opciones junto al campo de texto del filtro, puede

  • cambiar búsqueda sensible a mayúsculas y minúsculas

  • establecer Sintaxis del patrón de filtro a uno de

    • Normal

    • Comodín(es)

    • Expresiones Regulares

El widget de Propiedades, muestra información útil sobre algunas entradas/recursos, se puede habilitar/deshabilitar usando el botón |metadatos| Activar/desactivar el widget de propiedades. Cuando está habilitado, se abre en la parte inferior del panel del navegador, como se muestra en Figura 8.2.

../../../_images/browser_p_properties_w.png

Figura 8.2 El Widget Propiedades

Se puede abrir un segundo panel navegador activando el panel Explorador (2) en Ver ► Paneles. Teniendo dos paneles de exploración puede ser útil al copiar capas de recursos localizados dentro de diferentes ramas de la jerarquía del explorador.

8.1. Recursos que se pueden abrir/ejecutar desde el navegador

Se pueden lograr muchas cosas en el panel del navegador

  • Agregar capas vectoriales, ráster y de malla a su mapa haciendo doble click, arrastrándolo al lienzo del mapa o haciendo click en el botón addLayer Agregar capas seleccionadas (después de seleccionar capas)

  • Ejecutar Scripts de python (incluidos algoritmos de Procesamiento) haciendo doble click o arrastrando sobre el mapa del lienzo

  • Ejecutar modelos haciendo doble clic o arrastrándolos al lienzo del mapa

  • Extraer Símbolos… de archivos del Proyecto QGIS usando el menú contextual

  • Abrir archivos con sus aplicaciones por defecto (Abrir <file type> Externamente… en el menú contextual). Ejemplos: archivos HTML, hojas de calculo, imagenes, PDFs, archivos de texto, …

  • Copiar entradas

  • Rename and delete (multiple) layers (context menu: Manage ►)

  • Open a file explorer window and directly select the file Show in Files

Las acciones específicas de recursos se enumeran para los diferentes grupos de recursos ordenados en las entradas de nivel superior que se enumeran a continuación.

8.2. Entradas de nivel superior del panel del navegador

8.2.1. Favoritos

Las ubicaciones del sistema de archivos más utilizadas se pueden etiquetar como favoritas. Las que hayas etiquetado aparecerán aquí.

Además de las opercaiones descritas en Home, el menú contextual le permite Renombrar Favorito… y Borrar Favorito.

8.2.2. Marcadores espaciales

Aquí es donde encontrará sus marcadores espaciales, organizados en Marcadores de Proyecto y Marcadores de Usuario.

Desde el menú contextual de nivel superior, puede crear un marcador (Nuevo Marcador Espacial…), Mostrar el Adminstrador de Marcadores Espaciales, Importar Marcadores Espaciales… y Exportar Marcadores Espaciales….

Para las entradas de marcadores, puede hacer Zoom al marcador, Editar marcador espacial … `y :guilabel:`Eliminar marcador espacial

8.2.3. Project Home

Available once the project file has been saved, the Project home entry is a folder containing data and other contents (scripts, models, text, …) that may be used within the current project. Displayed in the Browser panel, it allows you to quickly access data and other files of the project.

It defaults to the project file folder but can be changed through the Project ► Properties… ► General ► Project home option, or by right-clicking on the Project Home item of the Browser panel and selecting Set project home…. Customizing that folder is especially useful in contexts where QGIS projects are not stored in the root folder of an organisational “project”, along with datasets.

8.2.4. Drives and file system

The next items of the Browser panel depend on the OS in use and concern the top level entries of its file system.

They are mainly:

  • The Home folder, pointing to the current user home folder

  • on Unix-based machines, the root / folder

  • the connected drives, either local or network. Depending on the OS, they are directly listed (eg, C:\, D:\) or through the /Volumes entry.

From the contextual menu of each of these folders or drives, you can:

  • refresh the contents

  • create a New ► subitem that is a Directory, GeoPackage or ESRI Shapefile format dataset

  • ocultar el directorio (Ocultar del Navegador)

  • Set color: customize the folder icon color, aiding in rapid browser navigation of complex folder structures

  • enable Scanning:

    • checkbox Monitor for changes: allows to manually control whether a particular directory should be monitored and automatically updated. This setting applies to the selected directory and all subdirectories. This means that you can manually opt-in to monitoring of network drives if you know there’s no issue, or manually opt-out of monitoring of large directories which you don’t want monitored for other reasons. By default, remote or network drives are not automatically monitored.

    • unchecked Fast scan this directory

  • open the directory in your file manager (Open Directory…)

  • open the directory in a terminal window (Open in Terminal…)

  • inspect the Properties… or the parent Directory Properties…

8.2.5. Database entries

Depending on your OS and installed drivers, you might have access to different database types to use in QGIS. Below are listed the different entries of contextual menu at each level of the dataset tree.

Level

Context menu

Type of database

geoPackage GeoPackage

spatialite SpatiaLite

postgis PostGIS

hana SAP HANA

mssql MSSQL

oracle Oracle

Top menu

Create a New Connection… to an existing database

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Create Database…

checkbox

checkbox

Save Connections… details to a file

checkbox

checkbox

checkbox

Load Connections…

checkbox

checkbox

checkbox

Connection / Database

Refresh a connection

checkbox

checkbox

checkbox

Edit Connection… settings

checkbox

checkbox

checkbox

Delete Connection

checkbox

checkbox

checkbox

checkbox

checkbox

Delete <database_name>

checkbox

checkbox

Compact Database (VACUUM)

checkbox

Create a New Schema…

checkbox

checkbox

checkbox

Create a New Table…

checkbox

checkbox

checkbox

checkbox

Execute SQL… query

checkbox

checkbox

checkbox

checkbox

Schema

Refresh a schema

checkbox

checkbox

checkbox

Schema Operations ► Rename Schema…

checkbox

checkbox

checkbox

Schema Operations ► Delete Schema…

checkbox

checkbox

checkbox

Create a New Table…

checkbox

checkbox

Execute SQL… query

checkbox

checkbox

Table / Layer

Table Operations ► Rename Table…

checkbox

checkbox

checkbox

Table Operations ► Truncate Table…

checkbox

checkbox

Execute SQL… query

checkbox

checkbox

checkbox

Export Layer ► To file…

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Rename Layer <layer_name>…

checkbox

checkbox

Manage ► Delete Layer <layer_name>…

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Delete Selected Layers

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Add Layer to Project

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Add Selected Layers to Project

checkbox

checkbox

checkbox

checkbox

checkbox

Open Layer Properties… dialog

checkbox

checkbox

checkbox

checkbox

checkbox

Open File Properties… dialog

checkbox

Fields

Add New Field…

checkbox

checkbox

checkbox

checkbox

Field

Delete Field…

checkbox

checkbox

checkbox

checkbox

8.2.6. Tiles and Web Services

Level

Context menu

Type of services

wms WMS / WMTS

vectorTileLayer Vector Tiles

xyz XYZ Tiles

wcs WCS

wfs WFS / OGC API - Features

afs ArcGIS REST Servers

geonode GeoNode

Top menu

Create a New Connection…

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Create a New Generic Connection…

checkbox

Create a New ArcGIS Vector Tile Service Connection…

checkbox

Save Connections… details to a file

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Load Connections…

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Connection

Refresh connection

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Edit… connection settings

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Delete connection

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

View Service Info in Web browser

checkbox

Table / Layer

Export Layer ► To File…

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Add layer to Project

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Open Layer properties… dialog

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

View Service Info in Web browser

checkbox

8.3. Recursos

  • Archivos de Proyecto. El menú contextual de archivos de proyecto de QGIS le permite:

    • abrirlas (Abrir Proyecto)

    • extraer símbolos (Extraer Símbolos…) - abre el administrador de estilos que le permite exportar símbolos a un archivo XML, añadir símbolos al estilo predeterminado o exportar como PNG o SVG.

    • inspeccionar propiedades (Propiedades de Archivo…)

    Puede expandir el archivo del proyecto para ver sus capas. El menú de contexto de una capa ofrece las mismas acciones como en cualquier otro lugar del navegador.

  • Archivos de definición de capa QGIS (QLR). Las siguientes acciones están disponibles en el menú contextual:

    • exportarla (Exportar Capar ► A archivo)

    • añadirla al proyecto (Añadir Capa a Proyecto)

    • inspeccionar Propiedades (Propiedades de capa…)

  • Modelos de procesamiento (.model3). Las siguientes acciones están disponibles en el menú contextual:

    • Ejecutar Modelo…)

    • Editar Modelo…)

  • Plantillas de composición de impresión QGIS (QPT). La siguiente acción está disponible en el menú contextual:

    • (Nuevo Diseño desde PLantilla)

  • Secuencias de comandos de Python (.py). Las siguientes acciones están disponibles en el menú contextual:

    • (Ejecutar script…)

    • (Abrir en Editor Externo)

  • Formatos ráster reconocidos. Las siguientes acciones están disponibles en el menú contextual:

    • borrarlo (Borrar Archivo <dataset name>)

    • exportarla (Exportar Capar ► A archivo)

    • añadirla al proyecto (Añadir Capa a Proyecto)

    • inspeccionar propiedades (Propiedades de capa…, Propiedades de Archivo…)

    Para algunos formatos puede además Abrir <file type> Externamente…

  • Formatos vectoriales reconocidos. Las siguientes acciones están disponibles en el menú contextual:

    • borrarlo (Borrar Archivo <dataset name>)

    • exportarla (Exportar Capar ► A archivo)

    • añadirla al proyecto (Añadir Capa a Proyecto)

    • inspeccionar propiedades (Propiedades de capa…, Propiedades de Archivo…)

    Para algunos formatos puede además Abrir <file type> Externamente…