8. Le panneau explorateur

Le panneau explorateur de QGIS est un bon moyen d’explorer, chercher, inspecter, copier et charger des ressources QGIS. Seuls les ressources que QGIS sait manipuler sont disponibles dans l’explorateur.

En utilisant le panneau Explorateur, vous pouvez localiser, inspecter et ajouter une donnée, comme décrit dans la section Le panneau Explorateur. En plus, le panneau Explorateur supporte le glisser et déplacer de nombreuses ressources QGIS, telles que les fichiers projet, les scripts Python, les scripts de traitement et les modèles de traitement.

Les scripts Python, les scripts de traitement et les modèles de traitement peuvent également être ouverts pour l’édition dans un éditeur extermine et le modeleur graphique.

Vous pouvez glisser/déposer des couches depuis le panneau Couches vers le panneau Explorateur, par exemple dans une base GeoPackage ou PostGIS.

../../../_images/browser_panel1.png

Fig. 8.1 Le panneau explorateur

Le panneau explorateur (Fig. 8.1) est organisé selon une hiérarchie extensible avec un niveau supérieur qui organise les ressources disponibles pour l’explorateur. Les nœuds en entrée sont développés en cliquant sur browserExpand à gauche du nom de l’entrée. Une branche se plie en cliquant sur browserCollapse. Le bouton collapseTree Tout replier plie tout les entrées du niveau supérieur.

Dans Préférences ► Personnalisation de l’interface il est possible de désactiver des ressources. Si, par exemple, vous ne souhaitez pas voir les scripts Python dans l’explorateur, vous pouvez décocher l’entrée Browser ► py et, si vous voulez retirer votre répertoire utilisateur de l’explorateur, vous pouvez décocher l’entrée Browser ► special:Home.

Un filtre (filterMap Filtrer l’explorateur) peut être utilisé pour effectuer une recherche sur les éléments visibles (les entrées fichier et les entrées de nœud dans la hiérarchie). En utilisant les options Options du menu déroulement, vous pouvez

  • Basculer vers une recherche Sensible à la casse

  • Mettre la syntaxe du filtre sur

    • Normal

    • Joker(s)

    • Expression régulière

L outil des propriétés affichant des informations utiles sur certaines entrées / ressources, peut être activé / désactivé à l’aide du metadata Activer/désactiver le bouton des propriétés. Quand il est activé, cela ouvre en bas du panneau d’exploration ce que l’on peut voir ici Fig. 8.2.

../../../_images/browser_p_properties_w.png

Fig. 8.2 L’outil propriétés

Un deuxième panneau explorateur peut être ouvert en activant le panneau Explorateur(2) dans Vue ► Panneaux. Avoir deux panneaux d’exploration peut être utile pour copier des couches entre deux ressources localisées dans différentes branches de la hiérarchie de l’explorateur.

8.1. Ressources qui peuvent être ouvertes / lancées depuis l’explorateur.

Beaucoup peuvent être utilisées dans le panneau explorateur

  • Ajouter des couches vecteur, raster ou maillées dans votre carte en double cliquant, glissant dans le canevas de la carte ou en cliquant sur le bouton addLayer Ajouter les couches sélectionnées (après avoir sélectionné les couches).

  • Lancer les scripts Python (incluant les traitements algorithmiques) en double cliquant ou glissant dans le canevas de la carte.

  • Lancer les modèles en double cliquant ou glissant dans le canevas de la carte

  • Extraire les symboles… des fichiers du projet QGIS en utilisant le menu contextuel

  • Ouvrir des fichiers avec leur application par défaut (Ouvrir <file type> avec une application externe… dans le menu contextuel). Exemples : fichiers HTML, classeurs, images, PDF, fichiers texte…

  • Copier les entrées

  • Rename and delete (multiple) layers (context menu: Manage ►)

  • Open a file explorer window and directly select the file Show in Files

Les actions spécifiques aux ressources sont répertoriées pour les différents groupes de ressources triés sous les entrées de premier niveau énumérées ci-dessous.

8.2. Entrées de haut niveau du panneau navigateur

8.2.1. Marque-pages

Les emplacements des systèmes de fichier souvent utilisés peuvent être marqués comme marque-pages. Ceux que vous avez marqués apparaîtront ici.

En plus des opérations décrites sous Accueil, le menu contextuel vous permet de Renommer le marque-page… et Supprimer le marque-page.

8.2.2. Signets spatiaux

C’est là que vous trouverez vos signets spatiaux, organisés en signet de projet et signet d’utilisateur.

Dans le menu du haut, vous pouvez créer un signet (Nouveau signet spatial…), Afficher le gestionnaire de signets spatiaux, Importer des signets spatiaux… et Exporter les signets spatiaux….

Pour les entrées de signet, vous pouvez Zoomer sur le signet, modifier le signet spatial… et supprimer le signet spatial.

8.2.3. Project Home

Available once the project file has been saved, the Project home entry is a folder containing data and other contents (scripts, models, text, …) that may be used within the current project. Displayed in the Browser panel, it allows you to quickly access data and other files of the project.

It defaults to the project file folder but can be changed through the Project ► Properties… ► General ► Project home option, or by right-clicking on the Project Home item of the Browser panel and selecting Set project home…. Customizing that folder is especially useful in contexts where QGIS projects are not stored in the root folder of an organisational “project”, along with datasets.

8.2.4. Drives and file system

The next items of the Browser panel depend on the OS in use and concern the top level entries of its file system.

They are mainly:

  • The Home folder, pointing to the current user home folder

  • on Unix-based machines, the root / folder

  • the connected drives, either local or network. Depending on the OS, they are directly listed (eg, C:\, D:\) or through the /Volumes entry.

From the contextual menu of each of these folders or drives, you can:

  • refresh the contents

  • create a New ► subitem that is a Directory, GeoPackage or ESRI Shapefile format dataset

  • cacher le répertoire (masquer depuis le navigateur)

  • Set color: customize the folder icon color, aiding in rapid browser navigation of complex folder structures

  • enable Scanning:

    • checkbox Monitor for changes: allows to manually control whether a particular directory should be monitored and automatically updated. This setting applies to the selected directory and all subdirectories. This means that you can manually opt-in to monitoring of network drives if you know there’s no issue, or manually opt-out of monitoring of large directories which you don’t want monitored for other reasons. By default, remote or network drives are not automatically monitored.

    • unchecked Fast scan this directory

  • open the directory in your file manager (Open Directory…)

  • open the directory in a terminal window (Open in Terminal…)

  • inspect the Properties… or the parent Directory Properties…

8.2.5. Database entries

Depending on your OS and installed drivers, you might have access to different database types to use in QGIS. Below are listed the different entries of contextual menu at each level of the dataset tree.

Level

Context menu

Type of database

geoPackage GeoPackage

spatialite SpatiaLite

postgis PostGIS

hana SAP HANA

mssql MSSQL

oracle Oracle

Top menu

Create a New Connection… to an existing database

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Create Database…

checkbox

checkbox

Save Connections… details to a file

checkbox

checkbox

checkbox

Load Connections…

checkbox

checkbox

checkbox

Connection / Database

Refresh a connection

checkbox

checkbox

checkbox

Edit Connection… settings

checkbox

checkbox

checkbox

Delete Connection

checkbox

checkbox

checkbox

checkbox

checkbox

Delete <database_name>

checkbox

checkbox

Compact Database (VACUUM)

checkbox

Create a New Schema…

checkbox

checkbox

checkbox

Create a New Table…

checkbox

checkbox

checkbox

checkbox

Execute SQL… query

checkbox

checkbox

checkbox

checkbox

Schema

Refresh a schema

checkbox

checkbox

checkbox

Schema Operations ► Rename Schema…

checkbox

checkbox

checkbox

Schema Operations ► Delete Schema…

checkbox

checkbox

checkbox

Create a New Table…

checkbox

checkbox

Execute SQL… query

checkbox

checkbox

Table / Layer

Table Operations ► Rename Table…

checkbox

checkbox

checkbox

Table Operations ► Truncate Table…

checkbox

checkbox

Execute SQL… query

checkbox

checkbox

checkbox

Export Layer ► To file…

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Rename Layer <layer_name>…

checkbox

checkbox

Manage ► Delete Layer <layer_name>…

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Delete Selected Layers

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Add Layer to Project

checkbox

checkbox

checkbox

checkbox

checkbox

Manage ► Add Selected Layers to Project

checkbox

checkbox

checkbox

checkbox

checkbox

Open Layer Properties… dialog

checkbox

checkbox

checkbox

checkbox

checkbox

Open File Properties… dialog

checkbox

Fields

Add New Field…

checkbox

checkbox

checkbox

checkbox

Field

Delete Field…

checkbox

checkbox

checkbox

checkbox

8.2.6. Tiles and Web Services

Level

Context menu

Type of services

wms WMS / WMTS

vectorTileLayer Vector Tiles

xyz XYZ Tiles

wcs WCS

wfs WFS / OGC API - Features

afs ArcGIS REST Servers

geonode GeoNode

Top menu

Create a New Connection…

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Create a New Generic Connection…

checkbox

Create a New ArcGIS Vector Tile Service Connection…

checkbox

Save Connections… details to a file

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Load Connections…

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Connection

Refresh connection

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Edit… connection settings

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Delete connection

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

View Service Info in Web browser

checkbox

Table / Layer

Export Layer ► To File…

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Add layer to Project

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

Open Layer properties… dialog

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

checkbox

View Service Info in Web browser

checkbox

8.3. Resources

  • Dossiers du projet. Le menu contextuel des fichiers de projet QGIS vous permet de

    • l’ouvrir (Ouvrir le projet)

    • extraire des symboles (Extraire les Symboles…) - ouvre le gestionnaire de style qui vous permet d’exporter des symboles vers un fichier XML, d’ajouter des symboles au style par défaut ou d’exporter au format PNG ou SVG.

    • inspecter les propriétés (Proprietes fichier…)

    Vous pouvez développer le fichier de projet pour voir ses couches. Le menu contextuel d’une couche offre les mêmes actions qu’ailleurs dans l’explorateur.

  • Fichiers de définition de couche QGIS (QLR). Les actions suivantes sont disponibles dans le menu contextuel :

    • l’exporter (Exporter couche ► Vers le fichier)

    • l’ajouter au projet (Ajouter la couche au projet)

    • inspecter les propriétés (Proprietes couche…)

  • Modèles de traitement (.model3). Les actions suivantes sont disponibles dans le menu contextuel:

    • Lancer Modele…)

    • Editer le Modele…)

  • Modèles de mise en page QGIS (QPT). L’action suivante est disponible dans le menu contextuel :

    • (Nouvelle mise en page depuis le Template)

  • Scripts Python (.py). Les actions suivantes sont disponibles dans le menu contextuel :

    • (Executer le script…)

    • (Ouvrir dans editeur (externe))

  • Formats rasters reconnus. Les actions suivantes sont disponibles dans le menu contextuel :

    • le supprimer (Supprimer le fichier <dataset name>`)

    • l’exporter (Exporter couche ► Vers le fichier)

    • l’ajouter au projet (Ajouter la couche au projet)

    • inspecter les propriétés (Proprietes couche…, Proprietes fichier…)

    Pour certains formats, vous pouvez aussi Ouvrir <file type> une application externe…

  • Formats vectoriels reconnus. Les actions suivantes sont disponibles dans le menu contextuel :

    • le supprimer (Supprimer le fichier <dataset name>`)

    • l’exporter (Exporter couche ► Vers le fichier)

    • l’ajouter au projet (Ajouter la couche au projet)

    • inspecter les propriétés (Proprietes couche…, Proprietes fichier…)

    Pour certains formats, vous pouvez aussi Ouvrir <file type> une application externe…