Interface de QGIS

Lorsque QGIS démarre, une interface graphique s’affiche comme indiqué dans la figure ci-dessous (les chiffres 1 à 5 dans les cercles jaunes sont présentés ci-dessous).

../../../_images/startup.png

Interface de QGIS avec les données d’exemple sur l’Alaska

Note

Le style des fenêtres peut apparaître différemment en fonction de votre système d’exploitation et de votre gestionnaire de fenêtres.

L’interface de QGIS est divisée en 5 parties:

  1. Barre de Menu
  2. Barres d’outils
  3. Panneaux
  4. Affichage de la carte
  5. Barre d’état

Faites défiler vers le bas pour obtenir des explications détaillées de ces fonctions.

Panneaux et barres d’outils

Depuis le menu Vue” (ou |kde| :menuselection:`préférences), vous pouvez activer et désactiver les widgets QGIS (Panneaux‣) et barres d’outils (Barres d’outils‣). Pour (dé)activer l’un d’entre eux, cliquez avec le bouton droit de la souris sur la barre de menu ou la barre d’outils et choisissez l’élément que vous voulez. Chaque panneau ou barre d’outils peut être déplacé et placé où vous le souhaitez dans l’interface QGIS. La liste peut également être étendue avec l’activation d’extensions de :ref:`cœur ou externes <plugins> `.

Barres d’outils

La barre d’outils permet d’accéder à la plupart des mêmes fonctions que les menus, ainsi qu’à des outils supplémentaires pour interagir avec la carte. Chaque élément de la barre d’outils dispose d’une aide contextuelle. Passez votre souris sur l’élément et une courte description de l’objectif de l’outil s’affichera.

Chaque barre d’outils peut être déplacée selon vos besoins. Vous pouvez les désactiver à partir du menu contextuel qui s’affiche d’un clic droit de la souris sur la barre d’outils.

../../../_images/toolbars1.png

Le menu Barres d’outils

Astuce

Restaurer des barres d’outils

Si vous avez accidentellement masqué une barre d’outils, vous pouvez la retrouver via le menu Vue ‣ Barres d’outils ‣ (ou kde Préférences ‣ Barres d’outils ‣). Si, pour une raison ou une autre, une barre d’outils (ou n’importe quel autre élément d’interface) disparaît complètement de l’interface, vous trouverez des conseils pour la retrouver dans Restaurer facilement l’IHM initiale de QGIS.

Panneaux

Outre les barres d’outils, QGIS dispose de plusieurs panneaux; les panneaux sont des widgets spéciaux qui vous permettent des interactions (sélection d’options, cases à cocher, saisie de champs…) afin d’exécuter des tâches plus complexes.

../../../_images/panels.png

Le menu Panneaux

Les panneaux disponibles par défaut dans QGIS sont listés ci-après:

Affichage de la carte

Encore appelé Canevas de carte, c’est la partie centrale de QGIS puisque les cartes y sont affichées ! Le contenu qui s’affiche dépend des couches de types raster et vecteur que vous avez choisies de charger.

Lorsque vous ajoutez une couche (voir par exemple Ouverture des données), QGIS recherche automatiquement son Système de Coordonnées de Référence (SCR) et zoome le projet sur l’étendue de la couche si aucune autre couche n’est présente. Le SCR de la couche est alors appliquée au projet. Si d’autres couches étaient déjà affichées, et dans l’hypothèse où la nouvelle couche est dans le même SCR que le projet, ses entités disponibles dans l’étendue courante de la carte sont alors visibles. Si le SCR de la nouvelle couche est différente, vous devrez Autoriser la transformation à la volée du SCR via le menu Projet ‣ Propriétés du Projet ‣ SCR (voir On The Fly (OTF) CRS Transformation). La couche ajoutée devrait maintenant être visible dans l’étendue courante si entités disponibles.

L’emprise de la carte peut être modifiée en portant le focus sur une autre région, ou en zoomant en avant ou en arrière. Plusieurs opérations peuvent être effectuées sur la carte à l’aide des Barres d’outils. La carte et la légende du panneau Couche sont étroitement liées — la carte reflète les changements que vous opérez dans la légende.

Astuce

Zoomer sur la carte avec la molette de la souris

Vous pouvez utiliser la molette de la souris pour changer le niveau de zoom de la carte. Placez votre curseur dans la zone d’affichage de la carte et faites rouler la molette vers l’avant pour augmenter l’échelle, vers vous pour la réduire. La vue sera recentrée sur la position du curseur de la souris. Vous pouvez modifier le comportement de la molette de la souris en utilisant l’onglet Outils cartographiques dans le menu Préférences ‣ Options.

Astuce

Se déplacer sur la carte avec les flèches et la barre espace

Vous pouvez utiliser les flèches du clavier pour vous déplacer sur la carte. Placez le curseur sur la carte et appuyez sur la flèche droite pour décaler la vue vers l’Est, la flèche gauche pour la décaler vers l’Ouest, la flèche supérieure vers le Nord et la flèche inférieure vers le Sud. Vous pouvez aussi déplacer la carte en gardant la touche espace appuyée et en bougeant la souris ou encore simplement en gardant la molette de la souris appuyée.

Vue 3D

Le support de visualisation 3D est disponible par la vue cartographique 3D.

Note

La visualisation 3D dans QGIS nécessite une version récente de la bibliothèque QT (5.8 ou ultérieure).

Vous créez et ouvrez une vue cartographique 3D via Vue ‣ new3DMap Nouvelle vue cartographique 3D. Un panneau QGIS flottant apparaîtra. Le panneau peut être ancré.

Pour commencer, la vue cartographique 3D a la même étendue et la même vue que le canevas 2D. Il n’y a pas de barre d’outils dédiée à la navigation dans le canevas 3D. Vous effectuez un zoom avant/arrière et un panoramique de la même manière que dans le canevas 2D principal. Vous pouvez également effectuer un zoom avant et arrière en faisant glisser la souris vers le bas/haut avec le bouton droit de la souris.

Options de navigation pour explorer la carte en 3D :

  • Inclinaison et rotation
    • To tilt the terrain (rotating it around a horizontal axis that goes through the center of the window):
      • Déplacez la souris vers l’avant/vers l’arrière avec le bouton central de la souris enfoncé.
      • Appuyez sur Shift et faites glisser la souris en avant/en arrière avec le bouton gauche de la souris enfoncé.
      • Appuyez sur Shift et utilisez les touches haut/bas.
    • Pour faire pivoter le terrain (autour d’un axe vertical qui passe par le centre de la fenêtre) :
      • Faites glisser la souris droite/gauche avec le bouton central de la souris enfoncé.
      • Appuyez sur Shift et faites glisser la souris droite/gauche avec le bouton gauche de la souris enfoncé.
      • Appuyez sur Shift et utilisez les touches gauche/droite
  • Modifier l’angle de la caméra
    • Appuyer sur Ctrl et faire glisser la souris avec le bouton gauche appuyé change l’angle de la caméra dans le sens correspondant au sens du déplacement.
    • Appuyez sur :kbd:`Ctrl`et utilisez les touches flèches pour tourner la caméra dans le sens monter, descendre, aller à gauche ou à droite.
  • Déplacer la caméra vers le haut/bas
    • Appuyer sur les touches Page Up/Page Down déplace le terrain vers le haut et le bas, respectivement
  • Zoom avant et arrière
    • Glisser la souris avec le bouton droit de la souris enfoncé permet de zoomer (glisser vers le bas) et de dézoomer (glisser vers le haut).
  • Déplacer le terrain
    • Glisser la souris avec le bouton gauche de la souris enfoncé permet de déplacer le terrain.
    • L’utilisation des touches haut/bas/gauche/droite déplace le terrain plus près, plus loin, à droite et à gauche respectivement.

Pour réinitialiser la vue de la caméra, cliquez sur le bouton zoomFullExtent Zoom Full situé en haut de la vue cartographique 3D.

Configuration du terrain

Un raster terrain fournit l’élévation. Cette couche raster doit contenir une bande qui représente l’élévation. Pour sélectionner le raster terrain :

  1. Cliquez sur le bouton 3dconfigure Configurer… en haut du panneau de la vue 3D pour ouvrir la fenêtre 3D configuration.
  2. Choisissez la couche raster de terrain dans le menu déroulant Elevation.

Dans la fenêtre de configuration 3D, il existe plusieurs autres options pour affiner la scène 3D. Avant d’entrer dans les détails, il convient de noter que le terrain dans une vue 3D est représenté par une hiérarchie de tuiles de terrain et que lorsque la caméra se rapproche du terrain, les tuiles existantes qui ne sont pas suffisamment détaillées sont remplacées par des tuiles plus petites et plus détaillées. Chaque tuile a une géométrie de maillage dérivée de la couche raster d’élévation et de la texture des couches 2D.

Options de configuration et leur signification :

  • Elevation : Raster à utiliser pour la génération du terrain.
  • Echelle verticale : Facteur d’échelle pour l’axe vertical. Augmenter l’échelle exagérera le relief.
  • Résolution des tuiles : quantité de données de couche raster terrain à utiliser pour chaque tuile. Une valeur de 16px signifie que la géométrie de chaque dalle sera construite à partir d’échantillons d’élévation 16x16. Des nombres plus élevés créent des tuiles de terrain plus détaillées au détriment d’une complexité de rendu accrue.
  • Hauteur de la jupe : Parfois, il est possible de voir de petites fissures entre les tuiles du terrain. En augmentant cette valeur, on ajoutera des murs verticaux (« jupes ») autour des tuiles du terrain pour masquer les fissures.
  • Résolution de la tuile de carte: Largeur et hauteur des images cartographiques 2D utilisées comme textures pour les tuiles terrain. 256px signifie que chaque tuile sera rendue en une image de 256x256 pixels. Des nombres plus élevés créent des tuiles de terrain plus détaillées au détriment d’une complexité de rendu accrue.
  • Max. erreur d’écran : Détermine le seuil d’échange des tuiles de terrain avec des tuiles plus détaillées (et vice versa) - c’est-à-dire le moment où la vue 3D utilisera des tuiles de meilleure qualité. Des nombres plus bas signifient plus de détails dans la scène au détriment d’une complexité de rendu accrue.
  • Max. erreur de terrain : Résolution des tuiles du terrain à laquelle la division des tuiles en tuiles plus détaillées s’arrêtera (les diviser n’introduirait de toute façon aucun détail supplémentaire). Cette valeur limite la profondeur de la hiérarchie des tuiles : des valeurs inférieures rendent la hiérarchie plus profonde, augmentant la complexité du rendu.
  • Étiquettes Zoom : Affiche le nombre de niveaux de zoom (dépend de la résolution de la tuile de carte et de l’erreur de terrain maximale).
  • unchecked Afficher les étiquettes : Activer/désactiver les étiquettes de carte
  • unchecked Afficher l’information de la tuile de carte : Inclure les numéros de bordure et de tuile pour les tuiles de terrain (utile pour le dépannage des problèmes de terrain)
  • unchecked Afficher les zones d’emprise : Afficher les cases de délimitation 3D des tuiles du terrain (utile pour le dépannage des problèmes de terrain)
  • unchecked Montrer le centre de la vue de la caméra.

Couches vectorielles 3D

Une couche vectorielle avec des valeurs d’élévation peut être affichée dans la vue 3D de la carte en cochant Activer le rendu 3D dans la section Vue 3D des propriétés de la couche vectorielle. Un certain nombre d’options sont disponibles pour contrôler le rendu de la couche vectorielle 3D.

Barre d’état

La barre d’état vous fournit des informations générales sur le visualiseur de carte et les actions traitées ou disponibles, et vous offre des outils pour gérer le visualiseur de carte.

Sur le côté gauche de la barre d’état, la barre de localisation, un widget de recherche rapide, vous aide à trouver et à exécuter toutes les fonctions ou options du QGIS. Tapez simplement le texte associé à l’élément que vous recherchez (nom, tag, mot-clé…) et vous obtenez une liste qui se met à jour au fur et à mesure que vous écrivez. Vous pouvez également limiter la portée de la recherche en utilisant les filtres de localisation. Cliquez sur le bouton search pour sélectionner l’un d’entre eux et appuyez sur Configurer pour avoir les paramètres globaux.

Dans la zone située à côté de la barre de localisation, un résumé des actions que vous avez effectuées s’affichera si nécessaire (comme la sélection d’entités dans un calque, la suppression d’un calque) ou une description longue de l’outil sur lequel vous passez la souris (non disponible pour l’ensemble des outils).

En cas d’opérations de longue durée, telles que la collecte de statistiques de couches raster, l’exécution d’algorithmes de traitement ou le rendu de plusieurs couches dans la vue de carte, une barre de progression est affichée dans la barre d’état.

L’option tracking Coordonnées affiche la position actuelle de la souris, en suivant les déplacements sur la carte. Vous pouvez définir les unités (et la précision) dans le menu Projet ‣ Propriétés…. ‣ Onglet Général. Cliquez sur le petit bouton à gauche de la zone de texte pour basculer entre l’option Coordonnées et l’option extents Emprise qui affiche les coordonnées des coins inférieur gauche et supérieur droit actuels de la vue de carte en unités cartographiques.

A côté de l’affichage des coordonnées se trouve l’affichage Echelle. Il montre l’échelle de la carte. Il y a un sélecteur qui vous permet de choisir des échelles prédéfinies et personnalisées.

Sur le côté droit de l’affichage de l’échelle, appuyez sur la touche lockedGray pour verrouiller l’échelle et utiliser la loupe pour effectuer un zoom avant ou arrière. La loupe vous permet de zoomer sur une carte sans modifier l’échelle de la carte, ce qui facilite l’ajustement précis de la position des étiquettes et des symboles. Le niveau d’agrandissement est exprimé en pourcentage. Si le la loupe a un niveau de 100%, alors la carte courante n’est pas agrandie. De plus, une valeur d’agrandissement par défaut peut être définie dans le menu préférences ‣ Options ‣ Options ‣ Rendu‣ Comportement de rendu, ce qui est très utile pour les écrans haute résolution pour agrandir les petits symboles.

À droite de la loupe, vous pouvez définir un angle de rotation horaire en degrés à appliquer à la carte.

Sur le côté droit de la barre d’état, il y a une petite case à cocher qui peut être utilisée temporairement pour empêcher le rendu des couches dans le Visualisateur de carte (voir section Rendu).

A droite des fonctions de rendu, vous trouvez le bouton projectionEnabled code EPSG montrant le SCR du projet courant. Cliquer sur ce bouton ouvre la boîte de dialogue Propriétés du projet et vous permet d’appliquer un autre SCR.

Le bouton messageLog Messages situé à côté ouvre le journal des messages qui contient des informations sur les processus sous-jacents (démarrage QGIS, chargement des plugins, outils de traitement…).

Selon les paramètres du gestionnaire d’extensions Plugin Manager, la barre d’état peut parfois afficher des icônes à droite pour vous informer de la disponibilité de nouvelles extensions pluginNew ou de mises à jour pluginUpgrade. Cliquez sur l’icône pour ouvrir la boîte de dialogue du gestionnaire d’extensions.

Astuce

Calculer l’échelle correcte de la carte

Lorsque vous démarrez QGIS, le SCR par défaut est WGS 84 (EPSG 4326) et les unités sont des degrés. Cela signifie que QGIS interprétera n’importe quelle coordonnée dans votre couche comme étant en degrés. Pour obtenir des valeurs d’échelle correctes, vous pouvez soit modifier manuellement ce paramètre dans l’onglet General dans le menu Projet ‣ Propriétés… (par exemple pour des mètres), soit utiliser l’icône projectionEnabled code EPSG vue ci-dessus. Dans ce dernier cas, les unités sont réglées sur ce que spécifie la projection du projet (par exemple, +units=m).

Merci de prendre note que le choix du SCR au démarrage peut être configuré dans Préférences ‣ Options ‣ SCR.