Docs in progress for ‘QGIS testing’. Visit https://docs.qgis.org/2.18 for QGIS 2.18 docs and translations.

QGIS GUI

When QGIS starts, a GUI displays as shown in the figure below (the numbers 1 through 5 in yellow circles are discussed below).

../../../_images/startup.png

QGIS GUI with Alaska sample data

Note

Your window decorations (title bar, etc.) may appear different depending on your operating system and window manager.

The QGIS GUI is divided into five components:

  1. Menu Bar
  2. Toolbars
  3. Panels
  4. Map View
  5. Status Bar

Scroll down for detailed explanations of these features.

Panels and Toolbars

From the View menu (or kde Settings), you can switch QGIS widgets (Panels ‣) and toolbars (Toolbars ‣) on and off. To (de)activate any of them, right-click the menu bar or toolbar and choose the item you want. Each panel or toolbar can be moved and placed wherever you feel comfortable within the QGIS interface. The list can also be extended with the activation of Core or external plugins.

Toolbars

The toolbar provides access to most of the same functions as the menus, plus additional tools for interacting with the map. Each toolbar item has pop-up help available. Hover your mouse over the item and a short description of the tool’s purpose will be displayed.

Every toolbar can be moved around according to your needs. Additionally, they can be switched off using the right mouse button context menu, or by holding the mouse over the toolbars.

../../../_images/toolbars1.png

The Toolbars menu

Tip

Restoring toolbars

If you have accidentally hidden a toolbar, you can get it back by choosing menu option View ‣ Toolbars ‣ (or kde Settings ‣ Toolbars ‣). If for some reason a toolbar (or any other widget) totally disappears from the interface, you’ll find tips to get it back at restoring initial GUI.

Panels

Besides toolbars, QGIS provides many panels to work with by default. Panels are special widgets that you can interact with (selecting options, checking boxes, filling values…) to perform more complex tasks.

../../../_images/panels.png

The Panels menu

Below are listed default panels provided by QGIS:

Map View

Also called Map canvas, this is the “business end” of QGIS — maps are displayed in this area. The map displayed in this window will depend on the vector and raster layers you have chosen to load.

When you add a layer (see e.g. Opening Data), QGIS automatically looks for its Coordinate Reference System (CRS) and zooms to its extent if you start with a blank QGIS project. The layer’s CRS is then applied to the project. If there are already layers in the project, and if the new layer has the same CRS as the project, its features falling in the current map canvas extent will be visualized. If the new layer is in a different CRS from the project’s, you must Enable on-the-fly CRS transformation from the Project ‣ Properties… ‣ CRS (see Define On The Fly (OTF) CRS Transformation). The added layer should now be visible if data are available in the current view extent.

The map view can be panned, shifting the display to another region of the map, and it can be zoomed in and out. Various other operations can be performed on the map as described in the Toolbars section. The map view and the legend are tightly bound to each other — the maps in the view reflect changes you make in the legend area.

Tip

Zooming the Map with the Mouse Wheel

You can use the mouse wheel to zoom in and out on the map. Place the mouse cursor inside the map area and roll the wheel forward (away from you) to zoom in and backwards (towards you) to zoom out. The zoom is centered on the mouse cursor position. You can customize the behavior of the mouse wheel zoom using the Map tools tab under the Settings ‣ Options menu.

Tip

Panning the Map with the Arrow Keys and Space Bar

You can use the arrow keys to pan the map. Place the mouse cursor inside the map area and click on the arrow keys to pan left, right, up and down. You can also pan the map by moving the mouse while holding down the space bar or the middle mouse button (or holding down the mouse wheel).

3D Map View

3D visualization support is offered through the 3D map view.

Note

3D visualization in QGIS requires a recent version of the QT library (5.8 or later).

You create and open a 3D map view via View ‣ new3DMap New 3D Map View. A floating QGIS panel will appear. The panel can be docked.

To begin with, the 3D map view has the same extent and view as the 2D canvas. There is no dedicated toolbar for navigation in the 3D canvas. You zoom in/out and pan in the same way as in the main 2D canvas. You can also zoom in and out by dragging the mouse down/up with the right mouse button pressed.

Navigation options for exploring the map in 3D:

  • Tilt and rotate
    • To tilt the terrain (rotating it around a horizonal axis that goes through the center of the window):
      • Drag the mouse forward/backward with the middle mouse button pressed
      • Press Shift and drag the mouse forward/backward with the left mouse button pressed
      • Press Shift and use the up/down keys
    • To rotate the terrain (around a vertical axis that goes through the center of the window):
      • Drag the mouse right/left with the middle mouse button pressed
      • Press Shift and drag the mouse right/left with the left mouse button pressed
      • Press Shift and use the left/right keys
  • Change the camera angle
    • Pressing Ctrl and dragging the mouse with the left mouse button pressed changes the camera angle corresponding to directions of dragging
    • Pressing Ctrl and using the arrow keys turns the camera up, down, left and right
  • Move the camera up/down
    • Pressing the Page Up/Page Down keys moves the terrain up and down, respectively
  • Zoom in and out
    • Dragging the mouse with the right mouse button pressed will zoom in (drag down) and out (drag up)
  • Move the terrain around
    • Dragging the mouse with the left mouse button pressed moves the terrain around
    • Using the up/down/left/right keys moves the terrain closer, away, right and left, respectively

To reset the camera view, click the zoomFullExtent Zoom Full button on the top of the 3D canvas panel.

Terrain Configuration

A terrain raster provides the elevation. This raster layer must contain a band that represents elevation. To select the terrain raster:

  1. Click the 3dconfigure Configure… button at the top of the 3D canvas panel to open the 3D configuration window
  2. Choose the terrain raster layer in the Elevation pull-down menu

In the 3D Configuration window there are various other options to fine-tune the 3D scene. Before diving into the details, it is worth noting that terrain in a 3D view is represented by a hierarchy of terrain tiles and as the camera moves closer to the terrain, existing tiles that do not have sufficient detail are replaced by smaller tiles with more details. Each tile has mesh geometry derived from the elevation raster layer and texture from 2D map layers.

Configuration options and their meaning:

  • Elevation: Raster to be used for generation of terrain.
  • Vertical scale: Scale factor for vertical axis. Increasing the scale will exaggerate the terrain.
  • Tile resolution: How many samples from the terrain raster layer to use for each tile. A value of 16px means that the geometry of each tile will be built from 16x16 elevation samples. Higher numbers create more detailed terrain tiles at the expense of increased rendering complexity.
  • Skirt height: Sometimes it is possible to see small cracks between tiles of the terrain. Raising this value will add vertical walls (“skirts”) around terrain tiles to hide the cracks.
  • Map tile resolution: Width and height of the 2D map images used as textures for the terrain tiles. 256px means that each tile will be rendered into an image of 256x256 pixels. Higher numbers create more detailed terrain tiles at the expense of increased rendering complexity.
  • Max. screen error: Determines the threshold for swapping terrain tiles with more detailed ones (and vice versa) - i.e. how soon the 3D view will use higher quality tiles. Lower numbers mean more details in the scene at the expense of increased rendering complexity.
  • Max. ground error: The resolution of the terrain tiles at which dividing tiles into more detailed ones will stop (splitting them would not introduce any extra detail anyway). This value limits the depth of the hierarchy of tiles: lower values make the hierarchy deep, increasing rendering complexity.
  • Zoom labels: Shows the number of zoom levels (depends on the map tile resolution and max. ground error).
  • unchecked Show labels: Toggles map labels on/off
  • unchecked Show map tile info: Include border and tile numbers for the terrain tiles (useful for troubleshooting terrain issues)
  • unchecked Show bounding boxes: Show 3D bounding boxes of the terrain tiles (useful for troubleshooting terrain issues)
  • unchecked Show camera’s view center

3D vector layers

A vector layer with elevation values can be shown in the 3D map view by checking Enable 3D Renderer in the 3D View section of the vector layer properties. A number of options are available for controlling the rendering of the 3D vector layer.

Status Bar

The status bar provides you with general information about the map view and processed or available actions, and offers you tools to manage the map view.

On the left side of the status bar, the locator bar, a quick search widget, helps you find and run any feature or options in QGIS. Simply type text associated with the item you are looking for (name, tag, keyword…) and you get a list that updates as you write. You can also limit the search scope using locator filters. Click the search button to select any of them and press the Configure entry for global settings.

In the area next to the locator bar, a summary of actions you’ve carried out will be shown when needed (such as selecting features in a layer, removing layer) or a long description of the tool you are hovering over (not available for all tools).

In case of lengthy operations, such as gathering of statistics in raster layers, executing Processing algorithms or rendering several layers in the map view, a progress bar is displayed in the status bar.

The tracking Coordinate option shows the current position of the mouse, following it while moving across the map view. You can set the units (and precision) in the Project ‣ Properties… ‣ General tab. Click on the small button at the left of the textbox to toggle between the Coordinate option and the extents Extents option that displays the coordinates of the current bottom-left and top-right corners of the map view in map units.

Next to the coordinate display you will find the Scale display. It shows the scale of the map view. There is a scale selector, which allows you to choose between predefined and custom scales.

On the right side of the scale display, press the lockedGray button to lock the scale to use the magnifier to zoom in or out. The magnifier allows you to zoom in to a map without altering the map scale, making it easier to tweak the positions of labels and symbols accurately. The magnification level is expressed as a percentage. If the Magnifier has a level of 100%, then the current map is not magnified. Additionally, a default magnification value can be defined within Settings ‣ Options ‣ Rendering ‣ Rendering behavior, which is very useful for high-resolution screens to enlarge small symbols.

To the right of the magnifier tool you can define a current clockwise rotation for your map view in degrees.

On the right side of the status bar, there is a small checkbox which can be used temporarily to prevent layers being rendered to the map view (see section Rendering).

To the right of the render functions, you find the projectionEnabled EPSG:code button showing the current project CRS. Clicking on this opens the Project Properties dialog and lets you apply another CRS to the map view.

The messageLog Messages button next to it opens the Log Messages Panel which has information on underlying processes (QGIS startup, plugins loading, processing tools…)

Depending on the Plugin Manager settings, the status bar can sometimes show icons to the right to inform you about availability of pluginNew new or pluginUpgrade upgradeable plugins. Click the icon to open the Plugin Manager dialog.

Tip

Calculating the Correct Scale of Your Map Canvas

When you start QGIS, the default CRS is WGS 84 (EPSG 4326) and units are degrees. This means that QGIS will interpret any coordinate in your layer as specified in degrees. To get correct scale values, you can either manually change this setting in the General tab under Project ‣ Properties… (e.g. to meters), or you can use the projectionEnabled EPSG:code icon seen above. In the latter case, the units are set to what the project projection specifies (e.g., +units=us-ft).

Note that CRS choice on startup can be set in Settings ‣ Options ‣ CRS.