QGIS GUI

The QGIS graphical user interface (GUI) is shown in the figure below (the numbers 1 through 5 in yellow circles indicate important elements of the QGIS GUI, and are discussed below).

../../../_images/startup.png

QGIS GUI with Alaska sample data

Note

Your window decorations (title bar, etc.) may appear different depending on your operating system and window manager.

The main QGIS GUI (QGIS GUI with Alaska sample data) consists of five components / component types:

  1. Menu Bar

  2. Toolbars

  3. Panels

  4. Map View

  5. Status Bar

Scroll down for detailed explanations of these.

Panels and Toolbars

From the View menu (or kde Settings), you can switch QGIS widgets (Panels ‣) and toolbars (Toolbars ‣) on and off. To (de)activate any of them, right-click the menu bar or toolbar and choose the item you want. Panels and toolbars can be moved and placed wherever you like within the QGIS interface. The list can also be extended with the activation of Core or external plugins.

Toolbars

The toolbars provide access to most of the functions in the menus, plus additional tools for interacting with the map. Each toolbar item has pop-up help available. Hover your mouse over the item and a short description of the tool’s purpose will be displayed.

Every toolbar can be moved around according to your needs. Additionally, they can be switched off using the right mouse button context menu, or by holding the mouse over the toolbars.

../../../_images/toolbars1.png

The Toolbars menu

Tip

Restoring toolbars

If you have accidentally hidden a toolbar, you can get it back using View ‣ Toolbars ‣ (or kde Settings ‣ Toolbars ‣). If, for some reason, a toolbar (or any other widget) totally disappears from the interface, you’ll find tips to get it back at restoring initial GUI.

Panels

QGIS provides many panels. Panels are special widgets that you can interact with (selecting options, checking boxes, filling values…) to perform more complex tasks.

../../../_images/panels.png

The Panels menu

Below is a list of the default panels provided by QGIS:

Map View

Exploring the map view

The map view (also called Map canvas) is the “business end” of QGIS — maps are displayed in this area. The map displayed in this window will reflect the rendering (symbology, labeling, visibilities…) you applied to the layers you have loaded. It also depends on the layers and the project’s Coordinate Reference System (CRS).

When you add a layer (see e.g. Opening Data), QGIS automatically looks for its CRS. If a different CRS is set by default for the project (see Project Coordinate Reference Systems) then the layer extent is “on-the-fly” translated to that CRS, and the map view is zoomed to that extent if you start with a blank QGIS project. If there are already layers in the project, no map canvas resize is performed, so only features falling within the current map canvas extent will be visible.

The map view can be panned, shifting the display to another region of the map, and it can be zoomed in and out. Various other operations can be performed on the map as described in the Toolbars section. The map view and the legend are tightly bound to each other — the maps in the view reflect changes you make in the legend area.

Tip

Zooming the Map with the Mouse Wheel

You can use the mouse wheel to zoom in and out on the map. Place the mouse cursor inside the map area and roll the wheel forward (away from you) to zoom in and backwards (towards you) to zoom out. The zoom is centered on the mouse cursor position. You can customize the behavior of the mouse wheel zoom using the Map tools tab under the Settings ‣ Options menu.

Tip

Panning the Map with the Arrow Keys and Space Bar

You can use the arrow keys to pan the map. Place the mouse cursor inside the map area and click on the arrow keys to pan left, right, up and down. You can also pan the map by moving the mouse while holding down the space bar or the middle mouse button (or holding down the mouse wheel).

Exporting the map view

Maps you make can be layout and exported to various formats using the advanced capabilities of the print layout or report. It’s also possible to directly export the current rendering, without a layout. This quick “screenshot” of the map view has some convenient features.

To export the map canvas with the current rendering:

  1. Go to Project ‣ Import/Export

  2. Depending on your output format, select either

    • saveMapAsImage Export Map to Image…

    • or saveAsPDF Export Map to PDF…

The two tools provide you with a common set of options. In the dialog that opens:

../../../_images/saveMapAsImage.png

The Save Map as Image dialog

  1. Choose the Extent to export: it can be the current view extent (the default), the extent of a layer or a custom extent drawn over the map canvas. Coordinates of the selected area are displayed and manually editable.

  2. Enter the Scale of the map or select it from the predefined scales: changing the scale will resize the extent to export (from the center).

  3. Set the Resolution of the output

  4. Control the Output width and Output height in pixels of the image: based by default on the current resolution and extent, they can be customized and will resize the map extent (from the center). The size ratio can be locked, which may be particularly convenient when drawing the extent on the canvas.

  5. checkbox Draw active decorations: in use decorations (scale bar, title, grid, north arrow…) are exported with the map

  6. checkbox Draw annotations to export any annotation

  7. checkbox Append georeference information (embedded or via world file): depending on the output format, a world file of the same name (with extension PNGW for PNG images, JPGW for JPG, …) is saved in the same folder as your image. The PDF format embeds the information in the PDF file.

  8. When exporting to PDF, more options are available in the Save map as PDF… dialog:

    ../../../_images/saveMapAsPDF.png

    The Save Map as PDF dialog

    • checkbox Export RDF metadata of the document such as the title, author, date, description…

    • unchecked Create Geospatial PDF (GeoPDF): Generate a georeferenced PDF file (requires GDAL version 3 or later). You can:

      • Choose the GeoPDF Format

      • checkbox Include vector feature information in the GeoPDF file: will include all the geometry and attribute information from features visible within the map in the output GeoPDF file.

      Note

      Since QGIS 3.10, with GDAL 3 a GeoPDF file can also be used as a data source. For more on GeoPDF support in QGIS, see https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/.

    • Rasterize map

    • checkbox Simplify geometries to reduce output file size: Geometries will be simplified while exporting the map by removing vertices that are not discernably different at the export resolution (e.g. if the export resolution is 300 dpi, vertices that are less than 1/600 inch apart will be removed). This can reduce the size and complexity of the export file (very large files can fail to load in other applications).

    • Set the Text export: controls whether text labels are exported as proper text objects (Always export texts as text objects) or as paths only (Always export texts as paths). If they are exported as text objects then they can be edited in external applications (e.g. Inkscape) as normal text. BUT the side effect is that the rendering quality is decreased, AND there are issues with rendering when certain text settings like buffers are in place. That’s why exporting as paths is recommended.

  9. Click Save to select file location, name and format.

    When exporting to image, it’s also possible to Copy to clipboard the expected result of the above settings and paste the map in another application such as LibreOffice, GIMP…

3D Map View

3D visualization support is offered through the 3D map view.

Note

3D visualization in QGIS requires a recent version of the QT library (5.8 or later).

You create and open a 3D map view via View ‣ new3DMap New 3D Map View. A floating QGIS panel will appear. The panel can be docked.

To begin with, the 3D map view has the same extent and view as the 2D canvas. There is no dedicated toolbar for navigation in the 3D canvas. You zoom in/out and pan in the same way as in the main 2D canvas. You can also zoom in and out by dragging the mouse down/up with the right mouse button pressed.

Navigation options for exploring the map in 3D:

  • Tilt and rotate

    • To tilt the terrain (rotating it around a horizontal axis that goes through the center of the window):

      • Drag the mouse forward/backward with the middle mouse button pressed

      • Press Shift and drag the mouse forward/backward with the left mouse button pressed

      • Press Shift and use the up/down keys

    • To rotate the terrain (around a vertical axis that goes through the center of the window):

      • Drag the mouse right/left with the middle mouse button pressed

      • Press Shift and drag the mouse right/left with the left mouse button pressed

      • Press Shift and use the left/right keys

  • Change the camera angle

    • Pressing Ctrl and dragging the mouse with the left mouse button pressed changes the camera angle corresponding to directions of dragging

    • Pressing Ctrl and using the arrow keys turns the camera up, down, left and right

  • Move the camera up/down

    • Pressing the Page Up/Page Down keys moves the terrain up and down, respectively

  • Zoom in and out

    • Dragging the mouse with the right mouse button pressed will zoom in (drag down) and out (drag up)

  • Move the terrain around

    • Dragging the mouse with the left mouse button pressed moves the terrain around

    • Using the up/down/left/right keys moves the terrain closer, away, right and left, respectively

To reset the camera view, click the zoomFullExtent Zoom Full button on the top of the 3D canvas panel.

Scene Configuration

The 3D map view opens with some default settings you can customize. To do so, click the options Configure… button at the top of the 3D canvas panel to open the 3D configuration window.

../../../_images/3dmapconfiguration.png

The 3D Map Configuration dialog

In the 3D Configuration window there are various options to fine-tune the 3D scene:

  • Camera’s Field of view: allowing to create panoramic scenes. Default value is 45°.

  • Terrain: Before diving into the details, it is worth noting that terrain in a 3D view is represented by a hierarchy of terrain tiles and as the camera moves closer to the terrain, existing tiles that do not have sufficient details are replaced by smaller tiles with more details. Each tile has mesh geometry derived from the elevation raster layer and texture from 2D map layers.

    • Type: It can be Flat terrain, DEM (Raster Layer) or Online.

    • Elevation: Raster layer to be used for generation of the terrain. This layer must contain a band that represents elevation.

    • Vertical scale: Scale factor for vertical axis. Increasing the scale will exaggerate the height of the landforms.

    • Tile resolution: How many samples from the terrain raster layer to use for each tile. A value of 16px means that the geometry of each tile will consist of 16x16 elevation samples. Higher numbers create more detailed terrain tiles at the expense of increased rendering complexity.

    • Skirt height: Sometimes it is possible to see small cracks between tiles of the terrain. Raising this value will add vertical walls (“skirts”) around terrain tiles to hide the cracks.

    • Map theme: Allows you to select the set of layers to display in the map view from predefined map themes.

  • unchecked Terrain shading: Allows you to choose how the terrain should be rendered:

    • Shading disabled - terrain color is determined only from map texture

    • Shading enabled - terrain color is determined using Phong’s shading model, taking into account map texture, the terrain normal vector, scene light(s) and the terrain material’s Ambient and Specular colors and Shininess

  • Lights: You can add up to eight point lights, each with a particular position (in X, Y and Z), Color, Intensity and Attenuation.

    ../../../_images/3dmapconfiguration_lights.png

    The 3D Map Lights Configuration dialog

  • Map tile resolution: Width and height of the 2D map images used as textures for the terrain tiles. 256px means that each tile will be rendered into an image of 256x256 pixels. Higher numbers create more detailed terrain tiles at the expense of increased rendering complexity.

  • Max. screen error: Determines the threshold for swapping terrain tiles with more detailed ones (and vice versa) - i.e. how soon the 3D view will use higher quality tiles. Lower numbers mean more details in the scene at the expense of increased rendering complexity.

  • Max. ground error: The resolution of the terrain tiles at which dividing tiles into more detailed ones will stop (splitting them would not introduce any extra detail anyway). This value limits the depth of the hierarchy of tiles: lower values make the hierarchy deep, increasing rendering complexity.

  • Zoom labels: Shows the number of zoom levels (depends on the map tile resolution and max. ground error).

  • unchecked Show labels: Toggles map labels on/off

  • unchecked Show map tile info: Include border and tile numbers for the terrain tiles (useful for troubleshooting terrain issues)

  • unchecked Show bounding boxes: Show 3D bounding boxes of the terrain tiles (useful for troubleshooting terrain issues)

  • unchecked Show camera’s view center

3D vector layers

A vector layer with elevation values can be shown in the 3D map view by checking Enable 3D Renderer in the 3D View section of the vector layer properties. A number of options are available for controlling the rendering of the 3D vector layer.

Status Bar

The status bar provides you with general information about the map view and processed or available actions, and offers you tools to manage the map view.

On the left side of the status bar, the locator bar, a quick search widget, helps you find and run any feature or options in QGIS. Simply type text associated with the item you are looking for (name, tag, keyword…) and you get a list that updates as you write. You can also limit the search scope using locator filters. Click the search button to select any of them and press the Configure entry for global settings.

In the area next to the locator bar, a summary of actions you’ve carried out will be shown when needed (such as selecting features in a layer, removing layer) or a long description of the tool you are hovering over (not available for all tools).

In case of lengthy operations, such as gathering of statistics in raster layers, executing Processing algorithms or rendering several layers in the map view, a progress bar is displayed in the status bar.

The tracking Coordinate option shows the current position of the mouse, following it while moving across the map view. You can set the units (and precision) in the Project ‣ Properties… ‣ General tab. Click on the small button at the left of the textbox to toggle between the Coordinate option and the extents Extents option that displays the coordinates of the current bottom-left and top-right corners of the map view in map units.

Next to the coordinate display you will find the Scale display. It shows the scale of the map view. There is a scale selector, which allows you to choose between predefined and custom scales.

On the right side of the scale display, press the lockedGray button to lock the scale to use the magnifier to zoom in or out. The magnifier allows you to zoom in to a map without altering the map scale, making it easier to tweak the positions of labels and symbols accurately. The magnification level is expressed as a percentage. If the Magnifier has a level of 100%, then the current map is not magnified. Additionally, a default magnification value can be defined within Settings ‣ Options ‣ Rendering ‣ Rendering behavior, which is very useful for high-resolution screens to enlarge small symbols.

To the right of the magnifier tool you can define a current clockwise rotation for your map view in degrees.

On the right side of the status bar, there is a small checkbox which can be used temporarily to prevent layers being rendered to the map view (see section Rendering).

To the right of the render functions, you find the projectionEnabled EPSG:code button showing the current project CRS. Clicking on this opens the Project Properties dialog and lets you apply another CRS to the map view.

The messageLog Messages button next to it opens the Log Messages Panel which has information on underlying processes (QGIS startup, plugins loading, processing tools…)

Depending on the Plugin Manager settings, the status bar can sometimes show icons to the right to inform you about availability of pluginNew new or pluginUpgrade upgradeable plugins. Click the icon to open the Plugin Manager dialog.

Tip

Calculating the Correct Scale of Your Map Canvas

When you start QGIS, the default CRS is WGS 84 (EPSG 4326) and units are degrees. This means that QGIS will interpret any coordinate in your layer as specified in degrees. To get correct scale values, you can either manually change this setting in the General tab under Project ‣ Properties… (e.g. to meters), or you can use the projectionEnabled EPSG:code icon seen above. In the latter case, the units are set to what the project projection specifies (e.g., +units=us-ft).

Note that CRS choice on startup can be set in Settings ‣ Options ‣ CRS.