19. Working with Point Clouds

19.1. Introduction to Point Clouds

What is A Point Cloud?

A point cloud is a three-dimensional image of a space made up of many individual of data points (up to billions, even trillions). Each of the points has an x, y and z coordinate. Depending on the capture method, point clouds usually also have additional attributes that came from the capture, such as color values or intensity. These attributes can be used, for instance, to display point clouds in different colors. In QGIS, a point cloud can be used to generate a three-dimensional image of the landscape (or of another space).

Supported Formats

QGIS supports the data formats Entwine Point Tile (EPT) and LAS/LAZ. To work with point clouds, QGIS always saves the data in EPT. EPT is a storage format that consists of several files stored in a common folder. To allow quick access to the data, EPT uses indexing. For more information on the EPT format, see entwine homepage

If the data is in LAS or LAZ format, QGIS will convert it to EPT when it is loaded for the first time. Depending on the size of the file, this may take some time. In this process, a subfolder is created in the folder in which the LAS/LAZ file is located according to the scheme ept_ + name_LAS/LAZ_file. If such a subfolder already exists, QGIS loads the EPT immediately (which leads to a reduced loading time).

Worth Knowing

In QGIS it is not (yet) possible to edit point clouds. If you want to manipulate your point cloud, you can use CloudCompare, an open source point cloud processing tool. Also the Point Data Abstraction Library (PDAL - similar to GDAL) offers you options to edit point clouds (PDAL is command line only).

Due to the large number of data points, it is not possible to display an attribute table of point clouds in QGIS. However, the identify Identify tool supports point clouds, so you can display all attributes, even of a single data point.

19.2. Point Clouds Properties

The Layer Properties dialog for a point cloud layer offers general settings for the layer and its rendering. It also provides information about the layer.

To access the Layer Properties dialog:

  • In the Layers panel, double-click the layer or right-click and select Properties… from the context menu;

  • Go to Layer ► Layer Properties… menu when the layer is selected.

The point cloud Layer Properties dialog provides the following sections:

metadata Information

system Source

symbology Symbology[1]

3d 3D View[1]

rendering Rendering

elevationscale Elevation[1]

editMetadata Metadata

basicStatistics Statistics

[1] Also available in the Layer styling panel

Note

Most of the properties of a point cloud layer can be saved to or loaded from a .qml file using the Style menu at the bottom of the properties dialog. More details at Save and Share Layer Properties

19.2.1. Information Properties

The metadata Information tab is read-only and represents an interesting place to quickly grab summarized information and metadata on the current layer. Provided information are:

  • General such as name in the project, source path, last save time and size, the used provider

  • Based on the provider of the layer: extent and number of points

  • The Coordinate Reference System: name, units, method, accuracy, reference (i.e. whether it’s static or dynamic)

  • Metadata delivered by the provider: creation date, version, data format, scale X/Y/Z, …

  • Picked from the editMetadata Metadata tab (where they can be edited): access, extents, links, contacts, history…

../../../_images/point_cloud_information.png

Fig. 19.1 Point cloud information tab

19.2.2. Source Properties

In the system Source tab you can see and edit basic information about the point cloud layer:

  • Settings: Set a Layer name different from the layer filename that will be used to identify the layer in the project (in the Layers Panel, with expressions, in print layout legend,…)

  • Assigned Coordinate Reference System (CRS): Here you can change the layer’s assigned Coordinate Reference System, selecting a recently used one in the drop-down list or clicking on setProjection set Projection Select CRS button (see Coordinate Reference System Selector). Use this process only if the CRS applied to the layer is a wrong one or if none was applied.

../../../_images/point_cloud_source.png

Fig. 19.2 Point cloud source tab

19.2.3. Symbology Properties

In the symbology Symbology tab the settings for the rendering of the point cloud are made. There are different options for rendering point clouds that can be selected using the drop-down menu at the top of the Symbology tab (see Fig. 19.3):

  • pointCloudExtent Extent Only: Only a bounding box of the extent of the data is displayed; the symbol can be changed with the Fill Symbols dialog by clicking in the line, clicking on the browserCollapse arrow at the end leads you to The color drop-down shortcut.

  • singlebandPseudocolor Attribute by Ramp: The data is drawn over a color gradient. See Attribute by Ramp Renderer

  • multibandColor RGB: Draw the data using red, green and blue color values. See RGB Renderer

  • paletted Classification: The data is drawn using different colors for different classes. See Classification Renderer

When a point cloud is loaded, QGIS follows a logic to select the best renderer:

  • if the dataset contains color information (red, green, blue attributes), the RGB renderer will be used

  • else if the dataset contains a Classification attribute, the classified renderer will be used

  • else it will fall back to rendering based on Z attribute

If you do not know the attributes of the point cloud, the basicStatistics Statistics tab provides a good overview of which attributes are contained in the point cloud and in which ranges the values are located.

../../../_images/point_cloud_symbology_overview.png

Fig. 19.3 Point cloud symbology tab

In the upper part of the Symbology tab, the settings of the different renderers can be found. In the lower part there are sections with which general settings for the entire layer can be made and which are the same for all renderers:

  • Under Point Symbol, the size and the unit (e.g. millimeters, pixels, inches) with which each data point is displayed can be set. Either Circle or Square can be selected as the style for the points.

  • In the Layer Rendering section you have the following options to modify the rendering of the layer:

    • Maximum error: Point clouds usually contains more points than are needed for the display. By this option you set how dense or sparse the display of the point cloud will be (this can also be understood as ‘maximum allowed gap between points’). If you set a large number (e.g. 5 mm), there will be visible gaps between points. Low value (e.g. 0.1 mm) could force rendering of unnecessary amount of points, making rendering slower (different units can be selected).

    • Opacity: You can make the underlying layer in the map canvas visible with this tool. Use the slider to adapt the visibility of your layer to your needs. You can also make a precise definition of the percentage of visibility in the menu beside the slider.

    • Blending mode: You can achieve special rendering effects with these tools. The pixels of your overlaying and underlying layers are mixed through the settings described in Blending Modes.

19.2.3.1. Attribute by Ramp Renderer

With singlebandPseudocolor Attribute by Ramp, the data can be displayed by numerical values over a color gradient. Such numerical values can be, for example, an existing intensity attribute or the Z-value. Depending on a minimum and a maximum value, the other values are spread to the color gradient via interpolation. The distinct values and their assignment to a certain color are called “color map” and are shown in the table. There are various setting options, which are described below the figure.

../../../_images/point_cloud_attribute_by_ramp.png

Fig. 19.4 Point cloud symbology tab: Attribute by Ramp

  • Min and Max define the range that is applied to the color ramp: the Min value represents the left, the Max value the right end of the color ramp, the values in between are interpolated. By default QGIS detects the minimum and the maximum from the selected attribute but they can be modified. Once you have changed the values, you can restore the defaults by clicking on the Load button.

  • The Interpolation entry defines how values are assigned their color:

    • Discrete (a <= symbol appears in the header of the Value column): The color is taken from the closest color map entry with equal or higher value

    • Linear The color is linearly interpolated from the color map entries above and below the pixel value, meaning that to each dataset value corresponds a unique color

    • Exact (a = symbol appears in the header of the Value column): Only pixels with value equal to a color map entry are applied a color; others are not rendered.

  • The Color ramp widget helps you select the color ramp to assign to the dataset. As usual with this widget, you can create a new one and edit or save the currently selected one.

  • The Label unit suffix adds a label after the value in the legend, and the Label precision controls the number of decimals to display.

The classification Mode helps you define how values are distributed across the classes:

  • Continuous: Classes number and color are fetched from the color ramp stops; limits values are set following stops distribution in the color ramp (you can find more information on stops in Setting a Color Ramp).

  • Equal interval: The number of classes is set by the Classes field at the end of the line; limits values are defined so that the classes all have the same magnitude.

The classes are determined automatically and shown in the color map table. But you can also edit these classes manually:

  • Double clicking in a Value in the table lets you modify the class value

  • Double clicking in the Color column opens the Color Selector widget, where you can select a color to apply for that value

  • Double clicking in the Label column to modify the label of the class

  • Right-clicking over selected rows in the color table shows a contextual menu to Change Color… and Change Opacity… for the selection

Below the table there are the options to restore the default classes with Classify or to manually symbologyAdd Add values or symbologyRemove Delete selected values from the table.

Since a customized color map can be very complex, there is also the option to fileOpen Load an existing color map or to fileSaveAs Save it for use in other layers (as a txt file).

If you have selected Linear for Interpolation, you can also configure:

  • checkbox Clip out of range values By default, the linear method assigns the first class (respectively the last class) color to values in the dataset that are lower than the set Min (respectively greater than the set Max) value. Check this setting if you do not want to render those values.

  • Legend settings, for display in the Layers panel and in the layout legend. More details at Customize Color Ramp Legend.

Customize Color Ramp Legend

Since the customization works the same way as with a raster layer, you can find information in the raster data chapter under Customize raster legend.

19.2.3.2. RGB Renderer

With the multibandColor RGB renderer, three selected attributes from the point cloud will be used as the red, green and blue component. If the attributes are named accordingly, QGIS selects them automatically and fetches Min and Max values for each band and scales the coloring accordingly. However, it is also possible to modify the values manually.

A Contrast enhancement method can be applied to the values: No Enhancement, Stretch to MinMax, Stretch and Clip to MinMax and Clip to MinMax

Note

The Contrast enhancement tool is still under development. If you have problems with it, you should use the default setting Stretch to MinMax.

../../../_images/point_cloud_rgb.png

Fig. 19.5 The point cloud RGB renderer

19.2.3.3. Classification Renderer

In the paletted Classification rendering, the point cloud is shown differentiated by color on the basis of an attribute. Any type of attribute can be used (numeric, string, …). Point cloud data often includes a field called Classification. This usually contains data determined automatically by post-processing, e.g. about vegetation. With Attribute you can select the field from the attribute table that will be used for the classification. By default, QGIS uses the definitions of the LAS specification (see table ‘ASPRS Standard Point Classes’ in the PDF on ASPRS home page). However, the data may deviate from this schema; in case of doubt, you have to ask the person or institution from which you received the data for the definitions.

../../../_images/point_cloud_classification.png

Fig. 19.6 The point cloud classification renderer

In the table all used values are displayed with the corresponding color and legend. At the beginning of each row there is a checkbox check box; if it is unchecked, this value is no longer shown on the map. With double click in the table, the Color, the Value and the Legend can be modified (for the color, the Color Selector widget opens).

Below the table there are buttons with which you can change the default classes generated by QGIS:

  • With the Classify button the data can be classified automatically: all values that occur in the attributes and are not yet present in the table are added

  • With symbologyAdd Add and symbologyRemove Delete, values can be added or removed manually

  • Delete All removes all values from the table

19.2.4. 3D View Properties

In the 3d 3D View tab you can make the settings for the rendering of the point cloud in 3D maps. Following options can be selected from the drop down menu at the top of the tab:

../../../_images/point_cloud_3d_view.png

Fig. 19.7 The point cloud 3D view tab with the classification renderer

In the lower part of the 3d 3D View tab you can find the Point Symbol section. Here you can make general settings for the entire layer which are the same for all renderers. There are the following options:

  • Point size: The size (in pixels) with which each data point is displayed can be set

  • Maximum screen space error: By this option you set how dense or sparse the display of the point cloud will be (in pixels). If you set a large number (e.g. 10), there will be visible gaps between points; low value (e.g. 0) could force rendering of unnecessary amount of points, making rendering slower (you can find more details at Symbology Maximum error).

  • Point budget: To avoid long rendering, you can set the maximum number of points that will be rendered

  • Point cloud size: For your information only, the total number of points is shown here

  • checkbox Show bounding boxes: Especially useful for debugging, shows bounding boxes of nodes in hierarchy

19.2.5. Rendering Properties

Under the Scale dependent visibility group box, you can set the Maximum (inclusive) and Minimum (exclusive) scale, defining a range of scale in which features will be visible. Out of this range, they are hidden. The mapIdentification Set to current canvas scale button helps you use the current map canvas scale as boundary of the range visibility. See Scale Dependent Rendering for more information.

../../../_images/point_cloud_rendering.png

Fig. 19.8 The point cloud rendering tab

19.2.6. Elevation Properties

In the elevationscale Elevation tab, you can set corrections for the Z-values of the data. This may be necessary to adjust the elevation of the data in 3D maps. There are two setting options:

  • You can set a Scale: If 10 is entered here, a point that has a value Z=``5`` is displayed at a height of 50.

  • An offset to the z-level can be entered. This is useful to match different data sources in its height to each other. By default, the lowest z-value contained in the data is used as this value. This value can also be restored with the refresh Refresh button at the end of the line.

../../../_images/point_cloud_elevation.png

Fig. 19.9 The point cloud elevation tab

19.2.7. Metadata Properties

The editMetadata Metadata tab provides you with options to create and edit a metadata report on your layer. See Metadata for more information.

19.2.8. Statistics Properties

In the basicStatistics Statistics tab you can get an overview of the attributes of your point cloud and their distribution.

At the top you will find the section Attribute Statistics. Here all attributes contained in the point cloud are listed, as well as some of their statistical values: Minimum, Maximum, Mean, Standard Deviation

If there is an attribute Classification, then there is another table in the lower section. Here all values contained in the attribute are listed, as well as their absolute Count and relative % abundance.

../../../_images/point_cloud_statistics.png

Fig. 19.10 The point cloud statistics tab