8. The Browser panel

The QGIS Browser panel is a great tool for browsing, searching, inspecting, copying and loading QGIS resources. Only resources that QGIS knows how to handle are shown in the browser.

Using the Browser panel you can locate, inspect and add data, as described in The Browser Panel. In addition, the Browser panel supports drag and drop of many QGIS resources, such as project files, processing scripts and processing models. Processing scripts and models can also be opened for editing in an external editor and the graphical modeller respectively.

You can drag and drop layers from the Layers panel to the Browser panel, for instance into a GeoPackage or a PostGIS database.

../../../_images/browser_panel1.png

Fig. 8.1 The Browser panel

The browser panel (Fig. 8.1) is organised as an expandable hierarchy with some fixed top-level entries that organise the resources handled by the browser. Node entries are expanded by clicking on browserExpand to the left of the entry name. A branch is collapsed by clicking on browserCollapse. The collapseTree Collapse All button collapses all top-level entries.

In Settings ‣ Interface Customization it is possible to disable resources. If you, for instance, would not like to show Python scripts in the browser, you can uncheck the Browser ‣ py entry, and if you want to get rid of your home folder in the browser, you can uncheck the Browser ‣ special:Home entry.

A filter (filterMap Filter Browser) can be used for searching based on entry names (both leaf entries and node entries in the hierarchy). Using the options Options pull-down menu next to the filter text field, you can

  • toggle Case Sensitive search

  • set the Filter pattern syntax to one of

    • Normal

    • Wildcard(s)

    • Regular Expressions

The Properties widget, showing useful information about some entries / resources, can be enabled / disabled using the metadata Enable/disable properties widget button. When enabled, it opens at the bottom of the browser panel, as shown in Fig. 8.2.

../../../_images/browser_p_properties_w.png

Fig. 8.2 The properties widget

A second browser panels can be opened by activating the Browser (2) panel in View ‣ Panels. Having two browser panels can be useful when copying layers between resources that are locationed deep down in different branches of the browser hierarcy.

8.1. Resources that can be opened / run from the Browser

A lot can be accomplished in the Browser panel

  • Add vector, raster and mesh layers to your map by double-clicking, dragging onto the map canvas or clicking the addLayer Add Selected Layers button (after selecting layers)

  • Run Python scripts (including Processing algorithms) by double-clicking or dragging onto the map canvas

  • Run Models by double-clicking or dragging onto the map canvas

  • Extract Symbols… from QGIS Project files using the context menu

  • Open files with their default applications (Open <file type> Externally… in the context menu). Examples: HTML files, spreadsheets, images, PDFs, text files, …

  • Copy entries

Resource specific actions are listed for the different resource groups sorted under the top-level entries listed below.

8.2. Browser panel top-level entries

8.2.1. Favorites

Often used file system locations can be tagged as favorites. The ones you have tagged will appear here.

In addition to the operations described under Home, the context menu allows you to Rename Favorite… and Remove Favourite.

8.2.2. Spatial Bookmarks

This is where you will find your spatial bookmarks, organised into Project Bookmarks and User Bookmarks.

From the top level context menu, you can create a bookmark (New Spatial Bookmark…), Show the Spatial Bookmark Manager, Import Spatial Bookmarks… and Export Spatial Bookmarks…,

For bookmark entries you can Zoom to Bookmark, Edit Spatial Bookmark… and Delete Spatial Bookmark

8.2.3. Home

Your file system home directory / folder. By right-clicking on an entry, and choosing Add as a Favorite, the location will be added to Favorites. From the context menu, you can also

  • add a directory, Geopackage or ESRI Shapefile format dataset (Add)

  • hide the directory (Hide from Browser)

  • toggle Fast Scan this Directory

  • open the directory in your file manager (Open Directory)

  • open the directory in a terminal window (Open in Terminal)

  • inspect properties (Properties…, Directory Properties…)

8.2.4. /

Your file system root directory / folder.

8.2.5. Geopackage

Geopackage files / databases. From the top level context menu, you can create a Geopackage file / database (Create Database…) or add an existing Geopackage file / database (New Connection…).

The context menu of each Geopackage lets you remove it from the list (Remove connection…), add a new layer or table to the Geopackage (Create new Layer or Table…), delete the Geopackage (Delete <name of geopackage>) and Compact Database (VACUUM).

For layer/table entries you can

  • rename it (Rename Layer <layer name>…)

  • export it (Export Layer ‣ To file)

  • add it to the project Add Layer to Project

  • delete it (Delete Layer)

  • inspect properties (Layer Properties…, File Properties…)

8.2.6. SpatiaLite

SpatiaLite database connections.

From the top level context menu, you can create a SpatiaLite file / database (Create Database…) or add an existing SpatiaLite file / database (New Connection…).

The context menu of each SpatiaLite file lets you delete it (Delete).

For layer/table entries you can

  • export it (Export Layer ‣ To file)

  • add it to the project Add Layer to Project

  • delete it (Delete Layer)

  • inspect properties (Layer Properties…)

8.2.7. PostGIS

PostGIS database connections.

From the top level context menu, you can add a new connection (New Connection…).

The context menu of each connection lets you Refresh it, edit it Edit connection…, delete it (Delete connection) or Create Schema….

The context menu of each schema lets you Refresh, Rename Schema… or Delete Schema.

For layers/tables you can

  • rename it (Rename Table…)

  • remove its contents (Truncate Table…)

  • export it (Export Layer ‣ To file)

  • add it to the project (Add Layer to Project)

  • delete it (Delete Layer)

  • inspect its properties (Layer Properties…)

8.2.8. MSSQL

Microsoft SQL Server connections.

From the top level context menu, you can add a new connection (New Connection…).

The context menu of each connection lets you Refresh it, edit it Edit connection…, delete it (Delete connection) or Create Schema….

The context menu of each schema lets you Refresh, Rename Schema… or Delete Schema.

For layers/tables you can

  • rename it (Rename Table…)

  • remove its contents (Truncate Table…)

  • export it (Export Layer ‣ To file)

  • add it to the project (Add Layer to Project)

  • delete it (Delete Layer)

  • inspect its properties (Layer Properties…)

8.2.9. DB2

IBM DB2 database connections.

From the top level context menu, you can add a new connection (New Connection…).

The context menu of each connection lets you Refresh it, edit it Edit connection…, delete it (Delete connection) or Create Schema….

The context menu of each schema lets you Refresh, Rename Schema… or Delete Schema.

For layers/tables you can

  • rename it (Rename Table…)

  • remove its contents (Truncate Table…)

  • export it (Export Layer ‣ To file)

  • add it to the project (Add Layer to Project)

  • delete it (Delete Layer)

  • inspect its properties (Layer Properties…)

8.2.10. WMS/WMTS

Web Map Services (WMS) and Web Map Tile Services (WMTS)

From the top level context menu, you can add a new connection (New Connection…).

The context menu of each WSM/WMTS service lets you Refresh it, Edit… it and delete it (Delete).

Group layers can be added by dragging them onto the map canvas.

For WMS/WMTS layer entries you can

  • export it (Export Layer ‣ To file)

  • add it to the project (Add Layer to Project)

  • inspect properties (Layer Properties…)

8.2.11. Vector Tiles

Vector tile services

From the top level context menu, you add an existing service (New Connection…), and you can Save Connections… or Load Connections… to / from XML files.

8.2.12. XYZ Tiles

XYZ tile services

From the top level context menu, you add an existing service (New Connection…), and you can Save Connections… or Load Connections… to / from XML files.

For the XYZ tile service entries you can

  • edit it (Edit…)

  • delete it (Delete)

  • export it (Export Layer ‣ To file)

  • add it to the project Add Layer to Project

  • inspect properties (Layer Properties…)

8.2.13. WCS

Web Coverage Services

From the top level context menu, you can add a new connection (New Connection…).

The context menu of each WCS lets you Refresh it, Edit… it and delete it (Delete).

For WCS layer entries you can

  • export it (Export Layer ‣ To file)

  • add it to the project (Add Layer to Project)

  • inspect properties (Layer Properties…)

8.2.14. WFS / OGC API - Features

Web Feature Services (WFS) and OGC API - Features services (aka WFS3)

From the top level context menu, you can add a new connection (New Connection…).

The context menu of each WFS lets you Refresh it, Edit… it and delete it (Delete).

For WFS layer entries you can

  • export it (Export Layer ‣ To file)

  • add it to the project (Add Layer to Project)

  • inspect properties (Layer Properties…)

8.2.15. OWS

Here you will find a read-only list of all your Open Web Services (OWS) - WMS / WCS / WFS / …

8.2.16. ArcGIS Map Service

8.2.17. ArcGIS Features Service

8.2.18. GeoNode

From the top level context menu, you can add a new connection (New Connection…).

The context menu of each service lets you Refresh it, Edit… it and delete it (Delete).

For the service layer entries you can

  • export it (Export Layer ‣ To file)

  • add it to the project (Add Layer to Project)

  • inspect properties (Layer Properties…)

8.3. Resources

  • Project files. The context menu for QGIS project files allows you to:

    • open it (Open Project)

    • extract symbols (Extract Symbols…) - open the style manager that allows you to export symbols to an XML file, add symbols to the default style or export as PNG or SVG.

    • inspect properties (File Properties…)

    You can expand the project file to see its layers. The context menu of a layers offers the same actions as elsewhere in the browser.

  • QGIS Layer Definition files (QLR) The following actions are available from the context menu:

    • export it (Export Layer ‣ To file)

    • add it to the project (Add Layer to Project)

    • inspect properties (Layer Properties…)

  • QGIS Models (.model3) The following actions are available from the context menu:

    • Run Model…)

    • Edit Model…)

  • QGIS print composer templates (QPT) The following action is available from the context menu:

    • (New Layout from Template)

  • Python scripts (.py) The following actions are available from the context menu:

    • (Run script…)

    • (Open in External Editor)

  • Recognized raster formats. The following actions are available from the context menu:

    • delete it (Delete File <dataset name>)

    • export it (Export Layer ‣ To file)

    • add it to the project (Add Layer to Project)

    • inspect properties (Layer Properties…, File Properties…)

    For some formats you can also Open <file type> Externally…

  • Recognized vector formats. The following actions are available from the context menu:

    • delete it (Delete File <dataset name>)

    • export it (Export Layer ‣ To file)

    • add it to the project (Add Layer to Project)

    • inspect properties (Layer Properties…, File Properties…)

    For some formats you can also Open <file type> Externally…