Premiers Pas

Ce chapitre donne un bref aperçu de l’installation de QGIS, du téléchargement de quelques jeux de données QGIS et du lancement d’une première session d’affichage de couches rasters et vectorielles.

Installer QGIS

QGIS project provides different ways to install QGIS depending on your platform.

Installing from binaries

Standard installers are available for win MS Windows and osx macOS. Binary packages (rpm and deb) or software repositories are provided for many flavors of GNU/Linux nix.

Pour plus d’information et des instructions pour votre système d’exploitation, rendez vous sur https://qgis.org/fr/site/forusers/download.html.

Installation depuis les sources

Si vous souhaitez compiler QGIS à partir des sources, veuillez vous référer aux instructions d’installation. Elles sont distribuées avec le code source de QGIS dans un fichier appelé INSTALL. Vous pouvez aussi le trouver en ligne à https://htmlpreview.github.io/?https://raw.github.com/qgis/QGIS/master/doc/INSTALL.html.

If you want to build a particular release and not the version in development, you should replace master with the release branch (commonly in the release-X_Y form) in the above-mentioned link (installation instructions may differ).

Installation sur support externe

Il est possible d’installer QGIS (avec tous les plugins et paramètres) sur une clé USB. Ceci est réalisé en définissant l’option –profiles-path qui remplace l’option par défaut user profile et force aussi QSettings à utiliser ce répertoire . Voir la section :ref:`env_options`pour plus d’informations.

Téléchargement des données exemple

This user guide contains examples based on the QGIS sample dataset (also called the Alaska dataset).

win L’installateur Windows possède une option qui permet de télécharger le jeu de données échantillon de QGIS. Si vous la cochez, les données seront téléchargées dans votre répertoire intitulé Mes Documents et placées dans un répertoire GIS Database. Vous pouvez utiliser l’explorateur Windows pour choisir un autre répertoire de votre choix. Si vous ne cochez pas cette option durant l’installation QGIS, vous pouvez :

  • Utiliser des données que vous possédez déjà.
  • Télécharger des données exemples depuis https://qgis.org/downloads/data/qgis_sample_data.zip
  • Désinstaller et réinstaller QGIS en cochant, cette fois, la case de téléchargement (uniquement si les solutions proposées ci-dessus ne fonctionnent pas).

nix osx For GNU/Linux and macOS, there are no dataset installation packages available as rpm, deb or dmg. To use the sample dataset, download it from https://qgis.org/downloads/data/qgis_sample_data.zip and unzip the archive on any convenient location on your system.

Le jeu de données Alaska inclut toutes les données SIG qui sont utilisées dans les exemples et dans les copie d’écran du guide de l’utilisateur mais aussi dans une petite base de données GRASS. La projection du jeu de données à renseigner dans QGIS est Alaska Albers Equal Area avec comme unités le pied. Le code EPSG est 2964.

PROJCS["Albers Equal Area",
GEOGCS["NAD27",
DATUM["North_American_Datum_1927",
SPHEROID["Clarke 1866",6378206.4,294.978698213898,
AUTHORITY["EPSG","7008"]],
TOWGS84[-3,142,183,0,0,0,0],
AUTHORITY["EPSG","6267"]],
PRIMEM["Greenwich",0,
AUTHORITY["EPSG","8901"]],
UNIT["degree",0.0174532925199433,
AUTHORITY["EPSG","9108"]],
AUTHORITY["EPSG","4267"]],
PROJECTION["Albers_Conic_Equal_Area"],
PARAMETER["standard_parallel_1",55],
PARAMETER["standard_parallel_2",65],
PARAMETER["latitude_of_center",50],
PARAMETER["longitude_of_center",-154],
PARAMETER["false_easting",0],
PARAMETER["false_northing",0],
UNIT["us_survey_feet",0.3048006096012192]]

Si vous avez l’intention d’utiliser QGIS comme interface graphique pour GRASS, vous pouvez trouver des échantillons de données (par exemple, Spearfish ou South Dakota) sur le site officiel de GRASS GIS, https://grass.osgeo.org/download/sample-data/

Démarrer et arrêter QGIS

QGIS peut être démarré comme toute autre application sur votre ordinateur. Cela signifie que vous pouvez lancer QGIS par :

  • en utilisant nix le menu Applications s’il s’agit d’une version précompilée, win le menu Démarrer ou osx le Dock
  • en double-cliquant sur l’icône dans votre répertoire d’Applications ou sur un raccourci sur le bureau
  • en double-cliquant sur un fichier de projet QGIS (.qgs) existant. Notez que cela ouvrira le projet dans QGIS
  • en tapant qgis dans une console (en supposant que QGIS a été ajouté à votre PATH ou que vous êtes dans le répertoire d’installation)

Pour arrêter QGIS :

  • nix win cliquez sur le menu Projet ‣ Fermer QGIS ou utilisez le raccourci clavier Ctrl+Q
  • cliquez sur osx QGIS ‣ Quit QGIS ou utilisez le raccourci clavier Cmd+Q
  • ou utilisez la croix rouge située au coin supérieur droit de l’interface principale.

Exemple de session : Chargement de couches raster et vectorielles

Now that you have QGIS installed and a sample dataset available, we will demonstrate a first sample session. In this example, we will visualize a raster and a vector layer. We will use:

  • la couche raster landcover du fichier (qgis_sample_data/raster/landcover.img)
  • et la couche vectorielle lakes du fichier (qgis_sample_data/gml/lakes.gml)

Where qgis_sample_data represents the path to the unzipped dataset.

  1. Démarrer QGIS comme vu dans Démarrer et arrêter QGIS.

  2. To load the files in QGIS:

    1. Click on the dataSourceManager Open Data Source Manager icon. The Data Source Manager should open in Browser mode.

    2. Browse to the folder qgis_sample_data/raster/

    3. Select the ERDAS IMG file landcover.img and double-click it. The landcover layer is added in the background while the Data Source Manager window remains open.

      ../../../_images/add_raster.png

      Adding data to a new project in QGIS

    4. To load the lakes data, browse to the folder qgis_sample_data/gml/, and double-click the lakes.gml file to open it.

    5. A Coordinate Reference System Selector dialog opens. In the Filter menu, type 2964, filtering the list of Coordinate Reference Systems below.

      ../../../_images/selectCRS.png

      Select the Coordinate Reference System of data

    6. Select the NAD27 / Alaska Alberts entry

    7. Click OK

    8. Close the Data Source Manager window

You now have the two layers available in your project in some random colours. Let’s do some customization on the lakes layer.

  1. Select the zoomIn Zoom In tool on the Navigation toolbar

  2. Zoom to an area with some lakes

  3. Double-click the lakes layer in the map legend to open the Properties dialog

  4. To change the lakes color:

    1. Click on the symbology Symbology tab

    2. Select blue as fill color.

      ../../../_images/selectFillColor.png

      Selecting Lakes color

    3. Press OK. Lakes are now displayed in blue in the map canvas.

  5. To display the name of the lakes:

    1. Reopen the lakes layer Properties dialog

    2. Click on the labeling Labels tab

    3. Select Single labels in the drop-down menu to enable labeling.

    4. From the Label with list, choose the NAMES field.

      ../../../_images/showLabels.png

      Showing Lakes names

    5. Press Apply. Names will now load over the boundaries.

  6. You can improve readability of the labels by adding a white buffer around them:

    1. Click the Buffer tab in the list on the left
    2. Check checkbox Draw text buffer
    3. Choose 3 as buffer size
    4. Click Apply
    5. Check if the result looks good, and update the value if needed.
    6. Finally click OK to close the Layer Properties dialog and apply the changes.

Let’s now add some decorations in order to shape the map and export it out of QGIS:

  1. Select View ‣ Decorations ‣ Scale Bar menu
  2. In the dialog that opens, check checkbox Enable Scale Bar option
  3. Customize the options of the dialog as you want
  4. Press Apply
  5. Likewise, from the decorations menu, add more items (north arrow, copyright…) to the map canvas with custom properties.
  6. Click Project ‣ Import/Export ‣ saveMapAsImage Export Map to Image…
  7. Press Save in the opened dialog
  8. Select a file location, a format and confirm by pressing Save again.
  9. Press Project ‣ fileSave Save… to store your changes as a .qgz project file.

Vous pouvez constater combien il est facile d’afficher des couches raster ou vecteur dans QGIS, de les configurer et de générer votre carte dans un format image que vous pouvez utiliser dans d’autres logiciels. Poursuivons pour en savoir plus sur les fonctionnalités, les fonctions et les paramètres disponibles, ainsi que sur la façon de les utiliser.

Note

Pour continuer à apprendre QGIS à travers des exercices pas-à-pas, suivre le :ref`Manuel d’apprentissage<QGIS-training-manual-index-reference>`.