Der erste Einstieg

This chapter provides a quick overview of installing QGIS, downloading QGIS sample data, and running a first simple session visualizing raster and vector data.

Installing QGIS

Installing QGIS is easy. Standard installers are available for MS Windows win and MacOS osx. Binary packages (rpm and deb) or software repositories are provided for many flavors of GNU/Linux nix.

For more information and instructions for your operating system check https://download.qgis.org.

Installing from source

If you need to build QGIS from source, please refer to the installation instructions. They are distributed with the QGIS source code in a file called INSTALL. You can also find them online at https://htmlpreview.github.io/?https://raw.github.com/qgis/QGIS/master/doc/INSTALL.html.

If you want to build a particular release, you should replace master by the release branch (commonly in the release-X_Y form) in the above-mentioned link because instructions may differ.

Installing on external media

It is possible to install QGIS (with all plugins and settings) on a flash drive. This is achieved by defining a –profiles-path option that overrides the default user profile path and forces QSettings to use this directory, too. See section System Settings for additional information.

Downloading sample data

This user guide contains examples based on the QGIS sample dataset.

win The Windows installer has an option to download the QGIS sample dataset. If checked, the data will be downloaded to your Documents folder and placed in a folder called GIS Database. You may use Windows Explorer to move this folder to any convenient location. If you did not select the checkbox to install the sample dataset during the initial QGIS installation, you may do one of the following:

  • bereits auf Ihrem Rechner vorhandene GIS Daten verwenden
  • Download sample data from https://qgis.org/downloads/data/qgis_sample_data.zip
  • QGIS deinstallieren, wieder neu installieren und dabei die entsprechende Option auswählen, wenn die oben angesprochenen Optionen nicht funktionieren.

nix osx For GNU/Linux and macOS, there are no dataset installation packages available as rpm, deb or dmg. To use the sample dataset, download the file qgis_sample_data as a ZIP archive from https://qgis.org/downloads/data/ and unzip the archive on your system.

The Alaska dataset includes all GIS data that are used for the examples and screenshots in this user guide; it also includes a small GRASS database. The projection for the QGIS sample datasets is Alaska Albers Equal Area with units feet. The EPSG code is 2964.

PROJCS["Albers Equal Area",
GEOGCS["NAD27",
DATUM["North_American_Datum_1927",
SPHEROID["Clarke 1866",6378206.4,294.978698213898,
AUTHORITY["EPSG","7008"]],
TOWGS84[-3,142,183,0,0,0,0],
AUTHORITY["EPSG","6267"]],
PRIMEM["Greenwich",0,
AUTHORITY["EPSG","8901"]],
UNIT["degree",0.0174532925199433,
AUTHORITY["EPSG","9108"]],
AUTHORITY["EPSG","4267"]],
PROJECTION["Albers_Conic_Equal_Area"],
PARAMETER["standard_parallel_1",55],
PARAMETER["standard_parallel_2",65],
PARAMETER["latitude_of_center",50],
PARAMETER["longitude_of_center",-154],
PARAMETER["false_easting",0],
PARAMETER["false_northing",0],
UNIT["us_survey_feet",0.3048006096012192]]

If you intend to use QGIS as a graphical front end for GRASS, you can find a selection of sample locations (e.g., Spearfish or South Dakota) at the official GRASS GIS website, https://grass.osgeo.org/download/sample-data/.

Starting and stopping QGIS

QGIS can be started like any other application on your computer. This means that you can launch QGIS by:

  • using nix the Applications menu, win the Start menu, or osx the Dock
  • Doppelklicken Sie das QGIS Icon oder die Desktop Verknüpfung
  • double clicking an existing QGIS project file (with .qgz or .qgs extension). Note that this will also open the project.
  • typing qgis in a command prompt (assuming that QGIS is added to your PATH or you are in its installation folder)

To stop QGIS, use:

  • nix win die Menüoptionen Projekt ‣ QGIS beenden oder benutzen Sie das Tastenkürzel Strg+Q
  • osx QGIS ‣ QGIS beenden, oder benutzen Sie das Tastenkürzel Ctrl+Q
  • or use the red cross at the top-right corner of the main interface of the application.

Sample Session: Loading raster and vector layers

Now that you have QGIS installed and a sample dataset available, we will demonstrate a first sample session. In this example, we will visualize a raster and a vector layer. We will use:

  • the landcover raster layer (qgis_sample_data/raster/landcover.img)
  • and the lakes vector layer (qgis_sample_data/gml/lakes.gml)
  1. Start QGIS as seen in Starting and stopping QGIS.
  2. To load the landcover data, click on the dataSourceManager Open Data Source Manager icon.
  3. The Data Source Manager should open in Browser mode.
  4. Browse to the folder qgis_sample_data/raster/, select the ERDAS IMG file landcover.img and double-click to open it. (The landcover layer is added in the background while the Data Source Manager window remains open.)
  5. To load the lakes data, browse to the folder qgis_sample_data/gml/, and double-click on the file lakes.gml to open it. The Coordinate Reference System Selector dialog opens with NAD27 / Alaska Alberts selected, click OK.
  6. Close the Data Source Manager window.
  7. Zoom to your favorite area with some lakes.
  8. Doppelklicken Sie auf lakes in der Legende. Der Dialog Layereigenschaften öffnet sich.
  9. Click on the symbology Symbology tab and select blue as fill color.
  10. Click on the labeling Labels tab and select Single labels in the drop-down menu to enable labeling. Then from the Label with list, choose the NAMES field to label each lake with its name.
  11. To improve readability of labels, you can add a white buffer around them by clicking Buffer in the list on the left, checking checkbox Draw text buffer and choosing 3 as buffer size.
  12. Click Apply. Check if the result looks good, and finally click OK.
  13. Select View ‣ Decorations ‣ Scale Bar, and in the dialog that opens, check checkbox Enable Scale Bar and press Apply (you can customize some options of the dialog if you want).
  14. Likewise, from the decorations menu, add more items (north arrow, copyright…) to the map canvas
  15. Click Project ‣ Import/Export ‣ saveMapAsImage Export Map to Image… and press Save in the opened dialog. Select a file location, a format and confirm by pressing Save again.
  16. Use Project ‣ fileSave Save… to store your changes as a .qgz project file.

That’s it! You can see how easy it is to visualize raster and vector layers in QGIS, configure them and generate your map in an image format you can use in other softwares. Let’s move on to learn more about the available functionality, features and settings, and how to use them.

Introducing QGIS projects

The state of your QGIS session is called a project. QGIS works on one project at a time. Any settings can be project-specific or an application-wide default for new projects (see section Optionen). QGIS can save the state of your workspace into a project file using the menu options Project ‣ fileSave Save or Project ‣ fileSaveAs Save As….

Bemerkung

If the project you loaded has been modified in the meantime, by default, QGIS will ask you if you want to overwrite the changes. This behavior is controlled by the checkbox Prompt to save project and data source changes when required setting under Settings ‣ Options ‣ General menu.

You can load existing projects into QGIS using Project ‣ fileOpen Open…, Project ‣ New from template or Project ‣ Open Recent ‣.

At startup, a list of recently opened projects is displayed, including screenshots, names and file paths (for up to ten projects). This is a handy quick way to access recently used projects. Double-click an entry in this list to open the corresponding project. If you instead want to create a new project, just add any layer and the list disappears, giving way to the map canvas.

If you want to clear your session and start fresh, go to Project ‣ fileNew New. This will prompt you to save the existing project if changes have been made since it was opened or last saved.

The information saved in a project file includes:

  • Hinzugefügte Layer
  • Welche Layer können abgefragt werden
  • Layereigenschaften, inklusive Symbologie und Styles
  • Projektion für das Kartenfenster
  • Zuletzt gewählte Ausdehnung im Kartenfenster
  • Print layouts
  • Print layout elements with settings
  • Print layout atlas settings
  • Digitalisierungseinstellungen
  • Tabellen Beziehungen
  • Projekt Markos
  • Projekt Vorgabestile
  • Erweiterungseinstellungen
  • QGIS Server-Einstellungen von dem OWS Registerkarte in den Projekteigenschaften
  • Abfragen gespeichert im DB Manager

The project file is saved in XML format. This means that it is possible to edit the file outside of QGIS if you know what you are doing. The file format has been updated several times compared with earlier QGIS versions. Project files from older QGIS versions may not work properly any more.

Bemerkung

By default, QGIS will warn you of version differences. This behavior is controlled in Settings ‣ Options. On the General tab, you should tick checkbox Warn when opening a project file saved with an older version of QGIS.

Whenever you save a .qgs project in QGIS, a backup of the project file is created with the extension .qgs~ and stored in the same directory as the project file.

The extension for QGIS projects is .qgs but when saving from QGIS, the default is to save using a compressed format with the .qgz extension. The .qgs file is embedded in the .qgz file (a zip archive), together with its associated sqlite database (.qgd) for auxiliary data. You can get to these files by unzipping.

Bemerkung

A zipped project may be particularly useful with the Auxiliary Storage Properties mechanism in order to embed the underlying database.

Projects can also be saved/loaded to/from a PostgreSQL database using the following Project menu items:

  • Project ‣ Open from
  • Project ‣ Save to

Both menu items have a sub-menu with a list of extra project storage implementations (currently just PostgreSQL). Clicking the action will open a dialog to pick a PostgreSQL connection name, schema name and project.

Projects stored in PostgreSQL can be also loaded from the QGIS browser panel (the entries are located within the schema they are stored in), either by double-clicking them or by dragging them to the map canvas.

Generating output

There are several ways to generate output from your QGIS session. We have already discussed saving as a project file in Introducing QGIS projects. Other ways to produce output files are:

  • Creating images: Project ‣ Import/Export ‣ saveMapAsImage Export Map to Image… opens a file dialog where you select the name, path and type of image (PNG, JPG and many other formats). This will also create a world file (with extension PNGW or JPGW) that is saved in the same folder as your image. This world file is used to georeference the image.
  • Exporting to DXF files: Project ‣ Import/Export ‣ Export Project to DXF… opens a dialog where you can define the ‚Symbology mode‘, the ‚Symbology scale‘ and vector layers you want to export to DXF. Through the ‚Symbology mode‘ symbols from the original QGIS Symbology can be exported with high fidelity (see section Creating new DXF files).
  • Designing print maps: Project ‣ newLayout New Print Layout… opens a dialog where you can layout and print the current map canvas (see section Laying out the maps).