Utiliser les projections

A Coordinate Reference System, or CRS, is a method of associating numerical coordinates with a position on the surface of the Earth. QGIS has support for approximately 7,000 standard CRSs, each with different use cases, pros and cons! Choosing an appropriate reference system for your QGIS projects and data can be a complex task, but fortunately QGIS helps guide you through this choice, and makes working with different CRSs as transparent and accurate as possible.

Aperçu de la gestion des projections

QGIS has support for approximately 7,000 known CRSs. These standard CRSs are based on those defined by the European Petroleum Search Group (EPSG) and the Institut Geographique National de France (IGNF), and are made available in QGIS through the underlying « Proj » projection library. Commonly, these standard projections are identified through use of an authority:code combination, where the authority is an organisation name such as « EPSG » or « IGNF », and the code is a unique number associated with a specific CRS. For instance, the common WGS 84 latitude/longitude CRS is known by the identifier EPSG:4326, and the web mapping standard CRS is EPSG:3857.

Custom, user-created CRSs are stored in a user CRS database. See section Système de Coordonnées de Référence personnalisé for information on managing your custom coordinate reference systems.

Layer Coordinate Reference Systems

In order to correctly project data into a specific target CRS, either your data must contain information about its coordinate reference system or you will need to manually assign the correct CRS to the layer. For PostGIS layers, QGIS uses the spatial reference identifier that was specified when that PostGIS layer was created. For data supported by OGR or GDAL, QGIS relies on the presence of a recognized means of specifying the CRS. For instance, for the Shapefile format this is a file containing the Well-Known Text (WKT) representation of the layer’s CRS. This projection file has the same base name as the .shp file and a .prj extension. For example, alaska.shp would have a corresponding projection file named alaska.prj.

Whenever a layer is loaded into QGIS, QGIS attempts to automatically determine the correct CRS for that layer. In some cases this is not possible, e.g. when a layer has been provided without retaining this information. Whenever QGIS cannot automatically determine the correct CRS for a layer, it will prompt you to manually select the CRS. Selecting the correct choice is crucial, as a wrong choice will place your layer in the wrong position on the Earth’s surface! Sometimes, accompanying metadata will describe the correct CRS for a layer, in other cases you will need to contact the original author of the data to determine the correct CRS to use.

Project Coordinate Reference Systems

Every project in QGIS also has an associated Coordinate Reference System. The project CRS determines how data is projected from its underlying raw coordinates to the flat map rendered within your QGIS map canvas. Behind the scenes, QGIS transparently reprojects all layers contained within your project into the project’s CRS, so that they will all be rendered in the correct position with respect to each other!

It is important to make an appropriate choice of CRS for your QGIS projects. Choosing an inappropriate CRS can cause your maps to look distorted, and poorly reflect the real-world relative sizes and positions of features. Usually, while working in smaller geographic areas, there will be a number of standard CRSs used within a particular country or administrative area. It’s important to research which CRSs are appropriate or standard choices for the area you are mapping, and ensure that your QGIS project follows these standards.

The project CRS can be set through the CRS tab of the Project properties dialog (Project ‣ Properties…). It will also be shown in the lower-right of the QGIS status bar.

../../../_images/projectionDialog.png

Fenêtre Propriétés du projet

The CRS tab also has an optional setting for No projection. Checking this setting will disable ALL projection handling within the QGIS project, causing all layer and map coordinates to be treated as simple 2D Cartesian coordinates, with no relation to positions on the Earth’s surface.

Whenever you select a new CRS for your QGIS project, the measurement units will automatically be changed in the General tab of the Project properties dialog (Project ‣ Properties…) to match the selected CRS. For instance, some CRSs define their coordinates in feet instead of meters, so setting your QGIS project to one of these CRSs will also set your project to measure using feet by default.

CRS Settings

By default, QGIS starts each new project using a global default projection. This default CRS is EPSG:4326 (also known as « WGS 84 »), and it is a global latitude/longitude based reference system. This default CRS can be changed via the CRS for New Projects setting in the CRS tab under Settings ‣ options Options. There is an option to automatically set the project’s CRS to match the CRS of the first layer loaded into a new project, or alternatively you can select a different default CRS to use for all newly created projects. This choice will be saved for use in subsequent QGIS sessions.

../../../_images/crsdialog1.png

The CRS tab in the QGIS Options Dialog

When you use layers that do not have a CRS, you can define how QGIS responds to these layers. This can be done globally in the CRS tab under Settings ‣ options Options.

Les options montrées sur figure_projection_options sont :

  • radioButtonOn Demander le SCR
  • radioButtonOff Utiliser le SCR du projet
  • radioButtonOff Use a default CRS

If you want to define the Coordinate Reference System for a certain layer without CRS information, you can also do that in the Source tab of the raster and vector properties dialog (see Source Properties for rasters and Onglet Source for vectors). If your layer already has a CRS defined, it will be displayed as shown in Onglet Source de la fenêtre Propriétés de la couche vectorielle. Note that changing the CRS in this setting does not alter the underlying data source in any way, rather it just changes how QGIS interprets the raw coordinates from the layer in the current QGIS project only.

Astuce

SCR dans le Panneau Couches

Un clic-droit sur une couche dans la légende (section Le panneau Couches) propose deux raccourcis concernant les SCR: Définir le SCR de la couche ouvre directement la fenêtre de sélection de SCR (voir figure_projection_project) et Définir le SCR du projet depuis cette couche applique le SCR de la couche au projet.

On The Fly (OTF) CRS Transformation

QGIS supports « on the fly » CRS transformation for both raster and vector data. This means that regardless of the underlying CRS of particular map layers in your project, they will always be automatically transformed into the common CRS defined for your project.

Sélectionneur de système de coordonnées de référence

Cette fenêtre vous permet de choisir un Système de Coordonnées de Référence pour un projet ou une couche et propose un ensemble de systèmes de coordonnées. Cette fenêtre dispose des éléments suivants :

  • Filter: If you know the EPSG code, the identifier, or the name for a Coordinate Reference System, you can use the search feature to find it. Enter the EPSG code, the identifier or the name.
  • Systèmes de coordonnées de référence récemment utilisés : Si vous utilisez certains SCR fréquemment dans vos travaux quotidiens, ils seront affichés dans cette liste. Cliquez sur l’un d’entre eux pour sélectionner le SCR du projet.
  • Liste de tous les SCR : C’est une liste de tous les SCR gérés par QGIS, incluant les systèmes de coordonnées de référence géographiques, projetés et personnalisés. Pour utiliser un SCR, sélectionnez-le dans la liste en dépliant le nœud approprié et en choisissant le système de coordonnées. Le SCR actif est présélectionné.
  • PROJ text: This is the CRS string used by the PROJ projection engine. This text is read-only and provided for informational purposes.

The CRS selector also shows a rough preview of the geographic area for which a selected CRS is valid for use. Many CRSs are designed only for use in small geographic areas, and you should not use these outside of the area they were designed for. The preview map shades an approximate area of use whenever a CRS is selected from the list. In addition, this preview map also shows an indicator of the current main canvas map extent.

Système de Coordonnées de Référence personnalisé

Si QGIS ne fournit pas le système de coordonnées de référence dont vous avez besoin, vous pouvez en définir un. Pour cela, sélectionnez customProjection Projection personnalisée… à partir du menu Préférences. Les SCR personnalisés sont stockés dans votre base de données utilisateur de QGIS. En plus de ceux-ci, cette base de données contient également vos signets spatiaux et autres données personnalisées.

../../../_images/customProjectionDialog.png

Fenêtre de SCR personnalisé

Defining a custom CRS in QGIS requires a good understanding of the PROJ projection library. To begin, refer to « Cartographic Projection Procedures for the UNIX Environment - A User’s Manual » by Gerald I. Evenden, U.S. Geological Survey Open-File Report 90-284, 1990 (available at ftp://ftp.remotesensing.org/proj/OF90-284.pdf).

This manual describes the use of proj and related command line utilities. The cartographic parameters used with proj are described in the user manual and are the same as those used by QGIS.

La fenêtre Définir un système de coordonnées de référence personnalisé nécessite seulement deux paramètres pour définir un SCR personnalisé :

  1. Un nom descriptif
  2. The cartographic parameters in PROJ format

Pour créer un nouveau SCR, cliquez sur le bouton signPlus Ajouter un nouveau SRC et entrez un nom descriptif et les paramètres du SCR.

Remarquez que les Paramètres doivent débuter par un bloc +proj= pour représenter le nouveau système de coordonnées de référence.

Vous pouvez tester vos paramètres de SCR pour voir s’ils produisent des résultats valides. Entrez des latitude et longitude connues en WGS 84 dans les champs Nord et Est respectivement. Cliquez sur le bouton Calculer et comparez les résultats avec les valeurs connues dans votre système de coordonnées de référence.

Integrate an NTv2-transformation in QGIS

To integrate an NTv2 transformation file in QGIS you need one more step:

  1. Place the NTv2 file (.gsb) in the CRS/Proj folder that QGIS uses (e.g. C:\OSGeo4W64\share\proj for windows users)

  2. Add nadgrids (+nadgrids=nameofthefile.gsb) to the Proj definition in the Parameters field of the Custom Coordinate Reference System Definition (Settings ‣ Custom Projections…).

    ../../../_images/nadgrids_example.PNG

    Setting an NTv2 transformation

Datum Transformations

In QGIS, “on-the-fly” CRS transformation is enabled by default, meaning that whenever you use layers with different coordinate systems QGIS transparently reprojects them to the project CRS. For some CRS, there are a number of possible transforms available to reproject to the project’s CRS! QGIS optionally allows you to define a particular transformation to use, otherwise QGIS uses a default one.

Cette personnalisation s’effectue dans le menu Préférences ‣`|options| :guilabel:`Options ‣ SCR dans le groupe Transformatoins géodésiques (datum) par défaut :

  • en utilisant checkbox demander à choisir la transformation de datum si plusieurs sont disponibles : lorsqu’il existe plus d’une transformation de données appropriée pour une combinaison source/destination de SCR, une boîte de dialogue s’ouvre automatiquement invitant les utilisateurs à choisir laquelle de ces transformations de données doit être utilisée pour le projet ;

  • ou prédéfinir une liste des transformations pertinentes par défaut à utiliser lors du chargement de couche dans des projets ou de la reprojection d’une couche.

    Utilisez le bouton signPlus pour ouvrir le dialogue Sélectionner la transformation de datum. Alors :

    1. Indiquez le SCR Source de la couche, en utilisant le menu déroulant ou le widget setProjection Selectionner le SCR.

    2. De même, indiquez le SRC de destination.

    3. En fonction des fichiers de grille de transformation (basés sur la version GDAL et PROJ installée sur votre système), une liste des transformations disponibles de la source à la destination est construite dans le tableau. Cliquer sur une ligne permet d’afficher le détail des paramètres appliqués (code epsg, précision de la transformation, nombre de stations impliquées…).

      Vous pouvez choisir de n’afficher que les transformations valides actuelles en cochant l’option checkbox Masquer les obsolètes.

    4. Trouvez votre transformation préférée, sélectionnez-la et cliquez sur OK.

      Une nouvelle ligne est ajoutée au tableau sous SCR‣ Transformations géodésiques par défaut avec des informations sur “SCR d’origine” et “SCR de destination” ainsi que “Datum de transformation d’origine” et “Datum de transformation de destination”.

    Dès lors, QGIS utilise automatiquement la transformation de données sélectionnée pour les transformations ultérieures entre ces deux SCRs jusqu’à ce que vous signMinus la supprimiez de la liste ou toggleEditing la remplaciez par une autre.

../../../_images/datumTransformation.png

Sélection d’une transformation de datum par défaut

Datum transformations set in the Settings ‣ options Options –> CRS tab will be inherited by all new QGIS projects created on the system. Additionally, a particular project may have its own specific set of transformations specified via the CRS tab of the Project properties dialog (Project ‣ Properties…). These settings apply to the current project only.