Outdated version of the documentation. Find the latest one here.

QGIS GUI

When QGIS starts, you are presented with the GUI as shown in the figure (the numbers 1 through 5 in yellow circles are discussed below).

Figure QGIS GUI 1:

../../../_images/startup.png

QGIS GUI with Alaska sample data

Note

Your window decorations (title bar, etc.) may appear different depending on your operating system and window manager.

The QGIS GUI is divided into five areas:

  1. Menu Bar
  2. Toolbars
  3. Panels
  4. Map View
  5. Status Bar

These five components of the QGIS interface are described in more detail in the following sections. Two more sections present keyboard shortcuts and context help.

Panels and Toolbars

From the View menu (Settings under KDE), you can switch on and off QGIS widgets (Panels ‣) or toolbars (Toolbars ‣). You can (de)activate any of them by right-clicking the menu bar or a toolbar and choose the item you want. Each panel or toolbar can be moved and placed wherever you feel comfortable with in QGIS interface. The list can also be extended with the activation of Core or external plugins.

Toolbars

The toolbar provides access to most of the same functions as the menus, plus additional tools for interacting with the map. Each toolbar item has pop-up help available. Hold your mouse over the item and a short description of the tool’s purpose will be displayed.

Every toolbar can be moved around according to your needs. Additionally, they can be switched off using the right mouse button context menu, or by holding the mouse over the toolbars.

Figure Toolbars:

../../../_images/toolbars1.png

The Toolbars menu

Tip

Restoring toolbars

If you have accidentally hidden a toolbar, you can get it back by choosing menu option View ‣ Toolbars ‣ (or Settings ‣ Toolbars ‣ under Linux KDE). If for some reason a toolbar (or any other widget) totally disappears from the interface, you’ll find tips to get it back at restoring initial GUI.

Panels

QGIS provides by default many panels to work with.

Figure Panels:

../../../_images/panels.png

The Panels menu

Some of these panels are described below while others may be found in different parts of the document, namely:

Layers Panel

The layers panel lists all the layers in the project. The checkbox in each legend entry can be used to show or hide the layer. The toolbar in the layers panel allows you to:

  • addGroup Add new group
  • showPresets Manage Visibility: control visibility of layers and preset layers combination
  • filterMap Filter Legend by Map Content: only the layers that are set visible and whose features intersect the current map canvas have their style rendered in the layers panel. Otherwise, a generic NULL symbol is applied to the layer. Based on the layer symbology, this is a convenient way to identify which kind of features from which layers cover your area of interest.
  • expressionFilter Filter Legend by Expression: helps you apply an expression to remove from the selected layer tree styles that have no feature satisfying the condition. This can be used for example to highlight features that are within a given area/feature of another layer. From the drop-down list, you can edit and clear the expression set.
  • expandTree Expand All or collapseTree Collapse All layers and groups in the layers panel.
  • and removeLayer Remove Layer/Group currently selected.

Figure Layer tools Bar:

../../../_images/layer_toolbar.png

Layer Toolbar in Layers Panel

The button showPresets allows you to add Presets views in the legend. Presets are a way to save and easily restore a combination of layers with their current style. To add a preset view, just set visible the layers you want, with their desired symbology, and click on showPresets button. Choose Add Preset... from the drop-down menu and give a name to the preset. The added preset is listed at the bottom of the drop-down menu and is recalled by clicking on it.

The Replace Preset ‣ option helps you overwrite a preset content with the current map view while the Remove Current Preset button deletes the active preset.

All the added presets are also present in the map composer in order to allow you to create a map layout based on your specific views (see Main properties).

Note

Tools to manage the layers panel are also available to layout the map and legend items of the print composer

A layer can be selected and dragged up or down in the legend to change the Z-ordering. Z-ordering means that layers listed nearer the top of the legend are drawn over layers listed lower down in the legend.

Note

This behavior can be overridden by the Layer Order panel.

Layers in the legend window can be organized into groups. There are two ways to do this:

  1. Press the folder icon to add a new group. Type in a name for the group and press Enter. Now click on an existing layer and drag it onto the group.
  2. Select some layers, right click in the legend window and choose Group Selected. The selected layers will automatically be placed in a new group.

To bring a layer out of a group, you can drag it out, or right click on it and choose Make to toplevel item. Groups can also be nested inside other groups.

The checkbox for a group will show or hide all the layers in the group with one click.

The content of the right mouse button context menu depends on whether the selected legend item is a raster or a vector layer. For GRASS vector layers, toggleEditing Toggle editing is not available. See section Digitizing and editing a GRASS vector layer for information on editing GRASS vector layers.

Below are listed available options in context menu depending on the selected item.

Option Vector Layer Raster Layer Group
zoomToLayer Zoom to Layer/Group checkbox checkbox checkbox
unchecked Show in Overview checkbox checkbox
zoomActual Zoom to Native Resolution (100%) checkbox
Stretch Using Current Extent checkbox
removeLayer Remove checkbox checkbox checkbox
duplicateLayer Duplicate checkbox checkbox
Set Layer Scale Visibility checkbox checkbox
Set Layer/Group CRS checkbox checkbox checkbox
Set Project CRS from Layer checkbox checkbox
Styles ‣ checkbox checkbox
Copy Style checkbox checkbox
Paste Style checkbox checkbox checkbox
openTable Open Attribute Table checkbox
toggleEditing Toggle Editing checkbox
allEdits Current Edits ‣ checkbox (in Edit mode)
Save As... checkbox checkbox
Save As Layer Definition File... checkbox checkbox checkbox
Filter checkbox
unchecked Show Feature Count checkbox
Properties checkbox checkbox
Move to Top-level checkbox checkbox
Rename checkbox checkbox checkbox
Group Selected checkbox checkbox
Properties checkbox checkbox
Set Group WMS Data checkbox
unchecked Mutually Exclusive Group checkbox
addGroup Add Group checkbox

Enabling the Mutually Exclusive Group option you can make a group have only one layer visible at the same time. Whenever a layer within the group is set visible the others will be toggled not visible.

It is possible to select more than one layer or group at the same time by holding down the Ctrl key while selecting the layers with the left mouse button. You can then move all selected layers to a new group at the same time.

You may also delete more than one layer or group at once by selecting several items with the Ctrl key and pressing Ctrl+D afterwards. This way, all selected layers or groups will be removed from the layers list.

Editing vector layer style

From the Layers panel, you have shortcuts to easily and quickly edit the layer rendering. Right-click on a vector layer and select Styles –> in the list in order to:

  • see the currently applied styles to the layer. In case you defined many styles for the layer, you can switch from one to another and have your layer rendering automatically updated in the map canvas.
  • copy the current style, and when applicable, paste a copied style from another layer
  • rename the current style, add a new one (which is actually a copy of the current one) or delete the current style (when multiple styles available).

Note

The previous options are also available for raster layer.

Whether the features in the vector layer have all the same unique symbol or they are classified (in that case, the layer is displayed in a tree structure with each class as sub-item), the following options are available at layer level or class level:

  • a Edit Symbol... button to open the The symbol Selector dialog and update any property (symbol, size, color...) of the layer or feature symbol. Double-clicking on a feature does also open the Symbol Selector dialog.
  • a Color Selector widget with a Color Wheel from which you can click a color and have it automatically update the symbol fill color. For convenience, Recent colors are available at the bottom of the color wheel.
  • a showAllLayers Show All Items and hideAllLayers Hide All Items to toggle on or off the visibility of all the classes of features. This avoids (un)checking items one by one.

Tip

Quickly share a layer style

From the context menu, copy the style of a layer and paste it to a group or a selection of layers: the style is applied to all the layers that are of the same type (vector vs raster) as the original layer and, in case of vector, have the same geometry type (point, line or polygon).

Working with the Legend independent layer order

There is a panel that allows you to define an independent drawing order for the layers panel. You can activate it in the menu Settings ‣ Panels ‣ Layer Order Panel. This feature allows you to, for instance, order your layers in order of importance, but still display them in the correct order (see figure_layer_order). Checking the checkbox Control rendering order box underneath the list of layers will cause a revert to default behavior.

Figure Layer Order:

../../../_images/layer_order.png

Define a legend independent layer order

Statistical Summary Panel

This panel can show some statistics on a specific vector layers. The panel allows users to choose:

  • the vector layer;
  • the column or the expression;
  • filter statistics to selected features;
  • refresh the informations;
  • the statistics information to display with the bottom right button;

QGIS Overview Panel

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labelling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Log Messages Panel

When loading or processing some operations, you can track and follow messages that appear in different tabs using the messageLog Log Messages Panel. It can be activated using the most right icon in the bottom status bar.

Undo/Redo Panel

For each layer being edited, this panel shows the list of actions done, allowing to quickly undo a set of actions by simply selecting the action listed above.

Map View

Also called Map canvas, this is the “business end” of QGIS — maps are displayed in this area. The map displayed in this window will depend on the vector and raster layers you have chosen to load (see sections that follow for more information on how to load layers). The map view can be panned, shifting the focus of the map display to another region, and it can be zoomed in and out. Various other operations can be performed on the map as described in the label_toolbars description above. The map view and the legend are tightly bound to each other — the maps in view reflect changes you make in the legend area.

Tip

Zooming the Map with the Mouse Wheel

You can use the mouse wheel to zoom in and out on the map. Place the mouse cursor inside the map area and roll the wheel forward (away from you) to zoom in and backwards (towards you) to zoom out. The zoom is centered on the mouse cursor position. You can customize the behavior of the mouse wheel zoom using the Map tools tab under the Settings ‣ Options menu.

Tip

Panning the Map with the Arrow Keys and Space Bar

You can use the arrow keys to pan the map. Place the mouse cursor inside the map area and click on the right arrow key to pan east, left arrow key to pan west, up arrow key to pan north and down arrow key to pan south. You can also pan the map using the space bar or the click on mouse wheel: just move the mouse while holding down space bar or click on mouse wheel.

Status Bar

The status bar provides you with general information about the map view, and actions processed or available and offers you tools to manage the map view.

On the left side of the status bar, you can get a summary of actions you’ve done (such as selecting features in a layer, removing layer) or a long description of the tool you are hovering over (not available for all tools). On startup, the bar status also informs you about availability of new or upgradeable plugins (if checked in Plugin Manager settings).

In case of lengthy operations, such as gathering of statistics in raster layers or rendering several layers in map view, a progress bar is displayed in the status bar to show the current progress of the action.

The tracking Coordinate option shows the current position of the mouse, following it while moving across the map view. You can set the unit (and precision) to use in the project properties, General tab. Click on the small button at the left of the textbox to toggle between the Coordinate option and the extents Extents option that displays in map units, the coordinates of the current lower leftmost and upper rightmost points of the map view, as you pan and zoom in and out.

Next to the coordinate display you will find the Scale display. It shows the scale of the map view. If you zoom in or out, QGIS shows you the current scale. There is a scale selector, which allows you to choose among predefined and custom scales to assign to the map view.

To the right of the scale display you can define a current clockwise rotation for your map view in degrees.

On the right side of the status bar, there is a small checkbox which can be used to temporarily prevent layers being rendered to the map view (see section Rendering).

To the right of the render functions, you find the projectionDisabled Current CRS: icon with the EPSG code of the current project CRS. Clicking on this lets you Enable ‘on the fly’ CRS transformation properties for the current project and apply another CRS to the map view.

Finally, the messageLog Messages button opens the Log Messages Panel which informs you on underlying process (QGIS startup, plugins loading, processing tools...)

Tip

Calculating the Correct Scale of Your Map Canvas

When you start QGIS, the default CRS is WGS 84 (epsg 4326) and units are degrees. This means that QGIS will interpret any coordinate in your layer as specified in degrees. To get correct scale values, you can either manually change this setting, e.g. to meters, in the General tab under Project ‣ Project Properties, or you can use the projectionDisabled Current CRS: icon seen above. In the latter case, the units are set to what the project projection specifies (e.g., +units=us-ft).

Note that CRS choice on startup can be set in Settings ‣ Options ‣ CRS.