QGIS GUI

Quando QGIS si avvia, viene visualizzata una GUI come mostrato nella figura sottostante (i numeri da 1 a 5 cerchiati in giallo sono di seguito trattati).

../../../_images/startup.png

QGIS GUI con i dati di esempio Alaska

Nota

L’aspetto delle finestre (barra del titolo, ecc.) potrà apparire diverso a seconda del sistema operativo e dell’ambiente desktop.

La QGIS GUI è divisa in 5 aree:

  1. Barra dei Menu
  2. Barre degli strumenti
  3. Pannelli
  4. Mappa
  5. Barra di Stato

Scorri verso il basso per spiegazioni dettagliate di queste funzionalità.

Pannelli e Barre degli strumenti

Dal menu Visualizza (o kde Impostazioni), puoi attivare e disattivare i widget QGIS (Panelli ‣) e le barre degli strumenti (Barre degli strumenti ‣). Per (dis)attivarle, clicca con il tasto destro del mouse sulla barra dei menu o sulla barra degli strumenti e scegli l’elemento desiderato. Ogni pannello o barra degli strumenti può essere spostato e posizionato ovunque ci si senta a proprio agio all’interno dell’interfaccia QGIS. La lista può anche essere estesa con l’attivazione di Core o plugin esterni.

Barre degli strumenti

La barra degli strumenti fornisce l’accesso alla maggior parte delle stesse funzioni dei menu, oltre a strumenti aggiuntivi per interagire con la mappa. Ogni elemento della barra degli strumenti dispone di un aiuto a comparsa. Passa il mouse sulla voce e verrà visualizzata una breve descrizione dello scopo dello strumento.

Puoi spostare a piacimento ogni barra in funzione delle tue esigenze. Inoltre puoi disattivare ogni barra cliccando con il tasto destro sulla barra degli strumenti disattivando la voce relativa nel menu.

../../../_images/toolbars1.png

Il menu Barra degli strumenti

Suggerimento

Ripristinare le barre degli strumenti

Se hai disattivato accidentalmente una barra strumenti, puoi ripristinarla dalla voce di menu Visualizza ‣ Barre degli strumenti ‣ (o kde Impostazioni ‣ Barre degli strumenti ‣). Se una barra degli strumenti per qualsiasi ragione scompare dall’interfaccia di QGIS puoi effettuare il ripristino come descritto in ripristinare la GUI iniziale.

Pannelli

Oltre alle barre degli strumenti, QGIS fornisce molti pannelli predefiniti con cui lavorare. I pannelli sono widget speciali con cui è possibile interagire (selezionando opzioni, caselle di controllo, riempiendo valori….) per eseguire compiti più complessi.

../../../_images/panels.png

Il menu Pannelli

Di seguito la lista dei pannelli di default previsti in QGIS:

Mappa

Chiamata anche Rappresentazione della Mappa, questa è il «fine aziendale» di QGIS – le mappe vengono visualizzate in questa area. La mappa visualizzata in questa finestra dipenderà dai layer vettoriali e raster che hai scelto di caricare.

Quando aggiungi un layer (vedi ad esempio Accedere ai dati), QGIS cerca automaticamente il suo sistema di riferimento delle coordinate (SR) ed effettua lo zoom fino alla sua estensione se si inizia con un progetto QGIS vuoto. Il SR del layer viene poi applicato al progetto. Se ci sono già dei layer nel progetto, e se il nuovo layer ha lo stesso SR del progetto, verranno visualizzati gli elementi che rientrano nell’estensione corrente della mappa. Se il nuovo layer ha un SR diverso da quello del progetto, devi scegliere Effettua la trasformazione “al volo” del SR (OTF) dal Progetto ‣ Proprietà….. ‣ SR (vedi Trasformazioni SR On The Fly (OTF)). Il layer aggiunto dovrebbe ora essere visibile se i dati sono disponibili nell’estensione della vista corrente.

La visualizzazione della mappa può essere spostata, spostando la visualizzazione in un’altra regione della mappa, e può essere ingrandita e rimpicciolita. È possibile eseguire diverse altre operazioni sulla mappa come descritto nella sezione Barre degli strumenti. La visualizzazione della mappa e la legenda sono strettamente collegate tra loro — le mappe in visualizzazione riflettono le modifiche apportate nell’area legenda.

Suggerimento

Zoom in e Zoom out con la rotella del mouse

Per le operazioni di zoom puoi anche utilizzare la rotella del mouse. Posizionando il puntatore del mouse nell’area di visualizzazione delle mappe aumenterai lo zoom girando la rotella verso lo schermo, lo ridurrai girandola nel verso contrario. La posizione del puntatore costituisce il centro per l’ingrandimento. Puoi regolare il comportamento della funzione di zoom con la rotella del mouse nella scheda Strumenti mappa del menu Impostazioni ‣ Opzioni .

Suggerimento

Muovere la mappa con i Tasti Freccia e la Barra Spazio

Puoi utilizzare i tasti freccia per spostare la mappa. Posiziona il cursore del mouse all’interno dell’area della mappa e fai clic sui tasti freccia per spostarti a sinistra, destra, su e giù. Puoi inoltre spostare la mappa muovendo il mouse tenendo premuto il pulsante centrale o la barra spaziatrice del mouse (o tenendo premuta la rotellina del mouse).

Visualizzazione Mappa 3D

Il supporto alla visualizzazione 3D viene reso disponibile attraverso la visualizzazione della mappa 3D.

Nota

La visualizzazione 3D in QGIS richiede una versione recente della libreria QT (5.8 o successiva).

Puoi creare e aprire una vista mappa 3D tramite Visualizza ‣ new3DMap Nuova Mappa 3D. Apparirà un pannello QGIS fluttuante. Il pannello può essere agganciato alla finestra.

Inizialmente, la visualizzazione della mappa 3D ha la stessa estensione e la stessa visualizzazione della mappa in 2D. Non esiste una barra degli strumenti dedicata per la navigazione nella mappa 3D. Lo zoom avanti/indietro e la panoramica sono uguali a quelli della mappa 2D principale. È inoltre possibile eseguire lo zoom avanti e indietro trascinando il mouse verso il basso/su con il tasto destro del mouse premuto.

Opzioni di navigazione per esplorare la mappa in 3D:

  • Inclina e ruota
    • Per inclinare il terreno (ruotandolo intorno ad un asse orizzontale che passa attraverso il centro della finestra):
      • Trascina il mouse avanti/indietro con il pulsante centrale del mouse premuto
      • Premi Shift e trascina il mouse avanti/indietro con il pulsante sinistro del mouse premuto.
      • Premi Shift e usa i tasti su/giù.
    • Per ruotare il terreno (intorno ad un asse verticale che passa attraverso il centro della finestra):
      • Trascina il mouse a destra/sinistra con il pulsante centrale del mouse premuto
      • Premi Shift e trascina il mouse a destra/sinistra con il pulsante sinistro del mouse premuto.
      • Premi Shift e usa i tasti sinistra/destra.
  • Cambiare l’angolo di ripresa
    • Premendo Ctrl e trascinando il mouse con il pulsante sinistro del mouse premuto cambia l’angolo di ripresa corrispondente alle direzioni di trascinamento.
    • Premendo Ctrl e usando i tasti freccia si gira la fotocamera in su, in giù, a sinistra e a destra.
  • sposta la fotocamera su/giù
    • Premendo i tasti Page Up/Page Down sposta il terreno su e giù, rispettivamente.
  • Ingrandisci e rimpicciolisci
    • Trascinando il mouse con il pulsante destro del mouse premuto, effettuerai lo zoom in avanti (trascina verso il basso) e indietro (trascina verso l’alto).
  • Spostarsi sul terreno
    • Trascinando il mouse con il pulsante sinistro del mouse premuto si sposta il terreno
    • Utilizzando i tasti su/giù/giù/sinistra/destra si sposta il terreno più vicino, lontano, a destra e a sinistra, rispettivamente.

Per ripristinare la visualizzazione della fotocamera, fai clic sul pulsante zoomFullExtent Zoom ad estensione massima nella parte superiore del pannello della mappa 3D.

Configura Terreno

Un raster del terreno fornisce l’elevazione. Questo layer raster deve contenere una banda che rappresenta l’elevazione. Per selezionare l’informazione raster del terreno:

  1. Fai clic sul pulsante 3dconfigure Configura nella parte superiore del pannello della mappa 3D per aprire la finestra Configurazione 3D.
  2. Scegli il layer raster del terreno nel menu a discesa Altitudine.

Nella finestra Configurazione 3D ci sono diverse altre opzioni per la regolazione fine della scena 3D. Prima di immergersi nei dettagli, vale la pena notare che il terreno in una vista 3D è rappresentato da una gerarchia di mattonelle del terreno e, man mano che la fotocamera si avvicina al terreno, le mattonelle esistenti che non hanno sufficienti dettagli sono sostituite da mattonelle più piccole con maggiori dettagli. Ogni mattonella ha una geometria mesh derivata dal layer raster altimetrico e una texture dai layer della mappa 2D.

Opzioni di configurazione e loro significato:

  • Elevazione: Raster da utilizzare per la generazione del terreno.
  • Scala verticale: Fattore di scala per l’asse verticale. Aumentando la scala amplificherà la variazione di altezza del terreno.
  • Risoluzione mattonella: Quante campionature dal layer raster del terreno da utilizzare per ogni mattonella. Un valore di 16px significa che la geometria di ogni mattonella sarà costruita a partire da 16x16 campionature di elevazione. Un numero più alto crea un terreno più dettagliato a scapito di una maggiore complessità di visualizzazione.
  • Altezza bordo: A volte è possibile vedere piccole crepe tra le mattonelle del terreno. Aumentando questo valore si aggiungono pareti verticali («bordi») intorno alle mattonelle del terreno per nascondere le crepe.
  • Risoluzione mattonelle Mappa: Larghezza e altezza delle immagini della mappa 2D usate come suddivisione in mattonelle del terreno. 256px significa che ogni mattonella sarà visualizzata in un’immagine di 256x256 pixel. Un numero più alto crea mattonelle di terreno più dettagliate a scapito di una maggiore complessità di visualizzazione.
  • Max. errore di schermo: Determina la soglia per sostituire le mattonelle del terreno con altre più dettagliate (e viceversa) - cioè quanto tempo la vista 3D utilizzerà mattonelle di qualità superiore. Un numero inferiore significa maggiori dettagli della scena a scapito di una maggiore complessità di visualizzazione.
  • Max. errore al suolo: La risoluzione delle mattonelle del terreno in cui si interrompe la divisione delle mattonelle in mattonelle più dettagliate (dividerle non introdurrebbe comunque alcun dettaglio in più). Questo valore limita la profondità della gerarchia delle mattonelle: valori più bassi rendono la gerarchia profonda, aumentando la complessità di visualizzazione.
  • Zoom labels: Mostra il numero di livelli di zoom (dipende dalla risoluzione delle mattonelle della mappa e dall’errore massimo al suolo).
  • unchecked Mostra etichette: Attiva/disattiva le etichette della mappa
  • unchecked Mostra le info sulle mattonelle della mappa: Include i numeri delle mattonelle di confine e delle mattonelle del terreno (utile per la soluzione delle tematizzazioni del terreno).
  • unchecked Mostra i perimetri di delimitazione: Mostra i perimetri di delimitazione 3D delle mattonelle del terreno (utile per la soluzione delle tematizzazioni del terreno)
  • unchecked Mostra il centro di ripresa della fotocamera

Layer vettoriali 3D

Un layer vettoriale con valori di elevazione può essere mostrato nella mappa 3D controllando Configura nella scheda Nuova mappa 3D delle proprietà del layer vettoriale. Sono disponibili diverse opzioni per controllare la visualizzazione del layer vettoriale 3D.

Barra di Stato

La barra di stato ti fornisce informazioni generali sulla visualizzazione della mappa e sulle azioni elaborate o disponibili e ti offre strumenti per gestire la visualizzazione della mappa.

Sul lato sinistro della barra di stato, la barra di localizzazione, un widget di ricerca rapida, ti aiuta a trovare ed eseguire qualsiasi funzione o opzione in QGIS. Basta digitare il testo associato all’elemento che stai cercando (nome, tag, parola chiave….) e ottieni una lista che si aggiorna mentre scrivi. Puoi anche limitare la portata della ricerca usando locator filters. Fai clic sul pulsante search per selezionare uno qualsiasi di essi e premi la voce Configura per le impostazioni globali.

Nell’area accanto alla barra di localizzazione, quando necessario ti verrà mostrato un riepilogo delle azioni eseguite (come la selezione di elementi in un layer, la rimozione del layer) o una completa descrizione dello strumento su cui si passa sopra (non disponibile per tutti gli strumenti).

In caso di lunghe operazioni, come l’acquisizione di statistiche in layer raster, l’esecuzione di algoritmi di elaborazione o la visualizzazione di più layer nella mappa, nella barra di stato viene visualizzata una barra dello stato di avanzamento.

L’opzione tracking Coordinate mostra la posizione corrente del mouse, seguendolo durante lo spostamento sulla mappa. Puoi impostare le unità di misura (e la precisione) nella scheda Progetto ‣ Proprietà… ‣ Generale. Clicca sul piccolo pulsante a sinistra della casella di testo per passare dall’opzione Coordinate all’opzione extents Estensioni che mostra le coordinate in unità mappa degli attuali angoli in basso a sinistra e in alto a destra della mappa.

Accanto al display delle coordinate si trova il display Scala. Mostra la scala della visualizzazione della mappa. C’è un selettore di scala, che permette di scegliere tra predefined and custom scales.

Sul lato destro del display della scala, premi il pulsante lockedGray per bloccare la scala e utilizza la lente di ingrandimento per ingrandire o ridurre lo zoom. La lente d’ingrandimento consente di ingrandire una mappa senza alterare la scala della mappa, rendendo più facile modificare con precisione la posizione delle etichette e dei simboli. Il livello di ingrandimento è espresso in percentuale. Se Livello di ingrandimento ha un livello del 100%, allora la mappa corrente non viene ingrandita. Inoltre, un valore di ingrandimento predefinito può essere impostato all’interno di Impostazioni ‣ Opzioni… ‣ Visualizzazione ‣ Livello ingrandimento, che è molto utile per schermi ad alta risoluzione per ingrandire simboli piccoli.

A destra della scala puoi definire la rotazione corrente in gradi in senso orario della mappa.

Sul lato destro della barra di stato, c’è una piccola casella di controllo che può essere usata temporaneamente per impedire che i layeri vengano aggiornati nella visualizzazione mappa (vedi la sezione Visualizzazione).

A destra delle funzioni di visualizzazione, trovi il pulsante projectionEnabled EPSG:code che mostra il SR del progetto corrente. Cliccando su questo pulsante si apre la finestra di dialogo Proprietà progetto e ti consente di applicare un altro SR alla visualizzazione della mappa.

Il pulsante messageLog Messages accanto ad esso apre il pannello Messaggi di Log che contiene informazioni sui processi in corso (attivazione di QGIS, caricamento di plugin, strumenti di processing….).

A seconda di Plugin Manager settings, la barra di stato può a volte mostrare icone a destra per informarti sulla disponibilità di plugin pluginNew nuovi o pluginUpgrade aggiornabili. Clicca sull’icona per aprire la finestra di dialogo Plugin.

Suggerimento

Calcolare la scala corretta della mappa

Quando avvii QGIS, il SR predefinito è WGS 84 (EPSG 4326) e le unità di misura sono i gradi. Ciò significa che QGIS interpreterà qualsiasi coordinata del layer come specificato in gradi. Per ottenere valori di scala corretti, è possibile modificare manualmente questa impostazione nella scheda Generale sotto Progetto ‣ Proprietà… (ad es. ai metri), oppure è possibile utilizzare l’icona projectionEnabled EPSG:code vista sopra. In quest’ultimo caso, le unità sono impostate a quanto specificato dalla proiezione del progetto (ad esempio, +units=us-ft).

Da notare che la scelta del sistema SR di partenza può essere fatta in Impostazioni ‣ Opzioni ‣ SR.