Accedere ai dati

Facendo parte di un ecosistema Software Open Source QGIS è costruito su diverse librerie che, unitamente agli specifici provider, offrono la capacità di leggere e spesso scrivere molti formati:

  • I formati di dati vettoriali includono formati ESRI (Shapefile, Geodatabase…), formati file MapInfo e MicroStation, AutoCAD DWG/DXF, GeoPackage, GeoJSON, GRASS, GPX, KML, Comma Separated Values, e molti altri… Vedi l’elenco completo in OGR vector supported formats;

  • I formati di dati raster includono ArcInfo Binary Grid, ArcInfo ASCII Grid, JPEG, GeoTIFF, ERDAS IMAGINE, MBTiles, R o Idrisi rasters, ASCII Gridded XYZ, GDAL Virtual, SRTM, Sentinel Data, e molti altri… Vedi l’elenco completo in raster supported formats.

  • I formati di database includono PostgreSQL/PostGIS, SQLite/SpatiaLite, Oracle, DB2 o MSSQL Spatial, MySQL …;

  • Il supporto di servizi dati web (WM(T)S, WFS, WCS, CSW, ArcGIS Servers…) è anche gestito dai provider di QGIS (vedi QGIS come client di dati OGC).

  • Puoi anche leggere i files supportati dalle cartelle archiviate e utilizzare formati nativi di QGIS come i layer virtuali e i layer in memoria.

Con riferimento alla data di questo manuale, più di 80 formati vettoriali e 140 raster sono supportati da GDAL/OGR e dai providers di QGIS.

Nota

Non tutti i formati in elenco possono funzionare in QGIS per vari motivi. Ad esempio, alcuni richiedono librerie proprietarie esterne o il sistema operativo in uso potrebbe non essere tra quelli previsti per l’installazione del formato GDAL/OGR che tu desideri utilizzare. Per avere un elenco di formati disponibili, eseguire la linea di comando ogrinfo --formats (per i vettori) o vedere il menu Impostazioni ‣ Opzioni ‣ GDAL (per i raster) in QGIS.

In QGIS, a seconda del formato dei dati, ci sono diversi strumenti per aprirlo, disponibili principalmente in Layer ‣Aggiungi layer ‣ o dalla barra degli strumenti Gestisci layer (abilitata tramite il menu Visualizza ‣ Barre degli Strumenti). Tuttavia, tutti questi strumenti hanno una finestra di dialogo unificata, la finestra di dialogo Gestore della sorgente dati che si può aprire direttamente con il pulsante dataSourceManager Apri Data Source Manager disponibile sulla Barra degli strumenti per la gestione della sorgente dati o premendo Ctrl+L. Infatti, la finestra di dialogo Data Source Manager offre un’interfaccia unificata per aprire dati vettoriali o raster basati su file, nonché database o servizi web supportati da QGIS. Può essere impostato modale o meno con la checkbox Finestra di gestione non modale della sorgente dati in Impostazioni ‣ Opzioni ‣ Menu generale.

../../../_images/datasource_manager.png

Finestra di dialogo QGIS Gestore delle sorgenti dati

Oltre a questo punto di ingresso principale, c’è anche il plugin dbManager DB Manager che offre funzionalità avanzate per analizzare e manipolare i database collegati. Maggiori informazioni sulle funzionalità di DB Manager sono esposte in Plugin DB Manager.

Ci sono anche molti altri strumenti, plugin nativi o di terze parti, che ti aiutano ad aprire specifici formati di dati.

Questo capitolo descrive solo gli strumenti forniti di default in QGIS per caricare i dati. Si concentrerà principalmente sulla finestra di dialogo Data Source Manager ma, oltre a descrivere ogni scheda, esplorerà anche gli strumenti riferiti al fornitore di dati o alle specificità del formato.

Il Pannello Browser

Il Browser è uno dei modi principali per aggiungere rapidamente e facilmente i tuoi dati ai progetti. È disponibile come:

  • una scheda Gestore della sorgente dati, abilitata premendo il pulsante dataSourceManager Apri gestore della sorgente dati (Ctrl+L);

  • come pannello QGIS che puoi aprire dal menu Visualizza ‣ Pannelli (o kde Impostazioni ‣ Pannelli) o premendo Ctrl+2.

In entrambi i casi, il Browser ti aiuta a navigare nel tuo file system e a gestire i geodati, indipendentemente dal tipo di layer (raster, vettore, tabella), o dal formato della fonte di dati (file semplici o compressi, database, servizi web).

The context menu for an element in the Browser panel is opened by right-clicking on it.

For file system directory entries, the context menu offers the following:

  • Add as a Favorite

  • Properties…

  • Hide from Browser

  • Fast Scan this Directory

  • New Directory…

  • Open Directory

Favourites, can also be removed and renamed:

  • Rename favourite…

  • Remove favourite

For leaf entries that can act as layers in the project, the context menu will have a selection of entries. For example, for non-database, non-service-based vector, raster and mesh data sources:

  • Add Selected Layer(s) to Canvas

  • Properties…

  • Delete File «<name of file>»…

In the Layer properties entry, you will find (similar to what you will find in the vector and raster layer properties once the layers have been added to the project):

  • Metadata for the layer. Metadata groups: Information from provider (if possible, Path will be a hyperlink to the source), Identification, Extent, Access, Fields (for vector layers), Bands (for raster layers), Contacts, Links (for vector layers), References (for raster layers), History.

  • A Preview panel

  • The attribute table for vector sources (in the Attributes panel).

To add a layer to the project using the Browser:

  1. Attiva Browser come descritto sopra. Viene visualizzato una lista ad albero con il tuo file system, i database e i servizi web. Potrebbe essere necessario collegare i database e i servizi web prima di poterli visualizzare (vedi le sezioni dedicate).

  2. Cerca il layer nell’elenco;

  3. Use the context menu, double-click its name, or drag-and-drop it into the map canvas. Your layer is now added to the Layers panel and can be viewed on the map canvas.

    Suggerimento

    Aprire un progetto QGIS direttamente dal browser

    Puoi anche aprire un progetto QGIS direttamente dal pannello del Browser facendo doppio clic sul suo nome o trascinandolo e rilasciandolo nell’area di disegno della mappa.

Una volta caricato un file, puoi ingrandirlo utilizzando gli strumenti di navigazione della mappa. Per modificare lo stile di un layer, apri la finestra di dialogo Proprietà Layer facendo doppio clic sul nome del layer o facendo clic con il pulsante destro del mouse sul nome nella legenda e scegliendo Proprietà nel menu contestuale. Vedi la sezione Proprietà Simbologia per ulteriori informazioni sull’impostazione di simbologia dei layer vettoriali.

Nella parte superiore del pannello Browser trovi alcune icone che ti aiutano a:

  • addLayer Aggiungi layer selezionati: puoi aggiungere dati nella mappa anche selezionando Aggiungi layer selezionato dal menu contestuale del layer;

  • draw Aggiorna la visualizzazione ad albero;

  • filterMap Browser filtri per cercare dati specifici. Immetti una parola di ricerca o un carattere jolly e il browser visualizzerà l’albero per visualizzare solo i percorsi corrispondenti a tabelle DB, file o cartelle DB - altri dati o cartelle non verranno visualizzate. Vedi l’esempio del Pannello di Browser (2) sulla figura figure_browser_panels. La ricerca può essere sensibile alla distinzione tra maiuscole e minuscole o meno. Può anche essere impostata su:

    • normale: restituisce qualsiasi elemento contenente il testo cercato;

    • utilizzando il/i carattere(i) jolly: confermare la ricerca utilizzando ? e/o * per specificare la posizione del testo cercato;

    • usando una espressione regolare.

  • collapseTree Racchiudi tutto collassa la struttura ad albero;

  • metadata Abilita/disabilita le proprietà del widget: quando viene attivato, viene aggiunto un nuovo widget nella parte inferiore del pannello che mostra, se applicabile, i metadati dell’oggetto selezionato.

Clic destro su un elemento nell’albero del browser ti aiuta a:

  • in caso di un file o di una tabella, visualizzarne i metadati o aprirli nel tuo progetto. Le tabelle possono anche essere rinominate, cancellate o troncate;

  • in caso di cartella, definirla come segnalibro nei preferiti, nasconderla dall’albero del browser. Le cartelle nascoste possono essere gestite dalla scheda Impostazioni ‣ Opzioni… ‣ Sorgente dei dati;

  • creare un collegamento a database o server web;

  • aggiornare, rinominare o eliminare la scelta.

Puoi anche importare i file nei database o copiare le tabelle da uno schema/database a un altro con un semplice trascinamento drag-and-drop. C’è un secondo pannello del browser disponibile per evitare lunghi scorrimenti durante il trascinamento. Basta selezionare il file e fare drag-and-drop da un pannello all’altro.

../../../_images/browser_panels.png

Pannelli QGIS Browser affiancati

Suggerimento

Aggiungi layer a QGIS con un semplice drag-and-drop dal visualizzatore file del tuo sistema operativo

Puoi anche aggiungere i file al progetto trascinandoli dal proprio visualizzatore di file del sistema operativo in uso al Panello Layer o all’area di visualizzazione mappa.

Il DB Manager

Il Plugin DB Manager è un altro degli strumenti principali e nativi per integrare e gestire i formati di database spaziali supportati da QGIS (PostGIS, SpatiaLite, GeoPackage, Oracle Spatial, MSSQL, DB2, Virtual layers) in un’interfaccia utente. Può essere attivato dal menu Plugins ‣ Gestisci ed installa Plugins….

Il Plugin dbManager DB Manager offre diverse funzionalità:

  • collegarsi a database e visualizzare la struttura e il contenuto;

  • anteprima di tabelle di database;

  • aggiungere layer alla visualizzazione mappa, sia con un doppio clic che con trascina e rilascia;

  • aggiungere layer a un database da QGIS Browser o da un altro database;

  • creare e aggiungere l’output delle query SQL alla visualizzazione mappa;

  • creare virtual layers.

Ulteriori informazioni sulle funzionalità di DB Manager sono esposte in Plugin DB Manager.

../../../_images/db_manager.png

Finestra di dialogo DB Manager

Strumenti di caricamento per specifici provider di dati

Oltre a Pannello Browser e DB Manager che sono gli strumenti di base forniti da QGIS per aggiungere layer a prescindere dal formato, puoi anche trovate strumenti che sono specifici ai fornitori di dati.

Nota

Alcuni external plugins propongono anche strumenti per aprire in QGIS file di formato specifico.

Caricare un layer da un file

Per caricare un layer da un file, puoi:

  • per i dati vettoriali (come Shapefile, Mapinfo o dxf layer), clicca su addOgrLayer Aggiungi vettore, oppure seleziona l’opzione Layer ‣ Aggiungi Layer ‣ addOgrLayerAggiungi vettore…. oppure premi Ctrl+Shift+V. Si aprirà una nuova finestra (vedi figure_vector_add) dalla quale puoi scegliere radioButtonOn File e cliccare su Browse. Puoi anche specificare la codifica per il file, se vuoi.

    ../../../_images/addvectorlayerdialog.png

    Finestra di dialogo aggiungi vettore

  • per i layer raster, clicca sull’icona addRasterLayer Aggiungi raster, selezione l’opzione del menu Layer ‣ Aggiungi layer ‣ o digita Ctrl+Shift+R.

Verrà visualizzata una finestra di dialogo standard per i file aperti (vedi figure_vector_open), che ti consente di navigare nel file system e caricare uno shapefile, un geotiff o un’altra fonte dati supportata. La casella di selezione Filtro selectString ti consente di preselezionare alcuni formati di file supportati. Solo i formati che sono stati ben testati appaiono nella lista. Altri formati non testati possono essere caricati selezionando Tutti i file (*. *) .

../../../_images/shapefileopendialog.png

Aprire una finestra di dialogo di un layer vettoriale supportato OGR

Selezionando un file dalla lista e cliccando su Apri lo carica in QGIS. È possibile caricare più di un layer contemporaneamente tenendo premuto il tasto Ctrl o Shift e cliccando su più oggetti nella finestra di dialogo. Figure_vector_loaded mostra QGIS dopo aver caricato il file alaska.shp.

../../../_images/shapefileloaded.png

QGIS con il caricamento dello Shapefile Alaska

Nota

Poiché alcuni formati come MapInfo (ad esempio .tab) o Autocad (.dxf) consentono di mescolare diversi tipi di geometrie in un singolo file, il caricamento di tale formato in QGIS apre una finestra di dialogo per selezionare le geometrie da utilizzare in modo da ricavare un layer a singola tipologia geometrica.

Utilizzando lo strumento addOgrLayer Aggiungi Vettore:

  • Puoi anche caricare formati specifici come ArcInfo Binary Coverage, UK. Formato di trasferimento nazionale, così come il formato TIGER grezzo dell” USA Census Bureau o OpenfileGDB. Per fare ciò, devi selezionare radioButtonOn Cartella come :guilabel:Tipo di Sorgente. In questo caso una directory può essere selezionata nella finestra di dialogo dopo aver premuto Sfoglia.

  • Con il Tipo di Sorgente radioButtonOn Database puoi selezionare una connessione al database esistente o crearne una al tipo di database selezionato. I tipi di database disponibili sono ODBC, OGDI Vectors, Esri Personal Geodatabase, MySQL, PostgreSQL o MSSQL.

    Premendo il pulsante Nuovo si apre la finestra di dialogo Crea una nuova connessione database OGR i cui parametri sono tra quelli presenti in Creazione della connessione. Premendo Apri puoi selezionare tra le tabelle disponibili, ad esempio del database PostGIS abilitato.

  • L’ultimo tipo di sorgente, radioButtonOn Protocollo, permette di aprire i dati dal web usando per esempio il formato GeoJSON o CouchDB. Dopo aver selezionato il tipo si deve riempire l’URI della fonte.

Suggerimento

Caricare layers e progetti da unità esterne montate su macOS

Su macOS, le unità portatili montate accanto al disco rigido primario non appaiono come previsto in File ‣ Open….. Stiamo lavorando su piùdi una finestra di dialogo open/save macOS-native per risolvere il problema. Come soluzione, puoi digitare /Volumi` nella casella File name e premere Enter. Poi puoi navigare verso unità esterne e supporti di rete.

Importare file di testo delimitato

Il file di testo delimitato (es. .csv, .txt) può essere caricato in QGIS utilizzando gli strumenti sopra descritti. Tuttavia, caricato in questo modo, apparirà come una semplice tabella di dati. A volte, i file di testo delimitati possono contenere dati geometrici che vuoi visualizzare; questo è ciò per cui è stato progettato addDelimitedTextLayer Aggiungi layer testo delimitato.

Fai clic sull’icona dataSourceManager Apri gestore della sorgente dati per aprire la finestra di dialogo Gestore della sorgente dati e attiva la scheda addDelimitedTextLayer Testo delimitato, come mostrato in figure_delimited_text_text.

../../../_images/delimited_text_dialog.png

Finestra di dialogo Testo Delimitato

In primo luogo, seleziona il file da importare (ad esempio, qgis_sample_data/csv/elevp.csv) cliccando sul pulsante Sfoglia. Nel campo Nome layer, fornisci il nome da utilizzare per il layer nel progetto (ad esempio, Elevation).

Formattazione file

Una volta selezionato il file, QGIS tenta di analizzare il file con l’ultimo delimitatore utilizzato, cercando di identificare campi e righe. Per consentire a QGIS di analizzare correttamente il file, è importante selezionare il delimitatore corretto. È possibile specificare un delimitatore attivandolo:

  • radioButtonOnCSV (comma separated values) valori separati da virgole;

  • radioButtonOffDelimitatori personalizzati, scegliendo tra alcuni delimitatori predefiniti come virgola, spazio, TAB, punto e virgola…;

  • o radioButtonOffDelimitatore espressione regolare e inserendo un testo nel campo Espressione. Per esempio se vuoi usare TAB come delimitatore usa \t (questa è l’espressione regolare usata per TAB).

Record e campi

Oltre alle impostazioni per identificare righe e campi nei dati, è possibile utilizzare alcune utili opzioni per facilitare il riconoscimento dei dati:

  • Numero di linee di intestazione da saltare: utile quando vuoi evitare alcune linee in importazione, sia perché si tratta di linee vuote o con un’altra formattazione.

  • checkboxIl primo record ha i nomi dei campi: i valori nella prima riga dei dati sono usati come nomi dei campi, altrimenti QGIS aggiunge una riga di campi di tipo field_1, field_2…..

  • checkboxDetect field types: riconosce automaticamente il tipo di campo. Se deselezionato, tutti gli attributi sono trattati come campi di testo.

  • checkboxLa virgola è il separatore decimale: se necessario, puoi forzare una virgola come separatore decimale.

  • checkboxRifinisci i campi: ti permette di troncare gli spazi iniziale e finali dai campi.

  • checkboxScarta i campi vuoti.

Mentre imposti le proprietà di interpretazione, un’anteprima dei dati campione viene aggiornata nella parte inferiore della finestra di dialogo.

Definizione geometria

Una volta che il file è stato interpretato, imposta Definizione della Geometria a:

  • radioButtonOnCoordinate del punto e attiva Campo X e Campo Y se il layer è di tipo geometrico e contiene tali tipi di coordinate. Se le coordinate sono definite come gradi/minuti/secondi, attiva la casella di controllo checkbox DMS coordinates;

  • radioButtonOnWell known text (WKT) opzione se l’informazione spaziale è rappresentata da WKT: seleziona il Campo Geometria contenente la definizione WKT e scegli l’appropriato Tipo di geometria oppure lascia che QGIS lo rilevi automaticamente;

  • Se il file contiene dati non spaziali, attiva radioButtonOn Nessuna geometria (solo tabella attributi) e verrà caricato come una normale tabella.

Oltre alle informazioni sulla geometria degli oggetti, puoi anche impostare il SR della geometria del layer utilizzando il widget setProjection Seleziona SR.

Impostazioni layer

Puoi anche attivare:

  • checkboxUsa indice spaziale per migliorare le prestazioni di visualizzazione e di selezione spaziale degli oggetti;

  • checkboxUsa indice di raggruppamento per migliorare le prestazioni di subset filters (quando definito nelle proprietà del layer);

  • checkboxControlla file per controllare le modifiche al file da parte di altre applicazioni mentre QGIS è in esecuzione.

Alla fine, fai clic su OK per aggiungere il layer alla mappa. Nel nostro esempio, al progetto viene aggiunto un layer di punti chiamato Elevazione e si comporta come qualsiasi altro layer di mappa in QGIS. Tuttavia, questo layer è il risultato di una query sul layer sorgente .csv (quindi, collegato ad esso) e richiederebbe to be saved per ottenere un layer spaziale su disco.

Importare file DXF o DWG

I file DXF e DWG possono essere aggiunti a QGIS con un semplice drag-and-drop dal comune pannello del browser. Ti verrà richiesto di selezionare i sublayer che vorresti aggiungere al progetto. I layer vengono aggiunti con proprietà di stile casuali.

Nota

Per i file DXF contenenti diversi tipi di geometria (punto, linea e/o poligono), il nome del layer sarà composto da <filename.dxf> entities <geometry type>.

Per mantenere la struttura del file dxf/dwg e la sua simbologia in QGIS, puoi utilizzare lo strumento dedicato Progetto ‣ Importa/Esporta ‣ Importa layer da DWG/DXF…. che ti permette di:

  1. importare oggetti dal file DWG/DXF in un database di GeoPackage.

  2. e aggiungere al progetto tutti gli oggetti importati.

Nella finestra di dialogo Importa DWG/DXF, per prima cosa per importare il contenuto del file:

  1. Inserisci la posizione del Target package, cioè il nuovo file GeoPackage che memorizzerà i dati. Se viene fornito un file esistente, allora verrà sovrascritto.

  2. Specifica il sistema di riferimento delle coordinate dei dati del file DWG/DXF.

  3. Seleziona checkbox Espandi riferimenti blocco per importare i blocchi nel file di disegno come oggetti normali.

  4. Scegli checkbox Usa curve per trasformare i layer importati in un tipo di geometria curva.

  5. Usa il pulsante Importa per selezionare il file DWG/DXF da utilizzare (uno per ogni geopackage). Il database del GeoPackage verrà automaticamente popolato con il contenuto del file DWG/DXF. A seconda delle dimensioni del file *CAD, questo potrebbe richiedere un po” di tempo.

Dopo che i dati .dwg o .dxf vengono importati nel database di GeoPackage, la cornice nella metà inferiore del dialogo viene popolata con l’elenco dei layer del file importato. Qui è possibile selezionare quali layer aggiungere al progetto QGIS:

  1. Nella parte superiore, imposta un Nome gruppo per raggruppare i file di disegno nel progetto.

  2. Scegli i layer da mostrare: Ogni layer selezionato viene aggiunto ad un gruppo ad hoc che contiene layer vettoriali per gli oggetti punto, linea, etichetta e area del layer DXF/DWG. Lo stile di ogni layer è impostato in modo che assomigli all’aspetto che aveva originariamente in *CAD.

  3. Scegli se il layer deve essere visibile all’apertura.

  4. In alternativa, utilizzando l’opzione checkbox Fondi layer, tutti i layer vengono posti in un unico gruppo.

  5. Premi OK per aprire i layer in QGIS.

../../../_images/dwg_dxf_import_dialog.png

Finestra di dialogo per importazione file DWG/DXF

Importare vettori OpenStreetMap

Negli ultimi anni il progetto OpenStreetMap ha guadagnato popolarità perché in molti Paesi non sono disponibili dati geodati gratuiti quali mappe stradali digitali. L’obiettivo del progetto OSM è quello di creare una mappa liberamente modificabile del mondo da dati GPS, fotografia aerea o conoscenze locali. Per supportare questo obiettivo, QGIS fornisce il supporto per i dati OSM.

Utilizzando il Pannello Browser, puoi caricare un file .osm sulla mappa, nel qual caso ti verrà visualizzata una finestra di dialogo per selezionare i sublayers in base al tipo di geometria. I layers caricati conterrano tutti i dati di quella tipologia di geometria presenti nel file e manterranno la struttura dati del file osm.

SpatiaLite Layers

addSpatiaLiteLayer La prima volta che carichi i dati da un database di SpatiaLite, inizia da:

  • facendo clic sul pulsante addSpatiaLiteLayer Aggiungi vettore SpatiaLite della barra degli strumenti;

  • selezionando l’opzione addSpatiaLiteLayer Aggiungi vettore SpatiaLite… dal menu Layer ‣ Aggiungi Layer;

  • o digitando Ctrl+Shift+L.

Si aprirà una finestra che ti permetterà di collegarti ad un database SpatiaLite già noto a QGIS, che puoi scegliere dal menu a tendina, oppure di definire una nuova connessione ad un nuovo database. Per definire una nuova connessione, clicca su Nuovo e usa il file browser per puntare al tuo database SpatiaLite, che è un file con estensione .sqlite.

QGIS supporta anche viste modificabili in SpatiaLite.

GPS

Il caricamento dei dati GPS in QGIS può essere effettuato utilizzando il plugin di base: Strumenti GPS. Le istruzioni sono descritte nel paragrafo Plugin GPS.

GRASS

Lavorare con i dati vettoriali GRASS è descritto nel capitolo Integrazione con GRASS GIS.

Formati QGIS personalizzati

QGIS dispone di due formati personalizzati che puoi caricare nell’applicazione utilizzando l’appropriato strumento di caricamento:

  • Layer temporaneo: un layer in memoria associato al progetto con il quale viene aperto (vedi Creazione di un nuovo Layer temporaneo per ulteriori informazioni)

  • Layers virtuali: un layer risultante da una query su altro(i) layer(s) (per ulteriori informazioni, vedi Layers virtuali)

QLR - QGIS Layer Definition File

Le definizioni del layer possono essere salvate come Layer Definition File (QLR - .qlr) usando :menuselection:` Esporta -> Salva come file di definizione layer…` nel menu contestuale del layer.

Il formato QLR consente di condividere layer QGIS «completi» con altri utenti QGIS. I file QLR contengono collegamenti alle fonti dati e tutte le informazioni di stile QGIS necessarie per lo stile del layer.

I file QLR sono mostrati nel Pannello Browser e possono essere usati per aggiungere layer (con i relativi stili salvati) al Pannello Layer. Puoi anche trascinare e rilasciare i file QLR dal file manager di sistema nell’area della mappa.

Connessione a web services

Con QGIS puoi accedere a diversi tipi di servizi web OGC (WM(T)S, WFS(-T), CSW …). Grazie a QGIS Server, puoi anche pubblicare questi servizi. La descrizione di queste funzionalità e le istruzioni per l’uso sono fornite nel capitolo Lavorare con i dati OGC.