24.5. Le modeleur graphique

Le modeleur graphique vous permet de créer des modèles complexes en utilisant une interface simple et facile à utiliser. Dans un SIG, la plupart des opérations d’analyses ne sont pas simples mais font partie d’une chaîne de traitements. En utilisant le modeleur graphique, cette chaîne de traitements peut être regroupée dans une tâche, qui est plus simple à exécuter et peut être réutilisée sur d’autres jeux de données. Peu importe le nombre d’étapes et d’algorithmes impliqués, un modèle est exécuté comme un seul algorithme, permettant ainsi d’économiser temps et effort.

Le modeleur graphique s’ouvre depuis le menu Traitement (Traitement ► Modeleur graphique…).

24.5.1. Interface du modeleur graphique

../../../_images/modeler_canvas.png

Fig. 24.16 Modeleur

In its main part, the modeler has a working canvas where the structure of the model and the workflow it represents can be constructed.

At the top of the dialog, different menus and the Navigation toolbar give access to a variety of tools.

24.5.1.1. Menu Modèle

Libellé

Raccourci

Barre d’outils Navigation

Description

success Valider le modèle

Checks whether the algorithms and inputs used in the model exist. Convenient before releasing a model.

play Run Model…

F5

checkbox

Exécute le modèle

Reorder Model Inputs…

Sets the order in which inputs are presented to the user in the algorithm dialog.

fileOpen Open Model…

Ctrl+O

checkbox

Opens a .model3 file for edit or execution

fileSave Save Model

Ctrl+S

checkbox

Saves the model to disk as a .model3 file

fileSaveAs Save Model as…

Ctrl+Shift+S

checkbox

Saves the model to disk as a new .model3 file

fileSave Save Model in project

checkbox

Embeds the model file in the project file, making it available when sharing the project file.

helpContents Edit Model Help…

checkbox

An interface to document the model, the algorithms, the parameters and outputs, as well as the author and versioning

Export ►

saveMapAsImage ► Export as Image…

checkbox

Saves the model’s graphical design to an image file format (for illustration purpose)

saveAsPDF► Export as PDF…

Saves the model’s graphical design to a PDF file format (for illustration purpose)

saveAsSVG ► Export as SVG…

Enregistre le design du modeleur graphique en fichier SVG (à des fins d’illustration)

fileSave► Export as Script Algorithm…

checkbox

Generates a python script file including the model’s instructions

24.5.1.2. Edit menu

Libellé

Raccourci

Barre d’outils Navigation

Description

selectAll Select All

Ctrl+A

Selects all the model components in the designer

Snap selected components to Grid

snaps and aligns the elements into a grid

redo Redo

Ctrl+Y

checkbox

Rollback the latest canceled action. See also the Undo/Redo panel.

undo Undo

Ctrl+Z

checkbox

Cancel the previous change. See also the Undo/Redo panel.

editCut Cut

Ctrl+X

Cuts a selection of components from the model.

editCopy Copy

Ctrl+C

Copies a selection of components from the model.

editPaste Paste

Ctrl+V

Pastes a cut or copied selection of components from a model to another or within the same model. The selected components keep their original properties and comments.

deleteSelected Delete selected components

Del

Removes a component from the model.

Add Group Box

Adds a box at the background of related components in order to visually group them. Particularly useful in big models to keep the workflow clean.

24.5.1.3. View menu

Libellé

Raccourci

Barre d’outils Navigation

Description

Zoom To ►

Zooms to the selected group box extent

zoomIn Zoom In

Ctrl++

checkbox

zoomOut Zoom Out

Ctrl+-

checkbox

zoomActual Zoom to 100%

Ctrl+1

checkbox

zoomFullExtent Zoom Full

Ctrl+0

checkbox

Displays all the components in the designer current canvas

checkbox Show Comments

Displays comments associated to every algorithm or input in the graphical designer

unchecked Enable Snapping

unchecked Toggle Panel Visibility

Ctrl+Tab

Switches ON or OFF the panels in the designer

24.5.1.4. Panels

The left part of the window is a section with five panels that can be used to add new elements to the model:

  1. Model Properties: specify the name (required) of the model and the group in which it will be displayed in the Processing Toolbox

  2. Inputs: all the input parameters that could shape your model

  3. Algorithms: the available Processing algorithms

  4. Variables: Models can contain dedicated variables that are unique and only available to them. These variables can be accessed by any expression used within the model. They are useful to control algorithms within a model and control multiple aspects of the model by changing a single variable. The variables can be viewed and modified in the Variables panel.

  5. Undo History: this panel will register everything that happens in the modeler, making it easy to cancel things you did wrong.

24.5.1.5. À propos des algorithmes disponibles

Some algorithms that can be executed from the toolbox do not appear in the list of available algorithms when you are designing a model. To be included in a model, an algorithm must have the correct semantic. If an algorithm does not have such a well-defined semantic (for instance, if the number of output layers cannot be known in advance), then it is not possible to use it within a model, and it will not appear in the list of algorithms that you can find in the modeler dialog. On the other hand some algorithms are specific to the modeler. Those algorithms are located within the group “Modeler Tools”.

24.5.2. Creating a model

La création d’un modèle comporte deux étapes fondamentales :

  1. Définition des entrées nécessaires. Ces entrées seront ajoutées à la fenêtre des paramètres, afin que l’utilisateur puisse définir leurs valeurs lors de l’exécution du modèle. Le modèle lui-même est un algorithme, la fenêtre des paramètres est donc générée automatiquement comme pour tous les algorithmes disponibles dans le cadre de traitement.

  2. Définir la chaîne de traitements. À partir des données d’entrée du modèle, la chaîne de traitements est définie en ajoutant des algorithmes et en sélectionnant comment ces derniers utiliseront les données ou d’autres données générées par d’autres algorithmes déjà présents dans le modèle.

24.5.2.1. Définition des données d’entrée

La première étape consiste à définir les données d’entrée du modèle. Les éléments suivants se trouvent dans le panneau Entrées sur le côté gauche de la fenêtre du modeleur :

Tableau 24.1 List of parameter types for model building

Annotation Layer

Authentication Configuration

Boolean

Color

Connection Name

Coordinate Operation

CRS

Database Schema

Database Table

Datetime

Distance

Duration

DXF Layers

Enum

Expression

Extent

Field Aggregates

Fields Mapper

File/Folder

Geometry

Map Layer

Map Theme

Matrix

Mesh Dataset Groups

Mesh Dataset Time

Mesh Layer

Multiple Input

Number

Point

Point Cloud Layer

Print Layout

Print Layout Item

Range

Raster Band

Raster Layer

Scale

String

TIN Creation Layers

Vector Features

Vector Field

Vector Layer

Vector Tile Writer Layers

Note

En survolant les entrées avec la souris, une info-bulle contenant des informations supplémentaires apparaîtra.

En double-cliquant sur un élément, un dialogue s’affiche pour vous permettre de définir ses caractéristiques. Selon le paramètre, le dialogue contiendra au moins un élément (la description, qui est ce que l’utilisateur verra en exécutant le modèle). Par exemple, lors de l’ajout d’une valeur numérique, comme le montre la figure suivante, en plus de la description du paramètre, vous devez définir une valeur par défaut et la plage des valeurs valides.

../../../_images/models_parameters.png

Fig. 24.17 Définition des Paramètres du Modèle

Vous pouvez définir votre entrée comme obligatoire pour votre modèle en cochant l’option Obligatoire et en cochant la case Avancé si elle n’est pas cochée, vous pouvez définir l’entrée comme étant dans la section Avancé. Cela est particulièrement utile lorsque le modèle comporte de nombreux paramètres et que certains d’entre eux ne sont pas triviaux, mais que vous souhaitez néanmoins les choisir.

Pour chaque entrée supplémentaire, un nouvel élément est ajouté au canevas du modeleur.

../../../_images/models_parameters2.png

Fig. 24.18 Paramètres du modèle

Vous pouvez également ajouter des entrées en faisant glisser le type d’entrée depuis la liste et en le déposant à l’endroit où vous le souhaitez dans le canevas du modeleur. Si vous souhaitez modifier un paramètre d’une entrée existante, il vous suffit de double-cliquer dessus, et la même boîte de dialogue s’affichera.

When using a model within another model, the inputs and outputs necessary will be displayed in the canvas.

24.5.2.2. Définition d’un flux de traitements

Dans l’exemple suivant, nous allons ajouter deux entrées et deux algorithmes. L’objectif du modèle est de copier les valeurs d’élévation d’une couche raster du MNT vers une couche linéaire en utilisant l’algorithme Drape, puis de calculer l’ascension totale de la couche linéaire en utilisant l’algorithme Climb Along Line.

Dans l’onglet Entrées, choisissez les deux entrées comme Couche vecteur pour la ligne et Couche raster pour le MNT. Nous sommes maintenant prêts à ajouter les algorithmes au flux de travail.

Les algorithmes peuvent être trouvés dans le panneau Algorithmes, regroupés à peu près de la même manière qu’ils le sont dans la boîte à outils Processing.

../../../_images/models_parameters3.png

Fig. 24.19 Entrées du modèle

Pour ajouter un algorithme à un modèle, double-cliquez sur son nom ou glissez-déposez-le, comme pour les entrées. Comme pour les entrées, vous pouvez modifier la description de l’algorithme et ajouter un commentaire. Lors de l’ajout d’un algorithme, un dialogue d’exécution apparaîtra, avec un contenu similaire à celui du panneau d’exécution qui est affiché lors de l’exécution de l’algorithme à partir de la boîte à outils. L’image suivante montre les dialogues d’algorithme Drape (set Z value from raster) et Climb along line.

../../../_images/models_parameters4.png

Fig. 24.20 Paramètres du modèle de l’algorithme

As you can see, there are however some differences. Each parameter has a drop-down menu next to it allowing to control how it will be served during the workflow:

  • fieldInteger Valeur : permet de définir le paramètre à partir d’une couche chargée dans le projet QGIS ou de parcourir une couche à partir d’un dossier

  • expression Valeur pré-calculée : avec cette option, vous pouvez ouvrir le générateur d’expression et définir votre propre expression pour remplir le paramètre. Les entrées du modèle ainsi que certaines autres statistiques de couche sont disponibles sous forme de variables et sont listées en haut de la boîte de dialogue de recherche du générateur d’expression

  • processingModel Modèle source : choisissez cette option si le paramètre provient d’une entrée du modèle que vous avez défini. Une fois que vous aurez cliqué sur cette option, vous obtiendrez une liste de toutes les entrées appropriées pour le paramètre

  • processingAlgorithm Algorithme sortie : est utile lorsque le paramètre d’entrée d’un algorithme est une sortie d’un autre algorithme

  • outputs parameters have the addditional modelOutput Model Output option that makes the output of the algorithm available in the model. If a layer generated by the algorithm is only to be used as input to another algorithm, don’t edit that text box.

    Dans l’image suivante, vous pouvez voir les deux paramètres d’entrée définis comme Entrée du modèle et la couche de sortie temporaire :

    ../../../_images/models_parameters5.png

    Fig. 24.21 Paramètres d’entrée et de sortie de l’algorithme

You will also find an additional parameter named Dependencies that is not available when calling the algorithm from the toolbox. This parameter allows you to define the order in which algorithms are executed, by explicitly defining one algorithm as a parent of the current one. This will force the parent algorithm to be executed before the current one.

Lorsque vous utilisez la sortie d’un algorithme précédent comme entrée de votre algorithme, cela définit implicitement l’algorithme précédent comme parent de l’algorithme actuel (et place la flèche correspondante dans le canevas du modeleur). Cependant, dans certains cas, un algorithme peut dépendre d’un autre même s’il n’utilise aucun objet de sortie de celui-ci (par exemple, un algorithme qui exécute une phrase SQL sur une base de données PostGIS et un autre qui importe une couche dans cette même base de données). Dans ce cas, il suffit de sélectionner l’algorithme précédent dans le paramètre Dépendances et ils seront exécutés dans le bon ordre.

Une fois tous les paramètres remplis, validez avec OK et l’algorithme sera ajouté au canevas. Il sera lié aux autres éléments déjà présents, données d’entrée ou algorithmes fournissant des objets à utiliser comme entrée de cet algorithme.

Elements can be dragged to a different position on the canvas using the select Select/Move Item tool. This is useful to make the structure of the model clearer and more intuitive. You can also resize the elements, grasping their border. This is particularly useful if the description of the input or algorithm is long. With View ► Enable snapping option checked, items resizing or displacement can be bound to a virtual grid, for a more visually structured algorithm design.

Links between elements are updated automatically and you can see a + button at the top and at the bottom of each algorithm. Clicking the button will list all the inputs and outputs of the algorithm so you can have a quick overview.

../../../_images/models_model.png

Fig. 24.22 Un modèle complet

With the Edit ► Add Group Box tool, you can add a draggable box to the canvas. This feature is very useful in big models to group related elements in the modeler canvas and to keep the workflow clean. For example we might group together all the inputs of the example:

../../../_images/model_group_box.png

Fig. 24.23 Boîte de groupe modèle

You can change the name and the color of the boxes. Group boxes are very useful when used together with View ► Zoom To ► tool, allowing you to zoom to a specific part of the model. You can also zoom in and out by using the mouse wheel.

Vous pouvez modifier l’ordre des entrées et la façon dont elles sont énumérées dans le dialogue principal du modèle. En bas du panneau Entrée, vous trouverez le bouton Réorganiser les entrées du modèle... et en cliquant dessus, une nouvelle boîte de dialogue apparaît, vous permettant de modifier l’ordre des entrées :

../../../_images/model_reorder_inputs.png

Fig. 24.24 Réorganiser les entrées du modèle

Comments can also be added to inputs or algorithms present in the modeler. This can be done by going in the Comment tab of the item or with a right-click. In the same tab a color can be set manual for individual model comments. Comments are visible only in the modeler canvas and not in the final algorithm dialog; they can be hidden by deactivating View ► Show Comments.

You can run your algorithm any time by clicking on the start Run model button. When using the editor to execute a model, any non-default values will be saved in the inputs. This means that executing the model at a later time from the editor will have the dialog prefilled with those values on any subsequent run.

In order to use the algorithm from the toolbox, it has to be saved and the modeler dialog closed, to allow the toolbox to refresh its contents.

24.5.2.3. Documenting your model

You need to document your model, and this can be done from the modeler itself. Click on the editHelpContentEdit model help button, and a dialog like the one shown next will appear.

../../../_images/help_edition.png

Fig. 24.25 Éditer la documentation

Sur la partie droite apparaîtra une simple page HTML, créée à partir de la description des paramètres d’entrées et des sorties de l’algorithme, ainsi que d’autres éléments tels que la description générale du modèle ou ses auteurs. À la première ouverture de l’éditeur d’aide, ces champs seront vides, mais vous pouvez les éditer à partir des éléments situés à gauche de la fenêtre. Sélectionnez un élément dans la partie supérieure puis remplissez sa description dans la partie inférieure.

L’aide d’un modèle est enregistrée comme une partie intégrante du modèle.

24.5.3. Sauvegarder et charger des modèles

24.5.3.1. Saving models

Utilisez le bouton fileSaveSauvegarder le modèle pour enregistrer le modèle actuel et le bouton fileOpenouvrir modèle pour ouvrir un modèle précédemment enregistré. Les modèles sont enregistrés avec l’extension .model3. Si le modèle a déjà été sauvegardé à partir de la fenêtre du modeleur, aucun nom de fichier ne vous sera demandé. Comme il y a déjà un fichier associé au modèle, ce fichier sera utilisé pour les sauvegardes ultérieures.

Avant de sauvegarder un modèle, il faudra définir son nom et le groupe auquel il appartient. Pour cela, remplissez les deux champs texte situés sur la partie haute de la fenêtre.

Les modèles sauvegardés dans le répertoire models (le répertoire par défaut) apparaîtront dans la boîte à outils dans le groupe correspondant. Lorsque la boîte à outils est ouverte, tous les fichiers portant l’extension .model3 du répertoire models sont chargés. Comme le modèle fait maintenant partie des algorithmes, il peut être utilisé comme tous les autres depuis la boite à outils ou depuis le modeleur.

Les modèles peuvent également être enregistrés dans le fichier de projet via le bouton addToProjectEnregistrer le modèle dans le projet. Les modèles sauvegardés par ce biais ne seront pas enregistrés dans un fichier .model3 mais directement intégrés au fichier du projet.

Les modèles associés au projet sont disponibles depuis le menu qgsProjectFileModèles du projet de la boîte à outils.

Le répertoire par défaut des modèles peut être défini dans les configurations du Module de Traitements, dans le groupe Modèles.

Les modèles sauvegardés dans le répertoire models apparaîtront dans la boîte à outils dans le groupe correspondant ainsi que dans la liste des Algorithmes proposés dans le modeleur. Cela signifie que vous pouvez utiliser un modèle depuis un autre modèle, comme tous les algorithmes.

Les modèles apparaîtront dans le panneau Browser et pourront être exécutés à partir de là.

24.5.3.2. Exporter le modèle en script Python

Comme nous le verrons dans un chapitre ultérieur, les algorithmes de traitement peuvent être appelés depuis la console Python de QGIS, et de nouveaux algorithmes de traitement peuvent être créés à l’aide de Python. Un moyen rapide de créer un tel script Python est de créer un modèle et de l’exporter ensuite sous forme de fichier Python.

Pour ce faire, cliquez sur le bouton saveAsPythonExporter comme Algorithme de script… dans le canevas du modeleur ou faites un clic droit sur le nom du modèle dans la boîte à outils de traitement et choisissez saveAsPythonExporter le modèle comme Algorithme Python….

24.5.3.3. Exporter un modèle comme image, PDF ou SVG.

Un modèle peut également être exporté en tant qu’image, SVG ou PDF (à des fins d’illustration) en cliquant sur saveMapAsImage Exporter en tant qu’image, saveAsPDF Exporter en PDF ou saveAsSVG Exporter en SVG.

24.5.4. Éditer un modèle

Vous pouvez éditer le modèle sur lequel vous travaillez, en redéfinissant la chaîne de traitements et les relations entre algorithmes et données d’entrée.

Si vous faites un clic-droit sur un algorithme dans le canevas, le menu contextuel suivant apparaîtra :

../../../_images/modeler_right_click.png

Fig. 24.26 Clic-droit sur un algorithme

Choisissez l’option Supprimer pour supprimer l’algorithme sélectionné. Un algorithme ne peut être enlevé que si aucun autre algorithme ne dépend de lui, c’est-à-dire si aucune de ses sorties n’est utilisée par ailleurs. Si vous tentez de supprimer un algorithme utilisé par ailleurs, le message d’avertissement suivant s’affichera :

../../../_images/cannot_delete_alg.png

Fig. 24.27 Impossible de supprimer l’algorithme

En sélectionnant l’option Editer…, le dialogue de paramétrage de l’algorithme s’affichera, ce qui vous permettra de modifier les entrées et les valeurs des paramètres. Tous les éléments d’entrée disponibles dans le modèle n’apparaîtront pas comme des entrées disponibles. Les couches ou les valeurs générées à une étape plus avancée du flux de travail défini par le modèle ne seront pas disponibles si elles provoquent des dépendances circulaires.

Sélectionnez les nouvelles valeurs et validez avec le bouton OK. Les liens entre les éléments du modèle seront actualisés sur le canevas du modeleur.

ajouter commentaire… vous permet d’ajouter un commentaire à l’algorithme pour mieux décrire le comportement.

Un modèle peut être exécuté partiellement en désactivant certains de ses algorithmes. Pour ce faire, sélectionnez l’option désactiver dans le menu contextuel qui apparaît lorsque l’on clique avec le bouton droit de la souris sur un élément de l’algorithme. L’algorithme sélectionné, et tous ceux du modèle qui en dépendent, seront affichés en gris et ne seront pas exécutés en tant que partie du modèle.

../../../_images/deactivated.png

Fig. 24.28 Modèle dont un algorithme a été désactivé

Si vous faîtes un clic-droit sur un algorithme qui n’est pas actif, vous verrez alors l’option Activer du menu que vous pouvez utiliser pour le rendre actif.