` `

IGU QGIS

Cuando QGIS se inicia, se presenta con la Interfaz Gráfica de Usuario como se muestra en la imagen (los números del 1 al 5 en círculos amarillos son explicados más adelante)

../../../_images/startup.png

Interfaz Gráfica de Usuario de QGIS con datos de muestra de Alaska

Nota

Las decoraciones de las ventanas (barra de título, etc.) pueden ser distintas dependiendo de su sistema operativo y su gestor de ventanas.

La Interfaz Gráfica de Usuario de QGIS está dividida en cinco componentes:

  1. Barra de Menú

  2. Barras de herramientas

  3. Paneles

  4. Vista del mapa

  5. Barra de Estado

Estos cinco componentes de la interfaz de QGIS están descritos con más detalle en las siguientes secciones. Dos secciones más muestran atajos de teclado y ayuda contextual.

Paneles y Barras de Herramientas

From the View menu (or kde Settings), you can switch on and off QGIS widgets (Panels ‣) or toolbars (Toolbars ‣). You can (de)activate any of them by right-clicking the menu bar or a toolbar and choose the item you want. Each panel or toolbar can be moved and placed wherever you feel comfortable within QGIS interface. The list can also be extended with the activation of Core or external plugins.

Barras de herramientas

La barra de herramientas proporciona acceso a la mayoría de las mismas funciones como las de los menús, y herramientas adicionales para interactuar con el mapa. Cada elemento de la barra de herramientas tiene ayuda emergente disponible. Mantenga el puntero del ratón sobre el elemento y una breve descripción del propósito de la herramienta se mostrará.

Every toolbar can be moved around according to your needs. Additionally, they can be switched off using the right mouse button context menu, or by holding the mouse over the toolbars.

../../../_images/toolbars1.png

The Toolbars menu

Truco

Restauración de barras de herramientas

If you have accidentally hidden a toolbar, you can get it back by choosing menu option View ‣ Toolbars ‣ (or kde Settings ‣ Toolbars ‣). If for some reason a toolbar (or any other widget) totally disappears from the interface, you’ll find tips to get it back at restoring initial GUI.

Paneles

Besides toolbars, QGIS provides by default many panels to work with. Panels are special widgets that you can interact with (selecting options, checking boxes, filling values...) in order to perform a more complex task.

../../../_images/panels.png

El menú de paneles

Below are listed default panels provided by QGIS:

Vista del mapa

Also called Map canvas, this is the “business end” of QGIS — maps are displayed in this area. The map displayed in this window will depend on the vector and raster layers you have chosen to load.

When you add a layer (see e.g. Opening Data), QGIS automatically looks for its Coordinate Reference System (CRS) and zooms to its extent if you work in a blank QGIS project. The layer’s CRS is then applied to the project. If there are already layers in the project, and in the case the new layer has the same CRS as the project, its features falling in the current map canvas extent will be visualized. If the new layer is in a different CRS from the project’s, you must Enable on-the-fly CRS transformation from the Project ‣ Project Properties ‣ CRS (see Define On The Fly (OTF) CRS Transformation). The added layer should now be visible if data are available in the current view extent.

The map view can be panned, shifting the focus of the map display to another region, and it can be zoomed in and out. Various other operations can be performed on the map as described in the Barras de herramientas description. The map view and the legend are tightly bound to each other — the maps in view reflect changes you make in the legend area.

Truco

Zum al mapa con la rueda del ratón

Puede utilizar la rueda del ratón para acercar y alejar zum en el mapa. Coloque el cursor del ratón dentro del mapa y gire la rueda hacia adelante (hacia la derecha) para acercar y hacia atrás (hacia usted) para alejarlo. El zum se centra en la posición del cursor del ratón. Puede personalizar el comportamiento del zum de la rueda del ratón usando la pestaña Herramientas del mapa bajo el menú Configuración‣ Opciones

Truco

Desplazar el mapa con las teclas de dirección y barra de espaciadora

Puede utilizar las teclas de flechas para desplazar el mapa. Coloque el cursor dentro del mapa y haga clic en la tecla de flecha a la derecha para desplazarse al este, tecla de flecha izquierda para el oeste, flecha arriba para el norte y flecha abajo al sur. Puede también desplazar el mapa utilizando la barra espaciadora o al hacer clic en la rueda del ratón: basta con mover el ratón mientras mantiene pulsada la barra espaciadora o haga clic en la rueda del ratón.

Barra de Estado

The status bar provides you with general information about the map view, and actions processed or available and offers you tools to manage the map view.

On the left side of the status bar, you can get a summary of actions you’ve done (such as selecting features in a layer, removing layer) or a long description of the tool you are hovering over (not available for all tools). On startup, the bar status also informs you about availability of new or upgradeable plugins (if checked in Plugin Manager settings).

In case of lengthy operations, such as gathering of statistics in raster layers or rendering several layers in map view, a progress bar is displayed in the status bar to show the current progress of the action.

The tracking Coordinate option shows the current position of the mouse, following it while moving across the map view. You can set the unit (and precision) to use in the project properties, General tab. Click on the small button at the left of the textbox to toggle between the Coordinate option and the extents Extents option that displays in map units, the coordinates of the current lower leftmost and upper rightmost points of the map view, as you pan and zoom in and out.

Next to the coordinate display you will find the Scale display. It shows the scale of the map view. If you zoom in or out, QGIS shows you the current scale. There is a scale selector, which allows you to choose among predefined and custom scales to assign to the map view.

On the right side of the scale display you can define a current magnification level for your map view. This allows to zoom in to a map without altering the map scale, making it easier to accurately tweak the positions of labels and symbols. The magnification level is expressed as a percentage. If the Magnifier has a level of 100%, then the current map is not magnified. Additionally, a default magnification value can be defined within Settings ‣ Options ‣ Rendering ‣ Rendering behaviour, which is very useful for high resolution screen to avoid too small symbols.

To the right of the magnifier tool you can define a current clockwise rotation for your map view in degrees.

On the right side of the status bar, there is a small checkbox which can be used to temporarily prevent layers being rendered to the map view (see section Renderizado).

To the right of the render functions, you find the projectionDisabled Current CRS: icon with the EPSG code of the current project CRS. Clicking on this lets you Enable ‘on the fly’ CRS transformation properties for the current project and apply another CRS to the map view.

Finally, the messageLog Messages button opens the Log Messages Panel which informs you on underlying process (QGIS startup, plugins loading, processing tools...)

Truco

Calcular la escala correcta de su lienzo de mapa

When you start QGIS, the default CRS is WGS 84 (epsg 4326) and units are degrees. This means that QGIS will interpret any coordinate in your layer as specified in degrees. To get correct scale values, you can either manually change this setting, e.g. to meters, in the General tab under Project ‣ Project Properties, or you can use the projectionDisabled Current CRS: icon seen above. In the latter case, the units are set to what the project projection specifies (e.g., +units=us-ft).

Note that CRS choice on startup can be set in Settings ‣ Options ‣ CRS.