` `

Configuración QGIS

QGIS is highly configurable through the Settings menu. Choose between Options, Project Properties and Customization.

Nota

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described below could be in the Project or the Settings menu.

Opciones

options Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ options Options. You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

The tabs where you can customize your options are described below.

Configuración general

Aplicación

  • Select the Style (QGIS restart required) selectString and choose between ‘Oxygen’, ‘Windows’, ‘Motif’, ‘CDE’, ‘Plastique’ and ‘Cleanlooks’.
  • Define the Icon theme selectString. It can be ‘default’ or ‘Night Mapping’.
  • Define the Icon size selectString.
  • Define the Font and its Size. The font can be radioButtonOn Qt default or a user-defined one.
  • Cambiar el Límite de tiempo para mensajes o diálogos con tiempo selectString.

  • checkbox Ocultar la pantalla de bienvenida al iniciar la aplicación

  • checkbox Mostrar consejos al iniciar

  • checkbox Check QGIS version at startup to keep you informed if a newer version is released
  • checkbox Cajas de grupo al estilo QGIS

  • checkbox Use native color chooser dialogs (see Selector de color)
  • checkbox Use live-updating color chooser dialogs (see Selector de color)
  • checkbox Canvas rotation support (restart required)

Los archivos de proyecto

  • Open project on launch selectString (choose between ‘New’, ‘Most recent’, ‘Welcome Page’, and ‘Specific’). When choosing ‘Specific’ use the browseButton to define the project to use by default. The ‘Welcome Page’ displays a list of recent projects with screenshot.
  • checkbox Crear nuevo proyecto desde el proyecto predeterminado. Tiene la posibilidad de presionar Establecer el actual proyecto como predeterminado o sobre Restablecer el predeterminado. Puede navegar a través de sus archivos y definir un directorio donde se encuentra las plantillas definidas por el usuario. Esto se añadirá a Proyecto ‣ Nueva plantilla de formulario. Si activa primero checkbox Crear nuevo proyecto desde proyecto predeterminado y entonces guarde un proyecto en l la carpeta de las plantillas de proyecto.

  • checkbox Solicitar guardar proyectos y fuentes de datos modificadas cuando sea necesario

  • checkbox Pedir confirmación cuando se va a eliminar una capa

  • checkbox Avisar cuando se abra un proyecto guardado con una versión anterior de QGIS

  • Enable macros selectString. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

System Settings

SVG paths

Add or Remove Path(s) to search for Scalable Vector Graphic (SVG) symbols. These SVG files are then available to symbolize features or decorate your map composition.

Rutas de complemento

Add or Remove Path(s) to search for additional C++ plugin libraries

QSettings

It helps you Reset user interface to default settings (restart required) if you made any customization.

Entorno

Variables de entorno del sistema ahora se puede ver, y muchos lo configuran en el grupo Entorno (ver figure_environment_variables). Esto es útil para las plataformas, como Mac, donde una aplicación GUI no heredan necesariamente entorno del casco del usuario. También es útil para configurar y visualizar las variables de entorno para los conjuntos de herramientas externas controladas por la caja de herramientas de procesamiento (por ejemplo, SAGA, GRASS), y para activar la salida de depuración para secciones específicas del código fuente.

  • checkbox Utilizar variables personalizadas (requiere reiniciar - incluir separadores). Puede [Añadir] y [Borrar] variables. Las variables de entorno ya definidas se muestran en Variables de entorno actuales, y es posible filtrarlos activando checkbox Mostrar sólo variables de QGIS específicas.

../../../_images/sys-env-options.png

Variables del ambiente del sistema en QGIS

Data Sources Settings

Atributos de entidades espaciales y tabla

  • checkbox Open attribute table in a dock window
  • Copy features as ‘Plain text, no geometry’, ‘Plain text, WKT geometry’, or ‘GeoJSON’ when pasting features in other applications.
  • Attribute table behavior selectString: set filter on the attribute table at the opening. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Default view: define the view mode of the attribute table at every opening. It can be ‘Remember last view’, ‘Table view’ or ‘Form view’.
  • Attribute table row cache selectNumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representación de valores NULOS. Aquí, puede definir un valor para los datos de campos que tienen un valor NULO.

Truco

Improve opening of big data attribute table

When working with layers with big amount of records, opening the attribute table may be slow as the dialog request all the rows in the layer. Setting the Attribute table behavior to Show features visible on map will make QGIS request only the features in the current map canvas when opening the table, allowing a quick data loading.

Note that data in this attribute table instance will be always tied to the canvas extent it was opened with, meaning that selecting Show All Features within such a table will not display new features. You can however update the set of displayed features by changing the canvas extent and selecting Show Features Visible On Map option in the attribute table.

Manejo de fuente de datos

  • Scan for valid items in the browser dock selectString. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectString. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Solicitar subcapas raster al abrir. Algunas subcapas raster soportadas — se les llama subdataset en GDAL. Un ejemplo son los archivos netCDF — si hay muchos variables netCDF, GDAL ve cada variable como un subconjunto de datos. La opción le permite controlar cómo lidiar con subcapas cuando se abre un archivo con subcapas. Dispone de las siguientes opciones:

    • ‘Siempre’: Siempre preguntar (Si hay subcapas existentes)

    • ‘Si es necesario’: Preguntar si la capa no tiene bandas, pero tiene subcapas

    • ‘Nunca’: Nunca preguntar, no se cargará nada

    • ‘Cargar todo’: Nunca preguntar, pero cargar todas las subcapas

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Añadir capas PostGIS con doble clic y seleccionar en modo extendido

  • checkbox Añadir capas de Oracle con doble clic y seleccionar en modo extendido

  • checkbox Ejecutar expresiones en el lado del servidor si es posible

Hidden Browser Path

This widget lists all the folder you chose to hide from the Browser panel. Removing a folder from the list will make it available in the Browser panel.

Rendering Settings

../../../_images/rendering_menu.png

Rendering tab of Project Properties dialog

Comportamiento de presentación

  • checkbox Por defecto las nuevas capas añadidas al mapa se deben mostrar

  • checkbox Utilizar el cacheo de presentación en lo posible a la velocidad de regeneración

  • checkbox Representación de capas en paralelo utilizando muchos núcleos CPU

  • checkbox Máximo de núcleos a utilizar

  • Intervalo de actualización del mapa (por defecto 250 ms)

  • checkbox Habilitar simplificación de objetos espaciales por defecto a las nuevas capas añadidas

  • Simplificación del umbral

  • Simplification algorithm: This option performs a local “on-the-fly” simplification on feature’s and speeds up geometry rendering. It doesn’t change the geometry fetched from the data providers. This is important when you have expressions that use the feature geometry (e.g. calculation of area) - it ensures that these calculations are done on the original geometry, not on the simplified one. For this purpose, QGIS provides three algorithms: ‘Distance’ (default), ‘SnapToGrid’ and ‘Visvalingam’.
  • checkbox Simplify on provider side if possible: the geometries are simplified by the provider (PostGIS, Oracle...) and unlike the local-side simplification, geometry-based calculations may be affected
  • Escala máxima a la que la capa se debe simplificar

  • doubleSpinBox Magnification level (see the magnifier)

Nota

Besides the global setting, feature simplification can be set for any specific layer from its Layer properties ‣ Rendering menu.

Calidad de representación

  • checkbox Hacer que las líneas se muestren menos quebradas a expensas del rendimiento de la representación

Curve segmentation

  • Segmentation tolerance: this setting controls the way circular arcs are rendered. The smaller maximum angle (between the two consecutive vertices and the curve center, in degrees) or maximum difference (distance between the segment of the two vertices and the curve line, in map units), the more straight line segments will be used during rendering.

  • Tolerance type: it can be ‘Maximum angle’ or ‘Maximum distance’

    Rásters

  • Con Selección de la banda RGB, puede definir el numero para la banda Roja, Verde y Azul.

Mejora de contraste

  • Single band gray selectString. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Límites (mínimo/máximo) selectString. Las opciones son ‘Corte del conteo acumulativo’, ‘Min/Máx’, ‘Media +/- desviación estándar’.

  • Límite para corte del conteo acumulativo de píxeles

  • Multiplicador de la desviación estándar

Depuración

  • checkbox Refrescar lienzo de mapa

Colors Settings

Este menú le permite añadir algunos colores personalizados que puede encontrar en cada ventana de diálogo de color de la representación. Verá un conjunto de colores predefinidos en la pestaña: se puede eliminar o editar todos ellos. Por otra parte se puede añadir el color que se desea y realizar algunas operaciones de copiar y pegar. Finalmente se puede exportar el conjunto de colores como un archivo gpl o importarlos.

Canvas and Legend Settings

Apariencia del mapa predeterminado (anulado por las propiedades del proyecto)

  • Definir un Color de selección y un Color de fondo.

Leyenda de capa

  • Double click action in legend selectString. You can either ‘Open layer properties’, ‘Open attribute table’ or ‘Open layer styling dock’ with the double click.
  • Lo siguiente es posible Estilos de elementos de la leyenda:

    • checkbox Comenzar el nombre de las capas con mayúsculas

    • checkbox Poner en negrita los nombres de la capa

    • checkbox Poner en negrita los nombres de grupo

    • checkbox Mostrar nombres de atributos de clasificación

    • checkbox Crear iconos de ráster (puede ser lento)

    • you can also set the WMS getLegendGraphic Resolution

Map tools Settings

This tab offers some options regarding the behavior of the Identify tool.

  • Search radius for identifying and displaying map tips is a tolerance distance within which the identify tool will depict results as long as you click within this tolerance.
  • Highlight color allows you to choose with which color should features being identified be highlighted.
  • Buffer determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width determines how thick should the outline of a highlighted object be.

Herramienta de medición

  • Definir Color de la banda de medida para herramienta de medida

  • Definir Lugares decimales

  • checkbox Keep base unit to not automatically convert large numbers (e.g., meters to kilometers)
  • Preferred distance units radioButtonOn (‘Meters’, ‘Kilometers’, ‘Feet’, ‘Yards’, ‘Miles’, ‘Nautical Miles’, ‘Degrees’ or ‘Map Units’ )
  • Preferred area units radioButtonOn (‘Square meters’, ‘Square kilometers’, ‘Square feet’, ‘Square yards’, ‘Square miles’, ‘Hectares’, ‘Acres’, ‘Square nautical miles’, ‘Square degrees” or ‘Map Units’)
  • Preferred angle units radioButtonOn (‘Degrees’, ‘Radians’, ‘Gon/gradians’, ‘Minutes of arc’, ‘Seconds of arc’ or ‘Turns/revolutions’)

Mover y zum

  • Define a Zoom factor for zoom tools or wheel mouse

Escalas predefinidas

Here, you find a list of predefined scales. With the signPlus and signMinus buttons you can add or remove your personal scales. You can also import or export scales from/to a .XML file. Note that you still have the possibility to remove your changes and reset to the predefined list.

Composer Settings

Predeterminados de la composición

You can define the Default font used within the print composer.

Apariencia de la cuadrícula

  • Definir el Estilo de cuadrícula selectString (‘Sólido, ‘Puntos’, ‘Cruces’)

  • Definir el Color de la cuadrícula

Valores predeterminados de la cuadrícula y guía

  • Define the Grid spacing selectNumber
  • Definir el Desplazamiento de cuadrícula selectNumber para x y y

  • Define the Snap tolerance selectNumber

Rutas del diseñador

  • Define Path(s) to search for extra print templates: a list of folders with custom composer templates to use while creating new one.

Configuración de digitalización

This tab helps you configure general settings when editing vector layer (attributes and geometry).

Creación de entidades espaciales

  • checkbox Suppress attribute form pop-up after feature creation
  • checkbox Reutilizar últimos valores de atributos introducidos

  • Validar geometrías. Editar lineas y polígonos complejos con muchos nodos puede resultar a una representación muy lenta. Esto se debe a los procesos de validación por defecto en QGIS puede tomar mucho tiempo. Para acelerar la representación, es posible seleccionar la validación de geometría GEOS (a partir de GEOS 3.3) o a pagarlo. La validación de geometría GEOS es mucho más rápido, pero la desventaja es que sólo el primer problema de geometría será reportado.

Banda de medición

  • Define Rubberband Line width, Line color and Fill color
  • Don’t update rubberband during node editing

Autoensamblado

  • checkbox Abrir opciones de autoensamblado en una ventana adosada(requiere reiniciar QGIS)

  • Define Default snap mode selectString (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Definir Tolerancia de autoensamblado predeterminado en unidades de mapa o píxeles

  • Definir el Radio de búsqueda para edición de vértices en unidades de mapa o píxeles

Marcar vértices

  • checkbox Mostrar marcadores sólo para los objetos espaciales seleccionados

  • Definir vértice Estilo de marcador selectString (‘Cruz’ (predeterminado), ‘Círculo semitransparente’ o ‘Nada’)

  • Definir vértice Tamaño de marcador

Herramienta de desplazamiento de curva

The next 3 options refer to the offsetCurve Offset Curve tool in Digitalización avanzada. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Join style: ‘Round’, ‘Mitre’ or ‘Bevel’
  • Segmentos del cuadrante

  • Límite Miter

Configuración de GDAL

GDAL es una biblioteca de intercambio de datos para archivos ráster. Es esta pestaña, puede Editar opciones de creación y Editar opciones de pirámides de los formatos ráster. Tu puedes definir que controlador GDAL se va a utilizar para un formato ráster, como en algunos casos más de un controlador está disponible.

Configuraciones SRC

SRC predeterminado para nuevos proyectos

  • radioButtonOff Don’t enable ‘on the fly’ reprojection
  • radioButtonOn Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radioButtonOff Enable ‘on the fly’ reprojection by default
  • Seleccionar un SRC y Empezar siempre nuevos proyectos con este SRC

SRC para nuevas capas

Esta área permite definir la acción a realizar cuando una nueva capa es creada, o cuando una capa sin SRC es cargada.

  • radioButtonOn Prompt for CRS
  • radioButtonOff Use project CRS
  • radioButtonOff Usar el SRC predeterminado

Por defecto transformación de datum

  • checkbox Preguntar por la trasformación del datum cuando el predeterminado no este definido

  • With the ‘on-the-fly’ CRS transformation enabled and the above option checked, adding layers of different CRS opens the Select datum transformations dialog. This offers you to select the most appropriate transformation settings. Validating this dialog with the ‘Remember selection’ option checked populates the table under CRS ‣ Default datum transformations with information about ‘Source CRS’ and ‘Destination CRS’ as well as ‘Source datum transform’ and ‘Destination datum transform’. From now, QGIS automatically uses the selected datum transformation for further transformation between these two CRSs until you signMinus remove it from the list.

    You can use the signPlus button to add a datum transformation if you know its parameters (source and destination ellipsoids and the numbers from the transformation table). You then need to manually enter each setting.

Nota

For more information on how QGIS handles layers projection, please read the dedicated section at Trabajar con Proyecciones.

Locale Settings

  • checkbox Override system locale and Locale to use instead
  • Información acerca del idioma del sistema

Authentication Settings

In the Authentication tab you can set authentication configurations and manage PKI certificates. See Sistema de autenticación for more details.

Network Tab

General

  • Definir Dirección de búsqueda de WMS, por omisión es http://geopole.org/wms/search?search=\%1\&type=rss

  • Definir Expiró el tiempo para solicitudes de red - por omisión 60000

  • Define Default expiration period for WMS Capabilities (hours) - default is 24
  • Definir Periodo de expiración predeterminada para teselas WMS-C/WMTS (en horas) - por omisión 24

  • Define Max retry in case of tile or feature request errors
  • Definir Agente- Usuario

../../../_images/proxy-settings.png

Configurar proxy en QGIS

Configuración de caché

Definir la configuración del caché Directorio y un Tamaño.

  • checkbox Usar proxy para acceso web y definir ‘Servidor’, ‘Puerto’, ‘Usuario’, y ‘Contraseña’.

  • Set the Proxy type selectString according to your needs.
    • Default Proxy: Proxy se determina con base en el proxy de aplicación que establece el uso

    • Socks5Proxy: Proxy genérico para cualquier tipo de conexión. Soporta TCP, UDP, unión a un puerto (conexiones entrantes) y autenticación.

    • HttpProxy: Implementado con el comando “CONNECT”, sólo admite conexiones TCP salientes; admite la autenticación.

    • HttpCachingProxy: Implementando el uso de comandos HTTP normales, es útil sólo en el contexto de peticiones HTTP.

    • FtpCachingProxy: Implementar el uso de un proxy FTP, es útil sólo en el contexto de las peticiones FTP.

Excluir algunas URLs se puede agregar a la caja de texto debajo los valores del proxy (ver Figure_Network_Tab).

If you need more detailed information about the different proxy settings, please refer to the manual of the underlying QT library documentation at http://doc.qt.io/qt-4.8/qnetworkproxy.html#ProxyType-enum

Truco

Utilizar proxies

Using proxies can sometimes be tricky. It is useful to proceed by ‘trial and error’ with the above proxy types, to check if they succeed in your case.

Variables Settings

The Variables tab lists all the variables available at the global-level.

It also allows the user to manage global-level variables. Click the signPlus button to add a new custom global-level variable. Likewise, select a custom global-level variable from the list and click the signMinus button to remove it.

More information about variables in the Variables section.

Configuración avanzada

Depending on your OS, all the settings related to QGIS (UI, tools, data providers, default values, plugins options...) are saved:

  • nix in a text file: $HOME/.config/QGIS/QGIS2.conf
  • osx in the properties list file: $HOME/Library/Preferences/org.qgis.qgis.plist
  • win in the registry under: HKEY\CURRENT_USER\Software\QGIS\qgis

The Advanced tab offers you in a single place, regardless your OS, means to manage these settings through the Advanced Settings Editor. After you promise to be careful, the widget is populated with a tree of all QGIS settings, which you can directly edit.

Advertencia

Avoid using the Advanced tab settings blindly

Be careful while modifying items in this dialog given that changes are automatically applied. Doing changes without knowledge can break your QGIS installation in various ways.

Propiedades del proyecto

In the properties window for the project under Project ‣ Project Properties (or kde Settings ‣ Project Properties), you can set project-specific options.

The project-specific options overwrite their equivalent in the options described above.

  • In the General tab, the general settings let you:

    • dé un texto al título del proyecto aparte de la ruta del archivo del proyecto

    • escoge el color a usar para objetos espaciales cuando son seleccionados

    • escoger el color de fondo: el color a usar para la tela de fondo del mapa

    • set whether the path to layers in the project should be saved as absolute (full) or as relative to the project file location. You may prefer relative path when both layers and project files can be moved or shared or if the project is accessed from computers on different platforms.
    • choose to avoid artifacts when project is rendered as map tiles. Note that checking this option can lead to performance degradation.

    Calculating areas and distances is a common need in GIS. However, these values are really tied to the underlying projection settings. The Measurements frame lets you control these parameters. You can indeed choose:

    • the ellipsoid to use: it can be an existing one, a custom one (you’ll need to set values of the semi-major and semi-minor axis) or None/Planimetric.
    • the units for distance measurements for length and perimeter and the units for area measurements. These settings, which default to the units set in QGIS options but then overrides it for the current project, are used in:
      • Attribute table field update bar
      • Cálculos de calculadora de campo

      • Identify tool derived length, perimeter and area values
      • Default unit shown in measure dialog

    The Coordinate display allows you to choose and customize the format of units to use to display the mouse coordinate in the status bar and the derived coordinates shown via the identify tool.

    Finally, you can define a project scale list, which overrides the global predefined scales.

../../../_images/project_general.png

General tab of Project Properties dialog

  • The CRS tab enables you to choose the Coordinate Reference System for this project, and to enable on-the-fly re-projection of raster and vector layers when displaying layers from a different CRS. For more information on projection’s handling in QGIS, please read Trabajar con Proyecciones section.

  • With the Identify layers tab, you set (or disable) which layers will respond to the identify tool. By default, layers are set queryable.

    You can also set whether a layer should appear as read-only, meaning that it can not be edited by the user, regardless of the data provider’s capabilities. Although this is a weak protection, it remains a quick and handy configuration to avoid end-users modifying data when working with file-based layers.

  • The Default Styles tab lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colors assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.

  • The tab OWS Server allows you to configure your project in order to publish it online. Here you can define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions. More information available in section Prepare a project to serve and subsequent.

  • The Macros tab is used to edit Python macros for projects. Currently, only three macros are available: openProject(), saveProject() and closeProject().

../../../_images/macro.png

Definición macro en QGIS

  • El panel:guilabel:Relaciones es utilizado para definir relaciones 1:n. Las relaciones están definidas en el diálogo de propiedades del proyecto. Una vez que existen las relaciones de una capa, un nuevo elemento de la interfaz de usuario en la vista del formulario (por ejemplo al identificar un elemento espacial y abrir el formulario) mostrará una lista de las entidades relacionadas. Este proporciona un poderosa forma para expresar, por ejemplo la inspección de la longitud de una tubería o el segmento de carretera. Se puede encontrar más información acerca de relaciones 1:n y soporte en la sección Creating one or many to many relations.

  • In the Data Sources tab, you can:
    • checkbox Evaluate default values on provider side: When adding new features in a PostGreSQL table, fields with default value constraint are evaluated and populated at the form opening, and not at the commit moment. This means that instead of an expression like nextval('serial'), the field in the Add Feature form will display expected value (e.g., 25).
    • checkbox Automatically create transaction groups where possible: When this mode is turned on, all (postgres) layers from the same database are synchronised in their edit state, i.e. when one layer is put into edit state, all are, when one layer is committed or one layer is rolled back, so are the others. Also, instead of buffering edit changes locally, they are directly sent to a transaction in the database which gets committed when the user clicks save layer. Note that you can (de)activate this option only if no layer is being edited in the project.
  • The Variables tab lists all the variables available at the project’s level (which includes all global variables). Besides, it also allows the user to manage project-level variables. Click the signPlus button to add a new custom project-level variable. Likewise, select a custom project-level variable from the list and click the signMinus button to remove it. More information on variables usage in the General Tools Variables section.

Personalización

The customization dialog lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you want to provide your end-users with a ‘light’ version of QGIS, containing only the icons, menus or panels they need.

Nota

Antes de aplicar los cambios, debe reiniciar QGIS.

../../../_images/customization.png

El diálogo de Personalización

Ticking the checkbox Enable customization checkbox is the first step on the way to QGIS customization. This enables the toolbar and the widget panel from which you can uncheck and thus disable some GUI items.

The configurable item can be:

With select Switch to catching widgets in main application, you can click on an item in QGIS interface that you want to be hidden and QGIS automatically unchecks the corresponding entry in the Customization dialog.

Once you setup your configuration, click [Apply] or [Ok] to validate your changes. This configuration becomes the one used by default by QGIS at the next startup.

The modifications can also be saved in a .ini file using fileSave Save To File button. This is a handy way to share a common QGIS interface among multiple users. Just click on fileOpen Load from File from the destination computer in order to import the .ini file. You can also run command line tools and save various setups for different use cases as well.

Truco

Easily restore predefined QGIS

The initial QGIS GUI configuration can be restored by one of the methods below:

  • unchecking checkbox Enable customization option in the Customization dialog or click the selectAllTree Check All button
  • pressing the [Reset] button in the QSettings frame under Settings ‣ Options menu, System tab
  • launching QGIS at a command prompt with the following command line qgis --nocustomization
  • setting to false the value of UI ‣ Customization ‣ Enabled variable under Settings ‣ Options menu, Advanced tab (see the warning).

In most cases, you need to restart QGIS in order to have the change applied.

Atajos de teclado

QGIS provides default keyboard shortcuts for many features. You can find them in section Barra de Menú. Additionally, the menu option Settings ‣ Configure Shortcuts... allows you to change the default keyboard shortcuts and add new keyboard shortcuts to QGIS features.

../../../_images/shortcuts.png

Define shortcut options

Configuration is very simple. Just select a feature from the list and click on :

  • [Change] and press the new combination you want to assign as new shortcut
  • [Set none] to clear any assigned shortcut
  • or [Set default] to backup the shortcut to its original and default value.

Proceed as above for any other tools you wish to customize. Once you have finished your configuration, simply [Close] the dialog to have your changes applied. You can also [Save] the changes as an .XML file and [Load] them into another QGIS installation.