` `

Herramientas generales

Ayuda de contexto

Cuando necesite ayuda sobre un tema especifico, puede acceder a la ayuda de contexto mediante el botón [Ayuda] disponible en la mayoría de diálogos – tenga en cuenta que los complementos de terceros pueden apuntar a paginas web dedicadas.

Paneles

QGIS provides by default many panels to work with. Some of these panels are described below while others may be found in different parts of the document. A complete list of default panels provided by QGIS is available at Paneles.

Panel de capas

The layers Panel lists all the layers in the project and helps you manage their visibility. A layer can be selected and dragged up or down in the legend to change the Z-ordering. Z-ordering means that layers listed nearer the top of the legend are drawn over layers listed lower down in the legend.

Nota

The Z-ordering behavior can be overridden by the Layer Order panel.

At the top of the Layers panel, a toolbar allows you to:

  • symbology Open the layer styling dock: toggle the layer styling panel on and off.
  • addGroup Añadir nuevo grupo

  • showPresets Manage Visibility: control visibility of layers and preset layers combination.
  • filterMap Filter Legend by Map Content: only the layers that are set visible and whose features intersect the current map canvas have their style rendered in the layers panel. Otherwise, a generic NULL symbol is applied to the layer. Based on the layer symbology, this is a convenient way to identify which kind of features from which layers cover your area of interest.
  • expressionFilter Filter Legend by Expression: helps you apply an expression to remove from the selected layer tree styles that have no feature satisfying the condition. This can be used for example to highlight features that are within a given area/feature of another layer. From the drop-down list, you can edit and clear the expression set.
  • expandTree Expand All or collapseTree Collapse All layers and groups in the layers panel.
  • and removeLayer Remove Layer/Group currently selected.
../../../_images/layer_toolbar.png

Barra de herramientas de capa en panel de capas

Nota

Tools to manage the layers panel are also available to layout the map and legend items of the print composer

Preset the layers visibility

The button showPresets allows you to add Presets views in the legend. Presets are a way to save and easily restore a combination of layers with their current style. To add a preset view, just set visible the layers you want, with their desired symbology, and click on showPresets button. Choose Add Preset... from the drop-down menu and give a name to the preset. The added preset is listed at the bottom of the drop-down menu and is recalled by clicking on it.

The Replace Preset ‣ option helps you overwrite a preset content with the current map view while the Remove Current Preset button deletes the active preset.

All the added presets are also present in the map composer in order to allow you to create a map layout based on your specific views (see Propiedades principales).

Overview of the context menu of the Layers panel

At the bottom of the toolbar, the main component of the Layers panel is the frame listing vector or raster layers added to the project and, those layers can be organized in groups. Depending on the item selected in the panel, a right-click shows a dedicated set of options presented below.

Opción

Capa vectorial

Capa Ráster

Grupo

zoomToLayer Zum a capa/grupo

checkbox checkbox checkbox

unchecked Mostrar vista general

checkbox checkbox

zoomActual Zum a resolución nativa (100%)

checkbox

Extender utilizando extensión actual

checkbox

removeLayer Eliminar

checkbox checkbox checkbox

duplicateLayer Duplicar

checkbox checkbox

Establecer escala de visibilidad de capa

checkbox checkbox

Zum a la escala visible

checkbox checkbox

Establecer SRC de la capa/grupo

checkbox checkbox checkbox

Establecer SRC del proyecto a partir de la capa

checkbox checkbox

Estilos ‣

checkbox checkbox

Copiar estilo

checkbox checkbox

Pegar estilo

checkbox checkbox checkbox

openTable Abrir tabla de atributos

checkbox

toggleEditing Conmutar edición

checkbox

allEdits Ediciones actuales ‣

checkbox (en modo Edición)

Guardar como...

checkbox checkbox

Guardar como archivo de definición de capa...

checkbox checkbox checkbox

Filtrar...

checkbox

unchecked Mostrar número de objetos espaciales

checkbox

Propiedades

checkbox checkbox

Mover al nivel superior

checkbox checkbox

Cambiar nombre

checkbox checkbox checkbox

Grupo seleccionado

checkbox checkbox

Establecer grupo de datos WMS

checkbox

unchecked Grupo Mutuamente Exclusivo

checkbox

addGroup Añadir grupo

checkbox

Tabla: Menú contextual de los elementos del panel de Capas

For GRASS vector layers, toggleEditing Toggle editing is not available. See section Digitalizar y editar una capa vectorial GRASS for information on editing GRASS vector layers.

Interactúe con grupos y capas

Layers in the legend window can be organized into groups. There are two ways to do this:

  1. Press the folder icon to add a new group. Type in a name for the group and press Enter. Now click on an existing layer and drag it onto the group.
  2. Select some layers, right click in the legend window and choose Group Selected. The selected layers will automatically be placed in a new group.

To bring a layer out of a group, you can drag it out, or right click on it and choose Move to top-level; the layer is placed at the same level than the group it was inside. Groups can also be nested inside other groups.

The checkbox for a group will show or hide all the layers in the group with one click.

Enabling the Mutually Exclusive Group option you can make a group have only one layer visible at the same time. Whenever a layer within the group is set visible the others will be toggled not visible.

It is possible to select more than one layer or group at the same time by holding down the Ctrl key while selecting the layers with the left mouse button. You can then move all selected layers to a new group at the same time.

You may also delete more than one layer or group at once by selecting several items with the Ctrl key and pressing Ctrl+D afterwards. This way, all selected layers or groups will be removed from the layers list.

Editing vector layer style

From the Layers panel, you have shortcuts to easily and quickly edit the layer rendering. Right-click on a vector layer and select Styles ‣ in the list in order to:

  • see the currently applied styles to the layer. In case you defined many styles for the layer, you can switch from one to another and have your layer rendering automatically updated in the map canvas.
  • copy the current style, and when applicable, paste a copied style from another layer
  • rename the current style, add a new one (which is actually a copy of the current one) or delete the current style (when multiple styles available).

Nota

The previous options are also available for raster layer.

Whether the features in the vector layer have all the same unique symbol or they are classified (in that case, the layer is displayed in a tree structure with each class as sub-item), the following options are available at layer level or class level:

  • a Edit Symbol... button to open the El Selector de Símbolo dialog and update any property (symbol, size, color...) of the layer or feature symbol. Double-clicking on a feature does also open the Symbol Selector dialog.
  • a Selector de color widget with a Color Wheel from which you can click a color and have it automatically update the symbol fill color. For convenience, Recent colors are available at the bottom of the color wheel.
  • a showAllLayers Show All Items and hideAllLayers Hide All Items to toggle on or off the visibility of all the classes of features. This avoids (un)checking items one by one.

Truco

Quickly share a layer style

From the context menu, copy the style of a layer and paste it to a group or a selection of layers: the style is applied to all the layers that are of the same type (vector vs raster) as the original layer and, in case of vector, have the same geometry type (point, line or polygon).

Working with the Legend independent layer order

There is a panel that allows you to define an independent drawing order for the layers panel. You can activate it in the menu Settings ‣ Panels ‣ Layer Order Panel. This feature allows you to, for instance, order your layers in order of importance, but still display them in the correct order (see figure_layer_order; you can notice that the airports features are displayed over the alaska polygon despite their layers placement in the Layers panel). Unchecking the checkbox Control rendering order box underneath the list of layers will cause a revert to default behavior.

../../../_images/layer_order.png

Define a legend independent layer order

Layer Styling Panel

This panel is somehow a shortcut to some of the features of the layer properties dialog. It indeed offers you a quick and handy way to define the rendering and the behavior of a layer, and to visualize its effects without opening the layer properties dialog.

Besides avoiding you dealing with the modal and blocking dialog of the layer properties, it also avoids you cluttering the screen with features dialogs given that it embeds most of them (color selector, effects properties, rule edit, label substitution...): e.g., clicking color buttons inside the layer style panel causes the color selector dialog to be opened inside the layer style panel itself rather than as a separate dialog.

From a drop-down list of current layers in the layer panel, select an item and:

  • set its symbology, transparency, and histogram in case of raster layer. These options are the same available in Dialogo de Propiedades Raster
  • set its symbology, and labels. These options are the same available in El Dialogo de las Propiedades del Vector
  • manage the associated style(s) as described in Managing Custom Styles
  • follow the whole history of changes you applied to the layer style in the current project; you can therefore cancel or restore to any state by selecting it in the list and hit [Apply] button.

Another powerful feature of this panel is the Live update checkbox. Tick it and your changes are automatically rendered in the map canvas as you go on. You no longer need to hit the [Apply] button.

../../../_images/layer_styling.png

Definir una simbología de capa desde el panel de diseño de capa

Truco

Add custom tabs to the Layer Styling panel

Using PyQGIS, you can set new tabs to manage layer properties in the Layer Styling Panel. See https://nathanw.net/2016/06/29/qgis-style-dock-part-2-plugin-panels/ for an example.

Panel de resumen estadístico

Este panel puede mostrar algunas estadísticas de capas vectoriales especificas. El panel permite al usuario elegir:

  • la capa vectorial;

  • la columna o la expresión

  • filtrar estadísticas a elementos seleccionados;

  • refrescar la información;

  • la información estadística para desplegar con el botón interior derecho.

Información estadística disponible es (depende del tipo de campo)

Estadísticas

Cadena

Entero

Coma flotante

Fecha

Número

checkbox checkbox checkbox checkbox

Contar valores distintos

checkbox     checkbox

Contar valores faltantes

checkbox     checkbox

Suma

  checkbox checkbox  

Media

  checkbox checkbox checkbox

Desviación estándar

  checkbox checkbox  

Desviación estándar en ejemplo

  checkbox checkbox  

Valor mínimo

checkbox checkbox checkbox checkbox

Valor máximo

checkbox checkbox checkbox checkbox

Rango

  checkbox checkbox checkbox

Minoría

  checkbox checkbox  

Mayoría

  checkbox checkbox  

Variedad

  checkbox checkbox  

Primer cuartil

  checkbox checkbox  

Tercer cuartil

  checkbox checkbox  

Rango intercuartil

  checkbox checkbox  

Longitud mínima

checkbox      

Longitud máxima

checkbox      

Tabla: Estadística disponible para cada tipo de campo

../../../_images/statistical_summary.png

Mostrar estadística en un campo

Panel de vista general de QGIS

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labelling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Panel de mensajes de registro

When loading or processing some operations, you can track and follow messages that appear in different tabs using the messageLog Log Messages Panel. It can be activated using the most right icon in the bottom status bar.

Panel de deshacer/rehacer

For each layer being edited, this panel shows the list of actions done, allowing to quickly undo a set of actions by simply selecting the action listed above. More details at Undo and Redo edits.

Renderizado

By default, QGIS renders all visible layers whenever the map canvas is refreshed. The events that trigger a refresh of the map canvas include:

  • Añadir una capa

  • Desplazar o hacer zoom

  • Redimensionando la ventana QGIS

  • Cambiar la visibilidad de una o varias capas

QGIS le permite controlar el proceso de representación de varias maneras.

Renderizado dependiente de la escala

Scale-dependent rendering allows you to specify the minimum and maximum scales at which a layer (raster or vector) will be visible. To set scale-dependent rendering, open the Properties dialog by double-clicking on the layer in the legend. On the General tab, tick the checkbox Scale dependent visibility checkbox and enter the Minimum (exclusive) and Maximum (inclusive) scale values.

You can also activate the scale dependent visibility on a layer from the Layers panel. Right-click on the layer and in the context menu, select Set Layer Scale Visibility.

The mapIdentification Set to current canvas scale button helps you use the current map canvas scale as boundary of the range visibility.

Nota

When a layer is not rendered in the map canvas due to the map scale out of its visibility scale range, the layer is greyed in the Layers panel and a new option Zoom to Visible Scale appears in the layer context menu. Select it and the map is zoomed to the layer’s nearest visibility scale.

Controlar el renderizado del mapa

Map rendering can be controlled in various ways, as described below.

Suspender el renderizado

To suspend rendering, click the checkbox Render checkbox in the lower right corner of the status bar. When the checkbox Render checkbox is not checked, QGIS does not redraw the canvas in response to any of the events described in section Renderizado. Examples of when you might want to suspend rendering include:

  • Añadir muchas capas y simbolizarlas antes de dibujar

  • Añadir una o más capas grandes y establecer la dependencia de escala antes de dibujar

  • Añadir una o más capas grandes y hacer zoom a una vista específica antes de dibujar

  • Cualquier combinación de la anteriores

Marcar la casilla checkbox Renderizar habilita el renderizado y origina un refresco inmediato del lienzo del mapa.

Configurar la opción de añadir una capa

Puede establecer una opción para cargar siempre las nuevas capas sin dibujarlas. Esto significa que las capas se añadirán al mapa pero su casilla de visibilidad en el panel Capas no estará marcada de forma predeterminada. Para establecer esta opción, seleccione la opción de menú Configuración ‣ Opciones y haga clic en la pestaña Representación. Desmarque la casilla checkbox Por omisión, las nuevas capas añadidas al mapa se deben visualizar. Cualquier capa añadida posteriormente al mapa estará desactivada (invisible) por omisión.

Detener el renderizado

Para detener el dibujado del mapa, presione la tecla ESC. Esto detendrá el refresco del lienzo del mapa y dejará el mapa parcialmente dibujado. Puede que tarde un poco desde que se presiona la tecla ESC hasta que se detenga el dibujado del mapa.

Nota

Actualmente no es posible detener la representación — esto se desactivó en el paso a Qt4 debido a problemas y cuelgues de la Interfaz de Usuario (IU).

Influir en la calidad del renderizado

QGIS has an option to influence the rendering quality of the map. Choose menu option Settings ‣ Options, click on the Rendering tab and select or deselect checkbox Make lines appear less jagged at the expense of some drawing performance.

Acelerar renderizado

Hay algunos ajustes que le permiten mejorar la velocidad de presentación. Abrir el diálogo de las opciones de QGIS usando Configuración‣ Opciones, ir a la pestaña guilabel:Representación y seleccionar o deseleccionar las siguientes casillas de verificación:

  • checkbox Usar cacheado de representación cuando sea posible para acelerar redibujados

  • checkbox Render layers in parallel using many CPU cores and then set the checkbox Max cores to use.
  • The map renders in the background onto a separate image and each checkbox Map Update interval, the content from this (off-screen) image will be taken to update the visible screen representation. However, if rendering finishes faster than this duration, it will be shown instantaneously.
  • With checkbox Enable Feature simplification by default for newly added layers, you simplify features’ geometry (less nodes) and as a result, they quickly display. Be aware that you can also face rendering inconsistencies.

Save and Share Layer Properties

Managing Custom Styles

When a vector layer is added to map canvas, QGIS uses by default a random symbol/color to render its features. You can however set a default symbol in Project ‣ Project Properties ‣ Default styles that will be applied to each newly added layer according to its geometry type.

But, most of the time, you’d prefer to have a custom and more complex style that can be applied automatically or manually (with less efforts) to the layers. You can achieve this goal using the Style combobox at the bottom of the Layer Properties dialog. This combobox provides you with functions to create, load and manage styles.

A style stores any information set in the layer properties dialog to render or interact with the features (including symbology, labeling, action, diagram... settings) for vector layer, or the pixels (band or color rendering, transparency, pyramids, histogram ...) for raster.

../../../_images/style_combobox.png

Vector layer style combobox options

By default, the style applied to a loaded layer is named default. Once you have got the ideal and appropriate rendering for your layer, you can save it by clicking the selectString Style combobox and choose:

  • Rename Current: The active style gets renamed and updated with the current options
  • Add: A new style is created using the current options. By default, it will be saved in the QGIS project file. See below to save the style in another file or a database
  • Remove: delete unwanted style, in case you have more than one style defined for the layer.

At the bottom of the Style drop-down list, you see the styles set for the layer and the active one is checked.

Note that each time you validate the layer properties dialog, the active style is updated with the changes you’ve done.

You can create as many styles as you wish for a layer but only one can be active at a time. Combined to layer visibility preset, this offers a quick and powerful way to manage complex projects with few layers (no need to duplicate any layer in the map legend).

Truco

Manage styles from layer context menu

Right-click on the layer in Layers Panel to add, rename or remove layer style.

Storing Style in a File or a Database

While created styles from the Style combobox are by default saved inside the project and can be copied and pasted from layer to layer in the project, it’s also possible to save them outside the project so that they can be loaded in another project.

Save in plain text file

Clicking the selectString Style ‣ Save Style, you can save the style as a:

  • QGIS layer style file (.qml)
  • or SLD file (.sld), only available for vector layers.

Used on file based format layers (.shp, .tab...), Save as Default generates a .qml file along the layer (with the same name). SLDs can be exported from any type of renderer – single symbol, categorized, graduated or rule-based – but when importing an SLD, either a single symbol or rule-based renderer is created. That means that categorized or graduated styles are converted to rule-based. If you want to preserve those renderers, you have to stick to the QML format. On the other hand, it can be very handy sometimes to have this easy way of converting styles to rule-based.

Save in database

Vector layer style can also be stored in a database if the layer datasource is a database provider. Supported formats are PostGIS, GeoPackage, SpatiaLite, MSSQL and Oracle. The layer style is saved inside a table (named layer_styles) of the database. Click on Save Style ‣ Save in database item then fill in the dialog to define a style name, add a description, a .ui file if applicable and check if the style should be the default style.

You can save several styles for a single table in the database. However each table can have only one default style. Default style can be saved in the layer database or in the QGIS local database, a SQLite database in the ~/.qgis2/ directory (where QGIS stores its local settings).

../../../_images/save_style_database.png

Save Style in database Dialog

Truco

Sharing style files between databases

You can only save your style in a database if the layer comes from such a database. You can’t mix databases (layer in Oracle and style in MSSQL for instance). Use instead a plain text file if you want the style to be shared among databases.

Nota

You may encounter issues to restore the layer_styles table from a PostgreSQL database backup. Follow QGIS layer_style table and database backup to fix that.

Cargar estilos

When loading a layer in QGIS, if a default style already exists for this layer, QGIS loads the layer with this style. Also Style ‣ Restore Default looks for and loads that file when pressed, replacing current style of the layer.

The Style ‣ Load Style helps you apply any saved style to a layer. While plain text file style (.sld or .qml) can be applied to any layer whatever its format is, loading styles stored in database is only possible if the layer is from the same database or the style is stored in the QGIS local database.

The Load Style from Database dialog displays a list of related styles to the layer found in the database and all the other styles saved in it, with name and description.

Truco

Quickly share a layer style within the project

You can also share layer style within a project without importing a file or database style: right-click on the layer in the Layers Panel and, from the Styles combobox , copy the style of a layer and paste it to a group or a selection of layers: the style is applied to all the layers that are of the same type (vector vs raster) as the original layer and, in case of vector, have the same geometry type (point, line or polygon).

Selector de color

The select color dialog will appear whenever you push the selectColor icon to choose a color. The features of this dialog depends on the state of the Use native color chooser dialogs parameter checkbox in Settings ‣ Options ‣ General menu. When checked, the color dialog used is the one of the OS being used. Otherwise, QGIS custom color chooser is used.

Truco

Dynamically change the color with the live-updating option

Check the Use live-updating color chooser dialogs option in the Settings ‣ Options ‣ General menu to have the color applied to your items as soon as you pick it in the color chooser dialog.

The custom color chooser dialog has four different tabs which allow you to select colors by colorBox color ramp, colorWheel color wheel, colorSwatches color swatches or colorPicker color picker (not available under osx).

Whatever method you use, the selected color is always described through color sliders for HSV (Hue, Saturation, Value) and RGB (Red, Green, Blue) values. The color is also identifiable as a HTML notation. Finally, there is an opacity slider to set transparency level.

Modifying a color is as simple as clicking in the color wheel or ramp or in any of the color parameters sliders. You can adjust such parameters with the spinbox beside or, handy, scrolling the mouse wheel over the corresponding slider. You can also typeset the color html notation.

The dialog also provides a visual comparison between the current (applied to widget) and the new (being selected) colors. Thanks to drag-and-drop, any of these colors can be saved in a slot for an easy access.

../../../_images/color_selector_ramp.png

Color selector ramp tab

With colorBox color ramp or colorWheel color wheel tab, you can browse to all possible color combinations and apply it to the item. In the colorSwatches color swatches tab, you can choose from a preselected list of color palettes:

  • Recent colors,
  • Standard colors, a user-defined list of colors set under Settings ‣ Options ‣ Colors menu
  • or Project colors, a user-defined list of colors set under Project ‣ Project Properties ‣ Default Styles.

The latest palettes can be modified thanks to the signPlus and signMinus buttons at the bottom of the frame. The ... button nearby the palette combobox also offers several options to:

  • copy, paste, import or export colors
  • create, import or remove color palettes. Check the Show in Color Buttons option to add the custom palette to the color selector widget (see figure_color_selector).
../../../_images/color_selector_recent_colors.png

Color selector switcher tab

Another option is to use the colorPicker color picker which allows you to sample a color from under your mouse pointer at any part of QGIS or even from another application by pressing the space bar. Please note that the color picker is OS dependent and is currently not supported by macOS.

Truco

Quick color modification

Click the drop-down arrow at the right of the selectColor color box button to display a widget for a quick color selection, either in the color wheel or from existing color palettes. You can also use it to copy or paste a color.

../../../_images/quick_color_selector.png

Menú seleccionador rápido de color

Modos de Mezcla

QGIS offers different options for special rendering effects with these tools that you may previously only know from graphics programs. Blending modes can be applied on layers, on features but also on print composer items:

  • Normal: This is the standard blend mode, which uses the alpha channel of the top pixel to blend with the pixel beneath it. The colors aren’t mixed.
  • Iluminado: Este selecciona el máximo de cada componente del primer y segundo plano de píxeles. Tenga en cuenta que los resultados tienden a ser irregulares y rigurosos.

  • Pantalla: píxeles de luz de la fuente se pintan sobre el destino, mientras que los píxeles oscuros no lo son. Este modo es muy útil para la mezcla de la textura de una capa con otra (por ejemplo, puede utilizar un sombreado para texturizar otra capa).

  • Esquivar: aclarará y saturar píxeles subyacentes en base a la ligereza del punto de imagen superior. Así, los píxeles superiores más brillantes provocan la saturación y el brillo de los píxeles subyacentes a aumentar. Esto funciona mejor si los píxeles superiores no son demasiado brillantes; de lo contrario el efecto sera demasiado extremo.

  • Addition: This blend mode simply adds pixel values of one item with the other. In case of values above one (in the case of RGB), white is displayed. This mode is suitable for highlighting features.
  • Darken: This creates a resultant pixel that retains the smallest components of the foreground and background pixels. Like lighten, the results tend to be jagged and harsh.
  • Multiply: Here, the numbers for each pixel of the top item are multiplied with the corresponding pixels for the bottom item. The results are darker pictures.
  • Burn: Darker colors in the top item cause the underlying items to darken. Burn can be used to tweak and colorise underlying layers.
  • Superposición: Este modo combina los modos de mescla multiplicar y pantalla. En la imagen resultante, partes de la luz se vuelven más ligeras y partes oscuras se oscurecen.

  • Soft light: This is very similar to overlay, but instead of using multiply/screen it uses color burn/dodge. This is supposed to emulate shining a soft light onto an image.
  • Hard light: Hard light is also very similar to the overlay mode. It’s supposed to emulate projecting a very intense light onto an image.
  • Difference: Difference subtracts the top pixel from the bottom pixel, or the other way around, to always get a positive value. Blending with black produces no change, as the difference with all colors is zero.
  • Subtract: This blend mode simply subtracts pixel values of one item from the other. In case of negative values, black is displayed.

Zum y paneo

QGIS provides tools to zoom and pan to your area of interest.

Apart from using the pan pan and zoomIn zoom-in / zoomOut zoom-out icons on the toolbar with the mouse, navigating can also be done with the mouse wheel, spacebar and the arrow keys. A Zoom factor can be set under the Settings ‣ options Options ‣ Map tools menu to define the scale behavior while zooming.

With the mouse wheel

You can press the mouse wheel to pan inside of the main window (on macOS, you may need to hold cmd key). You can roll the mouse wheel to zoom in and out on the map; the mouse cursor position will be the center of the zoomed area of interest. Holding down Ctrl while rolling the mouse wheel results in a finer zoom.

With the arrow keys

Panning the map is possible with the arrow keys. Place the mouse cursor inside the map area, and click on the right arrow key to pan east, left arrow key to pan west, up arrow key to pan north, and down arrow key to pan south.

You can also use the space bar to temporarily cause mouse movements to pan the map. The PgUp and PgDown keys on your keyboard will cause the map display to zoom in or out following the zoom factor set. Pressing Ctrl + or Ctrl - also performs an immediate zoom in/out on the map canvas.

When certain map tools are active (Identify, Measure...), you can perform a zoom by holding down Shift and dragging a rectangle on the map to zoom to that area. This is enabled for the map tools which are not selection tools (since they use Shift for adding to selection) nor edit tools.

Mediciones

Información general

QGIS provides four means of measuring geometries:

  • the interactive measurement tools measure,
  • measuring in the calculateField Field Calculator,
  • derived measures in the Identificar objetos espaciales tool,
  • and a vector analysis tool: Vector ‣ Geometry Tools ‣ Export/Add Geometry Columns

Measuring works within projected coordinate systems (e.g., UTM) and unprojected data. The first three measuring tools behave equally to global project settings:

  • If “on the fly” CRS transformation (see Define On The Fly (OTF) CRS Transformation) is enabled, the default measurement metric is - different from most other GIS - ellipsoidal, using the ellipsoid defined in File ‣ Project properties ‣ General. This is true both when geographic and projected coordinate systems are defined for the project.
  • If you want to calculate the projected / planimetric area or distance using cartesian maths, the measurement ellipsoid has to be set to “None / Planimetric” (File ‣ Project properties ‣ CRS). However, with a geographic (= unprojected) CRS defined for the data and project, area and distance measurement will be ellipsoidal.
  • If “on the fly” CRS transformation is disabled, the measurement metric is planimetric when the project coordinate system is projected and ellipsoidal when the project coordinate system is unprojected / geographic.

However, neither the identify tool nor the field calculator will transform your data to the project CRS before measuring. If you want to achieve this, you have to use the vector analysis tool: Vector ‣ Geometry Tools ‣ Export/Add Geometry Columns. Here, measurement is by default planimetric except if you choose the ellipsoidal measure.

Measure length, areas and angles interactive

Click the measure icon in the Attribute toolbar to begin measurements. The downward arrow near the icon helps you switch to the convenient tool to measure measure length, measureArea area or measureAngle angle. The default unit used in the dialog is the one set in Project ‣ Project Properties ‣ General menu.

Nota

Configuring the measure tool

While measuring length or area, clicking the Configuration button at the bottom of the widget helps you define in menu Settings ‣ Options ‣ Map Tools the rubberband color, the precision of the measurements and the unit behavior. You can also choose your preferred measurement or angle units but keep in mind that those values are superseded in the current project by options made in Project ‣ Project Properties ‣ General menu.

All measuring modules use the snapping settings from the digitizing module (see section Configurar la tolerancia del autoensamblado y radio de búsqueda). So, if you want to measure exactly along a line feature, or around a polygon feature, first set its layer snapping tolerance. Now, when using the measuring tools, each mouse click (within the tolerance setting) will snap to that layer.

By default, measure Measure Line: QGIS measures real distances between given points according to a defined ellipsoid. The tool then allows you to click points on the map. Each segment length, as well as the total, shows up in the measure window. To stop measuring, click your right mouse button.

Note that you can use the drop-down list near the total to interactively change the measurement units while measuring. This unit is kept for the widget until a new or another project is opened.

The Info section in the dialog explains how calculations are made according to CRS settings available.

../../../_images/measure_line.png

Medir Distancia

measureArea Measure Area: Areas can also be measured. In the measure window, the accumulated area size appears. Right-click to stop drawing. The Info section is also available as well as the ability to switch between different area units.

../../../_images/measure_area.png

Medir Área

measureAngle Medir ángulo: Se pueden también medir ángulos. El cursor se convierte en forma de cruz. Se debe hacer clic para dibujar el primer segmento del ángulo que se desea medir y a continuación mover el cursor para dibujar el ángulo deseado. La medida se mostrará en el diálogo emergente.

../../../_images/measure_angle.png

Medir Ángulo

Selecting features

QGIS provides several tools to select features in the map canvas. Selection tools are available in View ‣ Select menu or in the Attributes toolbar.

Nota

Selection tools work with the currently active layer.

Selecting manually in the map canvas

To select one or several features with the mouse, you can use one of the following tools:

  • selectRectangle Select Features by area or single click
  • selectPolygon Select Features by Polygon
  • selectFreehand Select Features by Freehand
  • selectRadius Select Features by Radius

Nota

Except the selectPolygon Select Features by Polygon tool, these manual selection tools allow you to select feature(s) in the map canvas with a single click.

While using the selectRectangle Select Feature(s) tool, holding Shift or Ctrl toggles whether feature is selected (ie either adds to the current selection or remove from it).

For the other tools, different behaviors can be performed holding:

  • Shift: add features to the current selection
  • Ctrl: substract features from the current selection
  • Ctrl + Shift: intersect with current selection, ie only keep overlapping features from the current selection
  • Alt: select features that are totally within the selection shape. Combined to Shift or Ctrl keys, you can add or substract features to/from the current selection.

Selección automática

The other selection tools, also available from the Attribute table, perform a selection based on feature’s attribute or its selection state (note that attribute table and map canvas show the same information, so if you select one feature in attribute table, it will be selected in map canvas also):

  • expressionSelect Select By Expression... allows user to select features using expression dialog.
  • formSelect Select Features By Value... or press F3
  • deselectAll Deselect Features from All Layers or press Ctrl+Shift+A to deselect all selected features in all layers.
  • selectAll Select All Features or press Ctrl+A to select all features in the current layer.
  • invertSelection Invert Feature Selection to invert the selection in the current layer.

For example, if you want to find regions that are boroughs from regions.shp of the QGIS sample data, you can use the expressionSelect Select features using an Expression icon. Then, you open the Fields and Values menu and choose the field that you want to query. Double-click the field ‘TYPE_2’ and also click [Load all unique values] in the right panel. From the list, choose and double-click ‘Borough’. In the Expression field, then you’d write the following query:

"TYPE_2"  =  'Borough'

From the expression builder dialog, you can also use the Function list ‣ Recent (Selection) to make a selection that you used before. The dialog remembers the last 20 used expressions. See Expresiones chapter for more information and some example.

Truco

Save your selection into a new file

Users can save selected features into a New Temporary Scratch Layer or a New Vector Layer using Edit ‣ Copy Features and Edit ‣ Paste Features as in the wanted format.

Seleccionar objetos por valor

This selection tool opens the layer’s feature form allowing the user to choose, for each field, which value to look for, if the search should be case sensitive, and the operation that should be used.

../../../_images/select_by_value.png

Filter/Select features using form dialog

Alongside each field, there is a drop-down list with the operation options to control the search behaviour. The common options are:

  • Exclude Field - The field will not be used for searching
  • Igual a (=)

  • No igual a

  • Falta (nulo)

  • No Falta (no nulo)

Para campos numéricos y fecha, las opciones adicionales son:

  • Mayor que (>)

  • Menor que (<)

  • Mayor que o igual a (>=)

  • Menor que o igual a (<=)

  • Entre (inclusivo)

  • No está entre (inclusivo)

Para campos de texto, las opciones adicionales son:

  • Contiene

  • No contiene

For the text options above, it is also possible to use the checkbox Case sensitive option.

After setting all search options, you can use the Select features button to select the matching features. The drop-down options are:

  • Seleccionar objetos espaciales

  • Añadir a una selección actual

  • Filtrar la selección actual

  • Eliminar de la selección actual

También puede limpiar todas las opciones utilizando el botón Restablecer formulario.

Configuración de anulación definida por datos

Beside many options in the vector layer properties dialog or settings in the print composer, you can find a dataDefined Data defined override icon. Thanks to expressions based on layer attributes or item settings, prebuild or custom functions and variables, this tool allows you to set dynamic value for the concerned parameter. When enabled, the value returned by this widget is applied to the parameter regardless its normal value (checkbox, textbox, slider...).

Clicking the dataDefined Data defined override icon shows following entries:

  • Description... that indicates if the option is enabled, which input is expected, the valid input type and the current definition. Hovering over the widget also pops up these information;
  • Tipo de campo: una entrada para seleccionar entre los campos de la capa que coincidan con el tipo de entrada válido;

  • una entrada a la lista de Variable disponibles;

  • botón Editar... para crear o editar la expresión a usar;

  • botones de Pegar y Copiar;

  • botón de Limpiar para eliminar la configuración.

Parámetros que se pueden utilizar con herramientas de definición de datos son:

  • Estilo y parámetros de simbología

  • Parámetros de Etiquetas

  • Parámetros del diseñador

Truco

Use right-click to (de)activate the data overriding

You can enable or disable a configured dataDefined data-defined override button by simply clicking the widget with the mouse right button.

Nota

When the data-defined override option is setup correctly the icon is yellow dataDefineOn or dataDefineExpressionOn; if it is broken, the icon is red dataDefineError or dataDefineExpressionError.

Identificar objetos espaciales

The Identify tool allows you to interact with the map canvas and get information on features in a pop-up window. To identify features, use:

  • View ‣ Identify Features menu,
  • or press Ctrl + Shift + I (or osx Cmd + Shift + I),
  • or click the identify Identify Features icon on the Attributes toolbar.

Using the Identify Features tool

QGIS offers two ways to identify features with the identify Identify Features tool:

  • left click will identify features according to the mode set in the Identify Results panel
  • right click will fetch all the snapped features from all the visible layers. This will open a context menu, allowing the user to choose more precisely the features to identify.

Truco

Filter the layers to query with the Identify Features tool

Uncheck the Identifiable column in Project ‣ (or kde Settings ‣), Project Properties ‣ Identify layers menu in front of a layer to avoid it being queried when using the identify Identify Features in a mode other than Current Layer. This is a handy way to return features from only layers that are of interest for you.

If you click on feature(s), the Identify Results dialog will list information about the clicked feature(s). The default view is a tree view where the first item is the name of the layer and its children are its identified feature(s). Each feature is described by the name of a field along with its value. This field is the one set in Layer Properties ‣ Display. Then follows all the other information about the feature.

Feature informations

The Identify Results dialog can be customized to display custom fields, but by default it will display three kinds of information:

  • Actions: Actions can be added to the identify feature windows. The action is run by clicking on the action label. By default, only one action is added, namely View feature form for editing. You can define more actions in the layer’s properties dialog (see Propiedades de acciones).
  • Derived: This information is calculated or derived from other information. This includes:
    • general information about the feature and its geometry: feature id, length or perimeter and area in map units depending on its geometry, the count of spatial parts and the number of the clicked part in case of multi-geometry, the count of vertices in the feature and the number of the closest one to the point clicked
    • coordinates information: the X and Y (and Z/M if available) coordinate values of the clicked point, the feature closest vertex and its first and last vertices. In case you click on a curved line using the info tool, QGIS will also display the radius of that section in the panel result.
  • Data attributes: This is the list of attribute fields and values for the feature that has been clicked.

Nota

Links in feature’s attributes are clickable from the Identify Results panel and will open in your default web browser.

../../../_images/identify_features.png

Dialogo de resultados de la identificación

The Identify Results dialog

At the top of the window, you have seven icons:

  • expandTree Expand tree
  • collapseTree Collapse tree
  • expandNewTree Default behavior to define whether next identified features information should be collapsed or expanded
  • propertyItem View the feature form
  • deselectAll Clear Results
  • editCopy Copy selected feature to clipboard
  • filePrint Print selected HTML response

At the bottom of the window, you have the Mode and View comboboxes. With the Mode combobox you can define from which layers features should be identified:

  • Current layer : only features from the selected layer are identified. The layer may not be visible in the canvas.
  • Top down, stop at first: for only features from the upper visible layer.
  • Top down: for all features from the visible layers. The results are shown in the panel.
  • and Layer selection: opens a context menu where the user selects the layer to identify features from. Operates like a right-click. Only the chosen features will be shown in the result panel.

Nota

Identify tool configuration

You can configure the identify feature in Project ‣ Project Properties in the Identify layers tab. The table allows user to select layer(s) that can be used by this tool to identify features (column Identifiable). You can also put this layer in read-only mode with the checkbox in the last column.

The View can be set as Tree, Table or Graph. ‘Table’ and ‘Graph’ views can only be set for raster layers.

The identify tool allows you to checkboxAuto open a form. If checked, each time a single feature is identified QGIS will open a form showing its attributes. This is a handy way to quickly edit a feature’s attributes.

Otras funciones se pueden encontrar en el menú contextual del elemento identificado. Por ejemplo, del menú contextual se puede:

  • Ver el formulario del objeto espacial

  • Zum a objeto espacial

  • Copiar objeto espacial: Copiar toda la geometría y atributos del objeto espacial

  • Toggle feature selection: Adds identified feature to selection
  • Copiar el valor del atributo: copiar solo el valor del atributo sobre el cual se hizo clic

  • Copiar atributos del objeto espacial: Copiar atributos del objeto espacial

  • Limpiar resultados: quitar resultados de la ventana

  • Limpiar resaltados: Deseleccionar los objetos espaciales en el mapa

  • Resaltar todo

  • Resaltar capa

  • Activar capa: Elegir una capa para ser activada

  • Propiedades de la capa: Abrir la ventana de propiedades de la capa.

  • Expandir todo

  • Colapsar todo

Herramientas de anotaciones

The textAnnotation Text Annotation tool in the attribute toolbar provides the possibility to place formatted text in a balloon on the QGIS map canvas. Use the Text Annotation tool and click into the map canvas.

../../../_images/annotation.png

Diálogo de texto de anotación

Haciendo doble clic sobre el elemento se abre un cuadro de diálogo con varias opciones. Hay un editor de texto para escribir el texto con formato y otros ajustes de elementos. Por ejemplo, existe la opción de tener el elemento colocado en una posición del mapa (mostrado por el símbolo del marcador) o tener el elemento en una posición de la pantalla (no relacionado con el mapa). El elemento se puede mover por la posición del mapa (al arrastrar el marcador del mapa) o moviendo solo el globo. Los iconos son parte del tema de los SIG, y se utilizan de forma predeterminada en otros temas también.

The annotation Move Annotation tool allows you to move the annotation on the map canvas.

Anotaciones HTML

The formAnnotation Html Annotation tools in the attribute toolbar provides the possibility to place the content of an html file in a balloon on the QGIS map canvas. Using the Html Annotation tool, click into the map canvas and add the path to the html file into the dialog.

Anotaciones SVG

La herramienta saveAsSVG Anotación SVG de la barra de herramientas de atributos provee la posibilidad para colocar un símbolo SVG en un globo en la vista del mapa de QGIS. Utilizando la herramienta Anotación SVG, haga clic en la vista del mapa y añada la ruta de acceso al archivo SVG en el diálogo.

Anotaciones de formulario

Additionally, you can also create your own annotation forms. The formAnnotation Form Annotation tool is useful to display attributes of a vector layer in a customized Qt Designer form (see figure_custom_annotation). This is similar to the designer forms for the Identify features tool, but displayed in an annotation item. Also see this video https://youtu.be/0pDBuSbQ02o?t=2m25s from Tim Sutton for more information.

../../../_images/custom_annotation.png

Customized qt designer annotation form

Nota

Si presiona Ctrl+T mientras está activa una herramienta Anotación (mover anotación, anotación de texto, anotación de formulario), se invierten los estados de visibilidad de los elementos.

Marcadores espaciales

Spatial Bookmarks allow you to “bookmark” a geographic location and return to it later. By default, bookmarks are saved on the computer, meaning that they are available from any project in the same computer. If you wish to store the bookmark in the project file (.qgs) then you can do this by selecting the In Project checkbox.

Crear un marcador

Para crear un marcador:

  1. Hacer zoom o desplazarse al área de interés.

  2. Select the menu option View ‣ New Bookmark or press Ctrl-B. The Spatial Bookmark panel opens with the newly created bookmark.
  3. Introduzca un nombre descriptivo para el marcador (hasta 255 caracteres).

  4. Check the In Project box if you wish to save the bookmark in the project file.
  5. Press Enter to add the bookmark or click elsewhere.

Tenga en cuenta que puede tener múltiples marcadores con el mismo nombre.

Trabajar con marcadores

To use or manage bookmarks, select the menu option View ‣ Show Bookmarks. The Spatial Bookmarks panel allows you to:

  • Zoom to a Bookmark: select the desired bookmark and then click Zoom To Bookmark. You can also zoom to a bookmark by double-clicking on it.
  • Delete a Bookmark: select the bookmark and click Delete Bookmark. Confirm your choice.
  • Import or Export a bookmark: To share or transfer your bookmarks between computers you can use the Import/Export Bookmarks pull down menu in the Spatial Bookmarks dialog. All the bookmarks are transferred.

Anidar proyectos

Sometimes, you’d like to keep in different projects a bunch of layers with the same style. You can either create a default style for these layers or embed them from another project to save you tons of work.

Embed layers and groups from an existing project has some advantages over styling:

  • all types of layers (vector or raster, local or online...) can be added
  • fetching groups and layers, you can keep the same tree structure of the “background” layers in your different projects
  • While the embedded layers are editable, you can’t change their properties such as symbology, labels, forms, default values, actions... This ensures homogeneity throughout the projects
  • modify the items in the original project and changes are propagated to all the other projects.

If you want to embed content from other project files into your project, select Layer ‣ Embed Layers and Groups and:

  1. Press browseButton to look for a project; you can see the content of the project (see figure_embed_dialog).
  2. Press Ctrl ( or osx Cmd) and click on the layers and groups you wish to retrieve.
  3. Press [OK]. The selected layers and groups are embedded in the Layer panel and can be visualized in the map canvas now. Names of embedded items appear in italic to distinguish them from regular layers and groups.
../../../_images/embed_dialog.png

Seleccionar capas y grupos para empotrar

Like any other layer, an embedded layer can be removed from the project by right-click on the layer and choose removeLayer Remove.

Truco

Change rendering of an embedded layer

It’s not possible to change rendering of an embedded layer, unless you make the changes in the original project file. However, right-click on a layer and select Duplicate creates a layer which is fully-featured and not dependent to the original project. You can then safely remove the linked layer.

Elementos decorativos

Las Ilustraciones de QGIS incluyen la Cuadrícula, Etiqueta de Copyright, Flecha de Norte y Barra de Escala. Se usan para ‘adornar’ el mapa al agregar elementos cartográficos

Cuadrícula

transformed Cuadrícula permite agregar una rejilla de coordenadas y anotaciones a la vista del mapa.

../../../_images/grid_dialog.png

El Diálogo Cuadrícula

  1. Select from menu View ‣ Decorations ‣ Grid. The dialog starts (see figure_decorations_grid).
  2. Activar la casilla checkbox Activar cuadrícula y establecer la definición de la cuadrícula de acuerdo con las capas cargadas en la vista del mapa.

  3. Activar la casilla checkbox Dibujar anotaciones y establecer la definición de las anotaciones de acuerdo con las capas cargadas en la vista del mapa.

  4. Click [Apply] to verify that it looks as expected or [OK] if you’re satisfied.

Flecha del Norte

northArrow North Arrow places a simple north arrow on the map canvas. Currently, there is only one style available. You can adjust the angle of the arrow or let QGIS set the direction automatically. If you choose to let QGIS determine the direction, it makes its best guess as to how the arrow should be oriented. For placement of the arrow, you have four options, corresponding to the four corners of the map canvas. You can refine the placement of the arrow by setting a Horizontal and/or Vertical Marging from (Canvas) Edge. These values can be a distance in Millimeter or Pixels or set as Percentage of the width or height of the map canvas.

../../../_images/north_arrow_dialog.png

El Diálogo Flecha Norte

Barra de escala

scaleBar Scale Bar adds a simple scale bar to the map canvas. You can control the style and placement, as well as the labelling of the bar.

../../../_images/scale_bar_dialog.png

El Diálogo Barra de Escala

QGIS only supports displaying the scale in the same units as your map frame. So if the units of your layers are in meters, you can’t create a scale bar in feet. Likewise, if you are using decimal degrees, you can’t create a scale bar to display distance in meters.

Para añadir una barra de escala:

  1. Seleccionar del menú Ver ‣ Ilustraciones ‣ Barra de escala. Se iniciará el diálogo (ver figure_decorations_scale).

  2. Comprobar que la casilla de verificación checkbox Habilitar barra de escala esté marcada.

  3. Elegir el estilo de la caja desplegable Estilo de la barra de escala selectString

  4. Seleccionar el color de la barra Color de la barra selectColor o usar el color negro predeterminado.

  5. Set the Size of bar selectNumber.
  6. Optionally, check checkbox Automatically snap to round number on resize to display values easy-to-read.
  7. Elegir la ubicación de la lista desplegable Ubicación selectString.

  8. You can refine the placement of the item by setting a Horizontal and/or Vertical Marging from (Canvas) Edge. These values can be a distance in Millimeter or Pixels or set as Percentage of the width or height of the map canvas.
  9. Click [Apply] to verify that it looks as expected or [OK] if you’re satisfied.

Truco

Configuración de elementos decorativos

Al guardar un proyecto .qgs, cualquiera de los cambios que se hayan hecho a la cuadrícula, flecha de norte, barra de escala y copyright se guardarán en el proyecto y se restaurán la próxima vez que cargue el proyecto.

Autenticación

QGIS has facility to store/retrieve authentication credentials in a secure manner. Users can securely save credentials into authentication configurations, which are stored in a portable database, can be applied to server or database connections, and safely referenced by their ID tokens in project or settings files. For more information see Sistema de autenticación.

A master password needs to be set up when initializing the authentication system and its portable database.

Variables

In QGIS, you can use variables to store useful recurrent values (e.g. the project’s title, or the user’s full name) that can be used in expressions. Variables can be defined at the application’s global level, project level, layer level, composition level, and composer’s item level. Just like CSS cascading rules, variables can be overwritten - e.g., a project level variable will overwrite any application’s global level variables set with the same name. You can use these variables to build text strings or other custom expressions using the @ character before the variable name. For example in composer creating a label with this content:

This map was made using QGIS [% @qgis_version %]. The project file for this
map is: [% @project_path %]

Representará la etiqueta como ésta:

This map was made using QGIS 2.14. The project file for this map is:
/gis/qgis-user-conference-2015.qgs

Besides the preset read-only variables, you can define your own custom variables for any of the levels mentioned above. You can manage:

To differentiate from editable variables, read-only variable’s names and values are emphasized in italic. On the other hand, higher level variables overwritten by lower level ones are strike through.

../../../_images/options_variables.png

Variables editor at the project’s level

Nota

You can read more about variables and find some examples in Nyall Dawson’s Exploring variables in QGIS 2.12, part 1, part 2 and part 3 blog posts.