7. Gebruikersinterface van QGIS

De grafische gebruikersinterface (GUI) van QGIS wordt weergegeven in de afbeelding hieronder (de nummers 1 tot en met 5 in gele cirkels geven belangrijke elementen van de GUI van QGIS aan, en worden hieronder besproken).

../../../_images/startup.png

Fig. 7.1 Gebruikersinterface van QGIS met Alaska voorbeeld gegevensset

Notitie

De weergave van uw venster (titelbalk, etc) kan enigszins afwijken, afhankelijk van uw besturingssysteem en vensterbeheer.

De hoofd-GUI van QGIS GUI (Fig. 7.1) bestaat uit vijf componenten / typen componenten:

  1. Menubalk

  2. Werkbalken

  3. Panelen

  4. Kaartweergave

  5. Statusbalk

Scroll naar beneden voor gedetailleerde uitleg hiervan.

7.2. Panelen en werkbalken

Vanuit het menu Beeld (of kde Extra), kunt u widgets (Panelen ►) en werkbalken (Werkbalken ►) van QGIS in- en uitschakelen. Klik met rechts op de menubalk of de werkbalk en kies het item dat u wilt om het te (de)activeren. Panelen en werkbalken kunnen worden verplaatst en neergezet worden waar u wilt binnen de interface van QGIS. De lijst kan ook worden uitgebreid met het activeren van Bron- of externe plug-ins.

7.2.1. Werkbalken

De werkbalken verschaffen toegang tot de meeste functies in de menu’s, plus aanvullende gereedschappen voor het werken met de kaart. Elk item voor de werkbalk heeft pop-up Help beschikbaar. Ga met uw muis over het item en een korte beschrijving over het doel van het gereedschap zal worden weergegeven.

Elke werkbalk kan verplaatst worden naar waar u wilt. Daarnaast kunt u werkbalken uitschakelen via het snelmenu, dat verschijnt wanneer u de rechtermuisknop indrukt of door de muisaanwijzer boven de werkbalken te houden.

../../../_images/toolbars1.png

Fig. 7.2 Menu Werkbalken

Tip

Werkbalken weer terugzetten

Als u per ongeluk een werkbalk hebt verborgen, kunt u die terughalen met Beeld ► Werkbalken ► (of kde Extra ► Werkbalken ►). Als, om enige reden, een werkbalk (of enig ander widget) totaal uit de interface verdwijnt, zult u tips vinden om het terug te krijgen in initiële GUI herstellen.

7.2.2. Panelen

QGIS verschaft vele panelen. Panelen zijn speciale widgets waarmee u kunt werken (opties selecteren, vakken selecteren, waarden vullen…) om meer complexe taken uit te voeren.

../../../_images/panels.png

Fig. 7.3 Menu Panelen

Hieronder staat een lijst met de standaardpanelen die worden verschaft door QGIS:

7.3. Kaartvenster

7.3.1. De kaartweergave verkennen

De kaartweergave (ook wel kaartvenster genoemd) is het “zakelijke gedeelte” van QGIS — kaarten worden in dit gebied weergegeven, in 2D. De in dit venster weergegeven kaart zal het renderen weergeven (symbologie, labelen, zichtbaarheid…), die u hebt toegepast op de lagen die u hebt geladen. Het is ook afhankelijk van de lagen en het Coördinaten ReferentieSysteem (CRS) van het project.

Wanneer u een laag toevoegt (bekijk bijv. Gegevens openen), zoekt QGIS automatisch naar het CRS ervan. Als standaard een ander CRS is ingesteld voor het project (zie Project coördinaten referentiesystemen), dan wordt het laagbereik “direct” vertaald naar dat CRS, en de kaartweergave wordt gezoomd naar dat bereik als u begint met een blanco project van QGIS. Als er al lagen in het project staan, wordt geen aanpassing van het kaartvenster uitgevoerd, dus zullen alleen objecten, die vallen binnen het huidige bereik van het kaartvenster, zichtbaar zijn.

Klik op de kaartweergave en u zou er interactief mee moeten kunnen werken:

  • het kan worden verschoven, wat de weergave verplaatst naar een ander gebied van de kaart: dit wordt uitgevoerd met het gereedschap pan Kaart verschuiven, de pijltoetsen, verplaatsen van de muis, terwijl de toets Spatie, de middelste knop van de muis of het muiswiel wordt ingedrukt.

  • het kan worden in- of uitgezoomd, met de aangewezen gereedschappen zoomIn Inzoomen en zoomIn Uitzoomen. Houd de Alt-toets ingedrukt om van het ene gereedschap naar het andere te schakelen. Zoomen kan ook worden uitgevoerd door het muiswiel voorwaarts te rollen voor inzoomen en naar achteren te rollen voor uitzoomen. De zoom wordt gecentreerd op de positie van de muiscursor.

    U kunt de Zoomfactor aanpassen in het menu Extra ► Opties ► Kaartgereedschap.

  • het kan worden gezoomd naar het volledige bereik van alle geladen lagen (zoomFullExtent Volledig zoomen), naar het bereik van een laag (zoomToLayer Zoom naar laag) of naar het bereik van de geselecteerde objecten (zoomToSelected Zoom naar selectie)

  • u kunt terug/vooruit navigeren door de geschiedenis van de kaartweergave met de knoppen zoomLastVorig beeld en zoomNextVolgend beeld of met de knoppen terug/vooruit van de muis.

Klik met rechts boven de kaart en u zou in staat moeten zijn om editCopy Coördinaten kopiëren te gebruiken voor het aangeklikte punt in het kaart-CRS, in WGS84 of in een aangepast CRS. De gekopieerde informatie kan dan worden geplakt in een expressie, een script, tekstbewerker of werkblad…

Standaard opent QGIS één enkele kaartweergave (“hoofdkaart” genoemd), die strak is verbonden aan het paneel Lagen; de hoofdkaart geeft automatisch de wijzigingen weer die u maakt in het gebied van het paneel Lagen. Maar het is ook mogelijk aanvullend kaartweergaven te openen waarvan de inhoud kan afwijken van de huidige status van het paneel Lagen. Zij mogen type 2D of 3D zijn, verschillende schaal of bereik weergeven, of een verschillende set van de geladen lagen weergeven, dankzij kaartthema’s.

7.3.2. Aanvullende kaartweergaven instellen

Ga, om een nieuwe kaartweergave toe te voegen, naar Beeld ► newMap Nieuwe kaartweergave. Een nieuw zwevend widget, dat de rendering van de hoofdkaartweergave nabootst, wordt toegevoegd aan QGIS. U mag net zoveel kaartweergaven toevoegen als u nodig hebt. Zij kunnen zwevend worden gehouden, naast elkaar worden geplaatst of op elkaar worden gestapeld.

../../../_images/map_views.png

Fig. 7.4 Meerdere kaartweergaven met verschillende instellingen

Boven het kaartvenster van een aanvullende kaartweergave staat een werkbalk met de volgende mogelijkheden:

  • zoomFullExtent Volledig zoomen, zoomToSelected Zoom naar selectie en zoomToLayer Zoom naar laag om binnen de weergave te navigeren

  • showMapTheme Thema voor weergave instellen om het kaartthema te selecteren dat moet worden weergegeven in de kaartweergave. Indien ingesteld op (geen), zal de weergave de wijzigingen in het paneel Lagen volgen.

  • options Instellingen voor weergave om de kaartweergave te configureren:

    • radioButtonOn Midden van weergave synchroniseren met hoofdkaart: synchroniseert het midden van de kaartweergaven zonder de schaal aan te passen. Dit maakt het voor u mogelijk een stijl overzichtskaart of vergrote kaart te hebben die het midden van het hoofdvenster volgt.

    • radioButtonOff Weergave naar selectie synchroniseren: hetzelfde als Zoom naar selectie

    • Schaal

    • Rotatie

    • Vergroting

    • unchecked Schaal synchroniseren met de schaal van de hoofdkaart. Een Schaalfactor kan dan worden toegepast, wat u in staat stelt een weergave te hebben die bijv. altijd 2x de schaal van het hoofdvenster heeft.

    • checkbox Annotaties weergeven

    • checkbox Positie van cursor weergeven

    • unchecked Bereik van hoofdkaart weergeven

    • checkbox Labels weergeven: maakt het mogelijk labels te verbergen, ongeacht of zij zijn ingesteld in de eigenschappen van de weergegeven laag

    • CRS voor kaart wijzigen…

    • Weergave hernoemen…

7.3.3. De kaartweergave exporteren

Kaarten die u maakt kunnen worden opgemaakt en geëxporteerd naar verscheidene indelingen met de geavanceerde mogelijkheden van de afdruklay-out of rapport. Het is ook mogelijk om de huidige rendering direct te exporteren, zonder een lay-out. Deze snelle “schermafdruk” van de kaartweergave heeft enkele handige mogelijkheden.

Het kaartvenster met de huidige rendering exporteren:

  1. Ga naar Project ► Importeren/Exporteren

  2. Selecteer, afhankelijk van uw indeling voor uitvoer, ofwel

    • saveMapAsImage Kaart als afbeelding exporteren…

    • of saveAsPDF Kaart als PDF exporteren…

De twee gereedschappen verschaffen u een aantal algemene opties. In het dialoogvenster dat opent:

../../../_images/saveMapAsImage.png

Fig. 7.5 Dialoogvenster Kaart als afbeelding opslaan

  1. Kies het Bereik om te exporteren: het mag het huidige bereik van de weergave zijn (de standaard), het bereik van een laag of een aangepast bereik dat in het kaartvenster wordt getekend. Coördinaten van het geselecteerde gebied worden weergegeven en zijn handmatig te bewerken.

  2. Voer de Schaal van de kaart in of selecteer het uit de vooraf gedefinieerde schalen: wijzigen van de schaal zal het te exporteren bereik aanpassen (vanuit het midden).

  3. Stel de Resolutie voor de uitvoer in

  4. Controleer de Breedte uitvoer en Hoogte uitvoer in pixels voor de afbeelding: standaard gebaseerd op de huidige resolutie en bereik, zij kunnen worden aangepast en zullen het kaartbereik aanpassen (vanuit het midden). De verhoudingen voor de grootte kunnen worden vergrendeld, wat in het bijzonder handig kan zijn bij het tekenen van het bereik in het kaartvenster.

  5. checkbox Actieve decoraties tekenen: in gebruik zijnde decoraties (schaalbalk, titel, raster, noordpijl…) worden geëxporteerd met de kaart

  6. checkbox Annotaties tekenen om eventuele annotaties te exporteren

  7. checkbox Voeg georeferentie informatie toe (ingebed of via world file): afhankelijk van de indeling voor de uitvoer zal een world file met dezelfde naam (met de extensie PNGW voor afbeeldingen PNG, JPGW voor afbeeldingen JPG, …) worden opgeslagen in dezelfde map als uw afbeelding. De indeling PDF bedt de informatie in het bestand PDF in.

  8. Bij het exporteren naar PDF zullen meer opties beschikbaar zijn in het dialoogvenster Kaart als PDF opslaan…:

    ../../../_images/saveMapAsPDF.png

    Fig. 7.6 Dialoogvenster Kaart als PDF opslaan

    • checkbox RDF-metadata exporteren van het document, zoals de titel, auteur, datum, beschrijving…

    • unchecked Georuimtelijke PDF maken (GeoPDF): Maak een PDF-bestand met geoverwijzingen (vereist GDAL versie 3 of later). U kunt:

      • De GeoPDF Indeling kiezen

      • checkbox informatie over vectorobject opnemen in het bestand GeoPDF: zal alle informatie over geometrie en attributen uit zichtbare objecten in de kaart opnemen in het uitvoerbestand GeoPDF.

      Notitie

      Vanaf QGIS 3.10 kan, met GDAL 3, een bestand GeoPDF ook worden gebruikt als een gegevensbron. Voor meer over ondersteuning voor GeoPDF in QGIS, bekijk https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/.

    • Kaart rasteriseren

    • checkbox Geometrieën vereenvoudigen om de bestandsgrootte te verkleinen: Geometrieën zullen worden vereenvoudigd bij het exporteren van de kaart door punten te verwijderen die niet opmerkelijk verschillen in de resolutie voor exporteren (bijv. als de resolutie voor exporteren 300 dpi is, zullen punten die minder dan 1/600 inch apart liggen worden verwijderd). Dit kan de grootte en complexiteit van het exportbestand verkleinen (hele grote bestanden zouden kunnen weigeren te laden in andere toepassingen).

    • Tekst exporteren instellen: beheert of tekstlabels worden geëxporteerd als echte tekstobjecten (Tekst altijd als tekstobjecten exporteren) of alleen als paden (Tekst altijd als paden exporteren). Als zij worden geëxporteerd als tekstobjecten, dan kunnen zij worden bewerkt in externe toepassingen (bijv. Inkscape) als normale tekst. MAAR het bijeffect is dat de kwaliteit van het renderen verminderd, EN er zijn problemen met renderen als er bepaalde instellingen voor de tekst, zoals buffers, van kracht zijn. Dat is de reden waarom exporteren als paden wordt aanbevolen.

  9. Klik op Save om de locatie, naam en indeling voor het bestand te selecteren.

    Bij het exporteren als afbeelding is het ook mogelijk om het verwachte resultaat van de bovenstaande instellingen te Kopiëren naar klembord en de kaart te plakken in een andere toepassing, zoals LibreOffice, GIMP…

7.4. 3D-kaartweergave

Ondersteuning voor visualisatie in 3D wordt aangeboden via de 3D-kaartweergave. U maakt en opent een 3D kaartweergave via Beeld ► new3DMap Nieuwe 3D-kaartweergave. Een zwevend paneel van QGIS zal verschijnen. Het paneel kan worden vastgezet.

De 3D-kaartweergave heeft, om mee te beginnen, hetzelfde bereik en weergave als het 2D-hoofdvenster. Een set navigatiegereedschappen is beschikbaar om de weergave om te zetten naar 3D.

../../../_images/3dmapview.png

Fig. 7.7 Het dialoogvenster 3D-kaartweergave

De volgende gereedschappen worden verschaft aan de bovenzijde van het paneel voor de 3D-kaartweergave:

  • pan Camerabeheer: verplaatst de weergave, dezelfde hoek en richting van de camera behoudend

  • zoomFullExtent Volledig zoomen: past de weergave aan naar het volledige bereik van de laag

  • 3dNavigation Navigeren op scherm aan-/uitzetten: toont/verbergt de widget voor navigatie (dat is bedoeld om het beheer van de kaartweergave te vergemakkelijken)

  • identify Identificeren: geeft informatie over het punt in het terrein of het/de 3D-object(en) waarop geklikt is – Meer details bij identificeren

  • measure Maatlijn: meet de horizontale afstand tussen punten

  • play Animaties: toont/verbergt de widget speler voor animaties

  • saveMapAsImage Als afbeelding opslaan…: exporteert de huidige weergave naar de indeling voor een afbeeldingbestand

  • 3d 3D-scene exporteren…: exporteert de huidige weergave als een 3D-scene (bestand .obj), wat het mogelijk maakt het na te bewerken in toepassingen zoals Blender… De objecten van terrein en vector worden geëxporteerd als 3D-objecten. De instellingen voor exporteren overschrijven de eigenschappen van de laag of configuratie van de kaartweergave, inclusief:

    • Naam scene en doel-map

    • Resolutie terrein

    • Resolutie textuur terrein

    • Schaal model

    • checkbox Afgevlakte randen

    • checkbox Normalen exporteren

    • checkbox Texturen exporteren

  • showMapTheme Thema voor weergave instellen: Stelt u in staat de set lagen, die moet worden weergegeven in de kaartweergave, te selecteren uit vooraf gedefinieerde kaartthema’s.

  • options Configureren van de instellingen van de kaartweergave

7.4.2. Een animatie maken

Een animatie is gebaseerd op een set sleutelframes - cameraposities op bepaalde tijden. Een animatie maken:

  1. Schakel het gereedschap play Animaties in, wat de widget voor de speler van animaties zal weergeven

  2. Klik op de knop signPlus Sleutelframe toevoegen en voer een Tijd sleutelframe in seconden in. Het combinatievak Sleutelframe geeft nu de ingestelde tijd weer.

  3. Verplaats, met de gereedschappen voor Navigatie, de camera naar de positie die moet worden gekoppeld aan de tijd voor het huidige sleutelframe.

  4. Herhaal de vorige stappen om net zoveel sleutelframes toe te voegen (met tijd en positie) als nodig.

  5. Klik op de knop play om een voorbeeld te zien van de animatie. QGIS zal scenes maken met de cameraposities/-rotaties van de ingestelde tijden, en ze interpoleren tussen deze sleutelframes. Verscheidene modi voor Interpolatie voor animaties zijn beschikbaar (bijv, lineair, inQuad, outQuad, inCirc… – meer details op https://doc.qt.io/qt-5/qeasingcurve.html#EasingFunction-typedef).

    Een voorbeeld van de animatie kan ook worden bekeken door de schuif voor de tijd te verplaatsen. Ingedrukt houden van de knop refresh Herhaal zal de animatie herhaaldelijk uitvoeren, terwijl het klikken op play een uitgevoerde animatie zal stoppen.

Het is mogelijk door de verschillende weergaven van de camera te bladeren met de lijst Sleutelframe. Wanneer een tijd actief is, zal het wijzigen van de kaartweergave automatisch de gekoppelde positie bijwerken. U kunt ook symbologyEdit Sleutelframe bewerken (alleen tijd) of signMinus Sleutelframe verwijderen.

Klik op fileSave Animatieframes exporteren om een reeks afbeeldingen, die de scene weergeven, te maken. Naast de bestandsnaam Sjabloon en de Map voor uitvoer, kunt u het aantal Frames per seconde, de Breedte uitvoer en Hoogte uitvoer instellen.

7.4.3. Scenes configureren

De 3D-kaartweergave opent met enkele standaard instellingen die u kunt aanpassen. Klik, om dat te doen, op de knop options Configureren… aan de bovenzijde van het 3D-kaartpaneel om het venster 3D configuratie te openen.

../../../_images/3dmapconfiguration.png

Fig. 7.8 Dialoogvenster 3D-configuratie

In het venster 3D-configuratie staan verscheidene opties om de 3D-scene fijn af te stemmen:

7.4.3.1. Terrein

  • Terrein: Voordat we in de details duiken, is het goed om te weten dat het terrein in een 3D-weergave wordt weergegeven door een hiërarchie van tegels van het terrein en als de camera zich dichter naar het terrein verplaatst worden bestaande tegels, die niet voldoende details hebben, vervangen door kleinere tegels meet meer details. Elke tegel heeft een geometrie van mazen, die zijn afgeleid van de laag met het hoogteraster en textuur uit 2D-lagen.

    • De hoogte van het terrein Type kan zijn:

    • Hoogte: Rasterlaag of laag met mazen die moet worden gebruikt voor het maken van het terrein. De rasterlaag moet een band bevatten die de hoogte weergeeft. Voor een laag met mazen worden de waarden Z van punten gebruikt.

    • Verticale schaal: Schaalfactor voor de verticale as. Verhogen van de schaal zal de hoogte van landvormen overdrijven.

    • Resolutie tegel: Hoeveel monsters uit de rasterlaag voor het terrein te gebruiken voor elke tegel. Een waarde van 16px betekent dat de geometrie van elke tegel zal bestaan uit 16x16 hoogtemonsters. Hogere getallen maken meer gedetailleerde tegels voor het terrein, ten koste van verhoogde complexiteit bij het renderen.

    • Hoogte ring: Soms kunnen kleine scheurtjes zichtbaar zijn tussen tegels van het terrein. Verhogen van deze waarde zal verticale muren (“skirts”) toevoegen rondom tegels van het terrein om de scheurtjes te verbergen.

  • Wanneer een laag met mazen wordt gebruikt als terrein, kunt u de Instellingen driehoeken (weergave draadmodel, afgevlakte driehoeken) en de Instellingen voor renderen van kleuren (als uniform of afhankelijk van het niveau van het terrein) configureren. Meer details in het gedeelte Eigenschappen laag met mazen.

  • unchecked Terreinschaduw: Stelt u in staat te kiezen hoe het terrein zou moeten worden gerenderd:

    • Schaduw uitgeschakeld - kleur voor het terrein wordt alleen bepaald vanuit de textuur van de kaart

    • Schaduw ingeschakeld - kleur voor het terrein wordt bepaald met het Phong’s shading-model, dat rekening houdt met de textuur van de kaart, de normale vector van het terrein, licht(en) voor de scene en kleuren Omringen en Spiegelen en Glanzen van het materiaal van het terrein

7.4.3.2. Lichten

Op de tab Lichten, druk op het menu signPlus om toe te voegen

  • tot maximaal acht Puntlichten: schijnt licht in alle richtingen, zoals een bol licht dat een gebied vult. Objecten dichter bij het licht zullen helderder zijn, en objecten verder weg zullen donkerder zijn. Een puntlicht heeft een ingestelde positie (X, Y en Z), een Kleur, een Intensiteit en een Demping

  • maximaal vier Richtingslichten: bootst de verlichting na die u zou krijgen van een reusachtige zaklamp, heel ver weg van uw objecten, altijd gecentreerd en dat nooit dooft (bijv. de zon). Het straalt parallelle lichtstralen in één enkele richting maar het licht reikt tot in oneindigheid. Een richtingslicht kan worden geroteerd met een opgegeven Azimut, een Hoogte hebben, een Kleur en een Intensiteit.

../../../_images/3dmapconfiguration_lights.png

Fig. 7.9 Dialoogvenster 3D Lichten configureren

7.4.3.3. Schaduw

Selecteer unchecked Schaduwen weergeven om schaduwen binnen uw scene weer te geven, gegeven:

  • een Richtingslicht

  • een Maximum afstand schaduw renderen: om renderen van schaduw op objecten te veraf te vermijden, in het bijzonder als de camera langs de horizon kijkt

  • een Schuine schaduw: om effecten van zelf-schaduw te vermijden dat sommige gebieden donkerder zou kunnen maken dan andere, vanwege verschillen tussen grootten van kaarten. Hoe lager hoe beter

  • een Kaartresolutie schaduw: om schaduwen er scherper uit te laten zien. Het zou kunnen resulteren in mindere uitvoering als de parameter voor de resolutie te hoog is.

7.4.3.4. Camera & skybox

  • Camera’s Veld voor weergave: maakt het mogelijk panoramische scenes te maken. Standaardwaarde is 45°.

  • Selecteer unchecked Skybox weergeven om renderen van skybox in de scene in te schakelen. Het type skybox kan zijn:

    • Panoramische textuur, met een enkel bestand dat zicht verschaft op 360°

    • Afzonderlijke zijden, met een textuurbestand voor elk van de zes zijden van een box die de scene bevat

    Textuurbestanden mogen bestanden op schijf zijn, URL’s op afstand of ingebed in het project (meer details).

7.4.3.5. Geavanceerd

  • Resolutie kaarttegel: Breedte en hoogte van de 2D kaartafbeeldingen worden gebruikt als texturen voor de tegels van het terrein. 256px betekent dat elke tegel zal worden gerenderd naar een afbeelding van 256x256 pixels. Hogere getallen maken meer gedetailleerde tegels voor het terrein, ten koste van een grotere complexiteit voor het renderen.

  • Max. scherm fout: Bepaalt de drempel voor het verwisselen van tegels voor het terrein door meer gedetailleerde (en vice versa) - d.i. hoe snel de 3D-kaartweergave een hogere kwaliteit tegels gaat gebruiken. Lagere getallen betekenen meer details in de scene, ten koste van een verhoogde complexiteit voor het renderen.

  • Max. grond fout: De resolutie van de tegels voor het terrein waarop het opdelen van tegels in meer gedetailleerde zal stoppen (splitsen ervan zal niet op enigerlei wijze meer detail verschaffen). Deze waarde beperkt de diepte van de hiërarchie van de tegels: lagere waarden maken de hiërarchie dieper, wat de complexiteit voor het renderen verhoogt.

  • Zoomniveaus: Geeft het aantal zoomniveaus weer (afhankelijk van de resolutie van de kaarttegels en de max. grond fout).

  • unchecked Labels tonen: Schakelt labels voor de kaart in/uit

  • unchecked Info kaarttegel tonen: Bevatten grenzen en tegelnummers voor de tegels van het terrein (nuttig voor het oplossen van problemen met het terrein)

  • unchecked Begrenzingsvakken tonen: Geeft 3D-begrenzingsvakken weer van de tegels van het terrein (nuttig voor het oplossen van problemen met het terrein)

  • unchecked Middelpunt camera weergeven

  • unchecked Lichtbronnen weergeven: geeft een bol weer op de plek van origine van de lichtbronnen, wat het gemakkelijker maakt lichtbronnen opnieuw te positioneren of te plaatsen, relatief ten opzichte van de inhoud van de scene

7.4.4. 3D-vectorlagen

Een vectorlaag met waarden voor hoogten kan in 3D-kaartweergave worden weergegeven door 3D-renderer inschakelen in het gedeelte 3D-weergave van de eigenschappen voor de vectorlaag. Een aantal opties zijn beschikbaar voor het beheren van het renderen van de 3D-vectorlaag.

7.5. Statusbalk

De Statusbalk verschaft u algemene informatie over de kaartweergave, en verwerkte of beschikbare acties en biedt u gereedschappen om de kaartweergave te beheren.

7.5.1. balk Lokaliseren

Aan de linkerkant van de statusbalk, de balk Lokaliseren, een widget om snel te zoeken, helpt u enkele mogelijkheden of opties in QGIS te zoeken en uit te voeren:

  1. Klik in de tekstwidget om de zoekbalk Lokaliseren te activeren of druk op Ctrl+K.

  2. Typ een tekst die is geassocieerd aan het item waar u naar zoekt (naam, tag, sleutelwoord, …). Standaard worden de resultaten teruggegeven voor de ingeschakelde filters voor Lokaliseren, maar u kunt de zoekactie beperken tot een bepaald bereik door uw tekst te laten voorafgaan door het voorvoegsel voor filters van Lokaliseren, d.i. typen van l cad zal alleen de lagen teruggeven waarvan de naam cad bevat.

    Het filter kan ook worden geselecteerd met een dubbelklik in het menu dat wordt weergegeven bij het activeren van de widget Lokaliseren.

  3. Klik op een resultaat om de overeenkomstige actie uit te voeren, afhankelijk van het type item.

Tip

Opzoeken beperken tot één veld van de actieve laag

Standaard wordt een zoekactie met het filter “Objecten in alle lagen” (af) uitgevoerd op de gehele attributentabel van de laag U kunt de zoekactie beperken tot een bepaald veld door het voorvoegsel @ te gebruiken. Bijv. af @name sal of @name sal geeft alleen de objecten terug waarvan het attribuut “name” ‘sal’ bevat. Tekst automatisch aanvullen is actief bij het schrijven en de suggestie kan worden toegepast met de toets Tab.

Zoeken wordt afgehandeld met threads, zodat resultaten altijd zo snel mogelijk beschikbaar komen, zelfs als een traag filter is geïnstalleerd. Zij verschijnen ook zodra zij worden tegengekomen door een filter, wat betekent dat bijv. een zoekfilter voor bestanden de resultaten één voor één zal teruggeven omdat de boom met bestanden moet worden gescand. Dit zorgt er voor dat de gebruikersinterface altijd reageert, zelfs als er een bijzonder traag filter aanwezig is (bijv. een die een online service gebruikt).

Tip

Snelle toegang tot de configuratie van Lokaliseren

Klik op het pictogram search op de widget Lokaliseren op de Statusbalk om de lijst met filters weer te geven die u kunt gebruiken en een item Configureren dat de tab Lokaliseren van het menu Extra ► Opties… opent.

7.5.2. Acties rapporteren

In het gebied naast de balk Lokaliseren wordt een overzicht weergegeven, indien nodig, van de acties die u heeft uitgevoerd (zoals het selecteren van objecten in een laag, verwijderen van een laag) of een lange beschrijving van het gereedschap waar u overheen gaat (niet voor alle gereedschappen beschikbaar).

In het geval van langdurige bewerkingen, zoals het verzamelen van statistieken in rasterlagen, het uitvoeren van algoritmen van Processing of het renderen van verscheidene lagen in de kaartweergave, wordt een voortgangsbalk weergegeven in de Statusbalk.

7.5.3. Het kaartvenster beheren

De optie tracking Coördinaten geeft de huidige positie van de muis weer en volgt die bij het verplaatsen over de kaartweergave. U kunt de eenheid instellen (en de precisie) op de tab Project ► Eigenschappen… ► Algemeen. Klik op de kleine knop aan de linker zijde van het tekstvak om te schakelen tussen de optie Coördinaten en de optie extents Bereiken dat de coördinaten van de huidige meest linksonder en meest rechtsboven gelegen punten van de kaart weergeeft, in kaarteenheden.

Naast de weergave van de coördinaten vindt u de weergave Schaal. Het geeft de schaal weer van het kaartvenster. Er is een keuzelijst die u in staat stelt te kiezen uit vooraf gedefinieerde en aangepaste schalen.

Druk, aan de rechterkant van de schaalweergave, op de knop lockedGray om de te gebruiken schaal vast te zetten bij het gebruiken van het vergrootglas om in of uit te zoomen. Het vergrootglas stelt u in staat in te zoomen op een kaart zonder de schaal van de kaart te wijzigen, wat het gemakkelijker maakt de positie van labels en symbolen nauwkeuriger aan te passen. Het vergrotingsniveau is uitgedrukt als een percentage. Als het Vergrootglas een niveau heeft van 100%, dan is de huidige kaart niet vergroot. Aanvullend kan een standaard vergrotingswaarde worden gedefinieerd in Extra ► Opties ► Rendering ► Rendering-gedrag, wat heel nuttig is voor schermen met hoge resoluties om kleine symbolen te vergroten.

Rechts naast het gereedschap Vergrootglas kunt u een huidige rotatie met de klok mee, in graden, definiëren voor uw kaartweergave.

Aan de rechterkant van de Statusbalk staat een klein keuzevak dat kan worden gebruikt om tijdelijk te voorkomen dat lagen worden gerenderd naar de kaartweergave (zie gedeelte Renderen).

Rechts van de functies voor renderen vindt u de knop projectionEnabled EPSG:code met het huidige project-CRS. Klikken hierop opent het dialoogvenster Projecteigenschappen en kunt u een ander CRS toewijzen aan de kaartweergave.

Tip

Berekenen van de correcte schaal in het kaartvenster

Wanneer u QGIS start is het standaard CRS WGS 84 (EPSG 4326) en zijn graden de eenheid. Dat betekent dat QGIS een coördinaat in uw laag zal interpreteren als zijnde gespecificeerd in graden. U kunt, om de juiste schaalwaarden te verkrijgen, ofwel handmatig deze instelling wijzigen, bijv. naar meters, op de tab Algemeen onder Project ► Eigenschappen… of u kunt het pictogram projectionEnabled EPSG:code gebruiken zoals hierboven weergegeven. In het laatste geval worden de eenheden ingesteld op wat de projectie voor het project specificeert (bijv. +units=us-ft).

Onthoud dat de keuze voor het CRS bij het opstarten kan worden ingesteld in Extra ► Opties ► CRS.

7.5.4. Berichten

De knop messageLog Berichten ernaast opent het paneel Logboekmeldingen met informatie over onderliggende processen (opstarten van QGIS, laden van plug-ins, verwerken van gereedschappen…)

Afhankelijk van de instellingen van Plug-ins beheren en installeren, kan de statusbalk aan de rechterzijde pictogrammen weergeven om u te informeren over nieuwe pluginNew of bij te werken pluginUpgrade plug-ins. Klik op het pictogram om het dialoogvenster Plug-ins beheren en installeren te openen.