13.1. Gegevens openen

Als deel van een Open Source Software ecosysteem is QGIS gebouwd met verschillende bibliotheken die, gecombineerd met zijn eigen providers, mogelijkheden bieden tot het lezen en vaak ook schrijven in veel indelingen:

  • Indelingen voor vectorgegevens omvatten onder meer GeoPackage, GML, GeoJSON, GPX, KML, Comma Separated Values, ESRI indelingen (Shapefile, Geodatabase…), MapInfo en MicroStation bestandsindelingen, AutoCAD DWG/DXF, GRASS en nog veel meer… Lees de complete lijst met ondersteunde vectorindelingen.

  • Indelingen voor rastergegevens omvatten onder meer GeoTIFF, JPEG, ASCII Gridded XYZ, MBTiles, R of Idrisi rasters, GDAL Virtual, SRTM, Sentinel Data, ERDAS IMAGINE, ArcInfo Binary Grid, ArcInfo ASCII Grid, en nog veel meer… Lees de complete lijst met ondersteunde rasterindelingen.

  • Database-indelingen omvatten PostgreSQL/PostGIS, SQLite/SpatiaLite, Oracle, DB2 of MSSQL Spatial, MySQL…;

  • Webkaart- en gegevensservices (WM(T)S, WFS, WCS, CSW, XYZ-tegels, ArcGIS services, …) worden ook afgehandeld door providers van QGIS. Bekijk Werken met protocollen van OGC / ISO voor meer informatie over enkele hiervan.

  • U kunt ondersteunde bestanden lezen vanuit archiefmappen en eigen indelingen van QGIS gebruiken, zoals QML-bestanden (QML - De QGIS indeling voor stijlbestand) en virtuele en geheugenlagen.

Meer dan 80 vector- en 140 rasterindelingen worden ondersteund door GDAL en eigen providers van QGIS.

Notitie

Niet alle vermelde indelingen zouden kunnen werken in QGIS, om verschillende redenen. Sommige vereisen, bijvoorbeeld, externe merkgebonden bibliotheken, of de installatie van GDAL/OGR voor uw besturingssysteem zou niet gebouwd hoeven te zijn om de indeling, die u wilt gebruiken, te ondersteunen. Voer, om de lijst met beschikbare indelingen te bekijken, de opdrachten voor de opdrachtregel ogrinfo --formats (voor vectors) en gdalinfo --formats (voor rasters) uit, of selecteer het menu Extra ► Opties ► GDAL in QGIS.

In QGIS, afhankelijk van de gegevensindeling, staan verschillende gereedschappen om een gegevensset te openen, voornamelijk beschikbaar in het menu Kaartlagen ► Laag toevoegen ► of vanaf de werkbalk Kaartlagen beheren (ingeschakeld via het menu Beeld ► Werkbalken). Al deze gereedschappen verwijzen naar een uniek dialoogvenster, het dialoogvenster Databronnen beheren, dat u kunt openen met de knop dataSourceManager Databronnen beheren openen, beschikbaar op de werkbalk Databronnen beheren, of door te drukken op Ctrl+L. Het dialoogvenster Databronnen beheren Fig. 13.1 biedt een geünificeerde interface om gegevens, gebaseerd op vector- of rasterbestanden, te openen, als ook databases of webservices die worden ondersteund door QGIS. Het kan modaal of niet ingesteld worden met checkbox Modeless dialoogvenster Databronnen beheren in het menu Extra ► Opties ► Algemeen.

../../../_images/datasource_manager.png

Fig. 13.1 QGIS dialoogvenster Databronnen beheren

Naast dit belangrijkste toegangspunt, heeft u ook de plug-in dbManager DB Manager die geavanceerde mogelijkheden biedt om verbonden databases te analyseren en te bewerken. Meer informatie over mogelijkheden van DB Manager is te vinden in Plug-in DB Manager.

Er zijn nog veel meer andere gereedschappen, eigen of plug-ins van derde partijen, die u helpen bij het openen van verscheidene indelingen voor gegevens.

Dit hoofdstuk zal alleen de gereedschappen beschrijven die standaard worden verschaft in QGIS voor het laden van gegevens. Het zal zich voornamelijk focussen op het dialoogvenster Databronnen beheren, maar meer dan het beschrijven van elke tab, zal het ook de gereedschappen verkennen, gebaseerd op de gegevensprovider of de specifieke bijzonderheden van de indeling.

13.1.1. Het paneel Browser

De Browser is één van de vele manieren om snel een eenvoudig uw gegevens aan projecten toe te voegen. Het is beschikbaar als:

  • een tab Databronnen beheren, ingeschakeld door te drukken op de knop dataSourceManager Databronnen beheren openen (Ctrl+L);

  • als een paneel van QGIS dat u kunt openen vanuit het menu Beeld ► Panelen (of kde Settings ► Panels) of door te drukken op Ctrl+2.

In beide gevallen helpt de Browser u te navigeren in uw bestandssysteem en geogegevens te beheren, ongeacht het type laag (raster, vector, tabel), of de indeling van de gegevensbron (platte of gecomprimeerde bestanden, databases, webservices).

13.1.1.1. De interface verkennen

Boven in het paneel Browser vindt u enkele knoppen die u helpen bij:

  • addLayer Geselecteerde lagen toevoegen: u kunt ook gegevens toevoegen aan het kaartvenster door Geselecteerde lagen toevoegen uit het contextmenu van de laag;

  • refresh Bijwerken van de boom van de browser;

  • filterMap Filter browser om te zoeken naar specifieke gegevens. Voer een zoekwoord of jokerteken in en de browser zal de boom filteren om alleen de paden te laten zien die overeenkomen met databasetabellen, bestandsnamen of mappen – andere gegevens of mappen worden niet meer weergegeven. Bekijk het voorbeeld van Browser Panel(2) in Fig. 13.2. De vergelijking mag hoofdlettergevoelig zijn of niet. Het kan ook worden ingesteld op:

    • Normaal: geef items weer die de zoektekst bevatten

    • Jokerteken(s): stem de zoekactie fijn af met de tekens ? en/of * om de positie van de zoektekst te specificeren

    • Reguliere expressie

  • collapseTree Alles inklappen de gehele boom;

  • metadata Widget Eigenschappen in-/uitschakelen: indien ingeschakeld wordt een nieuw widget toegevoegd aan de onderzijde van het paneel, dat, indien van toepassing, metadata voor het geselecteerde item weergeeft.

De items in het paneel Browser zijn hiërarchisch georganiseerd, en er zijn verscheidene items op het bovenste niveau:

  1. Favorieten waar u snelkoppelingen kunt plaatsen naar vaak gebruikte locaties

  2. Favoriete plaatsen waar u vaak gebruikte kaartbereiken kunt opslaan (zie Favoriete plaatsen)

  3. Thuis voor project: voor snelle toegang tot de map waarin de (meeste) gegevens die gerelateerd zijn aan uw project zijn opgeslagen. De standaardwaarde is de map waar uw projectbestand is opgeslagen.

  4. Home-map in het bestandssysteem en de bronmap van het bestandssysteem.

  5. Verbonden lokale of netwerkschijven

  6. Daarna komen er een aantal container / typen database en serviceprotocollen, afhankelijk van uw platform en onderliggende bibliotheken:

    • geoPackage GeoPackage

    • spatialite SpatiaLite

    • postgis PostGIS

    • mssql MSSQL

    • oracle Oracle

    • db2 DB2

    • wms WMS/WMTS

    • vectorTileLayer Vectortegels

    • xyz XYZ-tegels

    • wcs WCS

    • wfs WFS/OGC API-Features

    • ows OWS

    • ams ArcGIS Map Service

    • afs ArcGIS Feature Service

    • geonode GeoNode

13.1.1.2. Interactie met de items van de Browser

De browser ondersteunt slepen-en-neerzetten in de browser, vanuit de browser naar het kaartvenster en paneel Lagen, en vanuit het paneel Lagen naar containers van lagen (bijv. GeoPackage) in de browser.

Items van het projectbestand in de browser kunnen worden opengeklapt, wat de volledige boom van de laag weergeeft (inclusief groepen), die zijn opgenomen in dat project. Items voor het project worden op dezelfde manier behandelt als elk ander item in de browser, dus kunnen zij binnen de browser worden gesleept en neergezet (bijvoorbeeld om een item laag te kopiëren naar een bestand van Geopackage) of worden toegevoegd aan het huidige project met slepen-en-neerzetten of dubbelklikken.

Het contextmenu voor een element in het paneel Browser wordt geopend door er met rechts op te klikken.

Voor items van de map voor het bestandssysteem biedt het contextmenu het volgende:

  • Nieuw ► om in het geselecteerde item te maken een:

    • Map…

    • GeoPackage…

    • ShapeFile…

  • Als Favoriet toevoegen: favoriete mappen kunnen op elk moment worden hernoemd (Favoriet hernoemen…) of verwijderd (Favoriet verwijderen).

  • Verbergen in browser: verborgen mappen kunnen weer naar zichtbaar worden geschakeld met de instelling Extra ► Opties ► Databronnen ► Paden verbergen in paneel van browser

  • Deze map snel scannen

  • Map openen

  • In Terminal openen

  • Eigenschappen…

  • Mapeigenschappen…

Voor bladitems die kunnen optreden als lagen in het project, zal het contextmenu ondersteunende items hebben. Bijvoorbeeld voor niet-database, niet op service gebaseerde vector-, raster- en gegevensbronnen met mazen:

  • Bestand verwijderen “<name of file>”…

  • Laag exporteren –> Naar bestand…

  • Laag aan project toevoegen

  • Laageigenschappen

  • Bestandseigenschappen

In het item Laageigenschappen zult u vinden (soortgelijk aan dat wat u zult vinden in de vector en raster laageigenschappen als de lagen eenmaal zijn toegevoegd aan het project):

  • Metadata voor de laag. Groepen voor metadata: Informatie van provider (indien mogelijk, Pad zal een hyperlink naar de bron zijn), Identificatie, Bereik, Toegang, Velden (voor vectorlagen), Banden (voor rasterlagen), Contact, Links (voor vectorlagen), Verwijzingen (voor rasterlagen), Geschiedenis.

  • Een paneel Voorbeeld

  • De attributentabel voor vectorbronnen (in het paneel Attributen).

De Browser gebruiken om een laag aan het project toe te voegen:

  1. Schakel de Browser in zoals hierboven beschreven. Een boom voor de browser met uw bestandssysteem, databases en webservices wordt weergegeven. U zou misschien moeten verbinden met databases en webservices voordat zij zichtbaar zijn (zie betreffende gedeelten).

  2. Zoek de laag op in de lijst.

  3. Gebruik het contextmenu, dubbelklik op de naam ervan of sleep en zet het neer in het kaartvenster. Uw laag wordt nu toegevoegd aan het paneel Lagen en kan worden bekeken in het kaartvenster.

    Tip

    Een project van QGIS direct openen vanuit de browser

    U kunt ook direct een project van QGIS openen vanuit het paneel Browser door te dubbelklikken op de naam of door het te slepen en neer te zetten in het kaartvenster.

Als een bestand eenmaal is geladen, kunt u daar in zoomen met de gereedschappen voor kaartnavigatie. Open, om de stijl van een laag te wijzigen, het dialoogvenster Laageigenschappen door te dubbelklikken op de naam van de laag of met rechts te klikken op de naam in de legenda en Eigenschappen te kiezen in het contextmenu. Bekijk het gedeelte Eigenschappen Symbologie voor meer informatie over het instellen van symbologie voor vectorlagen.

Met rechts klikken op een item in de boom van de Browser helpt u om:

  • voor een bestand of een tabel, de metadata ervan weer te geven of het te openen in uw project. Tabellen kunnen zelfs worden hernoemd, verwijderd of afgebroken.

  • voor een map, een bladwijzer te maken in uw Favorieten of het te verbergen in de boom van de Browser. Verborgen mappen kunnen worden beheerd vanaf de tab Extra ► Opties ► Databronnen.

  • uw Favoriete plaatsen te beheren: Favoriete plaatsen kunnen worden gemaakt, geëxporteerd en geïmporteerd als XML-bestanden.

  • een verbinding naar een database of een webservice te maken.

  • een schema te vernieuwen, te hernoemen of te verwijderen.

U kunt ook bestanden importeren in databases of tabellen kopiëren van het/de ene schema/database naar een ander met eenvoudig slepen-en-neerzetten. Er is een tweede paneel Browser beschikbaar om lang scrollen bij het slepen te vermijden. Selecteer eenvoudigweg het bestand en plaats het met slepen-en-neerzetten van het ene paneel in het andere.

../../../_images/browser_panels.png

Fig. 13.2 Panelen QGIS Browser naast elkaar

Tip

Lagen aan QGIS toevoegen door ze eenvoudigweg te slepen en neer te zetten vanuit de bestandsbrowser van uw besturingssysteem

U kunt ook bestand(en) toevoegen aan het project door ze te slepen en neer te zetten vanuit de bestandsbrowser van uw besturingssysteem naar het paneel Lagen of het kaartvenster.

13.1.2. De DB Manager

De plug-in DB Manager is een ander gereedschap voor het integreren en beheren van indelingen voor ruimtelijke databases, die worden ondersteund door QGIS (PostGIS, SpatiaLite, GeoPackage, Oracle Spatial, MSSQL, DB2, virtuele lagen). Het kan worden geactiveerd via het menu Plug-ins ► Plug-ins beheren en installeren….

De plug-in dbManager DB Manager verschaft verscheidene mogelijkheden:

  • verbinden met databases en hun structuur en inhoud weergeven

  • voorbeelden van tabellen van databases

  • lagen toevoegen aan het kaartvenster, ofwel door te dubbelklikken of met slepen-en-neerzetten.

  • lagen aan een database toevoegen vanuit de QGIS Browser of vanuit een andere database

  • SQL-query’s maken en hun uitvoer toevoegen aan het kaartvenster

  • virtuele lagen maken

Meer informatie over mogelijkheden van DB Manager is te vinden in Plug-in DB Manager.

../../../_images/db_manager.png

Fig. 13.3 Dialoogvenster DB Manager

13.1.3. Provider-gebaseerde gereedschappen voor laden

Naast het paneel Browser en de DB Manager, de belangrijkste door QGIS verschafte gereedschappen om lagen toe te voegen, zult u ook gereedschappen vinden die specifiek voor gegevensproviders zijn.

Notitie

Sommige externe plug-ins verschaffen ook gereedschappen om bestanden met specifieke indelingen te openen in QGIS.

13.1.3.1. Een laag uit een bestand laden

Een laag uit een bestand laden:

  1. Open de tab voor het type laag in het dialoogvenster Databronnen beheren, d.i. klik op de knop dataSourceManager Databronnen beheren openen (of druk op Ctrl+L) en schakel de tab voor het doel in of:

    • voor vectorgegevens (zoals GML, ESRI Shapefile, Mapinfo- en DXF-lagen): druk op Ctrl+Shift+V, selecteer de menuoptie Kaartlagen ► Laag toevoegen ► addOgrLayer Vectorlaag toevoegen of klik op de knop op de werkbalk addOgrLayer Vectorlaag toevoegen.

      ../../../_images/addvectorlayerdialog.png

      Fig. 13.4 Dialoogvenster Vectorlaag toevoegen

    • voor rastergegevens (zoals GeoTiff, MBTiles, GRIdded Binaire en DWG-lagen): druk op Ctrl+Shift+R, selecteer de menuoptie Kaartlagen ► Laag toevoegen ► addRasterLayer Rasterlaag toevoegen of klik op de knop op de werkbalk addRasterLayer Rasterlaag toevoegen.

      ../../../_images/addrasterlayerdialog.png

      Fig. 13.5 Dialoogvenster Rasterlaag toevoegen

  2. Selecteer het Type bron radioButtonOn Bestand

  3. Klik op de knop Bladeren

  4. Navigeer in het bestandssysteem en laadt een ondersteunde gegevensbron. Meer dan één laag kan tegelijkertijd worden geladen door de Ctrl-toets ingedrukt te houden en te klikken op meerdere items in het dialoogvenster of door de Shift-toets ingedrukt te houden om een bereik aan items te selecteren door te klikken op het eerste en laatste item in het bereik. Alleen indelingen die goed zijn getest zullen in het filter voor de indelingen verschijnen. Andere indelingen kunnen worden geladen door Alle bestanden te selecteren (het bovenste item in het keuzemenu).

  5. Druk op Openen om het geselecteerde bestand te laden in het dialoogvenster Databronnen beheren

    ../../../_images/openoptionsvectorlayer.png

    Fig. 13.6 Een Shapefile laden met opties voor openen

  6. Druk op Toevoegen om het bestand in QGIS te laden en het weer te geven in het kaartvenster. Fig. 13.7 geeft QGIS weer na het laden van het bestand alaska.shp.

    ../../../_images/shapefileloaded.png

    Fig. 13.7 QGIS met het geladen shapefile van Alaska

Notitie

Voor het laden van vectorbestanden biedt het stuurprogramma van GDAL de mogelijkheid om acties voor openen te definiëren. Deze zullen worden weergegeven als het vectorbestand wordt geselecteerd. Opties worden in detail beschreven op https://gdal.org/drivers/vector/.

Notitie

Omdat sommige indelingen, zoals MapInfo (bijv. .tab) of Autocad (.dxf) het mixen van verschillende typen geometrie in één enkel bestand toestaan, opent het laden van dergelijke gegevenssets een dialoogvenster om de te gebruiken geometrieën te selecteren, teneinde één geometrie per laag te hebben.

De tabs addOgrLayer Vectorlaag toevoegen en addRasterLayer Rasterlaag toevoegen staan het laden van lagen toe vanuit andere typen bron dan Bestand:

  • U kunt specifieke vectorindelingen, zoals ArcInfo Binary Coverage, UK. National Transfer Format, laden als ook de indeling voor ruwe TIGER van het US Census Bureau of OpenfileGDB. U selecteert, om dat te doen, radioButtonOn Map als Type bron. In dit geval kan een map worden geselecteerd in het dialoogvenster, na het drukken op Bladeren.

  • Met het Type bron radioButtonOn Database kunt u een bestaande databaseverbinding selecteren of er een maken voor het geselecteerde type database. Enkele mogelijke typen databases zijn ODBC, Esri Personal Geodatabase, MSSQL, als ook PostgreSQL of MySQL.

    Drukken op de knop Nieuw opent het dialoogvenster Nieuwe OGR-databaseverbinding maken, waarvan de parameters tussen die staan welke u kunt vinden in Een opgeslagen verbinding maken. Drukken op Openen laat u selecteren uit de beschikbare tabellen, bijvoorbeeld van met PostGIS ingeschakelde databases.

  • Het Type bron radioButtonOn Protocol: HTTP(S), cloud, etc. opent gegevens die lokaal zijn opgeslagen op het netwerk, ofwel publiek toegankelijk of in private mandjes of commerciële services voor opslag in de cloud. Ondersteunde typen protocol zijn:

    • HTTP/HTTPS/FTP, met een URI en, indien vereist, een authenticatie.

    • Opslag in de cloud, zoals AWS S3, Google Cloud Storage, Microsoft Azure Blob, Alibaba OSS Cloud, Open Stack Swift Storage. U dient Mandje of container en de Sleutel voor object in te vullen.

    • service die OGC ondersteunt WFS 3 (nog steeds experimenteel), gebruikt indeling GeoJSON of GEOJSON - Newline Delimited of gebaseerd op database CouchDB. Een URI is vereist, met optionele authenticatie.

    • Voor alle typen vectorbronnen is het mogelijk om de Codering te definiëren of de instelling Automatisch ► te gebruiken.

13.1.3.2. Laden van een laag met mazen

Een laag met mazen is een ongestructureerd raster, gewoonlijk met tijdelijke en andere componenten. De ruimtelijke component bevat een collectie punten, randen en zijden in ruimte 2D of 3D. Meer informatie over lagen met mazen op Werken met gegevens met mazen.

Een laag met mazen toevoegen aan QGIS:

  1. Open het dialoogvenster Databronnen beheren, ofwel door het te selecteren in het menu Kaartlagen ► of te klikken op de knop dataSourceManager Databronnen beheren openen.

  2. Schakel naar de tab addMeshLayer Mazen in het linkerpaneel

  3. Druk op de knop Bladeren om het bestand te selecteren. Verscheidene indelingen worden ondersteund.

  4. Selecteer de laag en druk op Toevoegen. De laag zal worden toegevoegd met de eigen rendering voor mazen.

../../../_images/mesh_datasource_manager.png

Fig. 13.8 Tab Mazen in Databronnen beheren

13.1.3.3. Een tekstgescheiden bestand importeren

Tekengescheiden tekstbestanden (bijv. .txt, .csv, .dat, .wkt) kunnen worden geladen met de hierboven beschreven gereedschappen. Op deze manier zullen zij verschijnen als eenvoudige tabellen. Soms kunnen tekengescheiden tekstbestanden coördinaten / geometrieën bevatten die u zou willen visualiseren. Dat is waar addDelimitedTextLayerTekstgescheiden-laag toevoegen voor is ontworpen.

  1. Klik op het pictogram dataSourceManager Databronnen beheren openen om het dialoogvenster Databronnen beheren te openen

  2. Schakel naar de tab addDelimitedTextLayer Tekengescheiden tekst

  3. Selecteer het te importeren gescheiden tekstbestand (bijv. qgis_sample_data/csv/elevp.csv) door te klikken op de knop Bladeren.

  4. In het veld Laagnaam, geef de te gebruiken naam op voor de laag in het project (bijv. Hoogte).

  5. Configureer de instellingen zoals die voor uw gegevensset en behoeften nodig zijn, zoals hieronder uitgelegd.

../../../_images/delimited_text_dialog.png

Fig. 13.9 Dialoogvenster Maak een laag uit een tekstgescheiden bestand

13.1.3.3.1. Bestandsindeling

Als het bestand eenmaal is geselecteerd, probeert QGIS het bestand te parsen met het meest recent gebruikte scheidingsteken, dat velden en rijen identificeert. Het is belangrijk om het juiste scheidingsteken te selecteren, om QGIS zodanig in te schakelen dat het bestand op de juiste wijze wordt geparset. U kunt een scheidingsteken selecteren door te kiezen tussen:

  • radioButtonOnCSV (komma gescheiden waarden) om het teken komma te gebruiken.

  • radioButtonOffReguliere expressie tekstscheider en voer tekst in in het veld Expressie. Gebruik bijvoorbeeld \t om het scheidingsteken naar tab te wijzigen (dit wordt in reguliere expressies gebruikt voor het teken tab).

  • radioButtonOffZelfgekozen tekstscheiders, kiezen uit enkele vooraf gedefinieerde scheidingstekens, zoals komma, spatie, tab, puntkomma, … .

13.1.3.3.2. Records en velden

Enkele andere handige opties kunnen worden gebruikt voor het herkennen van gegevens:

  • Aantal kopregels die overgeslagen kunnen worden: handig wanneer u de eerste regels in het bestand wilt vermijden bij het importeren, ofwel omdat het blanco regels zIjn, of met een andere opmaak.

  • checkboxDe eerste regel bevat veldnamen: waarden in de eerste regel worden gebruikt als veldnamen, anders gebruikt QGIS de veldnamen field_1, field_2

  • checkboxVeldtypen detecteren: automatisch het type veld herkennen. Indien niet geselecteerd worden alle attributen behandeld als tekstvelden.

  • checkboxDecimaal scheidingsteken is de komma: u kunt forceren dat een komma het decimale scheidingsteken is.

  • checkboxSpaties voor/na velden verwijderen: stelt u in staat spaties voor en achter de tekst van de velden te verwijderen.

  • checkboxSla lege velden over.

Als u de eigenschappen voor het parsen instelt, wordt de voorbeeldweergave van de gegevens aan de onderzijde van het dialoogvenster bijgewerkt.

13.1.3.3.3. Geometrie definitie

Als het bestand eenmaal is geparst, stel Geometrie definitie in op

  • radioButtonOnPunt coördinaten en geef de X-veld, Y-veld, Z-veld (voor 3-dimensionale gegevens) en M-veld (voor de dimensie maat) op als de laag van het type geometrie punt is en dergelijke velden bevat. Activeer het keuzevak checkboxDMS-coördinaten als de coördinaten zijn gedefinieerd als graden/minuten/seconden. Verschaf het van toepassing zijnde Geometrie CRS met de widget setProjection CRS selecteren.

  • radioButtonOnWell known text (WKT) optie als de ruimtelijke informatie wordt weergegeven als WKT: selecteer het Geometrie-veld dat de geometrie WKT bevat en kies het van toepassing zijnde Type geometrie of laat QGIS dat automatisch detecteren. Geef het van toepassing zijnde Geometrie CRS op met de widget setProjection CRS selecteren.

  • Als het bestand geen ruimtelijke gegevens bevat, activeer dan radioButtonOn Geen geometrieën (alleen attributentabel) en het zal worden geladen als een gewone tabel.

13.1.3.3.4. Laag-instellingen

Aanvullend kunt u inschakelen:

  • checkboxRuimtelijke index gebruiken om de uitvoering van het weergeven en ruimtelijk selecteren van objecten te verbeteren.

  • checkboxGebruik een subset index om het uitvoeren van subsetfilters te verbeteren (indien gedefinieerd in de laageigenschappen).

  • checkboxBestand in de gaten houden om de wijzigingen aan het bestand door andere toepassingen terwijl QGIS wordt uitgevoerd bij te houden.

Aan het einde, klik op Toevoegen om de laag aan de kaart toe te voegen. In ons voorbeeld wordt een puntenlaag, genaamd Hoogte, toegevoegd aan het project en gedraagt zich als elke andere laag in QGIS. Deze laag is het resultaat van een query op het bronbestand .csv (deswege, eraan gekoppeld) en zou moeten worden opgeslagen om een ruimtelijke laag op schijf te krijgen.

13.1.3.4. Een DXF- of DWG-bestand importeren

DXF- en DWG-bestanden kunnen aan QGIS worden toegevoegd door ze eenvoudigweg te slepen-en-neerzetten vanuit het paneel Browser. U zult worden gevraagd de sublagen te selecteren die u aan het project zou willen toevoegen. Lagen worden toegevoegd met willekeurige eigenschappen voor de stijl.

Notitie

Voor DXF-bestanden die verschillende typen geometrie bevatten (punt, lijn en/of polygoon), zal de naam van de lagen worden gemaakt als <bestandsnaam.dxf> entiteiten <geometry type>.

Wanneer u de bestandsstructuur van DXF/DWG en de symbologie ervan in QGIS wilt behouden, wilt u waarschijnlijk het toegewezen gereedschap Project ► Importeren/Exporteren ► Lagen importeren vanuit DWG/DXF… gebruiken dat u in staat stelt:

  1. elementen uit het bestand van de tekening in een database van GeoPackage te importeren.

  2. geïmporteerde elementen toe te voegen aan het project.

In het dialoogvenster DWG/DXF importeren om de inhoud van het bestand met de tekening te importeren:

  1. Voer de locatie van het Doelpakket in, d.i. het nieuwe bestand van GeoPackage dat de gegevens zal bevatten. Als een bestaand bestand wordt opgegeven, zal dat worden overschreven.

  2. Specificeer het coördinaten referentiesysteem van de gegevens in het bestand van de tekening.

  3. Selecteer checkbox Verwijzingen naar blokken uitbreiden om de blokken in het bestand van de tekening als normale elementen te importeren.

  4. Selecteer checkbox Bogen gebruiken om de geïmporteerde lagen te promoveren naar een type geometrie boog.

  5. Gebruik de knop Importeren om het te gebruiken bestand DWG/DXF te selecteren (één per Geopackage). De database van GeoPackage zal automatisch worden gevuld met de inhoud van het bestand van de tekening. Afhankelijk van de grootte van het bestand kan dit enige tijd duren.

Nadat de .dwg- of .dxf-gegevens zijn geïmporteerd in de database van GeoPackage wordt het frame in de onderste helft van het dialoogvenster gevuld met de lijst met lagen van het geïmporteerde bestand. Daar kunt u selecteren welke lagen toe te voegen aan het project van QGIS:

  1. Stel, bovenin, een Groepsnaam in om de tekeningbestanden in het project te groeperen.

  2. Selecteer weer te geven lagen: Elke geselecteerde laag wordt toegevoegd aan een ad hoc-groep die vectorlagen bevat voor de punt, lijn, label en gebiedsobjecten van de laag met de tekening. De stijl van de lagen zal lijken op hoe zij eruit zagen in *CAD.

  3. Kies of de laag zichtbaar zou moeten zijn bij openen.

  4. Selecteren van de optie checkbox Lagen samenvoegen plaatst alle lagen in één enkele groep.

  5. Druk op OK om de lagen in QGIS te openen.

../../../_images/dwg_dxf_import_dialog.png

Fig. 13.10 Dialoogvenster voor het importeren van bestanden DWG/DXF

13.1.3.5. OpenStreetMap vectors importeren

Het project OpenStreetMap is populair, omdat in veel landen geen vrije ruimtelijke gegevens, zoals digitale wegenkaarten, beschikbaar zijn. Het doel van het project OSM is om een vrij bewerkbare kaart van de wereld te maken uit gegevens van GPS, luchtfotografie en lokale kennis. QGIS verschaft ondersteuning voor gegevens van OSM om dit doel te ondersteunen.

Met het paneel Browser kunt u een bestand .osm laden in het kaartvenster, in welk geval u een dialoogvenster zult krijgen om sublagen te selecteren, gebaseerd op het type geometrie. De geladen lagen zullen alle gegevens bevatten van dat type geometrie in het bestand .osm, en zal de gegevensstructuur van het bestand osm behouden.

13.1.3.6. SpatiaLite-lagen

addSpatiaLiteLayer De eerste keer dat u gegevens laadt vanuit een database van SpatiaLite begint met:

  • klikken op de knop van de werkbalk addSpatiaLiteLayer SpatiaLite-laag toevoegen

  • selecteren van de optie addSpatiaLiteLayer SpatiaLite-laag toevoegen… uit het menu Kaartlagen ► Laag toevoegen

  • of door te typen Ctrl+Shift+L

Dit zal een venster openen dat u in staat zal stellen om ofwel te verbinden met een database van SpatiaLite, die al bekend is bij QGIS (die u kiest uit het keuzemenu) of om een nieuwe verbinding naar een nieuwe database te maken. Klik, om een nieuwe verbinding te definiëren, op Nieuw en gebruik de bestandsbrowser om naar uw database van SpatiaLite, wat een bestand is met de extensie .sqlite, te verwijzen.

QGIS ondersteunt ook het bewerken van gegevens via te bewerken Views in SpatiaLite.

13.1.3.7. GPS

Laden van gegevens van GPS in QGIS kan worden gedaan met de bronplug-in GPS-gereedschap. Instructies zijn te vinden in het gedeelte Plug-in GPS-gereedschap.

13.1.3.8. GRASS

Werken met vectorgegevens van GRASS wordt beschreven in het gedeelte Integratie van GRASS GIS.

13.1.4. QGIS aangepaste indelingen

QGIS stelt twee aangepaste indelingen voor:

13.1.5. QLR - QGIS Laag-definitiebestand

Laagdefinities kunnen worden opgeslagen als een Laag-definitiebestand (QLR - .qlr) met behulp van Exporteren ► Opslaan als Laag-definitiebestand… in het contextmenu van de laag.

De indeling QLR maakt het mogelijk om “complete” QGIS-lagen te delen met andere gebruikers van QGIS. QLR-bestanden bevatten koppelingen naar de gegevensbronnen en alle benodigde QGIS stijlinformatie om de laag op te kunnen maken.

QLR-bestanden worden in het paneel Browser weergegeven en kunnen worden gebruikt om lagen toe te voegen (met hun opgeslagen stijlen) aan het paneel Lagen. U kunt ook QLR-bestanden slepen en neerzetten vanuit de systeem bestandsbeheerder in het kaartvenster.

13.1.6. Verbinden met webservices

Met QGIS kunt u toegang verkrijgen tot verschillende typen webservices van OGC (WM(T)S, WFS(-T), WCS, CSW, …). Dankzij QGIS Server kunt u dergelijke services ook publiceren. QGIS Server Gebruikershandleiding bevat beschrijvingen van deze mogelijkheden.

13.1.6.1. Vector tegelservices gebruiken

Vector tegelservices zijn te vinden in het item op het hoogste niveau Vector Tiles in de Browser. U kunt een service toevoegen door het contextmenu te openen met een klik met rechts en te kiezen voor Nieuwe algemene verbinding …. U stelt een service in door een Naam en een URL toe te voegen. De Vector tegelservice moet tegels verschaffen in de indeling .pbf. Het dialoogvenster verschaft twee menu’s om het checkboxMin. zoomniveau en het checkboxMax. zoomniveau te definiëren. Vectortegels hebben een structuur van piramiden. Door deze opties te gebruiken heeft u de mogelijkheid om individueel lagen te maken uit de tegelpiramide. Deze lagen zullen dan worden gebruikt om de vectortegel te renderen in QGIS. Voor projectie Mercator (gebruikt door OpenStreetMap Vector Tiles) geeft zoomniveau 0 de gehele wereld weer op een schaal van 1:500.000.000. Zoomniveau 14 geeft de schaal 1:35.000 weer. Fig. 13.13 geeft het dialoogvenster weer met de configuratie voor de MapTiler planet Vector Tiles service.

../../../_images/vector_tiles_maptilerplanet.png

Fig. 13.13 Vector Tiles - configuratie Maptiler Planet

Door Nieuwe ArcGIS vectortegel serviceverbinding … te gebruiken kunt u verbinden met ArcGIS Vector Tile Services.

13.1.6.2. XYZ Tile-services gebruiken

XYZ Tile-services zijn te vinden in het item op het bovenste niveau XYZ Tiles in de Browser. Standaard is de OpenStreetMap XYZ Tile-service geconfigureerd. U kunt andere services toevoegen, die het protocol XYZ Tile gebruiken, door te kiezen Nieuwe verbinding in het contextmenu van XYZ Tiles (klik met rechts om te openen). Fig. 13.14 geeft het dialoogvenster weer met de configuratie van de OpenStreetMap XYZ Tile-service.

../../../_images/xyz_tiles_dialog_osm.png

Fig. 13.14 XYZ Tiles - OpenStreetMap configuratie

Configuraties kunnen worden opgeslagen (Verbindingen opslaan) naar XML en geladen (Verbindingen laden) via het contextmenu. Configuratie voor authenticatie wordt ondersteund. Het XML-bestand voor OpenStreetMap ziet er uit als dit:

<!DOCTYPE connections>
<qgsXYZTilesConnections version="1.0">
  <xyztiles url="https://tile.openstreetmap.org/{z}/{x}/{y}.png"
   zmin="0" zmax="19" password="" name="OpenStreetMap" username=""
   authcfg="" referer=""/>
</qgsXYZTilesConnections>

Als eenmaal een verbinding naar een XYZ tile-service is ingesteld, klik dan met rechts op het item voor:

  • Bewerken… van de verbindingsinstellingen voor XYZ

  • Verwijderen van de verbinding

  • Laag exporteren… ► Naar bestand, het opslaan als een raster

  • Laag aan project toevoegen: een dubbelklik voegt de laag ook toe

  • Bekijk de Laageigenschapopen… en krijg toegang tot metadata en een voorbeeld van de gegevens die door de service worden verschaft. Meer instellingen zijn beschikbaar als de laag in het project is geladen.

Voorbeelden van XYZ Tile-services:

  • OpenStreetMap Monochrome: URL: http://tiles.wmflabs.org/bw-mapnik/{z}/{x}/{y}.png, Min. Zoom Level: 0, Max. Zoom Level: 19.

  • Google Maps: URL: https://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}, Min. Zoom Level: 0, Max. Zoom Level: 19.

  • OpenWeather Map Temperature: URL: http://tile.openweathermap.org/map/temp_new/{z}/{x}/{y}.png?appid={api_key} Min. Zoom Level: 0, Max. Zoom Level: 19.