13.1. データを開く

オープンソース・ソフトウェアのエコシステムの一部として、QGISは様々なライブラリの上に構築されています。これらのライブラリは、QGIS独自のプロバイダと組み合わされることで、多くのフォーマットを読む機能と、そして多くの場合は書く機能も提供しています。ここに含まれるフォーマットは以下のようなものです。

  • ベクタデータ形式: GeoPackage、GML、GeoJSON、GPX、KML、コンマ区切りテキスト、ESRIフォーマット(シェープファイル、ジオデータベース等)、MapInfo、MicroStationファイル形式、AutoCAD DWG/DXF、GRASS、その他多くの形式が含まれます。 サポートしているベクタ形式 に完全なリストがあります。

  • ラスタデータ形式: GeoTIFF、JPEG、ASCII Gridded XYZ、MBTiles、RやIDRISIラスタ、 GDAL Virtual、SRTM、Sentinel Data、ERDAS IMAGINE、ArcInfo Binary Grid、ArcInfo ASCII Grid、その他多くの形式が含まれます。 サポートしているラスタ形式 に完全なリストがあります。

  • データベース形式: PostgreSQL/PostGIS、SQLite/SpatiaLite、Oracle、DB2、MSSQL Spatial、MySQL等が含まれます。

  • WebマップとWebデータサービス(WM(T)S、WFS、WCS、CSW、XYZ tiles、ArcGIS services等)もQGISのプロバイダで扱うことが可能です。これらの一部についてのより詳しい情報は Working with OGC / ISO protocols を参照してください。

  • アーカイブされたフォルダからサポートしているフォーマットのファイルを読み込んだり、QML ファイル ( QML-QGISスタイルファイル形式 )などのQGISネイティブ形式や仮想レイヤ、メモリレイヤを使用することができます。

80以上のベクタ形式と140以上のラスタ形式が GDAL とQGISネイティブプロバイダによってサポートされています。

注釈

さまざまな理由により、リストに挙げたすべてのフォーマットがQGISで動作するわけではありません。例えば、外部のプロプライエタリなライブラリを必要とする場合や、お使いのOSのGDAL/OGRのインストールが、使用したいフォーマットをサポートするようにビルドされていない場合もあります。利用可能なフォーマットのリストを確認するには、コマンドラインで ogrinfo --formats (ベクタ用)や gdalinfo --formats (ラスタ用)を実行するか、QGIS上で 設定 ► オプション ► GDAL のメニューを確認してください。

QGISでは、データ形式に応じて、データセットを開くためのさまざまなツールがあります。それらは主に レイヤ ► レイヤの追加 ► メニューまたは レイヤ管理 ツールバー( ビュー ► ツールバー メニューで有効にできます)で使用できます。ただし、これらのツールはすべて データソースマネージャ ダイアログというただ一つのダイアログを指しています。このダイアログは データソースマネージャツールバー にある dataSourceManager データソースマネージャを開く ボタンを押すか、または Ctrl+L を押すと開くことができます。 データソースマネージャ ダイアログ( 図 13.1 )は、ベクタ形式またはラスタ形式のファイルベースのデータやデータベース、QGISがサポートするWebサービスを開くための統一されたインターフェイスを提供します。 このダイアログは、 設定 ► オプション ► 一般 メニューの checkbox モードレスデータソースマネージャダイアログ でモーダルに設定したりモードレスに設定できます。

../../../_images/datasource_manager.png

図 13.1 QGISのデータソースマネージャダイアログ

このメインエントリポイントの他に、接続されたデータベースを分析したり操作したりする高度な機能を提供する dbManager DBマネージャ プラグインがあります。DBマネージャの機能についての詳細は、 DB Manager Plugin を参照してください。

他にも多くのツールやネイティブのプラグイン、サードパーティ製のプラグインがあり、様々なデータ形式を開くのに役立ちます。

この章では、QGISでデータをロードするためにデフォルトで提供されているツールのみを説明します。主に、 データソースマネージャ ダイアログに焦点を当てますが、 各タブの説明だけでなく、データプロバイダやフォーマットの仕様に基づいたツールについても説明します。

13.1.1. ブラウザパネル

ブラウザ は、素早く簡単にデータをプロジェクトに追加する主な方法の一つです。これは、以下の方法で利用できます。

  • dataSourceManager データソースマネージャを開く ボタン( Ctrl+L )を押して開いた データソースマネージャ のタブの一つにブラウザがあります。

  • ビュー ► パネルkde設定 ► パネル )メニューもしくは Ctrl+2 を押すことで開くQGISのパネルとして利用できます。

どちらの場合でも、 ブラウザ はレイヤの種類(ラスタ、ベクタ、テーブル)やデータソースの形式(プレーンまたは圧縮ファイル、データベース、webサービス)に関係なく、ファイルシステム内を検索しジオデータを管理するのに役立ちます。

13.1.1.1. インターフェースについて

ブラウザパネルの上部には、以下の機能を持つボタンがあります:

  • addLayer 選択したレイヤの追加 :レイヤのコンテキストメニューから レイヤをプロジェクトに追加する を選択することでも、マップキャンバスにデータを追加することができます。

  • refresh 再読み込み :ブラウザツリーを更新します

  • filterMap ブラウザのフィルタ :特定のデータを検索するためにブラウザをフィルタリングします。検索語やワイルドカードを入力すると、ブラウザはツリーをフィルタリングして、一致するDBテーブル、ファイル名、フォルダへのパスのみを表示します -- 他のデータやフォルダは表示されません。 図 13.2 のブラウザ(2)パネルの例を参照してください。比較は大文字と小文字を区別するかどうかを指定できます。また、下記のオプションを設定することもできます:

    • 通常 :検索テキストを含むアイテムを表示します

    • ワイルドカード?* の文字を使用して、検索テキストの位置指定を調整した検索を実行できます。

    • 正規表現

  • collapseTree すべて折りたたむ :ツリー全体を折りたたみます

  • metadata プロパティウィジェットの有効化/無効化 :オンに切り替わると、パネルの下部に新しいウィジェットが追加され、選択されたアイテムのメタデータが表示されます。

ブラウザ パネル内のエントリは階層的にまとめられており、いくつかのトップレベルエントリがあります:

  1. お気に入り :よく使用する場所へのショートカットを置くことができる場所です

  2. 空間ブックマーク :よく使用するマップ範囲を保存できる場所です( 空間ブックマーク 参照)

  3. プロジェクトホーム :プロジェクトに関連したデータ(の大半)が保存されているフォルダへのクイックアクセスです。デフォルト値は、プロジェクトファイルがあるディレクトリです。

  4. ファイルシステムの ホーム ディレクトリと、ファイルシステムのルートディレクトリ

  5. 接続されているローカルドライブやネットワークドライブ

  6. それから、プラットフォームと基礎となるライブラリにもよりますが、多数のコンテナ / データベース形式やサービスプロトコルのトップレベルエントリがあります:

    • geoPackage GeoPackage

    • spatialite SpatiaLite

    • postgis PostGIS

    • mssql MSSQL

    • oracle Oracle

    • db2 DB2

    • wms WMS/WMTS

    • vectorTileLayer Vector Tiles

    • xyz XYZ Tiles

    • wcs WCS

    • wfs WFS/OGC API-Features

    • ows OWS

    • ams ArcGIS Map Service

    • afs ArcGIS Feature Service

    • geonode GeoNode

13.1.1.2. ブラウザ項目とのインタラクション

ブラウザは、ブラウザへのドラッグ&ドロップやブラウザからキャンバスや レイヤ パネルへのドラッグ&ドロップ、 レイヤ パネルからブラウザ内のレイヤコンテナ(例えばGeoPackage等)へのドラッグ&ドロップをサポートしています。

ブラウザ内のプロジェクトファイルのアイテムは展開することができ、プロジェクトに含まれる(グループを含む)完全なレイヤツリーを表示します。プロジェクトのアイテムはブラウザ内の他のアイテムと同様に扱われるため、(例えばGeoPackageファイルにレイヤアイテムをコピーするために)ブラウザ内でドラッグ&ドロップしたり、ドラッグ&ドロップやダブルクリックで現在のプロジェクトにアイテムを追加したりすることができます。

ブラウザ パネル内の要素を右クリックすると、コンテキストメニューが開きます。

ファイルシステムのディレクトリエントリの場合、コンテキストメニューには次のようなものがあります:

  • 新規 ► は、選択された下記のエントリを作成します

    • ディレクトリ...

    • GeoPackage...

    • シェープファイル...

  • お気に入りとして追加 :お気に入りフォルダは好きな時に名前の変更( お気に入りの名前の変更... ) や削除( お気に入りを削除 )ができます。

  • ブラウザから隠す :隠されたフォルダは 設定 ► オプション ► データソース ► Hidden browser paths の設定で見えるように戻すことができます。

  • このディレクトリの高速スキャン

  • ディレクトリを開く...

  • ターミナルで開く...

  • プロパティ...

  • ディレクトリプロパティ...

プロジェクト内でレイヤとして扱うことのできるリーフエントリについては、コンテキストメニューにサポート項目があります。例えば、非データベース、非サービスベースのベクタ、ラスタ、メッシュデータソースには、以下の項目があります:

  • ファイル "<name of file>" を削除する...

  • レイヤエクスポート --> ファイルへ...

  • レイヤをプロジェクトに追加する

  • レイヤのプロパティ

  • ファイルプロパティ...

レイヤのプロパティ エントリを選択すると、(レイヤがプロジェクトに追加された後に ベクタ レイヤや ラスタ レイヤのプロパティで表示されるものと同様な)以下の情報が表示されます:

  • レイヤに関する メタデータ 。メタデータのグループは次のとおりです: プロバイダからの情報 (可能ならば パス はソースへのハイパーリンクで表示されます)、 識別領域アクセスフィールド (ベクタレイヤの場合)、 バンド (ラスタレイヤの場合)、 連絡先リンク (ベクタレイヤの場合)、 リファレンス (ラスタレイヤの場合)、 履歴

  • プレビュー パネル

  • ベクタソースの場合は属性テーブル( 属性 パネル内)

ブラウザ を使用してプロジェクトにレイヤを追加するには、次の手順で操作します:

  1. ブラウザ を上記のように有効にします。ファイルシステム、データベース、webサービスのブラウザツリーが表示されます。データベースやwebサービスが表示される前に、データベースやwebサービスへ接続する必要があるかもしれません(専用のセクションを参照してください)。

  2. リストの中からレイヤを見つけます。

  3. レイヤのコンテキストメニューを使用するか、レイヤ名をダブルクリックするか、レイヤを マップキャンバス へとドラッグ&ドロップします。これでレイヤは レイヤパネル に追加され、マップキャンバス上で見ることができるようになります。

    ちなみに

    ブラウザからQGISプロジェクトを直接開く

    プロジェクト名をダブルクリックするか、マップキャンバス上へドラッグ&ドロップすることで、ブラウザパネルからQGISのプロジェクトを直接開くこともできます。

ファイルがロードされたら、マップナビゲーションツールを使用してレイヤをあちこちズームすることができます。レイヤのスタイルを変更するには、凡例内のレイヤ名をダブルクリックするか、レイヤ名を右クリックしてコンテキストメニューから プロパティ を選択し、 レイヤプロパティ ダイアログを開きます。ベクタレイヤのシンボロジ設定の詳細については、 シンボロジプロパティ を参照してください。

ブラウザツリー内のアイテムを右クリックすると、以下の機能があります:

  • ファイルやテーブルについては、メタデータを表示したり、プロジェクト内に開きます。テーブルは名前を変更したり、行を削除したり、全行削除することもできます。

  • フォルダについては、お気に入りにブックマークしたり、ブラウザツリーから隠したりできます。非表示となったフォルダは、 設定 ► オプション ► データソース タブで管理することができます。

  • 空間ブックマーク の管理:ブックマークを作成したり、ブックマークを XML ファイルとしてエクスポートしたり、XML ファイルからインポートしたりできます。

  • データベースやwebサービスへの接続を作成します。

  • 再読み込みや、スキーマ名の変更、スキーマの削除ができます。

また、ファイルをデータベースにインポートしたり、1つのスキーマ/データベースから別のスキーマ/データベースにテーブルをコピーしたりすることもドラッグ&ドロップで簡単に行うことができます。2つ目のブラウザパネルを利用することで、ドラッグ中に長いスクロールを行わずに済みます。ファイルを選択して、一方のパネルから他方のパネルへとドラッグ&ドロップするだけです。

../../../_images/browser_panels.png

図 13.2 横並びのQGISブラウザパネル

ちなみに

OSのファイルブラウザからドラッグ&ドロップでQGISにレイヤを追加する

オペレーティングシステムのファイルブラウザから レイヤパネル またはマップキャンバスにファイルをドラッグ&ドロップしても、ファイルをプロジェクトに追加できます。

13.1.2. DBマネージャ

DBマネージャ プラグインは、QGISがサポートする空間データベース形式(PostGIS、SpatiaLite、GeoPackage、Oracle Spatial、MSSQL、DB2、仮想レイヤ)を統合して管理するためのもう一つのツールです。これは、 プラグイン ► プラグインの管理とインストール... メニューから有効化することができます。

dbManager DBマネージャ プラグインにはさまざまな機能があります。

  • データベースに接続し、その構造や内容を表示する

  • データベースのテーブルをプレビューする

  • ダブルクリックまたはドラッグ&ドロップで、マップキャンバスへレイヤを追加する

  • QGISブラウザや他のデータベースから、データベースにレイヤを追加する

  • SQLクエリを作成し、実行結果をマップキャンバスへ追加する

  • 仮想レイヤ を作成する

DBマネージャの機能に関する更なる情報は、 DB Manager Plugin を参照してください。

../../../_images/db_manager.png

図 13.3 DBマネージャダイアログ

13.1.3. プロバイダベースの読み込みツール

レイヤを追加するためにQGISが提供する主なツールであるブラウザパネルとDBマネージャの他に、データプロバイダに特化したツールもあります。

注釈

いくつかの 外部プラグイン も、QGISで特定の形式のファイルを開くためのツールを提供しています。

13.1.3.1. ファイルからレイヤを読み込む

ファイルからレイヤを読み込むには、次の手順で操作します:

  1. データソースマネージャ ダイアログでレイヤタイプのタブを開きます。つまり、 dataSourceManager データソースマネージャを開く ボタン(または Ctrl+L )を押し、目的のタブを有効にします。 もしくは、

    • ベクタデータ(GML、ESRIシェープファイル、Mapinfo、DXFなど)については、 Ctrl+Shift+V を押すか、 レイヤ ► レイヤの追加 ► addOgrLayer ベクタレイヤの追加 メニューオプションを選択するか、 addOgrLayer ベクタレイヤの追加 ツールバーボタンをクリックします。

      ../../../_images/addvectorlayerdialog.png

      図 13.4 ベクタレイヤの追加ダイアログ

    • ラスタデータ(GeoTiff、MBTiles、GRIdded Binary、DWGなど)については、 Ctrl+Shift+R を押すか、 レイヤ ► レイヤの追加 ► addRasterLayer ラスタレイヤの追加 メニューオプションを選択するか、 addRasterLayer ラスタレイヤの追加 ツールバーボタンをクリックします。

      ../../../_images/addrasterlayerdialog.png

      図 13.5 ラスタレイヤの追加ダイアログ

  2. ソースタイプは radioButtonOn ファイル を選択します

  3. ... ブラウズ ボタンをクリックします

  4. ファイルシステムを検索し、サポートされているデータソースを読み込みます。ダイアログで Ctrl キーを押しながら複数のアイテムをクリックするか、 Shift キーを押しながら最初と最後のアイテムを選択することでアイテム範囲を選択することで、複数のレイヤを同時に読み込むことが可能です。ファイル形式のフィルタには、十分にテストされたファイル形式のみが表示されます。他のファイル形式は、 全ファイル (プルダウンメニューの一番上のアイテム)を選択することで読み込むことができます。

  5. 開く ボタンを押し、選択したファイルを データソースマネージャ ダイアログに読み込みます

    ../../../_images/openoptionsvectorlayer.png

    図 13.6 Loading a Shapefile with open options

  6. 追加 ボタンを押すと、QGISにファイルが読み込まれ、マップビューに表示されます。 図 13.7 は、 alaska.shp ファイルがロードされた後のQGISを表示しています。

    ../../../_images/shapefileloaded.png

    図 13.7 アラスカのシェープファイルがロードされたQGIS

注釈

For loading vector files the GDAL driver offers to define open actions. These will be shown when the vector file is selected. Options are described in detail on https://gdal.org/drivers/vector/ .

注釈

MapInfo (例 .tab )やAutoCAD( .dxf )などいくつかのファイル形式は一つのファイル内にさまざまなジオメトリタイプを混在させることが可能なため、このようなデータセットを開く時には、レイヤごとに1つのジオメトリとするために、使用するジオメトリを選択するダイアログが開きます。

addOgrLayer ベクタaddRasterLayer ラスタ タブでは、 ファイル 以外のソースタイプからレイヤを読み込むことができます:

  • ArcInfo Binary CoverageUK. National Transfer FormatUS Census Bureau のraw TIGER形式、 OpenfileGDB といった特定のベクタフォーマットを読み込むことができます。これらを読み込むためには、 ソースタイプradioButtonOn ディレクトリ を選択します。この場合、 ... ブラウズ ボタンを押すと、ダイアログではディレクトリの選択が可能になります。

  • radioButtonOn データベース ソースタイプでは、既存のデータベース接続を選択したり、選択したデータベースタイプの接続を作成したりすることができます。利用可能なデータベースタイプには、 ODBCEsri Personal GeoDatabaseMSSQLPostgreSQLMySQL などがあります。

    新規 ボタンを押すと、 新しいOGRデータベース接続を作成する ダイアログが開きます。指定できるパラメータは 保存された接続の作成 で説明しているものと同じです。 Open ボタンを押すと、利用可能なテーブルの中から、例えば PostGIS が有効になっているデータベースのテーブルなどを選択することができます。

  • radioButtonOn プロトコル ソースタイプは、ローカル、あるいはネットワークに保存されたデータを開きます。このデータはパブリックアクセスが可能か、商用クラウドストレージサービスのプライベートバケットに保存されているかのいずれかです。サポートされているプロトコルタイプは以下のとおりです:

    • HTTP/HTTPS/FTPURI と、必要に応じて 認証 を指定します

    • AWS S3Google Cloud StorageMicrosoft Azure BlobAlibaba OSS CloudOpen Stack Swift Storage 等のクラウドストレージ。 バケットまたはコンテナオブジェクトキー を入力する必要があります。

    • OGC WFS 3 をサポートするサービス(まだ実験段階です)。 GeoJSON または GEOJSON - Newline Delimited フォーマットを使用しているか、 CouchDB データベースに基づくものです。 URI が必須で、 認証 はオプションです。

    • For all vector source types it is possible to define the Encoding or to use the Automatic ► setting.

13.1.3.2. メッシュレイヤを読み込む

メッシュは通常、時間やその他の成分を持った非構造格子です。空間成分には、2Dまたは3D空間の頂点、辺、面の集合が含まれます。メッシュレイヤに関する詳細な情報は メッシュデータの操作 を参照してください。

メッシュレイヤをQGISに追加するには、次の手順で操作します:

  1. レイヤ ► メニューから選択するか、 dataSourceManager データソースマネージャを開く ボタンをクリックして、 データソースマネージャ ダイアログを開きます。

  2. 左のパネルの addMeshLayer メッシュ タブを有効にします。

  3. ... ブラウズ ボタンを押し、ファイルを選択します。 さまざまなファイル形式 がサポートされています。

  4. レイヤを選択し、 追加 ボタンを押します。ネイティブのメッシュレンダリングを使用してレイヤが追加されます。

../../../_images/mesh_datasource_manager.png

図 13.8 データソースマネージャのメッシュタブ

13.1.3.3. 区切りテキストファイルをインポートする

区切りのあるテキストファイル(例えば .txt.csv.dat.wkt )は上記のツールを使って読み込むことができますが、この方法ではファイルはシンプルなテーブルとして表示されます。時には、区切りのあるテキストファイルに可視化したい座標 / ジオメトリが含まれていることがあります。 addDelimitedTextLayerCSVテキストレイヤの追加 で読み込むことで、これを可視化することができます。

  1. dataSourceManager データソースマネージャを開く アイコンをクリックし、 データソースマネージャ ダイアログを開きます

  2. addDelimitedTextLayer CSVテキスト タブを有効にします

  3. ... ブラウズ ボタンをクリックし、インポートしたい区切りのあるテキストファイル(例えば qgis_sample_data/csv/elevp.csv )を選択します。

  4. プロジェクト内でレイヤに使用したい名前を レイヤ名 フィールドに入力します。 (例: Elevation

  5. 以下に説明するように、データセットや必要に合わせて設定を行います。

../../../_images/delimited_text_dialog.png

図 13.9 CSVテキストダイアログ

13.1.3.3.1. ファイル形式

ファイルが選択されると、QGISは最近使用された区切り文字を使用してファイルの解析を試み、フィールドと行を識別します。QGISがファイルを正しく解析できるようにするためには、正しい区切り文字を選択することが重要です。区切り文字には、次のいずれかを選択して指定することができます:

  • radioButtonOnCSV(コンマで区切られた値) は、コンマの文字を使います。

  • radioButtonOff正規表現区切り を選んだ場合は フィールドにテキストを入力します。例えば、区切り文字をタブに変更するには、 \t (これは正規表現ではタブ文字に使用されます)を使用します。

  • radioButtonOffカスタム区切り は、 コンマ空白タブセミコロン 等の定義済み区切り文字の中から選択します。

13.1.3.3.2. レコードとフィールドのオプション

他にもデータ認識に使用できる便利なオプションがいくつかあります:

  • 破棄するヘッダ行数 :ファイルの始めの数行が空行あるいは別フォーマットであるときに、これをインポートしないようにする場合に便利です。

  • checkbox最初の行はフィールド名 :最初の行の値をフィールド名として使用します。チェックがない場合には、QGISはフィールド名に field_1field_2 等を使用します。

  • checkboxフィールド型を検出する :フィールドの型を自動的に認識します。チェックがない場合には、全ての属性はテキストフィールドとして扱われます。

  • checkbox小数点記号にコンマを使う :小数点の区切り文字を強制的ににコンマとすることができます。

  • checkbox前後の空白を削除する :フィールドから前後の空白文字を取り除くことができます。

  • checkbox空フィールドを削除する

解析器のプロパティを設定すると、ダイアログ下部のサンプルデータのプレビューが更新されます。

13.1.3.3.3. ジオメトリ定義

ファイルが解析されたら、 ジオメトリ定義 の設定を行います。

  • radioButtonOnポイント座標 レイヤがポイントジオメトリ型で、 X属性Y属性Z属性 (3次元データの場合)、 M値の属性 (計測次元の場合)のフィールドを含む場合には、これを指定します。座標が度 / 分 / 秒で定義されている場合には、 checkbox度分秒を使う のチェックボックスにチェックを入れます。 setProjection CRSの選択 ウィジェットを使用して、適切な ジオメトリのCRS を指定します。

  • radioButtonOnWell-known text (WKT) オプションは、空間情報がWKTにより表現されている場合に使用します:WKTジオメトリが含まれる ジオメトリフィールド を選択し、 適切な ジオメトリタイプ を選ぶか、QGISの自動検出に任せます。setProjection CRSの選択 ウィジェットを使用して、 適切な ジオメトリのCRS を指定します。

  • ファイルが非空間データの場合には、 radioButtonOn ジオメトリなし(属性のみのテーブル) を有効にすると、通常のテーブルとして読み込まれます。

13.1.3.3.4. レイヤ設定

また、以下を有効にできます:

  • checkbox空間インデックスを使う :地物の表示や空間的な選択のパフォーマンスを改善します。

  • checkboxサブセットインデックスを使う :(レイヤプロパティで定義されている場合に) サブセットフィルタ のパフォーマンスを改善します。

  • checkboxファイルを監視する :QGISの実行中に他のアプリケーションによってファイルが変更されたかを監視します。

最後に 追加 をクリックし、マップにレイヤを追加します。この例では、 Elevation という名前のポイントレイヤがプロジェクトに追加され、QGISの他のマップレイヤと同様に動作します。このレイヤは .csv ソースファイルに対するクエリの結果であり(従ってこれにリンクされているため)、ディスク上に空間レイヤを取得するには 保存する 必要があります。

13.1.3.4. DXFファイルやDWGファイルをインポートする

DXF ファイルや DWG ファイルはブラウザパネルからドラッグ&ドロップするだけでQGISに追加できます。プロジェクトに追加したいサブレイヤを選択するプロンプトが表示されます。レイヤはランダムなスタイルのプロパティで追加されます。

注釈

いくつかのジオメトリタイプ(ポイント、ライン、ポリゴン)を含むDXFファイルは、 <filename.dxf> entities <geometry type> のような名前でレイヤが生成されます。

dxf/dwgファイルの構成とシンボロジをQGISでも保つためには、 プロジェクト ► インポートとエクスポート ► DWG/DXFからレイヤをインポート... から専用のツールを使用するとよいでしょう。このツールにより、次の操作を行います:

  1. 図面ファイルからGeoPackageデータベースに要素をインポートする

  2. インポートした要素をプロジェクトに追加する

DWG/DXFのインポート ダイアログでは、図面ファイルの内容をインポートするために以下の情報を入力する必要があります:

  1. ターゲットパッケージ 、つまりデータが保存される新規GeoPackageファイルの場所を入力します。既存のファイルを指定した場合には、ファイルは上書きされます。

  2. 図面ファイルのデータの座標参照系を指定します。

  3. checkbox ブロック参照を展開する をチェックすると、図面ファイル内のブロックを標準的な要素としてインポートします。

  4. checkbox カーブを使用する をチェックすると、インポートされたレイヤを カーブ ジオメトリタイプに変換します。

  5. インポート ボタンを使用して、使用するDWG/DXFファイル(1つのGeoPackageに1ファイル)を選択します。図面ファイルの内容がGeoPackageデータベースに自動的に追加されます。ファイルのサイズにもよりますが、これには時間がかかる場合があります。

.dwg ファイルまたは .dxf ファイルのデータがGeoPackageデータベースへとインポートされたら、ダイアログの下半分にあるフレームにインポートファイルからのレイヤのリストが表示されます。ここからQGISプロジェクトに追加したいレイヤを選択できます:

  1. フレーム上部で、プロジェクト内で図面ファイルをグループ化するための グループ名 を設定します。

  2. 表示するレイヤにチェックを入れます。選択された各レイヤは、図面レイヤのポイント、ライン、ラベル、面地物に対するベクタレイヤを含むアドホックなグループに追加されます。レイヤのスタイルは、元々 *CADで持っていたスタイルと似た見た目になります。

  3. 最初からレイヤが表示されているかどうかを選択します。

  4. checkbox レイヤを結合する オプションをチェックすると、全てのレイヤを単一のグループにまとめます。

  5. OK ボタンを押すと、QGISでレイヤを開きます。

../../../_images/dwg_dxf_import_dialog.png

図 13.10 DWG/DXFファイルのインポートダイアログ

13.1.3.5. OpenStreetMapベクタのインポート

多くの国でデジタル道路地図等のジオデータが無料で利用できないため、OpenStreetMapプロジェクトは人気があります。OSMプロジェクトの目的は、GPSデータや航空写真、ローカルな知識からフリーで編集可能な世界地図を作成することです。この目的を支援するため、QGISはOSMデータのサポートを提供しています。

ブラウザパネル を使用して .osm ファイルをマップキャンバスに読み込むと、ジオメトリタイプに基づいてサブレイヤを選択するためのダイアログが現れます。読み込んだレイヤには .osm ファイル内のそのジオメトリタイプの全てのデータが含まれており、 osm ファイルのデータ構造が保持されています。

13.1.3.6. SpatiaLiteレイヤ

addSpatiaLiteLayer 初めてSpatiaLiteデータベースからデータをロードするときは、始めに以下の操作を行います:

  • addSpatiaLiteLayer SpatiaLiteレイヤの追加 ツールバーボタンをクリックする

  • レイヤ ► レイヤの追加 メニューから addSpatiaLiteLayer SpatiaLiteレイヤの追加... オプションを選択する

  • Ctrl+Shift+L を押す

これによりウィンドウが現れ、QGISが既に知っているSpatiaLiteデータベース(ドロップダウンメニューから選択)に接続するか、新しいデータベースへの新規接続を定義します。新規接続を定義するには、 新規 をクリックし、ファイルブラウザを使用してSpatiaLiteデータベースを指定します。SpatiaLiteデータベースは .sqlite 拡張子を持つファイルです。

また、QGISはSpatiaLiteで編集可能なビューもサポートしています。

13.1.3.7. GPS

QGISでGPSデータを読み込むには、コアプラグインの GPS Tools を使います。使い方は GPSプラグイン セクションにあります。

13.1.3.8. GRASS

GRASSベクタデータでの作業は GRASS GIS の統合 セクションで説明しています。

13.1.4. QGISカスタム形式

QGISには2つのカスタム形式があります:

13.1.5. QLR - QGISレイヤ定義ファイル

レイヤのコンテキストメニューで エクスポート ► レイヤ定義ファイルとして保存... を使用して、レイヤの定義を レイヤ定義ファイル (QLR - .qlr )として保存することができます。

QLR形式によって、 "完全な" QGISレイヤを他のQGISユーザーと共有することができます。 QLRファイルには、データソースへのリンクとレイヤのスタイル設定に必要な全てのQGISスタイル情報が含まれています。

QLRファイルはブラウザパネル内に表示され、レイヤ(を保存されたスタイルで)をレイヤパネルに追加するために使用できます。QLRファイルをシステムのファイルマネージャーからマップキャンバスへとドラッグ&ドロップすることもできます。

13.1.6. ウェブサービスへ接続する

QGISを使用すると、さまざまな種類のOGC ウェブサービス(WM(T)S、WFS(-T)、WCS、CSW、...)にアクセスすることができます。QGIS Serverのおかげで、このようなサービスを公開することもできます。 QGIS Server Guide/Manual には、これらの機能についての説明があります。

13.1.6.1. ベクトルタイルサービスを利用する

ベクトルタイルサービスは ブラウザ 内の Vector Tiles トップレベルエントリにあります。右クリックしてコンテキストメニューを開き 新しい一般接続... を選択すると、サービスを追加できます。サービスの設定には、 名前URL を追加します。ベクトルタイルサービスは、タイルを .pbf 形式で提供している必要があります。ダイアログには、 checkbox最小ズームレベルcheckbox最大ズームレベル を定義する、2つのメニューがあります。ベクトルタイルはピラミッド構造をしています。これらのオプションを使用すると、タイルピラミッドから個別にレイヤを生成することができます。これらのレイヤは、QGISでベクトルタイルのレンダリングに使用されます。メルカトル図法の場合(OpenStreetMap Vector Tilesで使用)、ズームレベル0は世界全体を 1:500,000,000 の縮尺で表現します。ズームレベル14は、縮尺 1:35,000での表現です。 図 13.13 は、MapTiler Planet のベクトルタイルサービスの設定ダイアログを示しています。

../../../_images/vector_tiles_maptilerplanet.png

図 13.13 ベクトルタイル - Maptiler Planet の設定

新しい ArcGIS Vector Tile Service接続... を使用すると、ArcGIS Vector Tile Services へ接続することができます。

13.1.6.2. XYZタイルサービスを使用する

XYZタイルサービスは ブラウザXYZ Tiles トップレベルエントリにあります。デフォルトでは、OpenStreetMap XYZタイルサービスが設定されています。XYZ Tilesのコンテキストメニュー(右クリックして開く)の 新しい接続 を選択すると、XYZタイルプロトコルを使用する他のサービスを追加することができます。 図 13.14 にOpenStreetMap XYZタイルサービスの設定ダイアログを示します。

../../../_images/xyz_tiles_dialog_osm.png

図 13.14 XYZ Tiles - OpenStreetMap の設定

コンテキストメニューから、設定をXMLで保存( 接続を保存 )したり、XMLから読み込んだり( 接続をロード )することができます。認証設定をサポートしています。OpenStreetMapのXMLファイルは以下のようになっています:

<!DOCTYPE connections>
<qgsXYZTilesConnections version="1.0">
  <xyztiles url="https://tile.openstreetmap.org/{z}/{x}/{y}.png"
   zmin="0" zmax="19" password="" name="OpenStreetMap" username=""
   authcfg="" referer=""/>
</qgsXYZTilesConnections>

XYZタイルサービスへの接続が設定できたら、エントリの上で右クリックすると以下の操作ができます:

  • 編集... XYZタイルサービスの接続設定を編集します

  • 削除 接続を削除します。

  • レイヤエクスポート... ► ファイルへ は、 タイルをラスタとして保存します

  • レイヤをプロジェクトに追加する :ダブルクリックでもレイヤを追加できます

  • レイヤのプロパティ... を確認し、サービスによって提供されるメタデータやデータのプレビューにアクセスできます。レイヤがプロジェクトに読み込まれている場合には、より多くの設定が可能です。

XYZタイルサービスの例:

  • OpenStreetMap Monochrome: URL: http://tiles.wmflabs.org/bw-mapnik/{z}/{x}/{y}.png, 最小ズームレベル: 0, 最大ズームレベル: 19

  • Googleマップ: URL: https://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}, 最小ズームレベル: 0, 最大ズームレベル: 19

  • Open Weather Map Temperature: URL: http://tile.openweathermap.org/map/temp_new/{z}/{x}/{y}.png?appid={api_key} 最小ズームレベル: 0, 最大ズームレベル: 19