11. 一般ツール

11.1. コンテキストヘルプ

特定のトピックでヘルプが必要な場合は多くのダイアログで利用できるようになっている Help ボタンを利用してこのユーザマニュアルの対応するページにアクセスできます --- サードパーティのプラグインは専用のWebページを指す可能性があることに注意してください。

11.2. パネル

QGISはデフォルトで多くのパネルを利用することができます。いくつかのパネルは以下に解説がありますが、その他はユーザマニュアルの別の場所に説明があるものもあります。QGISに用意されているデフォルトのパネルの完全なリストは ビュー ► パネル ► で参照でき、 パネル に説明されています。

11.2.1. レイヤパネル

レイヤパネル (「地図凡例」とも呼ばれます)には、プロジェクト内のすべてのレイヤが一覧表示され、レイヤの可視性の管理に役立ちます。 レイヤは Ctrl+1 を押すと表示または非表示にできます。レイヤを選択して凡例内で上下にドラッグすると、Z順序を変更できます。 Z順序とは、凡例の上部にリストされているレイヤが、凡例の下部にリストされているレイヤの上に描画されることを意味します。

注釈

Z順序の動作は レイヤ順序 パネルで上書きすることができます。

レイヤパネルの上部にあるツールバーによって、以下のことができます。

  • symbology レイヤのスタイルパネルを開く (F7): レイヤスタイルパネルの表示、非表示を切り替えます。

  • addGroup グループ追加

  • showMapTheme 地図テーマの管理: レイヤの可視設定を管理し、様々なマップテーマにレイヤを配置します。

  • filterMap コンテンツで凡例を絞り込む :レイヤが可視状態に設定されていて、かつ地物が現在の地図キャンバスに交差するレイヤのみが、レイヤパネル内でスタイルがレンダリングされます。それ以外の場合は、一般的なNULLシンボルがレイヤに適用されます。これは、どのレイヤのどの地物が関心のある領域をカバーしているのかをレイヤシンボルに基づいて識別するのに便利な方法です。

  • expressionFilter 条件式による凡例フィルタ:式を適用して、選択したレイヤツリーから条件を満たす地物がないスタイルを削除します。これは、別のレイヤの特定の領域/地物内にある地物を強調表示するために使用できます。ドロップダウンリストから、現在適用されている式を編集およびクリアできます。

  • expandTree すべて展開するcollapseTree すべて折りたたむ は、レイヤパネル内のすべてのレイヤとグループを展開する、あるいは折りたたみます

  • removeLayer レイヤ/グループの削除 現在選択されているレイヤやグループを削除します

../../../_images/layer_toolbar.png

図 11.1 レイヤパネル内のレイヤツールバー

注釈

レイヤパネルを管理するツールは、印刷レイアウトのマップアイテムと凡例アイテムにも使用できます。

11.2.1.1. マップテーマの設定

showMapTheme 地図テーマの管理 ドロップダウンボタンを使用すると、 レイヤ パネルの可視性を操作するための便利なショートカットにアクセスできます。

  • showAllLayers 全てのレイヤを表示

  • hideAllLayers 全てのレイヤを隠す

  • showSelectedLayers 選択レイヤを表示

  • hideSelectedLayers 選択レイヤを隠す

  • toggleSelectedLayers 選択レイヤを切り替え: は、パネル上で最初に選択されたレイヤの表示状態を変更し、その状態を他に選択されたレイヤにも適用します。 また、 スペースキー のショートカットからも利用できます。

  • 選択レイヤを個別切り替え: は、選択された各レイヤについて表示状態を変更します

  • hideDeselectedLayers 選択されてないレイヤを隠す

showMapTheme 地図テーマの管理 メニューでは、レイヤの可視性の単純な制御だけでなく、凡例で 地図テーマ を構成し、ある地図テーマから別の地図テーマに切り替えたりすることができます。地図のテーマは、現在の地図凡例の スナップショット であり、以下のものを記録しています:

  • レイヤ パネル内で可視状態に設定されたレイヤ

  • さらに 、各可視レイヤについて、

    • レイヤに適用された スタイル への参照情報

    • スタイルの可視クラス、すなわち、 レイヤパネル 内でチェックされたノード項目のレイヤ。これは単一定義のシンボルレンダリング以外の シンボロジ について適用されます。

    • 中に配置されいるレイヤのノードやグループの折りたたみ/展開状態

地図テーマを作成するには、

  1. 表示したいレイヤをチェックします

  2. レイヤのプロパティ(シンボロジ、ダイアグラム、ラベルなど...)をいつもどおりに設定します

  3. 下の方にある スタイル ► メニューを展開し、 追加... を押して、 プロジェクトに埋め込まれた新しいスタイル として保存します

    注釈

    地図のテーマはプロパティの現在の内容を保存しません。スタイル名への参照のみが保存されるため、このスタイルが有効なときにレイヤに変更を適用する(例えばシンボルレンダリングを変更する)と、テーマは新しい情報で更新されます。

  4. 他のレイヤについても必要なだけ上の手順を繰り返します

  5. 該当する場合は、 レイヤ パネルのグループや可視レイヤのノードを展開または折りたたみます。

  6. パネル上部の showMapTheme 地図テーマの管理 ボタンをクリックし、 テーマの追加... をクリックします。

  7. 地図テーマの名前を入力し、 OK ボタンをクリックします

新しい地図テーマが showMapTheme ドロップダウンメニューの下部にリストされます。

地図テーマは必要な数だけ作成できます。地図凡例の現在の組み合わせ(可視レイヤ、有効なスタイル、地図凡例ノード)が上記で定義された既存の地図テーマ内容と一致しない場合は、 テーマの追加... をクリックして新しい地図テーマを作成するか、 テーマの置き換え ► を使用して地図テーマを更新します。アクティブな地図テーマの名前を 現在のテーマの名前変更... で変更することもできますし、 現在のテーマの削除 ボタンで地図テーマを削除することもできます。

地図テーマは、あらかじめ設定されたさまざまな地図凡例の組み合わせをすばやく切り替えるのに便利です。リストで地図テーマを選択すると組み合わせが復元されます。設定されたすべてのテーマは印刷レイアウトにおいてもアクセスでき、特定のテーマに基づいて、現在のメインキャンバスのレンダリングとは関係なく、異なる地図アイテムを作成できます( 地図アイテムレイヤ を参照)。

11.2.1.2. レイヤパネルのコンテキストメニューの概要

ツールバーの下にあるレイヤパネルの主な構成要素は、プロジェクトに追加されたベクタまたはラスタレイヤの一覧が表示されるフレームです。レイヤは自由にグループにまとめられます。パネルで選択したアイテムに応じて、右クリック時に以下のような専用のオプションセットが表示されます。

オプション

ベクタレイヤ

ラスタレイヤ

グループ

zoomToLayer レイヤー/グループの領域にズーム

checkbox

checkbox

checkbox

zoomToLayer 選択範囲にズーム

checkbox

inOverview 全体図に表示

checkbox

checkbox

地物の数を表示

checkbox

レイヤ/グループのコピー

checkbox

checkbox

checkbox

レイヤ/グループの名前を変更

checkbox

checkbox

checkbox

zoomActual ネイティブ解像度にズーム

checkbox

現在の領域に引き伸ばす

checkbox

dbManager SQLレイヤの更新...

checkbox

addGroup グループの追加

checkbox

duplicateLayer レイヤの複製

checkbox

checkbox

removeLayer レイヤ/グループの削除...

checkbox

checkbox

checkbox

グループ外に移動

checkbox

checkbox

トップに移動

checkbox

checkbox

checkbox

一番下に移動

checkbox

checkbox

checkbox

チェックとすべての親

checkbox

checkbox

選択レイヤをグループにする

checkbox

checkbox

openTable 属性テーブルを開く

checkbox

toggleEditing 編集モード切替

checkbox

allEdits 現在の編集 ►

checkbox

フィルタ...

checkbox

データソースの変更...

checkbox

データソースを修復...

checkbox

選択に対するアクション ► (編集モード時)

checkbox

► 地物の複製

checkbox

► 地物の複製とデジタイズ

checkbox

レイヤを表示する縮尺の設定...

checkbox

checkbox

表示される縮尺にズーム

checkbox

checkbox

CRSの設定 ►

checkbox

checkbox

► レイヤ/グループのCRSを設定...

checkbox

checkbox

checkbox

► レイヤのCRSをプロジェクトのCRSに設定

checkbox

checkbox

グループのWMSデータの設定...

checkbox

unchecked 相互排他的グループ

checkbox

チェックとすべての子(Ctrlキーを押しながらクリック)

checkbox

グループと全メンバのチェックを外す(Ctrlキーを押しながらクリック)

checkbox

保存...

checkbox

エクスポート ►

checkbox

checkbox

checkbox

► 名前を付けて保存...

checkbox

► 地物の保存...

checkbox

► 選択地物の保存...

checkbox

► レイヤ定義ファイルとして保存...

checkbox

checkbox

checkbox

► QGISレイヤスタイルファイルとして保存...

checkbox

checkbox

スタイル ►

checkbox

checkbox

► スタイルのコピー

checkbox

checkbox

► スタイルの貼り付け

checkbox

checkbox

checkbox

► 追加...

checkbox

checkbox

► 現在のスタイル名を変更...

checkbox

checkbox

► シンボルの編集...

checkbox

► シンボルをコピー

checkbox

► シンボルを貼り付ける

checkbox

プロパティ...

checkbox

checkbox

表:レイヤパネルアイテムのコンテキストメニュー

GRASSベクタレイヤについては、toggleEditing 編集モード切替 は使用できません。GRASSベクタレイヤの編集については、 GRASSベクターレイヤーをデジタル化して編集する のセクションを参照してください。

11.2.1.3. グループやレイヤとの連携

凡例ウィンドウのレイヤをグループに編成できます。これを行うには2つの方法があります。

  1. folder アイコンを押して新しいグループを追加します。グループの名前を入力し Enter を押します。それから、既存のレイヤをクリックしてグループにドラッグします。

  2. レイヤをいくつか選択し、凡例ウィンドウで右クリックして 選択レイヤをグループにする を選択します。選択したレイヤが自動的に新しいグループに配置されます。

レイヤをグループ外に移動するには、ドラッグするか、右クリックして グループ外に移動 を選択します。レイヤはグループ外に移動され、グループの上に配置されます。グループは他のグループ内に入れ子にもできます。レイヤが入れ子にされたグループに配置されている場合、 グループ外に移動 は、入れ子になった全てのグループの外にレイヤを移動します。

グループまたはレイヤをレイヤパネルの最上位に移動するには、それらを最上位にドラッグするか、 トップに移動 を選択します。グループ内に入れ子になっているレイヤでこのオプションを使用すると、レイヤは現在のグループ中で最上位に移動します。 一番下に移動 オプションは同じ要領で、レイヤやグループを一番下に移動します。

グループのチェックボックスは、グループ内でチェックされたレイヤ全てを1クリックで表示・非表示にできます。 Ctrl キーを押しながらグループのチェックボックスをクリックすると、グループ内とそのサブグループ内の全てのレイヤも表示・非表示が切り替わります。

Ctrl を押しながらチェックされた/されていないレイヤをクリックすると、そのレイヤとすべての親レイヤのチェックを外し/付けます。

相互排他的グループ のオプションを有効にすると、グループ内で同時に表示されるレイヤが1つだけとなるようにすることができます。グループ内のあるレイヤが表示状態となると、他のすべてのレイヤは非表示になります。

Ctrl キーを押しながら追加のレイヤをクリックすると、複数のレイヤやグループを同時に選択することができます。選択したレイヤを同時に新しいグループに移動させることができます。

また、複数のアイテムを Ctrl キーを押しながら選択してから Ctrl+D を押すことで、選択されたすべてのレイヤやグループをレイヤのリストから一度に削除することもできます。

11.2.1.3.1. インジケータアイコンによるレイヤとグループの詳細情報

状況によっては、 レイヤ パネルのレイヤやグループの横にアイコンが表示され、レイヤー/グループについてのより詳しい情報が得られます。シンボルは次のとおりです。

  • toggleEditing レイヤが編集モードであり、データを変更できることを示します

  • editableEdits 編集中のレイヤに未保存の変更があることを示します

  • indicatorFilter レイヤに フィルタ が適用されていることを示します。アイコンにカーソルを乗せるとフィルタ式が表示され、ダブルクリックすると設定を変更します

  • indicatorNonRemovable このレイヤがプロジェクトに 必須の レイヤであり、削除できないことを示します

  • indicatorEmbedded 埋め込まれたグループやレイヤ であることを示し、オリジナルのプロジェクトファイルへのパスを表示します

  • indicatorBadLayer プロジェクトファイルを開いたときにデータソースが利用できなかったレイヤであることを示します( 壊れたファイルパスの取り扱い を参照)。アイコンをクリックするか、レイヤのコンテキストメニューから データソースの変更... エントリを選択して、データソースのパスを更新してください。

  • indicatorMemory レイヤが 一時スクラッチレイヤ であり、このプロジェクトを閉じた際に内容が破棄されることを思い出させてくれます。データが失われるのを回避しレイヤを永続的なものにするには、アイコンをクリックし、QGISでサポートされている任意のOGRベクタ形式でレイヤを保存します。

  • indicatorNoCRS CRSがない/不明なレイヤであることを示します

  • indicatorTemporal キャンバスアニメーションによって制御される時系列レイヤであることを示します

11.2.1.4. ベクタレイヤのスタイル編集

レイヤパネルから、レイヤのレンダリングをすばやく簡単に変更するショートカットがあります。ベクタレイヤを右クリックして、リストで スタイル ► を選択します。

  • 現在、レイヤーに適用されている スタイル が表示されます。レイヤにいくつもスタイルを定義している場合は、そのスタイルを切り替えることができ、マップキャンバス上のレイヤのレンダリングは自動的に更新されます。

  • 現在のスタイルの一部または全部をコピーします。また、適用可能な場合には別のレイヤからコピーしたスタイルを貼り付けます

    ちなみに

    レイヤスタイルを素早く共有

    コンテキストメニューから、レイヤのスタイルをコピーして、グループまたは選択したレイヤに貼り付けることで、素早くレイヤスタイルを共有できます。スタイルは、元のレイヤと同じタイプ(ベクタ/ラスタ)、ベクタレイヤの場合は同じジオメトリタイプ(ポイント、ライン、またはポリゴン)を持つのすべてのレイヤに適用されます。

  • 現在のスタイルの名前を変更したり、新しいスタイル(実際には現在のスタイルのコピー)を追加したり、現在のスタイルを削除(複数のスタイルが利用可能な場合)できます。

注釈

上に挙げたオプションは、ラスタレイヤやメッシュレイヤでも利用可能です。

  • シンボルの色カラーホイール を使って更新します。 便利なように、最近使用した色はカラーホイールの下部からも選べます。

  • シンボルの編集...: シンボルセレクタ ダイアログを開き、地物のシンボル(シンボルタイプ、サイズ、色など...)を変更します。

分類シンボルタイプ( カテゴリ値による定義連続値による定義 、あるいは ルールによる定義 )を使用している場合、前述のシンボルレベルのオプションは分類別のエントリのコンテキストメニューからも利用可能です。また、分類別のエントリには地物の分類すべての表示を切り替えるために toggleAllLayers アイテム切り替えshowAllLayers 全アイテム表示 、および hideAllLayers 全アイテム非表示 のエントリも用意されています。これらを使うことで、項目の一つ一つをチェックする(あるいはチェックを外す)事態を避けられます。

ちなみに

クラスの葉エントリをダブルクリックすることでも シンボルセレクタ ダイアログが開きます。

11.2.2. レイヤスタイル設定パネル

レイヤスタイル パネル( Ctrl+3 でも有効)は、 レイヤプロパティ ダイアログの機能の一部へのショートカットです。レイヤのレンダリングと動作を定義し、レイヤプロパティダイアログを開かずにその効果を視覚化するための迅速かつ簡単な方法を提供します。

レイヤスタイルパネルはレイヤプロパティダイアログによるブロッキング(または「モーダル」:ダイアログ操作以外は受け付けない状態)を回避することに加えて、ダイアログで画面が乱雑になることも避けられ、ほとんどのスタイル機能(カラーセレクタ、効果のプロパティ、ルール編集、ラベル置換...)が含まれています:たとえば、レイヤスタイルパネル内のカラーボタンをクリックすると、カラーセレクターダイアログが個別のダイアログとしてではなく、レイヤスタイルパネル自体の内部で開かれます。

レイヤパネルの現在のレイヤのドロップダウンリストから項目を選択して、以下の設定ができます:

  • レイヤのタイプに応じて、以下の設定ができます:

    • ラスタレイヤの symbology シンボロジtransparency 透過性rasterHistogram ヒストグラム プロパティ。これらのオプションは ラスタプロパティダイアログ と同一のものです。

    • ベクタレイヤの symbology シンボロジlabeling ラベルlabelmask マスク3d 3Dビュー プロパティ。これらのオプションは ベクタプロパティダイアログ と同一のもので、サードパーティ製ののプラグインによって導入されたカスタムプロパティによって拡張することができます。

    • メッシュレイヤの symbology シンボロジ3d 3Dビュー プロパティ。これらのオプションは メッシュデータセットのプロパティ と同一のものです。

  • 関連付けられたスタイルを stylePreset スタイルをマネージャ で管理する(詳細は カスタムスタイルを管理する を参照)。

  • 現在のプロジェクトにおいてレイヤスタイル対して適用した変更の history 履歴 を確認する:リストの中から任意の状態を選択して 適用 をクリックすることで、レイヤスタイルの状態を戻したり復元させたりすることができます。

Vector Tilesレイヤには、 checkbox 表示できるルールのみ を表示するオプションがあります。これは、現在のマップ キャンバスのズームレベル内にあるルールだけで作業したい場合に非常に便利です。

このパネルのもう1つの強力な機能は、 checkbox ライブ更新 チェックボックスです。これにチェックを入れるとスタイル変更がマップキャンバスにすぐに表示され、 適用 ボタンをクリックする必要はなくなります。

../../../_images/layer_styling.png

図 11.2 レイヤスタイルパネルからレイヤのシンボロジを定義する

11.2.3. レイヤ順序パネル

デフォルトでは、QGISのマップキャンバスに表示されるレイヤは レイヤ パネルの順序に従って描画されます。つまりパネル内でレイヤの位置が高いほど、マップビューではより前面に(従って、より見えやすく)表示されます。

レイヤ順序 パネルを ビュー ► パネル ► メニュー内からもしくは Ctrl+9 を押して有効にすると、レイヤパネル内の順序とは無関係にレイヤの描画順序を定義することができます。レイヤのリストの下にある checkbox 描画順序の制御 にチェックを入れて、パネル内のレイヤを好きなように再編成してください。この順序がマップキャンバスに適用される順序になります。例えば 図 11.3 の場合、レイヤパネル内でのそれぞれのレイヤ配置とは無関係に、「airports」 地物が「alaska」 ポリゴンの上に表示されていることがわかります。

checkbox 描画順序の制御 のチェックを外すと、デフォルトの動作に戻ります。

../../../_images/layer_order.png

図 11.3 凡例とは無関係にレイヤの順序を定義する

11.2.4. 全体図パネル

全体図 パネル( Ctrl+8 )は、いくつかのレイヤの全範囲ビューの地図を表示します。全体図マップは、 レイヤ メニューまたはレイヤのコンテキストメニューの 全体図に表示 オプションを使用するレイヤーで埋められます。ビュー内では、現在のマップキャンバス範囲が赤い長方形で表示され、地図全体のどの領域が現在表示されているかをすばやく判断するのに役立ちます。全体図フレーム内の赤い長方形をクリックしてドラッグすると、それに応じてメインマップビューの範囲が更新されます。

全体図で使用するレイヤにラベル付けが設定されていても、全体図にラベルはレンダリングされないことに注意してください。

11.2.5. ログメッセージパネル

何らかの操作をロードまたは処理するときは、 messageLog ログメッセージパネル を使用して別のタブに表示されるメッセージを追跡し従うことができます。これは、下のステータスバーの最右側のアイコンを使用して有効にできます。

11.2.6. 元に戻す/やり直しパネル

元に戻す/やり直す (Ctrl+5) パネルには、編集されたレイヤごとに実行されたアクションの一覧が表示されます。リストの上に表示されたアクションを選択することで、一連のアクションを素早く元に戻すことができます。さらなる詳細については、 元に戻すとやり直し を参照してください。

11.2.7. 統計パネル

統計 パネル (Ctrl+6) は任意のベクタレイヤに関する情報の要約を提供します。このパネルでは、以下の事柄についての選択操作が可能です:

  • 統計情報を計算するベクタレイヤ

  • 使用するカラム、もしくは expression

  • 返される統計量はダイアログ右下にあるドロップダウンボタンを使って選択できます。フィールド(あるいは式の値)の型に応じて、利用可能な統計量は以下のとおりです:

統計

文字列

整数

浮動小数

日付

個数

checkbox

checkbox

checkbox

checkbox

個数(ユニークな値)

checkbox

checkbox

個数(欠損値)

checkbox

checkbox

checkbox

checkbox

合計

checkbox

checkbox

平均

checkbox

checkbox

checkbox

標準偏差(母集団)

checkbox

checkbox

標準偏差(標本)

checkbox

checkbox

最小値

checkbox

checkbox

checkbox

checkbox

最大値

checkbox

checkbox

checkbox

checkbox

範囲

checkbox

checkbox

checkbox

最希少値

checkbox

checkbox

checkbox

最頻値

checkbox

checkbox

checkbox

多様

checkbox

checkbox

第1四分位

checkbox

checkbox

第3四分位

checkbox

checkbox

四分位範囲

checkbox

checkbox

最小長さ

checkbox

最大長さ

checkbox

平均の長さ

checkbox

表:各フィールド型に対して利用可能な統計量

統計量の概要は以下の設定・操作が可能です:

  • レイヤ全体に対する統計量を返す、もしくは checkbox 選択した地物のみ にチェックを入れて選択した地物のみの統計量を返す

  • refresh ボタンを押して、基礎となるデータソースに変更(例えば地物/フィールドの追加・削除や、属性値の変更)があった場合に統計量の再計算を行う

  • editCopy ボタンを押して統計量をクリップボードにコピーし、別のアプリケーションにテーブルとして貼りつけられるようにする

../../../_images/statistical_summary.png

図 11.4 フィールドに対する統計量を表示する

11.3. プロジェクトを入れ子にする

時には、異なるプロジェクトにあるいくつかのレイヤーをそのまま同じスタイルで保持したい場合もあるでしょう。これらのレイヤーに対して デフォルトスタイル を作成するか、別のプロジェクトからそのレイヤを埋め込むことで、時間と労力を節約することができます。

既存のプロジェクトからレイヤやグループを埋め込むことには、スタイル設定を超える利点がいくつかあります:

  • あらゆる種類のレイヤ(ベクタ/ラスタ、ローカル/オンラインなど...)を追加できます

  • グループとレイヤを取得することで、異なるプロジェクトで「背景」レイヤのツリー構造を同じに保つことができます

  • 埋め込まれたレイヤは編集可能ですが、シンボロジ、ラベル、フォーム、デフォルト値やアクションなどのプロパティを変更することはできないため、プロジェクト間で一貫性を確保できます

  • 元のプロジェクト内の項目を変更すると、変更は他のすべてのプロジェクトにも反映されます。

他のプロジェクトのコンテンツをあるプロジェクトに埋め込みたい場合には、 レイヤ ► レイヤとグループを埋め込む を選択して、以下のように操作します:

  1. ... ボタンをクリックし、プロジェクトを探します。プロジェクトの中身を確認することもできます( 図 11.5 を参照)

  2. Ctrl キー( osx の場合は Cmd キー)を押しながら取得したいレイヤやグループをクリックします

  3. OK をクリックします

選択したレイヤとグループは レイヤ パネルに埋め込まれ、マップキャンバスに表示されます。識別のために indicatorEmbedded アイコンが名前の横に追加され、この上にマウスカーソルを置くと、元のプロジェクトファイルパスを示すツールチップが表示されます。

../../../_images/embed_dialog.png

図 11.5 埋め込むレイヤとグループの選択

他のレイヤと同じように、埋め込まれたレイヤもレイヤを右クリックして removeLayer レイヤの削除 をクリックすることでプロジェクトから削除することができます。

ちなみに

埋め込みレイヤのレンダリングを変更する

元のプロジェクトファイルに変更を加えない限り、埋め込みレイヤのレンダリングは変更できません。しかし、レイヤ上で右クリックして 複製 を選択すると、完全な機能を備えた、元のプロジェクトに依存していないレイヤが作成されます。その後、リンクされた埋め込みレイヤを削除しても問題ありません。

11.4. マップキャンバスでの作業

11.4.1. レンダリング

デフォルトでは、QGISはマップキャンバスが更新されるたびにすべての可視レイヤをレンダリングします。マップキャンバスの更新を発生させるイベントは次のとおりです。

  • レイヤの追加

  • 地図のパン・ズーム

  • QGISウィンドウのサイズ変更

  • レイヤの可視性の変更

QGISではいくつかの方法でレンダリング処理を制御できます。

11.4.1.1. 縮尺依存レンダリング

縮尺依存レンダリングでは、レイヤ(ラスタまたはベクタ)が表示される最小および最大縮尺を指定できます。縮尺依存レンダリングを設定するには、凡例内のレイヤをダブルクリックして プロパティ ダイアログを開きます。 レンダリング タブで、 checkbox 縮尺に応じた表示設定 にチェックを入れ、最小(この値は含まない)最大(この値を含む) 縮尺値を入力します。

また、レイヤパネルからレイヤの縮尺依存表示を有効にすることもできます。レイヤを右クリックして、コンテキストメニューから レイヤを表示する縮尺の設定 を選択します。

mapIdentification 現在のキャンバスの縮尺に設定 ボタンは、現在のマップキャンバスの縮尺を可視範囲の境界として使用することができます。

注釈

マップの縮尺が表示可能な縮尺の範囲外にあるためにレイヤがマップキャンバスにレンダリングされない場合、そのレイヤはレイヤパネルでグレー表示され、新しいオプション 表示される縮尺にズーム がレイヤのコンテキストメニューに表示されます。これを選択すると、マップはそのレイヤの表示可能な縮尺に最も近い縮尺までズームします。

11.4.1.2. 地図レンダリングの制御

以下で述べるように、地図レンダリングはさまざまな方法で制御できます。

11.4.1.2.1. 描画の中断

レンダリングを中断するには、ステータスバーの右下角にある checkbox レンダ チェックボックスをクリックします。 checkbox レンダ がチェックされていない場合、QGISは レンダリング のセクションで説明されているイベントに応じたキャンバスの再描画を行いません。レンダリングを中断したい場合の例としては、以下のようなものがあります:

  • 多数のレイヤを追加し、描画される前にシンボルを設定したい場合

  • 1つもしくは多数の巨大なレイヤを追加し、描画される前に縮尺依存表示設定を行いたい場合

  • 1つもしくは多数の巨大なレイヤを追加し、描画される前に特定のビューにズームしたい場合

  • 上で挙げたいずれかの組み合わせの場合

checkbox レンダ がチェックされるとレンダリングが有効になり、即座にマップキャンバスが更新されます。

11.4.1.2.2. レイヤ追加時のオプションの設定

新しいレイヤを常に描画せずに読み込むオプションを設定できます。これは、レイヤはマップに追加されますが、凡例内の表示チェックボックスはデフォルトではオフになることを意味します。このオプションを設定するには、メニューオプションの 設定 ► オプション を選択して レンダリング タブをクリックします。 checkbox 追加レイヤのデフォルトで表示 のチェックを外します。その後にマップに追加されたレイヤは、デフォルトでオフ(非表示)になります。

11.4.1.2.3. 描画の中断

マップの描画を停止するには、 Esc キーを押します。これによりマップキャンバスの更新は中断され、マップは部分的に描画されたままになります。 Esc を押してからマップの描画が停止するまでには、少し時間がかかる場合があります。

11.4.1.2.4. レンダリング品質への影響

QGISにはマップのレンダリング品質に影響を与えるオプションがあります。メニューオプションの 設定 ► オプション を選択して、 レンダリング タブをクリックし、 checkbox 線のジャギーを目立たなくする(描画速度が若干低下します) を選択または選択解除してください。

11.4.1.2.5. レンダリングの高速化

レンダリング速度を上げる設定がいくつかあります。 設定 ► オプション からQGISのオプションダイアログボックスを開き、 レンダリング タブに行って、次のチェックボックスを選択または選択解除します:

  • checkbox 再描画の速度を上げられる時にレンダリングのキャッシュを利用する

  • checkbox レイヤの描画を複数のCPUコアを使って並列に行うcheckbox 最大コア数 の設定

  • マップはバックグラウンドで別々の画像にレンダリングされ、 checkbox 更新間隔 毎に、この(画面外の)画像の内容が表示画面の更新に使用されます。ただし、レンダリングがこの時間よりも早く終了した場合は、それが瞬時に表示されます。

  • checkbox 新規追加レイヤの地物の簡素化をデフォルトで有効にする を使用すると、地物のジオメトリが簡略化(ノード数が減少)され、結果として表示が速くなります。これはレンダリングに不整合が生じる場合があることに注意してください。

11.4.2. ズームとパン

関心のある領域にズームしたりパンしたりするための方法がいくつかあります。 マップナビゲーション ツールバーや、マップキャンバス上でのマウスやキーボード操作、さらに ビュー メニューのメニューアクションや レイヤ パネル内でのレイヤのコンテキストメニューも使用することができます。

アイコン

ラベル

使用法用

ビューメニュー

マップナビゲーションツールバー

レイヤコンテキストメニュー

pan

地図を移動

アクティブな状態でマップキャンバス上の任意の場所を左クリックすると、カーソル位置にマップをパンすることができます。また、マウスの左ボタンを押したままマップキャンバスをドラッグしても、マップをパンすることができます。

checkbox

checkbox

zoomIn

拡大

アクティブな状態でマップキャンバス上の任意の場所を左クリックすると、1レベル分拡大します。マウスカーソルの位置が拡大された関心のある領域の中心になります。また、マウスの左ボタンを押したままマップキャンバス上でドラッグした長方形領域を拡大することもできます。

checkbox

checkbox

zoomOut

縮小

アクティブな状態でマップキャンバス上の任意の場所を左クリックすると、1レベル分縮小します。マウスカーソルの位置が縮小された関心のある領域の中心になります。また、マウスの左ボタンを押したままマップキャンバス上でドラッグした長方形領域から縮小することもできます。

checkbox

checkbox

panToSelected

選択部分にパン

アクティブレイヤの選択された地物にマップをパンします。

checkbox

checkbox

zoomToSelected

選択部分にズーム

アクティブレイヤの選択された地物にズームします。

checkbox

checkbox

checkbox

zoomToLayer

レイヤの領域にズーム

アクティブレイヤの範囲に拡大縮小します。

checkbox

checkbox

checkbox

zoomFullExtent

全域表示

プロジェクト内のすべてのレイヤを含む範囲に拡大縮小します。

checkbox

checkbox

zoomLast

前の領域へズーム

マップを履歴内の前の表示範囲にズームします。

checkbox

checkbox

zoomNext

次の表示領域にズーム

マップを履歴内の次の表示範囲にズームします。

checkbox

checkbox

zoomActual

ネイティブ解像度にズーム

アクティブなラスタレイヤの1ピクセルがスクリーンの1ピクセルに一致するようにマップを拡大縮小します。

checkbox

checkbox

checkbox

設定 ► options オプション ► ツール メニューから ズーム倍率 を設定することができ、ズーム時のスケール動作を定義することができます。ここでは、 定義済み縮尺 のリストを設定することができ、マップキャンバス下部の縮尺で利用することができます。

11.4.2.1. マップキャンバス上でのマウス利用

上で述べた pan 地図を移動 zoomIn 拡大 zoomOut 縮小 ツールを使うほかに、マップキャンバス内でマウスホイールボタンを押しながらマウスカーソルをドラッグする(macOSでは cmd を押しながらする必要があるかもしれません)ことでも地図移動ができます。 また、マップ上でマウスホイールを回すと、拡大・縮小ができます。マウスカーソルの位置が拡大・縮小された関心域の中心となります。 Ctrl キーを押しながらマウスホイールを回すと、より細かい拡大縮小ができます。

11.4.2.2. マップキャンバス上でのキーボード利用

キーボードの スペースバー を押しながらマウスカーソルを動かすと、 pan 地図の移動 でマップキャンバスをドラッグしたときとと同じようにマップが移動します。

地図の移動は矢印キーでも可能です。マップエリア内にカーソルを置き、矢印キーを押すと、上下左右に移動します。

キーボードの PgUpPgDown キーを押すと、設定した拡大率でマップ表示を拡大または縮小します。 Ctrl++Ctrl+- を押すことでもマップキャンバスの拡大/縮小を行います。

特定のマップツール(地物の識別ツール、計測ツール...)がアクティブな場合、 Shift キーを押しながらマップ上で矩形をドラッグするとその領域にズームすることができます。これは選択ツールや編集ツールがアクティブな場合には使用することはできません(選択範囲への追加に Shift キーを使うため)。

11.4.3. 空間ブックマーク

空間ブックマークは地理的な場所を「ブックマーク」し、後でその場所に戻ることができます。デフォルトでは、ブックマークは( ユーザー・ブックマーク として)ユーザープロファイルに保存されるため、ユーザーが開いたどのプロジェクトからでもブックマークを利用できます。また、単一のプロジェクト に対して保存( プロジェクト・ブックマーク )することもでき、これはプロジェクトを他のユーザーと共有する場合に便利です。

11.4.3.1. ブックマークを作成する

ブックマークをを作成するには:

  1. 関心のある領域にズームやパンし移動します

  2. メニューオプションの ビュー ► newBookmark 空間ブックマークを作成... を選択するか、 Ctrl+B を押す、もしくは ブラウザ パネル内の showBookmarks 空間ブックマーク エントリを右クリックして、select 新規空間ブックマーク を選択します。 ブックマークエディタ ダイアログが開きます。

    ../../../_images/bookmark_editor.png

    図 11.6 ブックマークエディタダイアログ

  3. ブックマークにわかりやすい名前を付けます

  4. 関連するブックマークを保存するグループ名を入力または選択します。

  5. 保存したい領域範囲を領域セレクタを使用して選択します。保存範囲は読み込まれたレイヤの領域か、現在のマップキャンバス領域、もしくは現在のマップキャンバス上に描画した領域より計算されます。

  6. 領域に使用する CRS を指定します

  7. ブックマークの 保存先ユーザー・ブックマークプロジェクト・ブックマーク のどちらにするか選択します

  8. 保存 ボダンを押して、ブックマークをリストに追加します

同じ名前のブックマークを複数持てることに注意してください。

11.4.3.2. ブックマークを操作する

ブックマークを利用・管理するには、 空間ブックマーク パネル もしくは ブラウザ パネルを使用できます。

ビュー ► showBookmarks 空間ブックマーク・マネージャを表示 を選択するか Ctrl+7 を押すと、 空間ブックマークマネージャ パネルが開きます。 ビュー ► showBookmarks 空間ブックマークを表示 を選択するか Ctrl+Shift+B を押すと、 ブラウザ パネル内の showBookmarks 空間ブックマーク エントリが表示されます。

以下の作業を行うことができます:

タスク

空間ブックマークマネージャ

ブラウザ

ブックマークにズーム

ブックマーク上でダブルクリックするか、ブックマークを選択して zoomToBookmark ブックマークにズーム ボタンを押す

ブックマーク上でダブルクリックするか、ブックマークをマップキャンバス上へドラッグドロップする、あるいはブックマークで右クリックし、 ブックマークにズーム を選択する

ブックマークを削除する

ブックマークを選択して deleteSelected ブックマークを削除する ボタンを押し、削除の確認を承認する

ブックマークを右クリックして ブックマークを削除 を選択し、削除の確認を承認する

ブックマークをXMLへエクスポート

sharing ブックマークのインポートとエクスポート ボタンをクリックし、 sharingExport エクスポート を選択する。すべての空間ブックマーク(ユーザー、プロジェクトともに)がXMLファイルに保存される

1つまたは(ユーザー、プロジェクト)両方のフォルダ、あるいはサブフォルダ(グループ)を選択し、右クリックして sharingExport 空間ブックマークをエクスポート... を選ぶ。選択したブックマークのサブセットが保存される

ブックマークをXMLからインポート

sharing ブックマークのインポートとエクスポート ボタンをクリックし、 sharingImport インポート を選択する。XMLファイル内の全てのブックマークがユーザー・ブックマークとしてインポートされる

ブックマークをインポートしたい場所として 空間ブックマーク エントリか、その中のフォルダ(ユーザーまたはプロジェクト)のどれかか、あるいはそのサブフォルダ(グループ)を決めて右クリックし、 sharingImport 空間ブックマークをインポート を選ぶ。 空間ブックマーク エントリを選んだ場合、インポートしたブックマークは ユーザー・ブックマーク に追加される

ブックマークを編集

テーブル内の値を変えることでブックマークを変更することができる。名前、グループ名、範囲、そしてブックマークがプロジェクトに保存されるか否かを編集できる

編集したいブックマークを右クリックし、 空間ブックマークを編集... を選択する。 ブックマーク・エディタ が開き、ブックマークを最初に作成したときのようにさまざまな点についてを再定義できる

フォルダ間(ユーザー、プロジェクト)やサブフォルダ(グループ)間でブックマークをドラッグ・ドロップすることもできる

ロケータ バーにブックマーク名を入力して、ブックマーク範囲にズームすることもできます。

11.4.4. 地図整飾

地図整飾には、グリッド、タイトルラベル、著作権ラベル、画像、方位記号、スケールバー、そしてレイアウト範囲があります。 これらは地図要素を追加することによって地図を「整飾」するために使われます。

11.4.4.1. グリッド

addGrid グリッド はマップキャンバスに座標グリッドと座標注釈を追加します。

  1. ビュー ► 地図整飾 ► グリッド... のメニューオプションを選択し、ダイアログを開きます。

    ../../../_images/grid_dialog.png

    図 11.7 グリッドダイアログ

  2. checkbox グリッドを有効にする にチェックを入れ、マップキャンバスに読み込まれたレイヤに応じてグリッド定義を設定します:

    • グリッドタイプライン もしくは マーカー から選びます

    • グリッドのマークを表現するために使用される、関連した ラインシンボル あるいは マーカーシンボル

    • マップ単位によるグリッドマーク間の X 間隔Y 間隔

    • マップ単位によるマップキャンバス左下隅からグリッドマークまでの距離 X オフセットY オフセット

    • 間隔とオフセットのパラメータは、以下に基づいて設定することもできます:

      • キャンバスの領域: キャンバス幅のおおよそ1/5 の間隔でグリッドを生成します

      • アクティブラスタレイヤ の解像度に基づき設定します

  3. checkbox 注釈の描画 にチェックを入れ、グリッドのマークの座標を表示します。以下の設定があります。

    • 注記方向, ラベルがグリッド線に対して相対的にどのように配置されるかを設定します。これには以下の選択肢があります:

      • 全てのラベルを 水平 あるいは 垂直 に配置する

      • 水平と垂直 各ラベルは参照しているグリッドマークと平行です

      • 境界線の方向 各ラベルはキャンバスの境界線に沿っており、参照するグリッドマークに垂直です

    • 注記用フォント (テキストフォーマット、バッファ、影...) フォントセレクタウィジェット を使って設定します。

    • 地図のフレームへの距離 注記とマップキャンバスの端の間のマージンです。 例えば画像形式やPDFに マップキャンバスをエクスポート する際に便利で、「紙」の境界上に注記が乗ってしまうことを避けられます。

    • 座標精度

  4. 適用 ボタンをクリックして見た目が期待通りかを確認し、満足ならば OK ボタンをクリックします。

11.4.4.2. タイトルラベル

titleLabel タイトルラベルタイトル でマップを整飾します。

タイトルラベル整飾を追加するには:

  1. ビュー ► 地図整飾 ► タイトルラベル... のメニューオプションを選択し、ダイアログを開きます。

    ../../../_images/titleLabel.png

    図 11.8 タイトルラベルの装飾ダイアログ

  2. checkbox タイトルラベルの有効化 をチェックしてください

  3. マップに追加したいタイトルのテキストを入力します。 式の挿入・編集... ボタンを使用して、テキストを動的にすることもできます。

  4. ラベルの フォント を QGISの テキストの整形 オプションへフルアクセスできる フォントセレクタウィジェット を使用して選択します。フォントコンボボックスの右にある黒い矢印をクリックすると、フォントの色や不透明度を素早く設定することができます。

  5. タイトルの 背景のバーの色 に適用する を選択します。

  6. キャンバス内のラベルの 配置 を選択します。選択肢は 左上中上 (デフォルト)、 右上左下中下 そして 右下 です。

  7. 水平および/または垂直の 端からのマージン を設定することで、アイテムの配置を調整します。これらの値は ミリメートル または ピクセル 単位で指定するか、マップキャンバスの幅または高さの パーセント として設定することができます。

  8. 適用 ボタンをクリックして見た目が期待通りかを確認し、満足ならば OK ボタンをクリックします。

11.4.4.4. 画像

addImage 画像 はマップキャンバスに画像(ロゴ、凡例など...)を追加します。

画像を追加するには:

  1. ビュー ► 地図整飾 ► 画像... のメニューオプションを選択し、ダイアログを開きます。

    ../../../_images/image_decoration.png

    図 11.10 画像整飾ダイアログ

  2. checkbox 画像を有効化 をチェックしてください

  3. ... ブラウズ ボタンを押して、ビットマップ画像(例:png や jpg)か SVG画像を選択します

  4. パラメータが有効化されたSVG画像を選択した場合、 塗りつぶしストローク (輪郭線)の色も設定することができます。ビットマップ画像の場合には、この色設定は無効になっています。

  5. 画像の 大きさ をミリメートル単位で指定します。選択された画像の幅は、与えられた 大きさ にリサイズされます。

  6. 配置 コンボボックスを用いて、マップ上で画像を配置したい場所を選択します。 デフォルトの位置は 左上 です。

  7. (キャンバス)端からの水平 および 垂直 マージン を設定します。これらの値は ミリメートル または ピクセル 単位で指定するか、マップキャンバスの幅または高さの パーセント として設定することができます。

  8. 適用 ボタンをクリックして見た目が期待通りかを確認し、満足ならば OK ボタンをクリックします。

11.4.4.5. 方位記号

northArrow 方位記号 はマップキャンバスに北向き矢印を追加します。

方位記号を追加するには:

  1. ビュー ► 地図整飾 ► 方位記号... のメニューオプションを選択し、ダイアログを開きます。

    ../../../_images/north_arrow_dialog.png

    図 11.11 方位記号ダイアログ

  2. checkbox 方位記号を使用 をチェックしてください

  3. オプションで色やサイズを変更したり、カスタムSVGを選択したりすることができます。

  4. オプションで角度を変更するか、あるいはQGISに 自動 で方向を決定させることができます。

  5. オプションで配置コンボボックスから配置位置を選択できます。

  6. 必要に応じて、水平および/または垂直の (キャンバス)端からのマージン を設定して矢印の配置を調整します。これらの値は ミリメートル または ピクセル 単位で指定するか、マップキャンバスの幅または高さの パーセント として設定できます。

  7. 適用 ボタンをクリックして見た目が期待通りかを確認し、満足ならば OK ボタンをクリックします。

11.4.4.6. スケールバー

scaleBar スケールバー は、マップキャンバスに単純なスケールバーを追加します。スタイルや配置、バ​​ーのラベルを制御することができます。

QGISはマップフレームと同じ単位でのスケール表示しかサポートしていません。従って、プロジェクトのCRSの単位がメートルの場合には、フィート単位のスケールバーを作成することはできません。同様に、小数点表示の角度を使っている場合には、 距離をメートル単位で表示するスケールバーは作成できません。

スケールバーを追加するには:

  1. ビュー ► 地図整飾 ► スケールバー... のメニューオプションを選択し、ダイアログを開きます。

    ../../../_images/scale_bar_dialog.png

    図 11.12 スケールバーダイアログ

  2. checkbox スケールバーを有効にする をチェックしてください

  3. スケールバーのスタイル selectString コンボボックスからスタイルを選択します

  4. 塗りつぶし色(デフォルト:黒)とアウトライン色(デフォルト:白)を選択して、 バーの色 selectColor を設定します。色入力の右にある下矢印をクリックすると、スケールバーの塗りつぶしとアウトラインの不透明度を設定することもできます。

  5. バーのフォント selectString コンボボックスからスケールバーのフォントを選択します

  6. バーのサイズ selectNumber を設定します

  7. オプションで checkbox リサイズ時に自動的に四捨五入 をチェックすることで、読みやすい値で表示できます

  8. 配置 selectString コンボボックスから配置位置を選択します

  9. 水平および/または垂直の (キャンバス)端からのマージン を設定することで、アイテムの配置を調整します。これらの値は ミリメートル または ピクセル 単位で指定するか、マップキャンバスの幅または高さの パーセント として設定できます。

  10. 適用 ボタンをクリックして見た目が期待通りかを確認し、満足ならば OK ボタンをクリックします。

11.4.4.7. レイアウト範囲

addMap レイアウト範囲 は印刷レイアウトの 地図アイテム の範囲をキャンバスに追加します。 有効にすると、すべての印刷レイアウト内のすべての地図アイテムの範囲が、印刷レイアウトと地図アイテムの名前でラベル付けされた淡い点線の境界線を使用して表示されます。表示されたレイアウト範囲のスタイルとラベル付けを制御できます。この装飾は、ラベルなどの地図要素の位置を微調整していて、印刷レイアウトの実際の表示領域を知る必要がある場合に役立ちます。

../../../_images/decoration_layoutextents_example.png

図 11.13 2つの印刷レイアウトのレイアウト範囲をQGISプロジェクトに表示した例。「Sights」という名前の印刷レイアウトには2つの地図アイテムがあり、もう一つの印刷レイアウトの地図アイテムは1つ。

レイアウト範囲を追加するには:

  1. ビュー ► 地図整飾 ► レイアウト範囲... を選択し、ダイアログを開きます。

    ../../../_images/decoration_layoutextents.png

    図 11.14 レイアウト範囲ダイアログ

  2. checkbox レイアウトの範囲を表示する をチェックしてください。

  3. オプションで範囲のシンボルとラベル付けを変更することができます。

  4. 適用 ボタンをクリックして見た目が期待通りかを確認し、満足ならば OK ボタンをクリックします。

ちなみに

地図整飾の設定

QGISプロジェクトファイルを保存する際、グリッド、方位記号、スケールバー、著作権およびレイアウト範囲に加えた変更はそのプロジェクトに保存され、次回プロジェクトをロードした際に復元されます。

11.4.5. 注記ツール

注記は、地図キャンバスに追加されてバルーン内に表示される情報です。この情報は様々な種類のものが可能で、注釈は 属性ツールバー の対応するツールを使って追加されます。

  • textAnnotation 文字注記 カスタム書式テキストの注記

  • htmlAnnotation HTML注記 html ファイルのコンテンツを配置するための注記

  • svgAnnotation SVG注記 SVG ファイルのシンボルを追加するための注記

  • formAnnotation 注記フォーム: ベクタレイヤの属性を、カスタマイズされた ui ファイル( 図 11.15 を参照)で表示するのに便利です。 カスタム属性フォーム に似ていますが、これは注記アイテムに表示されます。詳細については、Tim Sutton 氏によるビデオ https://www.youtube.com/watch?v=0pDBuSbQ02o&feature=youtu.be&t=2m25s も参照してください。

../../../_images/custom_annotation.png

図 11.15 カスタマイズされたQtデザイナ注記フォーム

注記を追加するには、対応するツールを選択してマップキャンバスをクリックします。空のバルーンが追加されます。これをダブルクリックすると、さまざまなオプションを含むダイアログが開きます。このダイアログは、すべての注記タイプでほぼ同じです。

  • 一番上には、注記の種類に応じて htmlsvg または ui ファイルへのパスを入力するためのファイルセレクタがあります。テキスト注釈の場合は、テキストボックスにメッセージを入力して、通常のフォントツールを使用してそのレンダリングを設定できます。

  • checkbox 地図の固定位置:チェックを外すと、バルーンの配置は(地図ではなく)画面の位置に基づきます。つまり、注記は地図のキャンバスの範囲に関係なく常に表示されます。

  • リンクされたレイヤ: マップのレイヤに注記を関連付け、そのレイヤが表示状態のときのみ注記が表示されるようにします。

  • マーカー: QGISのシンボル を使って、バルーンのアンカー位置に表示されるシンボルを設定します( 地図の固定位置 にチェックが入っているときのみ表示されます)。

  • フレームスタイル: QGISのシンボル設定を使用して、フレームの背景色や透明度、バルーンのストローク色やストローク幅を設定します。

  • コンテンツのマージン: 注記フレームの内側のマージンを設定します。

../../../_images/annotation.png

図 11.16 注記テキストダイアログ

注記ツールが有効なときは、注記を選択できます。注記は、(マップマーカーをドラッグすることで)地図上の位置を移動したり、バルーンだけを移動したりすることができます。 annotation 注記の移動 ツールでマップキャンバス上のバルーンを移動させることもできます。

注記を削除するには、その注記を選択して Del または Backspace キーを押すか、またはその注記をダブルクリックしてプロパティダイアログの 削除 ボタンを押します。

注釈

注記 ツール(注記の移動、文字注記、注記フォーム )が有効な時に Ctrl+T を押すと、アイテムの表示・非表示が反転します。

ちなみに

マップに注記をレイアウトする

以下の方法で、注記をマップとともにさまざまな形式で印刷またはエクスポートすることができます。

  • プロジェクト メニュー内にあるマップキャンバスのエクスポートツール

  • 印刷レイアウト の場合には、対応する地図のアイテムプロパティで 地図キャンバスアイテムの描画 にチェックを入れる必要があります。

11.4.6. 計測

11.4.6.1. 一般情報

QGISは、ジオメトリを計測する4つの手段を提供します。

  • インタラクティブな計測ツール measure

  • calculateField フィールド計算機 による計測

  • 地物を識別する ツールによる派生した属性の計測

  • ベクタ解析ツール: ベクタ ► ジオメトリツール ► ジオメトリ属性の追加

計測は投影された座標系(例えばUTM)でも、非投影データでも機能します。最初の3つの計測ツールは、グローバルなプロジェクト設定に対しても同様に動作します:

  • 他のほとんどのGISとは異なり、QGISのデフォルトの計測基準は楕円体で、 プロジェクト ► プロパティ... ► 一般情報 で定義される楕円体を使っています。これは、プロジェクトに地理座標系や投影座標系が定義されている場合にも当てはまります。

  • 投影された/平面的な面積や距離を直交座標系によって計算したい場合には、計測の楕円体を「None/Planimetric」にしなければなりません( プロジェクト ► プロパティ... ► 一般情報 )。ただし、データとプロジェクトに定義された地理的(すなわち非投影の)CRSを使用すると、面積と距離の計測は楕円体計算になります。

しかしながら、地物情報表示ツールやフィールド計算機はどちらも計測前にデータをプロジェクトのCRSへ変換しません。これを行いたい場合には、ベクタ解析ツール: ベクタ ► ジオメトリツール ► ジオメトリ属性の追加... を使用する必要があります。ここでは、楕円体計測を選択しない限り、計測は平面座標系で行われます。

11.4.6.2. 対話的に長さ、面積、角度を計測

属性ツールバーの measure アイコンをクリックすると、計測を開始できます。アイコンの近くにある下矢印は measure 長さ、 measureArea 面積、 measureAngle 角度の計測を切り替えます。ダイアログで使用されるデフォルトの単位は、 プロジェクト ► プロパティ... ► 一般情報 メニュー内で設定された単位です。

注釈

計測ツールを設定する

長さや面積を測定しているときに、ウィジェットの下にある 設定 ボタンをクリックすると、 設定 ► オプション ► ツール メニューが開きます。ここではラバーバンド色、測定の桁数、計測単位を選択できます。好みの長さや角度の単位も選択できますが、現在のプロジェクト中ではこれらの値は プロジェクト ► プロパティ ► 一般情報 メニューで行われた選択と計測ウィジェットで行われた選択によって上書きされることに注意してください。

すべての計測モジュールは、デジタイジングモジュールのスナップ設定( スナップ許容誤差と検索半径の設定 セクションを参照)を使用します。正確にライン地物に沿って、あるいはポリゴン地物の周りを測定したいのであれば、最初にそのレイヤのスナップ許容誤差を設定します。すると、測定ツールを使用している場合の(許容誤差の設定内の)各マウスクリックはそのレイヤにスナップします。

デフォルトでは、 measure 線の長さを測る は与えられた点の実距離を定義された楕円体に基づいて計測します。このツールではマップ上の地点をクリックすると、各セグメントの長さと合計が計測ウィンドウに表示されます。計測を停止するには、マウスの右ボタンをクリックします。 全てをコピー ボタンを使用すると、全ての線の計測結果をクリップボードに一度にコピーすることができます。

計測ツールで作業中は、合計の近くにあるドロップダウンリストを操作しながら測定単位を対話的に変更できます、(「メートル」、「キロメートル」、「フィート」、「ヤード」、「マイル」、「海里」「センチメートル」、「ミリメートル」、「度」、「地図単位」)。この単位は、新しいプロジェクトが作成されるか、別のプロジェクトが開かれるまで、このウィジェットで保持されます。

ダイアログの 情報 セクションでは、利用可能なCRS設定に従ってどのように計算が行われるかが説明されています。

../../../_images/measure_line.png

図 11.17 距離の計測

measureArea 面積を測る: 面積も計測することができます。計測ウィンドウでは、累積の面積合計が表示されます。右クリックで描画を停止します。情報セクションがあり、異なる面積単位への変換機能(「平方メートル」、「平方キロメートル」、「平方フィート」、「平方ヤード」、「平方マイル」、「ヘクタール」、「エーカー」、「平方センチメートル」、「平方ミリメートル」、「平方海里」、「平方度」、「地図単位」)もあります。

../../../_images/measure_area.png

図 11.18 面積の計測

measureAngle 角度を測る: 角度を測ることもできます。カーソルが十字型に変化します。クリックして計測したい角の1つ目のセグメントを描画し、それからカーソルを動かして求める角を描きます。計測値はポップアップダイアログに表示されます。

../../../_images/measure_angle.png

図 11.19 角度の計測

11.5. 地物とのやりとり

11.5.1. 地物の選択

QGISには、マップキャンバス上の地物を選択するためのツールがいくつかあります。選択ツールは、 編集 ► 選択 メニューや 選択ツールバー にあります。

注釈

選択ツールは、現在アクティブなレイヤで動作します。

11.5.1.1. マップキャンバスで手動で選択する

マウスを使って1つもしくは多数の地物を選択するには、以下のツールのどれかを使います:

  • selectRectangle エリアまたはシングルクリックによる地物選択

  • selectPolygon ポリゴンによる地物選択

  • selectFreehand フリーハンドによる地物選択

  • selectRadius 円による地物選択

注釈

selectPolygon ポリゴンによる地物選択 を除き、これらの手動選択ツールはマップキャンバス上の地物をシングルクリックで選択することもできます。

注釈

(任意レイヤの)既存のポリゴン地物を使用して、アクティブレイヤ内で重なる地物を選択するには selectPolygon ポリゴンによる地物選択 ツールを使用してください。ポリゴンを右クリックして、クリックした点を含むすべてのポリゴンのリストを表示するコンテキストメニューから、使用したいポリゴンを選択します。すると、ポリゴンと重なり合うアクティブレイヤのすべての地物が選択されます。

ちなみに

編集 ► 選択 ► 地物を再選択 ツールを使うと、直前に行った選択をやり直せます。これは苦労して選択をした後、うっかりどこか別の場所をクリックしてしまい、選択がクリアされてしまった時に非常に便利です。

selectRectangle 地物の選択 ツールを使用中に Shift キーや Ctrl キーを押しながら選択すると、地物の選択状態が反転します(つまり、現在の選択に追加するか、選択から除くかをします)。

他のツールについては、以下のキーを押しながら選択した際の動作が異なります:

  • Shift :地物を現在の選択に追加します

  • Ctrl :地物を現在の選択から除きます

  • Ctrl+Shift: 現在の選択範囲との交差を取ります。すなわち、現在の選択範囲と重なりがある地物のみを残します

  • Alt: 選択形状の中に完全に入っている地物を選択します。 Shift キーや Ctrl キーと組み合わせると、地物を現在の選択に追加したり、選択から引いたりできます。

11.5.1.2. 自動選択

もう一方の選択ツールは、地物の属性やその選択状態に基づいて選択を実行します。ツールのほとんどは 属性テーブル からも利用できます(属性テーブルと地図のキャンバスは同じ情報を表示するので、属性テーブル内で1つの地物を選択した場合、それはまた、地図キャンバスでも選択されることに注意してください)。

  • expressionSelect 式による地物選択... 式ダイアログを使用して地物を選択します

  • formSelect 値による地物選択... または F3 を押します

  • deselectAll 全レイヤの選択を解除 または Ctrl+Alt+A を押しても全レイヤの地物選択を解除することができます

  • deselectActiveLayer アクティブレイヤの選択を解除 または Ctrl+Shift+A を押します

  • selectAll すべての地物を選択 または Ctrl+A でも現在のレイヤの地物全てを選択します

  • invertSelection 地物選択を反転 カレントレイヤ内の地物の選択状態を反転させます

  • algorithmSelectLocation 場所による選択 は、他の地物(同じレイヤもしくは他のレイヤ - 場所による選択 参照)との空間的な関係に基づいて地物を選択します

例えば、QGISサンプルデータの regions.shp からBorough(市)の地域を探したい場合には、次のようにします:

  1. expressionSelect 式による地物選択 アイコンをクリックします

  2. フィールドと値 グループを展開します

  3. クエリしたいフィールド( "TYPE_2" )をダブルクリックします

  4. 右に現れたパネルの 全てのユニーク ボタンをクリックします

  5. リストの中から、「市(Borough)」をダブルクリックします。 エディタフィールドで、以下のようにクエリを記述します:

    "TYPE_2"  =  'Borough'
    
  6. 地物の選択 ボタンをクリックします

式ビルダーダイアログから、 関数リスト ► 最近使用(selection) を使用して、以前に使用した式による選択を行うこともできます。ダイアログには最後に使用された20個の式が記憶されます。詳細情報や例は を参照してください。

ちなみに

新しいファイルに選択地物を保存する

編集 ► 地物のコピー編集 ► 新規レイヤへの地物貼り付け を使用することで、ユーザは選択した地物を 新しいスクラッチレイヤ や任意のファイル形式の 新しいベクタレイヤ に保存することができます。

11.5.1.3. 値による地物選択

この選択ツールはレイヤの地物フォームを開き、各フィールドで検索する値、大文字と小文字を区別するかどうか、使用する操作をユーザーが選択できるようにします。このツールには自動補完機能もあり、自動的に検索ボックスに既存の値を入力します。

../../../_images/select_by_value.png

図 11.20 フォームダイアログを使用して地物をフィルタ/選択

各フィールドの横には、検索動作を制御するためのオプションを選べるドロップダウンリストがあります:

フィールド検索オプション

文字列

数値

日付

フィールドを除外 :検索対象からフィールドを除外します

checkbox

checkbox

checkbox

等しい(=)

checkbox

checkbox

checkbox

等しくない(≠)

checkbox

checkbox

checkbox

より大きい(>)

checkbox

checkbox

より小さい(<)

checkbox

checkbox

以上(≥)

checkbox

checkbox

以下(≤)

checkbox

checkbox

範囲内(境界値を含む)

checkbox

checkbox

範囲外(境界値を含む)

checkbox

checkbox

含む

checkbox

含まない

checkbox

値がない(null)

checkbox

checkbox

checkbox

値がある(nullではない)

checkbox

checkbox

checkbox

で始まる

checkbox

で終わる

checkbox

文字列の比較には、 checkbox Case sensitive オプション(大文字・小文字を区別する)を使用することもできます。

全ての検索オプションを設定し終えたら、 地物の選択 ボタンをクリックしてマッチする地物を選択します。ドロップダウンオプションには以下のものがあります:

  • 地物の選択

  • 現在の選択に追加する

  • 現在の選択から除去する

  • 現在の選択をフィルタする

フォームのリセット ボタンを押すことで、全ての検索オプションをクリアすることができます。

検索条件をセットしたら、以下の操作も行えます:

  • 地物にズーム あらかじめ選択することなく、マップキャンバス上の地物にズームします

  • 地物をフラッシュ 検索条件に一致する地物を強調表示します。これは、選択や地物情報表示ツールを使用せずに地物を識別するのに便利な方法です。「地物をフラッシュ」はマップキャンバスの範囲を変更しないため、地物が現在の地図キャンバスの範囲内にある場合にのみ強調表示されることに注意してください。

11.5.2. 地物を識別する

地物情報表示ツールを使用すると、地図キャンバスと対話的に操作して地物に関する情報を取得し、ポップアップウィンドウ中に表示します。地物情報を表示するには、以下を使用します:

  • ビュー ► 地物情報表示

  • Ctrl+Shift+Iosx の場合は Cmd+Shift+I

  • 属性ツールバーの identify 地物情報表示 アイコン

11.5.2.1. 地物情報表示ツールを使用する

QGIS には identify 地物情報表示 ツールを使用して地物の情報を表示する方法がいくつかあります:

  • 左クリック 地物情報 パネルの 選択モード選択マスク の設定に応じて、地物の情報を表示します

  • 右クリック 地物情報 パネルで 選択モード 設定として 地物情報表示 ツールで右クリックすると、全ての可視レイヤからスナップされた地物全てを取得します。コンテキストメニューが開かれ、ユーザは情報表示しようとする地物をより正確に選択したり、あるいは地物に対して実行するアクションを選択したりすることができます。

  • 右クリック 地物情報 パネルで 選択モードポリゴンによる地物の特定 とした状態で右クリックすると、 地物情報 パネルの 選択マスク 設定に応じて、選択した既存のポリゴンと重複する地物の情報を表示します。

ちなみに

地物情報表示ツールでクエリするレイヤをフィルタリングする

プロジェクト ► プロパティ... ► データソース タブ内の レイヤのCapabilities で、レイヤ列の隣にある 情報表示可能 列のチェックを外すと、 カレントレイヤ モード以外のモードで identify 地物情報表地 ツールを使った場合に地物情報が検索されなくなります。これは、興味のあるレイヤのみから地物情報を返すための便利な方法です。

地物をクリックすると、 地物情報 ダイアログにクリックされた地物に関する情報が一覧表示されます。 デフォルトビューはツリービューで、最初の項目はレイヤの名前、その子は識別された地物です。 各地物は、フィールドの名前および値で記述されます。 このフィールドは レイヤプロパティ ► 表示名 で設定されたものです。 地物に関する他のすべての情報が続きます。

11.5.2.2. 地物情報

地物情報ダイアログはカスタムのフィールドを表示するようにカスタマイズすることもできますが、デフォルトでは以下の情報を表示します:

  • 地物の 表示名

  • アクション:アクションを地物情報ウィンドウに追加できます。アクションは、アクションのラベルをクリックすることで実行されます。デフォルトでは、編集のため 地物フォームを見る のアクション1つのみが追加されています。レイヤプロパティダイアログでより多くのアクションを定義することができます( アクションプロパティ を参照)。

  • 派生した属性 : この情報は、他の情報から計算されたものや、派生したものです。これには以下のものがあります:

    • 地物のジオメトリに関する一般的な情報:

      • ジオメトリのタイプにもよるが、レイヤのCRSの単位で表示したデカルト計測による長さ、周長、面積。3次元のラインベクタレイヤでは、ラインのデカルト長さも利用可能です。

      • ジオメトリのタイプにもよるが、プロジェクトのプロパティダイアログにおいて 計測 に楕円体が設定されている場合には、指定された単位で表示した楕円体計算による長さ、周長、面積

      • 地物内のジオメトリパーツの数と、クリックされたパーツの番号

      • 地物内の頂点数

    • プロジェクトのプロパティ 座標の表示 設定を使用した座標情報:

      • クリックされた点の XY 座標値

      • クリックされた点に最も近い頂点の番号

      • 最も近い頂点の XY 座標値(利用可能ならば Z / M も)

      • 曲線セグメントをクリックした場合には、その部分の曲率半径も表示されます。

  • データ属性 :これは、クリックされた地物の属性フィールドと値のリストです。

  • リレーション を定義している場合には、関連する子地物についての情報

    • リレーションの名前

    • 参照フィールドのエントリ、例えば関連した子地物の名前

    • アクション :レイヤプロパティダイアログで定義されているアクション( アクションプロパティ 参照)をリストします。デフォルトのアクションは 地物フォームを見る です。

    • データ属性 :これは、関連する子地物の属性フィールドと値のリストです。

注釈

地物属性内のリンクは 地物情報 パネルでクリックすることができ、デフォルトのウェブブラウザでリンクを開きます。

../../../_images/identify_features.png

図 11.21 地物情報ダイアログ

11.5.2.3. 地物情報ダイアログ

ウィンドウの上部には、少数のツールがあります:

  • formView 地物フォームを見る 現在の地物の属性フォームを開きます

  • expandTree ツリーを展開する

  • collapseTree ツリーを折りたたむ

  • expandNewTree 新しい結果をデフォルトで展開する 次に識別する地物情報のツリーを折りたたむか、展開するかを規定します

  • deselectAll 結果のクリア

  • editCopy 選択地物をクリップボードにコピー

  • filePrint 選択したHTMLレスポンスを印刷

  • 情報表示したい地物を取得するための選択モードには、以下のものがあります:

    • identifyByRectangle エリアまたはシングルクリックで地物を識別する

    • identifyByPolygon ポリゴンによる地物の特定

    • identifyByFreehand フリーハンドで地物を識別する

    • identifyByRadius 半径による地物の特定

    注釈

    identifyByPolygon ポリゴンによる地物の特定 を使用した際には、任意の既存のポリゴンを右クリックし、このポリゴンを重なりのある他のレイヤ内の地物を特定するために使用することができます。

ウィンドウの下部には、 モードビュー のコンボボックスがあります。 モード は、どのレイヤの地物情報を表示するかを定義します:

  • 現在のレイヤ(Current layer) :選択したレイヤの地物情報のみが表示されます。このレイヤはキャンバス内で見えている必要はありません。

  • トップダウン 最初の結果のみ : 最も上に見えているレイヤの地物のみを情報表示します。

  • トップダウン :全ての可視状態レイヤの地物情報を表示します。結果はパネル内に表示されます。

  • レイヤ選択 :右クリック時と同様に、コンテキストメニューを開き、どのレイヤの地物を情報表示するのかユーザがレイヤを選択します。パネルに表示されるのは選択されたレイヤの地物情報のみです。

ビューツリーテーブル または グラフ として設定できます。「テーブル」と「グラフ」ビューはラスタレイヤに対してのみ設定できます。

地物情報表示ツールでは options 地物情報表示の設定 の下にある checkbox 単一地物の場合、自動でフォームを開く の設定が行えます。これにチェックを入れると、単一の地物の情報を表示する場合には、フォームが開き地物属性が表示されます。これは地物の属性情報を素早く編集する際に便利な方法です。

その他の機能は、識別されたアイテムのコンテキストメニューにあります。たとえば、コンテキストメニューから次のことができます:

  • 地物フォームを表示

  • 地物にズームする

  • 地物のコピー: すべての地物ジオメトリと属性をコピーします

  • 選択地物を切り替え:識別された地物を選択範囲に追加します

  • 属性値のコピー: クリックした属性値のみをコピーします

  • 地物属性のコピー:地物属性をコピーします

  • 結果のクリア:ウィンドウ内の結果が削除されます

  • ハイライトをクリア:マップ上の地物ハイライトが除去されます

  • すべてをハイライトする

  • レイヤを強調表示

  • レイヤーをアクティブにする:アクティブにするレイヤを選択します

  • レイヤのプロパティ: レイヤプロパティウィンドウを開きます

  • すべて展開する

  • すべて折りたたむ

11.6. レイヤのプロパティの保存および共有

11.6.1. カスタムスタイルを管理する

ベクタレイヤがマップキャンバスに追加されると、QGISはデフォルトでランダムなシンボル/色を使用して地物をレンダリングします。ただし、 プロジェクト ►プロパティ... ► 既定スタイル でデフォルトのシンボルを設定することができ、新しく追加された各レイヤには、ジオメトリタイプに応じてこれが適用されます。

しかし、ほとんどの場合、レイヤに自動的にまたは手動で(より少ない労力で)適用できる、カスタマイズされたより複雑なスタイルが欲しいと思うでしょう。これはレイヤのプロパティダイアログの下部にある スタイル メニューを使えば実現できます。 このメニューには、スタイルを作成、読み込み、管理するための機能があります。

スタイルは、ベクタレイヤの場合はレイヤのレンダリングや相互作用(シンボロジ、ラベル付け、フィールドやフォームの定義、アクション、ダイアグラム...)、ラスタレイヤの場合はピクセル(バンド、色レンダリング、透明度、ピラミッド、ヒストグラム...)に関する、レイヤプロパティダイアログで設定された任意の情報を保存します。

../../../_images/style_combobox.png

図 11.22 ベクタレイヤのスタイルコンボボックスのオプション

デフォルトでは、読み込まれたレイヤに適用されるスタイルは default という名前です。あなたのレイヤに理想的で適切なレンダリングが設定できたら、 selectString スタイル コンボボックスをクリックして下記の項目を選択することで、スタイルを保存することができます。

  • 現在のスタイル名を変更 :現在アクティブなスタイルは名前が変更され、現在のオプションで上書きされます

  • 追加 :現在のオプションを使用して新しいスタイルが作成されます。デフォルトでは、QGISプロジェクトファイルに保存されます。別のファイルやデータベースにスタイルを保存するには、以下を参照してください。

  • 現在のスタイルを削除 :レイヤに複数のスタイルが定義されている場合は、不要なスタイルを削除します。

スタイルのドロップダウンリストの最下部で、レイヤに設定されているスタイルのうちアクティブなものにチェックが入っていることを確認できます。

レイヤのプロパティダイアログを確認するたびに、アクティブなスタイルは変更された内容で更新されることに注意してください。

あるレイヤに対するスタイルは、望むならば好きなだけ作成することができますが、一度にアクティブにできるのは1つだけです。 地図のテーマ と組み合わせることで、 マップ凡例のレイヤを複製することなく、複雑なプロジェクトを迅速かつ強力に管理することができます。

注釈

レイヤのプロパティに変更を適用すると、変更内容がアクティブなスタイルに保存されるため、 地図テーマ で使用しているスタイルを誤って変更しないよう、正しいスタイルを編集していることを常に確認するようにしましょう。

ちなみに

レイヤのコンテキストメニューからスタイル管理

レイヤ パネル内のレイヤを右クリックして、レイヤのスタイルをコピー、貼り付け、追加、スタイル名変更ができます。

11.6.2. スタイルをファイルやデータベースに保存する

スタイル コンボボックスから作成されたスタイルは、デフォルトではプロジェクト内に保存され、プロジェクト内のレイヤ間でスタイルをコピー・貼りつけできますが、スタイルをプロジェクト外に保存し、別のプロジェクトで読み込めるようにすることもできます。

11.6.2.1. テキストファイルに保存

selectString スタイル ► スタイルを保存 をクリックすることで、スタイルは以下の形式で保存できます:

  • QGIS QMLスタイルファイル( .qml

  • SLD スタイルファイル( .sld )、ベクタレイヤのみ可能

ファイルベース形式のレイヤ( .shp.tab... )を使っている場合、 デフォルトとして保存 はそのレイヤのための(ファイルと同名の) .qml ファイルを生成します。SLDファイルは任意のタイプのレンダラ -- 単一定義のシンボル、カテゴリ値による定義、連続値による定義、あるいは、ルールによる定義 -- からエクスポートすることができますが、SLDファイルをインポートする際は、単一定義もしくはルールによる定義のレンダラが生成されます。これは、カテゴリ値もしくは連続値による定義のスタイルは、ルールによる定義のスタイルへと変換されることを意味します。これらのレンダラを維持したい場合には、QML形式を使用する必要があります。一方で、このように簡単にスタイルをルールによる定義へと変換できる方法があると、非常に便利なこともあります。

11.6.2.2. データベースに保存

ベクタレイヤのデータソースがデータベースプロバイダの場合、スタイルはデータベース内に保存することもできます。サポートされるフォーマットはPostGIS、GeoPackage、SpatiaLite、MSSQLそしてOracleです。レイヤのスタイルは、データベースの( layer_styles という名前の)テーブル内に保存されます。 スタイルを保存... ► データベース をクリックし、スタイル名を定義し、説明を追加し、利用可能ならば .ui ファイルを指定し、このスタイルをレイヤの既定スタイルとして利用するかどうかについてチェックを入れ、ダイアログを埋めます。

You can save several styles for a single table in the database. However, each table can have only one default style. Default styles can be saved in the layer database or in qgis.db, a local SQLite database in the active user profile directory.

../../../_images/save_style_database.png

図 11.23 データベースにスタイルを保存ダイアログ

ちなみに

データベース間でスタイルファイルを共有する

レイヤが上記に挙げたデータベースから来ている場合にのみ、スタイルをデータベースに保存することができます。データベースを混在させることはできません(例えばOracleのレイヤとMSSQLのスタイル)。データベース間でスタイルを共有したい場合は、代わりにプレーンテキストファイルを使用してください。

注釈

PostgreSQLデータベースのバックアップから layer_styles テーブルを復元する際に問題が起こることがあります。この問題を修正するには、 QGIS layer_style テーブルとデータベースのバックアップ に従ってください。

11.6.2.3. スタイルの読み込み

QGISにレイヤを読み込むとき、レイヤにデフォルトのスタイルが存在する場合には、QGISはそのスタイルでレイヤを読み込みます。また、 スタイル ► デフォルトとして保存 はそのファイルを探して読み込み、レイヤの現在のスタイルでそのファイルを置き換えます。

スタイル ► スタイルを読み込む で、任意の保存されたスタイルをレイヤに適用させることができます。テキスト形式のスタイル( .sld.qml )はフォーマットが何であれどのようなレイヤにも適用できますが、データベース内に保存されたスタイルを読み込むのは、レイヤが同じデータベースのものであるか、またはスタイルがQGISのローカルデータベースに保存されている場合にのみ可能です。

DBマネージャ ダイアログは、データベース内で見つかったレイヤに関連するスタイルや、データベース内に保存されているその他スタイルのリストを名前と説明付きで表示します。

ちなみに

プロジェクト内でのレイヤスタイルの素早い共有

ファイルやデータベーススタイルをインポートせずに、プロジェクト内でレイヤースタイルを共有することもできます: レイヤパネル でレイヤを右クリックし、 スタイル コンボボックスからレイヤのスタイルをコピーして、レイヤのグループや選択したレイヤに貼りつけます。このスタイルは、元のレイヤーと同じタイプ(ベクタ、ラスタ)で、ベクタレイヤの場合は同じジオメトリタイプ(ポイント、ライン、ポリゴン)を持つ全てのレイヤに適用されます。

11.6.3. レイヤ定義ファイル

レイヤ定義は、アクティブなレイヤのコンテキストメニューで エクスポート ► レイヤ定義ファイルとして保存... を使用することで、 レイヤ定義ファイル.qlr )として保存することができます。レイヤ定義ファイル( .qlr )には、 レイヤのデータソースとスタイルへの参照が含まれています。 .qlr ファイルはブラウザパネルに表示され、レイヤパネルにレイヤ(と保存されたスタイル)を追加するために使用できます。システムのファイルマネージャからマップキャンバスに .qlr ファイルをドラッグアンドドロップすることもできます。

11.7. 値を変数に格納する

QGISでは、変数を使用して便利な頻出する値(プロジェクトのタイトル、ユーザーの氏名など)を保存し、それらを式で使用できます。変数は、アプリケーションのグローバルレベル、プロジェクトレベル、レイヤレベル、レイアウトレベル、レイアウトアイテムのレベルで定義できます。 CSSカスケードルールと同様に、変数は上書きできます。たとえば、プロジェクトレベルの変数は、同じ名前で設定されたアプリケーショングローバルレベルの変数を上書きします。これらの変数を使用して、変数名の前に「@」文字を使用してテキスト文字列または他のカスタム式を作成できます。たとえば、次の内容のラベルを作成する印刷レイアウトの場合:

This map was made using QGIS [% @qgis_version %]. The project file for this
map is: [% @project_path %]

このようなラベルをレンダリングします:

This map was made using QGIS 3.4.4-Madeira. The project file for this map is:
/gis/qgis-user-conference-2019.qgs

プリセットの読み取り専用変数 の他にも、上記のどのレベルに対しても独自のカスタム変数を定義することができます。以下の場所で変数を管理できます。

編集可能な変数と区別するために、読み取り専用変数の名前と値はイタリック体で表示されます。一方、低いレベルのもので上書きされた高レベル変数には取り消し線が引かれています。

../../../_images/options_variables.png

図 11.24 プロジェクトレベルの変数エディタ

注釈

変数についての詳細や例を知りたい場合には、 Nyall Dawson 氏のブログ投稿 Exploring variables in QGIS 2.12, part 1part 2part 3 を参照してください。

11.8. 認証

QGISには認証資格情報を安全な方法で保存/取得する機能があります。ユーザは認証情報を認証設定に安全に保存することができます。この認証情報はポータブルデータベースに保存され、サーバまたはデータベース接続に適用され、プロジェクトまたは設定ファイル内のIDトークンによって安全に参照されます。詳細については 認証システム を参照してください。

マスターパスワードは、認証システムとそのポータブルデータベースを初期化する際に設定する必要があります。

11.9. 共通のウィジェット

QGISでは、作業頻度が多いオプションがいくつかあります。作業に便利なように、QGIS では以下に紹介する特別なウィジェットが用意されています。

11.9.1. カラーセレクタ

11.9.1.1. 色ダイアログ

色を選ぶために selectColor をクリックすると、 色の選択 ダイアログが現れます。このダイアログの機能は 設定 ► オプション... ► 一般情報ネイティブの色選択ダイアログを使用する パラメータのチェックボックスの状態に依存します。チェックが入っている場合は、色選択にはQGISが起動しているOSのネイティブの色選択ダイアログが使用されます。チェックが入っていない場合には、QGISのカスタムカラーセレクタが使われます。

このカスタムカラーセレクタダイアログは4つの異なるタブを持っており、 colorBox カラーランプcolorWheel カラーホイールcolorSwatches 色見本 または colorPicker カラーピッカ― によって色を選択することができます。前2者のタブでは可能な全ての色組み合わせを閲覧し、選択した色をアイテムに適用することができます。

../../../_images/color_selector_ramp.png

図 11.25 カラーランプタブ

colorSwatches 色見本 タブでは、カラーパレットのリストから色を選択することができます(詳細は 参照)。 最近使った色 パレット以外はフレームの下部にある signPlus 現在の色の追加signMinus 選択した色の削除 ボタンで編集することができます。

パレットのコンボボックスの隣にある ... ボタンは以下のオプションを提供します。

  • 色のコピー、貼り付け、インポートまたはエクスポート

  • カラーパレットの新規作成、インポートまたは削除

  • 色ボタンに表示 の項目で、カスタムパレットをカラーセレクタウィジェットに追加する( 図 11.27 参照)

../../../_images/color_selector_recent_colors.png

図 11.26 色見本タブ

別の選択肢として、 colorPicker カラーピッカー を使用してQGISのUIや他のアプリケーションの任意の部分に置いたマウスカーソルの下にある色をサンプルすることができます。タブがアクティブなときにスペースバーを押し、目的の色の上にマウスを移動させて、クリックするかスペースバーを再度押します。 色をサンプルする ボタンをクリックしても、カラーピッカーを起動することができます。

どの方法を使ったとしても、選択された色はカラースライダーの HSV (Hue, Saturation, Value)と RGB (Red, Green, Blue)の値で表現されます。また、色は HTML表記法 でも確認できます。

色の変更は、カラーホイールやカラーランプ、任意の色パラメータのスライダーをクリックすることで簡単に行えます。色パラメータは横のスピンボックスを使うか、対応するスライダー上でマウスホイールをスクロールすることで調整することができます。また、HTML表記法で色を入力することもできます。最後に、透明度を設定するための 不透明度 スライダーがあります。

このダイアログには(オブジェクトに適用されている) 前の色 と(選択した) 現在の色 を視覚的に比較する機能もあります。ドラッグドロップするか、 atlasNext 見本に色を追加 ボタンを押すと、これらの色をスロットに保存し、簡単にアクセスできます。

ちなみに

クイックカラー変更

あるカラーセレクタウィジェットを別のカラーセレクタウィジェットへドラッグドロップすると、その色を適用することができます。

11.9.1.2. 色選択のドロップダウンショートカット

selectColor 色ボタンの右にあるドロップダウンの矢印をクリックすると、色を素早く選択するためのウィジェットが表示されます。このショートカットには、以下の機能があります:

  • 色を選ぶためのカラーホイール

  • 色の不透明度を変更するためのアルファ値スライダー

  • 色ボタンに表示 で設定されたカラーパレット

  • 現在の色のコピーと、別のウィジェットへの貼り付け

  • コンピュータ画面上の任意の場所から色を取得

  • カラーセレクタダイアログから色を選択する

  • 色をあるウィジェットから別のウィジェットにドラッグドロップして、素早く色を変更する

注釈

カラーウィジェットがデータによって定義された上書きプロパティによって プロジェクトの色 に設定されている場合、上記の色を変更するための機能は利用できません。まず初めに 色のリンクの解除 をするか、定義を クリア する必要があります。

../../../_images/quick_color_selector.png

図 11.27 クイックカラーセレクタメニュー

11.9.1.3. カラーランプのドロップダウンショートカット

カラーランプは、1つまたは複数の地物に色の組み合わせを適用するための実用的な方法です。その作成方法については、 カラーランプの設定 のセクションで説明しています。色については、 selectColorRamp カラーランプボタンを押すと、対応したカラーランプタイプのダイアログが開き、そのプロパティを変更することができます。

../../../_images/color_ramp_brewer.png

図 11.28 ColorBrewerランプをカスタマイズする

ボタンの右側にあるドロップダウンメニューを使用すると、カラーランプとオプションの幅広いセットに素早くアクセスできます:

  • カラーランプを反転

  • スタイルマネージャ ダイアログにおいて お気に入り に設定されている グラデーション あるいは カタログ: cpt-city のカラーランプのプレビュー

  • 全てのカラーランプ で、互換性のあるカラーランプデータベースへアクセスする

  • カラーランプを新規作成... で、現在のウィジェットで使用可能な、任意のサポートされている形式のカラーランプを作成する(このカラーランプは、ライブラリに保存しない限りは他の場所で使用できないことに注意してください)

  • カラーランプを編集... は、カラーランプボタンをクリックした時と同じです。

  • カラーランプを保存... は、現在のカラーランプをカスタマイズが適用された状態でスタイルライブラリに保存します

../../../_images/quick_colorramp_selector.png

図 11.29 クイックカラーランプ選択ウィジェット

11.9.2. シンボルウィジェット

シンボル セレクタウィジェットは、地物のシンボルプロパティを設定したい場合に便利なショートカットです。ドロップダウン矢印をクリックすると、以下のシンボルオプションが 色ドロップダウンウィジェット の機能とともに表示されます。

  • シンボルの編集... : これはシンボルセレクタウィジェットを起動するのと同じです。 シンボルのパラメータ を設定するためのダイアログを開きます。

  • シンボルをコピー は、現在のアイテムのシンボルをコピーします

  • シンボルを貼り付ける は、現在のアイテムにシンボルを貼り付けます。迅速にシンボル設定ができます

11.9.3. フォントセレクタ

フォント セレクタウィジェットはテキスト情報(地物のラベル、地図整飾のタイトルラベル、地図の凡例テキスト等...)に対してフォントプロパティを設定したい場合に便利なショートカットです。ドロップダウン矢印をクリックすると、以下のオプションの一部または全てが表示されます。

../../../_images/fontselector_widget.png

図 11.30 フォントセレクタのドロップダウンメニュー

  • フォントサイズ を関連する単位で設定します

  • 最近使ったフォント ► メニューは、最近使ったフォントと共に、アクティブなフォントが(最上部に)チェックされた状態で表示されます

  • フォーマットを設定... はフォントセレクタウィジェットのボタンを押した場合と同様です。テキストフォーマットのパラメータを設定するダイアログが開きます。テキスト設定の状況にもよりますが、このダイアログはOSのデフォルトの テキストフォーマット ダイアログもしくは、 ラベルテキストの書式設定 のセクションで説明する、高度なフォーマットのオプション(不透明度、テキストの向き、バッファ、背景、影など...)を備えたQGISのカスタムダイアログです。

  • コピー形式 :テキストのフォーマットをコピーします

  • 貼り付けフォーマット :コピーしたフォーマットをテキストに貼りつけ、フォーマットを素早く設定できます

  • 色ウィジェット :簡単に色設定ができます

11.9.4. 単位セレクタ

QGIS のアイテム(ラベル、シンボル、レイアウト要素 ...)のサイズプロパティは、必ずしもプロジェクト単位または特定のレイヤの単位に拘束されるわけではありません。多くのプロパティでは、 単位 セレクタのドロップダウンメニューを使用して、必要なレンダリングに応じて(画面解像度、用紙サイズ、または地形を基準として)プロパティの値を調整することができます。利用可能な単位は以下のとおりです:

  • ミリメートル(Millimeters)

  • ポイント(Points)

  • ピクセル(Pixels)

  • インチ(Inches)

  • 縮尺済みメートル(Meters at Scale) : これにより、基礎となる地図単位(例:インチ、フィート、度 ...)に関係なく、常にサイズをメートル単位で設定できます。メートル単位のサイズは、現在のプロジェクト楕円体の設定と、現在のマップ範囲の中心位置でのメートル単位の距離の投影に基づいて計算されます。

  • 地図単位 : サイズはマップビューのスケールに応じて拡大縮小されます。これは大きすぎる、あるいは小さすぎる値となることがあるため、エントリの隣にある options ボタンを使用して、サイズを以下に基づいた値の範囲に制限します:

    • 最小縮尺最大縮尺 :これらの縮尺限界値に到達するまでは、値はマップビューの縮尺に基づいてスケーリングされます。縮尺の範囲外の場合は、値は最も近い縮尺限界値に基づく値のままです。

    • かつ/または 最小サイズ最大サイズmm 単位で指定したもの :値はこれらのサイズ限界値に到達するまで、マップビューの縮尺に基づいてスケーリングされます。限界値に到達した場合は、このサイズ限界値で一定となります。

    ../../../_images/adjust_scaling.png

    図 11.31 縮尺範囲の調整ダイアログ

11.9.5. 数値フォーマット

数値フォーマットでは、様々な整形方法(例えば指数表記、通貨、パーセント等)を使用して数値の表示を整形できます。この使用例には、レイアウトのスケールバーや固定サイズのテーブルのテキストなどがあります。

様々なカテゴリフォーマットをサポートしています。多くの場合、下記の数値オプションの一部もしくはすべてを設定できます:

  • checkbox 数字の3桁区切り記号を表示

  • unchecked 正の符号を表示

  • unchecked ゼロ埋め表示

ただし、カスタム設定もあります。提供されているカテゴリは以下のとおりです。

  • 一般情報 、デフォルトのカテゴリ:設定がなく、親ウィジェットの設定もしくはグローバル設定と同様に値を表示します。

  • 数値

    • 値はユーザーが定義した 小数点以下桁数 もしくは 有効数字`で :guilabel:`数値を丸める ことができます

    • 数字の3桁区切り記号小数点記号 をカスタマイズできます

  • 方向/方位のテキスト表現を設定する 方位 には、以下の設定があります。

    • 形式 :利用可能な値の範囲は 0 から 180°, (E/W付き)-180 から +180°0 から 360° です

    • 小数点以下桁数 の数字

  • 通貨 は、通貨の値のテキスト表現のための設定です。

    • 接頭辞

    • 単位文字

    • 小数点以下桁数 の数字

  • 分数 は、小数値の分数表現のための設定です(例: 0.5 の代わりに 1/2

    • 表示に unchecked Unicode分数表現を使用 する。 例えば、1/2 の代わりに 1/2 を使用します

    • unchecked 専用Unicode文字を使用

    • 数字の3桁区切り記号 をカスタマイズする

  • パーセント - 値に % を付け足します。以下の設定があります

    • 小数点以下桁数 の数字

    • 縮尺 :実際の値がすでにパーセント表現となっている(そのままの値)か、小数値(パーセントに変換する)かを指示します

  • 指数表記 は、 2.56e+03 の形式での表記です。 小数点以下桁数 の数字を指定できます。

サンプル セクションの下には、設定のライブプレビューが表示されます。

11.9.6. 混合モード

QGISは混合モードツールを通じて、これまでは画像編集プログラムでしか知られていないような、特別なレンダリング効果のためのさまざまなオプションを提供しています。混合モードは、レイヤや地物に適用したり、印刷レイアウトアイテムにも適用することができます:

  • 通常:これは標準の混合モードで、上にあるピクセルのアルファチャンネルを使用して、その下のピクセルと混合します。色は混合されません。

  • 明るく:これは、前景と背景のピクセルから各成分の最大値を選択します。結果はギザギザで粗くなる傾向があることに注意してください。

  • 網掛け:アイテムの明るいピクセルは下のレイヤ上に塗られますが、暗いピクセルは塗られません。このモードは、あるアイテムのテクスチャを別のアイテムに混ぜるのに便利です(例えば、陰影図を使って他のレイヤのテクスチャを作成するなど)。

  • 覆い焼き:上にあるピクセルの明るさに基づき下のピクセルを明るくし、彩度を上げます。上にあるピクセルが明るいほど、下のピクセルの彩度と明るさが上がります。これは、上にあるピクセルが明るすぎない場合に最適です。そうでない場合は効果が極端になります。

  • 加算:あるアイテムのピクセル値を他方のピクセル値に加えます。値が上限値よりも大きくなる場合、(RGBモードの場合は)白色で表示されます。このモードは地物をハイライトするのに適しています。

  • 暗く:上と下のピクセルの各成分で最小値を保持します。「明るく」と同様に、結果はギザギザで粗くなる傾向があります。

  • 乗算:上のアイテムのピクセル値を下のアイテムのピクセル値と掛け合わせます。結果は暗くなります。

  • 焼きこみ:上にあるアイテムの色が濃いと、下にあるアイテムの色が濃くなります。「焼きこみ」は下にあるレイヤの色を調整したり、色付けしたりするのに使えます。

  • オーバーレイ:「乗算」と「網掛け」混合モードの組み合わせです。明るい部分はより明るく、暗い部分はより暗くなります。

  • ソフトライト:「オーバーレイ」とよく似ていますが、「乗算」/「網掛け」の代わりに「焼きこみ」/「覆い焼き」を使います。これは、画像に柔らかい光が当たっているのを模擬したものです。

  • ハードライト:「ハードライト」も「オーバーレイ」モードと非常によく似ています。画像に非常に強い光が当たっているのを模擬したものです。

  • 差分: 結果が常に正の値となるように、下のピクセル値から上のピクセル値を引く、もしくはその逆を行います。黒色との混合は、全ての色に対する違いがゼロのため、何の変化もありません。

  • 減算:あるアイテムのピクセル値から他のアイテムのピクセル値を引きます。負の値となる場合には、黒く表示されます。

11.9.7. データによって定義された上書きの設定

ベクタレイヤのプロパティダイアログの多くのオプションや印刷レイアウトの設定の横には、 dataDefined データによって定義された上書き アイコンがあります。このツールでは、レイヤ属性やアイテム設定に基づいた 、予め用意された関数やカスタム関数、 変数 を使用して、パラメータに動的な値を設定することができます。これを有効にすると、通常の値(チェックボックス、テキストボックス、スライダー...)に関係なく、このウィジェットによって返される値がパラメータに適用されます。

11.9.7.1. データによって定義された上書きウィジェット

dataDefined データによって定義された上書き アイコンをクリックすると、以下のエントリが表示されます:

  • 説明... は、オプションが有効化されているか、予想される入力値、有効な入力型、そして現在の定義を表示します。ウィジェットの上にマウスカーソルを乗せることでも、この情報を表示します。

  • データをプロジェクトに格納する補助テーブルプロパティ 機能を使用してプロパティをプロジェクトに保存することを許可するためのボタンです。

  • フィールドの型: レイヤのフィールドのうち、有効な入力型に一致するフィールドから選択するためのエントリです。

  • : ウィジェットが色プロパティと関連しているときには、このメニューから現在の プロジェクトの色 スキームとして定義されている色にアクセスできます。

  • 変数 :利用可能なユーザー定義の 変数 へアクセスするためのメニューです。

  • 編集... ボタンは、 式文字列ビルダ ダイアログを使用して、適用する式を作成もしくは編集するためのボタンです。正しく式を入力するのを助けるために、期待される出力フォーマットのヒントがダイアログ内に表示されています。

  • 貼り付けコピー ボタン

  • クリア ボタンで設定を削除します。

  • 数値と色のプロパティには、地物データがプロパティにどのように適用されるのかを再スケーリングするための アシスタント... があります(詳細については 下記 を参照ください)。

ちなみに

データによる上書きを右クリックで有効化(無効化)

データによって定義された上書きのオプションが正しく設定されている場合には、アイコンは黄色で dataDefineOndataDefineExpressionOn になります。もし上書きオプションが壊れている場合には、アイコンは赤色で dataDefineErrordataDefineExpressionError になります。

ウィジェットをマウスの右ボタンでクリックすることで、設定された dataDefined データによって定義された上書き ボタンを簡単に有効化・無効化できます。

11.9.7.2. データによる定義のアシスタントインターフェースを使用する

dataDefined データによって定義された上書き ボタンが数値もしくは色パラメータと関連付けられている場合、 アシスタント... オプションがあり、各地物に対してデータがパラメータに適用される方法を変更することができます。このアシスタントはには以下の機能があります:

  • 入力 データを定義します。すなわち:

    • フィールドのリストボックスまたは expression カラム式の設定 機能( 参照)を使用して、表す属性値を定義します。

    • 表す値の範囲: 値を手入力することもできますし、 refresh レイヤから値の範囲を取得する ボタンを使用して、選択した属性やデータに適用された式によって返される最小値と最大値からこれらのフィールドを自動的に入力することもできます。

  • unchecked 変換曲線を適用する :デフォルトでは、出力値(設定は下記を参照)は線形スケールに従って入力地物に適用されます。 これを変換曲線ロジックを利用して上書きすることができます:変換オプションを有効にして、グラフにブレークポイントを追加しポイントをドラッグして適用すべきカスタム分布を作成します。

  • 出力 値を定義します:このオプションは定義するパラメータによって異なります。共通して設定できるのは以下の項目です:

    • 選択したプロパティに適用する最小値と最大値(色設定の場合には、 カラーランプ を指定する必要があります)

    • 表現の スケール方法 は、 フラナリーサーフェスグリッド(Surface)半径 または 指数関数的 のどれかです。

    • データのスケーリングに使用する 指数 の設定

    • NULL値の場合の出力値あるいは地物を表す

プロパティに適合している場合には、ダイアログの右側にライブ更新プレビューが表示され、値のスケーリングを制御するのに役立ちます。

../../../_images/varying_size_assistant.png

図 11.32 データ定義によるサイズ設定のアシスタント

上図の可変サイズアシスタントで提示された値は、「データによって定義された上書き」のサイズを以下のように設定します:

coalesce(scale_exp(Importance, 1, 20, 2, 10, 0.57), 1)