Outdated version of the documentation. Find the latest one here.

一般ツール

地物情報表示

地物特定をするとマップキャンバスと対話的に操作してポップアップウィンドウで属性データを表示できます. 地物を特定する場合 View ‣ Identify features を選択するか Ctrl+Shift+I をキーボードで押すかツールバーの, mActionIdentify Identify features アイコンをクリックして下さい.

もしあなたが複数の地物をクリックした場合I, このポップアップは全地物の属性をリストします. 最初のアイテムは結果のアイテムの数でレイヤ名が続きます. 最初の子アイテムはフィールド名と値です. 最後に地物の全情報が表示されます.

このウィンドウはカスタムフィールドを表示するためにカスタマイズできますがデフォルトで3種類の情報を表示します:

  • アクション: 地物情報表示ウィンドウにアクションの追加ができます. アクションラベルをクリックするとアクションを実行できます デフォルトで編集用フォーム表示アクションのみが登録されています.

  • Derived: those informations are calculated or derived from other information. You can find clicked coordinate, X and Y coordinates, area in map unit and perimeter in map unit for polygon, length in map unit for line and feature id.
  • データ属性:これは、データの属性フィールドのリストです。

Figure Identify 1:

../../../_images/identify_features.png

地物情報表示ダイアログ nix (Gnome)

ウィンドウの下部には5個のアイコンがあります:

  • mActionIdentifyExpand ツリーを展開する

  • mActionIdentifyCollapse ツリーを折りたたむ

  • mActionIdentifyDefaultExpand デフォルトの動作

  • mActionIdentifyCopyAttributes 属性をコピーする

  • mActionIdentifyPrint 選択したHTMLのレスポンスを表示する

レスポンスツリーの任意の場所でマウス右ボタンをクリックすると表示されるメニューにはさらに多くの機能があります.

このメニューでは次のことができます:

  • 地物フォームの表示

  • 地物のズーム

  • 地物のコピー: すべての地物,たとえばジオメトリと属性をコピーします;

  • 属性値のコピー: あなたがクリックした属性値のみをコピーします。

  • 地物の属性をコピーする:属性のみをコピーする;

  • 結果のクリア:ウィンドウ内の結果が削除されます

  • ハイライトのクリア:地図上で地物がハイライトしているのが除去されます

  • すべてをハイライトする

  • レイヤをハイライトする

  • レイヤプロパティ: レイヤプロパティウィンドウを表示する

  • すべてを展開する

  • すべてを折りたたむ

キーボードショートカット

QGIS は多くの機能のデフォルトキーボードショートカットを提供しています.セクション メニューバー にそれらは記述されています.さらにメニューオプション Settings ‣ Configure Shortcuts を使うとデフォルトキーボードショートカットを変更して新しいキーボードショートカットを QGIS の機能に加えることができます.

Figure Shortcuts 1:

../../../_images/shortcuts.png

ショートカットオプションの定義|nix| (Gnome)

構成はとても簡単です。リストから機能を選択し [変更], [無し] を設定 または **[デフォルトを設定]**をクリックして下さい. あなた自身の構成を作成したら,その設定をXMLファイルで保存して他の QGIS インストレーションでロードして利用することができます.

コンテキストヘルプ

特定のトピックでヘルプが必要な場合多くのダイアログに実装されている Help ボタンでコンテキストヘルプを利用することができます- サードパーティプラグインでは専用のウェッブページを指し示すことを注意して下さい.

レンダリング

デフォルトで QGIS レンダラはマップキャンパスに含まれる全ての可視レイヤ表示を更新しますイベントはマップキャンバスに含まれるもののリフレッシュを引き起こします:

  • レイヤの追加

  • パンまたはズーム

  • QGISウィンドウのリサイズします

  • レイヤまたはレイヤ群の表示、非表示を変更します

QGIS ではいくつもの方法で描画プロセスを管理できます.

スケール依存レンダリング

スケール依存レンダリングを利用するとあるレイヤが表示される最小と最大のスケールを指定することができます. スケール依存レンダリングを設定する場合レイヤを凡例でダブルクリックして プロパティ ダイアログを開いて下さい. 一般情報 タブで, checkbox縮尺に応じた表示設定 チェックボックスをアクティブにして最小と最大の縮尺値を設定して下さい. .

QGIS ステータスバーでスケール値を見ることで,そのレイヤを表示するのと表示しないスケール値を決めることができます.

地図レンダリングの制御

地図レンダリングは以下の方法で制御することができます:

描画の中断

描画を中止したい場合はステータスバーの右側角にある checkbox Render`チェックボックスをクリックしてください. |checkbox| :guilabel:`Render`がチェックされていない場合, |qg| はセクション :ref:`redraw_events に記述されているあらゆるイベントに反応せずキャンバスに再描画を行いません.地図描画を行わないほうがいい場合は以下のような場合があります:

  • 沢山のレイヤを追加して描画する前に描画方法を編集したい場合

  • データ量が多いレイヤを追加して描画する前に縮尺依存描画条件を指定したい場合

  • データ量が多いレイヤを追加して描画する前に特定の位置にズームしておきたい場合

  • 上記の場合のいくつかの組み合わせ

Checking the checkbox Render checkbox enables rendering and causes an immediate refresh of the map canvas.

レイヤ追加オプションの設定

新しくレイヤを追加した時に,すぐに描画しないオプションを設定できます.これはレイヤが地図に追加された時に,地図凡例の可視属性チェックボックスがデフォルトでチェックされないことを意味します.このオプションを指定するためには 設定 ‣ オプション ‣ を選択して:guilabel:レンダリング タブをクリックしてください. checkbox By default new layers added to the map should be displayed のチェックを解除してください.すると,地図に追加されたレイヤの表示属性はオフ (不可視) の状態がデフォルトになります.

Another option in Settings ‣ Options ‣ Rendering menu is the checkbox Enable back buffer checkbox. It provides better graphics performance at the cost of loosing the possibility to cancel rendering and incremental feature drawing. If it is unchecked, you can set the ‘Number of features to draw before updating the display’, otherwise it is inactive.

最終的に checkbox 再描画の速度を上げられる場合にレンダのキャッシュを利用します チェックボックスをアクティブにできます.

描画の中断

地図描画を中断したい場合は ESC キーを押して下さい.これにより地図キャンパスの更新が中断され地図の一部が描画された状態になります. ESC キーを押してから地図描画が中断されるまで少し時間がかかります.

ノート

現在描画中断機能は利用できません - これはqt4のポートに依存しています,なぜならばユーザーインターフェース(UI)に問題が発生してクラッシュするからです.

描画中に地図表示を更新する

地図に地物が描画更新されるオプションの設定を行うことができます. デフォルトで, QGIS はレイヤの描画が終了するまで地物を表示しません. 地物がデータストアから読まれるときに表示を更新したい場合, メニューオプションの Settings ‣ Options を選択して Rendering メニューをクリックして下さい. 描画更新を行う適切な地物の数を設定して下さい. 設定値が 0 の場合描画時の更新を行いません (これがデフォルトです). 設定値が小さい場合地物読み込み時に地図キャンバスの継続的な更新が行われパフォーマンスが低下します. 推奨値は500以上です.

描画品質への影響

描画品質に影響がある2個のオプションがあります. メニュー 設定 ‣ オプション を選択して レンダリング メニューをクリックして以下のチェックボックスを選択、または非選択して下さい.

  • checkbox 線のジャギーを目立たなくします(描画パフォーマンスが低下します)

  • checkbox ポリゴンの不正な塗りつぶしを修正します

計測

計測は投影座標系(e.g., UTM)と投影されていないデータ内で機能します。ロードされたマップは地理座標系(緯度/経度)で定義され、ラインや面積の計測結果は正確ではないでしょう。必要に応じ、適切なマップの座標系(ref:`label_projections`のセクションを参照)を設定することで解決します。すべての計測モジュールはデジタイジングモジュール由来のスナップ設定が使用されています。ベクターレイヤのラインやエリアにそって計測をしたい場合、これは便利です。

計測ツールを選択するためには mActionMeasure をクリックして使いたいツールを選択してください.

距離,面積と角度の計測

mActionMeasure Measure Line: QGIS では与えられた点の間の実距離を定義された楕円体にしたがって測ることができます. この機能を構成するためにはTo configure this, choose menu optiメニューオプション Settings ‣ Options を選択して, click on the Map tools タブをクリックして最適な楕円体を選択して下さい. そこではラバーバンドの色と最適な計測単位 (メーターまたはフィート) と角度の単位 (度, ラディアン と gon)も指定できます. このツールを使うと地図上にポイントをクリックできます. それぞれのセグメントの長さと合計値が計測ウィンドウに表示されます. 計測を終了したい場合はマウス右ボタンをクリックして下さい.

Figure Measure 1:

../../../_images/measure_line.png

距離の計測 nix (Gnome)

mActionMeasureArea Measure Area: Areas can also be measured. In the measure window the accumulated area size appears. In addition, the measuring tool will snap to the currently selected layer, provided that layer has its snapping tolerance set. (See Section スナップ許容量と検索半径の設定). So if you want to measure exactly along a line feature, or around a polygon feature, first set its snapping tolerance, then select the layer. Now, when using the measuring tools, each mouse click (within the tolerance setting) will snap to that layer.

Figure Measure 2:

../../../_images/measure_area.png

面積の計測 nix (Gnome)

mActionMeasureAngle Measure Angle: You can also measure angles. The cursor becomes cross-shaped. Click to draw the first segment of the angle you wish to measure, then move the the cursor to draw the desired angle. The measure is displayed in a popup dialog.

Figure Measure 3:

../../../_images/measure_angle.png

角度の計測 nix (Gnome)

地物の選択と選択解除

QGIS ツールバーはマップキャンバスで地物を選択するためにいくつかのツールを提供しています.1つまたはいくつかの地物をクリックのみで選択する場合は |mActionSelect|をクリックし,あなたのツールを選択します.

  • mActionSelect 1個の地物を選択する

  • mActionSelectRectangle 矩形による地物選択

  • mActionSelectPolygon 多角形による地物選択

  • mActionSelectFreehand フリーハンドによる地物選択

  • mActionSelectRadius 半径による地物選択

選択されている地物をすべて解放したい場合は mActionDeselectAll すべてのレイヤから地物選択を取り消す をクリックして下さい.

整飾

QGISの装飾には著作権ラベル、北向き矢印とスケールバーが含まれています。これらは地図製作の要素として投下することで、マップを’装飾’するために用いられます。

グリッド

transformed グリッド では座標のグリッドと座標注記をマップキャンバスに追加します。

Figure Decorations 1:

../../../_images/grid_dialog.png

グリッドダイアログ nix

  1. Select from menu View ‣ Decorations ‣ Grid. The dialog starts (see figure_decorations_1).
  2. マップキャンバスにロードされているレイヤにしたがって checkbox Enable grid チェックボックスを有効にしてグリッドの設定を行って下さい.

  3. マップキャンバスにロードされているレイヤにしたがって checkbox Draw annotations チェックボックスを有効にしてアノテーションの定義を行ってください.

  4. Click [Apply] to check, if it looks as expected.
  5. [OK] をクリックしてダイアログを閉じます.

北向き矢印

north_arrow 北向き矢印 を使うとシンプルな北向き矢印をマップキャンバスに置くことができます. 現在1種類のスタイルのみが利用できます. 矢印の角度は調整可能ですし,また QGIS が自動的に方向を設定することもできます. もし QGIS が方位を決める方法を選択すると最良の矢印の方向を指し示します. 矢印を置く場所は4つのオプションがあります, マップキャンバスの4つの隅です.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

北向き矢印ダイアログ nix

スケールバー

scale_bar スケールバー はシンプルなスケールバーをマップキャンバスに追加します. スタイルと位置,バーの上のラベルを設定できます.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

スケールバーダイアログ nix

QGISは、あなたのマップフレームと同じ単位スケールを表示することをサポートしています。もしレイヤの単位がメートルであるなら、フィート単位のスケールバーを作成することはできません。同様に、小数単位を使用している場合はメートル単位で距離を表示するスケールバーを作成することはできません。

スケールバーを追加するために:

  1. メニューの`ビュー –> 地図整飾 –> 著作権ラベル`を選択します。ダイアログが表示されます( figure_decorations_4 を参照すること)。

  2. guilabel:Placement のドロップダウンリストの’Bottom Right’からラベルの配置を選択します。

  3. guilabel:`Scale bar style`の’Tick Down’リストからスタイルを選択します。

  4. guilabel:`Color of bar`の ‘black’でバーの色を選択するか、デフォルト色の黒色を使用します。

  5. バーのサイズとそのラベル(guilabel:`Size of bar`の ‘30 degrees’)を設定します。

  6. Make sure the checkbox Enable scale bar checkbox is checked
  7. checkbox :guilabel:`Automatically snap to round number on resize`オプションで、キャンバスサイズが変更された時に、切りの良い数字にスナップされるように選択することができます。

  8. [OK] をクリックします。

ちなみに

整飾の設定

.qgs プロジェクトを保存する際、グリッド、方位記号、スケールバーと著作権ラベルに加えた変更はそのプロジェクトに保存され、次回プロジェクトをロードした際に復元されます。

アノテーションツール

属性ツールバーの mActionTextAnnotation Text Annotation ツールを使うと QGIS マップキャンバスに書式整形されたテキストを表示したバルーンを表示できます. Text Annotation ツールを使ってマップキャンバスをクリックして下さい.

Figure annotation 1:

../../../_images/annotation.png

アノテーションテキストダイアログ nix

Double click on the item opens a dialog with various options. There is the text editor to enter the formatted text and other item settings. E.g. there is the choice of having the item placed on a map position (displayed by a marker symbol) or to have the item on a screen position (not related to the map). The item can be moved by map position (drag the map marker) or by moving only the balloon. The icons are part of GIS theme, and are used by default in the other themes too.

The mActionAnnotation Move Annotation tool allows to move the annotation on the map canvas.

HTML注記

属性ツールバーの mActionFormAnnotation Html Annotation ツールを使うと QGIS マップキャンバスにhtml ファイルを内容としたバルーンを表示することができます. Html Annotation ツールを使ってマップキャンバスをクリックして下さい, そしてhtmlファイルのパスを追加して下さい.

SVG注記

属性ツールバーにある mActionSaveAsSVG SVG Annotation ツールを使うと QGIS マップキャンバスにSVGシンボルを描画したバルーンを表示することができます. SVG Annotation ツールを使いマップキャンバスをクリックした後にダイアログでSVGファイルのパスを追加して下さい.

注記の書式設定

Additionally you can also create your own annotation forms. The mActionFormAnnotation Form Annotation tool is useful to display attributes of a vector layer in a customized qt designer form (see figure_custom_annotation). It is similar to the designer forms for the Identify features tool, but displayed in an annotation item. Also see QGIS blog http://blog.qgis.org/node/143 for more information.

Figure annotation 2:

../../../_images/custom_annotation.png

カスタマイズされたqtデザイナアノテーションフォーム nix

ノート

If you press Ctrl+T while an Annotation tool is active (move annotation, text annotation, form annotation), the visibility states of the items are inverted.

空間ブックマーク

空間ブックマークを使用すると地理的な場所を”ブックマーク”し、あとでその位置に戻ることができます。

ブックマークの作成

ブックマークを作るには:

  1. 関心のある領域にズームまたはパンします。

  2. メニューオプション View ‣ New Bookmark を選択するか Ctrl-B を押して下さい.

  3. ブックマークを説明する名称(255文字まで)を入力します。

  4. ブックマークを追加するためには Enter を入力するかブックマークを削除するためには [Delete] を押して下さい.

同じ名称で複数のブックマークを所有できることにご注意ください。

ブックマークの操作

ブックマークを利用または管理する場合メニューオプション View ‣ Show Bookmarks を選択して下さい. Geospatial Bookmarks ダイアログを使うとブックマークへのズームと削除ができます. ブックマーク名や座標は編集できません.

ブックマークへのズーム

From the Geospatial Bookmarks dialog, select the desired bookmark by clicking on it, then click [Zoom To]. You can also zoom to a bookmark by double-clicking on it.

ブックマークの削除

ブックマークを削除するには`地理空間ブックマーク`ダイアログにてそれを選択し、[削除]**をクリックします。選択を確定するには **[はい] をクリックし、削除をキャンセルするには [いいえ] をクリックします。

プロジェクトの入れ子

あなたのプロジェクトに他のプロジェクトファイルからコンテンツを埋め込む場合、:menuselection:`Layer –> 埋め込みレイヤとグループ`を選択します。

埋め込みレイヤ

次のダイアログで、他のプロジェクトのレイヤを埋め込むことができます。

  1. Press browsebutton to look for another project from the Alaska dataset.
  2. プロジェクトファイルのgrasslandを選択します。あなたはプロジェクトの中身を表示することができます。(see figure_embed_dialog_を参照してください)

  3. Press Ctrl and klick on the layers grassland and regions. The layers are embedded in the map legend and the map view now.

Figure Nesting 1:

../../../_images/embed_dialog.png

埋め込むためのレイヤとグループを選択する|nix|

埋め込まれている間が編集できる間は、スタイルやラベリングのようなプロパティは変更することができません。

埋め込みレイヤの除去

組み込みレイヤを右ボタンクリックして mActionRemoveLayer Remove を選択して下さい.

デリミテッドテキストレイヤの追加

この機能を使うと、QGISでデリミティッドテキストファイルを読み込むことができます。次の設定が必要です:

  1. File format 通常は radiobuttonon CSV (カンマで区切られた値) です. もし他の区切り文字が利用されている場合 radiobuttonon custom delimiter ラジオボタンをアクティブにしてください,またそれぞれの行が正規表現で分割されている場合は radiobuttonon Regular expression delimiter ラジオボタンをアクティブにしてください.

  2. As Record options a text file usually provides a delimited header row of field names. This is usually the first line in the text file. If there is no header row available, deactivate the checkbox first records have field names checkbox. And if the header row isn’t the first line of the text file, define the number of header lines to discard.
  3. As Field options you can trim leading and trailing spaces from fields activating the checkbox Trim fields checkbox. You can checkbox Discard empty fields in each record and you can define that the checkbox Decimal separator is comma. Otherwise it will be point.
  4. As Geometry definitions a typical text file provides radiobuttonon Point coordinates. This means there must be an ‘X’ and ‘Y’ field with coordinate values. If the text file provides a radiobuttonon Well Known Text field, there must be a ‘WKT’ field with geometry information for point, line or polygon objects. These fields can have any name. Otherwise for attribute tables define radiobuttonon no geometry. The x and y coordinates must be specified as a number. The coordinate system is not important. If they are defined in degree/minutes/seconds, activate the checkbox DMS coordinates checkbox.
  5. As Layer settings you can activate checkbox Use spatial index to improve performance of displaying and spatially selecting features. You can define to checkbox Use Subset index and to checkbox Watch file to watch for changes to the file by other applications, while QGIS is running.

:file:`elevp.csv`は標高ポイントデータをインポートする正しい型式のデリミテッドテキストファイルの例です。elevp.csv はQGISサンプルデータセットに付属しています。 (:ref:`label_sampledata`のセクションを参照):

X;Y;ELEV
-300120;7689960;13
-654360;7562040;52
1640;7512840;3
[...]

このサンプルテキストファイルについての解説:

  1. 例のテキストファイルでは``;`` (セミコロン) をでリミッターとして使っています。どんな文字でもフィールドのでリミッターとして使うことができます。

  2. 最初の行はヘッダーです。それには X, Y および``ELEV``のフィールドが含まれています。

  3. 引用符(")はテキストフィールドを区切るために使用されます。

  4. X座標は``X`` フィールドに含まれています。

  5. y座標は``Y``フィールドに含まれています。

機能の利用

Manage layers ツールバーにあるアイコン delimited_text デリミテッドテキストレイヤの追加 をクリックすると  Create a Layer from a Delimited Text File ダイアログを figure_delimited_text_1 のように開きます.

Figure Delimited Text 1:

../../../_images/delimited_text_dialog.png

デリミティッドテキストダイアログ nix

最初に [Browse] ボタンをクリックしてインポートするファイル (例., qgis_sample_data/csv/elevp.csv ) を選択して下さい. ファイルが選択されると QGIS は最後に利用されたデリミタを使ってファイルを解析しようとします, この場合セミコロン (;)が使われています. 適切にファイルを解析するためには,正しいデリミタを選択することが重要です. デリミタをタブに変更する場合は \t を使って下さい(これはタブの文字の正規表現です).

ファイルの解析が行われると Geometry definition radiobuttononPoint coordinates が作成され XY フィールドをドロップダウンリストから選択する必要があります. 最後にレイヤ名 (例., elevp)を figure_delimited_text_1 のように入力して下さい. レイヤを地図に追加する場合 [OK].をクリックして下さい ディミッテッドテキストファイルはこの時点で QGIS の他のマップレイヤと同じように扱えます|.