Outdated version of the documentation. Find the latest one here.

QGIS 設定

QGIS is highly configurable through the Settings menu. Choose between Panels, Toolbars, Project properties, Options and Customization.

パネルとツールバー

In the Panels‣ menu you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

パネルとツールバーメニュー nix

ちなみに

QGISオーバービューを有効にする

In QGIS you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

ちなみに

ログメッセージの表示

It’s possible to track the QGIS messages. You can activate checkboxLog Messages in the menu Settings ‣ Panels and follow the messages in the General and Plugin tab during loading and operation.

プロジェクトのプロパティ

In the properties window for the project under nix Project ‣ Project Properties or win Project ‣ Project Properties you set project specific options. These include:

  • In the General menu the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You also can define a project scale list, that overrides the global predefined scales.
  • The CRS menu enables you to choose the Coordinate Reference System for this project, and to enable on-the-fly re-projection of raster and vector layers when displaying layers from a different CRS.
  • With the third Identify layers menu you set (or disable) which layers will respond to the identify tool. (See the Map tools paragraph from the オプション section to enable identifying of multiple layers.)
  • The menu Default Styles lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them.
  • The tab OWS Server allows to define information about the QGIS Server WMS and WFS Capabilities, the Extent and the CRS Restrictions.
  • The menu Macros is to create a Python module, saved into a project.qgs file to be loaded and have specific functions run on the following project events: openProject(), saveProject() and closeProject().

Figure Macro Menu:

../../../_images/macro.png

|qg|でのマクロ設定

オプション

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The menus where you can optimize your options are:

一般情報メニュー

アプリケーション

  • スタイル (QGIS再起動が必要です) selectstring を選択し ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ と ‘Cleanlux’ (nix)の中から選択します。

  • アイコンテーマ |selectstring|を定義します。現時点では’デフォルト’のみ利用可能です。

  • Define the Icon size selectstring.
  • :guilabel:`フォント`を定義します。 radiobuttonon :guilabel:`QT 規定値`とユーザ定義のフォントから選択します。

  • メッセージやダイアログのタイムアウト設定 |selectstring|を変更します。

  • checkbox 起動時のスプラッシュスクリーンを隠す

  • checkbox 起動時にチップスを表示する

  • checkbox グループボックスのタイトルを太字にする

  • checkbox QGISスタイルのグループボックス

  • checkbox 色選択ダイアログの随時更新

プロジェクトファイル

  • 起動時にプロジェクトを開く |selectstring|(’新規’、’最新’と ‘指定’の間から選択します。) ‘指定’を選択した時プロジェクトを定義するために |browsebutton|を使用します。

  • checkbox 既定のプロジェクトから新プロジェクトを作成する. 現在のプロジェクトを既定プロジェクトとして指定する または 既定を解除 ボタンをクリックすることができます. またユーザが作成したプロジェクトテンプレートをファイルやディレクトリを指定するとブラウズすることができます. プロジェクト ‣ テンプレートをもとに新規作成 というエントリでそれができます.プロジェクトテンプレートを保存したい場合は最初に checkbox 既定のプロジェクトから新プロジェクトを作成する をアクティブにしてプロジェクトテンプレートフォルダーにプロジェクトを保存してください.

  • checkbox 必要に応じプロジェクトとデータソースの変更の保存を促す

  • checkbox Warn when opening a project file saved with an older version of |qg|
  • Enable macros selectstring. This option was created to handle macros which are written to perform an action

on project events. You can chosse between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

システムメニュー

環境

System environment variables can now be viewed and many configured in the Environment menu (see figure_environment_variables). This is useful for platforms, such as Mac, where a GUI application does not necessarily inherit the user’s shell environment. It’s also useful for setting/viewing environment variables for the external tool sets controlled by the processing toolbox, e.g. SAGA, GRASS; and, for turning on debugging output for specific sections of the source code.

  • checkbox Use custom variables (restart required - include separators). You can Add and Remove variables. Current environment variables ‣ are displayed below and it’s possible to checkbox Show only QGIS-specific variables.

Figure System Environment:

../../../_images/sys-env-options.png

|qg|におけるシステム環境の多様性

プラグインパス

  • Add or Remove Path(s) to search for additional C++ plugin libraries

データソースメニュー

地物属性とテーブル

  • checkbox :guilabel:`ドックウィンドウで属性テーブルを開く(QGISの再起動が必要)’

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelectedCopy selected rows to clipboard from the Attribute table menu then this has the result that also the coordinates of points or vertices are copied to the clipboard.
  • 属性テーブルの動作 selectstring。3つの選択肢があります: ‘全ての地物を表示する’, ‘選択した地物を表示する’ 、 ‘地図上に表示された地物を表示する’

  • Attribute table row cache selectstring. This row cache makes it possible to save the last loaded x attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representation for NULL values Here you can define a value for data fields containing a NULL value.

データソースの操作

  • ブラウザドック内の正しいアイテムをスキャンする selectstring。’領域のチェック’および’ファイルコンテンツのチェック’から選択できます。

  • ブラウザドック内の圧縮ファイル(zip)にあるコンテンツをスキャンする selectstring。’いいえ’、’ベーシックスキャン’、’フルスキャン’から選択できます。

  • Prompt for raster sublayers when opening. Some rasters support sublayers - they are called subdatasets in GDAL. An example is netcdf files - if there are many netcdf variables, GDAL sees every variable as a subdataset. The option is to control how to deal with sublayers when a file with sublayers is opened. You have the following choices:
    • ‘常に’:毎回確認 (サブレイヤが存在する場合)

    • ‘必要な場合’:バンドがなくサブレイヤをもつかを尋ねます

    • ‘利用しない’:確認せず何もロードしません

    • ‘‘すべてをロード’:確認せず、すべてのサブレイヤをロードします

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information this will be ignored by QGIS.
  • checkbox ダブルクリックでPostGISレイヤを追加する.拡張選択モードを利用する

  • checkbox ダブルクリックでOracleレイヤを追加する.拡張選択モードを利用する

レンダリングメニュー

描画品質

  • checkbox 線のジャギーを目立たなくします(描画パフォーマンスが低下します)

  • checkbox ポリゴンの不正な塗りつぶしを修正します

ラスタ

  • with RGB band selection you can define the number for the Red, Green and Blue band.

コントラスト強調

  • シングルバンドグレイ selectstring. シングルバンドグレイでは ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ と ‘Clip to MinMax’ を設定できます

  • マルチバンドカラー (byte/band) selectstring. ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ と ‘Clip to MinMax’ を設定できます.

  • マルチバンドカラー (>byte/band) selectstring. ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ と ‘Clip to MinMax’.

  • Limits (minimum/maximum) selectstring. ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’
  • Cumulative pixel count cut limits
  • Standard deviation multiplier

デバッグ

  • Show these events in the Log Message panel (under rendering tab): checkbox Map canvas refresh

キャンバスと凡例のメニュー

デフォルトのマップ外観(プロジェクトプロパティを上書きします)

  • Define a Selection color and a Background color.

レイヤの凡例

  • Double click action in legend selectstring. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • 以下の Legend item styles は利用可能です

    • checkbox レイヤ名の最初を大文字にする

    • checkbox レイヤ名を太字にする

    • checkbox グループ名を太字にする

    • checkbox 分類の属性名称を表示する

    • checkbox ラスタアイコンの作成(多分遅い)

    • checkbox 新規レイヤをカレントグループに追加する

マップツールズメニュー

地物情報の表示

  • checkbox 地物検索結果を連結されたウィンドウに表示する (QGIS の再起動が必要)

  • The Mode setting determines which layers will be shown by the Identify tool. By switching to ‘Top down’ or ‘Top down, stop at first’ instead of ‘Current layer’ attributes for all identifiable layers (see the Project properties section under: プロジェクト to set which layers are identifiable) will be shown with the Identify tool.
  • checkbox 単一の地物が確認された場合地物フォームを開く

  • Define 検索半径を地図の幅に対する割合で指定する

計測ツール

  • 計測ツールの :guilabel:`ラバーバンド色`を定義します。

  • Define 小数位

  • checkbox 基礎単位の保持

  • Preferred measurements units radiobuttonon (‘meters’ or ‘feet’)`
  • Preferred angle units radiobuttonon (‘Angle’, ‘Radians’ or ‘Gon’)

パンとズーム

  • マウスホィール動作 の定義 selectstring (‘ズーム’, ‘ズームと中心移動’, ‘マウスカーソルにズーム’, ‘無し’)

  • ホイールマウスの ズーム倍率 の定義

定義済み縮尺

Here you find a list of predefined scales. With the ‘+’ and ‘-‘ buttons you can add or remove your individual scales.

デジタイズメニュー

地物の作成

  • checkbox Suppress attributes pop-up windows after each created feature
  • checkbox Reuse last entered attribute values
  • Validate geometries. Editing complex lines/polygons with many nodes can end up with very slow rendering. This is because the default validation procedures in QGIS can use a lot of time. To speed up rendering it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

ラバーバンド

  • Define Rubberband Line width and Line color

スナップ

  • checkbox Open snapping options in a dock window (QGIS restart required)
  • Define Default snap mode selectstring (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Define Default snapping tolerance in map units or pixels
  • Define the Search radius for vertex edits in map units or pixels

頂点マーカー

  • checkbox Show markers only for selected features
  • Define vertex Marker style selectstring (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Define vertex Marker size

カーブオフセットツール

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in 高度なデジタイジング. Through the various settings, it is possible to influence the shape of the line offset. These options are possible from GEOS 3.3 .

  • Join style for curve offset
  • Quadrant segments for curve offset
  • Miter limit for curve offset

GDALメニュー

GDAL is a data exchange library for raster files. In this tab you can Edit create options and Edit Pyramids Options of the raster formats. Define which GDAL driver to be used for a raster format as in some cases more than one GDAL driver is available.

CRSメニュー

新プロジェクトの既定の投影座標系

  • checkbox Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • checkbox オンザフライ再投影をデフォルトで有効にする

  • Select a CRS and Always start new projects with this CRS

新しいレイヤの投影座標系

This area allows to define the action, when a new layer is created, or when a layer without CRS is loaded.

  • radiobuttonon Prompt for CRS
  • radiobuttonoff Use project CRS
  • radiobuttonoff Use default CRS displayed below

ロケールタブ

  • checkbox Overwrite system locale and Locale to use instead
  • 有効なシステムロケールについての情報

ネットワークタブ

一般情報

  • Define WMS search address, default is http://geopole.org/wms/search?search=\%1\&type=rss
  • Define Timeout for network requests (ms) - default is 60000
  • Define Default expiration period for WMSC/WMTS tiles (hours) - default is 24

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

キャッシュ設定

キャッシュのための ディレクトリサイズ の指定.

  • checkbox Web接続にプロキシを使用する と ‘ホスト’, ‘ポート’, ‘ユーザ’, と ‘パスワード’ の指定.

  • Set the プロキシタイプ selectstring 必要に応じて設定して下さい.

    • Default Proxy: プロキシはアプリケーションのプロキシ設定によって決まります

    • Socks5Proxy: あらゆる種類の接続に対応した一般的なプロキシ. TCP, UDP, ポートへのバインディング (入力コネクション) と認証をサポートします.

    • HttpProxy: Implemented using the “CONNECT” command, supports only outgoing TCP connections; supports authentication.
    • HttpCachingProxy: Implemented using normal HTTP commands, it is useful only in the context of HTTP requests
    • FtpCachingProxy: Implemented using an FTP proxy, it is useful only in the context of FTP requests

Excluding some URLs can be added to the text box below the proxy-settings (see Figure_Network_Tab).

If you need more detailed information about the different proxy-settings, please refer to the manual of the underlying QT-library-documentation at http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

ちなみに

プロキシの利用

プロキシを使用すると、時々注意が必要です。それはプロキシタイプで’試行錯誤’するのに有用で、そのケースで成功するかを確認します。

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix settings are saved in a text file: $HOME/.config/QGIS/qgis.conf
  • osx $HOME/Library/Preferences/org.qgis.qgis.plist で設定を見つけることができます。

  • win の設定では以下のレジストリに保存されます:HKEY\CURRENT_USER\Software\QGIS\qgis

カスタマイゼーション

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can get very useful if you have a lot of plug-ins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

カスタマイゼーションダイアログ nix

QGIS Customization is divided into five groups. In checkbox Menus you can hide entries in the Menu bar. In checkbox Panel you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also パネルとツールバー). In the checkbox Status Bar features like the coordinate information can be deactivated. In checkbox Toolbars you can (de)activate the toolbar icons of QGIS and in checkbox Widgets you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application you can click on elements in QGIS you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various different setups for different use cases as well. Before your changes are applied, you need to restart QGIS.