9. QGISの設定

QGISでは高度な設定が可能です。 設定 メニューを通じて、以下のさまざまなツールを提供します。

9.1. オプション

options QGISのいくつかの基本オプションは、オプション ダイアログを使用して選択できます。メニューオプション 設定 ‣ options オプション を選択してください。必要に応じてオプションを変更できます。 オプションが有効になるにはQGISの再起動が必要になるものもあります。

以下で、オプションをカスタマイズできる画面をタブごとに説明します。

注釈

プラグインの設定はオプションダイアログに埋め込み可能

以下ではコア設定のみを紹介しますが、 インストールされたプラグイン が独自のオプションを標準オプションダイアログに実装することでこのリストを拡張できることに注意してください。これにより、それぞれのプラグインが独自の設定ダイアログを持ち、それらのためだけに余分なメニュー項目を持つことを避けられます...

9.1.1. 一般情報

システムロケールを上書きする

デフォルトでは、QGIS の言語の設定と数字の操作はオペレーティングシステムの設定に依存しています。このグループを有効にすると、動作をカスタマイズすることができます。

  • ユーザーインターフェースの言語 で、GUIに適用する言語を選択する

  • ロケール(数字、日付、通貨の形式) で、日付や数字の入力・表示形式を選択する

  • checkbox 数字の3桁区切り(カンマ)を表示

選択された設定の概要とその設定がどのように解釈されるかについては、フレームの下部に表示されます。

アプリケーション

  • スタイル (QGISの再起動が必要) を選択します。つまり、ウィジェットの外観やダイアログ内の位置を設定します。可能な値はオペレーティングシステムによって異なります。

  • UIテーマ (QGISの再起動が必要) selectString を設定します。'default'、 'Night Mapping'、または 'Blend of Gray' を使用できます。

  • アイコンサイズ selectString を定義します

  • フォントサイズ を定義します。フォントは radioButtonOn Qt のデフォルト か、ユーザ定義のフォントにすることができます。

  • メッセージやダイアログのタイムアウト設定 を変更します

  • unchecked 起動時にスプラッシュスクリーンを表示しない

  • checkbox QGISニュースを起動ページに表示する :QGISニュースフィードを起動ページに表示します。これによりプロジェクトのニュース(ユーザー/開発者の会議の日付と概要、コミュニティ調査、リリースのお知らせ、さまざまなヒント...)を知ることができます

  • checkbox 起動時にQGISバージョンを確認する は、新しいバージョンがリリースされたときに知らせてくれます

  • unchecked ネイティブの色選択ダイアログを使用する ( カラーセレクタ を参照)

  • unchecked モードレスデータソースマネージャダイアログ は、プロジェクトにレイヤを追加する際に データソースマネージャ ダイアログが開いたままでQGIS インターフェースとの対話を可能にします。

プロジェクトファイル

  • 起動時に開くプロジェクト

    • 「ウェルカムページ」 (デフォルト) は、 "ニュース” フィードやプロジェクトテンプレート、 ユーザープロファイル の最近使用したプロジェクト(とそのサムネイル画像)を表示します。デフォルトではプロジェクトは開かれません。

    • 「新規」: は、デフォルトのテンプレートに基づき新しいプロジェクトを開きます。

    • 「最近」: は最後に保存したプロジェクトを再度開きます。

    • 「指定」: は特定のプロジェクトファイルを開きます。 ... ボタンを押して、デフォルトで使用するプロジェクトを指定します。

  • checkbox 既定のプロジェクトから新プロジェクトを作成する では、 現在のプロジェクトを既定プロジェクトとして指定する または 既定を解除 ボタンをクリックすることができます。ファイルをブラウズして、ユーザー定義のプロジェクトテンプレートがあるディレクトリを指定することができます。これは プロジェクト ‣ テンプレートから新規作成 に追加されます。最初に checkbox 既定のプロジェクトから新プロジェクトを作成する をアクティブにしてから、プロジェクトテンプレートフォルダーにプロジェクトを保存してください。

  • checkbox 必要なときにプロジェクトおよびデータソースの変更を保存するか尋ねる は、変更が失われないよう必要な時に尋ねます。

  • checkbox レイヤが削除されるときに確認プロンプトを表示する

  • checkbox 古いバージョンのQGISで保存されたプロジェクトファイルを開く時に警告する QGISの古いバージョンで作成されたプロジェクトはいつでも開くことができますが、プロジェクトを保存すると、そのバージョンで使用できない機能のために古いリリースで開くことができなくなる場合があります。

  • マクロを有効にする selectString このオプションは、プロジェクトのイベントのアクションを実行するために書かれたマクロを扱うために作成されました。このオプションは、「利用しない」、「確認する」、「このセッションのみ」、「このセッションは無効」、「常に許可(非推奨)」の中で選択できます。

9.1.2. システム

SVGパス

Scalable Vector Graphic (SVG) シンボルを探すパス を追加・削除します。このSVG ファイルは地物のシンボルやラベル、マップコンポジションの装飾に利用できます。

シンボルやラベルにSVGファイルを使用する場合、QGISでは以下のことが可能です。

  • ファイルシステムからファイルをロード: ファイルはファイルパスを通じて識別され、QGISでは対応する画像を表示するためにパスを解決する必要があります

  • リモートURLからファイルをロード: 上と同様ですが、画像はリモートリソースの取得に成功した場合にのみロードされます。

  • SVG ファイルをアイテムに埋め込む: SVGファイルは現在のプロジェクト、スタイルデータベース、もしくは印刷レイアウトテンプレート内に埋め込まれます。これにより、このSVGファイルはアイテムの一部として常にレンダリングされます。 これはカスタムSVGシンボルを持った自己完結型のプロジェクトを作成するのに便利な方法で、異なるユーザーやQGISインストール環境の間でカスタムSVGシンボルを簡単に共有できます。

    埋め込まれたSVGファイルをシンボルやラベルから抽出して、ディスクに保存することもできます。

注釈

SVGファイルをプロジェクトにロードおよび保存するための上記のオプションは、シンボル、ラベル、または装飾のカスタマイズに使用できるラスタ画像にも適用できます。

プラグインパス

追加のC++プラグインライブラリを探すパス を追加・削除します。.

ドキュメントのパス

QGISのヘルプを探すパス を追加・削除します。デフォルトでは、使用されているバージョンに対応する公式オンラインユーザーマニュアルへのリンクが追加されています。ただし、他のリンクを追加することもできます。ダイアログの ヘルプ ボタンをクリックするたびに一番上のリンクがチェックされ、対応するページが見つからない場合は次のリンクが順に試されるので、追加した他のリンクに上から下へと優先順位をつけられます。

注釈

ドキュメントはQGIS長期リリース(LTR)に対してのみバージョン管理され翻訳されています。つまり、通常のリリース(QGIS 3.0など)を実行している場合、ヘルプボタンはデフォルトで次のLTRマニュアルページ(3.4 LTR)を開くため、新しいリリース(3.2および3.4​​)の機能の説明が含まれる場合があります。 LTRドキュメントが利用できない場合は、新しいバージョンと開発バージョンの機能が記載された testing ドキュメントが使用されます。

設定

何か カスタマイズ をした後で、 ユーザーインターフェイスを既定の設定にリセット(QGISの再起動が必要) する際に役立ちます

環境

../../../_images/sys-env-options.png

図 9.1 QGISのシステム環境変数

環境変数 グループでは、システム環境変数を表示し、多くの設定を行うことができます。これはMacなど、GUIアプリケーションが必ずしもユーザのシェル環境を継承しないプラットフォームで役立ちます。また、Processingツールボックス(SAGA、GRASSなど)によって制御される外部ツールセットの環境変数を設定および表示したり、ソースコードの特定のセクションのデバッグ出力をオンにしたりする場合にも役立ちます。

checkbox :guilabel:` カスタム環境変数を用いる(区切り文字を含む - 再起動が必要)` 。変数を 追加 および 削除 できます。定義済みの環境変数は 現在の環境変数 に表示され、 checkbox QGIS固有の変数のみを表示する を有効にするとそれらをフィルタできます。

9.1.3. 座標参照系(CRS )

注釈

QGIS がレイヤの投影をどのように扱っているかについての詳細は、 投影法の利用方法 の専用セクションを読んでください。

../../../_images/options_crs.png

図 9.2 QGISでのCRS設定

プロジェクトのCRS

新しいプロジェクトのCRSを自動的に設定するオプションがあります。

  • radioButtonOn最初のレイヤのCRSを使う : プロジェクトのCRSは、ロードされた最初のレイヤのCRSに設定されます

  • radioButtonOff デフォルトのCRSを使う :事前に選択されたCRSがデフォルトで新しいプロジェクトに適用され、プロジェクトにレイヤを追加しても変更されません。

この選択内容は保存され、以降のQGISセッションでも使われます。プロジェクトの座標参照系はなおも プロジェクト ‣ プロパティ... ‣ 座標参照系 タブからオーバーライドすることができます。

レイヤのCRS

レイヤのデフォルトCRS は、レイヤを作成した時のデフォルトのCRSを選択します

新しいレイヤが作成されるか、座標参照系のないレイヤが読み込まれた時に実行するアクションを定義することもできます。

  • radioButtonOn 未知のCRSのまま (何もしない)

  • radioButtonOff CRSダイアログを表示

  • radioButtonOff プロジェクトCRSを使う

  • radioButtonOff デフォルトCRSを使う

デフォルトのデータ変換

このグループでは、レイヤを別のCRSに再投影するかどうかを制御できます。

  • QGIS のデフォルト変換設定を使用して自動的に処理します

  • かつ/または、次のようなカスタム設定でユーザがより制御します

    • checkbox 測地系変換が複数利用可能な場合は尋ねる

    • デフォルトで適用する測地系変換の事前定義リスト。詳細は 測地系変換 を参照してください。

  • unchecked 平面計測: は、新しく作成したプロジェクトに対する "平面計測" プロパティのデフォルトを設定します。

9.1.4. データソース

../../../_images/options_data_sources.png

図 9.3 QGISのデータソース設定

地物属性とテーブル

  • checkbox ドックウィンドウとして新しい属性テーブルを開く

  • 地物のコピー は、地物をコピーして他のアプリケーションに貼り付けるときの形式として、 「プレーンテキスト(ジオメトリなし)」、「プレーンテキスト(WKTジオメトリ)」もしくは、「GeoJSON」のどれかを設定します。

  • 属性テーブルの動作 selectString :属性テーブルを開いた時のフィルタを設定します。 「全ての地物を表示」、「選択した地物を表示」、「地図上に表示されている地物を表示」の3つうちのどれかです。

  • デフォルトビュー :属性テーブルを開いた時のビューモードを定義します。「最後のビューを記憶する」、「テーブルビュー」、または「フォームビュー」のどれかです。

  • 属性テーブル行キャッシュ selectNumber 。この行キャッシュは最後にロードされた属性をN行分保存することで、属性テーブルでの作業をより速くできるようにします。キャッシュは属性テーブルを閉じるときに削除されます。

  • NULL値の表示方法 。NULL値を含んだデータフィールドの値を定義できます。

ちなみに

巨大な属性テーブルを開く際の動作を改善する

大量のレコードを含むレイヤーを操作する場合、ダイアログがレイヤー内のすべての行を要求するため、属性テーブルを開くのが遅くなることがあります。 属性テーブルの動作地図上に表示されている地物を表示 に設定すると、QGISはテーブルを開くときに現在の地図キャンバス内にある地物だけを要求するため、データの読み込みが早くなります。

この属性テーブルインスタンスのデータは、開いたキャンバスの範囲に常に関連付けられます。つまり、そのテーブル内の すべての地物を表示 を選択すると新しい地物は表示されません。ただし、キャンバス範囲を変更して、属性表の Show Visible On Map オプションを選択すると、表示されている地物のセットを更新できます。

データソースの操作

  • ブラウザドック内で有効なアイテムをスキャンする selectString 。「拡張子のチェック」と「ファイルの内容のチェック」のどちらかを選択できます。

  • ブラウザドック内で圧縮ファイル(.zip)にあるコンテンツをスキャンする selectString では、圧縮ファイルを照会する際に、ブラウザパネルの下部に表示できるプロパティウィジェットでの情報をどの程度詳細に表示するかを定義します。 「いいえ」、「ベーシックスキャン」、「フルスキャン」の選択肢があります。

  • ラスタサブレイヤを開くときにプロンプトを表示する 。ラスタファイルの一部はサブレイヤをサポートしています。 --- GDALでは「サブデータセット」と呼ばれています。一例としては、netCDF ファイルがあります。--- netCDF変数が多数ある場合、GDAL はすべての変数をサブデータセットとみなします。このオプションでは、サブレイヤを含むファイルを開いたときにサブレイヤをどのように扱うかを制御できます。これには次の選択肢があります。

    • ‘常に’: 毎回、確認プロンプトを表示します(サブレイヤが存在する場合)

    • ‘必要な場合’: レイヤがバンドは無いがサブレイヤを持っている場合にプロンプトを表示します

    • ‘利用しない’:プロンプトを表示せず、何もロードしません

    • '‘すべてをロード':プロンプトは表示しませんが、すべてのサブレイヤをロードします

  • checkbox シェープファイルのコード化宣言を無視 。シェープファイルは、情報をコード化している場合、これはQGISによって無視されます。

  • checkbox 可能であればサーバ側で式を実行する: データソースから地物をリクエストする場合、QGISはフィルタ条件式を直接サーバに送信することでリクエストを最適化し、条件に一致する地物のみをダウンロードするようにします。例えば、ユーザーインターフェース上のリストで農家のうち「ベルンに住む人」のみをリストアップする場合、QGISは``WHERE "ホームタウン" = 'ベルン'`` をデータベースに送信します。場合によっては、フィルタ条件が複雑すぎてQGIS式からデータベース互換のSQLに変換できないことがあります。そのような場合は、QGISはデータ全体をダウンロードし、安全のためにローカルでフィルタリングを行いますが、これははるかにパフォーマンスが低下します。

    このオプションを無効にすると、QGISは常にデータ全体をダウンロードしてローカルでフィルタリングせざるを得なくなり、パフォーマンスが犠牲となります。この選択肢は安全のための措置であり、オプションを無効にするのはQGIS 式変換エンジンの誤動作を確認した場合のみにしてください。

  • checkbox デフォルト値を評価 は、データベースプロバイダからのデフォルト値を、新しい地物のデジタル化(チェックされたステータス)または変更の保存時に計算するかどうかを定義します。

ブラウザに表示しないパス

このウィジェットは ブラウザパネル から非表示にすることを選択したすべてのフォルダをリストアップします。リストからフォルダパスを削除すると、 ブラウザ パネルで表示できるようになります。

9.1.5. レンダリング

../../../_images/rendering_menu.png

図 9.4 レンダリングタブ

レンダリング動作

  • checkbox 追加レイヤのデフォルトで表示: このオプションのチェックを外すと、新しいレイヤが読み込まれたときにキャンバスにレンダリングされてプロセスが遅くなるのを避けられるため、複数のレイヤを読み込む際に便利です。

  • checkbox 再描画の速度を上げられる時にレンダリングのキャッシュを利用する

  • checkbox レイヤの描画を複数のCPUコアを使って並列に行う

  • checkbox 最大コア数

  • 更新間隔(デフォルトは250 msです)

  • checkbox 新規追加レイヤの地物の簡素化をデフォルトで有効にする

  • 簡素化しきい値

  • 簡素化のアルゴリズム: このオプションは、地物のローカルな簡素化を "オンザフライ" で実行し、ジオメトリのレンダリングを高速化します。この簡素化は、データプロバイダからフェッチされたジオメトリを変更することはしません。この違いは地物ジオメトリを使用する式(面積の計算など)を使用する場合に重要です。地物ジオメトリを使用する計算は、簡素化されたジオメトリではなく元のジオメトリに対して行われることが保証されます。地物の簡素化のためにQGISでは '距離' (デフォルトの設定)、 'グリッドにスナップ' 、そして 'Visvalingam' の3つのアルゴリズムを提供しています。

  • unchecked 可能であればプロバイダ側で簡素化する: ジオメトリはプロバイダ(PostGIS、Oracle...)によって簡素化されます。ローカル側での簡素化と異なり、ジオメトリに関連する計算は簡素化の影響を受けます。

  • レイヤーを簡素化する最大スケール

  • doubleSpinBox 拡大レベル (詳細は 拡大 を参照)

注釈

グローバル設定に加えて、特定のレイヤに対しても レイヤのプロパティ ‣ レンダリング メニューから地物の簡素化の設定をできます。

レンダリング品質

  • checkbox 線のジャギーを目立たなくする(描画速度が若干低下します)

曲線の分割

  • 分割の許容差:この設定は、円弧の描画方法を制御します。最大角度(2つの連続した頂点と曲線の中心の間の角度を度単位で指定)または最大差(2つの頂点のセグメントと曲線との間の距離を地図単位で指定)が より小さい ほど、 より多くの直線 セグメントがレンダリング中に使用されます。

  • 許容誤差のタイプ :近似直線と曲線の間での 最大角度 または 最大差 を指定します。

ラスタ

  • RGB バンド選択 で、赤、緑、青のバンドの番号を定義できます。

  • 拡大リサンプリング縮小リサンプリング の方法を定義できます。 拡大リサンプリング の場合、「最近傍」、「バイリニア(Bilinear)」、「キュービック(Cubic)」の3つのリサンプリング方法から選択できます。 縮小リサンプリング の場合、「最近傍」と「平均(Average)」のどちらかを選択できます。 オーバーサンプリング 値も設定できます(0.0 から 99.99 の間。値が大きほどQGISの処理がより多くなります。デフォルト値は2.0です)。

コントラスト

コントラストの強調オプションを 単バンドグレーマルチバンドカラー(1バイト/バンド) または マルチバンドカラー(1バイト超/バンド) のラスタファイルに適用できます。それぞれについて、次を設定できます:

  • 使用する アルゴリズム の値は、「強調なし」、「最小最大範囲に引き伸ばす」、「最小最大範囲に引き伸ばしカット」、あるいは「最小最大範囲以外はカット」のどれかです。

  • 適用する 制限(最小/最大) の値は、「累積ピクセル数のカット」、「最小 / 最大」、「平均 +/- 標準偏差」のどれかです。

ラスタファイルのレンダリングに対しては、次のオプションも定義することができます。

  • 累積ピクセル数のカット制限

  • 標準偏差の乗数

デバッグ

  • checkbox キャンバスの更新 ログメッセージ パネルでレンダリング時間のデバッグを行えます。

9.1.6. キャンバスと凡例

../../../_images/options_canvas_legend.png

図 9.5 キャンバスと凡例

これらのプロパティでは以下を設定できます:

  • デフォルトの体裁(プロジェクトプロパティに上書きされます)選択物の色 および 背景色

  • レイヤの凡例 に対するインタラクション

    • 凡例をダブルクリックした場合の動作 selectString ダブルクリックで、「レイヤのプロパティを開く」、「属性テーブルを開く」、「レイヤスタイルドックを開く」のいずれかを行うことができます。

    • checkbox レイヤタイトルに分類属性を表示する たとえばカテゴリ値による定義やルールによる定義のレンダラを適用する場合、レイヤパネルに分類に使用した属性名を表示します(詳細は Symbology Properties を参照)。

    • the WMS getLegendGraphic 解像度

  • 表示までの遅延(ミリ秒) レイヤの 地図のtips が表示されるまでの遅延です。

9.1.7. ツール

../../../_images/options_map_tools.png

図 9.6 QGISのマップツール設定

このタブは 地物情報表示ツール の動作に関するいくつかのオプションを提供しています 。

  • 地物検索・Tips表示のための検索半径 は、この許容範囲内でクリックする限り地物情報表示ツールが結果を表示する許容距離です。

  • ハイライト色 を使用すると、地物情報表示されている地物を強調表示する色を選択できます。

  • バッファ は、地物情報表示でハイライトされている地物の輪郭に表示するバッファの距離を決定します。

  • 最小幅 ハイライト表示されるオブジェクトの輪郭がどれだけの厚さであるべきかを決定します。

計測ツール

  • 計測ツールの ラバーバンド色 を定義します。

  • 小数点以下桁数 を定義します

  • checkbox 基本単位の維持 は、大きい数を自動的に変換しません(例えば、メートルをキロメートルに変換するなど)

  • 優先される距離の単位: は、「メートル」、「キロメートル」、「フィート」、「ヤード」、「マイル」、「海里」、「センチメートル」、「ミリメートル」、「度」、「地図上の単位」のいずれかです。

  • 優先される面積の単位: は、「平方メートル」、「平方キロメートル」、「平方フィート」、「平方ヤード」、「平方マイル」、「ヘクタール」、「エーカー」、「平方海里」、「平方センチメートル」、「平方ミリメートル」、「平方度」、「地図上の単位」のいずれかです。

  • 優先される角度の単位: は、「度」、「ラジアン」、「グラード」、「弧の分」、「弧の秒」、「Turns/revolutions」、「ミリラジアン(SI定義)」、「ミル(NATO定義)」のいずれかです。

ズーム

  • ズームツールまたはホイールマウスの ズーム倍率 を定義します。

定義済み縮尺

ここには、あらかじめ定義された縮尺のリストがあります。 signPlussignMinus ボタンで個人用の縮尺を追加または削除できます。また、縮尺を .XML ファイルに読み込みまたは書き出しできます。なお、変更した内容を削除して定義済みのリストに戻すこともできます。

9.1.8.

../../../_images/options_colors.png

図 9.7

このメニューを使用すると、アプリケーション全体で使用される色のパレットを カラーセレクタウィジェット で作成または更新できます。以下から選択できます。

  • 最近使った色 :最近使用した色を表示します

  • 標準色 :デフォルトの色パレットです

  • プロジェクトの色 :現在のプロジェクトに固有の色のセットです(詳細は 既定スタイル を参照してください)。

  • 新しいレイヤの色 :新しいレイヤがQGISに追加されたときにデフォルトで使用される色のセットです。

  • あるいは、パレットコンボボックスの横にある ... ボタンを押して、カスタムパレットを新規作成もしくはインポートできます。

デフォルトでは、 最近使った色標準色、および プロジェクトの色 パレットは削除できず、色ボタンドロップダウンに表示されるように設定されています。カスタムパレットは 色ボタンに表示 オプションで、ウィジェットに追加できます。

どのパレットでも、フレームの横にあるツールセットを使って色のリストを管理することができます。

  • signPlus 色の追加 あるいは signMinus 色の削除

  • editCopy 色のコピー あるいは editPaste 色の貼り付け

  • fileOpen ファイルから色のインポート あるいは fileSave 色のエクスポート で色のセットを .gpl ファイルからインポート / ファイルへエクスポート

リスト内の色をダブルクリックして カラーセレクタ ダイアログで色を調整したり、置き換えたりできます。 ラベル 列をダブルクリックして、色の名前を変更することもできます。

9.1.9. デジタイズ

../../../_images/options_digitizing.png

図 9.8 QGISのデジタイズ設定

このタブでは、 ベクタレイヤを編集する (属性とジオメトリ)際の一般的な設定を行います。

地物の作成

  • checkbox 地物作成後に属性フォームをポップアップさせない :この選択は各レイヤのプロパティダイアログで上書きできます。

  • checkbox 最後に入力した値を利用する

  • ジオメトリの検証 。多くのノードを持つ複雑なラインとポリゴンを編集すると、レンダリングが非常に遅くなる可能性があります。これは、QGISでのデフォルトの検証手順は多くの時間がかかることがあるためです。レンダリングを高速化するために、GEOSジオメトリ検証を選択する(GEOS 3.3以降)か、または検証をオフにすることが可能です。GEOSジオメトリの検証ははるかに高速ですが、最初に見つかったジオメトリの問題しか報告されないという欠点があります。

    選択範囲によっては、ジオメトリエラーの報告が他と異なる場合があることに注意してください(詳細は Types of error messages and their meanings を参照)

  • デフォルトのZ値 は、新しい3次元地物を作成するときに使うZ値のデフォルト値です。

ラバーバンド

  • ラバーバンドの 線幅線の色 および 塗りつぶし色 を定義します。

  • 頂点の編集中にラバーバンドを更新しない

スナップ

  • checkbox デフォルトでスナップを有効にする プロジェクトを開いたときにスナップを有効にします

  • 既定のスナップモード を定義します。 selectString (「点」、「点とセグメント」、「セグメント」)

  • 既定のスナップ許容量 を地図上の単位またはピクセルで指定します

  • 頂点編集用検索半径 を地図上の単位またはピクセルで指定します

  • メインダイアログの表示(再起動が必要) : は、スナップオプションが 'ダイアログ' として開かれるか、「ドック」として開かれるかを設定します。

  • スナップマーカーの色

  • checkbox スナップツールチップを表示する スナップしようとしている地物のあるレイヤの名前などを表示します。複数の地物が重なり合っている場合に役立ちます。

  • checkbox 非表示の地物に対してもスナップを有効にする (マップキャンバス上に現れていない地物)

頂点マーカー

  • checkbox 選択地物のみマーカーを表示する

  • マーカースタイル selectString 頂点マーカースタイルを定義します(「クロス」(デフォルト)、「半透明の円」または「なし」)

  • マーカーの大きさ(単位ミリ) 頂点マーカーの大きさを定義します

曲線のオフセットツール

次の3つのオプションについては、 高度なデジタイジング 中の offsetCurve オフセット曲線 ツールを参照してください。さまざまな設定により、オフセット線の形状に影響を与えることができます。これらのオプションはGEOS 3.3 以降で使用可能です。

  • 継ぎ目スタイル :「ラウンド」「マイター」「べベル」

  • 象限セグメント

  • miter 制限

9.1.10. レイアウト

../../../_images/options_layouts.png

図 9.9 QGISのレイアウト設定

レイアウトのデフォルト

プリントレイアウト で使用される デフォルトフォント を定義できます。

グリッドの外見

  • グリッドスタイル selectString (「ソリッド」、「点」、「十字」)を定義します。

  • グリッド色 を定義します

グリッドとガイドのデフォルト

  • グリッド間隔 selectNumber を定義します

  • グリッドオフセット selectNumber を X方向とY方向で定義します

  • スナップ許容量 selectNumber を定義します

レイアウトのパス

  • 追加のプリントテンプレートを探すパス 新しいレイアウトを作成する際に使用するカスタムのレイアウトテンプレートが保存されたフォルダの一覧を定義します。

9.1.11. GDAL

GDAL とは、ベクタファイルやラスタファイルのデータ変換ライブラリです。GDAL はさまざまなフォーマットでデータを読み書きするためのドライバを提供します。 GDAL タブでは今のところ、ラスタ形式に対するドライバとその機能を公開しています。

9.1.11.1. GDAL ドライバオプション

このフレームでは、読み取りおよび書き込みアクセスをサポートするドライバの動作をカスタマイズする方法を提供します。

  • 作成オプションを編集: ファイル変換の際に使う別のプロファイルを編集または追加することができます。すなわち、ラスタファイルを出力する際に使用するパラメータ(圧縮の種類とレベル、ブロックサイズ、全体図、測色、アルファ... )の事前に定義された組み合わせのセットを編集・追加できます。パラメータはドライバに依存します。

    ../../../_images/gdalCreateOptions.png

    図 9.10 オプションプロファイルの作成サンプル (GeoTiff 用)

    ダイアログの上部には現在のプロファイルが一覧表示され、新しいプロファイルを追加したり、削除したりできます。プロファイルを変更した場合に、デフォルトのパラメータにリセットすることもできます。一部のドライバ(GeoTiff など)には、プロファイルのサンプルがあります。

    ダイアログの下部:

    • signPlus ボタンを押すと、パラメータの名称と値を入力できる行を追加します

    • signMinus ボタンを押すと、選択したパラメータを削除します

    • 検証 ボタンをクリックすると、指定されたフォーマットに対して入力された作成オプションが有効であるかを確認します

    • ヘルプ ボタンを押して使用するパラメータを見つけるか、 GDAL raster drivers documentation を参照してください。

  • Edit ピラミッドオプションを編集

    ../../../_images/gdalPyramidsOptions.png

    図 9.11 ピラミッドプロファイルのサンプル

9.1.11.2. GDAL ドライバ

このフレームでは、ファイルの読み取りや書き込みに使用するGDALドライバを定義できます。使用できるGDALドライバは複数ある場合があるためです。

../../../_images/options_gdal.png

図 9.12 QGIS の GDAL 設定

ちなみに

読み取り・書き込みアクセスが可能 (rw+(v)) なドライバをダブルクリックして 作成オプションの編集 ダイアログを開き、作成オプションをカスタマイズすることができます。

9.1.12. 変数

変数 タブには、グローバルレベルで利用可能なすべての変数がリストされています。

ここではグローバルレベルの変数の管理もできます。 signPlus ボタンをクリックして、新しいカスタムグローバルレベル変数を追加します。同様に、リストからカスタムグローバルレベル変数を選択し、 signMinus ボタンを押して削除します。

変数の詳細については、 値を変数に格納する セクションを参照してください。

../../../_images/options_variables_global.png

図 9.13 QGIS の変数設定

9.1.13. 認証

認証 タブでは、認証設定を設定し、PKI証明書を管理できます。詳細は 認証システム 参照。

../../../_images/auth-editor-configs21.png

図 9.14 QGISの認証設定

9.1.14. ネットワーク

一般情報

  • WMS 検索アドレス を定義します。デフォルトは http://geopole.org/wms/search?search=\%1\&type=rss です

  • ネットワークリクエストのタイムアウト(ミリ秒) を定義します。デフォルトは 60000 ミリ秒です

  • WMS Capabilitiesのデフォルト有効期限(hours) を定義します。デフォルトは 24時間です

  • WMS-C/WMTS タイルのデフォルト有効期限(hours) を定義します。デフォルトは 24時間です

  • タイル / 地物リクエストエラーの場合の最大再試行 の回数を指定します

  • User-Agent を定義します

../../../_images/proxy-settings.png

図 9.15 QGISでのプロキシ設定

キャッシュ設定

キャッシュの ディレクトリサイズ[KiB] を定義します。また、 SSL エラーで接続認証キャッシュを自動的に消去する(推奨) ためのツールを提供します。

ウェブアクセスのプロキシ

  • checkbox ウェブアクセスにプロキシを使用する

  • 必要に応じて プロキシタイプ selectString を設定し、「ホスト」と「ポート」を定義します。利用可能なプロキシタイプは以下の通りです。

    • Default Proxy: プロキシはシステムのプロキシ設定をもとに決定されます

    • Socks5Proxy: あらゆる種類の接続に対応した一般的なプロキシ. TCP, UDP, ポートへのバインディング (入力コネクション) と認証をサポートします.

    • HttpProxy: "CONNECT" コマンドを実装しています, 外向きの TCP コネクションのみサポートしています; 認証をサポートしています.

    • HttpCachingProxy: 通常のHTTPコマンドを使って実装され、HTTPリクエストのコンテキストでのみ役に立ちます。

    • FtpCachingProxy:FTPプロキシを使用して実装、それだけでFTP要求のコンテキストで便利です。

プロキシの資格情報は 認証ウィジェット を使用して設定します。

プロキシ設定の下のテキストボックスにいくつかの除外URLを追加することができます( Figure_Network_Tab を参照)。ターゲットURLがこのテキストボックスにリストされた文字列の1つで始まる場合、プロキシは使用されません。

さまざまなプロキシ設定に関するより詳細な情報が必要な場合は、 https://doc.qt.io/qt-5.9/qnetworkproxy.html#ProxyType-enum にあるQTライブラリのマニュアルを参照してください。

ちなみに

プロキシの利用

プロキシを使用すると、時にはトリッキーなことができます。それらが自分の場合に成功するかどうか確認するため、上記のプロキシタイプで「試行錯誤」しながら進むのが便利です。

9.1.15. ロケータ

search ロケータ タブでは、 ロケータバー の設定を行えます。 これは、ステータスバー上で利用可能なクイック検索ウィジェットで、アプリケーション内の任意の場所で検索を実行できます。デフォルトのフィルタ(や接頭辞)なども設定できます。

  • プロジェクトのレイヤ (l): レイヤ パネル内のレイヤを検索し、選択します。

  • プロジェクトのレイアウト (pl): 印刷レイアウトを検索し、開きます。

  • アクション (.): QGISのアクションを検索し、実行します。アクションには、QGISのツールやメニュー、パネルを開く等があります。

  • アクティブレイヤの地物 (f): 現在アクティブなレイヤから任意のフィールドで一致する属性を検索し、選択した地物にズームします。

  • 全てのレイヤの地物 (af): 各 検索可能なレイヤ表示名 でマッチする属性を検索し、選択した地物にズームします。

  • 計算機 (=): 任意の QGIS 式の評価ができ、有効な式であれば、結果をクリップボードにコピーするオプションが与えられます。

  • 空間ブックマーク (b): ブックマーク範囲を検索し、ズームします。

  • 設定 (set): プロジェクトやアプリケーション全体のプロパティダイアログを参照し開きます。

  • プロセシングアルゴリズム (a): プロセシングアルゴリズムダイアログを検索し開きます。

  • 選択地物を編集する (ef): プロセシングアルゴリズムへのクイックアクセスを提供し、互換性のある in-place 編集 のプロセシングアルゴリズムをアクティブレイヤで実行します。

各フィルタについて、フィルターをカスタマイズし、デフォルトで有効にするかどうかを設定できます。デフォルトのロケータフィルタのセットはプラグインによって拡張できます。例えば、OSM nominatim 検索や直接データベース検索、レイヤカタログ検索などがあります。

Ctrl+K を押すとロケータ検索バーが起動し、テキストを入力して検索できます。デフォルトでは、有効になっているすべてのロケータフィルタに対して検索結果が返されますが、 ロケータフィルタの接頭辞をテキストの前に付けることで、検索対象を特定のフィルターに限定することができます。 l cad と入力すると、名前に cad を含むレイヤのみが返されます。結果をクリックすると、アイテムの種類に応じて対応するアクションが実行されます。

検索はスレッドを使用して処理されるため、低速の検索フィルタがインストールされているかどうかに関係なく、常に可能な限り早く結果が得られるようになっています。また、各フィルターがそれぞれの検索結果を見つけると、すぐに表示されるようになっています。例えば、ファイル検索フィルタがファイルツリーをスキャンすると、結果を一つ見つけるごとに表示されます。これにより、非常に遅い検索フィルタ(オンラインサービスを使用するものなど)が存在する場合でも、UIは常に応答できるようになっています。

ちなみに

ロケータの設定へのクイックアクセス

ステータスバーのロケータウィジェット内の search アイコンをクリックし、使用可能なフィルタのリストを表示したら、 設定... エントリをクリックすると、 設定 ‣ オプション... メニューの ロケータ タブが開きます。

../../../_images/options_locator.png

図 9.16 QGISのロケータ設定

9.1.16. 高度な設定

../../../_images/options_advanced.png

図 9.17 QGISの高度な設定タブ

QGISに関連するすべての設定(UI、ツール、データプロバイダ、プロセシングアルゴリズムの構成、デフォルト値やパス、プラグインのオプション、式、ジオメトリチェックなど)は、アクティブな ユーザープロファイル ディレクトリの QGIS/QGIS3.ini ファイルに保存されます。このファイルを他のインストール環境にコピーすることで、設定を共有することができます。

QGIS 内では、 高度な設定 タブの 高度な設定エディタ を使用してこれらの設定を管理する方法を提供しています。慎重に設定変更することを約束したら、ウィジェットには既存のすべての設定のツリーが表示され、その値を編集することができるようになります。設定やグループの上で右クリックすると、設定やグループを削除することができます(設定やグループを追加するには、 QGIS3.ini ファイルを編集する必要があります)。変更は自動的に QGIS3.ini ファイルに保存されます。

警告

「高度な設定」タブの設定をやみくもに使用しないこと

変更は自動的に適用されるため、このダイアログで項目を変更する際には注意が必要です。知識のないまま変更を行うと、さまざまな形で QGIS のインストール環境が壊れる可能性があります。

9.1.17. 高速化

OpenCL による高速化の設定。

../../../_images/acceleration_menu.png

図 9.18 高速化タブ

9.1.18. プロセシング

processing プロセシング タブでは、QGIS プロセシングフレームワークで使用されるツールやデータプロバイダの一般的な設定を行うことができます。詳細は、 QGIS プロセッシングフレームワーク を参照してください。

../../../_images/options_processing.png

図 9.19 QGISのプロセシング設定タブ

9.2. ユーザープロファイルの操作

設定->ユーザープロファイル メニューは、ユーザープロファイルを設定したり、ユーザープロファイルにアクセスする機能を提供します。ユーザープロファイルとは、単一のフォルダに保存される一元管理されたアプリケーション構成で、以下のものを含みます。

  • ロケール、投影法、認証設定、カラーパレット、ショートカットなどを含むすべての グローバル設定

  • GUI の構成と カスタマイズ

  • インストールされた プラグイン とその構成

  • プロジェクトのテンプレートと、保存されたプロジェクトの履歴およびその画像プレビュー

  • プロセシングの設定 やログ、スクリプト、モデル

デフォルトでは、QGISインストールには default という名前のユーザープロファイルが一つだけ含まれています。ただし、ユーザープロファイルは必要な数だけ作成できます。

  1. 新しいプロファイル... エントリをクリックします。

  2. プロファイル名を指定するように求められ、同じ名前のフォルダが ~/<UserProfiles>/ の下に作成されます。

    • ~ホーム ディレクトリを表します。 win Windows では、通常は C:\Users\(user) のようなフォルダです。

    • <UserProfiles> は、メインプロファイルフォルダを表します。

      • nix .local/share/QGIS/QGIS3/profiles/

      • win AppData\Roaming\QGIS\QGIS3\profiles\

      • osx Library/Application Support/QGIS/QGIS3/profiles/

    ユーザープロファイルフォルダは、 アクティブなプロファイルフォルダを開く を使用してQGIS 内から開くことができます。

  3. クリーンな構成を使用して、QGIS の新しいインスタンスが起動されます。その後、カスタム構成を設定することができます。

If you have more than one profile in your QGIS installation, the name of the active profile is shown in the application title bar between square brackets.

各ユーザープロファイルには個別の設定、プラグイン、および履歴が含まれているため、異なるワークフローで使い分けたり、デモ用途や、同じマシンでユーザーが複数いる場合、あるいは設定のテスト用などに最適です。 設定->ユーザープロファイル メニューで選択することで、あるプロファイルから別のプロファイルへと切り替えができます。 コマンドライン から特定のユーザープロファイルでQGISを実行することもできます。

最後に閉じられたQGISセッションのプロファイルは、変更されない限りは次のQGISセッションで使用されます。

ちなみに

新しいユーザープロファイルでQGISを実行して、バグの持続性を確認する

QGISの一部の機能で奇妙な動作が発生した場合には、新しいユーザープロファイルを作成してコマンドを再度実行してください。バグは、現在のユーザープロファイルに残っているものが関係していることがあります。新しいユーザープロファイルを作成すると、新しい(クリーンな)プロファイルでQGISを再起動するため、バグが修正されることがあります。

9.3. プロジェクトのプロパティ

プロジェクト->プロジェクトのプロパティ のプロジェクトのプロパティウィンドウで、プロジェクト固有のオプションを設定できます。プロジェクト固有のオプションは、上記の オプション ダイアログの同じオプションを上書きします。

9.3.1. 一般情報

一般情報 タブの 一般設定 では、以下の設定が可能です:

  • プロジェクトファイルの場所を見る

  • プロジェクトのホームフォルダを設定する(ブラウザパネルの プロジェクトホーム アイテムでも可能)。パスは、プロジェクトファイルのフォルダに対する相対パス(として入力する)にも、絶対パスにもできます。プロジェクトホームはプロジェクトに役立つデータやその他のコンテンツを保存するために使用されます。

  • プロジェクトにタイトルを付ける

  • 地物が選択されたときに使用する色を選択する

  • 背景色を選択する:地図キャンバスに使用する色を選択します

  • プロジェクト内でレイヤへのパスを絶対(フル)パスとして保存するか、プロジェクトファイルの場所に対する相対パスとして保存するかを設定する。レイヤとプロジェクトファイルの両方が移動するもしくは共有する可能性がある場合や、異なるプラットフォーム上のコンピュータからプロジェクトにアクセスする場合には、相対パスの方が良いかもしれません。

  • プロジェクトが地図タイルとしてレンダリングされる時のずれを回避するか選択する。このオプションをチェックすると、パフォーマンスの低下につながる可能性があります。

GISでは面積や距離の計算がよく必要になります。しかしながら、これらの値は実際には基礎となる投影設定に関連付けられています。 計測 フレームではこれらのパラメータを制御できます。以下が選択できます。

  • 楕円体 :距離や面積の計算に完全に基づいている楕円体を選択します。これには以下の値があります。

    • None/Planimetric: この場合には、計算値はデカルト計測による値です。

    • カスタム : 楕円体の長軸と短軸の値を設定する必要があります。

    • または定義済みのリスト(Clarke 1866、 Clarke 1880 IGN、 New International 1967、 WGS 84 など) から既存のものを選択します。

  • 長さと周長のための 距離計測の単位 と、 面積計測の単位 。これらの設定は、デフォルトではQGISオプションで設定した単位が使われますが、現在のプロジェクトの単位で上書きされ、以下の値の単位に使用されます。

    • 属性テーブルのフィールド更新バー

    • フィールド計算機の計算

    • 地物情報表示ツールで表示される長さ、周長および面積値

    • 計測ダイアログに表示されるデフォルトの単位

座標の表示 では、ステータスバーに表示されるマウス座標や、地物情報表示ツールによって表示される派生した属性のクリック座標を表示するために使用する単位の形式を選択およびカスタマイズできます。

最後に、 プロジェクト定義済み縮尺 のリストを設定し、グローバル設定で定義済みの縮尺を上書きできます。

../../../_images/project_general.png

図 9.20 プロジェクトのプロパティダイアログの一般情報タブ

9.3.2. メタデータ

メタデータ タブでは、著者、作成日、言語、要約、カテゴリ、キーワード、連絡先の詳細、リンク、履歴など、詳細なメタデータを定義できます。特定のフィールドが入力されているかどうかを確認する検証機能もありますが、これは強制されません。詳細は ベクタレイヤのメタデータプロパティ をご覧ください。

9.3.3. 参照座標系

注釈

QGIS がプロジェクトの投影をどのように扱っているかについての詳細は、 投影法の利用方法 の専用セクションを読んでください。

crs CRS タブでは、そのプロジェクトで使用する座標参照系を設定できます。以下の設定があります。

  • checkbox 投影なし(または未知 / 非地球投影): レイヤの生の座標に基づいてレイヤが描画されます

  • または、既存の座標参照系で 地理的座標系投影された座標系 あるいは ユーザ定義の座標系 を使用することができます。プロジェクトに追加されたレイヤは、重ね合わせるために元のCRSに関係なくオンザフライでこのCRSに変換されます。

crs CRS タブでは、現在のプロジェクトで適用する測地系変換を設定することで、レイヤーの再投影設定を制御することができます。例によってこれらは対応するグローバル設定を上書きします。詳細については 測地系変換 を参照してください。

9.3.4. 既定スタイル

既定スタイル タブでは、既存の .qml スタイルが定義されていない場合にプロジェクトで新しいレイヤをどのように描画するかを制御できます。以下の設定ができます。

  • Set default symbols (Marker, Line, Fill) to apply depending on the layer geometry type as well as a default Color Ramp

  • Apply a default Opacity to new layers

  • checkbox Assign random colors to symbols, modifying the symbols fill colors, hence avoiding same rendering for all layers.

../../../_images/project_default_styles.png

図 9.21 Default Styles tab

Using the styleManager Style Manager button, you can also quickly access the Style Manager dialog and configure symbols and color ramps.

There is also an additional section where you can define specific colors for the running project. Like the global colors, you can:

  • signPlus 色の追加 あるいは signMinus 色の削除

  • editCopy 色のコピー あるいは editPaste 色の貼り付け

  • fileOpen ファイルから色のインポート あるいは fileSave 色のエクスポート で色のセットを .gpl ファイルからインポート / ファイルへエクスポート

リスト内の色をダブルクリックして カラーセレクタ ダイアログで色を調整したり、置き換えたりできます。 ラベル 列をダブルクリックして、色の名前を変更することもできます。

These colors are identified as Project colors and listed as part of color widgets.

ちなみに

Use project colors to quickly assign and update color widgets

プロジェクトの色はそれらのラベルを使用することで参照でき、それらが使用されるカラーウィジェットはそれらにバインドされます。これが意味するのは、多くのプロパティに同じ色を繰り返し設定する代わりに、面倒な更新を避けるために以下が可能であることです:

  1. Define the color as a project color

  2. Click the data defined override widget next to the color property you want to set

  3. Hover over the Color menu and select the project color. The property is then assigned the expression project_color('color_label') and the color widget reflects that color.

  4. Repeat steps 2 and 3 as much as needed

  5. Update the project color once and the change is reflected EVERYWHERE it's in use.

9.3.5. Data Sources Properties

データソース タブでは、できることは:

  • unchecked 可能であればトランザクショングループを自動的に作成する :このモードをオンにすると、同じデータベースのすべての(postgres)レイヤーが編集状態で同期されます。つまり、あるレイヤーが編集状態になると、 1つのレイヤーがコミットされるか、または1つのレイヤーがロールバックされます。また、編集変更をローカルでバッファリングする代わりに、データベース内のトランザクションに直接送信され、ユーザーが保存レイヤーをクリックしたときにコミットされます。プロジェクトでレイヤーが編集されていない場合にのみ、このオプションを有効にできます。

  • unchecked プロバイダー側でのデフォルト値の評価 :PostgreSQLのテーブルに新しい地物を追加すると、デフォルト値の制約を持つフィールドが評価され、コミットの瞬間ではなく、フォームのオープン時に読み込まれます。これは、 nextval( 'serial') のような式の代わりに 地物を追加 フォームのフィールドが期待値(例えば 25 )を表示することを意味します。

  • unchecked データソースにメタデータがない場合にプロジェクトを信頼する :データチェックをスキップしてプロジェクトの読み込みを高速化します。 QGIS Serverコンテキストまたは巨大なデータベースビュー/マテリアライズドビューを持つプロジェクトで役立ちます。レイヤーの範囲は(データソースの代わりに)QGISプロジェクトファイルから読み取られ、PostgreSQLプロバイダーを使用する場合、ビューとマテリアライズドビューの主キーの単一性はチェックされません。

  • Configure the Layers Capabilities, i.e.:

    • Set (or disable) which layers are identifiable, i.e. will respond to the identify tool. By default, layers are set queryable.

    • レイヤーを「読み取り専用」として、つまり、データプロバイダーの機能に関係なくユーザーは編集できないように、表示するかどうか設定します。これは弱い保護ですが、ファイルベースのレイヤーで作業しているときにエンドユーザーがデータを変更するのを避けるための迅速かつ便利な構成のままです。

    • Define which layers are searchable, i.e. could be queried using the locator widget. By default, layers are set searchable.

    • どのレイヤーを「必須」として定義するかを定義します。このリスト内でチェックされたレイヤは、プロジェクトからの不注意な削除から保護されます。

    The Layers Capabilities table provides some convenient tools to:

    • 複数のセルを選択し、 選択の切り替え を押して、チェックボックスの状態を変更します。

    • unchecked Show spatial layers only, filtering out non-spatial layers from the layers list;

    • search Filter layers... and quickly find a particular layer to configure.

../../../_images/project_datasources.png

図 9.22 Data Sources tab

9.3.6. Relations Properties

関係 タブは1:nの関係を定義するために使用されます。関係は、プロジェクトのプロパティダイアログで定義されています。関係は、レイヤーに存在すると、フォームビュー(例えば、地物を識別し、そのフォームを開くとき)で、新しいユーザーインターフェイス要素は、関連するエンティティのリストが表示されます。これは、例えばパイプラインや道路区間の長さの検査履歴を表現するための強力な方法を提供します。1:n関係のサポートについての詳細はセクション 1対多または多対多の関係を作成する にあります。

../../../_images/project_relations.png

図 9.23 Relations tab

9.3.7. 変数のプロパティ

変数 タブには、プロジェクトのレベルで使用可能なすべての変数(すべてのグローバル変数を含む)がリストされます。また、プロジェクトレベルの変数を管理することもできます。 signPlus ボタンをクリックして、新しいカスタムプロジェクトレベル変数を追加します。同様に、リストからカスタムプロジェクトレベルの変数を選択し、 signMinus ボタンを押して削除します。変数の使用法の詳細は一般ツール 値を変数に格納する セクションで。

9.3.8. Macros Properties

マクロ タブはPythonマクロの編集のために使います. 現時点では: openProject(), saveProject() そして closeProject() の3つのマクロのみ使用可能です.

../../../_images/macro.png

図 9.24 QGISでマクロの設定

9.3.9. QGIS Server Properties

タブ QGISサーバー では、プロジェクトをオンラインで公開するために設定することを可能にします。ここでは、QGISサーバーのWMSとWFSの機能、範囲、およびCRSの制限に関する情報を定義できます。より詳しい情報は Configure your project 以降にあります。

../../../_images/project_qgisserver.png

図 9.25 QGIS Server settings tab

9.4. カスタマイズ

カスタマイズダイアログでは、QGISのユーザーインターフェイスのほぼすべての要素を有効(無効)にできます。彼らが必要とする唯一のアイコン、メニューやパネルを含む、QGISの「光」バージョンを使用して、エンドユーザーに提供したい場合、これは非常に便利です。

注釈

変更が適用される前に、QGISを再起動する必要があります。

../../../_images/customization.png

図 9.26 カスタマイズダイアログ

checkbox カスタマイズ チェックボックスを切り替えるのは、QGISのカスタマイズへの道の最初のステップです。これはツールバーやウィジェットパネルを有効にし、それらからチェックを外していくつかのGUIの項目を無効にできます。

設定可能な項目があることができます:

  • メニュー または メニューバー からのそのサブメニューのいくつか

  • 全体 パネル ( パネルとツールバー 参照)

  • ステータスバー で説明される ステータスバー またはその項目の何か

  • ツールバー : バー全体またはそのアイコンの何か

  • または任意の ウィジェット QGISで任意のダイアログから:ラベル、ボタン、コンボボックス...

With select Switch to catching widgets in main application, you can click on an item in QGIS interface that you want to be hidden and QGIS automatically unchecks the corresponding entry in the Customization dialog. You can also use the Search box to find items by their name or label.

設定をセットアップしたら、 適用 または OK をクリックして変更を検証します。この構成は、次回の起動時にQGISによってデフォルトで使用される構成になります。

変更は fileSave ファイルに保存 ボタン使用して .ini ファイルにも保存できます 。これは、複数のユーザー間で共通のQGISインターフェイスを共有するための便利な方法です。 .ini ファイルをインポートするためには、先のコンピュータから fileOpen ファイルからロード をクリックするだけです。また同様に、 コマンドラインツール を実行してさまざまなユースケースのための各種設定を保存できます。

ちなみに

簡単に定義済みのQGISを復元

初期QGISのGUI構成は、以下のいずれかの方法で復元できます。

  • カスタマイズダイアログで checkbox カスタマイズを有効にする オプションのチェックを外すか、 selectAllTree すべてチェック ボタンをクリック

  • pressing the Reset button in the QSettings frame under Settings ‣ Options menu, System tab

  • 次のコマンドラインを使用してコマンドプロンプトでQGISを起動します: qgis --nocustomization

  • false設定‣オプション メニュー、 高度な タブの下の UI ‣ カスタマイズ ‣有効化 変数の値を設定すると、( 警告 参照) 。

ほとんどの場合、変更が適用されるためにはQGISを再起動する必要があります。

9.5. キーボードショートカット

QGISは多くの機能にデフォルトのキーボードショートカットを提供します。それらはセクション メニューバー で見ることができます。さらに、メニューオプション 設定-> keyboardShortcuts キーボードショートカット... を使用すると、デフォルトのキーボードショートカットを変更し、QGIS機能に新しいショートカットを追加できます。

../../../_images/shortcuts.png

図 9.27 ショートカットオプションを定義

構成は非常に簡単です。ダイアログの上部にある検索ボックスを使用して特定のアクションを見つけ、リストからそれを選択してをクリックします:

  • 変更 して、新しいショートカットとして割り当てる新しい組み合わせを押します

  • Set None to clear any assigned shortcut

  • or Set Default to backup the shortcut to its original and default value.

カスタマイズする他のツールについては、上記の手順に従ってください。設定が完了したら、ダイアログを単に 閉じる して変更を適用します。変更を:file:.XML ファイルとして 保存 し、それらを別のQGISインストールに ロード することもできます。

9.6. 高度な設定でQGISを実行する

9.6.1. コマンドラインと環境変数

QGISを起動する のはOS上のどのアプリケーションに関しても行われることを見てきました。 QGISでは、より高度な使用例のためのコマンドラインオプションを提供しています(場合によっては、コマンドラインオプションの代わりに環境変数を使用できます)。オプションのリストを取得するには、コマンドラインで qgis --help と入力します:

QGIS is a user friendly Open Source Geographic Information System.
Usage: /usr/bin/qgis.bin [OPTION] [FILE]
  OPTION:
        [--version]     display version information and exit
        [--snapshot filename]   emit snapshot of loaded datasets to given file
        [--width width] width of snapshot to emit
        [--height height]       height of snapshot to emit
        [--lang language]       use language for interface text (changes existing override)
        [--project projectfile] load the given QGIS project
        [--extent xmin,ymin,xmax,ymax]  set initial map extent
        [--nologo]      hide splash screen
        [--noversioncheck]      don't check for new version of QGIS at startup
        [--noplugins]   don't restore plugins on startup
        [--nocustomization]     don't apply GUI customization
        [--customizationfile path]      use the given ini file as GUI customization
        [--globalsettingsfile path]     use the given ini file as Global Settings (defaults)
        [--authdbdirectory path] use the given directory for authentication database
        [--code path]   run the given python file on load
        [--defaultui]   start by resetting user ui settings to default
        [--hide-browser]        hide the browser widget
        [--dxf-export filename.dxf]     emit dxf output of loaded datasets to given file
        [--dxf-extent xmin,ymin,xmax,ymax]      set extent to export to dxf
        [--dxf-symbology-mode none|symbollayer|feature] symbology mode for dxf output
        [--dxf-scale-denom scale]       scale for dxf output
        [--dxf-encoding encoding]       encoding to use for dxf output
        [--dxf-map-theme maptheme]      map theme to use for dxf output
        [--take-screenshots output_path]        take screen shots for the user documentation
        [--screenshots-categories categories]   specify the categories of screenshot to be used (see QgsAppScreenShots::Categories).
        [--profile name]        load a named profile from the user's profiles folder.
        [--profiles-path path]  path to store user profile folders. Will create profiles inside a {path}\profiles folder
        [--version-migration]   force the settings migration from older version if found
        [--openclprogramfolder]         path to the folder containing the sources for OpenCL programs.
        [--help]                this text
        [--]            treat all following arguments as FILEs

  FILE:
    Files specified on the command line can include rasters,
    vectors, and QGIS project files (.qgs and .qgz):
     1. Rasters - supported formats include GeoTiff, DEM
        and others supported by GDAL
     2. Vectors - supported formats include ESRI Shapefiles
        and others supported by OGR and PostgreSQL layers using
        the PostGIS extension

ちなみに

コマンドライン引数を利用する例

コマンドラインで1つまたは複数のデータファイルを指定することで、QGISを起動できます。たとえば、 qgis_sample_data ディレクトリにいると仮定すると、次のコマンドを使用することで、起動時にベクタレイヤとラスタファイルをロードするように設定されたQGISを起動できます: qgis ./raster/landcover.img ./gml/lakes.gml

9.6.1.1. --version

このオプションはQGISのバージョン情報を返します。

9.6.1.2. --snapshot

このオプションを使うとPNG形式で現在のビューのスナップショットを作れます。これは、多数のプロジェクトがあり、データからスナップショットを作成したい場合、または更新されたデータで同じプロジェクトのスナップショットを作成したい場合に便利です。

このオプションを使うと800x600 ピクセルのPNGファイルが作成されます。 --width--height を引数に加えることでサイズの調整ができます。 --snapshot の後にファイル名を指定できます。例えば:

qgis --snapshot my_image.png --width 1000 --height 600 --project my_project.qgs

9.6.1.3. --width

このオプションは、出力されるスナップショットの幅を返します( --snapshot と共に使用されます)。

9.6.1.4. --height

このオプションは、出力されるスナップショットの高さを返します( --snapshot と共に使用されます)。

9.6.1.5. --lang

地域に基づいて、QGISは正しい言語対応を選択します。言語を変更したいならば言語コードを指定できます。例えば、 qgis --lang it であればイタリア語対応でQGISを起動します。

9.6.1.6. --project

既存のプロジェクトファイルをQGISを起動することも可能です。プロジェクト名の後に --project コマンドラインオプションを追加するだけで、QGISは与えられたファイル内のすべてのレイヤーがロードされて開きます。

9.6.1.7. --extent

ある地図の領域を指定してQGISを起動する場合はこのオプションを使います.この場合 下記のようにカンマで区切られた書式の領域指定で領域を包含する長方形を指定する 必要があります:

--extent xmin,ymin,xmax,ymax

このオプションは -project オプションと組み合わせて、特定のプロジェクトを目的の範囲で開くときにおそらくより意味があります。

9.6.1.9. --noversioncheck

起動時にQGISの新しいバージョンの検索をスキップします。

9.6.1.10. --noplugins

起動時にプラグインのトラブルがある場合、起動時にプラグインのロードを無効にできます。それらのプラグインは後からプラグインマネージャで有効にすることができます。

9.6.1.11. --nocustomization

このオプションを使用すると、既存の GUIカスタマイズ は起動時に適用されません。これは、非表示のボタン、メニュー項目、ツールバーなどがQGISの起動時に表示されることを意味します。これは永続的な変更ではありません。このオプションなしでQGISを起動すると、カスタマイズが再度適用されます。

このオプションは、カスタマイズによって削除されたツールへのアクセスを一時的に許可する場合に役立ちます。

9.6.1.12. --customizationfile

このオプションを使用すると、起動時に使用されるUIカスタマイズファイルを定義できます。

9.6.1.13. --globalsettingsfile

このオプションを使用して、デフォルト設定とも呼ばれるグローバル設定ファイル( .ini )のパスを指定できます。指定されたファイルの設定は、元のインラインのデフォルト設定を置き換えますが、ユーザープロファイルの設定はそれらの最上に設定されます。デフォルトのグローバル設定は your_QGIS_PKG_path/resources/qgis_global_settings.ini にあります。

現在、設定を書き込むファイルを指定する方法はありません。したがって、元の設定ファイルのコピーを作成し、名前を変更し、適応させることができます。

qgis_global_setting.ini ファイルパスをネットワーク共有フォルダに設定すると、システム管理者は1つのファイルを編集するだけで複数のマシンのグローバル設定とデフォルトを変更できます。

The equivalent environment variable is QGIS_GLOBAL_SETTINGS_FILE.

9.6.1.14. --authdbdirectory

このオプションは --globalsettingsfile に似ていますが、認証データベースが保存およびロードされるディレクトリへのパスを定義します。

9.6.1.15. --code

This option can be used to run a given python file directly after QGIS has started.

For example, when you have a python file named load_alaska.py with following content:

from qgis.utils import iface
raster_file = "/home/gisadmin/Documents/qgis_sample_data/raster/landcover.img"
layer_name = "Alaska"
iface.addRasterLayer(raster_file, layer_name)

ファイル load_alaska.py が配置されているディレクトリにいると仮定して、QGISを起動し、ラスターファイルをロードできます。 landcover.img をし、次のコマンドを使用してレイヤーに名前「アラスカ」を付ける:

qgis --code load_alaska.py

9.6.1.16. --defaultui

ロード時に、ユーザーインターフェイス(UI)を既定の設定に 永続的にリセット します。このオプションは、パネルとツールバーの表示、位置、サイズを復元します。再度変更しない限り、次のセッションではデフォルトのUI設定が使用されます。

Notice that this option doesn't have any effect on GUI customization. Items hidden by GUI customization (e.g. the status bar) will remain hidden even using the --defaultui option. See also the --nocustomization option.

9.6.1.17. --hide-browser

ロード時に、ユーザーインターフェースから ブラウザ パネルを非表示にします。パネルを有効にするには、ツールバーのスペースを右クリックするか、 表示->パネルkde Linux KDEでは 設定->パネル )を使用します。

Unless it's enabled again, the Browser panel will remain hidden in the following sessions.

9.6.1.18. --dxf-*

これらのオプションは、DXFファイルにQGISプロジェクトをエクスポートするために使用できます。いくつかのオプションが用意されています:

  • --dxf-export : レイヤーを出力するDXFファイル名;

  • --dxf-extent : 最終DXFファイルの範囲;

  • --dxf-symbology-mode :ここでは、none(シンボルなし)、symbollayer(シンボルレイヤシンボル)、feature(地物シンボル)の値を使用できます。

  • --dxf-scale-denom: シンボルの縮尺分母;

  • --dxf-encoding: ファイルのエンコード

  • --dxf-map-theme: choose a map theme from the layer tree configuration.

9.6.1.19. --take-screenshots

ユーザドキュメントのスクリーンショットを撮ります。 --screenshots-categories とともに使用して、ドキュメントスクリーンショットのどのカテゴリ/セクションを作成するかをフィルターできます( QgsAppScreenShots::Categories 参照)。

9.6.1.20. --profile

ユーザのプロファイルフォルダから特定のプロファイルを使用してQGISを読み込みます。変更しない限り、選択したプロファイルは次のQGISセッションで使用されます。

9.6.1.21. --profiles-path

このオプションを使用すると、プロファイル(ユーザ設定)をロードして保存するパスを選択できます。 {path}\profiles フォルダ内にプロファイルを作成します。このフォルダには、設定、インストールされたプラグイン、プロセシングモデルとスクリプトなどが含まれます。

このオプションを使用すると、たとえば、すべてのプラグインと設定をフラッシュドライブで実行したり、ファイル共有サービスを使用して異なるコンピュータ間で設定を共有したりできます。

The equivalent environment variable is QGIS_CUSTOM_CONFIG_PATH.

9.6.1.22. --version-migration

If settings from an older version are found (e.g., the .qgis2 folder from QGIS 2.18), this option will import them into the default QGIS profile.

9.6.1.23. --openclprogramfolder

このオプションを使用すると、OpenCLプログラムの代替パスを指定できます。これは、既存のプログラムを置き換えることなく、プログラムの新しいバージョンをテストする開発者にとって便利です。

同等の環境変数は :menuselection: QGIS_OPENCL_PROGRAM_FOLDER です。

9.6.2. Deploying QGIS within an organization

カスタム構成ファイルを使用して組織内にQGISをデプロイする必要がある場合、最初に your_QGIS_PKG_path/resources/qgis_global_settings.ini にあるデフォルト設定ファイルの内容をコピーして貼り付ける必要があります。このファイルには、 [] で始まるブロックで識別されるデフォルトのセクションがすでに含まれています。これらのデフォルト値を保持し、ファイルの下部に独自のセクションを追加することをお勧めします。ファイル内でセクションが重複している場合、QGISは上から下に最後のセクションを取得します。

You can change allowVersionCheck=false to disable the QGIS version check.

新規インストール後に移行ウィンドウを表示したくない場合は、次のセクションが必要です。

[migration]
fileVersion=2
settings=true

If you want to add a custom variable in the global scope:

[variables]
organisation="Your organization"

To discover the possibilities of the settings INI file, we suggest that you set the config you would like in QGIS Desktop and then search for it in your INI file located in your profile using a text editor. A lot of settings can be set using the INI file such as WMS/WMTS, PostGIS connections, proxy settings, maptips…

Finally, you need to set the environment variable QGIS_GLOBAL_SETTINGS_FILE to the path of your customized file.

さらに、Pythonマクロ、カラーパレット、レイアウトテンプレート、プロジェクトテンプレートなどのファイルをQGISシステムディレクトリまたはQGISユーザープロファイルのいずれかに配置することもできます。

  • Layout templates must be deployed in the composer_templates directory.

  • Project templates must be deployed in the project_templates directory.

  • Custom Python macros must be deployed in the python directory.