5. はじめましょう

この章ではQGISのインストール、QGISサンプルデータのダウンロードとラスタとベクタデータを表示する簡単な最初のセッションの実行についての概要を提供します。

5.1. QGISのインストール

QGISプロジェクトでは、プラットフォームに応じてQGISをインストールするさまざまな方法を提供しています。

5.1.1. バイナリからインストールする

win MS Windowsおよび osx macOS用の標準インストーラが提供されています。 GNU / Linux各種 nix 向けにはバイナリパッケージ(rpmおよびdeb)またはソフトウェアリポジトリが提供されています。

あなたのオペレーティングシステム向けの更なる情報と手順については https://download.qgis.org を参照して下さい。

5.1.2. ソースからのインストール

If you need to build QGIS from source, please refer to the installation instructions. They are distributed with the QGIS source code in a file called INSTALL. You can also find them online at https://github.com/qgis/QGIS/blob/master/INSTALL.md.

開発中のバージョンではない特定のリリースをビルドする場合は、上記のリンクの master をリリースブランチ(通常は release-X_Y という形式)に置き換えてください(インストール手順は異なる場合があります)。

5.1.3. 外部メディアへのインストール

QGISを (すべてのプラグインと設定を含めて) フラッシュドライブにインストールすることが可能です。 このインストールは --profiles-path オプションを定義してデフォルトの user profile パスを上書きし QSettings にもこのディレクトリを設定すると利用できます。 詳しい情報は システム セクションを参照して下さい。

5.1.4. サンプルデータのダウンロード

このユーザガイドには QGISサンプルデータセット ( Alaska dataset ともよばれています) に基づく例が含まれています.

win Windows インストーラにはQGIS サンプルデータセットをインストールするオプションがあります.それがチェックされているとデータは Documents フォルダにダウンロードされ GIS Database というフォルダに置かれます。Windowsエキスプローラを利用すると利用しやすい場所にこのフォルダを移動できます。 もしQGISの初期インストールでサンプルデータインストールチェックボックスを選択していない場合は以下の作業のうちのどれかを行うことができます:

  • 既にあなたがお持ちのGISデータを利用する;

  • Download sample data from https://github.com/qgis/QGIS-Sample-Data/archive/master.zip and unzip the archive on any convenient location on your system.

  • QGISをアンインストールし、データのダウンロードオプションを指定して再インストールする(上記の方法が失敗した場合にのみ推奨)

nix osx For GNU/Linux and macOS, there are no dataset installation packages available as rpm, deb or dmg. To use the sample dataset, download it from https://github.com/qgis/QGIS-Sample-Data/archive/master.zip and unzip the archive on any convenient location on your system.

アラスカデータセットにはユーザーガイドサンプルとスクリーンショットで利用されているすべてのGISデータが含まれています。そこには小さなGRASSデータベースも含まれています。QGISサンプルデータセットの投影法はフィート単位のAlaska Albers Equal Area図法です。それのEPSGコードは2964です。

PROJCS["Albers Equal Area",
GEOGCS["NAD27",
DATUM["North_American_Datum_1927",
SPHEROID["Clarke 1866",6378206.4,294.978698213898,
AUTHORITY["EPSG","7008"]],
TOWGS84[-3,142,183,0,0,0,0],
AUTHORITY["EPSG","6267"]],
PRIMEM["Greenwich",0,
AUTHORITY["EPSG","8901"]],
UNIT["degree",0.0174532925199433,
AUTHORITY["EPSG","9108"]],
AUTHORITY["EPSG","4267"]],
PROJECTION["Albers_Conic_Equal_Area"],
PARAMETER["standard_parallel_1",55],
PARAMETER["standard_parallel_2",65],
PARAMETER["latitude_of_center",50],
PARAMETER["longitude_of_center",-154],
PARAMETER["false_easting",0],
PARAMETER["false_northing",0],
UNIT["us_survey_feet",0.3048006096012192]]

GRASS用のグラフィカルフロントエンドとしてQGISを使用したい場合は、公式のGRASS GISのウェブサイト https://grass.osgeo.org/download/sample-data/ でサンプルlocations(例えば、Spearfish やSouth Dakota)をみつけて選択することができます。

5.2. QGISの起動と終了

あなたのコンピュータの他のアプリケーションと同じような方法でQGISは起動できます.次のような方法でQGISを起動できます:

  • using nix the Applications menu, win the Start menu, or osx the Dock

  • アプリケーションフォルダまたはデスクトップショートカットのアイコンをダブルクリック

  • 既存のQGIS プロジェクトファイル( .qgz または .qgs という拡張子)をダブルクリックして下さい. 注 この操作ではそのプロジェクトも開かれます.

  • コマンドプロンプトで qgis とタイプして下さい ( QGIS のインストール場所が PATH に追加されているかインストールされているフォルダになたがいることが前提です)

QGISを終了させる場合は以下の方法を使って下さい:

  • nix win メニューオプション プロジェクト ‣ QGISを終了 またはショートカット Ctrlキー+Q を使用

  • osx QGIS ‣ QGISを終了 、またはショートカット Cmd+Q を使用します

  • またはアプリケーションメインインターフェースで上右の角にある赤いバツ印を使って下さい.

5.3. サンプルセッション:ラスタとベクタのレイヤをロードする

さて今では QGISをインストール されていて サンプルデータセット が利用できるようになっていますので、最初のサンプルセッションを例示します。この例の中ではラスタおよびベクタレイヤを視覚化します。以下を使用します:

  • landcover ラスターレイヤー( qgis_sample_data/raster/landcover.img

  • そして lakes ベクタレイヤ (qgis_sample_data/gml/lakes.gml)

Where qgis_sample_data represents the path to the unzipped dataset.

  1. Start QGIS as seen in QGISの起動と終了.

  2. QGIS にファイルをロードします:

    1. dataSourceManager データソースマネージャを開く アイコンをクリックします。データソースマネージャがブラウザモードで開きます。

    2. Browse to the folder qgis_sample_data/raster/

    3. ERDAS IMGファイル landcover.img を選択してダブルクリックします。データソースマネージャウィンドウを開いたまま、ランドカバーレイヤがバックグラウンドで追加されます。

      ../../../_images/add_raster1.png

      図 5.1 Adding data to a new project in QGIS

    4. lakes データをロードするためには qgis_sample_data/gml/ フォルダを開き, lakes.gml をダブルクリックして開いて下さい.

    5. 座標参照系の選択 ダイアログが開きます. In the フィルター メニューで, 2964 と打ち込んでください, フィルターされた座標参照系のリストが下に表示されます.

      ../../../_images/selectCRS.png

      図 5.2 Select the Coordinate Reference System of data

    6. Select the NAD27 / Alaska Alberts entry

    7. OK をクリックします

    8. データソースマネージャウィンドウを閉じて下さい

これで、プロジェクトの中で2つのレイヤをランダムな色で使用できるようになりました。 lakesレイヤーでカスタマイズを行いましょう。

  1. zoomIn Navigation ツールバーの Zoom In ツールを選択します

  2. 湖がある場所にズームします

  3. Double-click the lakes layer in the map legend to open the Properties dialog

  4. 湖の色を変えてみます:

    1. Click on the symbology Symbology tab

    2. 塗りつぶし色として青を選択しましょう.

      ../../../_images/selectFillColor.png

      図 5.3 湖の色を選択する

    3. OK を押して下さい. 地図キャンバスで湖が青で表示されます.

  5. 湖の名前を表示します:

    1. lakes レイヤ プロパティ ダイアログを再度開きます

    2. Click on the labeling Labels tab

    3. ドロップダウンメニューで 単一定義(single ) を選択するとラベリングが有効になります.

    4. Label with リストで, NAMES フィールドを選んでください.

      ../../../_images/showLabels.png

      図 5.4 Showing Lakes names

    5. Apply を押して下さい. 名前が境界線の上に表示されます.

  6. ラベルに縁取り(バッファ)を加えて読みやすくすることができます:

    1. 左のリストで バッファ タブをクリックして下さい

    2. checkbox テキストバッファを描画 をチェックして下さい

    3. バッファサイズとして 3 を選択して下さい

    4. Click Apply

    5. できばえがいいかどうかチェックしましょう, 必要があれば値を変えてみましょう.

    6. 最後に OK をクリックして レイヤプロパティ ダイアログを閉じて変更を適用して下さい.

地図にいくつかの整飾を加えてからQGISの外にエキスポートしてみましょう:

  1. Select View ‣ Decorations ‣ Scale Bar menu

  2. 開いたダイアログの中で checkbox スケールバーを有効にする オプションをチェックして下さい

  3. お好みにあわせてダイアログにあるオプションを設定して下さい

  4. 適用 を押します。

  5. 同じように地図整飾メニューではさらにいくつかのアイテムを (方位記号, 著作権ラベル...) いくつかのプロパティを指定して地図キャンバスに追加できます.

  6. Click Project ‣ Import/Export ‣ saveMapAsImage Export Map to Image...

  7. 開いたダイアログで 保存 を押して下さい

  8. ファイルの保存場所を選択して形式を確認した上で 保存 を再度押して下さい.

  9. 変更を .qgz プロジェクトファイルに保存する場合は プロジェクト ‣ fileSave 保存... を押して下さい.

これでおしまい! QGISでラスタレイヤとベクタレイヤを視覚化し、それらを構成して、他のソフトウェアで使用できる画像形式で地図を作成するのがどれほど簡単かわかったでしょう。次には、使用可能な機能、機能と設定、およびそれらの使用方法について詳しく説明します。

注釈

QGISをステップバイステップの演習で勉強したい場合は トレーニングマニュアル を参照して下さい.