3. 記述ルール

このセクションでは、このマニュアルの全体で使われている、一貫した記述ルールについて説明します。

3.1. GUI記述ルール

GUIの記述スタイルはGUIの外観をまねるように意図されています。一般的にはこのスタイルはツールチップが表示されていない状態を反映しています。ですからユーザーはGUIの外観をざっと眺めるだけで、マニュアルの指示と同じと思われるものを見つけることができます。

  • メニューからの選択: レイヤー‣ラスターレイヤーを追加 あるいは 設定‣ツールバー ‣デジタル化

  • ツール: addRasterLayer ラスターレイヤーを追加

  • ボタン: Save as Default

  • ダイアログボックスの見出し: レイヤーのプロパティ

  • タブ: 一般情報

  • チェックボックス checkbox 描画

  • ラジオボタン: radioButtonOn Postgis SRID radioButtonOff EPSG ID

  • 数値を選択: selectNumber

  • 文字を選択: selectString

  • ファイルの一覧から選択: ...

  • 色を選択: selectColor

  • スライダー: slider

  • テキストを入力: inputText

影がついているのはクリック可能なGUIコンポーネントであることを表します。

3.2. テキストやキーボードの記述ルール

このマニュアルでは、クラスやメソッドなど異なるエンティティを識別するために、テキストやキーボードショートカット、コーディングに関連するスタイルも使われています。これらのスタイルはQGISでの実際のテキストやコードの外観には一切対応していません。

  • ハイパーリンク: https://qgis.org

  • キーの組み合わせ: Ctrl+B を押す —— これはCtrl キーを押し下げたままでBキーを押すことを意味します。

  • ファイル名: lakes.shp

  • クラス名: NewLayer

  • メソッド: classFactory

  • サーバー: myhost.de

  • ユーザー入力テキスト: qgis --help

プログラムのコードは固定幅フォントで表示されます。

PROJCS["NAD_1927_Albers",
  GEOGCS["GCS_North_American_1927",

3.3. プラットフォーム固有の指示

GUIでの一連の操作と少量の文字列の場合は、インラインで(行内で)フォーマットされます。たとえば: nix win ファイル osx QGIS ‣ 終了してQGISを閉じる をクリック —— これは「Linux、UnixおよびWindowsプラットフォーム上では最初に [ファイル] メニューをクリックしてそれから [終了] する」こと、一方「macOSプラットフォーム上では最初に [QGIS] メニューをクリックしてそれから [終了] する」ことを示しています。

文字が多くなる場合はリストとしてフォーマットされることもあります。

  • nix xxx をしてください

  • win xxx をしてください

  • osx xxx をしてください

または段落としてフォーマットされることもあります。

nix osx Linux、Unix、Macintosh OSXプラットフォーム向けの解説です。文章中の解説手順に基づいて作業してください。

win Windowsプラットフォーム向けの解説です。文章中の解説手順に基づいて作業してください。

Screenshots that appear throughout the user guide have been created on different platforms.