6. プロジェクトファイルでの作業

6.1. QGIS プロジェクトの紹介

あなたの QGIS セッションの状態はプロジェクトと呼ばれます. QGIS は1つのプロジェクトで動作しています. プロジェクト特有、またはアプリケーション全体で決められている規定値が新規のプロジェクトのために設定できます ( オプション 参照). QGISではあなたのワークスペースの状態をメニューオプション プロジェクト ▶ fileSave 保存 または プロジェクト ▶ fileSaveAs 名前をつけて保存... を利用することで QGIS プロジェクトファイル に保存できます.

注釈

If the project has been modified the * symbol will appear in the title bar and QGIS will, by default, ask you if you would like to save the changes. This behavior is controlled by the checkbox Prompt to save project and data source changes when required setting under Settings ▶ Options ▶ General.

既存のプロジェクトをQGISに読み込むにはブラウザパネルを利用するか Project ▶ fileOpen Open..., Project ▶ New from template または Project ▶ Open Recent ▶ を利用して下さい.

起動時に, a list of Project TemplatesRecent Projects のリストが表示されます, そこには名前とファイルパス (最近の10プロジェクトの)が表示されます. Recent Projects リストは最近使ったプロジェクトを利用するときに便利です. エントリをダブルクリックするとプロジェクトかプロジェクトテンプレートが開きます. 新しいプロジェクトに自動的にレイヤを加えることができます. その後リストは消えマップキャンバスに移動します.

セッションをクリアし、新たに起動したい場合は、プロジェクト ▶ fileNew 新規 に進みます。ここでは、それが開かれたか、最後に保存されて以降、変更が行われた場合、既存のプロジェクトを保存するように求められます。

When you open a fresh project, the title bar will show Untitled Project until you save it.

../../../_images/new_project.png

図 6.1 QGIS で新しいプロジェクトを開始する

以下の情報がプロジェクトファイルに保存されます:

  • 追加されたレイヤー群

  • どのレイヤーをクエリできるか

  • レイヤーのプロパティ、記号化とスタイルを含めて

  • 地図ビューの投影法

  • 最後に表示された範囲

  • 印刷レイアウト

  • 設定付きの印刷レイアウト要素

  • 印刷レイアウト地図帳設定

  • デジタイズの設定

  • テーブルのリレーション

  • プロジェクトマクロ

  • プロジェクトデフォルトスタイル

  • プラグイン設定

  • プロジェクトプロパティ中のOWS 設定タブからのQGISサーバー設定

  • DBマネージャに格納されたクエリ

プロジェクトファイルはXML 形式で保存されます ( QGS/QGZ - QGISプロジェクトファイル形式 参照). このことはあなたがやりたいことがある場合QGISの外でファイルを編集することができることを意味します. プロジェクトファイルの形式はしばしば更新されます. QGISの古いバージョンのプロジェクトファイルは正しく機能しなくなる可能性があります.

注釈

デフォルトでQGISは開いたプロジェクトファイルとプログラムのバージョンが異なると警告します. この動作は 設定 ▶ オプション の  一般情報 タブ (checkbox 古いバージョンのQGISで保存されたプロジェクトファイルを開く時に警告する)で管理できます.

QGISで .qgs プロジェクトファイルを保存すると同じディレクトリに .qgs~ という拡張子のバックアップファイルが作成されます.

QGIS プロジェクトファイルの拡張子は .qgs です.しかし QGISから保存を行った場合 .qgz 拡張子で圧縮された形式で保存されるのがデフォルトです. The .qgs ファイルは .qgz ファイルに(zip アーカイブされています)組み込まれていて, auxiliary data 用に構成された sqlite データベース (.qgd) が同梱されています. それらのファイルは .qgz を解凍すると取得できます.

注釈

The Auxiliary Storage Properties mechanism makes a zipped project particularly useful, since it embeds auxiliary data.

プロジェクトでは以下のプロジェクトメニュー項目を使用してPostgreSQLデータベースに保存/ロードすることもできます.

  • プロジェクト ▶ 開く

  • プロジェクト ▶ 保存

両方のメニューアイテムにはリストされているような拡張プロジェクト保存実装のサブメニューがあります (PostgreSQL と GeoPackage). アクションをクリックすると GeoPackage 接続を選択するダイアログか PostgreSQL 接続,スキーマとプロジェクトを選択するダイアログが開きます.

Geopackage や PostgreSQLに格納されたプロジェクトは QGIS ブラウザパネルからロードすることもできます, それらをダブルクリックするか地図キャンバスまでドラッグして下さい.

6.2. 出力を作成する

QGISセッションから出力を作成するには、いくつかの方法があります。 QGIS プロジェクトの紹介 でプロジェクトファイルとして保存することについては既に説明しました。出力ファイルを作成する他の方法は:

  • イメージの作成: プロジェクト ▶ インポートとエクスポート ▶ saveMapAsImage 地図を画像にエクスポート... を使うと地図キャンバスに描画されているものをスケール,解像度,サイズを指定してイメージ形式 (PNG, JPG, TIFF...) で出力できます, ... ジオリファレンスされたイメージの出力も可能です. 詳細は マップビューのエクスポート を参照して下さい.

  • PDF ファイルへの出力: プロジェクト ▶ インポートとエクスポート ▶ 地図をPDFへエクスポート... を使うとスケール,解像度といくつかの設定(簡素化, ジオリファレンス, ...)を指定して地図キャンバスをPDFに出力することができます. 詳細は マップビューのエクスポート を参照して下さい.

  • DXF ファイルに出力する: プロジェクト ▶ インポートとエクスポート ▶ Export Project to プロジェクトをDXFにエクスポート... を選ぶとダイアログが開き 'シンボロジモード' 'シンボルの縮尺' と DXFに出力するベクタレイヤを選択できます. Through the 'シンボロジモード' を使うとQGISのオリジナルシンボルを忠実に出力できます ( Creating new DXF files 参照).

  • 地図デザイン: プロジェクト ▶ newLayout 新規印刷レイアウト... を選択すると現在のマップキャンバスをレイアウトして印刷するダイアログが表示されます ( 地図のレイアウト 参照).