9. QGISの設定

QGISでは高度な設定が可能です。 設定 メニューを通じて、以下のさまざまなツールを提供します。

9.1. オプション

options QGISのいくつかの基本オプションは、オプション ダイアログを使用して選択できます。メニューオプション 設定 ► options オプション を選択してください。必要に応じてオプションを変更できます。 オプションが有効となるためにはQGISの再起動が必要なものもあります。

以下で、オプションをカスタマイズできる画面をタブごとに説明します。

注釈

プラグインの設定はオプションダイアログに埋め込み可能

以下ではコア設定のみを紹介しますが、 インストールされたプラグイン が独自のオプションを標準のオプションダイアログ内に実装することで、このリストを拡張できることに注意してください。これにより、それぞれのプラグインが独自の設定ダイアログを持ち、それらのためだけに余分なメニュー項目を持つことを避けられます...

9.1.1. 一般情報

../../../_images/options_general.png

図 9.1 QGISの一般情報設定

システムロケールを上書き

デフォルトでは、QGIS の言語の設定と数字の扱いはオペレーティングシステムの設定に依存しています。このグループを有効にすると、動作をカスタマイズすることができます。

  • ユーザーインターフェイスの言語 で、GUIに適用する言語を選択する

  • ロケール(数字、日付、通貨の形式) で、日付や数字の入力・表示形式を選択する

  • checkbox 数字の3桁区切り記号を表示

選択された設定の概要とその設定がどのように解釈されるかについては、フレームの下部に表示されます。

アプリケーション

  • スタイル(QGISの再起動が必要) の選択、つまり、ウィジェットの外観やダイアログ内の位置を設定します。可能な値は、オペレーティングシステムによって異なります。

  • UIテーマ(QGISの再起動が必要) selectString の設定。'default'、 'Night Mapping'、または 'Blend of Gray' を使用できます。

  • アイコンサイズ selectString を定義します

  • フォントサイズ を定義します。フォントは radioButtonOn Qt のデフォルト か、ユーザ定義のフォントにすることができます。

  • メッセージやダイアログのタイムアウト設定 を変更します

  • unchecked 起動時にスプラッシュスクリーンを表示しない

  • checkbox QGISニュースを起動ページに表示する :QGISニュースフィードを起動ページに表示します。これによりプロジェクトのニュース(ユーザー/開発者の会議の日付と概要、コミュニティ調査、リリースのお知らせ、さまざまなヒント...)を知ることができます

  • checkbox 起動時にQGISバージョンを確認する は、新しいバージョンがリリースされたときに知らせてくれます

  • unchecked ネイティブの色選択ダイアログを使用するカラーセレクタ を参照)

  • unchecked モードレスデータソースマネージャダイアログ は、プロジェクトにレイヤを追加する際に データソースマネージャ ダイアログが開いたままでQGIS インターフェースの操作を可能にします。

プロジェクトファイル

  • 起動時に開くプロジェクト

    • 「ウェルカムページ」(デフォルト)は、 "ニュース” フィードやプロジェクトテンプレート、 ユーザープロファイル の最近使用したプロジェクト(とそのサムネイル画像)を表示します。デフォルトではプロジェクトは開かれません。

    • 「新規」: は、デフォルトのテンプレートに基づいて新しいプロジェクトを開きます。

    • 「最近」: は、最後に保存したプロジェクトを再度開きます。

    • 「テンプレートを指定」: は、特定のプロジェクトファイルを開きます。 ... ボタンを押して、デフォルトで使用するプロジェクトを指定します。

  • checkbox 既定のプロジェクトから新プロジェクトを作成する では、 現在のプロジェクトを既定のプロジェクトとして設定する または デフォルトにリセット ボタンをクリックすることができます。ファイルをブラウズして、ユーザー定義のプロジェクトテンプレートがあるディレクトリを指定することもできます。これは、 プロジェクト ► テンプレートから新規作成 に追加されます。最初に checkbox 既定のプロジェクトから新プロジェクトを作成する をアクティブにしてから、プロジェクトテンプレートフォルダにプロジェクトを保存してください。

  • checkbox 必要なときにプロジェクトおよびデータソースの変更を保存するか尋ねる は、変更が失われないよう、必要な時に尋ねます。

  • checkbox レイヤが削除されるときに確認プロンプトを表示する

  • checkbox 古いバージョンのQGISで保存されたプロジェクトファイルを開く時に警告する 古いバージョンのQGISで作成されたプロジェクトは常に開くことができますが、一旦プロジェクトを保存してしまうと、古いバージョンのQGISでは開けなくなることがあります。古いバージョンでは使用できない機能があるためです。

  • マクロを有効にする selectString このオプションは、プロジェクトのイベントのアクションを実行するために書かれたマクロを扱うためにあります。このオプションは、「利用しない」、「確認する」、「このセッションのみ」、「このセッションは無効」、「常に許可(非推奨)」の中で選択できます。

  • デフォルトパス 新しいプロジェクトで使用するファイルやレイヤへのパスの保尊方法を「絶対パス」とするか、プロジェクトに対する「相対パス」とするかを定義します。この設定は、プロジェクトレベルで上書きできます。

  • デフォルトのプロジェクトファイル形式

    • radioButtonOn QGZ Archive ファイル(補助データ付き)補助データ 参照)

    • radioButtonOff QGS Projectファイル(テキスト形式、補助データなし) :補助データはプロジェクトファイルとは別に、 .qgd ファイルに保存されます。

9.1.2. システム

SVGパス

Scalable Vector Graphic(SVG)シンボルを探すパス を追加・削除します。このSVG ファイルは地物のシンボルやラベル、印刷レイアウトの装飾に利用できます。

QGISのパスでSVGファイルを参照する別の方法として、 Remote or embedded file selector も参照してください。

プラグインパス

追加のC++プラグインライブラリを探すパス を追加・削除します。

ドキュメントのパス

QGISのヘルプを探すパス を追加・削除します。デフォルトでは、使用されているバージョンに対応する公式オンラインユーザーマニュアルへのリンクが追加されています。ただし、他のリンクを追加することもできます。ダイアログの ヘルプ ボタンをクリックするたびに一番上のリンクがチェックされ、対応するページが見つからない場合は次のリンクが順に試されるので、追加した他のリンクに上から下へと優先順位をつけられます。

注釈

ドキュメントはQGIS長期リリース(LTR)に対してのみバージョン管理され翻訳されています。つまり、通常のリリース(QGIS 3.0など)を実行している場合、ヘルプボタンはデフォルトで次のLTRマニュアルページ(3.4 LTR)を開くため、新しいリリース(3.2および3.4​​)の機能の説明が含まれる場合があります。 LTRドキュメントが利用できない場合は、新しいバージョンと開発バージョンの機能が記載された testing ドキュメントが使用されます。

設定

ユーザーインターフェイスを既定の設定にリセット(QGISの再起動が必要) は、何か カスタマイズ をした後で、設定をリセットする際に役立ちます。

環境

../../../_images/sys-env-options.png

図 9.2 QGISのシステム環境変数

環境 グループでは、システム環境変数を表示し、多くの設定を行うことができます。これはMacなど、GUIアプリケーションが必ずしもユーザのシェル環境を継承しないプラットフォームで役立ちます。また、Processingツールボックス(SAGA、GRASSなど)によって制御される外部ツールセットの環境変数を設定および表示したり、ソースコードの特定のセクションのデバッグ出力をオンにしたりする場合にも役立ちます。

checkbox カスタム変数を用いる(区切り文字を含む - QGISの再起動が必要) 。変数を 追加 および 削除 できます。定義済みの環境変数は 現在の環境変数 に表示され、 checkbox QGIS固有の変数のみ表示する を有効にすると、それらをフィルタできます。

9.1.3. 座標参照系(CRS)

注釈

QGIS がレイヤの投影をどのように扱っているかについての詳細は、専用のセクションである 投影法の利用方法 を読んでください。

../../../_images/options_crs.png

図 9.3 QGISのCRS設定

プロジェクトの座標参照系(CRS)

新しいプロジェクトのCRSを自動的に設定するオプションがあります。

  • radioButtonOn最初のレイヤのCRSを使う : プロジェクトのCRSは、ロードされた最初のレイヤのCRSに設定されます

  • radioButtonOff デフォルトのCRSを使う :事前に選択されたCRSがデフォルトで新しいプロジェクトに適用され、プロジェクトにレイヤを追加しても変更されません。

この選択内容は保存され、以降のQGISセッションでも使われます。プロジェクトの座標参照系は、 プロジェクト ► プロパティ... ► 座標参照系(CRS) タブから上書きすることができます。

レイヤのCRS

レイヤのデフォルトCRS は、レイヤを作成した時のデフォルトのCRSを選択します

新しいレイヤが作成されるか、座標参照系のないレイヤが読み込まれた時に実行するアクションを定義することもできます。

  • radioButtonOn 未知のCRSのまま (何もしない)

  • radioButtonOff CRSダイアログを表示

  • radioButtonOff プロジェクトCRSを使う

  • radioButtonOff デフォルトCRSを使う

精度に関する警告

精度警告の閾値 指定した距離を超えるCRSの誤差が生じる場合にのみ、警告を表示します。これは、データセットを直接作成するか修正し、低い精度のデータムアンサンブルに基づいたCRSを選択する場合に発生します。デフォルトでは、不正確な場合には警告を 常に表示 するようになっています。 PROJ 8.0 以降を使用するQGISバージョンで利用できます。

unchecked CRS精度警告を表示 チェックを入れた場合、精度に問題のあるCRS(すなわち、座標エポックがない動的CRS、またはユーザーが設定した限界を超える固有の誤差を持つデータムアンサンブルに基づくCRS)のレイヤには、精度が低いレイヤであることを表すため、 レイヤ パネルで indicatorLowAccuracy の警告アイコンが表示されます。

これは、エンジニアリングやBIM、アセットマネジメントなど、メートル級 / サブメートル級の不正確さが非常に危険または高価になる可能性のある分野での使用を想定しています。

unchecked 平面計測: は、新しく作成したプロジェクトで "平面計測" プロパティをデフォルトとするよう設定します。

9.1.4. 変換

transformation 変換 タブは、プロジェクトにレイヤが読み込まれる際やレイヤを再投影する際に適用される座標変換や操作を設定することができます。

../../../_images/options_transformations.png

図 9.4 変換

デフォルトの測地系変換

このグループでは、レイヤを別のCRSに再投影する方法を以下のいずれかで制御できます。

  • QGIS のデフォルト変換設定を使用して自動的に処理する

  • 以下のカスタム設定でユーザがより細かく制御する

    • checkbox 測地系変換が複数利用可能な場合は尋ねる

    • デフォルトで適用する測地系変換の事前定義リスト。詳細は 測地系変換 を参照してください。

9.1.5. データソース

../../../_images/options_data_sources.png

図 9.5 QGISのデータソース設定

地物属性とテーブル

  • checkbox ドックウィンドウとして属性テーブルを開く

  • 地物のコピー は、地物をコピーして他のアプリケーションに貼り付けるときの形式として、 「プレーンテキスト(ジオメトリなし)」、「プレーンテキスト(WKTジオメトリ)」もしくは、「GeoJSON」のいずれかを設定します。

  • 属性テーブルの動作 selectString :属性テーブルを開いた時のフィルタを設定します。 「全地物を表示」、「選択した地物を表示」、「地図上に表示されている地物を表示」の3つうちのいずれかです。

  • デフォルトの表示形式 :属性テーブルを開いた時の表示モードを定義します。「直前の表示形式」、「テーブル表示」、または「フォーム表示」のいずれかです。

  • 属性テーブル行キャッシュ selectNumber 。この行キャッシュは、最後にロードされた属性をN行分保存することで、属性テーブルでの作業をより速くできるようにします。キャッシュは属性テーブルを閉じるときに削除されます。

  • NULL値の表示方法 。NULL値を含んだデータフィールドの値を定義できます。

ちなみに

巨大な属性テーブルを開く際の動作を改善する

大量のレコードを含むレイヤを操作する場合、ダイアログがレイヤ内のすべての行をリクエストすると、属性テーブルを開くのが遅くなることがあります。 属性テーブルの動作地図上に表示されている地物を表示 に設定すると、QGISはテーブルを開くときに現在の地図キャンバス内にある地物だけをリクエストするため、データの読み込みが早くなります。

この属性テーブルインスタンスのデータは、開いたキャンバスの範囲に常に関連付けられます。つまり、そのテーブル内の 全地物を表示 を選択すると新しい地物は表示されません。ただし、キャンバス範囲を変更して、属性テーブルの 地図上に表示されている地物を表示 オプションを選択すると、表示されている地物のセットを更新できます。

データソースの操作

  • ブラウザドック内で有効なアイテムをスキャンする selectString 。「拡張子をチェック」と「ファイルの内容をチェック」のどちらかを選択できます。

  • ブラウザドック内で圧縮ファイル(.zip)にあるコンテンツをスキャンする selectString は、圧縮ファイルの情報を確認する際に、ブラウザパネル下部にプロパティウィジェット情報をどの程度詳細に表示するかを定義します。 「No」、「ベーシックスキャン」、「フルスキャン」の選択肢があります。

  • ラスタサブレイヤを開くときにプロンプトを表示する :ラスタファイルの一部はサブレイヤをサポートしています。 --- GDALでは「サブデータセット」と呼ばれています。一例としては、netCDF ファイルがあります。 --- netCDF変数が多数ある場合、GDAL はすべての変数をサブデータセットとみなします。このオプションでは、サブレイヤを含むファイルを開いたときにサブレイヤをどのように扱うかを制御できます。これには次の選択肢があります。

    • 「常に」: 毎回、確認プロンプトを表示します(サブレイヤが存在する場合)

    • 「必要な場合」: レイヤがバンドは無いがサブレイヤを持っている場合にプロンプトを表示します

    • 「利用しない」:プロンプトを表示せず、何もロードしません

    • 「すべて読み込む」:プロンプトは表示しませんが、すべてのサブレイヤをロードします

  • checkbox 内容が変更された時、自動でブラウザのディレクトリが更新されます :デフォルトで行われる ブラウザ パネル内のディレクトリの監視を、実行しないように手動で設定できます(例:ネットワーク遅延による潜在的な速度低下を回避するため)。

ローカルデータのパス

任意の種類のファイルベースのデータソースに対して、ローカライズされたパスを使用することが可能です。ローカライズされたパスとは、データソースの位置を抽象化するために使用されるパスのリストです。例えば、 C:\my_maps がローカルデータのパスのリストにあるとすると、 C:\my_maps\my_country\ortho.tif をデータソースとして持つレイヤは、 localized:my_country\ortho.tif としてプロジェクト内に保存されます。

パスは、優先順位の高い順にリストアップされています。言い換えると、QGIS はまず最初のパスでファイルを探し、次に 2 番目のパスで、といった具合にファイルを探します。

ブラウザに表示しないパス

このウィジェットは ブラウザパネル から非表示にすることを選択したすべてのフォルダをリストアップします。リストからフォルダパスを削除すると、 ブラウザ パネルで表示できるようになります。

9.1.6. レンダリング

../../../_images/rendering_menu.png

図 9.6 レンダリングタブ

レンダリング動作

  • checkbox 地図に追加されたレイヤはデフォルトで表示する :このオプションのチェックを外すと、新しいレイヤが読み込まれたときにキャンバスにレンダリングされてプロセスが遅くなるのを避けられるため、複数のレイヤを読み込む際に便利です。

  • checkbox 再描画の速度を上げられる時にレンダリングのキャッシュを利用する

  • checkbox レイヤの描画を複数のCPUコアを使って並列に行う

  • checkbox 最大コア数

  • 更新間隔(デフォルトは250 msです)

  • checkbox 新規追加レイヤの地物の簡素化をデフォルトで有効にする

  • 簡素化閾値

  • 簡素化のアルゴリズム: このオプションは、地物のローカルな簡素化を "オンザフライ" で実行し、ジオメトリのレンダリングを高速化します。この簡素化は、データプロバイダからフェッチされたジオメトリを変更することはしません。この違いは地物ジオメトリを使用する式(面積の計算など)を使用する場合に重要です。地物ジオメトリを使用する計算は、簡素化されたジオメトリではなく元のジオメトリに対して行われることが保証されます。地物の簡素化のためにQGISでは「距離」(デフォルトの設定)、「グリッドにスナップ」、そして「Visvalingam」の3つのアルゴリズムを提供しています。

  • unchecked 可能であればプロバイダ側で簡素化する: ジオメトリはプロバイダ(PostGIS、Oracle...)によって簡素化されます。ローカル側での簡素化と異なり、ジオメトリに関連する計算は簡素化の影響を受けます。

  • レイヤを簡素化する最大スケール

  • doubleSpinBox 拡大レベル (詳細は 拡大 を参照)

注釈

グローバル設定に加えて、特定のレイヤに対しても レイヤのプロパティ ► レンダリング メニューから地物の簡素化の設定ができます。

レンダリング品質

  • checkbox 線のジャギーを目立たなくする(描画速度が若干低下します)

曲線の分割

  • 分割の許容差:この設定は、円弧の描画方法を制御します。最大角度(2つの連続した頂点と曲線の中心の間の角度を度単位で指定)または最大差(2つの頂点のセグメントと曲線との間の距離を地図単位で指定)が より小さい ほど、 より多くの直線 セグメントがレンダリング中に使用されます。

  • 許容誤差のタイプ :近似直線と曲線の間での 最大角度 または 最大差 を指定します。

ラスタ

  • RGB バンド選択 で、赤、緑、青のバンドの番号を定義できます。

  • 拡大リサンプリング縮小リサンプリング の方法を定義できます。 拡大リサンプリング の場合、「最近傍(Nearest Neighbour)」、「バイリニア(Bilinear)」、「キュービック(Cubic)」の3つのリサンプリング方法から選択できます。 縮小リサンプリング の場合、「最近傍(Nearest Neighbour)」と「平均(Average)」のどちらかを選択できます。 オーバーサンプリング 値も設定できます(0.0 から 99.99 の間。値が大きほどQGISの処理がより多くなります。デフォルト値は2.0です)。

コントラスト

コントラストの強調オプションを 単バンドグレーマルチバンドカラー(1バイト/バンド) または マルチバンドカラー(1バイト超/バンド) のラスタファイルに適用できます。それぞれについて、次を設定できます:

  • 使用する アルゴリズム の値は、「強調なし」、「最小最大範囲に引き伸ばす」、「最小最大範囲に引き伸ばしカット」、あるいは「最小値から最大値までの範囲以外は無視」のいずれかです。

  • 適用する 制限(最小/最大) の値は、「累積ピクセル数のカット」、「最小 / 最大」、「平均 +/- 標準偏差」のいずれかです。

ラスタファイルのレンダリングに対しては、次のオプションも定義することができます。

  • 累積ピクセル数のカット制限

  • 標準偏差の乗数

デバッグ

  • checkbox キャンバスの更新 ログメッセージ パネルでレンダリング時間のデバッグを行えます。

9.1.7. キャンバスと凡例

../../../_images/options_canvas_legend.png

図 9.7 キャンバスと凡例

このプロパティでは、以下を設定できます:

  • デフォルトの体裁(プロジェクトプロパティに上書きされます)選択物の色 および 背景色

  • レイヤの凡例 のインタラクションに関する設定:

    • 凡例をダブルクリックした場合の動作 selectString ダブルクリックで、「レイヤのプロパティを開く」、「属性テーブルを開く」、「レイヤスタイルドックを開く」のいずれかを行うことができます。

    • checkbox レイヤタイトルに分類属性を表示する たとえばカテゴリ値による定義やルールによる定義のレンダラを適用する場合、レイヤパネルに分類に使用した属性名を表示します(詳細は シンボロジプロパティ を参照)。

    • WMS getLegendGraphic 解像度

    • 最小凡例シンボルサイズ最大凡例シンボルサイズ は、 レイヤ パネル内で表示するシンボルサイズをコントロールします

  • 遅延(ミリ秒単位) レイヤの 地図のtips が表示されるまでの遅延時間です。

  • QGISを checkbox スクリーンDPIにする :これを有効にすると、QGISはモニタの物理DPIに応じて物理的に正確なスケールで画面上にマップキャンバスを表示しようとします。特定の表示サイズのシンボロジも同様に、正確なスケールでレンダリングされます。例えば、10mmのシンボルは、画面上で10mmで表示されます。ただし、キャンバス上のラベルのフォントサイズは、QGISのUIや他のアプリケーションのフォントサイズとは異なる場合があります。この設定をオフにするとQGISはOSの論理DPIを使用するため、システム上の他のアプリケーションとDPIが一致するようになります。ただし、キャンバスのスケールとシンボロジのサイズは画面上では物理的に不正確な場合があります。特に、高DPIのスクリーンでは、シンボロジが非常に小さく表示される可能性があります。

    ベストな体験のためには、 checkbox スクリーンDPIにする を有効にすることを推奨します。特に、複数のモニタや異なる種類のモニタを使用し、視覚的に高品質なマップを表示する場合には、これを有効にしてください。 checkbox スクリーンDPIにする を無効にして生成される出力は、画面上での使用のみを目的とした地図に適しています。特に、フォントサイズを他のアプリケーションと一致させたい場合にはこれを無効としてください。

注釈

印刷レイアウトのレンダリングは、 スクリーンDPIにする の設定の影響を受けません。印刷レイアウトは常に、ターゲット出力デバイスに指定されたDPIとなります。また、この設定は、OSによって報告される物理スクリーンDPIを使用することに注意してください。これは、全てのディスプレイについて正確であるとは限りません。

9.1.8. ツール

../../../_images/options_map_tools.png

図 9.8 QGISのマップツール設定

このタブは 地物情報表示ツール の動作に関するいくつかのオプションを提供しています。

  • 地物検索・Tips表示のための検索半径 は、この許容範囲内でクリックする限り地物情報表示ツールが結果を表示する許容距離です。

  • ハイライト色 は、地物情報表示されている地物を強調表示する色を選択できます。

  • バッファ は、地物情報表示でハイライトされている地物の輪郭に表示するバッファの距離を決定します。

  • 最小幅 ハイライト表示されるオブジェクトの輪郭の厚さを決定します。

計測ツール

  • 計測ツールの ラバーバンド色 を定義します。

  • 小数点以下桁数 を定義します

  • checkbox 基本単位の維持 は、大きい数を自動的に変換しません(例えば、メートルをキロメートルに変換するなど)

  • 優先される距離の単位: は、「メートル」、「キロメートル」、「フィート」、「ヤード」、「マイル」、「海里」、「センチメートル」、「ミリメートル」、「度」、「地図単位」のいずれかです。

  • 優先される面積の単位: は、「平方メートル」、「平方キロメートル」、「平方フィート」、「平方ヤード」、「平方マイル」、「ヘクタール」、「エーカー」、「平方海里」、「平方センチメートル」、「平方ミリメートル」、「平方度」、「地図単位」のいずれかです。

  • 優先される角度の単位: は、「度」、「ラジアン」、「グラード」、「弧の分」、「弧の秒」、「Turns/revolutions」、「ミリラジアン(SI定義)」、「ミル(NATO定義)」のいずれかです。

座標と方位を表示

  • 新規プロジェクトのデフォルト方位フォーマット の定義:マップキャンバスをパンした際にステータスバーに表示されるマウス座標に使用する書式を定義します。この設定はプロジェクトのプロパティダイアログで上書きすることができます。

ズーム

  • ズームツールまたはマウスホイールの ズーム倍率 を定義します。

定義済み縮尺

ここには、ステータスバーの 縮尺 ドロップダウンウィジェットで表示される事前定義縮尺のリストがあり、素早く拡大縮小するために利用できます。 symbologyAdd ボタンと symbologyRemove ボタンを使用して、個人用の縮尺を追加・削除できます。また、縮尺を .XML ファイルからインポートしたり、ファイルにエクスポートすることもできます。なお、変更した内容を削除して、デフォルトのリストにリセットすることもできます。

9.1.9. 3D

../../../_images/options_3d.png

図 9.9 3D

3d 3D メニューでは、 3Dマップビュー に使用される設定の一部をデフォルト設定できます。これは、 デフォルトカメラ設定 の設定を参照します:

  • 投影タイプ :3Dシーンを以下の設定で表示できます。

    • 透視投影(Perspective) (デフォルト):平行な線が遠方で合流しているように見える投影法です。物体はカメラから遠ざかるにつれて縮小して見えます。

    • 正射投影(Orthogonal) :平行な線は平行なままに見える投影法です。物体はカメラ距離にかかわらず同じ大きさに見えます。

  • カメラの 視覚 :透視投影(Perspective)モードにのみ関係し、デフォルトの垂直方向の視野を度単位で指定し、カメラが見えるシーンの範囲を決定します。デフォルトの値は 45° です。

  • ナビゲーションモード :3Dシーンとやりとりするためのさまざまな手段を提供します。利用可能なモードは以下の2つです:

    • 地形モード :シーンをナビケートする際、カメラは地形の表面の固定点の周りをまわるように動きます。

    • ウォークモード(一人称視点)

    選択したモードによって、 ナビゲーションコマンド は異なります。

  • 移動速度

  • 垂直軸を逆転 :垂直軸方向の動きを、通常時の動作とは反対にします。 ウォークモード(一人称視点) での動きにのみ影響します。以下のいずれかに設定できます:

    • 利用しない

    • ドラッグ時のみ :クリックしてドラッグすることでカメラを回転させている時のみ、垂直軸の動きを反転させます

    • 常に :クリックしてドラッグでカメラを回転させる場合と、カメラの動きがカーソルにロックされている( ~ キーを押す)場合の両方で、垂直軸の動きを反転させます。

9.1.10.

../../../_images/options_colors.png

図 9.10

このメニューでは、アプリケーション全体で使用される色のパレットを カラーセレクタウィジェット で作成・更新できます。以下から選択できます。

  • 最近使った色 :最近使用した色を表示します

  • 標準色 :デフォルトの色パレットです

  • プロジェクトの色 :現在のプロジェクトに固有の色のセットです(詳細は 既定スタイル を参照してください)。

  • New layer colors :新しいレイヤがQGISに追加されたときにデフォルトで使用される色のセットです。

  • あるいは、パレットコンボボックスの横にある ... ボタンを押して、カスタムパレットを新規作成もしくはインポートできます。

デフォルトでは、 最近使った色標準色、および プロジェクトの色 パレットは削除できず、色ボタンドロップダウンに表示されるように設定されています。カスタムパレットは 色ボタンに表示 オプションで、ウィジェットに追加できます。

どのパレットでも、フレームの横にあるツールセットを使って色のリストを管理することができます。

  • symbologyAdd 色を追加 あるいは symbologyRemove 色の削除

  • editCopy 色のコピー あるいは editPaste 色の貼り付け

  • fileOpen ファイルから色のインポート あるいは fileSave 色のエクスポート で色のセットを .gpl ファイルからインポート / ファイルへエクスポート

リスト内の色をダブルクリックして カラーセレクタ ダイアログで色を調整したり、置き換えたりできます。 ラベル 列をダブルクリックして、色の名前を変更することもできます。

9.1.11. デジタイズ

../../../_images/options_digitizing.png

図 9.11 QGISのデジタイズ設定

このタブでは、 ベクタレイヤを編集する (属性とジオメトリ)際の一般的な設定を行います。

地物の作成

  • checkbox 地物作成後に属性フォームをポップアップさせない :この選択は各レイヤのプロパティダイアログで上書きできます。

  • checkbox 最後に入力した値を利用する :各賊子絵の最後に使用した値を記憶し、次にデジタイズする地物のデフォルト値として使用します。これはレイヤ毎に動作します。この動作は、フィールド毎でも制御することができます( フィールドの動作を設定する 参照)。

  • ジオメトリの検証 :多数のノードを持つ複雑なラインやポリゴンを編集すると、レンダリングが非常に遅くなる可能性があります。これは、QGISのデフォルトのジオメトリ検証は長時間かかることがあるためです。レンダリングを高速化するため、GEOSジオメトリ検証を選択する(GEOS 3.3以降)か、または検証をオフにすることが可能です。GEOSジオメトリの検証ははるかに高速ですが、最初に見つかったジオメトリの問題しか報告されないという欠点があります。

    選択範囲によっては、ジオメトリエラーの報告が他と異なる場合があることに注意してください(詳細は エラーメッセージの種類と意味 を参照)

  • デフォルトのZ値 は、新しい3次元地物を作成するときに使うZ値のデフォルト値です。

ラバーバンド

  • ラバーバンドの 線幅線の色 および 塗りつぶし色 を定義します。

  • 頂点の編集中にラバーバンドを更新しない

スナップ

  • checkbox デフォルトでスナップを有効にする プロジェクトを開いたときにスナップを有効にします

  • 既定のスナップモード を定義します selectString (「頂点」、「セグメント」、「重心点」、「セグメントの中央」、「線のエンドポイント」、「領域(Area)」)

  • 既定のスナップ許容量 を地図上の単位またはピクセルで指定します

  • 頂点編集用検索半径 を地図上の単位またはピクセルで指定します

  • メインダイアログの表示(QGISの再起動が必要) : は、スナップオプションが「ダイアログ」として開かれるか、「ドック」として開かれるかを設定します。

  • スナップマーカーの色

  • checkbox スナップツールチップを表示する スナップしようとしている地物のあるレイヤの名前などを表示します。複数の地物が重なり合っている場合に役立ちます。

  • checkbox 非表示の地物に対してもスナップを有効にする (「非表示の地物」とは、マップキャンバス上に現れていない地物のことです)

頂点マーカー

  • checkbox 選択地物のみマーカーを表示する

  • マーカースタイル selectString 頂点マーカースタイルを定義します(「クロス」(デフォルト)、「半透明円」または「なし」)

  • マーカーの大きさ(単位ミリ) 頂点マーカーの大きさを定義します

曲線オフセットツール

次の3つのオプションについては、 先進的デジタイズ 中の offsetCurve オフセット曲線 ツールを参照してください。さまざまな設定により、オフセット線の形状に影響を与えることができます。これらのオプションはGEOS 3.3 以降で使用可能です。

  • 継ぎ目スタイル :「Round」「Miter」「Bevel」

  • 象限セグメント

  • miter 制限

トレース

checkbox トレースを曲線に変換する(実験的) を有効にすると、デジタイズ中に曲線セグメントを作成できます。データプロバイダが曲線地物をサポートしている必要があることに留意してください。

9.1.12. レイアウト

../../../_images/options_layouts.png

図 9.12 QGISのレイアウト設定

レイアウトのデフォルト

印刷レイアウト で使用される デフォルトフォント を定義できます。

グリッドの外観

  • グリッドスタイル selectString (「塗りつぶし」、「点」、「十字」)を定義します。

  • グリッド色 を定義します

グリッドとガイドのデフォルト

  • グリッド間隔 selectNumber を定義します

  • グリッドオフセット selectNumber を X方向とY方向で定義します

  • スナップ許容量 selectNumber を定義します

レイアウトのパス

  • 追加のプリントテンプレートを探すパス の定義:新しい印刷レイアウトを作成する際に使用する、カスタムの印刷レイアウトテンプレートが保存されたフォルダのリストです。

9.1.13. GDAL

GDAL は地理空間データのためのデータ変換ライブラリで、多数のベクタ形式やラスタ形式をサポートしています。GDALはデータの読み込みと(大抵の場合)これらの形式でデータを書き出すためのドライバを提供しています。 GDAL タブではラスタ形式およびベクタ形式用のドライバと、その機能を公開しています。

9.1.13.1. GDALのラスタドライバとベクタドライバ

複数のGDALドライバが利用可能な場合があるため、 ラスタドライバベクタドライバ のタブでは、読み書きにどのGDALドライバを有効にするかを定義できます。

../../../_images/options_gdal.png

図 9.13 QGISのGDAL設定 - ラスタドライバ

ちなみに

読み取り・書き込みアクセスが可能( rw+(v) )なラスタドライバをダブルクリックすると、 作成オプションの編集 ダイアログが開き、作成オプションをカスタマイズできます。

9.1.13.2. ラスタドライバオプション

このフレームでは、読み取りおよび書き込みアクセスをサポートするラスタドライバの動作をカスタマイズする方法を提供します。

  • 作成オプションを編集: ファイル変換の際に使うさまざまなプロファイルを編集または追加することができます。すなわち、ラスタファイルを出力する際に使用するパラメータ(圧縮の種類と圧縮レベル、ブロックサイズ、全体図、測色、アルファ... )の事前に定義された組み合わせのセットを編集・追加できます。パラメータはドライバに依存します。

    ../../../_images/gdalCreateOptions.png

    図 9.14 オプションプロファイルの作成サンプル(GeoTiff ドライバ)

    ダイアログの上部には現在のプロファイルが一覧表示され、新しいプロファイルを追加したり、削除したりできます。プロファイルを変更した場合に、デフォルトのパラメータにリセットすることもできます。一部のドライバ(GeoTiff など)には、プロファイルのサンプルがあります。

    ダイアログの下部では、以下の操作ができます:

    • symbologyAdd ボタンを押すと、パラメータの名前と値を入力できる行を追加します

    • symbologyRemove ボタンを押すと、選択したパラメータを削除します

    • 検証 ボタンをクリックすると、指定したフォーマットに対して入力した作成オプションが有効であるかを確認します

    • ヘルプ ボタンを押して使用するパラメータを見つけるか、 GDAL raster drivers documentation を参照してください。

  • ピラミッドオプションを編集

    ../../../_images/gdalPyramidsOptions.png

    図 9.15 ピラミッドプロファイルのサンプル

9.1.14. 変数

変数 タブには、グローバルレベルで利用可能なすべての変数がリストされています。

ここではグローバルレベルの変数の管理もできます。 symbologyAdd ボタンをクリックして、グローバルレベルの新しいカスタム変数を追加します。同様に、リストからカスタムグローバルレベル変数を選択し、 symbologyRemove ボタンを押して削除します。

変数の詳細については、 値を変数に格納する セクションを参照してください。

../../../_images/options_variables_global.png

図 9.16 QGIS の変数設定

9.1.15. 認証

認証 タブでは、認証設定を設定し、PKI証明書を管理できます。詳細は 認証システム 参照。

../../../_images/auth-editor-configs2.png

図 9.17 QGISの認証設定

9.1.16. ネットワーク

一般情報

  • ネットワークリクエストのタイムアウト(ミリ秒) を定義します。デフォルトは 60000 ミリ秒です

  • WMS Capabilitiesのデフォルト有効期間(hours) を定義します。デフォルトは 24時間です

  • WMS-C/WMTS タイルのデフォルト有効期間(hours) を定義します。デフォルトは 24時間です

  • タイル / 地物リクエストエラーの場合の最大再試行 の回数を指定します

  • User-Agent を定義します

../../../_images/proxy-settings.png

図 9.18 QGISでのプロキシ設定

キャッシュ設定

キャッシュの ディレクトリサイズ[KiB] を定義します。また、 SSL エラーで接続認証キャッシュを自動的に消去する(推奨) ためのツールを提供します。

ウェブアクセスのプロキシ

  • checkbox ウェブ接続にプロキシを使用する

  • 必要に応じて プロキシタイプ selectString を設定し、「ホスト」と「ポート」を定義します。利用可能なプロキシタイプは以下の通りです。

    • Default Proxy: プロキシはシステムのプロキシ設定をもとに決定されます

    • Socks5Proxy: あらゆる種類の接続に対応した一般的なプロキシです。TCP、UDP、ポートへのバインディング (入力コネクション)と認証をサポートします。

    • HttpProxy: "CONNECT" コマンドで実装され、外向きのTCPコネクションのみサポートしています。また、認証をサポートしています。

    • HttpCachingProxy: 通常のHTTPコマンドを使って実装され、HTTPリクエストのコンテキストでのみ役に立ちます。

    • FtpCachingProxy:FTPプロキシを使用して実装されています。FTPリクエストのコンテキストでのみ役に立ちます。

プロキシの資格情報は 認証ウィジェット を使用して設定します。

プロキシ設定の下のテキストボックスにいくつかの除外URLを追加することができます( 図 9.18 を参照)。ターゲットURLがこのテキストボックスにリストされた文字列の1つで始まる場合、プロキシは使用されません。

さまざまなプロキシ設定に関するより詳細な情報が必要な場合は、 https://doc.qt.io/qt-5.9/qnetworkproxy.html#ProxyType-enum にあるQTライブラリのマニュアルを参照してください。

ちなみに

プロキシの利用

プロキシを使うのは時に厄介なことがあります。上記のようなプロキシタイプを使って「試行錯誤」し、自分のケースでうまくいくかどうかを確認ながら進めていくのがよいでしょう。

9.1.17. ロケータ

search ロケータ タブでは、 ロケータバー の設定を行えます。 これはステータスバーにあるクイック検索ウィジェットで、アプリケーション内の検索を実行できます。デフォルトのフィルタ(や接頭辞)なども設定できます。

../../../_images/options_locator.png

図 9.19 QGISのロケータ設定

  • プロジェクトのレイヤ (l): レイヤ パネル内のレイヤを検索し、選択します。

  • プロジェクトのレイアウト (pl): 印刷レイアウトを検索し、開きます。

  • アクション (.): QGISのアクションを検索し、実行します。アクションには、QGISのツールやメニュー、パネルを開く等があります。

  • アクティブレイヤの地物 (f): 現在アクティブなレイヤから任意のフィールドで一致する属性を検索し、選択した地物にズームします。 settings を押すと、結果の最大数を設定できます。

  • 全てのレイヤの地物 (af): 各 検索可能なレイヤ表示名 でマッチする属性を検索し、選択した地物にズームします。 settings を押すと、結果の最大数とレイヤごとの結果の最大数を設定できます。

  • 計算機 (=): 任意の QGIS 式の評価ができ、有効な式であれば、結果をクリップボードにコピーするオプションが与えられます。

  • 空間ブックマーク (b): ブックマーク範囲を検索し、ズームします。

  • 設定 (set): プロジェクトやアプリケーション全体のプロパティダイアログを参照し開きます。

  • 座標へ (go): コンマまたは空白区切りのxy座標の組で定義される場所、あるいはフォーマットされたURL(例:OpenStreetMap、Leaflet、OpenLayer、Google Maps、...)で定義される場所へマップキャンバスを移動します。 座標値はWGS 84( epsg:4326 )またはマップキャンバスのCRSです。

  • Nominatim geocoder (>): OpenStreetMap Foundationの Nominatim ジオコーディングサービスを使用したジオコーディングを行います。

  • プロセシングアルゴリズム (a): プロセシングアルゴリズムダイアログを検索し開きます。

  • 選択地物を編集する (ef): プロセシングアルゴリズムへのクイックアクセスを提供し、互換性のある in-place 編集 のプロセシングアルゴリズムをアクティブレイヤで実行します。

このダイアログでは、以下の設定ができます:

  • フィルタの 接頭辞 すなわちフィルタ利用のトリガーとなるキーワードをカスタマイズします

  • フィルタの 有効化 の設定:フィルタを検索で使用し、ロケータバーのメニューでショートカットを有効とするかどうかを設定します

  • フィルタの デフォルト の設定: フィルタを使用しない検索では、デフォルトフィルタのカテゴリによる結果のみが返されます

  • 一部のフィルタには、検索結果の数を設定する方法があります。

デフォルトのロケータフィルタのセットはプラグインによって拡張できます。例えば、OSM nominatim 検索や直接データベース検索、レイヤカタログ検索などがあります。

9.1.18. 高速化

OpenCL による高速化の設定です。

../../../_images/acceleration_menu.png

図 9.20 高速化タブ

お使いのハードウェアやソフトウェア環境にもよりますが、OpenCLアクセラレーションを有効にするためには、追加のライブラリをインストールする必要がある場合があります。

9.1.19. プロセシング

processingAlgorithm プロセシング タブでは、QGIS プロセシングフレームワークで使用されるツールやデータプロバイダの一般的な設定を行うことができます。詳細は、 QGIS プロセシングフレームワーク を参照してください。

../../../_images/options_processing.png

図 9.21 QGISのプロセシング設定タブ

9.1.20. Python コンソール

runConsole Pythonコンソール 設定では、Pythonエディタ( 対話型コンソールコードエディタプロジェクトのマクロカスタム式 等)の動作の管理と制御を行えます。このメニューには、下記の options オプション... ボタンからもアクセスできます。

  • Pythonコンソール ツールバー

  • Pythonコンソール ウィジェットのコンテキストメニュー

  • コードエディタのコンテキストメニュー

../../../_images/options_pythonconsole.png

図 9.22 Pythonコンソール設定タブ

以下の設定ができます:

  • unchecked 入力補完(オートコンプリート) :コードの入力補完を有効にします。現在のドキュメント、インストールされたAPIファイル、またはその両方から自動補完されます。

    • 入力補完の閾値 :自動補完リストを表示する閾値を(文字数で)設定します。

  • タイピング

    • unchecked カッコの自動挿入 :左括弧を入力した時の右括弧の自動入力を有効にします

    • checkbox 'from xxx' に 'import' 文字列を自動挿入する :インポート指定の際に 'import' 文字列の挿入を有効にします。

  • 実行とデバッグ

    • unchecked オブジェクトインスペクタを有効にする(タブの切り替えが遅くなる場合があります) :オブジェクトインスペクタを有効にします。

    • unchecked 実行前にスクリプトを自動保存する :スクリプトの実行時に自動的にスクリプトを保存します。このアクションは一時ファイルを(システムディレクトリの一時領域に)保存し、実行後には自動的に削除されます。

API では、以下の設定ができます:

  • checkbox プリロードされたAPIファイルを使用 :プリロードされたAPIファイルを使用するかどうかを選択できます。 これがチェックされていない場合にはAPIファイルを追加することができ、また、事前に準備されたAPIファイルを使用するかどうかを選択することもできます(次のオプションを参照)。

  • unchecked 事前に準備されたAPIファイルを利用する :チェックした場合、選択した *.pap ファイルがコード補完に使用されます。準備されたAPIファイルを生成するには、少なくとも1つの *.api ファイルをロードし、 APIをコンパイル... ボタンをクリックしてそれをコンパイルする必要があります。

GitHubアクセストークン では、Pythonコードエディタ内からコードスニペットを共有するための個人アクセストークンを生成できます。詳細については、 GitHub authentication を参照してください。

9.1.21. コードエディタ

codeEditor コードエディタ タブでは、コードエディタウィジェット(Pyhon対話型コンソール、コードエディタ、式ウィジェット、関数エディタ等)の見た目や動作を制御することができます。

../../../_images/options_codeeditor.png

図 9.23 コードエディタ設定タブ

ダイアログの上部にあるウィジェットでは、さまざまなプログラミング言語(Python、QGIS式、HTML、SQL、JavaScript)で現在の設定をライブプレビューできます。設定を調整するのに便利です。

  • unchecked コードエディタのフォント上書き にチェックを入れると、デフォルトの フォント ファミリーと 大きさ を修正できます。

  • グループでは、以下の設定ができます:

    • 配色 の選択:定義済みの設定は デフォルト低コントラスト(暗)低コントラスト(明) です。色を変更すると カスタム スキームとなり、定義済みのスキームを選択することでリセットできます。

    • コメント、クォート、関数、背景など、コードの各要素の を変更できます。

9.1.22. 詳細設定

../../../_images/options_advanced.png

図 9.24 QGISの詳細設定タブ

QGISに関連するすべての設定(UI、ツール、データプロバイダ、プロセシングアルゴリズムの構成、デフォルト値やパス、プラグインのオプション、式、ジオメトリチェックなど)は、アクティブな ユーザープロファイル ディレクトリの QGIS/QGIS3.ini ファイルに保存されます。このファイルを他のインストール環境にコピーすることで、設定を共有することができます。

QGIS 内では、 詳細設定 タブの 詳細設定エディタ を使用してこれらの設定を管理する方法を提供しています。慎重に設定変更することを約束したら、ウィジェットには既存のすべての設定のツリーが表示され、その値を編集することができるようになります。設定やグループの上で右クリックすると、設定やグループを削除することができます(設定やグループを追加するには、 QGIS3.ini ファイルを編集する必要があります)。変更は自動的に QGIS3.ini ファイルに保存されます。

警告

「高度な設定」タブの設定をやみくもに使用しないこと

変更は自動的に適用されるため、このダイアログで項目を変更する際には注意が必要です。知識のないまま変更を行うと、さまざまな形で QGIS のインストール環境が壊れる可能性があります。

9.2. ユーザープロファイルの操作

設定 ► ユーザープロファイル メニューは、ユーザープロファイルを設定したり、ユーザープロファイルにアクセスする機能を提供します。ユーザープロファイルとは、単一のフォルダに保存される一元管理されたアプリケーション構成で、以下のものを含みます。

  • ロケール、投影法、認証設定、カラーパレット、ショートカットなどを含むすべての グローバル設定

  • GUI の構成と カスタマイズ

  • 測地系変換のためにインストールされたグリッドファイルやその他のprojヘルパーファイル

  • インストールされた プラグイン とその構成

  • プロジェクトのテンプレートと、保存されたプロジェクトの履歴およびその画像プレビュー

  • プロセシングの設定 やログ、スクリプト、モデル

デフォルトでは、QGISインストールには default という名前のユーザープロファイルが一つだけ含まれています。ただし、ユーザープロファイルは以下の方法で必要な数だけ作成できます:

  1. 新規プロファイル... エントリをクリックします。

  2. プロファイル名を指定するように求められ、同じ名前のフォルダが ~/<UserProfiles>/ の下に作成されます。

    • ~HOME ディレクトリを表します。 win Windowsでは、通常は C:\Users\<username> のような名前のフォルダです。

    • <UserProfiles> は、メインプロファイルフォルダを表します。

      • nix .local/share/QGIS/QGIS3/profiles/

      • win %AppData%\Roaming\QGIS\QGIS3\profiles\

      • osx Library/Application Support/QGIS/QGIS3/profiles/

    ユーザープロファイルフォルダは、 アクティブなプロファイルフォルダを開く を使用してQGIS 内から開くことができます。

  3. クリーンな構成を使用して、QGIS の新しいインスタンスが起動されます。その後、カスタム構成を設定することができます。

QGISインストール環境に複数のプロファイルがある場合、アプリケーションのタイトルバーにアクティブなプロファイル名が角括弧囲みで表示されます。

各ユーザープロファイルには個別の設定、プラグイン、および履歴が含まれているため、異なるワークフローで使い分けたり、デモ用途や、同じマシンでユーザーが複数いる場合、あるいは設定のテスト用などに最適です。 設定 ► ユーザープロファイル メニューで選択することで、あるプロファイルから別のプロファイルへと切り替えができます。 コマンドライン から特定のユーザープロファイルでQGISを実行することもできます。

最後に閉じられたQGISセッションのプロファイルは、変更されない限りは次のQGISセッションで使用されます。

ちなみに

新しいユーザープロファイルでQGISを実行して、バグの持続性を確認する

QGISの一部の機能で奇妙な動作が発生した場合には、新しいユーザープロファイルを作成してコマンドを再度実行してください。バグは、現在のユーザープロファイルに残っているものが関係していることがあります。新しいユーザープロファイルを作成すると、新しい(クリーンな)プロファイルでQGISを再起動するため、バグが修正されることがあります。

9.3. プロジェクトのプロパティ

プロジェクト ► プロジェクトのプロパティ のプロジェクトのプロパティウィンドウで、プロジェクト固有のオプションを設定できます。プロジェクト固有のオプションは、上記の オプション ダイアログの同じオプションを上書きします。

9.3.1. 一般情報

general 一般情報 タブの 一般設定 では、以下の設定が可能です:

  • プロジェクトファイルの場所を見る

  • プロジェクトのホームフォルダを設定する( ブラウザ パネルの プロジェクトホーム アイテムからでも可能です)。パスは、プロジェクトファイルのフォルダに対する相対パス(として入力する)にも、絶対パスにもできます。プロジェクトのホームは、プロジェクトに利用するデータやその他のコンテンツを保存するために使用できます。これは、データセットとプロジェクトファイルが同じ場所には保存されていない場合に便利です。これが入力されていない場合は、 プロジェクトのホーム はデフォルトでプロジェクトファイルのフォルダとなります。

  • プロジェクトにタイトルを付ける

  • 地物が選択されたときに使用する色を選択する

  • 背景色を選択する:マップキャンバスに使用する色を選択します

  • プロジェクト内でレイヤへのパスを絶対パス(フルパス)として保存するか、プロジェクトファイルの場所に対する相対パスとして保存するかを設定する。レイヤとプロジェクトファイルの両方が移動するもしくは共有する可能性がある場合や、異なるプラットフォーム上のコンピュータからプロジェクトにアクセスする場合には、相対パスの方が良いかもしれません。

  • プロジェクトが地図タイルとしてレンダリングされる時のずれを回避するか選択する。このオプションをチェックすると、パフォーマンスの低下につながる可能性があります。

GISでは面積や距離の計算がしばしば必要になります。しかしながら、これらの値は実際には基礎となる投影設定に関連付けられています。 計測 フレームではこれらのパラメータを制御できます。以下が選択できます。

  • 楕円体 :距離や面積の計算の基礎となっている楕円体を選択します。これには以下の値があります。

    • None/Planimetric: この場合は、距離・面積の計算値はデカルト計測による値です。

    • カスタム : 楕円体の長軸と短軸の値を設定する必要があります。

    • または定義済みのリスト(Clarke 1866、 Clarke 1880 IGN、 New International 1967、 WGS 84 など) から既存のものを選択します。

  • 長さと周長のための 距離計測の単位 と、 面積計測の単位 。これらの設定は、デフォルトではQGISオプションで設定した単位が使われますが、現在のプロジェクトの単位で上書きされ、以下の値の単位に使用されます。

    • 属性テーブルのフィールド更新バー

    • フィールド計算機の計算

    • 地物情報表示ツールで表示される長さ、周長および面積値

    • 計測ダイアログに表示されるデフォルトの単位

座標と方位を表示 では、ステータスバーに表示されるマウス座標や、地物情報表示ツールで表示される派生した属性について、座標の表記に使用する方位の書式や単位の書式を選択およびカスタマイズできます。

../../../_images/project_general.png

図 9.25 プロジェクトのプロパティダイアログの一般情報タブ

9.3.2. メタデータ

editMetadata メタデータ タブでは、制作者、作成日、言語、要約、カテゴリ、キーワード、連絡先の詳細、リンク、履歴など(その他の項目も同様)の詳細なメタデータを定義できます。特定のフィールドが入力されているかどうかを確認する検証機能もありますが、これは強制されません。詳細は、 ベクタレイヤのメタデータプロパティ を参照してください。

9.3.3. 表示設定

../../../_images/project_viewsettings.png

図 9.26 プロジェクトのプロパティダイアログの表示設定タブ

overlay 表示設定 タブは、プロジェクトのマップキャンバスをコントロールする手段を提供します。このタブでは、以下の設定ができます:

  • プロジェクト定義済み縮尺 の設定:これは、ステータスバーの 縮尺 ドロップダウンウィジェットに表示される縮尺のリストです。この設定は、グローバルで定義済みの縮尺を上書きします。

  • プロジェクト範囲を設定 :この範囲は、マップの全域表示でズームする( zoomFullExtent )際に、全レイヤの範囲の代わりに使用されます。この設定は、プロジェクトにウェブ地図のレイヤや国規模・世界規模のレイヤが含まれていても、プロジェクトの実際の対象領域はより狭い地理的範囲である場合に便利です。プロジェクトの全域の座標は、 範囲セレクタ ウィジェットを使用して設定できます。

9.3.4. 座標参照系(CRS)

注釈

QGIS がプロジェクトの投影をどのように扱っているかについての詳細は、 投影法の利用方法 の専用セクションを読んでください。

crs 座標参照系 タブでは、そのプロジェクトで使用する座標参照系を設定できます。以下の設定があります。

  • checkbox CRSなし(または未知 / 非地球) : レイヤの生の座標に基づいてレイヤが描画されます

  • 既存の座標参照系で 地理的座標系投影された座標系 あるいは ユーザ定義の座標系 を使用できます。プロジェクトに追加されたレイヤは、重ね合わせるために元のCRSに関係なく、オンザフライでこのCRSに変換されます。

9.3.5. 変換

transformation 変換 タブでは、現在のプロジェクトで適用する測地系変換を設定することで、レイヤの再投影設定を制御することができます。他の設定同様、これは対応するグローバル設定を上書きします。詳細については 測地系変換 を参照してください。

9.3.6. 既定スタイル

symbology 既定スタイル タブでは、既存の .qml スタイル定義が無い場合に、プロジェクトで新しいレイヤをどのように描画するのかを制御できます。以下の設定ができます:

  • レイヤのジオメトリタイプに応じて適用するデフォルトのシンボル( マーカーライン塗りつぶし )と、デフォルトの カラーランプ を設定します。

  • デフォルトの 不透明度 を新規レイヤに適用します

  • checkbox ランダムな色をシンボルに設定する は、シンボルの塗りつぶし色を変えることで、すべてのレイヤが同じように描画されるのを避けられます。

../../../_images/project_default_styles.png

図 9.27 既定スタイルタブ

styleManager スタイルマネージャ ボタンを押すと、 スタイルマネージャ ダイアログに素早くアクセスし、シンボルやカラーランプの設定が行えます。

また、実行中のプロジェクトの特定の色を定義するセクションもあります。グローバルの色設定 と同様に、以下の設定ができます。

  • symbologyAdd 色を追加 あるいは symbologyRemove 色の削除

  • editCopy 色のコピー あるいは editPaste 色の貼り付け

  • fileOpen ファイルから色のインポート あるいは fileSave 色のエクスポート で色のセットを .gpl ファイルからインポート / ファイルへエクスポート

リスト内の色をダブルクリックして カラーセレクタ ダイアログで色を調整したり、置き換えたりできます。 ラベル 列をダブルクリックして、色の名前を変更することもできます。

これらの色は プロジェクトの色 として識別され、 色ウィジェット の一部としてリストに表示されます。

ちなみに

プロジェクトの色を使用して、カラーウィジェットを素早く割り当てて更新する

プロジェクトの色はそのラベルを使って参照することができ、それらが使用されているカラーウィジェットはそれらにバインドされます。これによって、多くのプロパティに同じ色を繰り返し設定したり面倒な更新を避けるために、以下のようにすることができます:

  1. 色をプロジェクトの色として定義します

  2. 設定したい色プロパティの隣にある、 データによって定義された上書きウィジェット をクリックします

  3. メニューの上にマウスカーソルを置き、プロジェクトの色を選択します。このプロパティには式 project_color('color_label') が指定され、カラーウィジェットにはその色が反映されます。

  4. ステップ2とステップ3を必要なだけ繰り返します

  5. プロジェクトの色を一度更新するだけで、その色が使われている箇所の「全て」に変更が反映されます。

9.3.7. データソース

openTable データソース タブでは、以下の設定ができます:

  • unchecked 可能な場合は自動的にトランザクショングループを作成する :このモードをオンにすると、同じデータベースのすべてのレイヤが同じ編集状態で同期されます。つまり、あるレイヤが編集状態になるとすべてのレイヤが編集状態となり、 1つのレイヤがコミットされるか、または1つのレイヤがロールバックされると、そのほかも同様にコミットもしくはロールバックされます。また、編集した変更をローカルでバッファリングする代わりに、変更はデータベース内のトランザクションに直接送信され、ユーザがレイヤの保存をクリックしたときにコミットされます。プロジェクトでレイヤが編集されていない場合にのみ、このオプションを有効(無効)にできます。

  • unchecked プロバイダ側でデフォルト値を評価する :PostgreSQLのテーブルに新しい地物を追加すると、デフォルト値の制約を持つフィールドは、コミット時ではなくフォームを開いた際に値が評価され入力されます。これは、 地物を追加 フォームのフィールドに nextval( 'serial') のような式ではなく、期待された値(例えば 25 )が表示されることを意味します。

  • unchecked データソースにメタデータがない場合にプロジェクトを信頼する :データチェックをスキップしてプロジェクトの読み込みを高速化します。 QGIS Serverコンテキストまたは巨大なデータベースビュー/マテリアライズドビューを持つプロジェクトで役立ちます。レイヤの範囲は(データソースの代わりに)QGISプロジェクトファイルから読み取られ、PostgreSQLプロバイダを使用する場合、ビューやマテリアライズドビューの主キーの単一性はチェックされません。

  • レイヤのCapabilities の設定ができます。すなわち、

    • どのレイヤを 情報表示可能 (あるいは不可)とするか、すなわち、 地物情報表示ツール に反応するかを設定します。デフォルトでは、レイヤは問合せ可能に設定されています。

    • レイヤを 読取専用 として表示するかどうかを設定します。つまり、データプロバイダのケーパビリティに関係なく、ユーザが編集できなくなります。これは弱い保護ですが、ファイルベースのレイヤで作業しているときに、エンドユーザがデータを変更しないようにするための簡単で便利な設定です。

    • どのレイヤを 検索可能 とするか、すなわち、 ロケータウィジェット を使って問合せ可能かを定義します。デフォルトでは、レイヤは検索可能に設定されています。

    • どのレイヤを 必須 とするかを定義します。このリスト内でチェックされたレイヤは、不注意でプロジェクトから削除されないように保護されます。

    • どのレイヤを プライベート 、つまりは レイヤ パネルでは非表示とするかを定義します。これは、プロジェクトでは必要だが、凡例ツリーや他のレイヤ選択ツールには見せたくない、アクセサリレイヤ(ベースマップ、結合テーブル、値のリレーションのルックアップテーブル、たいていの非空間レイヤなど)のためのものです。表示状態であった場合、そのレイヤはマップキャンバスに表示され、印刷レイアウトの凡例にはレンダリングされます。 レイヤ パネル上部のツールバーにある filterMap 凡例フィルタ ► プライベートレイヤを表示 オプションを使用すると、プライベートレイヤを一時的に表示し、レイヤを操作できるようになります。

    レイヤのCapabilities テーブルには便利なツールがあります:

    • 複数のセルを選択してから 選択切替 を押すと、チェックボックスの状態を変更できます。

    • unchecked 空間レイヤのみ表示 は、空間レイヤでないものをレイヤのリストから除外します。

    • search レイヤのフィルタ... を使用して、設定したい特定のレイヤを素早く探し出せます。

../../../_images/project_datasources.png

図 9.28 データソースタブ

9.3.8. リレーション

relations リレーション タブは、1:nのリレーションや多態リレーションを定義するために使用されます。リレーションは、プロジェクトのプロパティダイアログで定義されます。あるレイヤにリレーションが存在すると、フォームビューの新しいユーザーインターフェース要素(例えば、地物を特定し、そのフォームを開くとき)に関連するエンティティのリストが表示されます。これは、例えばパイプラインの長さや道路区間の検査履歴を表現するための強力な方法を提供します。1:n リレーションのサポートについての詳細は、 1対多または多対多のリレーションの作成 のセクションを参照してください。

../../../_images/project_relations.png

図 9.29 リレーションタブ

9.3.9. 変数

expression 変数 タブには、プロジェクトレベルで使用可能なすべての変数(すべてのグローバル変数を含む)がリストされています。これに加え、プロジェクトレベルの変数を管理することができます。 symbologyAdd ボタンをクリックすると、新しいカスタムプロジェクトレベル変数を追加できます。同様に、リストからカスタムプロジェクトレベルの変数を選択して symbologyRemove ボタンをクリックすれば、変数を削除できます。変数の使用法の詳細については、一般ツールの 値を変数に格納する のセクションを参照してください。

9.3.10. マクロ

action マクロ タブは、プロジェクトのPythonマクロの編集のために使います。 現時点では: openProject(), saveProject() そして closeProject() の3つのマクロのみ使用可能です。

../../../_images/macro.png

図 9.30 QGISでのマクロ設定

9.3.11. QGISサーバー

overlay QGISサーバー タブでは、プロジェクトをオンラインで公開するための設定を行うことができます。ここでは、QGISサーバーのWMSとWFSのケーパビリティ、範囲、およびCRSの制限に関する情報を定義できます。より詳しい情報は Configure your project 以降のセクションを参照してください。

../../../_images/project_qgisserver.png

図 9.31 QGISサーバー設定タブ

9.3.12. 時系列

temporal 時系列 タブは、プロジェクトの時系列範囲の設定に使用します。時系列範囲は 開始時刻終了時刻 を使用して手入力で設定することも、現在のプロジェクトの時系列レイヤから計算して設定することもできます。プロジェクトの時間範囲は 時系列コントローラパネル において、マップキャンバスの 時系列ナビゲーション の管理に使用できます。

../../../_images/project_temporal.png

図 9.32 プロジェクトの時系列タブ

9.4. インタフェースのカスタマイズ

インタフェースのカスタマイズ ダイアログでは、QGISのユーザーインタフェースのほぼすべての要素を有効(無効)にできます。これは、必要なアイコン、メニュー、またはパネルのみが含まれた「軽量な」バージョンの QGIS をエンドユーザーに提供したい場合に非常に便利です。

注釈

変更が適用される前に、QGISを再起動する必要があります。

../../../_images/customization.png

図 9.33 カスタマイズダイアログ

checkbox カスタマイズを有効にする チェックボックスにチェックを入れることは、QGIS のカスタマイズへの第一歩です。これによりツールバーとウィジェットパネルが有効になり、いくつかの GUI アイテムのチェックを外して無効にすることができます。

設定可能な項目には以下のものがあります。

  • メニューバー にある メニュー やそのサブメニュー

  • パネル の全て( パネルとツールバー 参照)

  • ステータスバー で説明されている ステータスバー やその項目

  • ツールバー : バー全体やアイコン

  • ラベル、ボタン、コンボボックス等の、QGISのダイアログにある ウィジェット

select メインアプリケーションのウィジェットのキャッチを切り替える を使用すると、QGISインタフェース内で非表示にしたい項目をクリックしたときに自動的にカスタマイズダイアログで対応する項目のチェックを外します。また、 検索 ボックスを使用して、項目の名前やラベルから項目を検索することもできます。

設定を行ったら、 適用 または OK をクリックして変更内容を確認します。この設定は、次回の起動時にQGISがデフォルトで使用するものになります。

変更は fileSave ファイルへ保存 ボタン使用して .ini ファイルにも保存できます 。これは、複数のユーザー間で共通のQGISインターフェイスを共有するための便利な方法です。 .ini ファイルをインポートするには、先のコンピュータから fileOpen ファイルから読み込む をクリックするだけです。また同様に、 コマンドラインツール を実行してさまざまなユースケースに応じた各種設定を保存できます。

ちなみに

定義済みのQGISを簡単に復元する

QGISのGUIの初期構成は、以下のいずれかの方法で復元できます。

  • カスタマイズダイアログで checkbox カスタマイズを有効にする オプションのチェックを外すか、 selectAllTree 全てをチェック ボタンをクリックする

  • 設定 ► オプション メニューの システム タブ内、 設定 フレームにある リセット ボタンを押す

  • コマンドプロンプトで次のコマンドラインを使用してQGISを起動する: qgis --nocustomization

  • 設定► オプション メニューの 詳細設定 タブ( 警告 参照)内で、 UI ► Customization ► Enabled 変数の値を false に設定する

ほとんどの場合、変更が適用されるためにはQGISを再起動する必要があります。

9.5. キーボードショートカット

QGISには多数の機能のためのデフォルトのキーボードショートカットが用意されています。これらは メニューバー のセクションにあります。さらに、 設定 ► keyboardShortcuts キーボードショートカット... のメニューオプションを使用すると、デフォルトのキーボードショートカットを変更したり、QGISの機能に新しいショートカットを追加したりすることができます。

../../../_images/shortcuts.png

図 9.34 キーボードショートカットの定義オプション

設定するのは非常に簡単です。ダイアログの上部にある検索ボックスを使用して特定のアクションを見つけ、リストからそれを選択して以下のボタンをクリックします:

  • 変更 ボタンを押し、新しいショートカットとして割り当てる新しい組み合わせを押す

  • 設定解除 ボタンを押し、割り当てられているショートカットを解除する

  • デフォルトに設定 ボタンを押し、ショートカットをもとのデフォルト値に戻す

カスタマイズしたいツールについて、上記の手順に従ってショートカットを設定してください。設定が完了したら、ダイアログを 閉じる と変更が適用されます。また、変更をユーザーショートカットのみ、または全ショートカットを .XML ファイルとして 保存 したり、全てのショートカットを .PDF ファイルとして保存し、それらを他のQGISインストール環境に 読み込み させることもできます。

9.6. 高度な設定でQGISを実行する

9.6.1. コマンドラインと環境変数

QGISの起動 はOS上の他のアプリケーションと同様に実行されることを見てきました。 QGISでは、より高度な使用例のためにコマンドラインオプションを提供しています(場合によっては、コマンドラインオプションの代わりに環境変数を使用できます)。オプションのリストを取得するには、コマンドラインで qgis --help と入力します:

QGIS is a user friendly Open Source Geographic Information System.
Usage: /usr/bin/qgis.bin [OPTION] [FILE]
  OPTION:
        [--version]     display version information and exit
        [--snapshot filename]   emit snapshot of loaded datasets to given file
        [--width width] width of snapshot to emit
        [--height height]       height of snapshot to emit
        [--lang language]       use language for interface text (changes existing override)
        [--project projectfile] load the given QGIS project
        [--extent xmin,ymin,xmax,ymax]  set initial map extent
        [--nologo]      hide splash screen
        [--noversioncheck]      don't check for new version of QGIS at startup
        [--noplugins]   don't restore plugins on startup
        [--nocustomization]     don't apply GUI customization
        [--customizationfile path]      use the given ini file as GUI customization
        [--globalsettingsfile path]     use the given ini file as Global Settings (defaults)
        [--authdbdirectory path] use the given directory for authentication database
        [--code path]   run the given python file on load
        [--defaultui]   start by resetting user ui settings to default
        [--hide-browser]        hide the browser widget
        [--dxf-export filename.dxf]     emit dxf output of loaded datasets to given file
        [--dxf-extent xmin,ymin,xmax,ymax]      set extent to export to dxf
        [--dxf-symbology-mode none|symbollayer|feature] symbology mode for dxf output
        [--dxf-scale-denom scale]       scale for dxf output
        [--dxf-encoding encoding]       encoding to use for dxf output
        [--dxf-map-theme maptheme]      map theme to use for dxf output
        [--take-screenshots output_path]        take screen shots for the user documentation
        [--screenshots-categories categories]   specify the categories of screenshot to be used (see QgsAppScreenShots::Categories).
        [--profile name]        load a named profile from the user's profiles folder.
        [--profiles-path path]  path to store user profile folders. Will create profiles inside a {path}\profiles folder
        [--version-migration]   force the settings migration from older version if found
        [--openclprogramfolder]         path to the folder containing the sources for OpenCL programs.
        [--help]                this text
        [--]            treat all following arguments as FILEs

  FILE:
    Files specified on the command line can include rasters,
    vectors, and QGIS project files (.qgs and .qgz):
     1. Rasters - supported formats include GeoTiff, DEM
        and others supported by GDAL
     2. Vectors - supported formats include ESRI Shapefiles
        and others supported by OGR and PostgreSQL layers using
        the PostGIS extension

ちなみに

コマンドライン引数を利用する例

コマンドラインで1つまたは複数のデータファイルを指定してQGISを起動できます。たとえば、 qgis_sample_data ディレクトリにいると仮定すると、次のコマンドを使用して、起動時にベクタレイヤとラスタファイルをロードするように設定されたQGISを起動できます: qgis ./raster/landcover.img ./gml/lakes.gml

9.6.1.1. --version

このオプションはQGISのバージョン情報を返します。

9.6.1.2. --snapshot

このオプションを使うとPNG形式で現在のビューのスナップショットを作れます。これは、多数のプロジェクトがあり、データからスナップショットを作成したい場合、または更新されたデータで同じプロジェクトのスナップショットを作成したい場合に便利です。

このオプションを使うと800x600 ピクセルのPNGファイルが作成されます。 --width--height を引数に加えることでサイズの調整ができます。 --snapshot の後にファイル名を指定できます。例えば:

qgis --snapshot my_image.png --width 1000 --height 600 --project my_project.qgs

9.6.1.3. --width

このオプションは、出力されるスナップショットの幅を返します( --snapshot と共に使用されます)。

9.6.1.4. --height

このオプションは、出力されるスナップショットの高さを返します( --snapshot と共に使用されます)。

9.6.1.5. --lang

ロケールに基づいて、QGISは正しい言語対応を選択します。言語を変更したいならば言語コードを指定できます。例えば、 qgis --lang it であればイタリア語対応でQGISを起動します。

9.6.1.6. --project

既存のプロジェクトファイルからQGISを起動することも可能です。プロジェクト名の後に --project コマンドラインオプションを追加するだけで、指定されたファイル内のすべてのレイヤが読み込まれた状態で QGIS が開きます。

9.6.1.7. --extent

ある地図の領域を指定してQGISを起動する場合はこのオプションを使います。この場合、下記のようにカンマで区切られた書式の領域指定で領域を包含する長方形を指定する必要があります。

--extent xmin,ymin,xmax,ymax

このオプションは -project オプションと組み合わせて、特定のプロジェクトを目的の範囲で開くようにすれば、より意味のあるものになるでしょう。

9.6.1.9. --noversioncheck

起動時のQGISの新しいバージョンの検索をスキップします。

9.6.1.10. --noplugins

起動時にプラグインのトラブルがある場合、起動時にプラグインのロードを無効にできます。プラグインは、後からプラグインマネージャで有効にすることができます。

9.6.1.11. --nocustomization

このオプションを使用すると、既存の GUIカスタマイズ は起動時に適用されません。これは、非表示のボタン、メニュー項目、ツールバーなどがQGISの起動時に表示されることを意味します。これは永続的な変更ではありません。このオプションなしでQGISを起動すると、カスタマイズが再度適用されます。

このオプションは、カスタマイズによって削除されたツールへのアクセスを一時的に許可する場合に役立ちます。

9.6.1.12. --customizationfile

このオプションを使用すると、起動時に使用されるUIカスタマイズファイルを定義できます。

9.6.1.13. --globalsettingsfile

これと同等な環境変数は、 QGIS_GLOBAL_SETTINGS_FILE です。

このオプションを使用して、デフォルト設定とも呼ばれるグローバル設定ファイル( .ini )のパスを指定できます。指定されたファイルの設定は、元のインラインのデフォルト設定を置き換えますが、ユーザープロファイルの設定はそれらを上書きして設定されます。

QGISはデフォルトのグローバル設定ファイルを以下の順番で検索し、最初に見つかったものを使用します:

  • コマンドラインパラメータで指定されたパス

  • 環境変数で定義されたパス

  • アプリケーションのデータ(AppDataLocation)フォルダ。ここには永続的なアプリケーションデータを格納できます。これはユーザーまたはシステム管理者が管理し、インストーラによる変更は行われず、コマンドラインパラメータや設定環境変数を渡すなどの追加設定を必要としません。このフォルダはOSによって異なります:

    • nix $HOME/.local/share/QGIS/QGIS3/

    • win C:\Users\<username>\%AppData%\Roaming\QGIS\QGIS3\

    • osx $HOME/Library/Application Support/QGIS/QGIS3/

  • インストールディレクトリ。すなわち、 your_QGIS_package_path/resources/qgis_global_settings.ini

現在、設定を書き込むファイルを指定する方法はありません。したがって、元の設定ファイルのコピーを作成し、名前を変更し、適応させることができます。

qgis_global_setting.ini ファイルパスをネットワーク共有フォルダに設定すると、システム管理者は1つのファイルを編集するだけで、複数のマシンのグローバル設定とデフォルトを変更できます。

9.6.1.14. --authdbdirectory

このオプションは --globalsettingsfile に似ていますが、認証データベースが保存およびロードされるディレクトリへのパスを定義します。

9.6.1.15. --code

このオプションを使用すると、指定したpython ファイルを QGIS を開始した直後に実行します。

例えば、以下の内容の load_alaska.py という名前の python ファイルがあるとします。

from qgis.utils import iface
raster_file = "/home/gisadmin/Documents/qgis_sample_data/raster/landcover.img"
layer_name = "Alaska"
iface.addRasterLayer(raster_file, layer_name)

ファイル load_alaska.py が配置されているディレクトリにいると仮定して、次のコマンドを使用することで、QGISを起動し、ラスタファイル landcover.img をロードし、レイヤに 'Alaska' という名前を付けることができます。

qgis --code load_alaska.py

9.6.1.16. --defaultui

ロード時に、ユーザーインターフェイス(UI)を既定の設定に 永続的にリセット します。このオプションは、パネルとツールバーの表示、位置、サイズを復元します。再度変更しない限り、次のセッションではデフォルトのUI設定が使用されます。

このオプションは GUI のカスタマイズ には何の影響もないことに注意してください。GUI のカスタマイズによって隠されたアイテム(例えばステータスバー)は、 --defaultui オプションを使ったとしても隠されたままです。--nocustomization オプションについても参照してください。

9.6.1.17. --hide-browser

ロード時に、ユーザーインタフェースから ブラウザ パネルを非表示にします。パネルを有効にするには、ツールバーのスペースを右クリックするか、 表示 ► パネルkde Linux KDEでは 設定 ► パネル )を使用します。

ブラウザパネルが再度有効にならない限り、次のセッションでもパネルは隠されたままになります。

9.6.1.18. --dxf-*

これらのオプションは、DXFファイルにQGISプロジェクトをエクスポートするために使用できます。いくつかのオプションが用意されています:

  • --dxf-export : レイヤを出力するDXFファイル名;

  • --dxf-extent : 最終的なDXFファイルの範囲;

  • --dxf-symbology-mode :ここでは、none(シンボルなし)、symbollayer(シンボルレイヤシンボル)、feature(地物シンボル)の値を使用できます。

  • --dxf-scale-denom: シンボルの縮尺分母;

  • --dxf-encoding: ファイルのエンコーディング

  • --dxf-map-theme: レイヤツリー設定から 地図テーマ を選択

9.6.1.19. --take-screenshots

ユーザドキュメントのスクリーンショットを撮ります。 --screenshots-categories とともに使用して、ドキュメントスクリーンショットのどのカテゴリ/セクションを作成するかをフィルターできます( QgsAppScreenShots::Categories 参照)。

9.6.1.20. --profile

ユーザのプロファイルフォルダから特定のプロファイルを使用してQGISを読み込みます。変更しない限り、選択したプロファイルは次のQGISセッションで使用されます。

9.6.1.21. --profiles-path

このオプションを使用すると、プロファイル(ユーザ設定)をロードして保存するパスを選択できます。 {path}\profiles フォルダ内にプロファイルを作成します。このフォルダには、設定、インストールされたプラグイン、プロセシングモデルとスクリプトなどが含まれます。

このオプションを使用すると、たとえば、すべてのプラグインと設定をフラッシュドライブで持ち運んだり、ファイル共有サービスを使用して異なるコンピュータ間で設定を共有したりできます。

これと同等な環境変数は、QGIS_CUSTOM_CONFIG_PATH です。

9.6.1.22. --version-migration

古いバージョンの設定( 例えば 、 QGIS 2.18 の .qgis2 フォルダ)が見つかったときに、このオプションはデフォルトのQGISプロファイルに設定をインポートします。

9.6.1.23. --openclprogramfolder

このオプションを使用すると、OpenCLプログラムの代替パスを指定できます。これは、既存のプログラムを置き換えることなく、プログラムの新しいバージョンをテストする開発者にとって便利です。

同等の環境変数は QGIS_OPENCL_PROGRAM_FOLDER です。

9.6.2. 組織内でのQGISの導入

カスタム構成ファイルを使用して組織内にQGISをデプロイする必要がある場合、最初に your_QGIS_package_path/resources/qgis_global_settings.ini にあるデフォルト設定ファイルの内容をコピーして貼り付ける必要があります。このファイルには、 [] で始まるブロックで識別されるデフォルトのセクションがすでに含まれています。これらのデフォルト値はそのままにしておき、ファイルの下部に独自のセクションを追加することをお勧めします。ファイル内でセクションが重複している場合、QGISは上から下に向かって検索して見つかった最後のセクションを使用します。

QGIS のバージョンチェックを無効にするには allowVersionCheck=false と変更します。

新規インストール後に移行ウィンドウを表示したくない場合は、次のセクションが必要です。

[migration]
fileVersion=2
settings=true

グローバルスコープのカスタム変数を追加したい場合は、以下が必要です。

[variables]
organisation="Your organization"

INI ファイルの設定による可能性について理解するため、QGIS デスクトップで設定を行った後、プロファイルにある INI ファイルをテキストエディタを使って検索することをお勧めします。 WMS/WMTS、PostGIS 接続、プロキシ設定、地図のtipsなど、数多くの設定を INI ファイルを使用して行うことができます。

最後に、カスタマイズしたファイルのパスを環境変数 QGIS_GLOBAL_SETTINGS_FILE に設定する必要があります。

さらに、Pythonマクロ、カラーパレット、レイアウトテンプレート、プロジェクトテンプレートなどのファイルをQGISシステムディレクトリまたはQGISユーザープロファイルのいずれかに配置することもできます。

  • レイアウトテンプレートは composer_templates ディレクトリ内に配置する必要があります。

  • プロジェクトテンプレートは project_templates ディレクトリ内に配置する必要があります。

  • カスタム Python マクロは python ディレクトリ内に配置する必要があります。