Outdated version of the documentation. Find the latest one here.

QGISの設定

QGISでは Settings メニューを通じて高度な設定が可能です。プロジェクトのプロパティ、オプションやカスタマイズの間で選択します。

ノート

QGISはオプションとプロジェクトのプロパティ項目の場所をデスクトップのガイドラインに従います。したがって、使用しているOSに関連し、以下の項目のいくつかの場所は ProjectSettings メニュー中である可能性があります。

プロジェクトのプロパティ

nix 設定 - >プロジェクトProperties (kde)の下のプロジェクトの[プロパティ]ウィンドウで、または nix osx win プロジェクト - >プロジェクトProperties (Gnomeの、OS XまたはWindows)で、プロジェクト固有のオプションを設定できます。

  • 一般 メニューの中の 一般設定 では次のことが可能です。

    • プロジェクトファイルパスの横にあるプロジェクトにタイトルを与えます

    • それらが選択されたときの機能に使用する色を選択してください

    • マップキャンバスに使用する色:背景色を選択してください

    • プロジェクト内のレイヤーへのパスが絶対(フル)またはプロジェクトファイルの場所に対する相対などとして保存すべきかどうかを設定します。レイヤーとプロジェクトファイルの両方を移動または共有やプロジェクトは、異なるプラットフォーム上のコンピュータからアクセスされた場合に可能な相対パスを好むかもしれません。

    • プロジェクトはマップタイルとしてレンダリングされたときにアーチファクトを回避することを選択しました。このオプションをチェックすると、パフォーマンスの低下につながる可能性があります。

    面積と距離を計算することはGISにおいてよく必要になります。しかし、これらの値は、本当は基本的な投影の設定に関連付けられています。 測定 フレームを使用して、これらのパラメータを制御できます。確かに選択できます:

    • 使用する楕円体:既存のものも、カスタム(半長軸と半短軸の値を設定する必要があります)、またはなし/面積測定。

    • 長さと周長のための 距離計測の単位面積計測の単位 。これらの設定は、デフォルトではQGISオプションで設定した単位、その後現在のプロジェクトのためにそれを上書きし、以下において使用されます:

      • 属性テーブルのフィールド更新バー

      • フィールドの電卓の計算

      • ツール由来の長さ、周囲および面積値を識別

      • デフォルトの単位は、測定ダイアログに表示します

    座標表示 選択し、マウスがステータスバーと識別ツールを使用して示す派生座標に座標表示するために使用する単位の形式をカスタマイズできます。

    最後に、グローバルな定義済の縮尺を上書きする、 プロジェクト縮尺 リストを定義できます。

Figure General Menu:

../../../_images/project_general.png

プロジェクトのプロパティ]ダイアログの[全般]タブ

  • The CRS menu enables you to choose the Coordinate Reference System for this project, and to enable on-the-fly re-projection of raster and vector layers when displaying layers from a different CRS.
  • レイヤー識別 メニューではどのレイヤーが ツールを識別 に応答するか設定(または無効に)できます。デフォルトでは、レイヤーは照会可能に設定されています。

  • デフォルトStyles のメニューでは、それらは既存の持っていないときに描画されますどのように新しいレイヤーを制御できます .qml スタイルが定義されています。また、新しいレイヤーのデフォルトの透明度レベルを設定でき、シンボルは、それらに割り当てられたランダムな色を持っているかどうかを指定します。実行中のプロジェクトのための特定の色を定義でき、追加のセクションもあります。各レンダラに存在する色ダイアログウィンドウのドロップダウンメニューで追加の色を見つけることができます。

  • タブ OWS Server ではQGIS ServerのWMSとWFS機能、範囲およびCRSの制限に関する情報を定義できます。

  • マクロ メニューはPythonマクロの編集のために使います. 現時点では: openProject(), saveProject() そして closeProject() の3つのマクロのみ使用可能です.

Figure Macro Menu:

../../../_images/macro.png

QGISでマクロの設定

  • Relations メニューは1:nの関係を定義するために使用されます。関係は、プロジェクトのプロパティダイアログで定義されています。関係は、レイヤに存在すると、フォームビュー(例えば、地物を識別し、そのフォームを開くとき)で、新しいユーザインタフェース要素は、関連するエンティティのリストが表示されます。これは、例えばパイプラインや道路区間の長さの検査履歴を表現するための強力な方法を提供します。1:n関係のサポートについての詳細はセクション 1対多関係を作成する にあります。

オプション

options QGISのためのいくつかの基本的なオプションは Options ダイアログを使用して選択できます。メニューオプション 設定-> options Options を選択します。オプションをカスタマイズできるタブが以下に記載されています。

一般情報メニュー

アプリケーション

  • スタイル(QGISの再起動が必要) selectString を選択し、 ‘酸素’、 ‘Windows’、 ‘モチーフ’、 ‘C​​DE’、 ‘Plastique’ 、 ‘Cleanlooks’ の中から選択します( nix )。

  • アイコンtheme selectString を定義してください。現在は「デフォルト」のみ可能です。

  • アイコンsize selectString を定義してください。

  • Font を定義します。radioButtonOn Qt default とユーザ定義のフォントの間で選択します 。

  • 時限メッセージまたはダイアログのタイムアウト selectString を変更します。

  • checkbox 起動時のスプラッシュスクリーンを隠す

  • checkbox 起動時にチップスを表示する

  • checkbox グループボックスのタイトルを太字にする

  • checkbox QGISスタイルのグループボックス

  • checkbox ネイティブ色選択ダイアログを使用

  • checkbox 利用ライブ更新色選択dialogs

  • checkbox カスタムサイドバーstyle

  • checkbox 実験キャンバスの回転をサポート(再起動が必要)

プロジェクトファイル

  • 起動時にプロジェクトを開く selectString (「新」、「最後」と「特定」の間で選択します)。「特定」を選択するときは browseButton を使用してプロジェクトを定義します。

  • checkbox 既定のプロジェクトから新プロジェクトを作成する. 現在のプロジェクトを既定プロジェクトとして指定する または 既定を解除 ボタンをクリックすることができます. またユーザが作成したプロジェクトテンプレートをファイルやディレクトリを指定するとブラウズすることができます. プロジェクト ‣ テンプレートをもとに新規作成 というエントリでそれができます.プロジェクトテンプレートを保存したい場合は最初に checkbox 既定のプロジェクトから新プロジェクトを作成する をアクティブにしてプロジェクトテンプレートフォルダーにプロジェクトを保存してください.

  • checkbox 必要に応じプロジェクトとデータソースの変更の保存を促す

  • checkbox :guilabel: レイヤーがremoveされる場合に確認のプロンプト

  • checkbox QGISの旧バージョンで保存したプロジェクトファイルを開く際に警告する

  • マクロを有効 selectString 。このオプションは、プロジェクトのイベントのアクションを実行するために書かれているマクロを処理するために作成されました。「常に(推奨されません)」「このセッションにのみ」、「尋ねる」、「決して」の中で選択できます。

システムメニュー

環境

現在システム環境変数を表示でき、その多くは グループ 環境で構成できます( figure_environment_variables を参照)。これは、GUIアプリケーションは、必ずしもユーザーのシェル環境を継承していない、Macなどのプラットフォームに便利です。処理ツールボックス(例えば、SAGA、GRASS)によって制御される外部ツールセットの環境変数を設定したり表示するにも、ソースコードの特定のセクションのためのデバッグ出力をオンにするにも便利です。

  • checkbox カスタム変数の使用 - (再起動が必要なセパレータを含めます) 。変数を [追加] および [削除] できます。定義済みの環境変数は 現在の環境変数 に表示され、 checkbox のみ表示QGIS固有variables を有効にすることでそれらにフィルタを掛けることが可能です。

Figure System Environment:

../../../_images/sys-env-options.png

QGISでのシステム環境変数

プラグインパス

[Add] or [Remove] Path(s) to search for additional C++ plugin libraries

データソースメニュー

地物属性とテーブル

  • checkbox ドックウィンドウで属性テーブルを開く(QGISの再起動が必要)

  • checkbox :guilabel: 属性tableからWKT表現でコピージオメトリ属性テーブル ダイアログからの copySelected 選択行をclipboardにコピー を使用している場合、 これは点または頂点の座標がクリップボードにコピーされるという結果を有しています。

  • 属性テーブルbehavior selectString 。「すべての地物を表示」、「選択地物を表示」と「地図上で表示された地物を表示」:3つの可能性があります。

  • 属性テーブルの行cache selectNumber 。属性テーブルでの作業は速くなりますように、この行キャッシュは最後にロードN属性の行を保存することが可能となります。属性テーブルを閉じるときにキャッシュが削除されます。

  • NULL値の表現 。ここでは、NULL値を含むデータフィールドの値を定義できます。

データソースの操作

  • ブラウザdock で有効な項目をスキャン selectString 。「チェック・拡張」と「チェック・ファイルの内容」のどちらかを選択できます。

  • ブラウザdock で圧縮ファイル(.zipファイル)の内容をスキャン selectString。「いいえ」、「基本スキャン」と「完全スキャン」も可能です。

  • ラスタサブレイヤのプロンプト時にopening 。いくつかのラスタ・サポート・サブレイヤは—それらはGDALでサブデータセットと呼ばれます。多くのnetCDF変数がある場合などは— netCDFファイルで、GDALはサブデータセットとして、すべての変数を見ています。オプションは、サブレイヤでファイルを開いたときのサブレイヤに対処する方法を制御できます。次の選択肢があります。

    • ‘常に’:毎回確認 (サブレイヤが存在する場合)

    • ‘必要な場合’:バンドがなくサブレイヤをもつかを尋ねます

    • ‘利用しない’:確認せず何もロードしません

    • ‘‘すべてをロード’:確認せず,すべてのサブレイヤをロードします

  • checkbox シェープファイルのエンコーディングdeclarationを無視 。シェープファイルは、情報をコード化している場合、これはQGISによって無視されます。

  • checkbox ダブルクリックでPostGISレイヤを追加し、拡張モード で選択

  • checkbox ダブルクリックでOracleレイヤを追加する.拡張選択モードを利用する

  • checkbox 可能な場合はサーバー側で式を実行

  • checkbox 可能な限りトランザクション・グループを自動的に作成(実験) 。このモードをオンにすると、同じデータベースからのすべての(postgres)レイヤはその編集状態に同期されます。すなわち、1つのレイヤが編集状態に置かれるとすべてがそうなり、一つのレイヤがコミットされたか一つのレイヤがロールバックされると他もそうされます。また、編集変更をローカルにバッファする代わりに、それらはユーザーがレイヤを保存をクリックするときにコミットされるデータベースでトランザクションに直接に送信されます。

隠しブラウザのパス

このウィジェットを使用すると、ブラウザパネルから隠すために選択したすべてのフォルダが一覧表示されます。リストからフォルダを削除すると、ブラウザパネルで、それが利用できるようになります。

レンダリングメニュー

レンダリング動作

  • checkbox 地図に新しくレイヤを追加した際にそのレイヤが表示されることをデフォルトにする

  • checkbox 再描画の速度を上げられる場合にレンダのキャッシュを利用します

  • checkbox 多くのCPUのcoresを使用して並行してレイヤをレンダー

  • checkbox 使用する最大コア

  • 地図更新時間間隔(デフォルトは250 ms)

  • checkbox 新しく追加されたlayersため、デフォルトでは機能の簡素化を有効にします

  • 単純化の閾値

  • checkbox 可能であればプロバイダ側で簡素化

  • レイヤを単純化する最大縮尺

描画品質

  • checkbox 線のジャギーを目立たなくします(描画パフォーマンスが低下します)

ラスタ

  • RGB バンド選択 で、赤、緑、青のバンドの数を定義できます。

コントラスト強調

  • シングルバンドgray selectString 。シングルバンドグレーは「ストレッチなし」、「MinMaxにストレッチ」、「MinMaxにストレッチかつクリップ」、また「MinMaxにクリップ」にもできます。

  • マルチバンドカラー(バイト/バンド) selectString 。オプションは、「ストレッチなし」、「MinMaxにストレッチ」、「MinMaxにクリップ」「MinMaxにストレッチおよびクリップ」。

  • マルチバンドカラー(>バイト/バンド) selectString 。オプションは、「ストレッチなし」、「MinMaxにストレッチ」、「MinMaxにクリップ」「MinMaxにストレッチおよびクリップ」。

  • 限界(最小/最大) selectString。オプションは、「累積画素数カット」、「最小/最大」、「平均+/-標準偏差」です。

  • 累積ピクセル数のカット制限

  • 標準偏差の乗数

デバッグ

  • checkbox マップキャンバスリフレッシュ

[色]メニュー

このメニューでは、レンダラーの各色ダイアログウィンドウで見つけることができるいくつかのカスタム色を追加できます。タブで事前に定義された色セットが表示されます。それらのすべてを削除したり、編集できます。また、望む色を追加し、いくつかのコピー&ペースト操作を行うことができます。最後に、 色セットを gpl ファイルとして書き出し、または読み込みできます。

キャンバスと凡例のメニュー

デフォルトのマップ外観(プロジェクトプロパティを上書きします)

  • 選択色背景色 を指定して下さい.

レイヤの凡例

  • legend でダブルクリックアクション selectString 。「レイヤーのプロパティを開く」または「属性テーブルを開く」のダブルクリックどちらかで。

  • 以下の 凡例アイテムスタイル は利用可能です

    • checkbox レイヤ名の最初を大文字にする

    • checkbox レイヤ名を太字にする

    • checkbox グループ名を太字にする

    • checkbox 分類の属性名称を表示する

    • checkbox ラスタアイコンの作成(多分遅い)

マップツールズメニュー

このメニューは 識別tool の動作に関するいくつかのオプションを提供しています 。

  • 地図tipsを識別し表示するための検索半径 は、地図幅のパーセンテージとして表される許容係数です。これは、この許容範囲内をクリックする限り識別ツールが結果を表示することを意味します。

  • ハイライト色 識別される地物がどの色で強調されることになるかを選択できます。

  • Buffer は、特定のハイライトの概要からレンダリングされるバッファ距離を決定します。

  • 最小width 強調表示されるオブジェクトの輪郭がどれだけの厚さであるべきかを決定。

計測ツール

  • 計測ツールの ラバーバンド色 を定義します。

  • 小数位 を定義

  • checkbox ベース単位をキープ は、大きい数を自動的に変換しません(例えば、メートルをキロメートルに)

  • 好みの距離単位 radioButtonOn (「メートル」、「フィート」、「海里」、「度」や「地図単位」)

  • 好みの面積単位 radioButtonOn (‘平方メートル’, ‘Square feet’, ‘Square yards’, ‘Hectares’, ‘Map Units’ ...)

  • 好みの角度単位 radioButtonOn (‘度’, ‘ラジアン’, ‘Gon/gradians’, ‘Minutes of arc’ ...)

パンとズーム

  • Mouse wheel action selectString を定義します(‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)

  • ホイールマウスの ズーム倍率 の定義

定義済み縮尺

ここでは、あらかじめ定義された縮尺のリストを見つけます。signPlussignMinus ボタンで個人的な縮尺を追加または削除できます。また、 `` .XML``ファイルへ/から縮尺を読み込みまたは書き出しできます。まだ変更を削除し、定義済みリストにリセットする可能性を持っていることに注意してください。

コンポーザメニュー

コンポジションデフォルト

ここで デフォルトfont を定義できます。

グリッドの外観

  • Grid style selectString (‘Solid’, ‘Dots’, ‘Crosses’)を定義します。

  • Grid color を定義します

Grid and guide defaults

  • グリッドspacing selectNumber を定義

  • xおよびyの グリッド・オフセット selectNumber を定義

  • スナップ許容誤差 selectNumber を定義

デジタイズメニュー

地物の作成

  • checkbox 地物作成後のポップアップ属性入力を行わない

  • checkbox 最後に入力した値を再利用する

  • ジオメトリを検証 。多くのノードを持つ複雑なラインとポリゴンを編集すると、非常に遅いレンダリングをもたらす可能性があります。QGISでのデフォルトの検証手順は多くの時間を取ることがありうるからです。レンダリングスピードアップするために、(GEOS 3.3から始まる)GEOSジオメトリ検証を選択するか、またはそれをオフにすることが可能です。GEOSジオメトリの検証がはるかに高速ですが、欠点は、最初のジオメトリの問題が報告されるということです。

ラバーバンド

  • ラバーバンドの 線幅線色 を指定して下さい

スナップ

  • checkbox ドックウィンドウ内でスナップオプションを開く (QGIS の再起動が必要)

  • デフォルトのスナップモード selectString 定義(「頂点」、「セグメントへ」、「頂点とセグメントに」、「オフ」)

  • Define Default snapping tolerance in map units or pixels
  • Define the Search radius for vertex edits in map units or pixels

頂点マーカー

  • checkbox 選択された地物のみマーカーを表示する

  • マーカーstyle selectString 頂点を定義します(「クロス」(デフォルト)、「半透明の円」または「なし」)

  • 頂点の マーカーの大きさ を指定して下さい

カーブオフセットツール

次の3つのオプションは 高度なデジタイジング 中の offsetCurve オフセット曲線 ツールを参照してください。各種設定を通じ、オフセット線の形状に影響を与えることが可能です。これらのオプションは、GEOS 3.3から始まることも可能です。

  • 結合スタイル

  • Quadrant segments
  • 継ぎ目制限

GDALメニュー

GDALはラスターファイルのためのデータ交換ライブラリです。このタブでは、次のことができます。 編集options を作成してラスタ形式の 編集ピラミッドOptions を。複数のGDALドライバが利用可能であるいくつかのケースでのように、ラスタ形式のために使用されるべきGDALドライバ定義。

CRSメニュー

新プロジェクトの既定の投影座標系

  • radioButtonOff 「その場で」再投影を有効にしない

  • radioButtonOn レイヤーのCRSが異なる場合「その場で」再投影を自動的に有効にする

  • radioButtonOff :guilabel:`デフォルトで「その場で」再投影を有効にする `

  • CRS の選択と 新しいプロジェクトは常にこの CRSで開始する

新しいレイヤの投影座標系

このエリアでは新しいレイヤが作成された場合、またはCRSのないレイヤが読み込まれた場合に、実行するアクションを定義することができます。

  • radioButtonOn CRSのプロンプト

  • radioButtonOff 利用プロジェクトCRS

  • radioButtonOff デフォルトを使用CRS

デフォルト datum 変換

  • checkbox デフォルトが定義されていないときにデータム変換をするか尋ねる

  • 「その場で」CRS変換で作業している場合は、下のウィンドウに変換の結果を見ることができます。「変換元CRS」と「変換先CRS」についての情報だけでなく、「変換元データム」と「変換先データム」を見つけることができます。

ロケールメニュー

  • checkbox システムロケールを上書きする代わりに利用するロケール

  • 有効なシステムロケールについての情報

認証

Authentication タブでは、認証設定を設定し、PKI証明書を管理できます。詳細は 認証システム 参照。

ネットワークメニュー

一般情報

  • Define WMS search address, default is http://geopole.org/wms/search?search=\%1\&type=rss
  • Define Timeout for network requests (ms) - default is 60000
  • Default expiration period for WMSC/WMTS tiles (hours) を定義して下さい- デフォルトは 24です

  • Max retry in case of tile request errors の指定

  • User-Agent の指定

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

キャッシュ設定

キャッシュのための ディレクトリサイズ の指定.

  • checkbox Web接続にプロキシを使用する と ‘ホスト’, ‘ポート’, ‘ユーザ’, と ‘パスワード’ の指定.

  • Set the Proxy type selectString according to your needs.
    • Default Proxy: プロキシはアプリケーションのプロキシ設定によって決まります

    • Socks5Proxy: あらゆる種類の接続に対応した一般的なプロキシ. TCP, UDP, ポートへのバインディング (入力コネクション) と認証をサポートします.

    • HttpProxy: “CONNECT” コマンドを実装しています, 外向きの TCP コネクションのみサポートしています; 認証をサポートしています.

    • HttpCachingProxy: 通常のHTTPコマンドを使って実装され、HTTPリクエストのコンテキストでのみ役に立ちます。

    • FtpCachingProxy:FTPプロキシを使用して実装、それだけでFTP要求のコンテキストで便利です。

プロキシ設定の下のテキストボックスに除外するいくつかのURLを追加できます( Figure_Network_Tab 参照).

別のプロキシ設定に関するより詳細な情報が必要な場合は、http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enumで基本となるQTライブラリのドキュメントのマニュアルを参照してください。

ちなみに

プロキシの利用

プロキシを使用すると、時にはトリッキーなことができます。それらが自分の場合に成功するかどうか確認するため、上記のプロキシタイプで「試行錯誤」しながら進むのが便利です。

必要に応じてオプションを変更できます。変更によっては、有効にするためにQGISを再起動する必要があることもあります。

  • nix 設定はテキストファイルに保存されます: $HOME/.config/QGIS/QGIS2.conf

  • osx $HOME/Library/Preferences/org.qgis.qgis.plist で設定を見つけることができます。

  • win  設定は以下のレジストリに保存されます: HKEY\CURRENT_USER\Software\QGIS\qgis

カスタマイゼーション

customization ダイアログでは、QGISのユーザーインターフェイスのほぼすべての要素を有効(無効)にできます。彼らが必要とする唯一のアイコン、メニューやパネルを含む、QGISの「光」バージョンを使用して、エンドユーザーに提供したい場合、これは非常に便利です。

ノート

変更が適用される前に、QGISを再起動する必要があります。

Figure Customization 1:

../../../_images/customization.png

カスタマイズダイアログ

checkbox customization チェックボックスを切り替えるのは、QGISのカスタマイズへの道の最初のステップです。これは、チェックを外しので、いくつかのGUIの項目を無効でき、そこからツールバーやウィジェットパネルを可能にします。

設定可能な項目があることができます:

  • a Menu or some of its sub-menus from the メニューバー
  • a whole Panel (see パネルとツールバー)
  • the Status bar described in ステータスバー or some of its items
  • a Toolbar: the whole bar or some of its icons
  • または任意の**ウィジェット** QGISで任意のダイアログから:ラベル、ボタン、コンボボックス...

 select メインapplicationでウィジェットを引くに切り替え で、隠すことにしたいとQGISが自動的にカスタマイズ]ダイアログ内の対応するエントリのチェックを外しQGISインターフェースの項目をクリックできます。

構成を設定したら、 [適用][OK] をクリックして変更内容を検証します。この構成は、次回の起動時にQGISでデフォルトで使用されるものとなります。

変更は fileSave Fileに保存 ボタン使用して .ini ファイルにも保存できます 。これは、複数のユーザ間で共通のQGISインターフェースを共有するための便利な方法です。 ``.ini``ファイルをインポートするためには、先のコンピュータから fileOpen Fileからロード をクリックするだけです。また同様に、 コマンドラインツール を実行してさまざまなユースケースのための各種設定を保存できます。

ちなみに

簡単に定義済みのQGISを復元

初期QGISのGUI構成は、以下のいずれかの方法で復元できます。

  • カスタマイズダイアログで checkbox カスタマイズを有効にする オプションのチェックを外すか、 selectAllTree すべてチェック ボタンをクリック

  • QSettings フレーム下で **[リセット] ** ボタンを押す 設定->Options メニュー、System タブ

  • 次のコマンドラインを使用してコマンドプロンプトでQGISを起動し、 `` QGIS –nocustomization``

  • setting to false the value of UI ‣ Customization ‣ Enabled variable under Settings ‣ Options menu, Advanced tab.

ほとんどの場合、変更が適用されるためにはQGISを再起動する必要があります。