Outdated version of the documentation. Find the latest one here.

一般ツール

キーボードショートカット

QGISは多くの機能のデフォルトのキーボードショートカットを提供します。それらはセクション メニューバー で見つけることができます。また、メニューオプション 設定] - > [設定のショートカット... ではデフォルトのキーボードショートカットを変更し、QGISの機能に新しいキーボードショートカットを追加できます。

Figure Shortcuts 1:

../../../_images/shortcuts.png

ショートカットオプションを定義

構成は非常に簡単です。リストから機能を選択し、クリックしてください:

  • [変更] と、新しいショートカットとして割り当てる新しい組み合わせを押してください

  • [Noneを設定] で任意の割り当てられたショートカットをクリアする

  • または [既定値に設定] でその元とデフォルト値へのショートカットをバックアップする。

構成が終了したら、XMLファイルとして保存し、別のQGISのインストールにそれをロードできます。

コンテキストヘルプ

特定のトピックでヘルプが必要な場合多くのダイアログに実装されている [Help] ボタンでコンテキストヘルプを利用することができます- サードパーティプラグインでは専用のウェッブページを指し示すことを注意して下さい.

レンダリング

デフォルトでは、QGISは、マップキャンバスが更新されるたびすべての可視レイヤーをレンダリングします。マップキャンバスの更新をトリガするイベントは、次のとおりです。

  • レイヤの追加

  • パンまたはズーム

  • QGISウィンドウのサイズ変更

  • レイヤまたはレイヤ群の表示、非表示を変更します

QGISではいくつかの方法でレンダリング処理を制御できます。

スケール依存レンダリング

スケール依存レンダリングを利用するとあるレイヤが表示される最小と最大のスケールを指定することができます. スケール依存レンダリングを設定する場合レイヤを凡例でダブルクリックして プロパティ ダイアログを開いて下さい. 一般情報 タブで, checkbox縮尺に応じた表示設定 チェックボックスをアクティブにして最小と最大の縮尺値を設定して下さい.

まず使用するレベルにズームしてQGISのステータスバーの縮尺値に注目することによって、縮尺値を決定できます。

地図レンダリングの制御

後述のように地図レンダリングは、さまざまな方法で制御することができます。

描画の中断

レンダリングを一時停止するには、ステータスバーの右下隅にある checkbox Render チェックボックスをクリックしてください。 checkbox Render チェックボックスがチェックされていないとき、QGISではセクション レンダリング で説明したイベントのいずれかに応じてキャンバスを再描画されません。レンダリングを一時停止する可能性がある場合の例としては、

  • 沢山のレイヤを追加して描画する前に描画方法を編集したい場合

  • データ量が多いレイヤを追加して描画する前に縮尺依存描画条件を指定したい場合

  • データ量が多いレイヤを追加して描画する前に特定の位置にズームしておきたい場合

  • 上記の場合のいくつかの組み合わせ

Checking the checkbox Render checkbox enables rendering and causes an immediate refresh of the map canvas.

レイヤ追加オプションの設定

新しくレイヤを追加した時に,すぐに描画しないオプションを設定できます.これはレイヤが地図に追加された時に,地図凡例の可視属性チェックボックスがデフォルトでチェックされないことを意味します.このオプションを指定するためには 設定 ‣ オプション ‣ を選択して レンダリング タブをクリックしてください. checkbox By default new layers added to the map should be displayed のチェックを解除してください.すると,地図に追加されたレイヤの表示属性は不可視の状態がデフォルトになります.

描画の中断

地図描画を中断したい場合は ESC キーを押して下さい.これにより地図キャンパスの更新が中断され地図の一部が描画された状態になります. ESC キーを押してから地図描画が中断されるまで少し時間がかかります.

ノート

現在描画中断機能は利用できません - これはQt4のポートに依存しています,なぜならばユーザーインターフェース(UI)に問題が発生してクラッシュするからです.

描画品質への影響

QGISは地図のレンダリング品質に影響を与えるためのオプションを持っています。メニューオプションを選択してください 設定 - > Options 、をクリックしてください Rendering ]タブを選択または checkbox いくらか描画性能を犠牲に線のギザギザを少なく を選択解除してください。

スピードアップレンダリング

レンダリング速度を向上させることができ、いくつかの設定があります。使用してQGISのオプション]ダイアログボックスを開き 設定 - > Options 、に行く Rendering ]タブを選択するか、次のチェックボックスをオフにします。

  • checkbox 再描画の速度を上げられる場合にレンダのキャッシュを利用します

  • checkbox 多くのCPUのcoresを使用して並列にレイヤーをレンダリング してから checkbox 最大コアを使用 を設定する。

  • 地図は、別々の画像とそれぞれにバックグラウンドでレンダリング checkbox 地図更新間隔 、この(オフスクリーン)画像のコンテンツが表示画面の表示を更新するために取られます。レンダリングはこの期間よりも早く終了した場合は、それが瞬時に表示されます。

  • checkbox 新しく追加されたレイヤについて地物簡素化をデフォルトで有効化 では地物ジオメトリを簡素化でき(ノードを少なく)、その結果それらは速やかに表示されます。またレンダリング矛盾に直面することもあるので注意してください。

カラーセレクタ

selectColor アイコンを押して color を選択するたび、 色選択 ダイアログが表示されます。このダイアログの機能は、の状態に依存 で使用ネイティブカラーチューdialogs パラメータのチェックボックス 設定 - >オプション - > General メニュー。チェックボックスをオンにすると、使用する色のダイアログが使用されているOSの一つです。それ以外の場合は、QGISカスタムカラー選択が使用されています。

このダイアログでは、 colorBox カラーrampcolorWheel 色wheelcolorSwatches カラーswatches または colorPicker カラーpickerosx の下で利用可能ではない)によって色を選択できるようにする四つの異なるタブがあります。

どのような方法を使用しても、選択した色は常にHSV(色相、彩度、値)とRGB(赤、緑、青)の値のカラースライダによって記述されています。透明度レベルを設定する opacity スライダーもあります。ダイアログの左下の部分では current と現在選択している new 色との比較を見ることができ、右下の部分では今カラー・スロット・ボタンに微調整した色を追加するオプションがあります。

Figure color selector 1:

../../../_images/color_selector_ramp.png

カラーセレクタランプ]タブ

ちなみに

動的 ライブ更新オプションを使用して色を変更

一般設定で ライブ更新色選択ダイアログを使用 オプションをチェックし、QGISのカスタムカラー選択ダイアログで色パラメータを変更すると色がアイテムに適用されるようにします。

colorBox カラーrampcolorWheel カラーwheel で、すべての可能な色の組み合わせを参照できます。他の可能性がありますけれども。colorSwatches 色swatches を使用することにより、事前に選択されたリストから選択できます。この選択リストは、3つの方法のいずれかが取り込まれます。

  • 最近使用した色

  • Standard colors, Settings ‣ Options ‣ Colors メニュー下の色セットのユーザー定義リスト

  • または プロジェクト色プロジェクト - >プロジェクトのプロパティ - >デフォルトStyles 下の設定色のユーザ定義リスト。

Figure color selector 2:

../../../_images/color_selector_recent_colors.png

カラーセレクタスイッチャータブ

別のオプションは colorPicker カラーpicker を使用することです スペースバーを押すことにより、QGISの任意の部分に、あるいは別のアプリケーションからマウスポインタの下から色をサンプリングすることを可能にする。カラーピッカーはOSに依存しており、現在はOSXでサポートされていないことに注意してください。

ちなみに

quick color picker + copy/paste colors

最近colors、から 標準colors または単に色を コピー貼り付け selectColor カラーボックス次のドロップダウン矢印をクリックしてすばやくから選択できます|。

Figure color selector 3:

../../../_images/quick_color_selector.png

クイックカラーセレクタメニュー

描画モード

QGISは特別の レンダリング効果 のためのさまざまなオプションを、以前にグラフィックプログラムから知っているだけかもしれないこれらのツールで提供しています。 ブレンドmodes はレイヤに、地物に、プリントコンポーザアイテムにも適用できます。

  • 通常:これは、その下のピクセルとブレンドするトップピクセルのアルファチャンネルを使用して、標準のブレンドモード、です。色が混合されていません。

  • 明るく:これは、前景と背景の画素から各成分の最大値を選択します。結果はギザギザで粗くなる傾向があることに注意してください。

  • 画面:元からの明るいピクセルが先の上に描かれ、暗いピクセルは描かれません。このモードは、一つの項目のテクスチャを他の項目と混合するために最も有用です(例えば他のレイヤをテクスチャするために陰影起伏を使用できます)。

  • ダッジ:ダッジは明るく、トップのピクセルの明るさに基づいて、基礎となるピクセルを飽和させます。だから、明るいトップピクセルは、基礎となるピクセルの彩度と明るさが増加する原因となります。トップピクセルは明るすぎていない場合、これが最も適しています。それ以外の場合は効果があまりにも極端です。

  • 追加:このブレンドモードは、単に他に1つの項目の画素値を追加します。(RGBの場合)1以上の値の場合には、白が表示されます。このモードでは、機能を強調するために適しています。

  • 暗く:これは、前景と背景のピクセルの最小構成要素を保持し、得られたピクセルを生成します。明のように、結果がギザギザと厳しい傾向にあります。

  • 乗算:ここでは、一番上の項目の各ピクセルのための番号が一番下の項目のための対応する画素に乗算されます。結果は暗い写真です。

  • バーン :トップ項目に暗い色を暗くする基礎となる項目を引き起こします。バーンは微調整と下のレイヤーをcoloriseするために使用できます。

  • オーバーレイ:このモードでは、乗算とスクリーンブレンドモードを兼ね備えています。得られた画像において、光部品が軽くなり、暗い部分がより暗くなります。

  • ソフトライト:これは、色のバーン/ダッジを使用してオーバーレイすることは非常に似ていますが、代わりに乗算/画面を使用して。これは、画像の上に柔らかい光を照射エミュレートすることになっています。

  • ハードライト:ハード光もオーバーレイモードと非常によく似ています。画像上に非常に強い光を投射エミュレートすることになっています。

  • :差は、下のピクセルからトップのピクセルを減算、またはその逆で、常に正の値を取得します。黒とブレンドすると、すべての色との差がゼロとなるので、何の変化も生じません。

  • 減算:このブレンドモードは、単に、他の一つの項目の画素値を減算します。負の値の場合には、黒色が表示されます。

ズームとパン

QGISは関心のお住まいの地域にズームするためのツールとパンを提供します。

マウスで pan pan とツールバーの zoomIn ズームイン / zoomOut ズームアウト アイコンを使用するのとは別に、マウスホイール、スペースバーと矢印キーでもナビゲーションできます。

ズームやマウスホイールでパン

マウスのホイールを押すことでメインウィンドウの内側にパンができ、マウスのホイールを回転することで地図上でズームイン、ズームアウトできます。ズームの場合は、地図エリア内にマウスカーソルを置き、それを前方に(から離れて)回してズームインするか、後方に(手前)回してズームアウトします。マウスカーソルの位置が関心のズーム領域の中心となります。 設定-> options Options メニューの下の 地図tools タブの使用して、マウスホイールのズームの動作をカスタマイズできます。

矢印キーでパニング

マップをパンニングして、矢印キーで可能です。マップ領域内にマウスカーソルを置き、北パンするには、矢印キーまで、西パン東、左矢印キーをパンする右矢印キーをクリックして、ダウン南をパンする矢印キーを。

また、一時的に地図をパンするには、マウスの動きを引き起こすためにスペースバーを使用できます。キーボードの PgUpPgDown キーで地図表示がズームインまたはズームアウトします。

計測

QGISは、ジオメトリを測定する4つの手段を提供します。

  • インタラクティブな測定ツール measure

  • calculateField Field Calculator で測定する、

  • 地物情報表示 ツールで導出された測定、

  • そして、ベクトル解析ツール: ベクトル - >ジオメトリツール] - > [エクスポート/追加ジオメトリColumns

投影された座標系(例えば、UTM)と非投影データ内の作品を測定します。最初の3つの測定ツールは、グローバルなプロジェクト設定にも同様に動作します:

「オンザフライ」CRS変換を有効にした場合、デフォルトの測定メトリックは - 楕円、で定義された楕円使用して - 他のほとんどのGIS異なる ファイル - >プロジェクトのプロパティ - > General を。システムは、プロジェクトのために定義されている投影座標の両方場合、地理的、これは真実です。( ファイル->プロジェクトのプロパティ->CRS )デカルト数学を使って投影/面積測定面積や距離を計算したい場合は、測定楕円体は、「なし/面積測定」に設定する必要があります。しかし、データ、プロジェクト、面積及び距離測定のために定義された地理的(=非投影)CRSと楕円となります。「オンザフライ」CRS変換が無効になっている場合、プロジェクト座標系は、地理的/非投影である場合、測定メトリックは、プロジェクト座標系が投影される面積測定及び楕円形です。

しかし、特定のツールとフィールド計算機のどちらも、測定する前にプロジェクトのCRSにデータを変換しません。これを達成したい場合は、ベクトル解析ツールを使用する必要があります: ベクトル - >ジオメトリツール] - > [ジオメトリColumnsをエクスポート/追加 。ここでは、測定は、楕円指標を選択した場合を除き、デフォルトのプラニメトリックです。

長さ、領域を測定し、インタラクティブな角度

すべての測定モジュールは、デジタル化モジュールからのスナップ設定を使用します。ベクターレイヤーで線や領域に沿って測定したい場合に便利です。

測定ツールを選択するには、 measure をクリックし使用したいツールを選択します。

デフォルトでは、measure Lineを測定 : QGIS対策定義楕円に従って与えられた点間の実距離します。メニューオプション 設定 - >オプション - >地図Tools で、ラバーバンド色やお好みの測定単位(メートルまたはフィート)と角度の単位(度、ラジアンと坤)を定義できます。このツールは、地図上のポイントをクリックできます。各セグメントの長さ、ならびに合計は、メジャー・ウィンドウに表示されます。測定を停止するには、マウスの右ボタンをクリックしてください。対話的に測定ダイアログに測定単位を変更できることに注意してください。それはオプション中の 好適な測定units を上書きします。設定は、測定の計算の際に使用されているCRSを示すダイアログ内の情報セクションがあります。

Figure Measure 1:

../../../_images/measure_line.png

距離を計測

measureArea Areaを計測 :面積も計測できます。計測ウィンドウに累積された面積のサイズが表示されます。また、計測ツールは、現在選択されているレイヤにスナップし、そのレイヤは、( スナップ許容量と検索半径の設定 セクションを参照)、そのスナップ公差が設定されていました。正確にライン地物に沿って、またはポリゴン地物の周りを計測したいのであれば、まずレイヤーを選択し、そのスナップ許容値を設定します。今、計測ツールを使用している場合(許容範囲の設定内)の各マウスクリックは、そのレイヤーにスナップします。

Figure Measure 2:

../../../_images/measure_area.png

面積を測定

measureAngle 角度を測定 :角度も測定できます。カーソルが十字型になります。所望の角度を描画するためにカーソルを移動し、その後、測定したい角度の最初のセグメントを描画するためにクリックしてください。測定値は、ポップアップダイアログに表示されます。

Figure Measure 3:

../../../_images/measure_angle.png

角度を測定

地物の選択と選択解除

QGISのツールバーでは、地図キャンバスの地物を選択するためのいくつかのツールを提供します。一つまたは複数の地物を選択するには、 select をクリックしてツールを選択するだけです。

  • selectRectangle 領域または単一クリックで地物を選択 で、クリックするだけか長方形いずれかによって地物(複数可)を選択します

  • selectPolygon ポリゴンで地物を選択

  • selectFreehand フリーハンドで地物を選択

  • selectRadius 半径で地物を選択

選択されたすべての地物の選択を解除するには deselectAll すべてLayersからの地物の選択を解除 をクリックします。

expressionSelect 式を使用して地物を選択 では、ユーザが式ダイアログを使用して地物を選択できます。いくつかの例は 章を参照。

ユーザーは 編集->地物をコピー編集->地物貼り付けas を使用して 新しいメモリベクタレイヤー新しいベクトルレイヤー に選択した地物を希望の形式で保存できます。

データ定義された上書き設定

印刷コンポーザのベクターレイヤーのプロパティ]ダイアログボックスまたは設定で多くのオプションのほかに、見つけることができる dataDefined データがoverride アイコンを定義しました。レイヤーの属性や項目設定に基づく 、事前作成またはカスタム関数、および 変数 のおかげで、このツールでは関係パラメータの値を動的に設定できます。有効にすると、このウィジェットによって返される値が、その正常値にかかわらず、パラメータに適用されます(チェックボックス、テキストボックス、スライダー...)。

dataDefined データ定義された上書き アイコンをクリックすると以下が表示されます:

  • Description ... これが有効かどうか、どの入力タイプが予想されるか、有効な入力タイプ、および現在の定義を表示、

  • 利用可能な Field type をリストするエントリ、

  • 利用可能な Variable をリストするエントリ、

  • 使用する式を作成または編集するには 編集...ボタン

  • Paste および Copy ボタン,

  • Clear ボタンで設定を削除

ちなみに

データ定義された上書き オプションが正しく設定されると、アイコンは黄色 dataDefineOndataDefineExpressionOn ;それが壊れている場合、アイコンは赤 dataDefineErrordataDefineExpressionError

データ定義ツールで使用できるパラメータは:

  • スタイルと記号のパラメータ

  • ラベルパラメータ

  • コンポーザパラメータ

地物情報表示

識別ツールを使用すると、地図キャンバスと相互作用して、ポップアップウィンドウで地物についての情報を取得できます。地物を特定するには 表示->地物を特定 を使用するか、 Ctrlキー+シフト+ I を押すか、または属性ツールバーの identify featuresを識別 アイコンをクリックします。

QGISは、 identify Identify features ツールを使用して地物を識別する2つの方法を提供します:

  • 左クリックIdentify results パネルで設定されたモードに従って地物を識別します

  • 右クリック ではすべての表示レイヤーからすべてのスナップ地物を取得します。これはコンテキストメニューを開き、識別するより正確な地物をユーザが選択できます。

results ダイアログがクリックされた地物(複数可)についての情報が一覧表示されます確認しますが、地物(複数可)をクリックした場合。デフォルトのビューはツリービューです、その最初のアイテムはレイヤーの名前であり、その子供たちはその識別された地物(複数可)。各地物は、その値と一緒に、フィールドの名前で記述されています。このフィールドは プロパティ->Display で設定されるものです。そして、地物についての他のすべての情報を続く。

このウィンドウはカスタムフィールドを表示するためにカスタマイズできますがデフォルトで3種類の情報を表示します:

  • アクションActions は、地物の特定ウィンドウに追加できます。アクションは、アクションのラベルをクリックすることで実行されます。デフォルトでは、1つのアクションだけでは、編集のため、すなわち ビュー機能のform を追加されます。レイヤーのプロパティダイアログでより多くのアクションを定義できます。

  • 派生 :この情報は、他の情報から計算または導出されます。これに含れるのは、地物ID、ジオメトリに応じて地図単位でのその長さまたは周長と面積、マルチジオメトリの場合に空間部分の数とクリックされた部分の数、地物の頂点の数とクリックされた点に最も近い点の番号。また、クリックされた点と地物両方に最も近い頂点のX及びY(及び利用可能な場合Z/M)の座標値を報告します。

  • データ属性 :これは、クリックされた地物の属性フィールドと値のリストです。

Figure Identify 1:

../../../_images/identify_features.png

地物を特定ダイアログ

ウィンドウの上部には、7つのアイコンがあります。

  • expandTree ツリーを展開

  • collapseTree Collapse tree
  • expandNewTree Default behavior 次の識別された地物情報を折りたたむか展開するかを定義する

  • propertyItem 地物を表示フォーム

  • deselectAll 結果をクリア

  • editCopy 選択地物をクリップボードにコピー

  • filePrint Print selected HTML response

モードView コンボボックス、ウィンドウの下部には、持っています。 モード コンボボックスは、ユーザーが定義できますレイヤの地物が特定されるべきで、そこからの場合:

  • 「現在のレイヤー」:選択したレイヤーからの地物だけが特定されます。レイヤーは、キャンバスに表示されなくてもよいです。

  • 「上から下に、最初から停止する」:上から見えるレイヤーからのフィーチャだけを。

  • 「トップダウン」:可視レイヤーからのすべてのフィーチャー。結果はパネルに表示されます。

  • そして、「レイヤーの選択」:地物を識別するレイヤーをユーザーが選択するコンテキストメニューを開きます。右クリックのように動作します。選択された地物だけが結果パネルに表示されます。

View が「木」、「テーブル」または「グラフ」として設定できます。「表」と「グラフ」ビューは、ラスタレイヤを設定できます。

特定ツールは、 checkbox 自動formを開く することができます。チェックした場合、単一の地物が特定されるたびにQGISは、その属性を示すフォームが開きます。これはすぐに地物の属性を編集するための便利な方法です。

その他の機能は、識別されたアイテムのコンテキストメニューにあります。たとえば、コンテキストメニューから次のことができます:

  • 地物フォームの表示

  • 地物のズーム

  • 地物のコピー: すべての地物,のジオメトリと属性をコピーします;

  • 地物選択を切り替え:選択した地物を選択項目に追加します

  • 属性値のコピー: あなたがクリックした属性値のみをコピーします。

  • コピー地物属性:地物の属性をコピーします。

  • 結果のクリア:ウィンドウ内の結果が削除されます

  • ハイライトのクリア:地図上でハイライトしている地物が除去されます

  • すべてをハイライトする

  • レイヤをハイライトする

  • レイヤのアクティベート: アクティベートするレイヤの選択

  • レイヤプロパティ: レイヤプロパティウィンドウを表示する

  • すべてを展開する

  • すべてを折りたたむ

アノテーションツール

textAnnotation 属性ツールバーのテキストAnnotation ツールはQGIS地図キャンバス上の吹き出しでフォーマットされたテキストを配置する可能性を提供します。 テキストAnnotation ツールを使用、地図キャンバスにクリック。

Figure annotation 1:

../../../_images/annotation.png

注釈テキストダイアログ

項目をダブルクリックすると、さまざまなオプションを含むダイアログが開きます。フォーマットされたテキストやその他の項目の設定値を入力するテキストエディタがあります。例えば、マップの位置(マーカーシンボルが表示された)に関する項目またはスクリーンの位置(マップに関連していない)における選択肢を持ちます。この項目はマップの位置(マップマーカーをドラッグすることにより)が移動し、またはバルーンのみが移動します。アイコンは、GISの主題図の一部であり、それらも、他の主題図においてデフォルトとして用いられます。

annotation Annotation移動 ツールを使用すると、地図キャンバスで注釈を移動できます。

HTML注記

formAnnotation HtmlのAnnotation ツール属性ツールバーでは、QGISマップキャンバス上のバルーンにhtmlファイルの内容を配置する可能性を提供します。 HtmlのAnnotation ツールを使用し、マップキャンバス中をクリックしてダイアログにHTMLファイルへのパスを追加します。

SVG注記

属性ツールバーの saveAsSVG SVG Annotation ツールは、QGIS地図キャンバス上のバルーンにSVGのシンボルを配置する可能性を提供します。 SVGのAnnotation ツールを使用し、地図キャンバス中をクリックしてダイアログにSVGファイルへのパスを追加します。

注記の書式設定

また、独自の注釈フォームも作成できます。 formAnnotation フォームAnnotation ツールは、カスタマイズされたQtのデザイナーフォームにおけるベクトルレイヤの属性を表示することが有用である( figure_custom_annotation を参照)。これは、デザイナーフォームに似ています features ツールを識別しますが、注釈項目に表示されます。詳細については、ティム・サットンからのこのビデオ https://youtu.be/0pDBuSbQ02o?t=2m25s も参照してください。

Figure annotation 2:

../../../_images/custom_annotation.png

Customized qt designer annotation form

ノート

If you press Ctrl+T while an Annotation tool is active (move annotation, text annotation, form annotation), the visibility states of the items are inverted.

空間ブックマーク

空間ブックマークでは地理的な位置を「しおり」にすることを許可し、後でそれに戻れます。ブックマークは、それらが同一のコンピュータで任意のプロジェクトから利用可能であることを意味し、コンピュータに保存されています。

ブックマークの作成

ブックマークを作るには:

  1. 関心のある領域にズームまたはパンします。

  2. メニューオプション View ‣ New Bookmark を選択するか Ctrl-B を押します。新しく作成されたブックマークが表示された[Spatial Bookmark]パネルが開きます。

  3. ブックマークを説明する名称(255文字まで)を入力します。

  4. Enter を押してブックマークを追加するか、他の場所をクリックします。

同じ名称で複数のブックマークを所有できることにご注意ください。

ブックマークの操作

ブックマークを使用または管理するには ビュー- >ブックマークを表示 メニューオプションを選択します。 空間Bookmarks パネルは、次の操作を実行できます。

  • ブックマークにズーム:希望のブックマークを選択し、 Zoom To Bookmark をクリックします。それをダブルクリックしてもブックマークにズームできます。

  • ブックマークを削除する:ブックマークを選択して Delete Bookmark をクリックします。選択を確認してください。

  • インポート/エクスポートBookmarks:コンピュータ間でブックマークを共有したり転送するには、 空間Bookmarks ダイアログの ブックマークをインポートまたはエクスポート プルダウンメニューを使用できます。すべてのブックマークが転送されます。

プロジェクトの入れ子

プロジェクトに他のプロジェクトファイルからコンテンツを埋め込む場合 Layer ‣ 埋め込みレイヤとグループ を選択して下さい.

埋め込みレイヤ

次のダイアログで,他のプロジェクトのレイヤを埋め込むことができます.

  1.  browseButton を押し、アラスカのデータセットからプロジェクトを探します。

  2. relations.qgs プロジェクトファイルを選択します。プロジェクトの内容を見ることができます( figure_embed_dialog 参照)。

  3. Ctrl を押してレイヤー airportsregions をクリックしてください。 [OK] を押してください。選択されたレイヤは、現在、地図凡例とマップビューに埋め込まれています。

Figure Nesting 1:

../../../_images/embed_dialog.png

埋め込むためのレイヤーとグループを選択します

埋め込まれているレイヤが編集可能になっている間,スタイルやラベリングのようなプロパティは変更することができません.

埋め込みレイヤの除去

埋め込みレイヤーを右クリックし、 removeLayer Remove 選択します。

整飾

QGISの整飾には、グリッド、著作権ラベル、ノースアロー、およびスケールバーが含まれます。地図製作要素を追加することによって地図を「装飾」するために使用されます。

グリッド

transformed グリッド では座標のグリッドと座標注記をマップキャンバスに追加します。

Figure Decorations 1:

../../../_images/grid_dialog.png

グリッドダイアログ

  1. Select from menu View ‣ Decorations ‣ Grid. The dialog starts (see figure_decorations_1).
  2. マップキャンバスにロードされているレイヤにしたがって checkbox Enable grid チェックボックスを有効にしてグリッドの設定を行って下さい.

  3. マップキャンバスにロードされているレイヤにしたがって checkbox Draw annotations チェックボックスを有効にしてアノテーションの定義を行ってください.

  4. [適用] をクリックして、期待通りに表示されていることを確認するか、満足なら [OK] をクリックします。

北向き矢印

northArrow 北矢印 はマップキャンバス上で簡単な北の矢印を配置します。現在、利用可能なスタイルはただ一つだけあります。矢印の角度を調整したり、QGISが自動的に方向を設定できます。QGISが方向を決定させることを選択した場合、それは矢印が志向すべきかに関して、その最良の推測になります。矢印の配置については、地図キャンバスの四隅に対応した、4つのオプションがあります。 (キャンバス)EdgeからMarging 水平および/または垂直方向を設定することにより、矢印の配置を絞り込むことができます。これらの値は、 ミリ または ピクセル における距離、または地図キャンバスの幅又は高さの 割合 として設定できます。

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

The North Arrow Dialog

スケールバー

scaleBar スケールBar は、地図キャンバスに、単純なスケールバーを追加します。スタイルや配置だけでなく、バ​​ーのラベルを制御できます。

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

スケールバーダイアログ

QGISでは、地図フレームと同じ単位での目盛り表示だけがサポートされます。レイヤの単位がメートルならば、フィートでスケールバーは作成できません。同様に、小数度を使用している場合は、メーターで距離を表示するスケールバーは作成できません。

スケールバーを追加するために:

  1. メニューの ビュー ‣ 地図整飾 ‣ 著作権ラベル を選択して下さい.ダイアログが表示されます( figure_decorations_4 を参照して下さい).

  2. checkbox スケールバーを有効にする チェックボックスがチェックされているかどうか確認してください.

  3. Scale bar style selectString コンボボックスからスタイルを選択します。

  4. バー barの色 selectColor について色を選択するか、デフォルトの黒色を使用します。

  5. Size of bar selectNumber を設定します。

  6. 必要に応じて、 checkbox resize上の丸め数に自動的にスナップ をチェックして、読みやすい値を表示します。

  7. Placement selectString コンボボックスから配置を選択します。

  8. (キャンバス)Edge`からMarging `水平および/または垂直方向を設定することで、アイテムの配置を絞り込むことができます。これらの値は、 ミリ または ピクセル における距離、またはマップキャンバスの幅又は高さの 割合 として設定できます。

  9. [適用] をクリックして、期待通りに表示されていることを確認するか、満足なら [OK] をクリックします。

ちなみに

整飾の設定

.qgs プロジェクトを保存する際,グリッド,方位記号,スケールバーと著作権ラベルに加えた変更はそのプロジェクトに保存され,次回プロジェクトをロードした際に復元されます.

認証

QGISは安全な方法で認証資格情報を取得/保存するための機能があります。ユーザーは安全にポータブルデータベースに格納されている認証設定、に資格情報を保存、サーバーやデータベース接続に適用でき、かつ安全にプロジェクト内のIDトークンまたは設定ファイルが参照できます。詳細については、認証システム を参照。

マスターパスワードは、認証システムとそのポータブルデータベースを初期化する際に設定する必要があります。

ファイルにレイヤーを保存

レイヤー(ラスタまたはベクトル)は、レイヤーのコンテキストメニュー中の 名前を付けて保存... 機能(レイヤツリー内のレイヤを右クリックして)または レイヤー->名前を付けて保存... メニューにより、別の形式で保存できます。

保存As ダイアログではレイヤーを保存するときの動作を変更するいくつかのパラメータが表示されます。共通のパラメータ(ラスターとベクター)は、次のとおりです。

  • フォーマット

  • ファイル名

  • CRS
  • キャンバスに新しいレイヤーを追加するために、保存ファイルを地図に追加

  • 範囲(可能な値はレイヤー、地図ビューまたはカスタム範囲です)

  • いくつかの高度なオプションを変更でき(ラスター用)、レイヤーまたはカスタム(ベクターの)オプションを作成します。高度なユーザーは、 GDAL-OGR <http://gdal.org> _ドキュメントのドライバのマニュアルを参照してくださいすることができます。

しかしながら、ラスターとベクターのどちらかだけに特有のパラメーターもあります:

  • ラスター特有のパラメータ:

    • 解像度(水平および垂直)

    • ピラミッドの作成

    • 出力モード(生データ又はレンダリングされた画像)

  • ベクター特有のパラメータ:

    • エンコーディング

    • 選択地物のみを保存

    • 属性の作成をスキップ

    • シンボルの書き出し:DXFの書き出しのために、DXF、KMLとして(下記の注を参照)タブのファイル形式をOGR地物スタイルを管理するすべてのファイル形式のために主に使用できます。

      • シンボルなし:データを読み込むアプリケーションのデフォルトスタイル

      • 地物シンボル:OGR地物スタイルによるスタイルの保存(下記を参照)

      • シンボルレイヤーシンボル:OGR地物スタイルで保存(下記の注を参照)が、使用される複数のシンボルのシンボルレイヤーが存在する場合、同じジオメトリを複数回エクスポート

    • ジオメトリ:

      • マルチジオメトリへの力、

      • z次元を追加し、

      • ドロップダウンリストでジオメトリ列を追加または削除。これは、レイヤーの現在のジオメトリタイプとリンクされていません。属性テーブルに空のジオメトリ列を追加したり、空間レイヤーのジオメトリ列を削除できます。

ノート

OGRの地物スタイル は、隠し属性などのデータに直接スタイルを格納する方法です。この種の情報を扱えるフォーマットは限られています。KML、DXFおよびTABファイル形式は、このような形式です。高度なユーザーのために、 OGR地物スタイル仕様<http://www.gdal.org/ogr_feature_style.html> _ のドキュメントをお読みください。

ノート

DXFファイルについて

ベクタレイヤーは別のツール、 ProjectDXFエクスポート... 、を使用してDXFファイルにエクスポートできます。ウィンドウは、ユーザが、DXFファイルに含めるレイヤーファイル、記号モード(上記注を参照)、シンボルスケール、符号化、可視プリセットとレイヤーを選択することを可能にします。

オプションとして、 設定された場合はレイヤーのタイトルを名前として使用 または checkbox 現在の地図範囲と交差する地物を書き出し できます。

動的なコンテンツのための変数の使用

式 用にカスタム変数を定義できます。変数は、アプリケーションのグローバルレベル、プロジェクトレベル、階層レベルと組成のレベルで定義できます。ただ、CSSのカスケーディング規則のように、変数を上書できます - 例えば、プロジェクトレベルの変数が設定された任意のアプリケーションレベルの変数を上書きします。変数名の前に@文字を使用してテキスト文字列またはその他のカスタム式を構築するために、これらの変数を使用できます。例えば、コンポーザにこの内容でラベルを作成する:

This map was made using QGIS [% @qgis_version %]. The project file for this
map is: [% @project_path %]

このようなラベルをレンダリングします:

This map was made using QGIS 2.14. The project file for this map is:
/gis/qgis-user-conference-2015.qgs

設定- > Options メニュー、およびプロジェクトのプロパティからプロジェクトレベルの変数からグローバル変数を管理できます(独自のカスタム変数の追加など)。

Figure Variables dialog 2:

../../../_images/options_variables.png

プロジェクトレベルで編集変数

ノート

さらなる情報を読んだり、例をみつけられるのはここ Exploring variables in QGIS 2.12, part 1, part 2 and part 3