Outdated version of the documentation. Find the latest one here.

QGIS GUI

QGIS は起動時には図に示されているようなGUIで表示されます(黄丸中の数1から5までを下で説明します)。

Figure QGIS GUI 1:

../../../_images/startup.png

AlaskaサンプルデータでのQGIS GUI

ノート

ウィンドウの装飾(タイトルバーとか)は利用している オペレーティングシステムやウィンドウマネージャによって見かけが異なります.

QGIS GUIは、5つのエリアに分かれています。

  1. メニューバー

  2. ツールバー

  3. パネル

  4. 地図ビュー

  5. ステータスバー

QGISインターフェースのこれらの5つの構成要素は、以下のセクションでより詳細に記載されています。さらに2つのセクションではキーボードショートカットやコンテキストヘルプを説明しています。

パネルとツールバー

View メニュー( KDEの下Settings )から、およびQGISウィジェットオン・オフを切り替えることができます( パネル-> )またはツールバーの( ツールバー-> )。メニューバーやツールバーを右クリックすることにより、それらのいずれかを有効(無効)にして、必要な項目を選択できます。各パネルやツールバーが移動し、QGISインターフェースで快適に感じる場所に配置できます。リストはまた、 コアまたは外部のプラグイン の活性化にも拡張できます

ツールバー

ツールバーではメニューのほとんどと同じ機能を提供している上に対話的に地図を操作する機能を提供しています.ツールバーのそれぞれのアイテムではポップアップヘルプが提供されています.マウスでアイテムの上を動かすとツールの簡単な説明が表示されます.

すべてのツールバーには、必要に応じて周りに移動できます。さらに、それらは、マウスの右ボタンのコンテキストメニューを使用して、またはツールバーの上にマウスを保持することによって非表示にできます。

Figure Toolbars:

../../../_images/toolbars1.png

ツールバーメニュー

ちなみに

ツールバーの復元

誤ってツールバーが非表示になってしまった場合は、メニューオプションを選択することで元に戻せます 表示 - >ツールバー - > (またはLinuxのKDEの下では 設定 - >ツールバー - > )。何らかの理由でツールバー(または任意の他のウィジェット)が完全にインターフェイスから消えた場合は、 初期GUIを復元する のヒントでそれを取り戻すために見つけることができます

パネル

QGISは、デフォルトではで動作するように多くのパネルを提供します。

Figure Panels:

../../../_images/panels.png

[パネル]メニュー

他の人が文書の異なる部分に見出すことができるが、これらのパネルのいくつかは、すなわち、以下に記載します。

レイヤーパネル

レイヤーパネルには、プロジェクト内のすべてのレイヤーが一覧表示されています。各凡例項目のチェックボックスがレイヤーを表示または非表示にするために使用できます。レイヤーパネルのツールバーでできるのは:

  • addGroup 新規グループを追加

  • showPresets 可視性を管理:レイヤーと予め設定されたレイヤーの組み合わせの可視性を制御

  • filterMap 地図Contentによって凡例をフィルタ :表示に設定されていて、地物が現在の地図キャンバスと交差するレイヤーだけが、レイヤーパネルに自分のスタイルをレンダリングされます。それ以外の場合は、一般的なNULLシンボルがレイヤーに適用されます。レイヤーシンボルに基づいて、これは地物のどの種類のどのレイヤーからが関心のお住まいの地域をカバーしているかを識別するための便利な方法です。

  • expressionFilter 式によって凡例をフィルタ :式を適用して条件を満たす地物がない、選択したレイヤーツリースタイルから削除できます。これは例えば、他のレイヤーの所定の領域/地物内にある地物を強調するために、使用できます。ドロップダウンリストから、式セットを編集したりクリアできます。

  • レイヤーパネルでレイヤーとグループを expandTree すべて展開 または collapseTree すべてCollapse

  • そして removeLayer Remove Layer/Group 現在選択されている。

Figure Layer tools Bar:

../../../_images/layer_toolbar.png

Layer Toolbar in Layers Panel

ボタン showPresets では凡例に プリセット ビューを追加できます。プリセットは自分の現在のスタイルとレイヤーの組み合わせを簡単に保存し復元する方法です。プリセットビューを追加し、ちょうどしたいレイヤー表示設定、自分の希望のシンボルとし、 showPresets ボタンをクリックしてください。ドロップダウンメニューから プリセットを追加... を選択してください、プリセットに名前を付けます。追加されたプリセットはドロップダウンメニューの下部に表示され、これをクリックすることによって呼び出されます。

プリセットを交換 -> オプションでは現在のマップビューでプリセット内容を上書きでき、現在Presetを削除 ボタンはアクティブプリセットを削除できます。

すべての追加されたプリセットは、特定のビューに基づく地図レイアウトを作成することを可能にするために、地図コンポーザーにも存在しています( メインプロパティ を参照)。

ノート

印刷コンポーザの地図および凡例項目をレイアウトするためにレイヤーパネルを管理するためのツールも利用できます

レイヤは選択してドラッグで上下に移動することによってZオーダリングを変えることができます.Zオーダリングとは,凡例のリストでの表示順が地図表示のレイヤ表示順になることです.

ノート

この動作は Layer Order パネルによって上書きできます。

凡例ウィンドウ内のレイヤはグループに分類できます。その方法は2つあります:

  1. folder アイコンを押して新しいグループを追加します。グループ名を入力してから Enter キーを押して下さい。 それから既存のレイヤをクリックしてグループにドラッグして下さい。

  2. 凡例ウィンドウでいくつかのレイヤを選択してマウス右ボタンをクリックして Group Selected を選択して下さい.選択されたレイヤで自動的に新しいグループが作られます.

あるレイヤをグループからはずしたい場合はレイヤ名をドラッグしてグループ外に持っていくかマウス右ボタンクリックして Make to toplevel item を選択して下さい.グループは他のグループからネストすることができます.

グループ用チェックボックスを使うとグループ内全レイヤの表示,非表示を1回のクリックで行えます.

右マウスボタンのコンテキストメニューの内容は、選択された凡例項目がラスターレイヤーかベクトルレイヤーかに依存します。GRASSベクトルレイヤーについては、 toggleEditing 編集を切り替え は使用できません。GRASSベクトルレイヤーの編集については、 GRASSベクタレイヤのデジタイジングと編集 セクションを参照してください。

以下は、選択した項目に応じて、コンテキストメニューで利用可能なオプションを記載されています。

オプション

ベクタレイヤ

ラスターレイヤー

グループ

zoomToLayer Zoom to Layer/Group checkbox checkbox checkbox
unchecked Show in Overview checkbox checkbox
zoomActual Zoom to Native Resolution (100%) checkbox

現在範囲を使用してストレッチ

checkbox
removeLayer Remove checkbox checkbox checkbox
duplicateLayer Duplicate checkbox checkbox
Set Layer Scale Visibility checkbox checkbox
Set Layer/Group CRS checkbox checkbox checkbox

レイヤのCRS をプロジェクトに設定する

checkbox checkbox
Styles ‣ checkbox checkbox

スタイルコピー

checkbox checkbox
Paste Style checkbox checkbox checkbox
openTable Open Attribute Table checkbox
toggleEditing Toggle Editing checkbox
allEdits Current Edits ‣ checkbox (in Edit mode)
Save As... checkbox checkbox
Save As Layer Definition File... checkbox checkbox checkbox

フィルター

checkbox
unchecked Show Feature Count checkbox

プロパティ

checkbox checkbox
Move to Top-level checkbox checkbox

改名

checkbox checkbox checkbox

選択されたレイヤをグループにする

checkbox checkbox

プロパティ

checkbox checkbox
Set Group WMS Data checkbox
unchecked Mutually Exclusive Group checkbox
addGroup Add Group checkbox

相互排他グループ オプションを有効にすると、グループで同時に表示されるレイヤーは一つだけにできます。グループ内のレイヤーが表示設定されるといつでも他のものは非表示に切り替わります。

Ctrl キーを押しながらマウス左ボタンを使うことで複数のレイヤやグループを同時に選択することができます. 選択している全レイヤを同時に新しいグループにすることができます.

Ctrl キーで複数項目を選択してその後 Ctrlキー+D を押すことにより、複数のレイヤーまたはグループも一度に削除できます。この方法では、選択したすべてのレイヤーまたはグループがレイヤーリストから削除されます。

編集ベクトルレイヤースタイル

レイヤーパネルからは、簡単かつ迅速レイヤーのレンダリングを編集するためのショートカットを持っています。ベクタレイヤーを右クリックし、リストで[ スタイル - > するために選択:

  • レイヤーに現在適用されている スタイル を参照 。レイヤーのための多くのスタイルを定義した場合、別のに切り替えると、レイヤーのレンダリングが自動的に地図のキャンバスに更新できます。

  • 現在のスタイルをコピーし、該当する場合、別のレイヤーからコピーしたスタイルを貼り付け

  • (実際には、現在の1のコピーである)新しいものを追加し、現在のスタイルの名前を変更したり、現在のスタイルを削除します(使用可能な場合、複数のスタイル)。

ノート

以前のオプションもラスタレイヤのために用意されています。

ベクターレイヤーの地物が全て同じ一意のシンボルを持つか、それらが分類されるか(その場合、レイヤーは、サブ項目として各クラスにツリー構造で表示される)どうかを、次のオプションがレイヤーレベルまたはクラスレベルで利用可能です:

  • シンボルを編集... ` ボタン、レイヤーや地物のシンボルの :ref:`シンボルselector ダイアログを開き任意のプロパティ(シンボル、サイズ、色...)を更新します。地物をダブルクリックしても シンボルSelector ダイアログは開きます。

  • カラーホイール を持つ カラーselector ウィジェットでは、そこから色をクリックできますし、それが自動的にシンボルの塗りつぶしの色を更新しています。便利のために、 最近の色 がカラーホイールの下でご利用いただけます。

  • 地物のすべてのクラスの可視性をオンまたはオフを切り替える showAllLayers 全項目を表示hideAllLayers 全項目を非表示 。これにより項目のチェックを一つずつ付けはずししなくてよくなります。

ちなみに

すぐにレイヤースタイルを共有します

コンテキストメニューから、レイヤーのスタイルをコピーして、グループまたはレイヤーの選択に貼り付け:スタイルは、元のレイヤーと同じタイプ(ラスタ対ベクター)である全てのレイヤーに適用され、されていますベクターの場合に、同じジオメトリタイプ(点、線又はポリゴン)を有します。

レイヤの標示順序から独立した凡例の操作

凡例の順序とは独立に描画順序を指定できるウィジェットがあります。この機能はメニュー Settings ‣ Panels ‣ レイヤー順序Panel で有効にできます。ここでは 地図上でのレイヤ描画順序を指定できます。この指定でたとえば重要さの順にレイヤを描画できますが、このままでは依然として修正した結果の順にレイヤが表示されます ( figure_layer_order を参照)。レイヤリストの下にある checkbox レンダリング順序を制御 をチェックするとデフォルトの動作と異なる動作をするでしょう。

Figure Layer Order:

../../../_images/layer_order.png

レイヤの順序から独立した凡例を定義

統計の概要パネル

このパネルでは、特定のベクターレイヤー上のいくつかの統計情報を表示できます。パネルは、ユーザーが選択できます:

  • ベクターレイヤー;

  • 列または式;

  • 選択した地物の統計情報をフィルタリングします。

  • 情報を更新;

  • 下右ボタンで表示する統計情報;

QGIS全体図パネル

QGISでは追加されたレイヤの全範囲のビューを提供するオーバービューパネルを提供します。ビュー内に現在の地図範囲を示す矩形があります。これによって、現在表示している地図のどの領域かをすぐに決定できます。地図オーバービューのレイヤにラベリングが設定されていても、ラベルは地図オーバービューにレンダリングされないことに注意してください。オーバービューで現在の領域を示す赤い四角形をクリック・ドラッグすると、主地図ビューもそれに応じて更新されます。

ログメッセージパネル

いくつかの操作をロードまたは処理するときには、messageLog ログメッセージパネルを使用して別のタブに表示されるメッセージに追跡または従うことができます 。これは、下のステータスバーの最も右側のアイコンを使用して有効にできます。

取り消し/再実行パネル

編集中のそれぞれの層のために、このパネルは、迅速に、単に上記のアクションを選択することによって、一連のアクションを元に戻すできるように、行うアクションのリストを示します。

地図ビュー

地図キャンバス とも呼ばれ、これはQGISの「業務窓口」である—地図がこのエリアに表示されます。このウィンドウに表示された地図は、ロードすると選択したベクトル・ラスターレイヤーに依存します(レイヤーをロードする方法の詳細については、以下のセクションを参照)。地図ビューでは、他の領域に地図表示の焦点をシフトする、パンやズームインズームアウトできます。上記 label_toolbars 説明に記載されるように、様々な他の動作が地図上で行うことができます。地図ビューと凡例がしっかりと互いに結合している—ビューの地図を使って凡例領域で行った変更を反映しています。

ちなみに

マウスホィールを使って地図をズームします

マウスホィールを使って地図のズームインとズームアウトを行うことができます. マウスカーソルを地図エリアの中に置きホィールを前方(あなたの側から)ロールするとズームインを行えます,そして手前に(あなたの側に)ロールするとズームアウトします. マウスカーソルの位置がズームの中心になります. マウスホィールのズーム動作については Settings ‣ Options メニューの Map tools タブでカスタマイズができます.

ちなみに

矢印キーとスペースバーを使った地図パンニング

矢印キーを使ってパンを行うことができます. マウスカーソルを地図エリアにおきクリックした後右矢印キーを押すと東にパンします,左矢印キーを押すと西にパンします,上矢印キーを押すと北にパンします.下矢印キーを押すと南にパンします.またスペースバーかマウスホィールを使ってパンを行うことができます.この場合スペースバーを押しながらマウスを動かすかマウスホィールをクリックして下さい.

ステータスバー

ステータスバーには、マップビューに関する一般的な情報を提供します、そしてアクションが処理されるか、または利用可能とマップビューを管理するツールを提供しています。

ステータスバーの左側には、行った操作の概要(レイヤーの地物を選択、レイヤーの除去、など)や上にマウスを移動しているツールの長い説明(すべてのツールでは使用できません)を取得できます。起動時に、バーの状態は新規またはアップグレードプラグインの可用性について知らせます( プラグインマネージャの設定 にチェックされている場合)。

長い操作、ラスタレイヤーにおける統計の収集または地図ビューで複数レイヤーのレンダリングなど、の場合には、プログレスバーがアクションの現在の進行状況を表示するステータスバーに表示されます。

tracking :guilabel: 座標 オプションはマップビューを横切って移動しながら、それに続く、マウスの現在位置を示しています。プロジェクトのプロパティで[全般]タブを使用するユニット(および精度)を設定できます。座標オプションと範囲 extents 範囲 オプションを切り替えるには、テキストボックスの左側にある小さなボタンをクリックしてください。 地図単位で表示される、パンやズームイン、ズームアウトのように現在の下部左端とマップビューの上部右端点の座標。

縮尺 表示次座標表示に見つけるでしょう。これは、地図ビューの縮尺を示しています。またはズームアウトした場合、QGISは現在の縮尺を示しています。 定義済みおよびカスタム縮尺 中から選択することを可能にする縮尺セレクタがあり、マップビューに割り当てます。

縮尺表示の右側では、地図ビューの現在の時計回りの回転を度で定義できます。

ステータスバーの右側には、一時レイヤーが、マップビューにレンダリングされるのを防ぐために使用できる小型のチェックボックスがあります(セクション レンダリング を参照)。

レンダリング機能の右側には、が見つける projectionDisabled 現在のCRS :アイコン現在のプロジェクトのCRSのEPSGコードと。これをクリックすると、現在のプロジェクトのプロパティ 「その場で」CRS変換を有効 にでき、地図ビューに別のCRSを適用します。

最後に、 messageLog Messages ボタンは ログメッセージPanel を開き、基礎となるプロセスを通知します(QGISの起動、プラグインの読み込み、処理ツール...)

ちなみに

マップキャンバスにおける正しい縮尺を計算する

QGISを起動すると、デフォルトのCRSは `` WGS 84(EPSG 4326)`` で、単位は度です。これは、QGISは任意のレイヤーの座標を度で指定されていると解釈することを意味します。正しい縮尺値を取得するには、手動でこの設定を変更でき、例えばメートル、 プロジェクト->プロジェクトProperties 下の General タブ中、または使用できます projectionDisabled 現在のCRS: アイコン上で見ました。後者の場合には、単位はプロジェクトの投影が指定するもの(例えば +units=us-ft)に設定されます。

起動時のCRS 選択は Settings ‣ Options ‣ CRS で設定できることに注意。