Outdated version of the documentation. Find the latest one here.

ベクタープロパティダイアログ

ベクターレイヤのレイヤProperties ダイアログは、地図内のレイヤーの地物の外観(シンボル、ラベル、ダイアグラム)、マウスとの相互作用(アクション、地図のヒント、フォームデザイン)を管理するための一般設定を提供します。また、レイヤーについての情報を提供します。

アクセスするには、 レイヤProperties ダイアログを、凡例内のレイヤをダブルクリックするか、レイヤー上で右クリックして Properties をポップアップメニューから選択します。

ちなみに

異なるレイヤー表現をすばやく切り替える

 レイヤーProperties ダイアログの下部に スタイル - >Add コンボボックスを使用して、レイヤーのプロパティの設定(シンボル、ラベリング、図、フィールドが形成さ、アクションのように多くの組み合わせを保存できます。.. 。)望むよう。次に、単に レイヤーPanel 内のレイヤーのコンテキストメニューからスタイルを切り替えれば、自動的にデータの異なる表現が得られます。

一般メニュー

general このメニューはベクターレイヤの一般的な設定で利用します. ここには多くのオプションが利用できます:

レイヤ情報

  • displayed as を使うとレイヤの表示名称を変更できます

  • ベクターレイヤの Layer source を指定します

  • Define the Data source encoding to define provider-specific options and to be able to read the file

空間参照システム

  • Specify 座標参照系。ここでは、特定のベクターレイヤーの投影を表示または変更できます。

  • Create a Spatial Index (only for OGR-supported formats)
  • 領域の更新 レイヤの情報

  • ベクターレイヤに指定されている投影方法を閲覧や変更したい場合は 指定 ... をクリックして下さい

縮尺に応じた表示設定

最大(含む)最小(排他的) 縮尺を設定して、地物が表示される縮尺の範囲を定義できます。この範囲のうち、それらが隠されています。 mapIdentification 現在のキャンバス縮尺 ボタンに設定を使用すると、範囲の可視性の境界として、現在の地図キャンバス縮尺を使用できます。

Figure Vector General 1:

../../../_images/vector_general_menu.png

ベクターレイヤーのプロパティ]ダイアログボックスの[一般メニュー

クエリビルダ

プロバイダ機能フィルター フレームの下では、 クエリBuilder で、SQL風のWHERE句を使用して、レイヤ内の地物のサブセットを定義したり、メインウィンドウに結果を表示できます。限り、クエリが有効であるとして、その結果に対応する地物だけが、プロジェクトで利用できます。クエリ結果は、新しいベクターレイヤーとして保存できます。

クエリビルダ は、レイヤープロパティで General メニューの下部にある名祖の用語を介してアクセス可能です。 地物subset の下 クエリbuilder 、ボタンをクリックして [クエリビルダ] を開いてください。クエリビルダの プロバイダ特定のフィルタexpression ボックス TYPE_2 フィールドと regions レイヤーを持っている場合たとえば、 borough されている領域のみを選択できます。QGISサンプルデータから regions.shp レイヤー Figure_vector_general_2 を移入クエリビルダの例を示しています。フィールド、値と演算子のセクションでは、SQLのようなクエリを構築するのに役立ちます。

Figure Vector General 2:

../../../_images/queryBuilder.png

クエリビルダ

フィールドリスト には検索される属性テーブルのすべての属性列が含まれています。SQL WHERE句フィールドに属性の列を追加するには、[フィールド]リストでその名前をダブルクリックします。一般的に、様々なフィールド、値と演算子を使用してクエリを構築できます、またはSQLボックスにそれを入力するだけもできます。

値のリスト には属性テーブルの値が一覧表示されます。属性のすべての可能な値を一覧表示するには、[フィールド]リストで属性を選択して、[すべて] ボタン をクリックしてください。属性列の最初の25個のユニークな値を一覧表示するには、[フィールド]リスト内の属性の列を選択し、 [サンプル] ボタンをクリックしてください。SQL WHERE句のフィールドに値を追加するには、二重の値のリストでその名前をクリックします。

演算子セクション は、使用可能なすべての演算子が含まれています。SQL WHERE句フィールドに演算子を追加するには、適切なボタンをクリックしてください。リレーショナル演算子( = > 、...)、文字列比較演算子( LIKE )、論理演算子( AND OR ... ) ご利用いただけます。

[テスト] ボタンは、クエリ構築のプロセスにおいて有用である現在のクエリを満たす機能の数を示すメッセージボックスを示しています。 [クリア] ボタンは、SQL WHERE句のテキストフィールド内のテキストをクリアします。 [OK] ボタンは、ウィンドウを閉じ、クエリを満たす機能を選択します。 [キャンセル] ボタンは、現在の選択を変更せずにウィンドウを閉じます。

QGISではレイヤー全体かのように得られたサブセット作用を扱います。「自治区」の上にフィルタを適用する場合には、「市」、したがって、サブセットの一部ではありませんので、たとえば、クエリを表示するアンカレッジを保存したり、編集できません。

唯一の例外は、レイヤを編集できなくなるでしょうサブセットを使用して、レイヤーない限り、データベースの一部であるということです。

スタイルメニュー

Style メニューをレンダリングして、ベクターデータを象徴するための包括的なツールを提供します。すべてのベクターデータに共通するツールならびにベクターデータの異なる種類のために設計された特別な象徴ツールを使用できます。しかし、すべての種類は、次のダイアログ構造を共有:は レイヤレンダリング ウィジェット上部に、機能するために、下で使用するための分類とシンボルの準備に役立つウィジェットを持っています。

ちなみに

ベクターシンボロジーのエキスポート

Google *.kml, *.dxfとMapInfo *.tab ファイルにQGISからベクターシンボルをエクスポートするオプションがあります。ちょうどレイヤーの右マウスメニューを開き、 名前を付けて保存を... 上のクリック出力ファイルの名前とその形式を指定します。ダイアログで シンボルexport メニューを使用して、シンボルを、 地物シンボル - > または シンボルレイヤシンボル - > のいずれかとして保存します。シンボルレイヤを使用している場合は、第二の設定を使用することをお勧めします。

地物のレンダリング

レンダラは、正しいシンボルで地物を描画するための責任があります。レイヤーのジオメトリタイプに関係なく、レンダラの4つの一般的なタイプがあります:単一シンボル、分類、段階、規則に基づく。ポリゴンレイヤーも反転レンダラでレンダリングできるが、点レイヤーに対して、点変位とヒートマップレンダラーが利用可能です。

連続カラーレンダラはありません。実際には段階レンダラーの唯一の特殊なケースであるためです。分類および段階レンダラは、シンボルとカラーランプを指定して作成できる - それらは適宜、シンボルの色を設定します。各データ・タイプ(点、線及び多角形)のために、ベクターシンボルレイヤータイプが利用可能です。選択したレンダラによっては、ダイアログが異なる、追加のセクションを提供します。

ノート

レンダラの種類を変更する場合は、ベクターレイヤーのスタイルを設定するときは、シンボルのために作られた設定は維持されます。この手順は、1つの変更のために働くことに注意してください。レンダラの種類を変更繰り返すと記号の設定は失われます。

単一シンボルレンダラ

singleSymbol 単一シンボル レンダラは、単一のユーザー定義シンボルを使用して、レイヤーのすべての機能をレンダリングするために使用されます。記号表記の詳細は、 シンボルselector 参照。

Figure Symbology 1:

../../../_images/singlesymbol_ng_line.png

単一シンボルラインプロパティ

ちなみに

レイヤーパネルから直接記号を編集する

レイヤーパネル で分類して定義されたカテゴリを持つレイヤーを持っている場合は、段階やルールベースのスタイルモードで、すぐにカテゴリを右クリックしてカテゴリのシンボルの塗りつぶしの色を変更し、 colorWheel 色wheel メニューから好み色を選択できます。カテゴリ上で右クリックしても、オプションにアクセスできるようになります すべて項目非表示すべての項目を表示および記号を編集

分類レンダラ

categorizedSymbol 分類レンダラ がアスペクト選択された特徴の属性の値を反映して、ユーザ定義のシンボルを使用して、レイヤーのすべての地物をレンダリングするために使用されます。 Categorized メニューは、選択できます:

  • 属性(列のリストボックス、または expressionEditorOpen 列expression設定 機能を使用して、 章を参照)

  • 各クラスのデフォルトとして使用される( シンボルselector ダイアログを使用して)シンボル

  • シンボルに適用される色が選択された色(カラーランプのリストボックスを使用して)の範囲

属性列の個別の値から classes を次に作成するために分類ボタンをクリックします。各クラスは、クラス名の左にあるチェックボックスをオフにして無効にできます。

シンボル、値および/またはクラスのラベルを変更するには、変更したい項目をダブルクリック。

右クリックでコンテクストメニューに コピー/貼り付け色を変更変更透明度変更出力部変更シンボル幅 を示しています。

figure_symbology_2 の例では、QGISサンプルデータセットの川レイヤーに使用されるカテゴリのレンダリングダイアログが表示されます。

Figure Symbology 2:

../../../_images/categorysymbol_ng_line.png

分類シンボル化オプション

ちなみに

複数シンボルを選択して変更する

シンボロジでは複数のシンボルを選択して右クリックでそれらの色,透過度,サイズや太さを変更できます.

ちなみに

シンボル名にマッチカテゴリ

[詳細設定]メニューで、クラスの下で、分類内のカテゴリ名にシンボル名を一致させるために、2つの最初のアクションのいずれかを選択できます。 保存記号に一致 は 、スタイルマネージャ からシンボル名でカテゴリ名に一致。ファイルからシンボルに一致 は、カテゴリ名を外部ファイルからシンボル名へ一致。

段階レンダラ

graduatedSymbol Renderer は、その色やサイズクラスに選択された地物の属性の割り当てを反映し、ユーザ定義シンボルを使用して、レイヤーのすべての地物をレンダリングするために使用されて卒業。

カテゴリ別レンダラ、同様 段階レンダラ には、指定した列から回転とサイズスケールを定義できます。

また、カテゴリ別レンダラに類似し、それは選択できます:

  • 属性(列のリストボックスまたは expressionEditorOpen 列expression設定 機能を使用)

  • (シンボル選択ダイアログを使用して)、シンボル

  • 凡例形式と精度

  • 色やサイズ:記号を変更するために使用する方法

  • 色(カラーランプのリストを使用して)カラー方式が選択された場合

  • サイズ(サイズのドメインを用いて、そのユニット

Histogram タブ割り当てられたフィールドまたは式の値のインタラクティブなヒストグラムを示し、その後、使用できます。クラスブレークが移動またはヒストグラムウィジェットを使用して追加できます。

ノート

ベクターレイヤーに関する詳細な情報を取得するために統計概要パネルを使用できます。 統計の概要パネル 参照。

バッククラス]タブに、クラスの数も(モード]リストを使用して)、クラス内の地物を分類するためのモードを指定できます。使用可能なモードは以下のとおりです。

  • 等間隔:各クラスは、同じサイズている(例えば、0から16までの値と4つのクラスを、各クラスは、4のサイズを有します)。

  • 分位:それぞれのクラスは、内部の要素の数が同じでしょう(箱ひげ図の考え)。

  • 天然の切断(ジェンクス):クラス間分散が最大である各クラス内分散が最小です。

  • 標準偏差:クラスは値の標準偏差に応じて構築されています。

  • かなりブレーク:xの値の範囲をカバーする約N + 1等間隔nice値のシーケンスを計算します。それらはhttp://astrostatistics.psu.edu/datasets/R/html/base/html/pretty、10のべきの1、2又は5倍になるように値が選ばれます(R統計環境 http://astrostatistics.psu.edu/datasets/R/html/base/html/pretty.html からきれいに基づいて)。

The listbox in the center part of the Style menu lists the classes together with their ranges, labels and symbols that will be rendered.

選択したモードを使用してクラスを作成する 分類 ボタンをクリックしてください。各クラスは、クラス名の左にあるチェックボックスをオフに無効にできます。

シンボル、値および/またはクラスのラベルを変更するには、変更したい項目をダブルクリック。

右クリックでコンテクストメニューに コピー/貼り付け色を変更変更透明度変更出力部変更シンボル幅 を示しています。

figure_symbology_3 の例では、QGISサンプルデータセットの河川レイヤーのための段階レンダリングダイアログが表示されます。

Figure Symbology 3:

../../../_images/graduatesymbol_ng_line.png

段階シンボル化オプション

ちなみに

式を利用した主題図

分類と段階主題は、式の結果を使用して作成できます。ベクターレイヤーのプロパティダイアログでは、属性選択は expressionEditorOpen 列expression設定 機能で拡張されます。だから、分類属性は、複数のフィールドの複合、またはある種の式になりたい場合は、属性テーブルで新しい列に分類属性を記述する必要はありません。

比例シンボルと多変量解析

比例シンボルと多変量解析は、スタイルレンダリング]ドロップダウンリストから利用可能なタイプをレンダリングされていません。しかし、以前のレンダリングオプションのいずれかの上に適用 サイズ アシスタントオプションで、QGISはそのような表現を使ってポイントやラインのデータを表示できます。

比例シンボルを作成する

単一シンボルレンダラ 比例レンダリングは、第一のレイヤーに適用することによって行われます。シンボルを設定すると、シンボルツリーの上位レベルでは、dataDefined データ定義override ボタン利用可能な横 Size または Width オプション(点又は線レイヤーのためのそれぞれ)は、レイヤの比例シンボルを作成するためのツールを提供します。アシスタントはを通してさらにアクセス可能です dataDefined メニューには、サイズの式を定義するのに役立ちます。

Figure Symbology 4:

../../../_images/varying_size_assistant.png

Varying size assistant

アシスタントでは以下を定義できます:

  • 表現するための属性、フィールドのリストボックスまたは expressionEditorOpen 列expression設定 機能を使用して( 参照)

  • 「フラナリー」、「表面」ま​​たは「半径」とできる表現のスケール方法

  • シンボルの最小および最大サイズ

  • 値の範囲は表現する:下向きの矢印を使用すると、自動的に最小(またはゼロ)と選択した属性やデータに適用される式によって返される最大値で、これらのフィールドを埋めるのに役立ちます。

  • NULL値を表すためのユニークなサイズ。

ダイアログの右側に、ライブアップデートウィジェット内の特徴表現をプレビューできます。この表現は、レイヤーの凡例にレイヤーツリーに追加され、また印刷コンポーザ凡例項目内のレイヤ表現を形成するために使用されます。

上記の様々なサイズのアシスタントで提示値はとサイズ「データ定義のオーバーライド」を設定します::

coalesce(scale_exp(Importance, 1, 20, 2, 10, 0.57), 1)

多変量解析を作成する

多変量解析のレンダリングを使用すると2つの以上の変数間の関係を評価するのに役立ちます。例えば、1はカラーランプで表すことができます、もう1つはサイズで表現されている間。

QGISで多変量解析を作成する最も簡単な方法は、分類やすべてのクラスのシンボルの同じタイプを使用して、レイヤーの上に段階レンダリングを最初に適用することです。 シンボルselector ダイアログ上で見られるように、アクティブにして設定でき、そこからはをし、シンボルに [変更]分類枠以上 ボタンをクリックすると、得ます :ref:`サイズのアシスタント<size_assistant>`オプションのいずれか(点レイヤー用)のサイズまたは幅に(線レイヤー用)です。

比例シンボルのような、大きさに関連したシンボルは、分類または段階クラスシンボルの先頭に、レイヤツリーに追加されます。そして、両方の表現は、印刷コンポーザ凡例アイテムにも利用できます。

規則に基づくレンダリング

ruleBasedSymbol 規則に基づくレンダラ は使用して、レイヤーからのすべての機能をレンダリングするために使用されます。アスペクト 規則に基づく シンボルはクラスに、選択地物の属性の割り当てを反映しています。規則は、SQLステートメントに基づいています。ダイアログには、フィルタや規模によって、規則のグループ化を可能にし、シンボルレベルを有効にしたいか、または最初に一致した規則だけ使用したいか、決定できます。

規則 を作成するには、それをダブルクリックして、既存の行をアクティブにさせる、または「+」をクリックして、新しい規則をクリックしてください。 規則のプロパティ ダイアログでは、規則のラベルを定義できます。 browseButton 式の文字列ビルダを開くためのボタンを押す。 関数一覧 では、上のクリック フィールドとValues を検索する属性テーブルのすべての属性を表示します。フィールドの計算に属性を追加するには フィールドでその名前をダブルクリックします フィールドとValues リスト。一般的に、計算式を構築するために様々なフィールド、値や関数を使用でき、またはだけのボックスにそれを入力できます( 参照)。マウスの右ボタンで既存の規則をコピーして貼り付けることで、新しい規則を作成できます。また、そのレベル上の他の規則のどれもが一致しない場合に実行される「ELSE」規則を使用できます。QGIS 2.8以来のルールは、地図の凡例のツリー階層で表示されます。ただ、地図の凡例でルールをダブルクリックして、レイヤーのプロパティのスタイルメニューは、ツリー内のシンボルの背景である規則を示す表示されます。

figure_symbology_5 の例では、QGISサンプルデータセットの川レイヤーのための規則に基づくレンダリング]ダイアログボックスが表示されます。

Figure Symbology 5:

../../../_images/rulesymbol_ng_line.png

規則に基づくシンボル化オプション

ポイント変位

pointDisplacementSymbol ポイント変位 レンダラは、ポイントレイヤーのすべての地物を、それらが同じ場所を持っている場合でも、視覚化するために動作します。1つの中心シンボル周囲またはいくつかの同心円上の 変位circle これを行うには、ポイントのシンボルが上に配置されます。

Figure Symbology 6:

../../../_images/poi_displacement.png

ポイント変位ダイアログ

ノート

まだ使用して、単一のシンボル、段階、、カテゴリ別や規則に基づくレンダラのような他のレンダラで地物をレンダリングができます、 Renderer ドロップダウンリストの後 :guilabel:`レンダラー設定... ` ボタンをクリックします。

反転ポリゴン

invertedSymbol 逆Polygon レンダラは、ユーザがレイヤのポリゴンの外側に充填するシンボルを定義することを可能にします。上記のように、サブレンダラ、すなわち単一のシンボルを選択でき、分類された、規則に基づくまたは2.5 Dレンダラを段階。

Figure Symbology 7:

../../../_images/inverted_polygon_symbol.png

反転ポリゴンダイアログ

ヒートマップ

heatmapSymbolHeatmap レンダラを使用して、(マルチ)ポイントのレイヤーのためのライブの動的ヒートマップを作成できます。 heatmap 半径をピクセル、ミリメートルまたは地図単位で指定できます、選択し、ヒートマップスタイルのためのカラーランプを編集し、レンダリング速度と品質の間のトレードオフを選択するためのスライダーを使用します。また、最大値の制限を定義し、フィールドまたは式を使用して点に重みを与えることができます。機能を追加または削除するとヒートマップレンダラは自動的ヒートマップスタイルを更新します。

Figure Symbology 8:

../../../_images/heatmap_symbol.png

ヒートマップダイアログ

2.5 D

25dSymbol 2.5 D レンダラを使用すると、レイヤーの地物上の 2.5 D の効果を作成することが可能です。 Height 値(地図単位)選択して起動します。そのために、固定値で、レイヤーのフィールドのいずれか、または式を使用できます。(0° は西を意味し、反時計回り方向に大きく)、視聴者の位置を再作成するために Angle (度)また、選択する必要があります。 屋根ColorウォールColor 設定するには、高度な設定オプションを使用します。地物の壁に太陽放射をシミュレートしたい場合は、 checkbox aspectに基づくシェードの壁 オプションをチェックしてください。また ColorSize を設定することで、影をシミュレートできます(地図単位)。

Figure Symbology 9:

../../../_images/2_5dsymbol.png

2.5 Dダイアログ

ちなみに

他のレンダラとともに2.5 D効果を使用する

2.5 Dレンダラの基本的なスタイルの設定が完了したら、別のレンダラにこれを変換できます(単一、分類、段階)。2.5 Dの効果は保持されますし、他のすべてのレンダラ固有のオプションを微調整それら(素敵な2.5次元表現を持つ例えば分類記号を持っているか、2.5 Dシンボルにいくつかの余分なスタイリングを追加できますこの方法)へのために利用できるようになります。( 詳細->シンボルレベル... )影と「建物」自体が他の近くの機能に干渉しないことを確認するために、シンボルレベルを有効にする必要があります。2.5 Dの高さと角度の値は、レイヤの変数に保存されているので、レイヤーのプロパティ]ダイアログボックスの[変数]タブで、後でそれを編集できます。

レイヤレンダリング

[スタイル]タブからは、invariabilyレイヤーのすべての地物に作用するいくつかのオプションも設定できます。

  • レイヤ透過性 slider: このツールによって地図キャンパスにおけるレイヤの可視性を設定できます. このスライダでベクターレイヤの可視性を調整できます. メニューの横にあるスライダを使ってレイヤの表示比率を定義できます.

  • レイヤーブレンドモード地物ブレンドモード を:以前にのみグラフィックプログラムから知っている可能性があり、これらのツールとの特別なレンダリング効果を得ることができます。重ね合わせや下レイヤーのピクセルが ブレンドモード に記載されている設定によって混合されます。

  • ペイント効果 を持つすべてのレイヤーの地物に 描画効果 ボタンを適用します。

  • 地物レンダリング順序を制御 では、地物属性を使用して、それらがレンダリングされなければならない Z-順序 を定義できます。チェックボックスを有効にし、をクリックしてください browseButton ボタンの横にあります。 順序を定義 ダイアログ次に、取得します:

    • フィールドを選択するか、レイヤー地物に適用する式を作成

    • どの順序でフェッチされた地物が整列されるか設定します、すなわち 昇順 を選択する場合、より低い値の地物は、上限値とそれらの下にレンダリングされます。

    • NULL値を返す地物がレンダリングされるべきときを定義: 最初最後

    :index:`規則による順序 ` いくつかを追加できます。最初の規則は、レイヤーのすべての地物に適用され、返された値に応じてそれらをZ-順序。次いで、したがって同じzレベル(NULL値を持つものを含む)は、同じ値を持つ地物のグループごとに、次のルールは、それらの間にそのアイテムをソートするために適用されます。等々...

    一度:guilabel:Order ダイアログが適用される定義し、式(複数可)の概要を制御するために使用する レイヤーrendering が横にテキストボックスにretranscribedされる checkbox Control地物オプションをorder レンダリングします。

Figure Layer Rendering 1:

../../../_images/layer_rendering_options.png

レイヤのレンダリングオプション

他の設定

シンボルレベル

積み重ねられたシンボルレイヤを(唯一のヒートマップにはない)を許可レンダラーのために、各シンボルのレベルのレンダリング順序を制御するためのオプションがあります。

レンダラーのほとんどは、保存されたシンボルのリストの下にある [詳細] ボタンクリックする シンボルlevels 選択ことにより、シンボルレベルのオプションにアクセスできます。 規則に基づくレンダリング については、オプションは [シンボルレベル] ボタンから直接入手可能です、対して ポイント変位 レンダラーいついては同じボタンは レンダリングsettings ダイアログの内側にあります。

シンボルレベルを有効にするには checkbox シンボルlevelsを有効にする を選択します。各行は、合成シンボル、ラベルとそれに次の番号の列に分割され、個々のシンボルレイヤーの少量のサンプルを表示されます。数字は、シンボルレイヤが描画された描画順のレベルを表します。低い値のレベルがより高い値が他の上に、最後に描かれているが、底部に滞在、最初に描画されています。

Figure Symbols levels 1:

../../../_images/symbol_levels.png

シンボルレベルダイアログ

ノート

シンボルレベルを無効にしている場合は、完全なシンボルは、それぞれの特徴を順序に従って描画されます。重複シンボルは、単に以下の他に、難読化されます。また、同様の符号は、お互いに「併合」しません。

Figure Symbols levels 2:

../../../_images/symbol_levels_examples.png

シンボルレベル(A)活性化及び不活性化(B)の差

効果を描きます

地図の最終的なレンダリングのために他のソフトウェアに頼るのレイヤーのレンダリングを改善し、避ける(または少なくとも軽減)するために、QGISでは別の強力な機能を提供します: paintEffects 描画Effects オプション、これはベクターレイヤーの可視化をカスタマイズするためのペイントエフェクトを追加します。

オプションが利用可能である レイヤープロパティ] -> [Style ダイアログ、 レイヤーのレンダリング グループ下(レイヤー全体に適用する)、またはでは シンボルレイヤプロパティ (対応する地物に適用)。両方の使用を組み合わせることができます。

ペイント効果は checkbox 描画effects オプションをチェックし paintEffects 効果をカスタマイズ ボタンをクリックすることによって有効にできます、 効果のプロパティ ダイアログが開きます(figure_effects_1 を参照)。カスタムオプションを使用して、以下の効果の種類は、使用できます。

  • 元: レイヤーのプロパティの設定に従って地物の元々のスタイルを描画します。そのスタイルの透明度は調整できます。

    Figure Effects 1:

    ../../../_images/source.png

    描画効果:[元]ダイアログ

  • ぼかし: ベクターレイヤーにぼかし効果を追加します。誰かが変更できるオプションは次のとおりです。 ぼかし種類 が( Stackガウスぼかし )、ぼかし効果の強さと透明性。

    Figure Effects 2:

    ../../../_images/blur.png

    効果を描く:[ぼかし]ダイアログ

  • 色付け: この効果は1つの色相を使用してスタイルのバージョンを作るために使用できます。ベースは常にシンボルのグレースケールバージョンになりますと、 selectString Grayscale は使用できます、それを作成する方法を選択する(オプションは次のとおりです:「明度」「光度」「平均」)。もし checkbox Colorise が選択されている、それは別の色を混合し、それがどうあるべきかの強力な選択することが可能になります。結果のシンボルの 輝度コントラスト彩度 レベルも制御できます。

    Figure Effects 3:

    ../../../_images/colorise.png

    効果を描く:ダイアログを色付け

  • ドロップシャドウ: この効果を使用するには、余分な次元を追加するように見える地物、に影を追加します。影に向かってシフトすると、ソース・オブジェクトへの近接場所を決定する、この効果は オフセット 度と半径変更することによってカスタマイズできます。 ドロップシャドウ もぼかし半径、透明性と効果の色を変更するオプションがあります。

    Figure Effects 4:

    ../../../_images/drop_shadow.png

    効果を描く:ドロップシャドウダイアログ

  • シャドウ(内側): この効果は ドロップシャドウ 効果に似ているが、地物の縁の内側にシャドウ効果を追加します。カスタマイズ可能なオプションは ドロップシャドウ 効果と同じです。

    Figure Effects 5:

    ../../../_images/inner_shadow.png

    効果を描く:シャドウ(内側)]ダイアログ

  • インナーグロー: 地物の内側にグロー効果を追加します。 spread (幅)グローの、または ぼかし半径 この効果は、調整することによってカスタマイズできます。後者は、任意のぼかしが起こるしたい地物のエッジからの近接性を指定します。また、単色またはカラーランプと、グローの色をカスタマイズするためのオプションがあります。

    Figure Effects 6:

    ../../../_images/inner_glow.png

    描画効果:インナーグローダイアログ

  • 光彩(外側): この効果は インナーGlow 効果に似ているが、地物の縁の外側にグロー効果を追加します。カスタマイズ可能なオプションは インナーGlow 効果と同じです。

    Figure Effects 7:

    ../../../_images/outer_glow.png

    描画効果:光彩(外側)ダイアログ

  • 変換: シンボルの形状を変形する可能性を追加します。カスタマイズのための利用可能な最初のオプションは horizo​​ntal を反映して 実際に水平および/または垂直軸上反射を作成vertical を反映します。その他4つのオプションは以下のとおりです。

    • Shear :Xおよび/またはY軸に沿って地物を傾けます

    • Scale:所与のパーセンテージによってXおよび/またはY軸に沿って地物を拡大または最小化します

    • Rotation :その中心点を中心に地物をオン

    • そして Translate は、x及び/又はy軸上に与えられた距離に基づいて、アイテムの位置を変更します。

    Figure Effects 8:

    ../../../_images/transform.png

    描画効果:[変換]ダイアログ

すべての描画効果タイプで利用可能ないくつかの一般的なオプションがあります。 Transparencyモード オプションは レイヤレンダリング で説明したものと同様に動作ブレンドとすべてで使用でき、変換効果以外の効果を引き出します。

一つ以上の描画効果を同時に使用できます。効果リストでそのチェックボックスを使用して効果を有効/無効にします。selectString 効果type オプション使用して選択されている効果タイプを変更できます。 arrowUp up移動 arrowDown down移動 ボタンを使用して効果を並べ替えたり、 signPlus 効果を追加 および signMinus 効果を削除 ボタン使用して効果を追加/削除もできます。

すべての描画効果のために利用できる selectString 描画モード オプションもあります、そして記号をレンダリングする、および/または、変更するかどうかを選択できます。効果は、上から下’Renderにレンダリングのみ変更 『モードの効果が表示されないことを意味しますが、それが適用されることに変更は次の効果に渡されます」モードをしながら、効果が見えるようになることを意味します』(すぐ下のもの)。「レンダリングおよび変更」モードでは効果が見えるようにし、次の効果に変更を渡します。効果は、効果リストの先頭に、または場合であればすぐに効果上、それは(ソースと同様)レイヤーの特性から元のソースシンボルが使用され、変更モードではありません。

ラベルメニュー

labeling Labels コアアプリケーションは、スマート提供ベクター点、線およびポリゴンのレイヤーのための labeling を、わずか数のパラメータを必要とします。このアプリケーションは、その場で変換のレイヤーをサポートしています。以下のメニューは、ベクターレイヤーのラベルを設定するために使用されます。

  • テキスト

  • 整形

  • バッファ

  • 背景

  • 配置

  • 描画

レイヤ開始QGISにラベルを付け、ベクターレイヤーをロードします。凡例内のレイヤをアクティブにして、QGISのツールバーメニューで labeling レイヤのラベリングOptions アイコンをクリックするか、またはレイヤーのプロパティダイアログで Labels タブを有効にしてください。

最初のステップは、ドロップダウンリストから標識法を選択することです。利用できる4つのオプションがあります。

  • ラベルなし

  • このレイヤーのラベルを表示

  • 規則に基づくラベル付け

  • そして、このレイヤーに含まれる地物の概要から他のラベルを落胆 :独自の任意のラベルをレンダリングすることなく、他のレイヤーのラベルの単なる障害物としてレイヤーを設定できます。

このレイヤーのラベルを表示 オプションを選択し、 でラベル ドロップダウンリストでラベル付けに使用する属性列を選択します。式に基づいたラベルを定義したい場合は expressionEditorOpen をクリック - 式に基づいてラベルを定義する を参照。

次の手順は、 ドロップダウンメニューの隣に位置していますoverride 使用しなくても、簡単なラベルを記述する機能定義されたデータ、 - ユースケースのために 標識のためのデータ定義のオーバーライドを使用して 参照。

テキストメニュー

Text メニュー( Figure_labels_1 を参照)テキストスタイルを定義できます。 テキストのレンダリングに影響を与えるタイプcase オプションを使用します。テキスト「すべて大文字」、「すべての小文字の」または「最初の文字を大文字」をレンダリングする可能性があります。グラフィックスプログラムから知られている効果を作成するには ブレンドmodes を使用してください。

Figure Labels 1:

../../../_images/label_points.png

ベクターポイントレイヤーのスマートラベル

フォーマットメニュー

Formatting メニューでは「文字の上にラップ」関数とラベルに改行の文字を定義できます。 ラインHeight とアライメント、フォーマットできます。後者の典型的な値に使用できるプラス ラベルの配置に従ってください 。このモードに設定すると、ラベルのテキストの配置は、ポイントに対するラベルの最終的な配置に依存することになります。ラベルはポイントの左側に配置されている場合などは、そのラベルは右詰めされ、それがポイントの右側に配置されている場合、ラベルは左詰めされます。

ラインベクターレイヤーのためには、ライン方向シンボルを含めることができます。シンボルの種類とシンボルの配置を指定するオプションがあります。

checkbox 数を書式設定する オプションを使用して属性テーブルで数値を書式設定します。ここでは、小数点以下を挿入してもよいです。このオプションを有効にした場合、小数点以下3桁は最初にデフォルトで設定されています。

バッファメニュー

バッファを作成するには、単に checkbox Buffer メニュー テキストbufferを描画 チェックボックスを有効にします。バッファ色は可変です。ここでも、ブレンドモードを使用できます。もし checkbox カラーバッファのfill チェックボックスが有効にされ、それは部分的に透明テキストと相互作用して、混合色の透明度の結果が得られます。バッファ充填をオフにすると(バッファのストロークの内部側面は、テキストの塗りつぶしと交差する場合を除く)その問題を修正し、また、概説されたテキストを行うことができます。

背景メニュー

Background メニューでは、背景の形状の サイズXサイズY が定義できます。 サイズtype を使用して背景に追加の「バッファ」を挿入します。バッファサイズは、ここではデフォルトで設定されています。 サイズXサイズY 背景には、バッファのプラスのバックグラウンドで構成されています。 Rotation を設定でき、ここでは「ラベルと同期」「ラベルのオフセット」「固定」のどれかを選択できます 。「ラベルのオフセット」と「固定」を使用して、背景を回転できます。定義 XとYの値をX、Y オフセット、および背景がシフトされます。適用時 半径X、Y を、背景は角を丸められます。再び、 ブレンドモード を使用して地図キャンバスに下のレイヤーで背景を混在させることも可能です( :ref:`ブレンド-modes`を参照)。

シャドウメニュー

ユーザ定義のための Shadow には ドロップshadow メニューを使用します。背景の描画は非常に変数です。「最低ラベル・コンポーネント」、「テキスト」、「バッファ」と「背景」の間で選択します。 オフセット 角度は、ラベルの向きに依存します。 checkbox 使用グローバルshadow チェックボックスを選択した場合、そして角度のゼロ点は、常に北を向いているとラベルの向きに依存しません。 :guilabel:`ぼかし半径`と影の外観に影響を与えることができます。影柔らかく、数値が高いほど。ドロップシャドウの外観もブレンドモードを選択することによって変更できます。

配置メニュー

ラベルplacement と標識の優先順位を設定するには Placement メニューを選択します。配置オプションは、ベクターレイヤーの種類、すなわち点、線又はポリゴンに応じて異なることに留意されたいです。

ポイントレイヤの配置

radioButtonOn Cartographic 配置モード、ポイントラベルが理想的な地図製作配置規則次のポイント地物を備えた最高の視覚的な関係、で生成されます。点地物自体から、または地物を表すために使用されるシンボルの境界のいずれかから Distance ラベルがセットに配置できます。それは、データ定義されたサイズで設定されたかどうかに分類レンダラーに異なるシンボルを使用している場合、シンボルの大きさは、例えば、固定されていない場合、後者のオプションは特に便利です。

デフォルトでは、配置は次の順序で優先順位付けされています。

  1. 右上

  2. 左上

  3. 右下

  4. 左下

  5. 右中央

  6. 左中央

  7. トップ、少し右

  8. 底部は、やや左。

配置優先順位は、しかし優先位置のデータ定義されたリストを使用して、個々の地物に合わせてカスタマイズまたは設定できます。また、これはラベルが土地の上に配置されることを防ぐことができ、沿岸の地物のために、たとえば、唯一の特定の配置を使用できます。

radioButtonOn 周りのpoint 設定ではラベルを( Distance で設定)地物の周りに円をに等しい半径で配置します。 Quadrant オプションを使用してラベルの配置も制約できます。

radioButtonOn pointからのオフセット 配置では、ラベルは点地物からの固定オフセットで配置されます。ラベルを配置している Quadrant 選択できます。また、Xを設定できますし、Yはポイントとそのラベルの間の距離をオフセットとしてラベルの配置の角度を変更できます Rotation 設定。したがって、定義された回転に選択象限の配置が可能です。

線レイヤーでの配置

線レイヤーのラベルオプションは、 radioButtonOn Parallel, radioButtonOff Curved or radioButtonOff Horizontal です。 radioButtonOn ParallelradioButtonOff Curved オプションのために、ポジションを設定できます checkbox 線より上 checkbox 線上 checkbox 線より下 。これは、一度に複数のオプションを選択することが可能です。その場合には、QGISは最適なラベル位置を探します。平行湾曲配置について、また、ラベルの位置のためのラインの向きを使用できます。また、 radioButtonOff Curved オプションを選択しているときは 曲面characters間の最大角度 を定義できます(Figure_labels_2 を参照)。

すべての3つの配置オプションについて、ラベルを繰り返すための最小距離を設定できます。距離は mm または 地図単位 であることができます。

Figure Labels 2:

../../../_images/label_line.png

ベクター線レイヤーのスマートラベル

ポリゴンレイヤの配置

ポリゴンのラベルを配置するため、次のいずれかのオプションを選択できます:radioButtonOn 重心からのオフセット radioButtonOff 水平(slow), radioButtonOff 重心周り radioButtonOff 自由 radioButtonOff perimeterを使用

radioButtonOn 重心からのオフセット 設定中で、重心が radioButtonOn 見えるpolygon または radioButtonOff 全体polygon であるかどうかを指定できます。つまり、どんなに地図上の全地物を見ることができれば、重心のいずれかを使用して、地図上で見ることができたポリゴンのために使用されているか、重心が全体のポリゴンのために決定されることを意味します。特定の象限内のラベルを配置し、オフセットと回転を定義できます。 radioButtonOff 周りcentroid 設定では、重心の周りに指定した距離での場所にラベルを配置します 。ここでも、 radioButtonOn 見えるpolygon または radioButtonOff 重心のための全体polygon 定義できます。

radioButtonOff perimeterを使用 設定で、位置やラベルの距離を定義できます。位置については、 checkbox 線より上checkbox 線上checkbox 線より下checkbox ラインの向きに依存position が可能です。ラベルとポリゴンのアウトラインだけでなく、ラベルの繰り返し間隔の間の距離を指定できます。

Figure Labels 3:

../../../_images/label_area.png

ベクターポリゴンレイヤーのスマートラベル

priority セクションでは、ラベルは、すべての3つのベクターのレイヤータイプ(点、線、多角形)のためにレンダリングされる優先順位を定義できます。この配置オプションは、地図キャンバス内の他のベクターレイヤーのラベルと対話します。異なるレイヤーからのラベルが同じ場所にある場合は、優先度の高いラベルが表示され、他は取り残されます。

レンダリングメニュー

Rendering メニュー中で、ラベルをいつレンダリングできるか、および他のラベルや地物との相互作用をチューンできます。

ラベルoptions の下では、 縮尺に基づくピクセルサイズに基づく の表示設定を見つけます。

ラベルZ-index は、ラベルが他のレイヤーからの標識と同様に(データ定義のオーバーライド式を使用して)レイヤーで他の地物ラベル、との関係においても、レンダリングされる順序を決定します。より高いz屈折率を有するラベルは、低いz屈折率を持つ(任意レイヤーからの)ラベルの上にレンダリングされます。

ように2つのラベルは、Zインデックスが一致した場合、さらに、ロジックは、次に、微調整されています。

  • それらが同じレイヤーからのものである場合、より小さなラベルが大きいラベル上に描画されます

  • ラベルは、それらは異なるレイヤーからしている場合、そのレイヤー自身と同じ順序で描画されます(すなわち地図の凡例に設定された順序を尊重)。

この設定では、ラベルが他のレイヤーからの地物の下に描画されることはありません、それだけでラベルがすべてのレイヤーの地物の上に描画される順序を制御していることに注意してください。

ラベルをレンダリングし、読みやすいラベルを表示するために、一方で、QGISは自動的にラベルの位置を評価し、衝突の場合には、それらの一部を非表示にできます。ただしこのレイヤーのための checkbox すべてのラベルを表示(衝突ラベルを含む) に選択できます、手動でそれらの配置を修正するため。

表示label常にShow データ定義の表現では、どのラベルをレンダリングする必要があるか微調整できます。

地物options の下では、 ラベル付けする地物の数を制限 マルチパート地物のすべての部分にラベル を選択できます。 小さい地物than のラベルを抑制し、両方のラインとポリゴンのレイヤーが使用して、地物をラベル付けするためには最小サイズを設定するオプションを提供します。ポリゴン地物の場合、また、それらは完全に地物かに収まるかどうかに応じて表示するようにラベルを絞り込むことができます。ライン地物については、選択できます 重複labelsを避けるために連結されたラインをマージ と一緒に非常に風通しの良い地図をレンダリングし、 距離 か[配置]タブで Repeat オプション。

Obstacles フレームから、ラベルと地物の間のカバーの関係を管理できます。アクティベート checkbox をfeaturesカバーからラベルを思いとどまら レイヤーの地物は、(同一レイヤー内の他の地物からのラベルを含む)任意のラベルのための障害物として作用すべきかどうかを決定するためのオプション。障害物とは、その上にQGISがラベルを配置しないように可能な限りしようとする地物です。代わりに、全レイヤーでは、使用して、障害物として使用する地物のサブセットを定義できます dataDefined データに定義されたoverride オプションの横に制御します。

障害物のための slider 優先制御スライダーを使用すると、ラベルは、特定のレイヤーではなく、他からの地物をオーバーラップすることを好む行うことができます。 軽量 障害物の優先順位は、レイヤーの地物は、以下の障害物と見なされ、ラベルでカバーされるので、より可能性が高いことを意味します。この優先順位は、同じレイヤー内に、特定の特徴が他のものよりも被覆されやすいように、データを定義できます。

ポリゴンレイヤの場合、ラベルの配置を最小化することによって、可能性障害物の地物の種類を選択できます。

  • 地物のインテリアにわたり :ポリゴンの内部(ポリゴンの内側に完全に外側またはわずかにラベルを置くことを好む)の上にラベルを配置する回避します

  • または 地物の境界上で :(ポリゴンの内側外側または完全にラベルを置くことを好む)、ポリゴンの境界線の上にラベルを配置する回避できます。これは、地物はエリア全体をカバーする地域の境界レイヤー、用などに便利です。このケースでは、これらの地物の中にラベルを配置しないようにすることは不可能だし、それは、地物間の境界上にそれらを置くことを避けるために非常に良く見えます。

式に基づいてラベルを定義する

QGISは地物にラベルを付けるために式を使用できます。 labeling Labels メニュープロパティダイアログの expressionEditorOpen アイコンをクリックするだけ。 figure_labels_4 には、フィールド「NAME_2」、いくつかの説明文、および見た目を良くする format_number() と組み合わせた関数 $area に基づいて、名前と面積サイズでアラスカの地域にラベルを付けるためのサンプル式があります。

Figure Labels 4:

../../../_images/label_expression.png

レベル付けに式を使用する

式に基づくラベル付け で作業するのは簡単です。世話をする必要があるすべては、次のとおりです。

  • このような concat + || として文字列の連結機能を持つすべての要素(文字列、フィールドと機能)を組み合わせる必要があります。これらのツールのすべては、必要性に合うとは限らない、いくつかの状況では(関与nullまたは数値)があることに注意してください

  • 文字列は「一重引用符」で書かれています

  • フィールドは、「二重引用符」または任意の引用符なしで書かれています。

いくつかの例を見てみましょう:

 # label based on two fields 'name' and 'place' with a comma as separator
 "name" || ', ' || "place"

 -> John Smith, Paris

 # label based on two fields 'name' and 'place' with other texts
 'My name is ' + "name" + 'and I live in ' + "place"
 'My name is ' || "name" || 'and I live in ' || "place"
 concat('My name is ', name, ' and I live in ', "place")

 -> My name is John Smith and I live in Paris

 # label based on two fields 'name' and 'place' with other texts
 # combining different concatenation functions
 concat('My name is ', name, ' and I live in ' || place)

 -> My name is John Smith and I live in Paris
 -> My name is John Smith     # if the field 'place' is NULL

 # multi-line label based on two fields 'name' and 'place' with a descriptive text
 concat('My name is ', "name", '\n' , 'I live in ' , "place")
 -> My name is John Smith
    I live in Paris

 # label based on a field and the $area function
 # to show the place name and its rounded area size in a converted unit.
 'The area of ' || "place" || ' has a size of ' || round($area/10000) || ' ha'

 -> The area of Paris has a size of 10500 ha

 # create a CASE ELSE condition. If the population value in field
 # population is <= 50000 it is a town, otherwise a city.
 concat('This place is a ', CASE WHEN "population <= 50000" THEN 'town' ELSE 'city' END)

-> This place is a town

式ビルダーで見ることができるように、QGISではデータにラベルを付けるために、シンプルで非常に複雑な式を作成するために利用可能な機能の数百を持っています。式の詳細と例については 章を参照。

標識のためのデータ定義のオーバーライドを使用して

データ定義のオーバーライド 機能では、ラベルの設定が属性テーブルのエントリで上書きされます。この機能はマウスの右ボタンで有効または無効にできます。シンボルの上にマウスを移動し、現在の定義フィールドを含むデータ定義のオーバーライドに関する情報を参照してください。ここで moveLabel ラベルを移動 機能に対してデータ定義のオーバーライド機能を使用した例を説明します( figure_labels_5 を参照)。

  1. QGISサンプルデータセットから lakes.shp をインポートします。

  2. レイヤーのプロパティを開くには、レイヤーをダブルクリックします。 LabelsPlacement をクリックしてください。 radioButtonOn 重心からのオフセット を選択してください。

  3. データdefined エントリを探します。 dataDefined アイコンをクリックして Coordinate ためのフィールドタイプを定義します。Xには「xlabel」とYには「ylabel」を選択してください。アイコンが今黄色で強調表示されている。

  4. 湖へズーム

  5. Set editable the layer using the toggleEditing Toggle Editing button.
  6. ラベルのツールバーに移動し、 moveLabel アイコンをクリックしてください。今、別の位置( figure_labels_6 参照)に手動でラベルをシフトできます。ラベルの新しい位置は、属性テーブルの「xlabel」と「ylabel」列に保存されます。

Figure Labels 5:

../../../_images/label_data_defined.png

データ定義のオーバーライドを有するベクターポリゴンレイヤーのラベリング

Figure Labels 6:

../../../_images/move_label.png

ラベルを移動します

規則に基づくラベル付け

規則に基づくラベル付け 複数のラベルの設定を定義し、 規則に基づくレンダリング 同様に、表現フィルタのベースに選択的に適用できます.

規則はラベルパネルの上部で対応するオプションを選択して設定できます(figure_labels_7_を参照)。

Figure Labels 7:

../../../_images/label_rules_panel.png

規則に基づくラベル作成パネル

規則を作成するには、それをダブルクリックして既存の行を活性化させる、または「+」をクリックして、新しい規則をクリックしてください。パネル内では、フィルタ式と関連するラベルの設定を設定できます。

Figure Labels 8:

../../../_images/label_rule_settings.png

規則の設定

フィールドメニュー

attributes fields メニュー内で、選択したデータセットのフィールド属性を操作できます。データセットが toggleEditing 編集モード であるときボタン newAttribute 新COLUMNdeleteAttribute COLUMNを削除 を使用できます。

編集ウィジェット

Figure Fields 1:

../../../_images/editwidgetsdialog.png

属性列の編集ウィジェットを選択するためのダイアログ

fields をメニュー内では、また、 編集ウィジェット 列を見つけます。この列は、値または特定の属性表の列に追加することを許可される値の範囲を定義するために使用できます。 [編集ウィジェット] ボタンをクリックした場合は、別のウィジェットを定義でき、ダイアログが開きます。これらのウィジェットは、以下のとおりです。

  • チェックボックス:チェックボックスを表示し、そして、チェックボックスがアクティブかされていない場合、列に追加されているものの属性を定義できます。

  • 分類: , プロパティの スタイル メニューで ‘固有値’ を凡例タイプとして選択している場合コンボボックスで分類を行う値を選択してください.

  • :ユーザーがカラーダイアログウィンドウから色を選択でき、色のボタンを表示します。

  • 日付/時刻 :日付、時刻、またはその両方を入力するには、カレンダーウィジェットを開くことができる行フィールドを表示します。列タイプはテキストでなければなりません。カスタム形式を選択でき、ポップアップカレンダーを、など

  • 列挙 :列のタイプ内で使用できる値を持つコンボボックスを開きます。これは、現在、PostgreSQLのプロバイダによってサポートされています。

  • ファイル名: ダイアログにファイル選択を追加した簡素なファイル選択.

  • Hidden: 隠れた属性カラムは見ることができません. ユーザーはそのコンテンツをみることができません.

  • 写真: ピクチャのファイル名を含むフィールドです。フィールドの幅と高さが定義されます。

  • レンジ :特定の範囲から数値を設定できます。編集ウィジェットは、スライダやスピンボックスのいずれかになります。

  • 関係リファレンス:このウィジェットは、実際のレイヤーの特徴フォームの参照レイヤーの機能フォームを埋め込むことができます。 1対多関係を作成する 参照。

  • **テキスト編集**(デフォルト):これは単純なテキストまたは複数行を使用でき、テキスト編集フィールドを開きます。複数の行を選択した場合は、HTMLコンテンツを選択できます。

  • ユニークな値:すでに属性テーブルで使用される値のいずれかを選択できます。「編集可能」が有効になっている場合、ラインエディットは、そうでない場合は、コンボボックスが使用され、自動補完をサポートして示されています。

  • UUID ジェネレータ:空の場合、読み取り専用のUUID (Universally Unique Identifiers) フィールドを生成します。

  • 値マップ:事前に定義された項目を持つコンボボックス。値は、属性に格納され、説明はコンボボックスに示されています。手動で値を定義するか、またはレイヤーまたはCSVファイルからそれらを読み込むことができます。

  • 値の関係 :コンボボックス内の関連テーブルから値を提供しています。レイヤー、キー列と値の列を選択できます。値でNULL値、順序を許可し、複数選択および自動入力補完の使用を許可する:いくつかのオプションが標準の動作を変更することが可能です。コンプリチェックボックスが有効になっている場合、フォームは、ドロップダウンリストまたは行の編集フィールドのいずれかが表示されます。

  • WebView :フィールドにはURLが含まれています。フィールドの幅と高さは可変です。

ノート

QGISのpythonを使用して、独自のフィールドのウィジェットを定義し、ウィジェットのこの印象的なリストに追加するには、高度な「隠れた」オプションを持っています。これはトリッキーですが、それは非常によく説明し、ウィジェットのように使用でき、リアルタイムの検証ウィジェットを作成する方法について説明します優れたブログを以下に説明されています。http://blog.vitu.ch/10142013-1847/write-your-own-qgis-form-elementsを参照してください。

ちなみに

ウィジェットでの相対パス

ファイルブラウザで選択されたパスが.qgsプロジェクトファイル以下と同じディレクトリにある場合、パスは相対パスに変換されます。これは、付属のマルチメディア情報とQGSプロジェクトの移植性を向上させます。これは、この時点でファイル名のみ、写真やWeb表示用に有効になっています。

属性エディタのレイアウト を使用すると、今定義できます :index:`組み込みのforms`( figure_fields_2 を参照)。これは、データ入力の仕事のために有用であるか、多くの属性を持つオブジェクトを持っていたときに開いているフォームの自動オプションを使用してオブジェクトを識別するために。属性フィールドを提示するには、いくつかのタブや名前付きグループでエディタを作成できます。

「ドラッグアンドドロップデザイナー」と属性列を選択してください。カテゴリを作成するための signPlus アイコンを使用してタブまたは名前付きグループを挿入します( figure_fields_3 を参照)。新しいカテゴリを作成する場合は、QGISはビルトイン形でカテゴリの新しいタブまたは名前付きグループを挿入します。次のステップでは、と、選択したカテゴリに関連するフィールドを割り当てることになります arrowRight アイコン。より多くのカテゴリを作成して、再度同じフィールドを使用できます。

ダイアログ内のその他のオプションは、「自動生成」と「UI-ファイルを指定して」です。

  • 「自動生成は、ちょうどすべてのフィールドのためのエディタを作成し、それを表にしたものです。

  • 「UI-ファイルを提供する」オプションを使用すると、Qt-Designerで作られた複雑なダイアログを使用できます。UI-ファイルを使用すると、ダイアログボックスを作成するにはかなり自由にできます。詳細については、http://nathanw.net/2011/09/05/qgis-tips-custom-feature-forms-with-python-logic/を参照してください。

QGISダイアログがダイアログが開かれたときに呼び出されるPythonの機能を持たせることができます。ダイアログに余分なロジックを追加するには、この機能を使用してください。フォームのコードでは、3つの異なる方法で指定できます。

  • startup.py やプラグインからの例のための)環境からのロード

  • 外部ファイルからのロードは、ファイル選択は、ファイルシステムからPythonのファイルを選択できるように、その場合に表示されます

  • 直接フォームのコードを入力できる場所インラインコードからロード、Pythonのエディタが表示されます

すべての場合において、(下の例では open )に呼び出される関数の名前を入力する必要があります。

例は(MyForms.pyモジュール)です。

def open(dialog,layer,feature):
    geom = feature.geometry()
    control = dialog.findChild(QWidged,"My line edit")

そのようなPythonのinit関数で参照: open

Figure Fields 2:

../../../_images/attribute_editor_layout.png

属性編集レイアウト でカテゴリを生成するダイアログ

Figure Fields 3:

../../../_images/resulting_feature_form.png

内蔵の結果タブと名前付きグループを持つフォーム

結合メニュー

join 結合 メニューは、ロードされたベクターレイヤーにロードされた属性テーブルを 結合 できます。 signPlus をクリックした後 ベクター結合を追加 ダイアログが表示されます。 ターゲットベクターレイヤーに接続したいレイヤー 結合キー列として、定義する必要があります。次に、結合するレイヤーとターゲットレイヤーの両方に共通する結合フィールドを指定する必要があります。今、また、チェックボックスに基づいて、結合レイヤーからフィールドのサブセットを指定できます checkbox joined であるフィールドを選択してください。結合の結果として、結合レイヤーとターゲットレイヤーからのすべての情報は、結合情報としてターゲットレイヤーの属性テーブルに表示されています。フィールドのサブセットを指定した場合のみ、これらのフィールドは、ターゲットレイヤーの属性テーブルに表示されます。

QGISは現在OGR(例えば、CSV、DBFやExcel)、区切りのテキストとPostgreSQLプロバイダ( figure_joins_1 を参照)でサポートされている非空間テーブルのフォーマットに参加をサポートしています。

Figure Joins 1:

../../../_images/join_attributes.png

既存のベクターレイヤーに属性テーブルに参加

さらにベクター結合ダイアログでは次のことができます:

  • checkbox 結合レイヤをヴァーチャルメモリにキャッシュする

  • checkbox 結合フィールドに属性インデックスを作成する

  • checkbox 結合されているフィールドを選択

  • checkbox カスタムフィールド名prefix を作成します

ダイアグラムメニュー

diagram ダイアグラム メニューではベクターレイヤにグラフィックオーバーレイを行うことができます ( figure_diagrams_1 参照).

図の現在のコアの実装は、以下にサポートを提供します:

  • 円グラフ 、数値の割合を示すためにスライスに分割された円形統計グラフィック。各スライスの弧の長さは、それが表す量に比例しています

  • テキスト・ダイアグラム 、内部に統計値を表示するhorizo​​ntaly分割円

  • そして、 ヒストグラム

index:diagram の種類ごと、メニューは、5つのタブに分割されています。

属性

Attributes 変数は図に表示するかを定義します。 signPlus itemを追加 ボタンを使用して「割り当てられた属性」パネルに必要なフィールドを選択します。 で生成された属性も使用できます。

atributesの表示方法を並べ替え、クリックとドラッグでアップし、任意の行下に移動できます。また、項目をダブルクリックすることで「レジェンド」列またはattibute色でラベルを変更できます。

このラベルは、印刷コンポーザのか、レイヤツリーの凡例に表示されるデフォルトのテキストです。

Figure Diagrams 1:

../../../_images/diagram_tab.png

ベクタープロパティは、ダイアグラム]メニューでダイアログ

外観

Appearance は、図がどのように見えるかを定義します。それは、次のような統計値に干渉しない一般的な設定を提供します。

  • グラフィック、透明性、その輪郭線の幅と色

  • ヒストグラムの場合はバーの幅

  • テキスト図の場合の円の背景色、およびテキストに使用するフォント

  • 円グラフで示される第1のスライスの左線の向き。スライスが時計回りに表示されていることに注意してください。

このメニューでは、また、ダイアグラムの可視性を管理できます。

  • 他と重複する図を削除するか、それらが重なっている場合でも すべてのdiagramsを表示 ことによって 、

  • 縮尺可視性 を設定することにより、

サイズ

Size は、選択した統計情報が表現される方法を設定するためのメインタブです。図のサイズの単位は、「地図単位」または「ミリメートル」にできます。使用できます。

  • 固定size は、独特のサイズは、ヒストグラムを表示する場合を除いて、すべての機能のグラフィックを表現します

  • または スケールドsize レイヤーの属性を使用して式に基づいて、。

Figure Diagrams 2:

../../../_images/diagram_tab_size.png

ベクタープロパティは、ダイアグラム]メニュー、[サイズ]タブでダイアログ

配置

Placement は図の位置を定義するのに役立ちます。レイヤジオメトリタイプによれば、配置のためのさまざまなオプションを提供しています。

  • ポイントジオメトリのための「ポイントアラウンド」や「ポイント以上」。後者の変数は、以下までの半径を必要とします。

  • ラインジオメトリのための「線を中心に」または「行にわたって」。ポイント地物と同様に、最後の変数は尊重すると、ユーザは(および/またはライン「の下に」「に」、「以上」)機能を図の配置を相対指定でき、距離を必要とすることは、一度に複数のオプションを選択することが可能です。その場合には、QGISは、図の最適な位置を探します。ここでまた、図の位置のためのラインの向きを使用できることを覚えておいてください。

  • (距離が設定された)「重心アラウンド」、「重心以上」、「ポリゴンインサイド」「ペリ」とどこかには、ポリゴン地物のためのオプションです。

図はまた、地物の属性と XY フィールドを満たすことによって地物データを使用して配置できます。

優先 スライダーや Zインデックス 値を設定することにより、図やラベル間の位置の競合を検出して解決できますので、図の配置は、ラベルと対話できます。

オプション

Options タブでは、ヒストグラムのみの場合には設定があります。バーの向きが、「下」、「右」と「左」「上」するかどうかを選択できます。

ちなみに

図をすばやく切り替える

図を設計する際に、ほとんどすべての上の設定は、図の異なるタイプに共通していることを考えると、何も損失なしに簡単に図の種類を変更し、どれがデータにとってより適切であるか確認できます。

ケーススタディ

アラスカ州の境界レイヤーの上に、気候ベクターレイヤーからの温度データを示すテキスト図を例とオーバーレイのデモンストレーションを行います。両方のベクターレイヤーはQGISサンプルデータセットの一部( サンプルデータ セクションを参照)です。

  1. まず、 addOgrLayer ロードVector アイコンをクリックして、QGISサンプルデータセットフォルダを参照し、2つのベクターシェイプレイヤー alaska.shpclimate.shp をロードしてください。

  2. 地図凡例にある climate layer をダブルクリックして レイヤプロパティ ダイアログを開いて下さい.

  3. Diagrams メニュークリックして、アクティブ checkbox このlayer を表示図、及びから :guilabel:`ダイアグラムのtype`が selectString コンボボックスを選択し「テキスト図」。

  4. Appearance タブで、背景色として水色を選択し、 Size タブ中、18ミリメートルに固定されたサイズを設定しました。

  5. Position タブ、配置は「点の周り」に設定できます。

  6. 図では、3つの列の値は T_F_JANT_F_JULT_F_MEAN を表示したいです。だから、 Attributes タブ中で最初の T_F_JAN を選択し、 signPlus ボタンをクリックして T_F_JUL 、最後に T_F_MEAN を繰り返します。

  7. 今QGISメインウィンドウにダイアグラムを表示するには、 [適用] をクリックします。

  8. Size タブには、チャートのサイズを適応させることができます。 radioButtonOn アクティブ化 size をスケーリングとに基づいて図のサイズを設定 属性の最大[値]と :guilabel:`Size オプション。ダイアグラムが画面に表示される小さすぎる場合は、アクティブにできます checkbox 小diagrams チェックボックスのサイズを大きくし、図の最小サイズを定義します。

  9. で色の値をダブルクリックして属性の色を変更します フィールド属性 が割り当てられました。 Figure_diagrams_3 は、結果のアイデアを提供します。

  10. 最後に [OK] をクリックします。

Figure Diagrams 3:

../../../_images/climate_diagram.png

地図上に重ねた温度データからのダイアグラム

checkbox Position タブで、図の データ定義position が可能であることを思い出してください。ここでは、図の位置を定義するための属性を使用できます。 Appearance タブで縮尺に応じた表示も設定できます。

サイズや属性も表現できます。 expressionEditorOpen ボタンを使用式を追加します。詳細と例について 章を参照。

アクションメニュー

action QGISは、機能の属性に基づいてアクションを実行する機能を提供します。これは、Webレポーティングツールに機能の属性または渡すパラメータから構築された引数を指定してプログラムを実行している、例えば、任意の数のアクションを実行するために使用できます。

Figure Actions 1:

../../../_images/action_dialog.png

Overview action dialog with some sample actions

頻繁に外部のアプリケーションを実行したり、ベクターレイヤーに1つ以上の値に基づいてWebページを表示する際にアクションが便利です。それらは、6つのタイプに分けられ、このように使用できます。

  • Generic、Mac、WindowsとUnixのアクションが外部プロセスを開始します。

  • Python アクションは Python 構文を実行します.

  • GenericとPythonのアクションはどこでも見ることができます。

  • マック、WindowsとUnixのアクションは唯一、それぞれのプラットフォーム上に表示されている(つまり、エディタを開くには、3つの「編集」アクションを定義でき、ユーザーは唯一のエディタを実行するには、そのプラットフォームのための1つの「編集」アクションを確認し、実行できます) 。

ダイアログに含まれていくつかの例があります。 [既定のアクションを追加] をクリックしてそれらをロードできます。一つの例は、属性値に基づいて検索を実行しています。この概念は、以下の議論で使用されています。

アクションの定義

レイヤProperties ダイアログアクションは、ベクターから定義されている属性。To action を定義するベクターを開く レイヤProperties ダイアログとをクリックしてください Actions メニュー。 アクションproperties に移動します。タイプとして「一般」を選択し、アクションの記述名を提供します。アクション自体は、アクションが呼び出されたときに実行されるアプリケーションの名前が含まれている必要があります。、アプリケーションへの引数として1つ以上の属性フィールドの値を追加できます。アクションが呼び出されると、フィールドの名前に続いて ````で始まる任意の文字の集合は、そのフィールドの値に置き換えられます。特殊文字 :index:`%%`(以下 using_actions 参照)を同定結果や属性テーブルから選択されたフィールドの値によって置き換えられます。二重引用符は、プログラム、スクリプトまたはコマンドへの単一の引数にグループのテキストに使用できます。前にバックスラッシュを付けた場合、二重引用符は無視されます。

他のフィールド名のサブストリングあるフィールド名を持っている場合 (例えば col1 と``col10``)、角括弧でフィールド名 (および % 文字) を囲むことで示す必要があります (e.g., [%col10])。 これは  %col10 フィールド名が 末尾に 0%col1 フィールド名と間違えているから防ぐことができます。フィールドの値に代入したときのブラケットはQGISによって除去されます。角括弧に囲まれて、置換フィールドをしたい場合は、このような第2のセットを使用します: [[%col10]]

Features識別 ツールを使用して、 Resultsを識別 ダイアログ開くことができます。これは、レイヤーのタイプに関連する情報が含まれる (派生) アイテムを含みます。この項目の値は、 (派生). で派生されるフィールド名を進めることにより、その他のフィールドと同様の方法でアクセスできます。例えば、点レイヤーは、 XY フィールドを有し、これらのフィールドの値は、 %(派生).X%(派生).Y でアクション中で使用できます。派生属性は 属性Table ダイアログボックスではなく、Results識別 ダイアログボックスからのみ利用可能です。

2つの アクション例 が以下にあります:

  • konqueror http://www.google.com/search?q=%nam
  • konqueror http://www.google.com/search?q=%%

最初の例では、WebブラウザKonquerorは呼び出され、開くためにURLが渡されます。URLは、私たちのベクターレイヤーから `` nam``フィールドの値にGoogle検索を実行します。アクションによって呼び出されるアプリケーションまたはスクリプトがパスになければならないことに注意してください、または完全なパスを提供しなければなりません。一定であるために、 /opt/kde3/bin/konqueror http://www.google.com/search?q=%nam として最初の例を書き換えることができたかも。これは、アクションが呼び出されたときにKonquerorのアプリケーションが実行されることを保証します。

第二の例では、その値が特定のフィールドに依存しない%の%の表記を使用します。アクションが呼び出されると、%%は、識別結果や属性テーブルの選択したフィールドの値に置き換えられます。

アクションの使用

アクションは Resultsを識別`ダイアログ、 :guilabel:`属性Table ダイアログ、または 実行機能Action いずれかから呼び出すことができます(これらのダイアログは、 identify 地物を識別openTable open属性TableactionRun 実行機能Action をクリックすることで開くことができることを思い出してください)。アクションを呼び出すには、右クリックしてポップアップメニューからアクションを選択します。アクションは、アクションを定義するときに割り当てた名前でポップアップメニューに表示されます。起動したいアクションをクリックします。

もし %% 表記を使ってアクションを呼び出した場合, アプリケーションかスクリプトに渡したいフィールドを Identify Results ダイアログか Attribute Table ダイアログで右クリックして下さい.

nix または多分 osx それだけで動作します)ここでは別のベクターレイヤーからデータを引き出し、bashを使用してファイルと echo コマンドに挿入する例があります。当該レイヤーは、種名 taxon_name 、緯度 lat 及び経度 long のためのフィールドを有しています。地域の空間的な選択を行うと(QGIS地図領域に黄色で表示)選択したレコードのためのテキストファイルにこれらのフィールドの値をエクスポートできるようにしたいと思います。ここでは、これを達成するためのアクションは次のとおりです。

bash -c "echo \"%taxon_name %lat %long\" >> /tmp/species_localities.txt"

いくつかの地域を選択して、それぞれのアクションを実行し、出力ファイルを開いた後、このようなものが表示されます。

Acacia mearnsii -34.0800000000 150.0800000000
Acacia mearnsii -34.9000000000 150.1200000000
Acacia mearnsii -35.2200000000 149.9300000000
Acacia mearnsii -32.2700000000 150.4100000000

練習として、 lakes レイヤーでGoogle検索を行うアクションを作成できます。まず、キーワードで検索を実行するために必要なURLを決定する必要があります。これだけで簡単にGoogleに行くと、ブラウザのアドレスバーからURLをつかん、単純な検索を行うことによって行われます。この少しの努力から、フォーマットが http://google.com/search?q=qgis であることがわかります、ここで QGIS は検索用語。この情報を武器に進むことができます:

  1. 必ず lakes レイヤをロードしましょう。

  2. 凡例中のレイヤーをダブルクリックして レイヤProperties ダイアログを開き、または右クリックしてポップアップメニューから Properties を選択します。

  3. Click on the Actions menu.

  4. アクションの名前を入力して下さい.たとえば Google Search.

  5. アクションを定義するために実行する外部プログラムの名前を提供しなければいけません. この場合私達はFirefoxを使います. もしプログラムがシステムのパス内に存在しない場合はフルパスを指定する必要があります.

  6. 以下の外部アプリケーション名にGoogle searchを行うためのURL http://google.com/search?q= を加えます.しかし検索文字は含まれていません

  7. The text in the Action field should now look like this: firefox http://google.com/search?q=

  8. lakes レイヤのフィールド名が含まれているドロップダウンボックスをクリックして下さい. それは [Insert Field] ボタンの左側にあります.

  9. ドロップダウンボックスで ‘NAMES’ を選択した後に [Insert Field] をクリックして下さい.

  10. アクションテキストは現在このようになっています:

    firefox http://google.com/search?q=%NAMES

  11. 最後に [Add to action list] ボタンをクリックして下さい.

アクションは完成して利用可能になりました. 最終的なテキストはこのようになっています:

firefox http://google.com/search?q=%NAMES

これでアクションの利用が可能です. Layer Properties ダイアログを閉じて地図を見たい領域にズームして下さい. lakes レイヤがアクティブであることに注意して地物情報表示ツールで湖をクリックして下さい. 結果表示ボックスの中にアクションが表示されているはずです:

Figure Actions 2:

../../../_images/action_identifyaction.png

地物を選択し、アクションを選択してください

アクションをクリックすると、それは、Firefoxを立ち上げると、URL http://www.google.com/search?q=Tustumena に移動します。アクションにさらに属性フィールドを追加することも可能です。そのため、追加できます + アクションのテキストの最後に、別のフィールドを選択し、 [フィールドの挿入] をクリックしました。この例では、検索するために理にかなって利用できるだけで、他のフィールドがありません。

レイヤーのための複数のアクションを定義でき、それぞれに表示されます Results ダイアログを確認します。

また、ポップアップメニューからアクションを選択し、行および右クリックを選択することにより、属性テーブルからアクションを呼び出すことができます。

アクションのための用途のすべての種類があります。、ファイル名と一緒に画像や写真の場所を含むポイントレイヤーを持っている場合たとえば、画像を表示するビューアを起動するためのアクションを作成できます。また、我々はGoogleの検索例で行ったのと同じ方法でそれらを指定して、フィールドの属性フィールドまたはそれらの組み合わせのためのWebベースのレポートを起動するためにアクションを使用できます。

また、より複雑な例を、例えば Python アクションを使用して作成できます。

外部アプリケーションでファイルを開くためのアクションを作成するときに通常、絶対パス、または最終的には相対パスを使用できます。第二のケースでは、パスは、外部プログラムの実行可能ファイルの場所への相対的です。しかし、私たちが選択したレイヤー(シェープファイルまたはSpatiaLiteのようなファイルベースの1、)に対する相対パスを使用する必要がある場合はどうですか?次のコードは、トリックを行います。

command = "firefox"
imagerelpath = "images_test/test_image.jpg"
layer = qgis.utils.iface.activeLayer()
import os.path
layerpath = layer.source() if layer.providerType() == 'ogr'
  else (qgis.core.QgsDataSourceURI(layer.source()).database()
    if layer.providerType() == 'spatialite' else None)
path = os.path.dirname(str(layerpath))
image = os.path.join(path,imagerelpath)
import subprocess
subprocess.Popen( [command, image ] )

アクションは Python の一種であり、 と *コマンドimagerelpath 変数は私たちの必要に合わせて変更する必要があることをちょうど思い出す必要があります。

しかし、どのような相対パスは、(保存)プロジェクトファイルへの相対する必要がある場合はどうですか?Pythonのアクションのコードは次のようになります。

command="firefox"
imagerelpath="images/test_image.jpg"
projectpath=qgis.core.QgsProject.instance().fileName()
import os.path
path=os.path.dirname(str(projectpath)) if projectpath != '' else None
image=os.path.join(path, imagerelpath)
import subprocess
subprocess.Popen( [command, image ] )

別のPythonの動作例は、プロジェクトに新しいレイヤーを追加することが可能にするものです。例えば、以下の実施例は、それぞれプロジェクトベクターとラスターに追加します。プロジェクトに追加するファイルやレイヤーに与えられる名前の名前は、データ駆動型( ファイル名layername は、アクションが作成されたベクターの属性のテーブルの列の名前です)されています。

qgis.utils.iface.addVectorLayer('/yourpath/[% "filename" %].shp',
  '[% "layername" %]', 'ogr')

ラスタ(この例ではTIFイメージ)を追加するには、次のようになります:

qgis.utils.iface.addRasterLayer('/yourpath/[% "filename" %].tif',
  '[% "layername" %]')

メニュー表示

mapTips このメニューは、 地図Tips のために特別に作成されます。HTMLでの地図ヒント表示テキスト:それは便利な機能が含まれています。まだ選択できますが、地図上の地物の上にマウスを移動するとき、 radioButtonOff Field が表示されるように、それは地物の上にマウスを移動する際の複雑な表示を作成するHTMLコードを挿入することも可能です。マップチップを有効にするには、 ビュー - >地図Tips メニューオプションを選択。

図形表示1及び2は、HTMLコードの例を示し、それが地図キャンバスに動作方法。

Figure Display 1:

../../../_images/display_html.png

マップチップのためのHTMLコード

Figure Display 2:

../../../_images/map_tip.png

HTMLコードで作られた地図の先端

レンダリングメニュー

generalisation QGISはオンザフライ機能のサポートを提供しています。これは、小さな縮尺で多くの複雑な地物を描画するときにレンダリング時間を改善できます。この機能は、 checkbox geometryを簡素化 オプションを使用してレイヤの設定で有効または無効にできます。( オプション の項を参照)、新たに追加されたレイヤーに対して、デフォルトで一般化を可能にするグローバル設定もあります。

Figure Rendering 1:

../../../_images/simplify_rendering.png

レイヤジオメトリ簡素化ダイアログ

ノート

地物のジェネラリゼーションは、いくつかの場合では、レンダリングされた出力にアーティファクトを持ち込むことがあります。これらは、ポリゴンとオフセットベースシンボルレイヤを使用して不正確なレンダリングの間に繊維束を含むことができます。

非常に詳細なレイヤー(ノードの膨大な数の例えばポリゴンレイヤー)をレンダリングするが、これはすべてのノードがエクスポートされたファイルに含まれているので、PDF / SVG形式のコンポーザ書き出しを巨大にすることを引き起こす可能性があります。また、これは他のプログラムで開い/で動作するように結果ファイルが非常に遅いことができます。

checkbox :guilabel: rasterとしてレイヤーをレンダリングするよう強制 をチェックすると、エクスポートしたファイルは、これらのレイヤーに含まれるすべてのノードを含める必要はありませんし、レンダリングがゆえ高速化されるようにラスタライズされるように、これらのレイヤーを強制するようします。

また、ラスタとしてエクスポートするコンポーザを強制することでこれを行うことができますが、それはラスターは、すべてのレイヤーに適用されることを考えると、全か無かのソリューションです。

メタデータメニュー

metadata Metadata メニューは Description, Attribution, MetadataURL, LegendUrl and Properties セクションで構成されます。

Properties セクションには、種類や場所、地物の数、地物タイプ、および編集地物についての詳細を含むレイヤー、に関する一般的な情報を取得します。レイヤーのCRSに関する情報である レイヤ空間参照SystemExtents テーブルはレイヤーの広がりとの情報を提供します。これは、レイヤに関する有用な情報を取得する簡単な方法を提供できます。

また、Description セクションでは、レイヤーのタイトルと抄録を追加したり、編集できます。 キーワードがここlist それは定義することも可能です。これら キーワードlists は、メタデータカタログで使用できます。 DataUrl フィールドは、XMLメタデータファイルからタイトルを使用する場合は、内のリンクに記入しなければなりません。

Attribution を使用してXMLメタデータ・カタログから属性データを取得します。

MetadataUrl では、XMLメタデータカタログへの一般的なパスを定義できます。この情報は、その後のセッションのためのQGISプロジェクトファイルに保存され、QGISサーバに使用されます。

LegendUrl セクションでは、URLフィールドに、凡例画像のURLを提供できます。、画像の適切なフォーマットを適用する書式のドロップダウンオプションを使用できます。現在、PNG、JPGやJPEG画像フォーマットがサポートされています。

Figure Metadata 1:

../../../_images/vector_metadata_tab.png

ベクターレイヤーのプロパティ]ダイアログボックスのメタデータメニュー

保存して、レイヤーのプロパティを共有します

カスタムスタイルを管理します

レイヤーはキャンバスを地図に追加された場合、QGISは、その機能をレンダリングするために、デフォルトでは、ランダムなシンボル/色を使用しています。 プロジェクト - >プロパティ ->デフォルトstyles そのジオメトリタイプに応じて、各新しく追加されたレイヤーに適用されますただしにおけるデフォルトのシンボルを設定できます。

しかし、ほとんどの時間は、レイヤーに(より少ない労力で)、自動または手動で適用でき、カスタム、より複雑なスタイルを持っていることを好むだろう。[レイヤプロパティ]ダイアログの下部にある Style コンボボックス使用して、この目標を達成できます。このコンボボックスでは、作成負荷やスタイルを管理するための機能を提供します。

スタイルは、レンダリングまたは(シンボル、ラベル、アクション、図...設定を含む)の地物と対話するために対話レイヤーのプロパティで設定されたすべての情報を格納します。

Figure Vector Properties 10:

../../../_images/style_combobox.png

スタイルコンボボックスのオプション

デフォルトでは、ロードされたレイヤーに適用されるスタイルは default という名前です。レイヤーのための理想的な、適切なレンダリングを持っているたら、クリックして保存できます selectString Style コンボボックスを選択します:

  • 現在名前を変更 。アクティブなスタイルの名前を変更し、現在のオプションで更新されます

  • 追加 :新しいスタイルは、現在のオプションを使用して作成されます。

スタイル]ドロップダウンリストの一番下に、レイヤーに設定されたスタイルを見ると、アクティブなものがチェックされます。レイヤーのために定義された複数のスタイルを持っていたら、 現在の削除 オプションでは、もはやたいそれらを削除できます。

レイヤーのプロパティダイアログボックスを検証するたびに、アクティブなスタイルは、やった変更で更新されていることに注意してください。

レイヤーのために望むように、できるだけ多くのスタイルを作成できますが、一つだけが一度にアクティブにできます。視界のプリセットをレイヤーに合わせて、これはいくつかのレイヤー(地図の凡例内の任意のレイヤーを複製する必要はありません)で複雑なプロジェクトを管理するために迅速かつ強力な方法を提供しています。

ちなみに

レイヤーのコンテキストメニューからスタイルを管理します

レイヤーPanel でレイヤーを右クリックして、レイヤースタイルを追加、名前変更、または削除します。また、地物シンボルを編集できます。

ファイルまたはデータベースにスタイルを保存します

これらのスタイルは、プロジェクト内に保存され、プロジェクト内のレイヤーからレイヤーにコピーして貼り付けることができますが、それらは別のプロジェクトにロードできるように、それはプロジェクトの外にもそれらを保存できます。 selectString スタイル - >保存Style クリックはQGISのレイヤースタイルファイルとしてシンボルを保存します( .qml )またはSLDファイル( .sld )。段階またはルールベースの分類、単一のシンボル - - のSLDは、レンダラの任意のタイプからエクスポートできるが、SLDをインポートするときに、いずれかの単一のシンボルまたは規則に基づくレンダラが作成されます。これは、分類または段階スタイルはルールベースに変換されていることを意味します。それらのレンダラーを保持したい場合は、QML形式に固執する必要があります。一方、それは、規則に基づくのためにスタイルを変換するこの簡単な方法を持っているために、時には非常に便利です。

レイヤーのデータソースは、データベース(例えばPostGISのかSpatialite)である場合は、データベースのテーブル内のレイヤースタイルを保存できます。ちょうど 保存Style コンボボックスをクリックして データベース内保存 アイテムをを選択し、その後、スタイル名を定義し、該当する場合について、UIファイルを追加し、スタイルがデフォルトのスタイルであるかどうかを確認するダイアログボックスに記入。データベース内のいくつかのスタイルを追加できます。しかし、各テーブルにはデフォルトのスタイルを1つだけ持つことができます。

QGISでレイヤーを読み込むときのデフォルトのスタイルはすでにこのレイヤーに存在する場合、QGISはレイヤーとそのスタイルをロードします。レイヤースタイルを変更した後、デフォルトのものかなりの新しいスタイルを作成し、 デフォルトとして保存 できます、満足していない場合スタイルを デフォルトに戻す ことができます。

Figure Vector Properties 2:

../../../_images/save_style_database.png

データベースダイアログでスタイルを保存

ちなみに

素早くプロジェクト内でレイヤースタイルを共有する

また、ファイルやデータベースのスタイルをインポートせずに、プロジェクト内のレイヤースタイルを共有できます:でレイヤーを右クリックし、 レイヤーPanel と、から Styles コンボボックス、レイヤーのスタイルをコピーしますグループまたはレイヤーの選択に貼り付け:スタイルが(同じタイプの点のオリジナルレイヤーと、ベクターの場合には、同じジオメトリタイプを有するとして(ラスタ対ベクター)であるすべてのレイヤーに適用され、ラインまたはポリゴン)。