Outdated version of the documentation. Find the latest one here.

.

一般ツール

キーボードショートカット

QGIS は多くの機能のデフォルトキーボードショートカットを提供しています.セクション メニューバー にそれらは記述されています.さらにメニューオプション Settings ‣ Configure Shortcuts を使うとデフォルトキーボードショートカットを変更して新しいキーボードショートカットを QGIS の機能に加えることができます.

Figure Shortcuts 1:

../../../_images/shortcuts.png

ショートカットオプションの定義 nix (Gnome)

構成はとても簡単です.リストから機能を選択し [変更], [無し] を設定 または [デフォルトを設定] をクリックして下さい. あなた自身の構成を作成したら,その設定をXMLファイルで保存して他の QGIS インストレーションでロードして利用することができます.

コンテキストヘルプ

特定のトピックでヘルプが必要な場合多くのダイアログに実装されている [Help] ボタンでコンテキストヘルプを利用することができます- サードパーティプラグインでは専用のウェッブページを指し示すことを注意して下さい.

レンダリング

デフォルトで QGIS レンダラはマップキャンバスに含まれる全ての可視レイヤ表示を更新します.このイベントはマップキャンバスに含まれるものすべてをリフレッシュします:

  • レイヤの追加

  • パンまたはズーム

  • QGISウィンドウのリサイズします

  • レイヤまたはレイヤ群の表示、非表示を変更します

QGIS ではいくつもの方法で描画プロセスを管理できます.

スケール依存レンダリング

スケール依存レンダリングを利用するとあるレイヤが表示される最小と最大のスケールを指定することができます. スケール依存レンダリングを設定する場合レイヤを凡例でダブルクリックして プロパティ ダイアログを開いて下さい. 一般情報 タブで, checkbox縮尺に応じた表示設定 チェックボックスをアクティブにして最小と最大の縮尺値を設定して下さい.

QGIS ステータスバーでスケール値を見ることで,そのレイヤを表示するのと表示しないスケール値を決めることができます.

地図レンダリングの制御

地図レンダリングは以下に記述される様々な方法で制御することができます:

描画の中断

描画を中止したい場合はステータスバーの右側角にある checkbox Render チェックボックスをクリックしてください. checkbox Render がチェックされていない場合 QGIS はセクション レンダリング に記述されているあらゆるイベントに反応せずキャンバスに再描画を行いません.地図描画を行わないほうがいい場合は以下のような場合があります:

  • 沢山のレイヤを追加して描画する前に描画方法を編集したい場合

  • データ量が多いレイヤを追加して描画する前に縮尺依存描画条件を指定したい場合

  • データ量が多いレイヤを追加して描画する前に特定の位置にズームしておきたい場合

  • 上記の場合のいくつかの組み合わせ

Checking the checkbox Render checkbox enables rendering and causes an immediate refresh of the map canvas.

レイヤ追加オプションの設定

新しくレイヤを追加した時に,すぐに描画しないオプションを設定できます.これはレイヤが地図に追加された時に,地図凡例の可視属性チェックボックスがデフォルトでチェックされないことを意味します.このオプションを指定するためには 設定 ‣ オプション ‣ を選択して レンダリング タブをクリックしてください. checkbox By default new layers added to the map should be displayed のチェックを解除してください.すると,地図に追加されたレイヤの表示属性は不可視の状態がデフォルトになります.

描画の中断

地図描画を中断したい場合は ESC キーを押して下さい.これにより地図キャンパスの更新が中断され地図の一部が描画された状態になります. ESC キーを押してから地図描画が中断されるまで少し時間がかかります.

ノート

現在描画中断機能は利用できません - これはQt4のポートに依存しています,なぜならばユーザーインターフェース(UI)に問題が発生してクラッシュするからです.

描画中に地図表示を更新する

地図に地物が描画更新されるオプションの設定を行うことができます. デフォルトで, QGIS はレイヤの描画が終了するまで地物を表示しません. 地物がデータストアから読まれるときに表示を更新したい場合, メニューオプションの Settings ‣ Options を選択して Rendering メニューをクリックして下さい. 描画更新を行う適切な地物の数を設定して下さい. 設定値が 0 の場合描画時の更新を行いません (これがデフォルトです). 設定値が小さい場合地物読み込み時に地図キャンバスの継続的な更新が行われパフォーマンスが低下します. 推奨値は500以上です.

描画品質への影響

描画品質に影響がある2個のオプションがあります. メニュー 設定 ‣ オプション を選択して レンダリング タブをクリックして以下のチェックボックスを選択、または非選択して下さい.

  • checkbox 線のジャギーを目立たなくします(描画パフォーマンスが低下します)

  • checkbox ポリゴンの不正な塗りつぶしを修正します

スピードアップレンダリング

描画品質に影響がある2個のオプションがあります. メニュー 設定 ‣ オプション を選択して QGIS オプションダイアログを開き レンダリング タブをクリックして以下のチェックボックスを選択、または非選択して下さい.

  • checkbox バックバッファを有効にする. このオプションはキャンセル機能を無効にすることでグラフィックのパフォーマンスを向上させています,そして地物を追加しながら描画します . これがチェックされていない場合 Number of features to draw before updating the display を設定できます, そうでない場合このオプションは非アクティブです.

  • checkbox 再描画の速度を上げられる場合にレンダのキャッシュを利用します

計測

計測は投影座標系(e.g., UTM)と投影されていないデータ内で機能します.ロードされたマップは地理座標系(緯度/経度)で定義され、ラインや面積の計測結果は正確ではないでしょう.必要に応じ、適切なマップの座標系( 投影法の利用方法 のセクションを参照)を設定することで解決します。すべての計測モジュールはデジタイジングモジュール由来のスナップ設定が使用されています.ベクターレイヤのラインやエリアにそって計測をしたい場合、これは便利です.

計測ツールを選択するためには mActionMeasure をクリックして使いたいツールを選択してください.

距離,面積と角度の計測

mActionMeasure Measure Line: QGIS では与えられた点の間の実距離を定義された楕円体にしたがって測ることができます. この機能を構成するためにはメニューオプション Settings ‣ Options を選択して, Map tools タブをクリックして最適な楕円体を選択して下さい. そこではラバーバンドの色と最適な計測単位 (メーターまたはフィート) と角度の単位 (度, ラディアン と gon)も指定できます. このツールを使うと地図上にポイントをクリックできます. それぞれのセグメントの長さと合計値が計測ウィンドウに表示されます. 計測を終了したい場合はマウス右ボタンをクリックして下さい.

Figure Measure 1:

../../../_images/measure_line.png

距離の計測 nix (Gnome)

mActionMeasureArea 面積の計測: 面積も計測することができます。計測ウィンドウで、累積の面積サイズが表示されます。さらに、計測ツールでは現在選択しているレイヤにスナップする場合のスナップ許容値を設定できます( スナップ許容量と検索半径の設定 のセクションを参照)。ラインフィーチャまたはポリゴンの周辺に正確に沿って計測したい場合は、そのスナップ許容値を設定し、レイヤを選択します。計測ツールを使う賽、マウスをクリックするたびに(許容値の設定内で)レイヤをスナップします。

Figure Measure 2:

../../../_images/measure_area.png

面積の計測 nix (Gnome)

mActionMeasureAngle Measure Angle: 角度を計測することができます.カーソルが十字の形状になります.測定したい最初のセグメントをクリックし,計測を希望する角度を描くようにカーソルを移動します.計測結果がポップアップダイアログに表示されます.

Figure Measure 3:

../../../_images/measure_angle.png

角度の計測 nix (Gnome)

地物の選択と選択解除

QGIS ツールバーはマップキャンバスで地物を選択するためにいくつかのツールを提供しています.1つまたはいくつかの地物をクリックのみで選択する場合は mActionSelect をクリックし,あなたのツールを選択して下さい.

  • mActionSelect 1個の地物を選択する

  • mActionSelectRectangle 矩形による地物選択

  • mActionSelectPolygon 多角形による地物選択

  • mActionSelectFreehand フリーハンドによる地物選択

  • mActionSelectRadius 半径による地物選択

選択されている地物をすべて解放したい場合は mActionDeselectAll すべてのレイヤから地物選択を取り消す をクリックして下さい.

mIconExpressionSelect Select feature using an expression allow user to select feature using expression dialog. See Expressions chapter for some example.

Users can save features selection into a New Memory Vector Layer or a New Vector Layer using Edit ‣ Paste Feature as ... and choose the mode you want.

地物情報表示

地物特定をするとマップキャンバスと対話的に操作してポップアップウィンドウで属性データを表示できます. 地物を特定する場合 View ‣ Identify features を選択するか Ctrl + Shift + I をキーボードで押すかツールバーの, mActionIdentify Identify features アイコンをクリックして下さい.

もしあなたが複数の地物をクリックした場合I, Identify results ダイアログは全地物の属性をリストします. 最初のアイテムは結果のアイテムの数でレイヤ名が続きます. 最初の子アイテムはフィールド名と値です. 最後に地物の全情報が表示されます.

このウィンドウはカスタムフィールドを表示するためにカスタマイズできますがデフォルトで3種類の情報を表示します:

  • アクション: 地物情報表示ウィンドウにアクションの追加ができます. アクションラベルをクリックするとアクションを実行できます デフォルトで編集用フォーム表示アクションのみが登録されています.

  • 由来:この情報は、他の情報から計算するか導き出されたものです。クリックされた位置のマップ単位での座標値、x,y座標、マップ単位でのポリゴンの境界の長さ、地物IDを見つけることができます。

  • データ属性:これは、データの属性フィールドのリストです。

Figure Identify 1:

../../../_images/identify_features.png

地物情報表示ダイアログ nix (Gnome)

ウィンドウの下部には5個のアイコンがあります:

  • mActionIdentifyExpand ツリーを展開する

  • mActionIdentifyCollapse ツリーを折りたたむ

  • mActionIdentifyDefaultExpand デフォルトの動作

  • mActionIdentifyCopyAttributes 属性をコピーする

  • mActionIdentifyPrint 選択したHTMLのレスポンスを表示する

その他の機能は、識別されたアイテムのコンテキストメニューにあります。たとえば、コンテキストメニューから次のことができます:

  • 地物フォームの表示

  • 地物のズーム

  • 地物のコピー: すべての地物,のジオメトリと属性をコピーします;

  • 選択地物の切替:特定の地物を選択するために追加します。

  • 属性値のコピー: あなたがクリックした属性値のみをコピーします。

  • 地物の属性をコピーする:属性のみをコピーする;

  • 結果のクリア:ウィンドウ内の結果が削除されます

  • ハイライトのクリア:地図上でハイライトしている地物が除去されます

  • すべてをハイライトする

  • レイヤをハイライトする

  • レイヤのアクティベート: アクティベートするレイヤの選択

  • レイヤプロパティ: レイヤプロパティウィンドウを表示する

  • すべてを展開する

  • すべてを折りたたむ

整飾

QGIS の整飾にはグリッド,著作権ラベル、北向き矢印とスケールバーが含まれています.これらは地図描画のエレメントとして地図を’整飾’するために用いられます。

グリッド

transformed グリッド では座標のグリッドと座標注記をマップキャンバスに追加します。

Figure Decorations 1:

../../../_images/grid_dialog.png

グリッドダイアログ nix

  1. Select from menu View ‣ Decorations ‣ Grid. The dialog starts (see figure_decorations_1).
  2. マップキャンバスにロードされているレイヤにしたがって checkbox Enable grid チェックボックスを有効にしてグリッドの設定を行って下さい.

  3. マップキャンバスにロードされているレイヤにしたがって checkbox Draw annotations チェックボックスを有効にしてアノテーションの定義を行ってください.

  4. Click [Apply] to verify that it looks as expected.
  5. [OK] をクリックしてダイアログを閉じます.

北向き矢印

north_arrow 北向き矢印 を使うとシンプルな北向き矢印をマップキャンバスに置くことができます. 現在1種類のスタイルのみが利用できます. 矢印の角度は調整可能ですし,また QGIS が自動的に方向を設定することもできます. もし QGIS が方位を決める方法を選択すると最良の矢印の方向を指し示します. 矢印を置く場所は4つのオプションがあります, マップキャンバスの4つの隅です.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

北向き矢印ダイアログ nix

スケールバー

scale_bar スケールバー はシンプルなスケールバーをマップキャンバスに追加します. スタイルと位置,バーの上のラベルを設定できます.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

スケールバーダイアログ nix

QGIS はあなたのマップフレームと同じ単位スケールを表示することをサポートしています.もしレイヤの単位がメートルであるなら,フィート単位のスケールバーを作成することはできません.同様に,度数単位を使用している場合はメートル単位で距離を表示するスケールバーを作成することはできません.

スケールバーを追加するために:

  1. メニューの ビュー ‣ 地図整飾 ‣ 著作権ラベル を選択して下さい.ダイアログが表示されます( figure_decorations_4 を参照して下さい).

  2. Choose the placement from the Placement selectstring combo box.
  3. Scale bar style selectstring コンボボックスからスタイルを選択して下さい.

  4. Color of bar selectcolor でバーの色を選択するか,デフォルトの黒を使用して下さい.

  5. バーの大きさとラベルの設定 Size of bar selectnumber.

  6. Make sure the checkbox Enable scale bar checkbox is checked.
  7. オプションで checkbox Automatically snap to round number on resize もチェックできます.

  8. [OK] をクリックして下さい.

ちなみに

整飾の設定

.qgs プロジェクトを保存する際,グリッド,方位記号,スケールバーと著作権ラベルに加えた変更はそのプロジェクトに保存され,次回プロジェクトをロードした際に復元されます.

アノテーションツール

属性ツールバーの mActionTextAnnotation Text Annotation ツールを使うと QGIS マップキャンバスに書式整形されたテキストを表示したバルーンを表示できます. Text Annotation ツールを使ってマップキャンバスをクリックして下さい.

Figure annotation 1:

../../../_images/annotation.png

アノテーションテキストダイアログ nix

項目をダブルクリックすると、さまざまなオプションを含むダイアログが開きます。フォーマットされたテキストやその他の項目の設定値を入力するテキストエディタがあります。例えば、マップの位置(マーカーシンボルが表示された)に関する項目またはスクリーンの位置(マップに関連していない)における選択肢を持ちます。この項目はマップの位置(マップマーカーをドラッグすることにより)が移動し、またはバルーンのみが移動します。アイコンは、GISの主題図の一部であり、それらも、他の主題図においてデフォルトとして用いられます。

The mActionAnnotation Move Annotation tool allows you to move the annotation on the map canvas.

HTML注記

属性ツールバーの mActionFormAnnotation Html Annotation ツールを使うと QGIS マップキャンバスにhtml ファイルを内容としたバルーンを表示することができます. Html Annotation ツールを使ってマップキャンバスをクリックして下さい, そしてhtmlファイルのパスを追加して下さい.

SVG注記

属性ツールバーにある mActionSaveAsSVG SVG Annotation ツールを使うと QGIS マップキャンバスにSVGシンボルを描画したバルーンを表示することができます. SVG Annotation ツールを使いマップキャンバスをクリックした後にダイアログでSVGファイルのパスを追加して下さい.

注記の書式設定

加えてあなたは自分独自のアノテーションフォームを作ることができます. mActionFormAnnotation Form Annotation ツールはベクタレイヤの属性をQt デザインフォームでカスタマイズして表示するためには便利なツールです ( figure_custom_annotation 参照). これは Identify features ツールのデザイナーに似ていますが注記アイテムを表示します. Tim Suttonのビデオhttps://www.youtube.com/watch?v=0pDBuSbQ02o に詳しい情報があるので見てください.

Figure annotation 2:

../../../_images/custom_annotation.png

カスタマイズされたqtデザイナアノテーションフォーム nix

ノート

If you press Ctrl+T while an Annotation tool is active (move annotation, text annotation, form annotation), the visibility states of the items are inverted.

空間ブックマーク

空間ブックマークを使用すると地理的な場所を”ブックマーク”し、あとでその位置に戻ることができます。

ブックマークの作成

ブックマークを作るには:

  1. 関心のある領域にズームまたはパンします。

  2. メニューオプション View ‣ New Bookmark を選択するか Ctrl-B を押して下さい.

  3. ブックマークを説明する名称(255文字まで)を入力します。

  4. ブックマークを追加するためには Enter を入力するかブックマークを削除するためには [Delete] を押して下さい.

同じ名称で複数のブックマークを所有できることにご注意ください。

ブックマークの操作

ブックマークを利用または管理する場合メニューオプション View ‣ Show Bookmarks を選択して下さい. Geospatial Bookmarks ダイアログを使うとブックマークへのズームと削除ができます. ブックマーク名や座標は編集できません.

ブックマークへのズーム

From the Geospatial Bookmarks dialog, select the desired bookmark by clicking on it, then click [Zoom To]. You can also zoom to a bookmark by double-clicking on it.

ブックマークの削除

ブックマークを削除するには 地理空間ブックマーク ダイアログでブックマークを選択し、[削除] をクリックして下さい.削除を確定する場合は [はい] をクリックし,削除をキャンセルする場合には [いいえ] をクリックして下さい.

プロジェクトの入れ子

あなたのプロジェクトに他のプロジェクトファイルからコンテンツを埋め込む場合 Layer ‣ 埋め込みレイヤとグループ を選択して下さい.

埋め込みレイヤ

次のダイアログで,他のプロジェクトのレイヤを埋め込むことができます.

  1. Press browsebutton to look for another project from the Alaska dataset.
  2. プロジェクトファイルの grassland を選択して下さい.あなたはプロジェクトの中身を表示することができます ( figure_embed_dialog を参照してください).

  3. Press Ctrl and click on the layers grassland and regions. Press [OK]. The selected layers are embedded in the map legend and the map view now.

Figure Nesting 1:

../../../_images/embed_dialog.png

埋め込むためのレイヤとグループを選択する nix

埋め込まれているレイヤが編集可能になっている間,スタイルやラベリングのようなプロパティは変更することができません.

埋め込みレイヤの除去

組み込みレイヤを右ボタンクリックして mActionRemoveLayer Remove を選択して下さい.