Outdated version of the documentation. Find the latest one here.

一般ツール

キーボードショートカット

QGIS provides default keyboard shortcuts for many features. You find them in Section メニューバー. Additionally the menu option Settings ‣ Configure Shortcuts allows to change the default keyboard shortcuts and to add new keyboard shortcuts to QGIS features.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Define shortcut options nix (KDE)

構成はとても簡単です。リストから機能を選択し [変更], [無し] を設定 または **デフォルトを設定]**をクリックして下さい. あなた自身の構成を作成したら,その設定をXMLファイルで保存して他のQGISインストレーションでロードして利用することができます.

コンテキストヘルプ

特定のトピックでヘルプが必要な場合多くのダイアログに実装されている Help ボタンでコンテキストヘルプを利用することができます- サードパーティプラグインでは専用のウェッブページを指し示すことを注意して下さい.

レンダリング

デフォルトでQGISレンダラはマップキャンパスに含まれる全ての可視レイヤ表示を更新しますイベントはマップキャンバスに含まれるもののリフレッシュを引き起こします:

  • レイヤの追加

  • パンまたはズーム

  • QGISウィンドウのリサイズします

  • レイヤまたはレイヤ群の表示、非表示を変更します

QGISではいくつもの方法で描画プロセスを管理できます.

スケール依存レンダリング

縮尺によって異なる描画方法を定義できます.あるレイヤが描画される最少と最大の縮尺を定義できます.縮尺依存レンダリングの定義を行うためには,地図凡例でレイヤ名をダブルクリックすると表示される プロパティ 画面を開いて下さい.画面の 一般情報 タブで最小と最大の縮尺値を設定した後に,|checkbox|:guilabel:縮尺依存レンダリングを使用する チェックボックスをクリックして下さい.

QGISステータスバーでスケール値を見ることで,そのレイヤを表示するのと表示しないスケール値を決めることができます.

地図レンダリングの制御

地図レンダリングは以下の方法で制御することができます:

Suspending Rendering

描画を中止したい場合はステータスバーの右側角にある checkbox Render`チェックボックスをクリックしてください. |checkbox| :guilabel:`Render`がチェックされていない場合, QGISはセクション :ref:`redraw_events に記述されているあらゆるイベントに反応せずキャンバスに再描画を行いません.地図描画を行わないほうがいい場合は以下のような場合があります:

  • 沢山のレイヤを追加して描画する前に描画方法を編集したい場合

  • データ量が多いレイヤを追加して描画する前に縮尺依存描画条件を指定したい場合

  • データ量が多いレイヤを追加して描画する前に特定の位置にズームしておきたい場合

  • 上記の場合のいくつかの組み合わせ

Checking the checkbox Render checkbox enables rendering and causes an immediate refresh of the map canvas.

Setting Layer Add Option

新しくレイヤを追加した時に,すぐに描画しないオプションを設定できます.これはレイヤが地図に追加された時に,地図凡例の可視属性チェックボックスがデフォルトでチェックされないことを意味します.このオプションを指定するためには 設定 ‣ オプション ‣ を選択して:guilabel:レンダリング タブをクリックしてください. checkbox By default new layers added to the map should be displayed のチェックを解除してください.すると,地図に追加されたレイヤの表示属性は不可視の状態がデフォルトになります.

描画の中断

To stop the map drawing, press the ESC key. This will halt the refresh of the map canvas and leave the map partially drawn. It may take a bit of time between pressing ESC and the time the map drawing is halted.

ノート

現在描画中断機能は利用できません - これはqt4のポートに依存しています,なぜならばユーザーインターフェース(UI)に問題が発生してクラッシュするからです.

Updating the Map Display During Rendering

You can set an option to update the map display as features are drawn. By default, QGIS does not display any features for a layer until the entire layer has been rendered. To update the display as features are read from the datastore, choose menu option Settings ‣ Options click on the Rendering tab. Set the feature count to an appropriate value to update the display during rendering. Setting a value of 0 disables update during drawing (this is the default). Setting a value too low will result in poor performance as the map canvas is continually updated during the reading of the features. A suggested value to start with is 500.

Influence Rendering Quality

To influence the rendering quality of the map you have 2 options. Choose menu option Settings ‣ Options click on the Rendering tab and select or deselect following checkboxes.

  • checkbox 線のジャギーを目立たなくします(描画パフォーマンスが低下します)

  • checkbox ポリゴンの不正な塗りつぶしを修正します

計測

計測は投影座標系(e.g., UTM)と投影されていないデータ内で機能します。ロードされたマップは地理座標系(緯度/経度)で定義され、ラインや面積の計測結果は正確ではないでしょう。必要に応じ、適切なマップの座標系(ref:`label_projections`のセクションを参照)を設定することで解決します。すべての計測モジュールはデジタイジングモジュール由来のスナップ設定が使用されています。ベクターレイヤのラインやエリアにそって計測をしたい場合、これは便利です。

計測ツールを選択するためには mActionMeasure をクリックして使いたいツールを選択してください.

距離,面積と角度の計測

mActionMeasure QGIS is able to measure real distances between given points according to a defined ellipsoid. To configure this, choose menu option Settings ‣ Options, click on the Map tools tab and choose the appropriate ellipsoid. There you can also define a rubberband color and your preferred measurement units (meters or feet) and angle units (degrees, radians and gon). The tools then allows you to click points on the map. Each segment-length as well as the total shows up in the measure-window. To stop measuring click your right mouse button.

Figure Measure 1:

../../../_images/measure_line.png

Measure Distance nix (KDE)

mActionMeasureArea Areas can also be measured. In the measure window the accumulated area size appears. In addition, the measuring tool will snap to the currently selected layer, provided that layer has its snapping tolerance set. (See Section スナップ許容量と検索半径の設定). So if you want to measure exactly along a line feature, or around a polygon feature, first set its snapping tolerance, then select the layer. Now, when using the measuring tools, each mouse click (within the tolerance setting) will snap to that layer.

Figure Measure 2:

../../../_images/measure_area.png

Measure Area nix (KDE)

mActionMeasureAngle You can also measure angles, selecting Measure Angle tool. The cursor becomes cross-shaped. Click to draw the first segment of the angle you wish to measure, then move the the cursor to draw the desired angle. The measure is displayed in a popup dialog.

Figure Measure 3:

../../../_images/measure_angle.png

Measure Angle nix (KDE)

地物の選択と選択解除

QGISツールバーはマップキャンバスで地物を選択するためにいくつかのツールを提供しています。1つまたはいくつかの地物をクリックのみで選択する場合は |mActionSelect|をクリックし、あなたのツールを選択します。

  • mActionSelect Select single feature
  • mActionSelectRectangle 矩形による地物選択

  • mActionSelectPolygon 多角形による地物選択

  • mActionSelectFreehand フリーハンドによる地物選択

  • mActionSelectRadius 半径による地物選択

To deselect all selected features click on mActionDeselectAll Deselect features from all layers.

整飾

QGISの装飾には著作権ラベル、北向き矢印とスケールバーが含まれています。これらは地図製作の要素として投下することで、マップを’装飾’するために用いられます。

ノート

QGIS 1.8 以前では同じ機能は整飾プラグインで提供されています.

北向き矢印

north_arrow North Arrow places a simple north arrow on the map canvas. At present there is only one style available. You can adjust the angle of the arrow or let QGIS set the direction automatically. If you choose to let QGIS determine the direction, it makes its best guess as to how the arrow should be oriented. For placement of the arrow you have four options, corresponding to the four corners of the map canvas.

Figure Decorations 2:

../../../_images/north_arrow_dialog.png

The North Arrow Dialog nix

スケールバー

scale_bar Scale Bar adds a simple scale bar to the map canvas. You control the style and placement, as well as the labeling of the bar.

Figure Decorations 3:

../../../_images/scale_bar_dialog.png

The Scale Bar Dialog nix

QGISは、あなたのマップフレームと同じ単位スケールを表示することをサポートしています。もしレイヤの単位がメートルであるなら、フィート単位のスケールバーを作成することはできません。同様に、小数単位を使用している場合はメートル単位で距離を表示するスケールバーを作成することはできません。

スケールバーを追加するために:

  1. メニューの`View –> Decorations –> Copyright Label`を選択します。ダイアログが表示されます( figure_decorations_1 を参照すること)。

  2. guilabel:Placement のドロップダウンリストの’Bottom Right’からラベルの配置を選択します。

  3. guilabel:`Scale bar style`の’Tick Down’リストからスタイルを選択します。

  4. guilabel:`Color of bar`の ‘black’でバーの色を選択するか、デフォルト色の黒色を使用します。

  5. バーのサイズとそのラベル(guilabel:`Size of bar`の ‘30 degrees’)を設定します。

  6. Make sure the checkbox Enable scale bar checkbox is checked
  7. checkbox :guilabel:`Automatically snap to round number on resize`オプションで、キャンバスサイズが変更された時に、切りの良い数字にスナップされるように選択することができます。

  8. **[OK]**をクリックします。

ちなみに

Settings of Decorations

.qgs プロジェクトを保存する際、方位記号、スケールバーと著作権ラベルに加えた変更はそのプロジェクトに保存され、次回プロジェクトをロードした際に復元されます。

アノテーションツール

The mActionTextAnnotation Text Annotation tools in the attribute toolbar provides the possibility to place formatted text in a balloon on the QGIS map canvas. Use the Text Annotation tool and click into the map canvas.

Figure annotation 1:

../../../_images/annotation.png

Annotation text dialog nix

Double click on the item opens a dialog with various options. There is the text editor to enter the formatted text and other item settings. E.g. there is the choice of having the item placed on a map position (displayed by a marker symbol) or to have the item on a screen position (not related to the map). The item can be moved by map position (drag the map marker) or by moving only the balloon. The icons are part of GIS theme, and are used by default in the other themes too.

The mActionAnnotation Move Annotation tool allows to move the annotation on the map canvas.

注記の書式設定

Additionally you can also create your own annotation forms. The mActionFormAnnotation Form Annotation tool is useful to display attributes of a vector layer in a customized qt designer form (see figure_custom_annotation). It is similar to the designer forms for the Identify features tool, but displayed in an annotation item. Also see QGIS blog http://blog.qgis.org/node/143 for more information.

Figure annotation 2:

../../../_images/custom_annotation.png

Customized qt designer annotation form nix

ノート

If you press Ctrl+T while an Annotation tool is active (move annotation, text annotation, form annotation), the visibility states of the items are inverted.

空間ブックマーク

空間ブックマークを使用すると地理的な場所を”ブックマーク”し、あとでその位置に戻ることができます。

ブックマークの作成

ブックマークを作るには:

  1. 関心のある領域にズームまたはパンします。

  2. Select the menu option View ‣ New Bookmark or press Ctrl-B.
  3. ブックマークを説明する名称(255文字まで)を入力します。

  4. Press Enter to add the bookmark or [Delete] to remove the bookmark.

同じ名称で複数のブックマークを所有できることにご注意ください。

ブックマークの操作

To use or manage bookmarks, select the menu option View ‣ Show Bookmarks. The Geospatial Bookmarks dialog allows you to zoom to or delete a bookmark. You can not edit the bookmark name or coordinates.

ブックマークへのズーム

From the Geospatial Bookmarks dialog, select the desired bookmark by clicking on it, then click [Zoom To]. You can also zoom to a bookmark by double-clicking on it.

ブックマークの削除

ブックマークを削除するには`地理空間ブックマーク`ダイアログにてそれを選択し、**[削除]**をクリックします。選択を確定するには **[はい]**をクリックし、削除をキャンセルするには **[いいえ]**をクリックします。

プロジェクトの入れ子

If you want to embed content from other project files into your project you can choose Layer ‣ Embed Layers and Groups.

埋め込みレイヤ

次のダイアログで、他のプロジェクトのレイヤを埋め込むことができます。

  1. Press browsebutton to look for another project from the Alaska dataset.
  2. プロジェクトファイルのgrasslandを選択します。あなたはプロジェクトの中身を表示することができます。(see figure_embed_dialog_を参照してください)

  3. Press Ctrl and klick on the layers grassland and regions. The layers are embedded in the map legend and the map view now.

Figure Nesting 1:

../../../_images/embed_dialog.png

Select layers and groups to embed nix

埋め込まれている間が編集できる間は、スタイルやラベリングのようなプロパティは変更することができません。

Removing embedded layers

Right-click on the embedded layer and choose mActionRemoveLayer Remove .