13.1. Abriendo Datos

Como parte de un ecosistema de software de código abierto, QGIS se basa en diferentes bibliotecas que, combinadas con sus propios proveedores, ofrecen capacidades para leer y, a menudo, escribir muchos formatos:

  • Los formatos de datos vectoriales incluyen GeoPackage, GML, GeoJSON, GPX, KML, valores separados por comas, formatos ESRI (Shapefile, Geodatabase …), formatos de archivo MapInfo y MicroStation, AutoCAD DWG / DXF, GRASS y muchos más … Leer el completo lista de formatos vectoriales compatibles.

  • Los formatos de datos ráster incluyen GeoTIFF, JPEG, ASCII Gridded XYZ, MBTiles, R o rásteres Idrisi, GDAL Virtual, SRTM, Sentinel Data, ERDAS IMAGINE, ArcInfo Binary Grid, ArcInfo ASCII Grid y muchos más… Lea la lista completa de formatos ráster compatibles.

  • Los formatos de base de datos incluyen PostgreSQL/PostGIS, SQLite/SpatiaLite, Oracle, DB2 o MSSQL Spatial, MySQL …

  • Los servicios de datos y mapas web (WM (T) S, WFS, WCS, CSW, mosaicos XYZ, servicios ArcGIS, …) también son manejados por proveedores de QGIS. Ver Trabajando con protocolos OGC / ISO para obtener más información sobre algunos de estos.

  • Puede leer archivos compatibles de carpetas archivadas y utilizar formatos nativos de QGIS como archivos QML (QML: el formato de archivo de estilo QGIS) y capas virtuales y de memoria.

Más de 80 formatos vectoriales y 140 ráster son compatibles con GDAL y proveedores nativos de QGIS.

Nota

No todos los formatos enumerados pueden funcionar en QGIS por varias razones. Por ejemplo, algunos requieren bibliotecas propietarias externas, o es posible que la instalación GDAL/OGR de su sistema operativo no se haya creado para admitir el formato que desea utilizar. Para ver la lista de formatos disponibles, ejecute la línea de comando ogrinfo --formats (para vectorial) y gdalinfo --formats (para ráster), o marque la Configuración -> Opciones -> Menú GDAL en QGIS.

En QGIS, dependiendo del formato de datos, existen diferentes herramientas para abrir un conjunto de datos, principalmente disponibles en el menú Capa -> Agregar capa -> o desde la barra de herramientas :guilabel: Administrador de Capas (habilitada a través de Ver -> Menú de barras de herramientas). Sin embargo, todas estas herramientas apuntan a un diálogo único, el diálogo Administrador de Fuentes de Datos, que puede abrir con el botón dataSourceManager Abrir Administrador de Fuentes de Datos, disponible en Barra de Herramientas del Administrador de las Fuentes de Datos, o presionando Ctrl + L. El cuadro de diálogo Administrador de Fuentes de Datos (Figura 13.1) ofrece una interfaz unificada para abrir datos vectoriales o basados en archivos ráster, así como bases de datos o servicios web compatibles con QGIS. Puede establecerse modal o no con el checkbox Diálogo del administrador de fuente de datos no modal en el menú :menuselection:` Configuración -> Opciones -> General`.

../../../_images/datasource_manager.png

Figura 13.1 Cuadro de diálogo Administrador de fuente de datos de QGIS

Además de este punto de entrada principal, también tiene el complemento dbManager Administrador de BBDD que ofrece capacidades avanzadas para analizar y manipular bases de datos conectadas. Puede encontrar más información sobre las capacidades de Administrador de BBDD en Complemento de Administración de BBDD.

Hay muchas otras herramientas, complementos nativos o de terceros, que lo ayudan a abrir varios formatos de datos.

Este capítulo describirá solo las herramientas proporcionadas por defecto en QGIS para cargar datos. Se centrará principalmente en el cuadro de diálogo Administrador de fuentes de datos pero más que describir cada pestaña, también explorará las herramientas basadas en el proveedor de datos o las especificidades del formato.

13.1.1. El panel Navegador

El Navegador es una de las principales formas de agregar datos a los proyectos de forma rápida y sencilla. Está disponible como:

  • una pestaña Administrador de fuentes de datos, habilitada presionando el botón dataSourceManager Abrir Administrador de fuentes de datos (Ctrl+L);

  • como panel QGIS puede abrir desde el menú: menuselection: Ver -> Paneles (o kde :menuselection:` Configuración -> Paneles`) o presionando Ctrl+2.

En ambos casos, el Navegador le ayuda a navegar en su sistema de archivos y administrar geodatos, independientemente del tipo de capa (raster, vector, tabla) o el formato de la fuente de datos (archivos sin formato o comprimidos, bases de datos, servicios web) .

13.1.1.1. Explorando la interfaz

En la parte superior del panel navegador, encontrará algunos botones que pueden ayudarle a:

  • addLayer Añadir capas seleccionadas: también puede agregar datos al lienzo del mapa seleccionando Agregar capa(s) seleccionadas en el menú contextual de la capa;

  • refresh Actualizar el árbol de navegador;

  • filterMap Explorador de Filtros para buscar datos específicos. Ingrese una palabra de búsqueda o un comodín y el navegador filtrará el árbol para mostrar solo las rutas a las tablas, nombres de archivo o carpetas de la base de datos que coincidan; no se mostrarán otros datos o carpetas. Vea el ejemplo del Panel del navegador (2) en Figura 13.2. La comparación puede distinguir entre mayúsculas y minúsculas o no. También se puede configurar para:

    • Normal: mostrar elementos que contienen el texto buscado

    • Wildcard(s): afine la búsqueda usando los caracteres ? y/o * para especificar la posición del texto de búsqueda

    • Expresión regular

  • collapseTree Colapsar Todo el árbol entero;

  • metadata Habilitar/deshabilitar el widget de propiedades: cuando se activa, se agrega un nuevo widget en la parte inferior del panel que muestra, si corresponde, los metadatos del elemento seleccionado.

Las entradas en el panel Navegador están organizados jerárquicamente, y hay varias entradas de nivel superior:

  1. Favorites where you can place shortcuts to often used locations

  2. Spatial Bookmarks where you can store often used map extents (see Marcadores espaciales)

  3. Project Home: para un acceso rápido a la carpeta en la que se almacenan (la mayoría de) los datos relacionados con su proyecto. El valor predeterminado es el directorio donde reside el archivo de su proyecto.

  4. Home directorio en el sistema de archivos y el directorio raíz del sistema de archivos.

  5. Unidades de red o locales conectadas

  6. Luego viene una serie de tipos de contenedores / bases de datos y protocolos de servicio, según su plataforma y bibliotecas subyacentes:

    • geoPackage GeoPackage

    • spatialite SpatiaLite

    • postgis PostGIS

    • mssql MSSQL

    • oracle Oracle

    • db2 DB2

    • wms WMS/WMTS

    • vectorTileLayer Teselas Vectoriales

    • xyz Teselas XYZ

    • wcs WCS

    • wfs WFS/OGC API-Objetos

    • ows OWS

    • ams ArcGIS Map Service

    • afs ArcGIS Feature Service

    • geonode GeoNode

13.1.1.2. Interactuar con los elementos del navegador

El navegador admite arrastrar y soltar dentro del navegador, desde el navegador al lienzo y el panel Capas, y desde el panel Capas a contenedores de capas (por ejemplo, GeoPackage) en el navegador.

Los elementos del archivo de proyecto dentro del navegador se pueden expandir, mostrando el árbol de capas completo (incluidos los grupos) contenido dentro de ese proyecto. Los elementos del proyecto se tratan de la misma manera que cualquier otro elemento en el navegador, por lo que se pueden arrastrar y soltar dentro del navegador (por ejemplo, para copiar un elemento de capa a un archivo de geopaquete) o agregar al proyecto actual a través de arrastrar y soltar o doble hacer clic.

El menú contextual de un elemento en el panel Navegador se abre haciendo clic derecho sobre él.

Para las entradas del directorio del sistema de archivos, el menú contextual ofrece lo siguiente:

  • Nuevo ► para crear en la entrada seleccionada una:

    • Directorio…

    • GeoPackage…

    • ArchivoShape…

  • Agregar como un favorito: las carpetas favoritas pueden ser renombradas (Renombrar favoritos…) o borradas (Borrar Favorito) en cualquier momento.

  • Ocultar del Navegador: las carpetas ocultas pueden ser conmutadas a visibles en la configuración Configuración ► Opciones ► Fuenntes de Datos ► Ocultar rutas de explorador

  • Escanear rápido este directorio

  • Abrir directorio

  • Abrir en Terminal

  • Propiedades…

  • Propiedades de directorio…

Para las entradas de hoja que pueden actuar como capas en el proyecto, el menú contextual tendrá entradas de apoyo. Por ejemplo, para fuentes de datos vectoriales, ráster y de malla que no son de base de datos, no basadas en servicios:

  • Borrar archivo «<name of file>»…

  • Exportar Capa –> a archivo…

  • Añadir capa a proyecto

  • Propiedades de capa

  • Propiedades de archivo

En la entrada propiedades de capa, encontrará (similar a lo que encontrará en las propiedades de capa vectorial y ráster una vez agregadas las capas al proyecto):

  • Metadatos para la capa. Grupos de metadatos: :guilabel:ʻInformación del proveedor` (si es posible, Ruta será un hipervínculo a la fuente), Identificación, Extensión, Acceso , Campos (para capas vectoriales), Bandas (para capas ráster), Contactos, Enlaces (para capas vectoriales), Referencias (para capas ráster), Historial.

  • Un panel Vista previa

  • La tabla de atributos para fuentes vectoriales (en el panel Atributos).

Para agregar una capa al proyecto usando Navegador:

  1. Habilite Navegador como se describe arriba. Se muestra un árbol del navegador con su sistema de archivos, bases de datos y servicios web. Es posible que deba conectar bases de datos y servicios web antes de que aparezcan (consulte las secciones dedicadas).

  2. Encuentre la capa en la lista.

  3. Utilice el menú contextual, haga doble clic en su nombre o arrástrelo y suéltelo en el lienzo del mapa. Su capa será añadida ahora al panel de Capas y se puede ver en el lienzo del mapa.

    Truco

    Abra un proyecto QGIS directamente desde el navegador

    También puede abrir un proyecto QGIS directamente desde el panel del navegador haciendo doble clic en su nombre o arrastrando y soltando en el lienzo del mapa.

Una vez que se carga un archivo, puede acercarlo usando las herramientas de navegación del mapa. Para cambiar el estilo de una capa, abra el cuadro de diálogo Propiedades de la capa haciendo doble clic en el nombre de la capa o haciendo clic derecho en el nombre en la leyenda y eligiendo Propiedades en el menú contextual. Consulte la sección Propiedades de simbología para obtener más información sobre cómo configurar la simbología para las capas vectoriales.

Hacer clic con el botón derecho en un elemento del árbol del navegador le ayuda a:

  • para un archivo o una tabla, muestre sus metadatos o ábralo en su proyecto. Las tablas incluso se pueden renombrar, eliminar o truncar.

  • para una carpeta, márquela en sus favoritos u ocúltela del árbol del navegador. Las carpetas ocultas se pueden administrar desde la pestaña Configuración -> Opciones -> Origen de datos.

  • administre sus marcadores espaciales: Los marcadores se pueden crear, exportar e importar como archivos XML.

  • crear una conexión a una base de datos o un servicio web.

  • actualizar, renombrar o eliminar un esquema.

También puede importar archivos a bases de datos o copiar tablas de un esquema / base de datos a otro con solo arrastrar y soltar. Hay un segundo panel de navegador disponible para evitar desplazamientos largos mientras se arrastra. Simplemente seleccione el archivo y arrastre y suelte de un panel al otro.

../../../_images/browser_panels.png

Figura 13.2 Paneles del navegador QGIS uno al lado del otro

Truco

Agregar capas a QGIS simplemente arrastrando y soltando desde el navegador de archivos de su sistema operativo

También puede agregar archivos al proyecto arrastrándolos y soltándolos desde el explorador de archivos de su sistema operativo en: guilabel: Layers Panel o el lienzo del mapa.

13.1.2. El gestor de Base de Datos

El complemento Administrador de BBDD es otra herramienta para integrar y administrar formatos de bases de datos espaciales compatibles con QGIS (PostGIS, SpatiaLite, GeoPackage, Oracle Spatial, MSSQL, DB2, capas virtuales). Se puede activar desde Complementos -> Administrar e instalar complementos ….

El Complemento dbManager Administrador de BBDD proporciona varias características:

  • conectarse a bases de datos y mostrar su estructura y contenido

  • previsualizar tablas de bases de datos

  • agregue capas al lienzo del mapa, ya sea haciendo doble clic o arrastrando y soltando.

  • agregar capas a una base de datos desde el navegador QGIS o desde otra base de datos

  • crear consultas SQL y agregar su salida al lienzo del mapa

  • crear capas virtuales

Encontrará más información sobre las capacidades de DB Manager en Complemento de Administración de BBDD.

../../../_images/db_manager.png

Figura 13.3 Diálogo del complemento administrador de BBDD

13.1.3. Herramientas de carga basadas en proveedores

Además del Panel del navegador y el Administrador de base de datos, las principales herramientas proporcionadas por QGIS para agregar capas, también encontrará herramientas que son específicas para los proveedores de datos.

Nota

Algunos complementos externos también proporcionan herramientas para abrir archivos de formato específico en QGIS.

13.1.3.1. Cargando una capa desde archivo

Para cargar una capa desde un archivo:

  1. Abra la pestaña de tipo de capa en el: guilabel: cuadro de diálogo Administrador de fuentes de datos, es decir, haga clic en el botón dataSourceManager Abrir Administrador de fuente de datos (o presione Ctrl + L) y habilita la pestaña de destino o:

    • para datos vectoriales (como capas GML, ESRI Shapefile, Mapinfo y DXF): presione Ctrl + Shift + V, seleccione la Opción de menú :menuselection:` Capa -> Agregar capa -> ` addOgrLayer Agregar capa vectorial» o haga clic en el Botón de la barra de herramientas |addOgrLayer| :sup:`Agregar capa vectorial.

      ../../../_images/addvectorlayerdialog.png

      Figura 13.4 Diálogo de Añadir capa vectorial

    • para datos ráster (como capas GeoTiff, MBTiles, GRIdded Binary y DWG): presione Ctrl+Shift+R, seleccione la opción de menú :menuselection:` Capa –> agregar capa –> ` addRasterLayer Agregar capa ráster o haga clic en el botón de barra de herramientas addRasterLayer Agregar capa ráster.

      ../../../_images/addrasterlayerdialog.png

      Figura 13.5 Diálogo para Añadir capa ráster

  2. Marque tipo de fuente radioButtonOn Archivo

  3. Click en el botón Navegador

  4. Navegue por el sistema de archivos y cargue una fuente de datos compatible. Se puede cargar más de una capa al mismo tiempo manteniendo presionada la tecla Ctrl y haciendo clic en varios elementos en el cuadro de diálogo o manteniendo presionada la tecla Shift para seleccionar un rango de elementos haciendo clic en los primeros y últimos elementos de la gama. Solo los formatos que han sido bien probados aparecen en el filtro de formatos. Se pueden cargar otros formatos seleccionando «Todos los archivos» (el elemento superior en el menú desplegable).

  5. Presione Abrir para abrir el archivo seleccionado en el diálogo Administrador de fuentes de datos

    ../../../_images/openoptionsvectorlayer.png

    Figura 13.6 Cargar un archivo Shape con opciones de apertura

  6. Presiona Agregar para cargar el archivo en QGIS y mostrarlo en el visor de mapa. Figura 13.7 muestra QGIS tras cargar el archivo alaska.shp.

    ../../../_images/shapefileloaded.png

    Figura 13.7 QGIS con archivo shape de Alaska cargado

Nota

Para cargar archivos vectoriales, el controlador GDAL ofrece definir acciones abiertas. Estos se mostrarán cuando se seleccione el archivo vectorial. Las opciones se describen en detalle en https://gdal.org/drivers/vector/ .

Nota

Debido a que algunos formatos como MapInfo (p. Ej. .tab) o Autocad (.dxf) permiten mezclar diferentes tipos de geometría en un solo archivo, al cargar dichos conjuntos de datos se abre un diálogo para seleccionar geometrías para usar en para tener una geometría por capa.

Las pestañas addOgrLayer Añadir capa vectorial y addRasterLayer Añadir capa ráster permitir la carga de capas de tipos de fuente distintos Archivo:

  • Puede cargar formatos vectoriales específicos como Cobertura binaria de ArcInfo, Reino Unido. Formato de transferencia nacional, así como el formato TIGER sin procesar de la Oficina del censo de EE. UU. o OpenfileGDB. Para hacerlo, seleccione radioButtonOn Directorio como :guilabel:` Tipo de fuente`. En este caso, se puede seleccionar un directorio en el diálogo después de presionar Examinar.

  • Con el tipo de fuente radioButtonOn Base de datos puede seleccionar una conexión de base de datos existente o crear una para el tipo de base de datos seleccionado. Algunos tipos de bases de datos posibles son ODBC, Esri Personal Geodatabase, MSSQL así como PostgreSQL o MySQL.

    Al presionar el botón Nuevo se abre el Cree una nueva conexión a la base de datos OGR cuyos parámetros se encuentran entre los que puede encontrar en Crear una conexión almacenada. Presionar Abrir le permite seleccionar de las tablas disponibles, por ejemplo, bases de datos habilitadas para PostGIS.

  • El tipo de fuente radioButtonOn Protocolo: HTTP(S), cloud, etc. abre datos almacenados localmente o en la red, ya sea de acceso público o en depósitos privados de servicios comerciales de almacenamiento en la nube. Los tipos de protocolos admitidos son:

    • HTTP/HTTPS/FTP, con URI y, si es necesario, una autenticación.

    • Almacenamiento en la nube como AWS S3, Google Cloud Storage, Microsoft Azure Blob, Alibaba OSS Cloud, Open Stack Swift Storage. Necesita rellenar en Cubo o contenedor y la Clave de Objeto.

    • servicio compatible con OGC WFS 3 (todavía experimental), utilizando el formato GeoJSON o GEOJSON - Newline Delimited o basado en la base de datos CouchDB. Un URI es obligatorio, con autenticación opcional .

    • Para todos los tipos de fuentes vectoriales es posible definir la Codificación o usar la configuración Automática ►.

13.1.3.2. Cargando una capa de malla

Una malla es una cuadrícula no estructurada generalmente con componentes temporales y de otro tipo. El componente espacial contiene una colección de vértices, aristas y caras en el espacio 2D o 3D. Más información sobre capas de malla en Trabajando con Malla de Datos.

Para añadir una malla a QGIS:

  1. Abra el diálogo Administrador de Fuente de datos , ya sea seleccionándolo desde el menú Capa -> o haciendo clic en el botón dataSourceManager Abrir Administrador de fuentes de datos.

  2. Habilite la pestaña addMeshLayer Malla en el panel izquierdo

  3. Presione el botón Navegador para seleccionar el archivo. Varios formatos son soportados.

  4. Seleccione la capa y presione Agregar. La capa erá añadida usando el renderizado de malla nativo.

../../../_images/mesh_datasource_manager.png

Figura 13.8 Pestaña malla en el Administrador de fuente de datos

13.1.3.3. Importando un archivo de texto delimitado

Archivos de texto delimitados (p.ej. .txt, .csv, .dat, .wkt) se puede cargar utilizando las herramientas descritas anteriormente. De esta forma, aparecerán como tablas simples. A veces, los archivos de texto delimitados pueden contener coordenadas/geometrías que podría querer visualizar. Esto es para lo que está diseñado addDelimitedTextLayer Añadir capa de texto delimitado.

  1. Click en el icono dataSourceManager Abrir Administrador de Fuentes de Datos para abrir el diálogo Administrador de fuente de datos

  2. Habilite la pestaña addDelimitedTextLayer Texto Delimitado

  3. Seleccione el archivo de texto delimitado a importar (p.ej., qgis_sample_data/csv/elevp.csv) clickando en el botón Navegador.

  4. En el campo nombre de capa, proporcione el nombre a usar para la capa en el proyecto (p,ej. Elevation).

  5. Configure los ajustes para conocer tu conjunto de datos y necesidades, como se eplica abajo.

../../../_images/delimited_text_dialog.png

Figura 13.9 Diálogo de Texto Delimitado

13.1.3.3.1. Formato de Archivo

Una vez que se selecciona el archivo, QGIS intenta analizar el archivo con el delimitador utilizado más recientemente, identificando campos y filas. Para permitir que QGIS analice correctamente el archivo, es importante seleccionar el delimitador correcto. Puede especificar un delimitador eligiendo entre:

  • radioButtonOnCSV (valores separados por comas) para usar un carácter coma.

  • radioButtonOffDelimitador de expresión regular e introduce texto en el campo Expresión. Por ejemplo, para cambiar el delimitador a tabulación, use \t (esto se usa en expresiones regulares para el carácter de tabulación).

  • radioButtonOffPersonalizar delimitadores, elegir entre algunos delimitadores predefinidos como comma, space, tab, semicolon, … .

13.1.3.3.2. Registros y campos

Algunas otras opciones convenientes pueden ser usadas para reconocimiento de datos:

  • Número de líneas de encabezado a descartar: conveniente cuando desea evitar las primeras líneas en el archivo en la importación, ya sea porque son líneas en blanco o con otro formato.

  • checkboxEl primer registro tiene nombres de campo: los valores en la primera línea se usan como nombres de campo, de lo contrario QGIS usa los nombres de campo field_1, field_2

  • checkboxDetectar tipos de campo: reconoce automáticamente el tipo de campo. Si no se marca, todos los atributos se tratan como campos de texto.

  • checkboxEl separador decimal es una coma: puede forzar que el separador decimal sea una coma.

  • checkboxRecortar campos: le permite recortar los espacios iniciales y finales de los campos.

  • checkbox:guilabel:Descartar campos vacíos`.

A medida que configura las propiedades del analizador, se actualiza una vista previa de datos de muestra en la parte inferior del cuadro de diálogo.

13.1.3.3.3. Definición de geometría

Una vez que se analiza el archivo, configure Definición de geometría

  • radioButtonOncoordenadas de punto y proporcione el campo X, campo Y, campo Z (para datos de 3 dimensiones) y campo M (para la dimensión de medición) si la capa es del tipo de geometría puntual y contiene dichos campos. Si las coordenadas están definidas como grados / minutos / segundos, active la casilla de verificación checkbox Coordenadas DMS. Proporcione el apropiado SRC de Geometría usando el widget setProjection Seleccionar SRC.

  • La opción radioButtonOnWell known text (WKT) si la información espacial se representa como WKT: seleccione el Campo de geometría que contiene la geometría de WKT y elija el apropiado Campo de geometría o deje que QGIS lo detecte automáticamente. Proporcione el SRC de Geometría apropiado usando el widget setProjection Seleccionar SRC.

  • Si el archivo contiene datos no espaciales, active radioButtonOn : guilabel:Sin geometría (solo tabla de atributos) y se cargará como una tabla ordinaria.

13.1.3.3.4. Configuración de capa

Adicionálmente, puede habilitar:

  • checkboxUsar índice espacial para mejorar el rendimiento de visualización y selección espacial de entidades.

  • checkbox:guilabel:»Utilizar índice de subconjunto» para mejorar el rendimiento de filtros de subconjunto (cuando se define en las propiedades de la capa).

  • checkboxVer archivo para observar cambios en el archivo por otras aplicaciones mientras QGIS se está ejecutando.

Al final, haga clic en: guilabel: ʻAdd` para agregar la capa al mapa. En nuestro ejemplo, una capa de puntos llamada Elevación se agrega al proyecto y se comporta como cualquier otra capa de mapa en QGIS. Esta capa es el resultado de una consulta en el archivo fuente .csv (por lo tanto, vinculado a él) y requeriría ser guardado para obtener una capa espacial en el disco.

13.1.3.4. Importando un archivo DXF o DWG

Los archivos DXF y DWG se pueden agregar a QGIS simplemente arrastrando y soltando desde el Panel del navegador. Se le pedirá que seleccione las subcapas que le gustaría agregar al proyecto. Las capas se agregan con propiedades de estilo aleatorias.

Nota

Para archivos DXF que contienen varios tipos de geometría (punto, línea y / o polígono), el nombre de las capas se generará como <filename.dxf> entidades <geometry type>.

Para mantener la estructura del archivo dxf/dwg y su simbología en QGIS, es posible que desee utilizar la dedicada Proyecto -> Importar / Exportar -> Importar capas desde DWG / DXF … :

  1. Importa elementos desde el archivo de dibujo en la ase de datos de GeoPackage.

  2. añadir elementos importados al proyecto..

En el diálogo Importar DWG/DXF, para importar los contenidos del archivo de dibujo:

  1. Introduce la ubicación del Target package, p.ej. el nuevo archivo GeoPackage que almacenará los datos. Si se proporciona un archivo existente, se sobrescribirá.

  2. Especifique el sistema de referencia de coordenadas de los datos en el archivo de dibujo.

  3. Marque checkbox Expand block references para importar los bloques en el archivo de dibujo como elementos normales.

  4. Marque checkbox Usar curvas para promover las capas importadas a un tipo de geoemtría curvada.

  5. Use el botón Importar para seleccionar el archivo DWG / DXF a usar (uno por geopaquete). La base de datos de GeoPackage se completará automáticamente con el contenido del archivo de dibujo. Dependiendo del tamaño del archivo, esto puede llevar algún tiempo.

Despues de que los datos .dwg or .dxf se ha importado a la base de datos de GeoPackage, el marco de la mitad inferior del cuadro de diálogo se rellena con la lista de capas del archivo importado. Allí puede seleccionar qué capas agregar al proyecto QGIS:

  1. Arriba, establezca un Nombre de grupo para agrupar los archivos de dibujo en el proyecto.

  2. Marque las capas para mostrar: cada capa seleccionada se agrega a un grupo ad hoc que contiene capas vectoriales para las características de punto, línea, etiqueta y área de la capa de dibujo. El estilo de las capas se parecerá al aspecto que tenían originalmente en *CAD.

  3. Elige si la capa debe ser visible al abrirla.

  4. Marcando la opción checkbox Mezclar capas ubica todas las capas en un único grupo.

  5. Presione Aceptar para abrir las capas en QGIS.

../../../_images/dwg_dxf_import_dialog.png

Figura 13.10 Diálogo de importación para archivos DWG/DXF

13.1.3.5. Importar Vectoriales de OpenStreetMap

El proyecto OpenStreetMap es popular porque en muchos países no se encuentran disponibles geodatos gratuitos como mapas de carreteras digitales. El objetivo del proyecto OSM es crear un mapa editable gratuito del mundo a partir de datos GPS, fotografías aéreas y conocimiento local. Para respaldar este objetivo, QGIS brinda soporte para datos OSM.

Usando el Panel de Navegador, puede cargar un archivo .osm en el lienzo del mapa, en cuyo caso aparecerá un diálogo para seleccionar subcapas según el tipo de geometría. Las capas cargadas contendrán todos los datos de ese tipo de geometría en el archivo .osm, y mantendrán la estructura de datos del archivo osm.

13.1.3.6. Capas SpatiaLite

addSpatiaLiteLayer La primera vez que carga datos de una base de datos SpatiaLite, comience por:

  • clickando en el botón de la barra de herramientas addSpatiaLiteLayer Añadir capa SpatiaLite

  • seleccionando la opción addSpatiaLiteLayer Añadir capa SpatiaLite.. del menú Capa ► Añadir capa

  • o pulsando Ctrl+Shift+L

Esto abrirá una ventana que le permitirá conectarse a una base de datos SpatiaLite ya conocida por QGIS (que elija en el menú desplegable) o definir una nueva conexión a una nueva base de datos. Para definir una nueva conexión, haga clic en Nuevo y use el navegador de archivos para apuntar a su base de datos SpatiaLite, que es un archivo con una extensión .sqlite.

QGIS también soporta vistas editables en SpatiaLite.

13.1.3.7. GPS

La carga de datos GPS en QGIS se puede realizar utilizando el complemento principal Herramientas GPS. Las instrucciones se encuentran en la sección Plugin de GPS.

13.1.3.8. GRASS

El trabajo con datos vectoriales de GRASS se describe en la sección Integracion GRASS SIG.

13.1.4. Formato personalizados QGIS

QGIS propone dos formatos personalizados:

13.1.5. QLR - Archivo de Definición de Capa QGIS

Las definiciones de capa se pueden guardar como Layer Definition File (QLR - .qlr) usando :menuselection:`Exportar -> Guardar como archivo de definición de capa…`en el menú contextual de la capa.

El formato QLR hace posible compartir capas QGIS «completas» con otros usuarios de QGIS. Los archivos QLR contienen enlaces a las fuentes de datos y toda la información de estilo QGIS necesaria para diseñar la capa.

Los archivos QLR se muestran en el Panel del navegador y se pueden usar para agregar capas (con sus estilos guardados) al Panel de capas. También puede arrastrar y soltar archivos QLR desde el administrador de archivos del sistema al lienzo del mapa.

13.1.6. Conectar con el servicios web

Con QGIS puede acceder a diferentes tipos de servicios web OGC (WM(T)S, WFS(-T), WCS, CSW,…). Gracias a QGIS Server, también puede publicar dichos servicios. Guía/Manual de Servidor QGIS contiene descripciones de estas capacidades.

13.1.6.1. Usando de Servicios de Teselas Vectoriales

Los servicios de Teselas Vectoriales se pueden encontrar en la entrada de nivel superior Teselas Vectoriales en Navegador. Puede agregar un servicio abriendo el menú contextual con un clic derecho y eligiendo Nueva conexión Genérica…. Configuras un servicio agregando un Nombre y un URL. Servicio de Teselas Vectoriales debe proporcionar mosaicos en formato .pbf. El diálogo proporciona dos menús para definir la checkbox Min. Nivel de zoom y el checkbox Máx. Nivel de zoom. Los mosaicos vectoriales tienen una estructura piramidal. Al usar estas opciones, tiene la oportunidad de generar capas individualmente a partir de la pirámide de mosaicos. Estas capas luego se usarán para renderizar el Vector Tile en QGIS. Para la proyección de Mercator (utilizado por OpenStreetMap Vector Tiles) El nivel de zoom 0 representa el mundo entero a una escala de 1: 500.000.000. El nivel de zoom 14 representa la escala 1: 35.000. Figura 13.13 muestra el diálogo con la configuración del servicio MapTiler planet Vector Tiles.

../../../_images/vector_tiles_maptilerplanet.png

Figura 13.13 Teselas Vectoriales - configuración Maptiler Planet

Por usar Nueva conexión del servicio de teselas vectoriales de ArcGIS… puede conectarse a ArcGIS Vector Tile Services.

13.1.6.2. Usando servicios de Teselas XYZ

Los servicios de XYZ Tile se pueden encontrar en la entrada de nivel superior Teselas XYZ en Explorador. De forma predeterminada, el servicio de Teselas XYZ de OpenStreetMap está configurado. Puede agregar otros servicios que utilizan el protocolo Teselas XYZ eligiendo Nueva Conexión en el menú contextual de XYZ Tiles (haga click con el botón derecho para abrir). Figura 13.14 muestra el diálogo con la configuración del servicio de Teselas XYZ de OpenStreetMap.

../../../_images/xyz_tiles_dialog_osm.png

Figura 13.14 XYZ Teselas - Configuración de OpenStreetMap

Las configuraciones se pueden guardar ( Guardar conexiones) en XML y cargar (Cargar conexiones) a través del menú contextual. Se admite la configuración de autenticación. El archivo XML para OpenStreetMap tiene este aspecto:

<!DOCTYPE connections>
<qgsXYZTilesConnections version="1.0">
  <xyztiles url="https://tile.openstreetmap.org/{z}/{x}/{y}.png"
   zmin="0" zmax="19" password="" name="OpenStreetMap" username=""
   authcfg="" referer=""/>
</qgsXYZTilesConnections>

Una vez que se establece una conexión a un servicio de teselas XYZ, haga clic derecho sobre la entrada para:

  • Editar… la configuración de la conexión XYZ

  • Eliminar la conexión

  • Exportar capa… ► a Archivo, guardándolo como un ráster

  • Añadir capa al proyecto: un doble clic también añade la capa

  • Vea Propiedades de la capa … y obtenga acceso a los metadatos y una vista previa de los datos proporcionados por el servicio. Hay más configuraciones disponibles cuando la capa se ha cargado en el proyecto.

Ejemplos de servicios de XYZ Teselas:

  • OpenStreetMap Monocromo: URL: http://tiles.wmflabs.org/bw-mapnik/{z}/{x}/{y}.png, Min. Zoom Level: 0, Max. Zoom Level: 19.

  • Google Maps: URL: https://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}, Min. Zoom Level: 0, Max. Zoom Level: 19.

  • Open Weather Mapa Temperatura: URL: http://tile.openweathermap.org/map/temp_new/{z}/{x}/{y}.png?appid={api_key} Min. Zoom Level: 0, Max. Zoom Level: 19.