13.1. Accedere ai dati

Facendo parte di un ecosistema Software Open Source QGIS è costruito su diverse librerie che, unitamente agli specifici provider, offrono la capacità di leggere e spesso scrivere molti formati:

  • I formati di dati vettoriali includono GeoPackage, GML, GeoJSON, GPX, KML, Comma Separated Values, formati ESRI (Shapefile, Geodatabase…), formati di file MapInfo e MicroStation, AutoCAD DWG/DXF, GRASS e molti altri… Leggi la lista completa dei formati vettoriali supportati <https://gdal.org/drivers/vector/index.html>`_.

  • I formati di dati raster includono GeoTIFF, JPEG, ASCII Gridded XYZ, MBTiles, R o Idrisi rasters, GDAL Virtual, SRTM, Sentinel Data, ERDAS IMAGINE, ArcInfo Binary Grid, ArcInfo ASCII Grid, e molti altri… Leggi la lista completa dei formati raster <https://gdal.org/drivers/raster/index.html> supportati.

  • I formati di database includono PostgreSQL/PostGIS, SQLite/SpatiaLite, Oracle, DB2 o MSSQL Spatial, MySQL …;

  • Anche i servizi web di mappe e dati (WM(T)S, WFS, WCS, CSW, tasselli XYZ, servizi ArcGIS, …) sono gestiti dai provider QGIS. Vedere Lavorare con i protocolli OGC / ISO per maggiori informazioni su alcuni di questi.

  • Puoi leggere i file supportati da cartelle archiviate e usare i formati nativi di QGIS come i file QML (QML - Il Formato FILE Stile QGIS) e i layer virtuali e in memoria.

Più di 80 formati vettoriali e 140 formati raster sono supportati da GDAL e dai provider nativi di QGIS.

Nota

Non tutti i formati elencati potrebbero funzionare in QGIS per varie ragioni. Per esempio, alcuni richiedono librerie proprietarie esterne, o l’installazione di GDAL/OGR del tuo sistema operativo potrebbe non essere stata sviluppata per supportare il formato che vuoi usare. Per vedere l’elenco dei formati disponibili, esegui la riga di comando ogrinfo --formats (per i vettori) e gdalinfo --formats (per i raster), o controlla il menu :menuselection: Impostazioni –> Opzioni –> GDAL in QGIS.

In QGIS, a seconda del formato dei dati, ci sono diversi strumenti per aprire un insieme di dati, principalmente disponibili nel menu Layer ► Aggiungi Layer ► o dalla barra degli strumenti Manage Layers (abilitata attraverso il menu Visualizza ► Barre degli strumenti). Comunque, tutti questi strumenti puntano ad un’unica finestra di dialogo, la finestra di Gestore fonti dati, che puoi aprire con il pulsante dataSourceManager Apri Gestore delle Sorgenti Dati, disponibile sulla Barra degli Strumenti per la Gestione delle Sorgenti Dati, o premendo Ctrl+L. La finestra di dialogo Data Source Manager (Fig. 13.1) offre un’interfaccia unificata per aprire dati vettoriali o raster basati su file, così come database o servizi web supportati da QGIS. Può essere impostata come modale o meno con la casella di controllo Finestra non modale di gestione delle sorgenti dati nel menu Impostazioni ► Opzioni ► Generale.

../../../_images/datasource_manager.png

Fig. 13.1 Finestra di dialogo QGIS Gestore delle sorgenti dati

Oltre a questo punto d’ingresso principale, hai anche il plugin dbManager DB Manager che offre funzionalità avanzate per analizzare e manipolare i database collegati. Maggiori informazioni sulle funzionalità di DB Manager possono essere trovate in Plugin DB Manager.

Ci sono molti altri strumenti, nativi o plugin di terze parti, che ti aiutano ad aprire vari formati di dati.

Questo capitolo descriverà solo gli strumenti forniti di default in QGIS per il caricamento dei dati. Si concentrerà principalmente sulla finestra di dialogo Data Source Manager ma più che descrivere ogni scheda, esplorerà anche gli strumenti basati sul fornitore di dati o sulle specificità del formato.

13.1.1. Il Pannello Browser

Il Browser è uno dei modi principali per aggiungere rapidamente e facilmente i tuoi dati ai progetti. È disponibile come:

  • una scheda Gestore della sorgente dati, abilitata premendo il pulsante dataSourceManager Apri gestore della sorgente dati (Ctrl+L);

  • come pannello QGIS che puoi aprire dal menu Visualizza ► Pannelli (o kde Impostazioni ► Pannelli) o premendo Ctrl+2.

In entrambi i casi, il Browser ti aiuta a navigare nel tuo file system e a gestire i geodati, indipendentemente dal tipo di layer (raster, vector, tabella), o dal formato della fonte dei dati (file semplici o compressi, database, servizi web).

13.1.1.1. Esplorare l’Interfaccia

Nella parte superiore del pannello Browser, trovi alcuni pulsanti che ti aiutano a:

  • addLayer Aggiungi layer selezionati: puoi anche aggiungere dati alla mappa selezionando Aggiungi layer selezionato(i) dal menu contestuale del layer;

  • refresh Aggiorna l’albero del browser;

  • filterMap Filtra Browser per cercare dati specifici. Inserisci una parola di ricerca o un carattere jolly e il browser filtrerà l’albero per mostrare solo i percorsi delle tabelle, dei nomi di file o delle cartelle del DB corrispondenti - altri dati o cartelle non saranno visualizzati. Vedi l’esempio di Browser Panel(2) in Fig. 13.2. Il confronto può essere sensibile alle maiuscole o meno. Può anche essere impostato a:

    • Normal: show items containing the search text

    • Wildcard(s): perfeziona la ricerca usando i caratteri ? e/o * per specificare la posizione del testo cercato

    • Espressione Regolare

  • collapseTree Racchiudi tutto collassa la struttura ad albero;

  • metadata :sup: Abilita/disabilita le proprietà del widget: quando è attivato, viene aggiunto un nuovo widget in fondo al pannello che mostra, se applicabile, i metadati per l’elemento selezionato.

Le voci nel pannello Browser sono organizzate gerarchicamente, e ci sono diverse voci di livello superiore:

  1. Preferiti dove puoi mettere collegamenti a percorsi usati spesso

  2. Segnalibri Spaziali dove puoi memorizzare destinazioni di mappe usate spesso (vedi Segnalibri Spaziali)

  3. Home del Progetto: per un rapido accesso alla cartella in cui (la maggior parte) dei dati relativi al tuo progetto sono memorizzati. Il valore predefinito è la cartella in cui risiede il file del tuo progetto.

  4. Home directory nel file system e la directory principale del file system.

  5. Unità locali o di rete collegate

  6. Poi viene una serie di tipologie di contenitori / database e protocolli di servizio, a seconda della piattaforma e delle librerie sottostanti:

    • geoPackage GeoPackage

    • spatialite SpatiaLite

    • postgis PostGIS

    • mssql MSSQL

    • oracle Oracle

    • db2 DB2

    • wms WMS/WMTS

    • vectorTileLayer Vector Tiles

    • xyz XYZ Tiles

    • wcs WCS

    • wfs WFS/OGC API-Features

    • ows OWS

    • ams ArcGIS Map Service

    • afs ArcGIS Feature Service

    • geonode GeoNode

13.1.1.2. Interagire con gli oggetti del Browser

Il browser supporta il trascinamento all’interno del browser, dal browser all’area di lavoro e al pannello Layer, e dal pannello Layer ai contenitori di layer (per esempio GeoPackage) nel browser.

Gli elementi dei file di progetto all’interno del browser possono essere espansi, mostrando l’intero albero dei layer (inclusi i gruppi) contenuti in quel progetto. Gli elementi del progetto sono trattati allo stesso modo di qualsiasi altro elemento nel browser, quindi possono essere trascinati e rilasciati all’interno del browser (per esempio per copiare un elemento del layer in un file geopackage) o aggiunti al progetto corrente attraverso il drag and drop o il doppio clic.

Il menu contestuale per un elemento nel pannello Browser si apre cliccandovi sopra con il tasto destro del mouse.

Per le voci delle cartelle del file system, il menu contestuale offre quanto segue:

  • New ► to create in the selected entry a:

    • Cartella…

    • GeoPackage…

    • ShapeFile…

  • Aggiungi ai Preferiti: le cartelle preferite possono essere rinominate (:guilabel: Rinomina Preferito…) o rimosse (Rimuovi Preferito) in qualsiasi momento.

  • Hide from Browser: hidden folders can be toggled to visible from the Settings ► Options ► Data Sources ► Hidden browser paths setting

  • Scansione Velocemente questa Cartella

  • Apri Cartella…

  • Apri nel Terminale…

  • Proprietà…

  • Proprietà Cartella…

Per le voci delle foglie che possono agire come layer nel progetto, il menu contestuale avrà voci di supporto. Per esempio, per fonti di dati vettoriali, raster e mesh non basati su database e non basati su servizi:

  • Elimina File «<name of file>»…

  • Esporta Layer –> Su File…

  • Aggiungi Layer al Progetto

  • Proprietà del Layer…

  • Proprietà File

Nella voce Proprietà del Layer…, troverai (simile a quello che troverai nelle proprietà dei layer vector e raster una volta che i layer sono stati aggiunti al progetto):

  • Metadata per il layer. Gruppi di metadati: Informazioni dalla Sorgente (se possibile, Percorso sarà un collegamento ipertestuale alla fonte), Identificazione, Estensione, Accesso, :guilabel: Campi (per i layer vettoriali), Bande (per layer raster), Contatti, :guilabel: Collegamenti (per layer vettoriali), Riferimenti (per layer raster), Storia.

  • Un pannello Anteprima

  • La tabella degli attributi per le fonti vettoriali (nel pannello :guilabel: Attributi).

Per aggiungere un layer al progetto usando il Browser:

  1. Attiva Browser come descritto sopra. Viene visualizzato una lista ad albero con il tuo file system, i database e i servizi web. Potrebbe essere necessario collegare i database e i servizi web prima di poterli visualizzare (vedi le sezioni dedicate).

  2. Cerca il layer nell’elenco.

  3. Usa il menu contestuale, fai doppio clic sul suo nome o trascinalo nella mappa map canvas. Il tuo layer è ora aggiunto al Layers panel e può essere visualizzato nell’area di disegno della mappa.

    Suggerimento

    Aprire un progetto QGIS direttamente dal browser

    Puoi anche aprire un progetto QGIS direttamente dal pannello del Browser facendo doppio clic sul suo nome o trascinandolo e rilasciandolo nell’area di disegno della mappa.

Una volta che un file è stato caricato, puoi zoomare intorno ad esso usando gli strumenti di navigazione della mappa. Per cambiare lo stile di un layer, apri la finestra di dialogo Proprietà del Layer facendo doppio clic sul nome del layer o facendo clic con il tasto destro del mouse sul nome nella legenda e scegliendo Proprietà dal menu contestuale. Vedi la sezione Proprietà Simbologia per maggiori informazioni sull’impostazione della simbologia per i layer vettoriali.

Fare clic con il tasto destro del mouse su un elemento nell’albero del browser ti aiuta a:

  • per un file o una tabella, visualizzare i suoi metadati o aprirlo nel tuo progetto. Le tabelle possono anche essere rinominate, cancellate o ritagliate.

  • per una cartella, metterla tra i preferiti o nasconderla dall’albero del browser. Le cartelle nascoste possono essere gestite dalla scheda Impostazioni ► Opzioni ► Sorgenti Dati.

  • gestire i tuoi segnalibri spaziali: i segnalibri possono essere creati, esportati e importati come file XML.

  • creare una connessione a un database o a un servizio web.

  • aggiornare, rinominare o eliminare uno schema.

Puoi anche importare file nei database o copiare tabelle da uno schema/database a un altro con un semplice drag-and-drop. C’è un secondo pannello del browser disponibile per evitare un lungo scorrimento durante il trascinamento. Basta selezionare il file e trascinare da un pannello all’altro.

../../../_images/browser_panels.png

Fig. 13.2 Pannelli QGIS Browser affiancati

Suggerimento

Aggiungi layer a QGIS con un semplice drag-and-drop dal visualizzatore file del tuo sistema operativo

Puoi anche aggiungere i file al progetto trascinandoli dal proprio visualizzatore di file del sistema operativo in uso al Panello Layer o all’area di visualizzazione mappa.

13.1.2. Il DB Manager

Il plugin DB Manager è un altro strumento per integrare e gestire i formati di database spaziali supportati da QGIS (PostGIS, SpatiaLite, GeoPackage, Oracle Spatial, MSSQL, DB2, Virtual layers). Può essere attivato dal menu Plugins ► Gestisci ed Installa Plugin….

Il Plugin dbManager DB Manager offre diverse funzionalità:

  • connettersi ai database e visualizzare la loro struttura e il loro contenuto

  • visualizzare in anteprima le tabelle dei database

  • aggiungere layer alla mappa, sia con un doppio clic o con il drag-and-drop.

  • aggiungere layer a un database dal Browser QGIS o da un altro database

  • creare query SQL e aggiungere il loro risultato alla mappa

  • creare virtual layers

Maggiori informazioni sulle funzionalità di DB Manager si trovano in Plugin DB Manager.

../../../_images/db_manager.png

Fig. 13.3 Finestra di dialogo DB Manager

13.1.3. Strumenti di caricamento per specifici provider di dati

Oltre al Pannello Browser e al DB Manager, i principali strumenti forniti da QGIS per aggiungere layer, troverai anche strumenti specifici per i provider di dati.

Nota

Alcuni external plugins forniscono anche strumenti per aprire file di formato specifico in QGIS.

13.1.3.1. Caricare un layer da un file

Per caricare un layer da un file:

  1. Apri la scheda del tipo di layer nella finestra di dialogo Data Source Manager, cioè clicca sul pulsante dataSourceManager OApri Gestore della Sorgente Dati (o premi Ctrl+L) e attiva la scheda di destinazione o:

    • per dati vettoriali (come GML, ESRI Shapefile, Mapinfo e layer DXF): premi Ctrl+Shift+V, seleziona l’opzione del menu Layer ► Aggiungi Layer ► addOgrLayer Aggiungi Layer Vettore… o clicca sul pulsante della barra degli strumenti addOgrLayer Aggiungi Layer Vettore.

      ../../../_images/addvectorlayerdialog.png

      Fig. 13.4 Finestra di dialogo aggiungi vettore

    • per i dati raster (come GeoTiff, MBTiles, GRIdded Binary e layer DWG): premi Ctrl+Shift+R, seleziona l’opzione del menu Layer ► Aggiungi Layer ► addRasterLayer Aggiungi Layer Raster… o clicca sul pulsante della barra degli strumenti addRasterLayer Aggiungi Layer Raster.

      ../../../_images/addrasterlayerdialog.png

      Fig. 13.5 Finestra di dialogo Aggiungi Layer Raster

  2. Seleziona radioButtonOn File tipo di sorgente

  3. Fai clic sul pulsante Sfoglia

  4. Naviga nel file system e carica un tipo di dati supportato. Più di un layer può essere caricato allo stesso tempo tenendo premuto il tasto Ctrl e cliccando su più elementi nella finestra di dialogo o tenendo premuto il tasto Shift per selezionare un intervallo di elementi cliccando sul primo e sull’ultimo elemento dell’intervallo. Solo i formati che sono stati ben testati appaiono nel filtro dei formati. Altri formati possono essere caricati selezionando Tutti i file (la voce in alto nel menu a tendina).

  5. Premi Apri per caricare il file selezionato nella finestra di dialogo Data Source Manager

    ../../../_images/openoptionsvectorlayer.png

    Fig. 13.6 Caricamento di uno Shapefile con le opzioni aperte

  6. Premi Aggiungi per caricare il file in QGIS e visualizzarlo nella vista mappa. Fig. 13.7 mostra QGIS dopo aver caricato il file alaska.shp.

    ../../../_images/shapefileloaded.png

    Fig. 13.7 QGIS con il caricamento dello Shapefile Alaska

Nota

Per caricare i file vettoriali, il driver GDAL offre la possibilità di definire le azioni di apertura. Queste saranno mostrate quando il file vettoriale è selezionato. Le opzioni sono descritte in dettaglio su https://gdal.org/drivers/vector/ .

Nota

Poiché alcuni formati come MapInfo (ad esempio, .tab) o Autocad (.dxf) permettono di mescolare diversi tipi di geometria in un unico file, caricando tali set di dati si apre una finestra di dialogo per selezionare le geometrie da usare in modo da avere una geometria per layer.

Le schede addOgrLayer Aggiungi Layer Vettore e addRasterLayer Aggiungi Layer Raster permettono il caricamento di layer da tipi di sorgente diversi da File:

  • Puoi caricare formati vettoriali specifici come ArcInfo Binary Coverage, UK. National Transfer Format, così come il formato grezzo TIGER del US Census Bureau o OpenfileGDB. Per farlo, seleziona radioButtonOn Cartella come Tipo Sorgente. In questo caso, una cartella può essere selezionata nella finestra di dialogo dopo aver premuto Sfoglia.

  • Con il tipo di sorgente radioButtonOn Database puoi selezionare una connessione al database esistente o crearne una al tipo di database selezionato. Alcuni tipi di database possibili sono ODBC, Esri Personal Geodatabase, MSSQL così come PostgreSQL o MySQL.

    Premendo il pulsante :guilabel: Nuovo si apre la finestra di dialogo Crea una Nuova Connessione Database OGR i cui parametri sono tra quelli che puoi trovare in Creazione della connessione. Premendo :guilabel: Apri si può scegliere tra le tabelle disponibili, per esempio dei database abilitati per PostGIS.

  • Il radioButtonOn Protocollo: HTTP(S), cloud, ecc. apre i dati memorizzati localmente o in rete, accessibili pubblicamente o in bucket privati di servizi commerciali di cloud storage. I tipi di protocollo supportati sono:

    • HTTP/HTTPS/FTP, con un URI e, se richiesto, un authentication.

    • Cloud storage come AWS S3, Google Cloud Storage, Microsoft Azure Blob, Alibaba OSS Cloud, Open Stack Swift Storage. Devi compilare la Bucket o contenitore e la Chiave oggetto.

    • servizio che supporta OGC WFS 3 (ancora sperimentale), usando il formato GeoJSON o GEOJSON - Newline Delimited o basato sul database CouchDB. È richiesto un URI, con opzionale authentication.

    • Per tutti i tipi di fonti dati vettoriali è possibile definire la Codifica o usare l’impostazione Automatico ►.

13.1.3.2. Caricare un layer mesh

Una mesh è una griglia non strutturata di solito con elementi temporali e altri elementi. La componente spaziale contiene una collezione di vertici, bordi e facce nello spazio 2D o 3D. Maggiori informazioni sui layer delle mesh in Lavorare con i dati Mesh.

Per aggiungere un layer mesh a QGIS:

  1. Apri la finestra di dialogo Data Source Manager, o selezionala dal menu Layer ► o cliccando il pulsante dataSourceManager Apri Gestore delle Sorgenti Dati.

  2. Abilita la scheda addMeshLayer Mesh nel pannello sinistro

  3. Premi il pulsante Sfoglia per selezionare il file. Various formats sono supportati.

  4. Seleziona il layer e premi Aggiungi. Il layer verrà aggiunto utilizzando la rappresentazione nativa della mesh.

../../../_images/mesh_datasource_manager.png

Fig. 13.8 Scheda Mesh in Data Source Manager

13.1.3.3. Importare file di testo delimitato

I file di testo delimitati (es. .txt, .csv, .dat, .wkt) possono essere caricati usando gli strumenti descritti sopra. In questo modo verranno visualizzati come semplici tabelle. A volte, i file di testo delimitati possono contenere coordinate / geometrie che potresti voler visualizzare. Questo è ciò per cui addDelimitedTextLayerAggiungi Layer Testo Delimitato è progettato.

  1. Fai clic sull’icona dataSourceManager Apri Gestore delle Sorgenti Dati per aprire la finestra di dialogo Data Source Manager

  2. Abilita la scheda addDelimitedTextLayer Testo Delimitato

  3. Seleziona il file di testo delimitato da importare (per esempio, qgis_sample_data/csv/elevp.csv) cliccando sul pulsante Sfoglia.

  4. Nel campo Nome Layer, fornire il nome da usare per il Layer nel progetto (ad esempio Elevation).

  5. Configura le impostazioni per conformare il tuo set di dati e le tue esigenze, come spiegato di seguito.

../../../_images/delimited_text_dialog.png

Fig. 13.9 Finestra di dialogo Testo Delimitato

13.1.3.3.1. Formattazione file

Una volta selezionato il file, QGIS tenta di analizzare il file con l’ultimo delimitatore usato, identificando campi e righe. Per permettere a QGIS di analizzare correttamente il file, è importante selezionare il delimitatore giusto. Puoi specificare un delimitatore scegliendo tra:

  • radioButtonOnCSV (comma separated values) per usare il carattere virgola.

  • radioButtonOffDelimitatore espressione regolare e inserisci del testo nel campo Espressione. Per esempio, per cambiare il delimitatore in tabulazione, usa `t (questo è usato nelle espressioni regolari per il carattere tabulazione).

  • radioButtonOffDelimitatori personalizzati, scegliendo tra alcuni delimitatori predefiniti come Virgola, Spazio, tab`, Punto e Virgola, … .

13.1.3.3.2. Record e campi

Alcune altre opzioni convenienti possono essere utilizzate per il riconoscimento dei dati:

  • Numero di righe di intestazione da saltare: comodo quando vuoi evitare le prime righe del file nell’importazione, o perché sono righe vuote o con un’altra formattazione.

  • checkboxIl primo record ha i nomi dei campi: i valori nella prima riga sono usati come nomi di campo, altrimenti QGIS usa i nomi di campo field_1, field_2

  • checkboxDetect field types: riconosce automaticamente il tipo di campo. Se deselezionato, tutti gli attributi sono trattati come campi di testo.

  • checkbox:guilabel: Il separatore decimale è una virgola`: puoi forzare il separatore decimale ad essere una virgola.

  • checkboxRifinisci i campi: ti permette di troncare gli spazi iniziale e finali dai campi.

  • checkboxScarta i campi vuoti.

Mentre imposti le proprietà di interpretazione, un’anteprima dei dati campione viene aggiornata nella parte inferiore della finestra di dialogo.

13.1.3.3.3. Definizione geometria

Una volta che il file è stato interpretato, imposta Definizione della Geometria a:

  • radioButtonOnCoordinate del punto e fornisci i campi Campo X, Campo Y, Campo Z (per dati tridimensionali) e Campo M (per la dimensione di misura) se il layer è di tipo geometrico puntuale e contiene tali campi. Se le coordinate sono definite come gradi/minuti/secondi, attiva la casella di controllo checkboxCoordinate GMS. Fornisci l’appropriato SR della geometria usando il widget setProjection Seleziona SR.

  • radioButtonOnWell known text (WKT) opzione se le informazioni spaziali sono rappresentate come WKT: selezionare il Campo geometria contenente la geometria WKT e scegliere il Campo geometria appropriato o lasciare che QGIS lo rilevi automaticamente. Fornisci l’appropriato SR della geometria usando il widget setProjection Seleziona SR.

  • Se il file contiene dati non spaziali, attiva radioButtonOn Nessuna geometria (solo tabella attributi) e verrà caricato come una normale tabella.

13.1.3.3.4. Impostazioni layer

Puoi anche attivare:

  • checkboxUsa indice spaziale per migliorare le prestazioni di visualizzazione e selezione spaziale degli elementi.

  • checkboxUsa indice di raggruppamento per migliorare le prestazioni dei filtri subset filters (quando definiti nelle proprietà del layer).

  • checkboxControlla file per controllare le modifiche al file da parte di altre applicazioni mentre QGIS è in esecuzione.

At the end, click Add to add the layer to the map. In our example, a point layer named Elevation is added to the project and behaves like any other map layer in QGIS. This layer is the result of a query on the .csv source file (hence, linked to it) and would require to be saved in order to get a spatial layer on disk.

13.1.3.4. Importare file DXF o DWG

I file DXF e DWG possono essere aggiunti a QGIS con un semplice drag-and-drop dal Pannello Browser. Ti verrà richiesto di selezionare i sublayers che vuoi aggiungere al progetto. I layer vengono aggiunti con proprietà di stile casuali.

Nota

Per i file DXF contenenti diversi tipi di geometria (punto, linea e/o poligono), il nome dei layer sarà generato come <filename.dxf> entities <geometry type>.

Per mantenere la struttura del file dxf/dwg e la sua simbologia in QGIS, puoi utilizzare lo strumento dedicato Progetto ► Importa/Esporta ► Importa layer da DWG/DXF…. che ti permette di:

  1. importare elementi dal file DWG/DXF in un database di GeoPackage.

  2. aggiungere elementi importati al progetto.

Nella finestra di dialogo Importa DWG/DXF, per importare il file Disegno nel Geopackage:

  1. Inserisci la posizione del Target package, cioè il nuovo file GeoPackage che memorizzerà i dati. Se viene fornito un file esistente, allora verrà sovrascritto.

  2. Specifica il sistema di riferimento delle coordinate dei dati del file DWG/DXF.

  3. Seleziona checkbox Espandi riferimenti blocco per importare i blocchi nel file di disegno come oggetti normali.

  4. Scegli checkbox Usa curve per trasformare i layer importati in un tipo di geometria curva.

  5. Usare il pulsante Importa per selezionare il file DWG/DXF da utilizzare (uno per geopackage). Il database del GeoPackage sarà automaticamente popolato con il contenuto del file di disegno. A seconda della dimensione del file, questo può richiedere del tempo.

Dopo che i dati .dwg o .dxf sono stati importati nel database di GeoPackage, la cornice nella metà inferiore della finestra di dialogo è popolata con la lista dei layer provenienti dal file importato. Lì puoi selezionare quali layer aggiungere al progetto QGIS:

  1. Nella parte superiore, imposta un Nome gruppo per raggruppare i file di disegno nel progetto.

  2. Controlla i layer da mostrare: ogni layer selezionato viene aggiunto ad un gruppo ad hoc che contiene layer vettoriali per le tipologie punto, linea, etichetta e area del layer di disegno. Lo stile dei layer assomiglierà all’aspetto che avevano originariamente in *CAD.

  3. Scegli se il layer deve essere visibile all’apertura.

  4. Selezionando l’opzione checkbox Fondi layer colloca tutti i layer in un unico gruppo.

  5. Premi OK per aprire i layer in QGIS.

../../../_images/dwg_dxf_import_dialog.png

Fig. 13.10 Finestra di dialogo per importazione file DWG/DXF

13.1.3.5. Importare vettori OpenStreetMap

Il progetto OpenStreetMap è popolare perché in molti paesi non sono disponibili geodati gratuiti come le mappe stradali digitali. L’obiettivo del progetto OSM è quello di creare una mappa modificabile gratuita del mondo da dati GPS, fotografie aeree e conoscenze locali. Per sostenere questo obiettivo, QGIS fornisce il supporto per i dati OSM.

Usando il Pannello Browser, puoi caricare un file .osm nella mappa, in tal caso otterrai un finestra di dialogo per selezionare i sublayers basati sul tipo di geometria. I layer caricati conterranno tutti i dati di quel tipo di geometria nel file .osm, e manterranno la struttura dati del file osm.

13.1.3.6. Layer SpatiaLite

addSpatiaLiteLayer La prima volta che carichi i dati da un database di SpatiaLite, inizia da:

  • cliccando sul pulsante della barra degli strumenti addSpatiaLiteLayer Aggiungi Layer SpatiaLite

  • selezionando l’opzione addSpatiaLiteLayer :menuselection: Aggiungi Layer SpatiaLite… dal menu Layer ► Aggiungi Layer

  • o digitando Ctrl+Shift+L

Questo farà apparire una finestra che ti permetterà o di connetterti ad un database SpatiaLite già noto a QGIS (che sceglierai dal menu a tendina) o di definire una nuova connessione ad un nuovo database. Per definire una nuova connessione, clicca su :guilabel: Nuovo e usa il browser dei file per puntare al tuo database SpatiaLite, che è un file con estensione .sqlite.

QGIS supporta anche viste modificabili in SpatiaLite.

13.1.3.7. GPS

Il caricamento di dati GPS in QGIS può essere fatto usando il plugin di base Strumenti GPS. Le istruzioni si trovano nella sezione Plugin GPS.

13.1.3.8. GRASS

Lavorare con i dati vettoriali di GRASS è descritto nella sezione Integrazione con GRASS GIS.

13.1.4. Formati QGIS personalizzati

QGIS offre due formati personalizzati:

  • Layer Scratch Temporaneo: un layer in memoria che è legato al progetto (vedi Creare un nuovo Vettore Temporaneo per maggiori informazioni)

  • Layers virtuali: un layer risultante da una query su altro(i) layer(s) (per ulteriori informazioni, vedi Layers virtuali)

13.1.5. QLR - QGIS Layer Definition File

Le definizioni del layer possono essere salvate come Layer Definition File (QLR - .qlr) usando :menuselection:` Esporta -> Salva come file di definizione layer…` nel menu contestuale del layer.

Il formato QLR consente di condividere layer QGIS «completi» con altri utenti QGIS. I file QLR contengono collegamenti alle fonti dati e tutte le informazioni di stile QGIS necessarie per lo stile del layer.

I file QLR sono mostrati nel Pannello Browser e possono essere usati per aggiungere layer (con i relativi stili salvati) al Pannello Layer. Puoi anche trascinare e rilasciare i file QLR dal file manager di sistema nell’area della mappa.

13.1.6. Connessione a web services

Con QGIS puoi avere accesso a diversi tipi di servizi web OGC (WM(T)S, WFS(-T), WCS, CSW, …). Grazie a QGIS Server, puoi anche pubblicare tali servizi. QGIS Server Guida/Manuale contiene descrizioni di queste funzionalità.

13.1.6.1. Usare i servizi Tasselli Vettoriali

I servizi di Tasselli Vettoriali possono essere trovati nella voce di primo livello Tasselli Vettoriali in Browser. Puoi aggiungere un servizio aprendo il menu contestuale con un clic destro e scegliendo Nuova Connessione Generica …. Si imposta un servizio aggiungendo un Nome e un URL. Il servizio di tasselli vettoriali deve fornire tasselli in formato .pbf. La finestra di dialogo fornisce due menu per definire il checkboxMinimo Livello di Zoom e il checkboxMassimo Livello di Zoom. I tasselli vettoriali hanno una struttura piramidale. Usando queste opzioni hai l’opportunità di generare individualmente dei livelli dalla piramide di tasselli. Questi livelli saranno poi usati per visulizzare il Tassello Vettoriale in QGIS. Per la proiezione Mercator (usata da OpenStreetMap Vector Tiles) Zoom Level 0 rappresenta il mondo intero ad una scala di 1:500.000.000. Il livello di zoom 14 rappresenta la scala 1:35.000. Fig. 13.13 mostra la finestra di dialogo con la configurazione del servizio MapTiler planet Vector Tiles.

../../../_images/vector_tiles_maptilerplanet.png

Fig. 13.13 Tasselli Vettoriali - Configurazione Map Tiler Planet

Usando Nuova Connessione al Vector Tile Service Connection di ArcGIS … puoi connetterti a ArcGIS Vector Tile Services.

13.1.6.2. Usare i servizi di Tasselli XYZ

I servizi Tassello XYZ possono essere trovati nella voce di primo livello Aggiungi layer XYZ nella cartella Browser. Per impostazione predefinita, è configurato il servizio OpenStreetMap Tassello XYZ . Puoi aggiungere altri servizi che usano il protocollo Tassello XYZ scegliendo Nuovo collegamento nel menu contestuale di Tasselli XYZ (clic destro per aprire). Fig. 13.14 mostra il dialogo con la configurazione del servizio Tassello OpenStreetMap XYZ.

../../../_images/xyz_tiles_dialog_osm.png

Fig. 13.14 Tasselli XYZ - Configurazione OpenStreetMap

Le configurazioni possono essere salvate (Salva) in XML e caricate (Carica) attraverso il menu contestuale. La configurazione dell’autenticazione è supportata. Il file XML per OpenStreetMap si presenta così:

<!DOCTYPE connections>
<qgsXYZTilesConnections version="1.0">
  <xyztiles url="https://tile.openstreetmap.org/{z}/{x}/{y}.png"
   zmin="0" zmax="19" password="" name="OpenStreetMap" username=""
   authcfg="" referer=""/>
</qgsXYZTilesConnections>

Una volta impostata una connessione a un servizio di Tasselli XYZ, clicca con il tasto destro del mouse sulla voce per:

  • Modifica… le impostazioni della connessione XYZ

  • Rimuovi la connessione

  • Esporta, saving it as a raster

  • Aggiungi: un doppio clic aggiunge anche il layer al Progetto

  • Visualizza le Proprietà del layer… e ottieni l’accesso ai metadati e un’anteprima dei dati forniti dal servizio. Altre impostazioni sono disponibili quando il layer viene caricato nel progetto.

Esempi di servizi di Tasselli XYZ:

  • OpenStreetMap Monochrome: URL: http://tiles.wmflabs.org/bw-mapnik/{z}/{x}/{y}.png, Minimo Livello di Zoom: 0, Massimo Livello di Zoom: 19.

  • Google Maps: URL: https://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}, Minimo Livello di Zoom: 0, Massimo Livello di Zoom: 19.

  • Open Weather Map Temperature: URL: http://tile.openweathermap.org/map/temp_new/{z}/{x}/{y}.png?appid={api_key} Minimo Livello di Zoom: 0, Massimo Livello di Zoom: 19.