8. Il pannello Browser

Il pannello QGIS Browser è un ottimo strumento per la navigazione, la ricerca, la consultazione, la copia e il caricamento delle risorse QGIS. Solo le risorse che QGIS sa come gestire sono mostrate nel browser.

Utilizzando il pannello Browser è possibile individuare, visualizzare e aggiungere dati, come descritto in Il Pannello Browser. Inoltre, il pannello Browser supporta il drag and drop di molte risorse QGIS, come file di progetto, script Python, script di Processing e modelli di Processing.

Gli script Python, gli script di Processing e i modelli di Processing possono anche essere aperti per l’editing in un editor esterno e nel modellatore grafico.

Puoi trascinare e rilasciare i layer dal pannello Layer al pannello Browser, ad esempio in un GeoPackage o in un database PostGIS.

../../../_images/browser_panel1.png

Fig. 8.1 Il pannello Browser

Il pannello del browser (Fig. 8.1) è organizzato in una gerarchia espandibile con alcune voci fisse al primo livello che organizzano le risorse gestite dal browser. Le voci di primo livello vengono espanse cliccando su browserExpand a sinistra del nome della voce. Un ramo viene collassato cliccando su browserCollapse. Il pulsante collapseTree Racchiudi Tutto fa collassare tutte le voci al primo livello.

In Impostazioni ► Personalizzazione Interfaccia è possibile disabilitare le risorse. Se, per esempio, non vuoi mostrare script Python nel browser, puoi deselezionare la voce Browser ► py, e se vuoi eliminare la cartella home nel browser, puoi deselezionare la voce Browser ► special:Home.

Un filtro (filterMap Filtra Browser) può essere utilizzato per la ricerca in base ai nomi delle voci (sia le voci delle foglie che quelle dei nodi nella gerarchia). Utilizzando il menu a tendina options Opzioni accanto al campo di testo del filtro, puoi

  • attivare/disattivare l’opzione Maiusc/minusc

  • impostare Filtra sintassi del pattern su una di queste opzioni

    • Normale

    • Carattere(i) jolly

    • Espressione Regolare

Il widget Proprietà, che mostra informazioni utili su alcune voci / risorse, può essere abilitato / disabilitato usando il pulsante metadata Abilita/disabilita le proprietà del widget. Quando è abilitato, si apre in fondo al pannello del browser, come mostrato in Fig. 8.2.

../../../_images/browser_p_properties_w.png

Fig. 8.2 Il widget proprietà

Un secondo pannello browser può essere aperto attivando il pannello Browser (2) in Visualizza ► Panelli. Avere due pannelli browser può essere utile quando si copiano i layer tra le risorse che si trovano in profondità in diversi rami della gerarchia del browser.

8.1. Risorse che possono essere aperte / eseguite dal Browser

Molto si può fare nel pannello Browser

  • Aggiungere layer vettoriali, raster e mesh alla mappa facendo doppio clic, trascinando sull’area della mappa o cliccando sul pulsante addLayer Aggiungi Layer selezionati (dopo aver selezionato i layer)

  • Eseguire script Python (inclusi gli algoritmi di Processing) facendo doppio clic o trascinandoli sull’area della mappa

  • Eseguire modelli facendo doppio clic o trascinandoli nell’area della mappa

  • Estrai simboli… dai file di progetto QGIS utilizzando il menu contestuale

  • Aprire file con le loro applicazioni predefinite (Open <file type> Externally… nel menu contestuale). Ad esempio: file HTML, fogli di calcolo, immagini, PDF, file di testo, …

  • Copiare voci

Le azioni specifiche per le risorse sono elencate per i diversi gruppi di risorse ordinate sotto le voci di primo livello elencate qui di seguito.

8.2. Voci di primo livello del pannello Browser

8.2.1. Preferiti

Spesso le posizioni del file system utilizzate possono essere etichettate come preferite. Quelle che hai etichettato appariranno qui.

Oltre alle operazioni descritte in Home, il menu contestuale ti permette di impostare Rinomina Preferito… e Rimuovi Preferito.

8.2.2. Segnalibri Spaziali

Qui troverai i tuoi segnalibri spaziali, organizzati in Segnalibri Progetto e Segnalibri Utente.

Dal menu contestuale di livello superiore, puoi creare un segnalibro (Nuovo Segnalibro Spaziale…), Mostra Gestore Segnalibri Spaziali, Importa Segnalibri Spaziali… e Esporta Segnalibri Spaziali….

Per le voci dei segnalibri puoi Zoom a Segnalibro, Modifica Segnalibro Spaziale… e Elimina Segnalibro Spaziale.

8.2.3. Home

La directory/cartella home del tuo file system. Cliccando con il tasto destro del mouse su una voce, e scegliendo Aggiungi come Preferito, la posizione verrà aggiunta a Preferiti. Dal menu contestuale, puoi anche

  • aggiungere una cartella, un Geopackage o un ESRI Shapefile (Nuovo)

  • nascondere la cartella (Nascondi dal Browser)

  • attivare/disattivare Scansiona Velocemente questa cartella.

  • aprire la cartella nel tuo file manager (Apri Cartella…)

  • aprire la cartella in una finestra del terminale (Apri nel Terminale…)

  • ispezionare le proprietà (Proprietà…, Proprietà Cartella…)

8.2.4. /

La tua directory / cartella principale del file system.

8.2.5. Geopackage

File Geopackage / database. Dal menu contestuale di livello superiore, puoi creare un file / database Geopackage (Crea Database…) o aggiungere un file / database Geopackage esistente (Nuova Connessione…).

Il menu contestuale di ogni Geopackage ti permette di rimuoverlo dalla lista (Rimuovi connessione…), aggiungere un nuovo layer o una nuova tabella al Geopackage (Crea nuovo layer o tabella…), cancellare il Geopackage (Cancella <name of geopackage>) e Compatta Database (VACUUM).

Per le voci di layer/tabella puoi

  • rinominare (Rinominare Layer <layer name>…)

  • esportare (Esporta Layer ► Su File…)

  • aggiungere al progetto Aggiungi Layer al Progetto

  • eliminare (Elimina File…)

  • consultare le proprietà (Proprietà del Layer…, Proprietà File…)

8.2.6. SpatiaLite

Connessioni al database SpatiaLite.

Dal menu contestuale di livello superiore, puoi creare un file / database SpatiaLite (Crea Database…) o aggiungere un file / database SpatiaLite esistente (Nuova Connessione…).

Il menu contestuale di ogni file SpatiaLite ti permette di cancellarlo (Elimina).

Per le voci di layer/tabella puoi

  • esportare (Esporta Layer ► Su File…)

  • aggiungere al progetto Aggiungi Layer al Progetto

  • eliminare (Elimina File…)

  • consultare le proprietà (Proprietà Layer…)

8.2.7. PostGIS

Connessioni al database PostGIS.

Dal menu contestuale di livello superiore, puoi aggiungere una nuova connessione (Nuova Connessione…).

Il menu contestuale di ogni connessione ti permette di Aggiornare, modificare Modifica connessione…, cancellare (Rimuovi connessione) o Creare Schema….

Il menu contestuale di ogni schema ti permette di Aggiornare, Rinominare Schema… o Eliminare Schema.

Per layer/tabelle tu puoi

  • rinominare (Rinomina Tabella…)

  • rimuovere il suo contenuto (Truncate Tabella…)

  • esportare (Esporta Layer ► Su File…)

  • aggiungerlo al progetto (Aggiungi Layer al Progetto)

  • eliminare (Elimina File…)

  • visualizzare le sue proprietà (Proprietà Layer…)

8.2.8. MSSQL

Connessioni Microsoft SQL Server.

Dal menu contestuale di livello superiore, puoi aggiungere una nuova connessione (Nuova Connessione…).

Il menu contestuale di ogni connessione ti permette di Aggiornare, modificare Modifica connessione…, cancellare (Rimuovi connessione) o Creare Schema….

Il menu contestuale di ogni schema ti permette di Aggiornare, Rinominare Schema… o Eliminare Schema.

Per layer/tabelle tu puoi

  • rinominare (Rinomina Tabella…)

  • rimuovere il suo contenuto (Truncate Tabella…)

  • esportare (Esporta Layer ► Su File…)

  • aggiungerlo al progetto (Aggiungi Layer al Progetto)

  • eliminare (Elimina File…)

  • visualizzare le sue proprietà (Proprietà Layer…)

8.2.9. DB2

Connessioni al database IBM DB2.

Dal menu contestuale di livello superiore, puoi aggiungere una nuova connessione (Nuova Connessione…).

Il menu contestuale di ogni connessione ti permette di Aggiornare, modificare Modifica connessione…, cancellare (Rimuovi connessione) o Creare Schema….

Il menu contestuale di ogni schema ti permette di Aggiornare, Rinominare Schema… o Eliminare Schema.

Per layer/tabelle tu puoi

  • rinominare (Rinomina Tabella…)

  • rimuovere il suo contenuto (Truncate Tabella…)

  • esportare (Esporta Layer ► Su File…)

  • aggiungerlo al progetto (Aggiungi Layer al Progetto)

  • eliminare (Elimina File…)

  • visualizzare le sue proprietà (Proprietà Layer…)

8.2.10. WMS/WMTS

Web Map Services (WMS) e Web Map Tile Services (WMTS)

Dal menu contestuale di livello superiore, puoi aggiungere una nuova connessione (Nuova Connessione…).

Il menu contestuale di ogni servizio WSM/WMTS ti permette di Aggiornare, Modificare… e cancellare (Elimina).

Layer in gruppo possono essere aggiunti trascinandoli sull’area della mappa.

Per i layer WMS/WMTS puoi

  • esportare (Esporta Layer ► Su File…)

  • aggiungerlo al progetto (Aggiungi Layer al Progetto)

  • consultare le proprietà (Proprietà Layer…)

8.2.11. Vector Tile

Servizi Vector tile

Dal menu contestuale di livello superiore, aggiungi un servizio esistente (Nuova Connessione…), e puoi Salva Connessione… o Carica Connessione… a / da file XML.

8.2.12. XYZ Tile

servizi XYZ tile

Dal menu contestuale di livello superiore, aggiungi un servizio esistente (Nuova Connessione…), e puoi Salva Connessione… o Carica Connessione… a / da file XML.

Per i servizi XYZ tile puoi

  • modificarlo (Modifica…)

  • cancellarlo (Elimina)

  • esportare (Esporta Layer ► Su File…)

  • aggiungere al progetto Aggiungi Layer al Progetto

  • consultare le proprietà (Proprietà Layer…)

8.2.13. WCS

Web Coverage Services

Dal menu contestuale di livello superiore, puoi aggiungere una nuova connessione (Nuova Connessione…).

Il menu contestuale di ogni WCS ti permette di Aggiornare, Modificare… e cancellare (Eliminare).

Per i layer WCS puoi

  • esportare (Esporta Layer ► Su File…)

  • aggiungerlo al progetto (Aggiungi Layer al Progetto)

  • consultare le proprietà (Proprietà Layer…)

8.2.14. WFS / OGC API - Features

Web Feature Services (WFS) e OGC API - Features services (aka WFS3)

Dal menu contestuale di livello superiore, puoi aggiungere una nuova connessione (Nuova Connessione…).

Il menu contestuale di ogni WFS ti permette Aggiornare, Modificare… e cancellare (Eliminare).

Per i layer WFS puoi

  • esportare (Esporta Layer ► Su File…)

  • aggiungerlo al progetto (Aggiungi Layer al Progetto)

  • consultare le proprietà (Proprietà Layer…)

8.2.15. OWS

Qui trovi una lista in solo lettura di tutti i tuoi Open Web Services (OWS) - WMS / WCS / WFS / WFS / …

8.2.16. ArcGIS Map Service

8.2.17. ArcGIS Features Service

8.2.18. GeoNode

Dal menu contestuale di livello superiore, puoi aggiungere una nuova connessione (Nuova Connessione…).

Il menu contestuale di ogni servizio ti permette di Aggiornare, Modificare… e cancellare (Eliminare).

Con le voci di gestione dei layer puoi

  • esportare (Esporta Layer ► Su File…)

  • aggiungerlo al progetto (Aggiungi Layer al Progetto)

  • consultare le proprietà (Proprietà Layer…)

8.3. Risorse

  • File di progetto. Il menu contestuale per i file di progetto QGIS ti permette di:

    • caricare (Apri Progetto)

    • estrarre simboli (Estrai Simboli…) - apre il gestore di stili che permette di esportare simboli in un file XML, aggiungere simboli allo stile predefinito o esportarli come PNG o SVG.

    • consultare proprietà (Proprietà File…)

    Puoi espandere il file di progetto per vederne i layer. Il menu contestuale di un layer offre le stesse opzioni come nelle altre funzionalità del browser.

  • File di definizione dei Layer QGIS (QLR). Le seguenti azioni sono disponibili dal menu contestuale:

    • esportare (Esporta Layer ► Su File…)

    • aggiungerlo al progetto (Aggiungi Layer al Progetto)

    • consultare le proprietà (Proprietà Layer…)

  • Modelli di elaborazione (.modello3). Le seguenti azioni sono disponibili dal menu contestuale:

    • (Esegui Modello…)

    • (Modifica Modello…)

  • Modelli di compositore di stampa QGIS (QPT). La seguente azione è disponibile dal menu contestuale:

    • (Nuovo Layout da Modello)

  • Script Python (.py). Le seguenti azioni sono disponibili dal menu contestuale:

    • (Esegui script…)

    • (Apri in un editor esterno)

  • Formati raster riconosciuti. Le seguenti azioni sono disponibili dal menu contestuale:

    • eliminare (Elimina File <dataset name>)

    • esportare (Esporta Layer ► Su File…)

    • aggiungerlo al progetto (Aggiungi Layer al Progetto)

    • consultare le proprietà (Proprietà del Layer…, Proprietà File…)

    Per alcuni formati puoi anche Apri <file type> Esternamente…

  • Formati vettoriali riconosciuti. Le seguenti azioni sono disponibili dal menu contestuale:

    • eliminare (Elimina File <dataset name>)

    • esportare (Esporta Layer ► Su File…)

    • aggiungerlo al progetto (Aggiungi Layer al Progetto)

    • consultare le proprietà (Proprietà del Layer…, Proprietà File…)

    Per alcuni formati puoi anche Apri <file type> Esternamente…