Outdated version of the documentation. Find the latest one here.

Gebruikersinterface van QGIS

Wanneer QGIS start zal de gebruikersinterface worden getoond zoals weergegeven in de afbeelding (de getallen 1 t/m 5 in de gele cirkels worden hieronder besproken):

Figure QGIS GUI 1:

../../../_images/startup.png

Gebruikersinterface van QGIS met Alaska voorbeeld gegevensset

Notitie

De weergave van uw venster (titelbalk, etc) kan enigszins afwijken, afhankelijk van uw besturingssysteem en vensterbeheer.

De QGIS gebruikersinterface is onderverdeeld in vijf gebieden:

  1. Menubalk

  2. Werkbalken

  3. Panelen

  4. Kaartvenster

  5. Statusbalk

Deze vijf onderdelen worden in de volgende gedeelten in detail beschreven. Daarnaast worden in twee gedeelten de snelkoppelingen en de context helpfunctie beschreven.

Panelen en werkbalken

Vanuit het menu Beeld (Extra onder KDE), kunt u QGIS widgets in- en uitschakelen (Panelen ‣) of werkbalken (Werkbalken ‣). U kunt elk daarvan (de)activeren door met rechts te klikken op de menubalk of een werkbalk en het item kiezen dat u wilt. Elk paneel of werkbalk kan worden verplaatst en geplaatst waar u dat wilt in de interface van QGIS. De lijst kan ook worden uitgebreid met het activeren van Bron- of externe plug-ins.

Werkbalken

De werkbalken geven toegang tot de meeste functies die u ook terugvindt in de menu-structuur, plus kaartgereedschap. Elke knop op de werkbalk heeft ook een tooltip, informatie die na een tijdje automatisch verschijnt wanneer u de muisaanwijzer er even boven houdt.

Elke werkbalk kan verplaatst worden naar waar u wilt. Daarnaast kunt u werkbalken tijdelijk verwijderen via het snelmenu, dat verschijnt wanneer u de rechter muisknop indrukt of wanneer de muisaanwijzer zich boven een werkbalk bevindt.

Figure Toolbars:

../../../_images/toolbars1.png

Menu Werkbalken

Tip

Werkbalken weer terugzetten

Indien u per ongeluk een werkbalk hebt verborgen, kunt u die terugkrijgen door te kiezen voor de menuoptie Beeld ‣ Werkbalken ‣ (of Extra ‣ Werkbalken ‣ onder Linux KDE). Als om enige reden een werkbalk (of enig ander widget) totaal verdwijnt uit de interface, vindt u tips om die terug te halen op initiële GUI herstellen.

Panelen

QGIS verschaft standaard veel panelen om mee te werken.

Figure Panels:

../../../_images/panels.png

Menu Panelen

Sommige van deze panelen worden hieronder beschreven terwijl andere in verschillende gedeelten van het document kunnen worden gevonden, namelijk:

Paneel Lagen

Het paneel lagen vermeldt alle lagen in het project. Het keuzevak voor elk item in de legenda kan worden gebruikt om de laag weer te geven of te verbergen. De werkbalk in het paneel lagen stelt u in staat om:

  • addGroup Nieuwe groep toevoegen

  • showPresets Zichtbaarheid lagen beheren: zichtbaarheid van lagen beheren en voorkeuze combinatie van lagen

  • filterMap Legenda filteren op kaartinhoud: alleen de lagen die zijn ingesteld om zichtbaar te zijn en waarvan de objecten kruisen met het huidige kaartvenster hebben hun stijl gerenderd in het paneel Lagen. Anders wordt een generiek symbool NULL toegepast op de laag. Gebaseerd op de symbologie van de laag is dit een handige manier om te identificeren welk soort objecten van welke lagen zich in uw gebied van interesse bevinden.

  • expressionFilter Legenda filteren met expressie: helpt u een expressie toe te passen om stijlen uit de geselecteerde lagenboom te verwijderen die geen object hebben dat voldoet aan de voorwaarde. Dit kan bijvoorbeeld worden gebruikt om objecten te accentueren die binnen een bepaald gebied/object van ene andere laag liggen. U kunt de ingestelde expressie vanuit het keuzemenu bewerken of leeg maken.

  • expandTree Alles uitklappen of collapseTree Alles inklappen, lagen en groepen in het paneel Lagen.

  • en removeLayer Laag/Groep verwijderen momenteel geselecteerd.

Figure Layer tools Bar:

../../../_images/layer_toolbar.png

Layer Toolbar in Layers Panel

De knop showPresets stelt u in staat Voorkeuze-weergaven aan de legenda toe te voegen. Voorkeuzen zijn een manier om een combinatie van lagen met hun huidige stijlen op te slaan of te herstellen. Stel, om een voorkeuze-weergave toe te voegen, de zichtbare lagen in die u wilt gebruiken, met hun gewenste symbologie, en klik op de knop showPresets. Kies Voorkeuze toevoegen... uit de keuzelijst en geef de voorkeuze een naam. De toegevoegde voorkeuze zal worden vermeld an de onderzijde van de keuzelijst en wordt opnieuw opgeroepen door er op te klikken.

De optie Voorkeuze vervangen ‣ helpt u de inhoud van een voorkeuze te overschrijven met de huidige kaartweergave terwijl de knop Huidige voorkeuze verwijderen de actieve voorkeuze verwijdert.

Alle toegevoegde voorkeuzen zijn ook aanwezig in de Printvormgeving om u in staat te stellen een kaartopmaak te maken die is gebaseerd op uw specifieke weergaven (zie Algemene eigenschappen).

Notitie

Gereedschappen om het paneel Lagen te beheren zijn ook beschikbaar om de kaart op te maken en items voor de legenda van Printvormgeving

Een laag kan na selectie hoger of lager in de legenda gezet worden door deze te slepen met ingedrukte linker muisknop. Hoe hoger in de legenda, hoe later deze laag getekend wordt. De bovenste kaartlaag wordt dan ook over alle andere kaartlagen getekend.

Notitie

Dit gedrag kan overschreven worden via het paneel Laagvolgorde.

Lagen in het venster Legenda kunnen in groepen worden ondergebracht. Er zijn twee manieren om dit te doen:

  1. Druk op het pictogram folder om een nieuwe groep toe te voegen. Typ een naam in voor de groep en druk op Enter. Klik nu op een bestaande laag en sleep die op de groep.

  2. Selecteer enkele lagen, start met de rechter muisknop het snelmenu vanuit het paneel van de legenda en kies Groep geselecteerd. De geselecteerde lagen zullen automatisch aan de nieuwe groep worden toegevoegd.

Om een laag uit een groep te halen kunt u deze eruit slepen, of door een laag in een groep te selecteren en dan via de rechtermuis het snelmenu te openen en te kiezen voor Maak hier een item op het hoogste niveau van. Een groep kan groepen bevatten.

Met het keuzevak kunt u met één klik de zichtbaarheid van alle lagen die behoren tot die groep aan- of uitzetten.

De inhoud van het contextmenu, dat u opent met de rechter muisknop, is, afhankelijk van het geselecteerde item van de legenda, verschillend voor vector- of rasterlagen. Wanneer het een vectorlaag van GRASS betreft ontbreekt de menuoptie toggleEditing Bewerken aan/uitzetten. Zie het gedeelte Digitaliseren en bewerken van een GRASS vectorlaag voor informatie over hoe u vectorlagen van GRASS kunt bewerken.

Hieronder zijn de in et contextmenu beschikbare opties vermeld, afhankelijk van het geselecteerde item.

Optie

Vectorlaag

Rasterlaag

Groeperen

zoomToLayer Zoom naar laag/groep

checkbox checkbox checkbox

unchecked In overzichtskaart tonen

checkbox checkbox

zoomActual Zoomen naar eigen resolutie (100%)

checkbox

Uitrekken naar huidig bereik

checkbox

removeLayer Verwijderen

checkbox checkbox checkbox

duplicateLayer Dupliceren

checkbox checkbox

Zichtbaarheidsschaal instellen

checkbox checkbox

CRS voor laag/groep instellen

checkbox checkbox checkbox

Project-CRS van laag overnemen

checkbox checkbox

Stijlen ‣

checkbox checkbox

Stijl kopiëren

checkbox checkbox

Stijl plakken

checkbox checkbox checkbox

openTable Attributentabel openen

checkbox

toggleEditing Bewerken aan/uitzetten

checkbox

allEdits Huidige wijzigingen ‣

checkbox (in modus Bewerken)

Opslaan als...

checkbox checkbox

Opslaan als Laag-definitiebestand...

checkbox checkbox checkbox

Query

checkbox

unchecked Aantal objecten tonen

checkbox

Eigenschappen

checkbox checkbox

Naar hoogste niveau verplaatsen

checkbox checkbox

Hernoemen

checkbox checkbox checkbox

Groep geselecteerd

checkbox checkbox

Eigenschappen

checkbox checkbox

WMS-gegevens groep instellen

checkbox

unchecked Gemeenschappelijk uitgesloten groep

checkbox

addGroup Groep toevoegen

checkbox

Met het inschakelen van de optie Gemeenschappelijk uitgesloten groep kunt u er voor zorgen dat slechts één laag per keer zichtbaar is. Wanneer een laag binnen de groep ingesteld is om zichtbaar te zijn zullen de andere als niet zichtbaar worden geschakeld.

Het is mogelijk om meer dan één laag of groep tegelijkertijd te selecteren door de Ctrl -toets vast te houden tijdens het selecteren van lagen met de linker muisknop. U kunt dan in een keer alles wat u geselecteerd heeft verplaatsen naar een groep.

U kunt ook meer dan één laag of groep tegelijkertijd verwijderen door deze te selecteren met ingehouden Ctrl -toets en daarna de toetsencombinatie Ctrl+D te gebruiken. Op deze manier zullen alle geselecteerde lagen of groepen verwijderd worden uit de lagenlijst.

Vector laagstijl bewerken

Vanuit het paneel Lagen hebt u sneltoetsen om het renderen van de laag snel en eenvoudig te bewerken. Klik met rechts op een vectorlaag en selecteer Stijlen –> in de lijst om:

  • de huidige toegepaste stijlen op de laag te zien. In het geval dat u veel stijlen voor de laag hebt gedefinieerd, kunt u van de een naar de ander schakelen en het renderen van de laag automatisch hebben bijgewerkt in het kaartvenster.

  • de huidige stijl te kopiëren, en indien van toepassing, een gekopieerde stijl op een andere laag plakken

  • de huidige stijl te hernoemen, een nieuwe toe te voegen (wat in feite ene kopie van de huidige is) of de huiidge stijl te verwijderen (indien meerdere stijlen beschikbaar zijn).

Notitie

De eerdere opties zijn ook beschikbaar voor rasterlagen.

Of de objecten op de vectorlaag allemaal hetzelfde unieke symbool hebben of dat zij zijn geclassificeerd (in dat geval wordt de laag weergegeven in een boomstructuur met elke klasse als een subitem), de volgende opties zijn beschikbaar op het niveau van de klasse of de laag:

  • een knop Symbool bewerken... om het dialoogvenster Symbool selecteren te openen en enige eigenschap bij te werken (symbool, grootte, kleur...) van de laag of het symbool van het object. Dubbelklikken op ene object opent ook het dialoogvenster Symbool selecteren.

  • een widget Kleur selecteren met een Kleurenwiel van waaruit u eop ene kleur kunt klikken om automatisch de vulkleur van het symbool bij te werken. Gemakshalve zijn Recente kleuren beschikbara aan de onderzijde van het wiel.

  • een showAllLayers Alle Items tonen en hideAllLayers Alle Items verbergen om de zichtbaarheid van alle klassen van objecten in of uit te schakelen. Dit voorkomt het één voor één (de)selecteren van items.

Tip

Snel een laagstijl delen

Kopieer, vanuit het contextmenu, de stijl van een laag en plak die op een groep of een selectie van lagen: de stijl wordt toegepast op alle lagen die van hetzelfde type zijn (vector vs raster) als de originele laag en, in het geval van vector, hebben hetzelfde type geometrie (punt, lijn of polygoon).

Werken met de onafhankelijke volgorde van lagen in Legenda

Er is een paneel waarmee u de tekenvolgorde, onafhankelijk van het Paneel Lagen, kunt aangeven. Dit paneel kan geactiveerd worden via het menu Beeld ‣ Panelen ‣ Paneel Laagvolgorde. Bepaal de tekenvolgorde van de lagen in het paneel Laagvolgorde. Vervolgens kunt u in de legenda de groepen anders indelen, waarbij deze lagen toch in de goede volgorde worden getekend (zie figure_layer_order). Wanneer onderin het paneel van de legenda, het keuzevak checkbox Rendervolgorde controleren uitgezet wordt, dan geldt alleen de tekenvolgorde van de legenda.

Figure Layer Order:

../../../_images/layer_order.png

Een onafhankelijke volgorde van lagen definiëren

Paneel Statistieken

Dit paneel kan enkele statistieken weergeven over specifieke vectorlagen. Het paneel stelt gebruikers in staat te kiezen uit:

  • de vectorlaag;

  • de kolom of de expressie;

  • statistieken filteren voor de geselecteerde objecten;

  • de informatie te vernieuwen;

  • de informatie van de statistieken weer te geven met de knop rechts onder;

Paneel QGIS Overzichtskaart

In QGIS kunt u een paneel activeren dat een overzichtskaart toont met het volledige bereik van de toegevoegde lagen. Binnen de weergave wordt een rechthoek getoond van het huidige kaartbereik. Dit stelt u in staat snel te bepalen welk gebied van de kaart u momenteel bekijkt. Onthoud dat labels niet worden getoond in de overzichtskaart, ook al zijn de lagen zo ingesteld dat er labels moeten worden getoond. Wanneer u het rode vierkant in de overzichtskaart versleept, met ingehouden linker muisknop, zal het kaartvenster zich overeenkomstig aanpassen.

Paneel Logboekmeldingen

Bij het laden of verwerken van sommige bewerkingen kunt u berichten traceren en volgen die op de verschillende tabs verschijnen met behulp van het messageLog Paneel Logboekmeldingen. Het kan worden geactiveerd met behulp van het meest rechts gelegen pictogram op de onderste statusbalk.

Paneel Ongedaan maken/Opnieuw

Voor elke laag die wordt bewerkt geeft dit paneel de uitgevoerde acties weer, wat het mogelijk maakt snel een set acties ongedana te maken door eenvoudigweg op de actie erboven te klikken.

Kaartvenster

Ook wel Kaartvenster genaamd is dit het “zakelijke gedeelte” van QGIS - kaarten worden weergegeven in dit gebied! De kaart die getoond word is afhankelijk van de geladen vector- en rasterlagen (zie volgende onderwerpen voor meer informatie over hoe kaartlagen geladen worden). Men kan het kaartvenster verschuiven of erop inzoomen of uitzoomen. Men kan nog verschillende andere dingen doen met het kaartvenster zoals beschreven in de label_toolbars description hierboven. De legenda van lagen en het kaartvenster hebben een sterke relatie met elkaar — het kaartvenster verandert direct wanneer u lagen in de legenda wijzigt.

Tip

Het kaartvenster in/uitzoomen met het muiswiel

Met het muiswiel kunt u in- en uitzoomen op de kaart. Plaats de muisaanwijzer in het kaartvenster en rol het muiswiel naar voren (van u af) om in te zoomen en achteruit (naar u toe) om uit te zoomen. De plaats van de muisaanwijzer is de plaats waar het in-/uitzoomen gebeurd. U kunt het gedrag van de muiswiel instellen in het menu Opties Extra ‣ Opties op de tab Kaartgereedschap.

Tip

Verschuiven van het kaartvenster met de pijltjestoetsen en de spatiebalk

U kunt de pijltjestoetsen gebruiken om het kaartbeeld te verschuiven. Plaats de muisaanwijzer in het kaartvenster en druk op de toets met de linkerpijl/rechterpijl om het kaartvenster naar west/oost te verschuiven of pijl omhoog/pijl omlaag om deze naar noord/zuid te verschuiven. Maar u kunt ook de spatiebalk gebruiken om het kaartvenster te verschuiven! Met ingedrukte spatiebalk kunt u met de muisaanwijzer het kaartvenster verschuiven in gewenste richting of klik op het muiswiel.

Statusbalk

De Statusbalk verschaft u algemene informatie over de kaartweergave, en verwerkte of beschikbare acties en biedt u gereedschappen om de kaartweergave te beheren.

Aan de linkerkant van de Statusbalk kunt u een overzicht krijgen van de acties die u heeft uitgevoerd (zoals het selecteren van objecten in een laag, verwijderen van ene laag) of een lange beschrijving van het gereedschap waar u overheen gaat (niet voor alle gereedschappen beschikbaar). Bij het opstarten informeert de Statusbalk u ook over de beschikbaarheid van nieuwe of bij te werken plug-ins (indien geselecteerd in de instellingen van Plug-ins beheren en installeren).

In het geval van langdurige bewerkingen, zoals het verzamelen van statistieken in rasterlagen of het renderen van verscheidene lagen in de kaartweergave, wordt een voortgangsbalk weergegeven in de Statusbalk om de huidige voortgang van de actie weer te geven.

De optie tracking Coördinaten geeft de huidige positie van de muis weer en volgt die bij het verplaatsen over de kaartweergave. U kunt de eenheid instellen (en de precisie) om in de projecteigenschappen te gebruiken, tab Algemeen. Klik op de kleine knop aan de linker zijde van het tekstvak om te schakelen tussen de optie Coördinaten en de optie extents Bereiken dat de coördinaten van het huidige meest linksonder en meest rechtsboven gelegen punten van de kaart weergeeft, in kaarteenheden, als u verschuift en in- en uitzoomt.

Naast de weergave van de coördinaten vindt u de weergave Schaal. Het geeft de schaal weer van het kaartvenster. Als u in- of uitzoomt toont QGIS u de huidige schaal. Er is ook een keuzelijst die u in staat stelt te kiezen uit vooraf gedefinieerde en aangepaste schalen om toe te wijzen aan de kaartweergave.

Rechts naast de weergave van de schaal kunt u een huidige rotatie met de klok mee definiëren voor uw kaartweergave in graden.

Aan de rechterkant van de Statusbalk staat een klein keuzevak dat kan worden gebruikt om tijdelijk te voorkomen dat lagen worden gerenderd naar de kaartweergave (zie gedeelte Renderen).

Rechts van de functies voor renderen vindt u het pictogram projectionDisabled Huidige CRS: met de code van EPSG van het huidige project-CRS. Door hierop te klikken kunt u eigenschappen voor Gelijktijdige CRS-transformatie gebruiken voor het huidige project instellen en een ander CRS toewijzen aan de kaartweergave.

Tenslotte opent de knop messageLog Berichten het Paneel Logboekmeldingen dat u informeert over het onderliggende proces (opstarten van QGIS, laden van plug-ins, verwerken van gereedschappen...)

Tip

Rekenen met de correcte schaal in het kaartvenster

Wanneer u QGIS start is het standaard CRS WGS 84 (epsg 4326) en worden graden als eenheid gebruikt. Dat betekent dat QGIS een coördinaat in uw laag zal interpreteren als zijnde gespecificeerd in graden. U kunt ofwel de eenheid handmatig deze instelling wijzigen, bijv. naar meters, op de tab Algemeen onder Project ‣ Projecteigenschappen of u kunt het pictogram projectionDisabled Huidige CRS gebruiken zoals hierboven weergegeven, In het laatste geval worden de eenheden ingesteld op wat de projectie voor het project specificeert (bijv. +units=us-ft).

Onthoud dat de keuze voor het CRS nij het opstarten kan worden ingesteld in Extra ‣ Opties ‣ CRS.