Outdated version of the documentation. Find the latest one here.

Algemeen gereedschap

Snelkoppelingen toetsenbord

QGIS heeft voor veel functies standaard snelkoppelingen. Deze worden in het gedeelte Menubalk beschreven. Daarnaast geeft de menu optie Instellingen ‣ Snelkoppelingen bewerken ... de mogelijkheid om de standaard snelkoppelingen aan te passen en nieuwe snelkoppelingen toe te voegen voor mogelijkheden in QGIS.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Snelkoppelingen definiëren

Configureren is erg eenvoudig. Selecteer een mogelijkheid uit de lijst en klik op :

  • [Aanpassen] en druk op de nieuwe combinatie die wilt toewijzen als de nieuwe snelkoppeling

  • [Niet gebruiken] om een toegewezen snelkoppeling te verwijderen

  • of [Als standaard zetten] om de snelkoppeling terug te zetten naar zijn originele en standaardwaarde.

Als u tevreden bent met uw configuratie, kunt u deze opslaan als een XML-bestand en laden in een andere installatie van QGIS.

Contextuele help

Wanneer u hulp nodig heeft over een specifiek onderwerp, kunt u in veel dialoogvensters/menu’s op de knop [Help] drukken. De knop Help in plug-ins die door derden zijn ontwikkeld, kunnen verwijzen naar speciaal daarvoor gemaakte webpagina’s.

Renderen

QGIS zal standaard automatisch de zichtbare lagen opnieuw opbouwen, renderen, als het kaartvenster wordt vernieuwd. De gebeurtenissen die het verversen van het kaartvenster starten bevatten:

  • Toevoegen van een laag

  • Verschuiven of in/uitzoomen

  • Het wijzigen van de grootte van het venster van QGIS

  • Het wijzigen van de zichtbaarheden van een laag of lagen

QGIS geeft u op een aantal manieren controle over het proces van renderen.

Schaalafhankelijk renderen

Met schaalafhankelijk tonen is het mogelijk om de minimum en maximum schalen in te stellen waarbij een laag zichtbaar zal zijn. Open het dialoogvenster Eigenschappen door te dubbelklikken op een laag in de legenda om schaalafhankelijk tonen in te stellen. Op de tab Algemeen kan men het keuzevak checkbox Gebruik schaalafhankelijk tonen selecteren en vervolgens de minimum en maximum schaalwaarden invullen waarbinnen de laag zichtbaar zal zijn.

U kunt de schaalwaarden bepalen door eerst op het kaartvenster in te zoomen tot u het niveau ziet dat u wilt gebruiken en dan de bijbehorende schaal af te lezen van de statusbalk van QGIS.

Controle over het renderen van de kaart

Renderen van het kaartvenster kan op verschillende manieren worden beheerd, zoals hieronder beschreven :

Uitstellen van het renderen

Om het renderen uit te stellen, vink het keuzevak checkbox Render uit in de rechter benedenhoek van de statusbalk. Wanneer het keuzevak checkbox Render niet is aangevinkt, zal QGIS het kaartvenster niet opnieuw opbouwen bij de gebeurtenissen die beschreven zijn in Renderen. Voorbeelden voor wanneer u het opnieuw renderen wilt uitstellen bevatten:

  • Na het toevoegen van veel kaartbladen wilt u deze eerst van symbologie voorzien en de tekenvolgorde instellen

  • Na het toevoegen van een of meer grote lagen wilt u eerst instellen bij welke schalen deze getekend zal worden

  • Na het toevoegen van één of meer grote lagen, wilt u eerst inzoomen op een bepaald gebied voordat dit getekend wordt

  • Een combinatie van bovenstaande redenen

Het weer selecteren van checkbox Render zal onmiddellijk het opnieuw opbouwen van het kaartvenster starten.

Instellen optie Laag toevoegen

Er is ook de mogelijkheid om het kaartvenster niet opnieuw te tekenen na het toevoegen van nieuwe lagen. Het keuzevak dat de zichtbaarheid weergeeft van de nieuw toegevoegde laag, is dan niet geselecteerd. Kies, om deze optie in te stellen, de menuoptie Extra ‣ Opties ‣ en open de tab Rendering. Deselecteer het keuzevak checkbox Standaard zullen nieuw toegevoegde lagen aan de kaart direct worden afgebeeld. De zichtbaarheid van elke laag die hierna wordt toegevoegd, zal standaard uit staan in de legenda.

Het renderen stoppen

Druk op de ESC-toets om het tekenen van de kaart te stoppen. Dit zal het tekenen van de kaart onderbreken waarbij de kaart slechts gedeeltelijk getekend is. Het kan even duren voordat het tekenen stopt na het indrukken van de ESC-toets.

Notitie

Het is momenteel niet mogelijk om het renderen te stoppen - dit is tijdelijk uitgeschakeld in de op Qt4 gebouwde versie aangezien dit kon leiden tot problemen als het stoppen van de toepassing.

Beïnvloeden van de kwaliteit van het renderen

QGIS heeft een optie waarmee de kwaliteit van het renderen kan worden beïnvloedt. Kies de menuoptie Extra ‣ Opties, klik op de tab Rendering en (de)selecteer checkbox Maak de lijnen minder rafelig ten koste van de tijd die het tekenen kost.

Het renderen versnellen

Er zijn enkele instellingen die u in staat stellen de snelheid van het renderen te beïnvloeden. Kies de menuoptie Extra ‣ Opties en klik op de tab Rendering en selecteer of deselecteer de volgende keuzevakken:

  • checkbox Gebruik de cache voor het tekenen indien mogelijk om het hertekenen te versnellen

  • checkbox Het gelijktijdig renderen van kaartlagen gebruik makende van meerdere CPU’s en selecteer dan checkbox Maximum CPU’s om te gebruiken.

  • De kaart rendert op de achtergrond in een afzonderlijke afbeelding en elke checkbox Kaart-update interval zal de inhoud van deze (niet op het scherm) afbeelding worden genomen om de zichtbare weergave op het scherm bij te werken. Als het renderen echter sneller is voltooid dan deze duur, zal het direct worden weergegeven.

  • Met checkbox Vereenvoudiging van objecten standaard inschakelen voor nieuw toegevoegde lagen vereenvoudigt u de geometrie van objecten (minder knopen) en als resultaat worden zij sneller weergegeven. Onthoud dat u daardoor ook inconsistenties kunt tegenkomen door het renderen.

Kleur selecteren

Het dialoogvenster Randkleur selecteren zal verschijnen als u op het pictogram selectColor drukt om een kleur te kiezen. De mogelijkheden van dit dialoogvenster zijn afhankelijk van de status van het keuzevak voor de parameter Eigen dialoogvenster voor kleurkeuze gebruiken in het menu Extra ‣ Opties ‣ Algemeen. Indien geselecteerd is het gebruikte dialoogvenster dat van het gebruikte besturingssysteem. Anders wordt de voor QGIS aangepaste kleurenkiezer gebruikt.

Dit dialoogvenster heeft vier verschillende tabs die u in staat stellen een kleur te kiezen vanuit colorBox Kleurverloop, colorWheel Kleurenwiel, colorSwatches Kleurenwaaiers of colorPicker Kleur overnemen (niet beschikbaar onder osx)..

Welke methode u ook gebruikt, de geselecteerde kleur wordt altijd beschreven door middel van kleurschuiven voor HSV- (Hue, Saturation, Value) en RGB- (Rood, Groen, Blauw) waarden. Er is ook een schuifbalk voor Doorzichtbaarheid om het niveau van transparantie in te stellen. In de linker onderkant van het dialoogvenster kunt u een vergelijking zien tussen de Huidige en de Oude kleur die u momenteel selecteert en in de rechter onderkant heeft u de optie om de kleur die u zojuist heeft bewerkt toe te voegen aan een kleurenknop.

Figure color selector 1:

../../../_images/color_selector_ramp.png

Tab Kleurenbalk

Tip

Optie voor dynamisch wijzigen van de kleur bij live updaten

Selecteer de optie Gebruik kleurkeuze-dialogen die direct updaten in de Algemene instellingen om de kleur te krijgen toegepast op items als u de parameters voor de kleur wijzigt in het dialoogvenster voor aangepaste kleur kiezen in QGIS.

Met colorBox Kleurverloop of met colorWheel Kleurenwiel kunt u naar alle mogelijke kleurcombinaties bladeren. Er zijn echter ook andere mogelijkheden. Door colorSwatches Kleurenwaaiers te gebruiken kunt u kiezen uit een vooraf gedefinieerde lijst. Deze geselecteerde lijst is gevuld met één van de drie methoden:

  • Recente kleuren,

  • Standaardkleuren, een gebruiker gedefinieerde lijst met kleuren, ingesteld in het menu Extra ‣ Opties ‣ Kleuren

  • of Projectkleuren,een gebruikergedefinieerde lijst van kleuren, ingesteld in het menu Project ‣ Projecteigenschappen ‣ Standaard stijlen.

Figure color selector 2:

../../../_images/color_selector_recent_colors.png

Tab Kleurenwaaiers

Een andere optie is om colorPicker Kleur overnemen te gebruiken die u in staat stelt een monster van een kleur te nemen van onder uw muiscursor vanuit een willekeurig deel van QGIS of zelfs vanuit een andere toepassing door op de spatiebalk te drukken. Onthoud echter dat Kleur overnemen afhankelijk is van uw besturingssysteem en dat momenteel OSX niet wordt ondersteund.

Tip

Snel kleur kiezen + kleuren kopiëren/plakken

U kunt snel kiezen uit Recente kleuren, uit Standaardkleuren of eenvoudig een kleur kopiëren of plakken door te klikken op de pijl naar beneden dat het vak met kleuren selectColor volgt.

Figure color selector 3:

../../../_images/quick_color_selector.png

Menu Snel kleur kiezen

Meng-modi

QGIS biedt verschillende opties voor speciale effecten voor renderen met deze gereedschappen die u eerder mogelijk alleen kende vanuit grafische programma’s. Meng-modi kan worden toegepast op lagen, op objecten, maar ook op items van Printvormgeving:

  • Normaal: Dit is de standaard mengmodus die het alfakanaal van de bovenliggende pixel mengt met de pixel eronder. De kleuren worden niet gemengd.

  • Lichter maken: Deze selecteert de maximum waarden van de pixels van de voor- en achtergrond. Het resultaat is vaak ruw, grof en kartelig.

  • Screen: Lichte pixels van de bronlaag worden getekend over de doellaag, terwijl dat niet gebeurd met donkere pixels. Deze modus is geschikt voor het mengen van de textuur van de ene laag met die van een andere laag. (bijv.: U kunt deze gebruiken om schaduwen van heuvels in te brengen in een andere laag).

  • Dodge: Hoe lichter de bovenliggende pixel is des te feller en met meer kleur zullen de onderliggende pixels getoond worden. Dus:, heldere pixels bovenop zorgen er voor dat de verzadiging en helderheid van de onderliggende pixels wordt verhoogt. Dit werkt het beste wanneer de bovenste pixels niet te fel zijn, anders wordt het resultaat te extreem.

  • Toevoegen: Deze mengmodus telt de waarde van de pixel van de ene laag op bij de andere. Wanneer de waarden boven 1 uitkomen (in het geval van RGB), zal die pixel wit worden. Deze modus is geschikt om bepaalde objecten op te laten lichten en zo te markeren.

  • Donkerder maken: De resulterende pixel die overblijft is die met de laagste waarde van de pixels van voor- en achtergrond. Net zoals bij de modus Lichter maken, neigt het resultaat naar ruw, grof en gekarteld.

  • Vermenigvuldigen: Deze vermenigvuldigt de waarden voor elke pixel van de toplaag met die van de onderliggende laag. Het resultaat is een donkerder kaart.

  • Branden: Donkere kleuren in de toplaag zorgen ervoor dat onderliggende lagen ook donkerder worden. Branden kan worden gebruikt om de kleuren van onderliggende lagen bij te stellen.

  • Overlay: Combineert de mengmodi vermenigvuldigen en screen. In het resulterend kaartvenster worden de lichtere delen lichter en donkere delen donkerder.

  • Zacht licht: Lijkt erg op overlay, maar in plaats van de combinatie vermenigvuldigen/screen wordt de combinatie branden/dodge gebruikt. Het effect waarnaar gestreefd wordt is dat van het schijnen van een zacht licht op het kaartvenster.

  • Hard licht: Hard licht lijkt op de modus overlay. Deze moet ervoor zorgen dat het lijkt of er een sterk licht schijnt op het kaartvenster.

  • Verschil: Verschil haalt de waarde van de bovenste pixel van de onderliggende pixel af of omgekeerd, zodat er altijd een positieve waarde ontstaat. Het mixen met zwart levert geen wijziging, omdat waarden voor alle kleuren nul zijn.

  • Aftrekken: Deze mengmodus trekt eenvoudig de waarde van de pixel van de ene laag af van de andere. Wanneer waarden van pixels negatief worden zullen die pixels zwart worden getoond.

Zoomen en verschuiven

QGIS verschaft gereedschappen om in te zoomen op het gebied van uw interesse of het te verschuiven.

Naast het gebruik van de pictogrammen pan Kaart verschuiven en zoomIn Inzoomen / zoomOut Uitzoomen op de werkbalk kunt u ook het muiswiel, de spatiebalk en de pijltjestoetsen gebruiken.

Zoomen en de kaart verschuiven met het muiswiel

U kunt met ingedrukt muiswiel, binnen de kaart, het kaartvenster verplaatsen en in- en uitzoomen met het muiswiel. Wanneer u met het muiswiel naar u toe rolt (achteruit) zal het kaartvenster uitzoomen en wanneer u het muiswiel van u af rolt (vooruit) inzoomen. De plaats van de muiscursor zal het centrum van het gebied zijn waarop u in- of uitzoomt. U kunt het gedrag voor het in- en uitzoomen met het muiswiel aanpassen op de tab Kaartgereedschap in het menu Extra ‣ options Opties.

De kaart verschuiven met de pijltjestoetsen

U kunt het kaartvenster verplaatsen met behulp van de pijltjestoetsen. Plaats de muiscursor in het kaartvenster en druk op de rechter- of de linker pijltjestoets om het kaartvenster naar het oosten of het westen te verplaatsen. Met de pijltjestoets omhoog of omlaag kunt u het kaartvenster naar het noorden of naar het zuiden verplaatsen.

U kunt ook de spatiebalk gebruiken om tijdelijke verschuivingen te maken van de kaart. De toetsen PgUp en PgDown van uw toetsenbord zorgen voor in- en uitzoomen op de weergave van de kaart.

Meten

QGIS heeft vier manieren voor het meten van geometrieën:

  • de interactieve meetgereedschappen measure,

  • meten in de calculateField Veldberekening,

  • afgeleide metingen in het gereedschap Objecten identificeren,

  • en een vector analysegereedschap: Vector ‣ Geometrie gereedschappen ‣ Geometriekolommen exporteren/toevoegen

Meten werkt binnen geprojecteerde coördinatensystemen (bijv. UTM) en niet geprojecteerde gegevens. De eerste drie gereedschappen voor meten gedragen zich gelijk aan de globale projectinstellingen:

Als “Gelijktijdige CRS transformatie gebruiken” is ingeschakeld is de standaard metriek voor meten - anders dan voor de meeste andere programma’s voor GIS - ellipsoïde, door gebruik te maken van de ellipsoïde die is gedefinieerd in Bestand ‣ Projecteigenschappen ‣ Algemeen. Dit is beide waar als geografische en geprojecteerde coördinatensystemen zijn gedefinieerd voor het project. Als u het geprojecteerde / planimetrische gebied of afstand wilt berekenen met behulp van Cartesiaanse berekeningen, moet de ellipsoïde voor berekeningen zijn ingesteld op “Geen / Planimetrisch” (Bestand ‣ Projecteigenschappen ‣ CRS). Echter, met een geografisch (= niet geprojecteerd) CRS gedefinieerd voor de gegevens en het project, zullen metingen van gebied en afstand ellipsoïde zijn. Als “Gelijktijdige CRS transformatie gebruiken” is uitgeschakeld, is de metriek voor de metingen planimetrisch als het project coördinatensysteem is geprojecteerd en ellipsoïde wanneer het project coördinatensysteem niet geprojecteerd / geografisch is.

Echter, noch het gereedschap Objecten identificeren noch Veldberekening zullen uw gegevens transformeren naar het CRS van het project, vóór het meten. Indien u dit wilt bereiken dient u het vector analysegereedschap te gebruiken: Vector ‣ Geometrie gereedschappen ‣ Geometriekolommen exporteren/toevoegen. Hier zijn metingen standaard planimetrisch, behalve als u voor ellipsoïde meten kiest.

Lengte, gebieden of interactieve hoeken meten

Alle modules voor meten gebruiken de instellingen voor snappen van de module Digitaliseren. Dit is nuttig als u langs lijnen wilt meten of gebieden in vectorlagen.

Selecteer, om een meetgereedschap te kiezen, measure en kies vervolgens het gereedschap dat u wilt gebruiken.

Standaard meet measure Lijn meten van QGIS de echte afstanden tussen twee punten overeenkomstig een gedefinieerde ellipsoïde. U kunt de kleur van het elastiek en de voorkeuren voor uw te gebruiken eenheden voor maateenheden( meters of voet) en hoeken (graden, radialen en decimale graden) instellen. Het gereedschap stelt u in staat te klikken op punten in het kaartvenster. Elke lengte van de lijnsegmenten als ook de totale lengte wordt getoond in het venster voor meten. Klik met rechts om het meten te beëindigen. Onthoud dat u interactief de maateenheden kunt wijzigen in het dialoogvenster Meten. Dat heeft voorrang boven de Voorkeur maateenheden in de opties. Er is een gedeelte Info in het dialoogvenster dat weergeeft welke instellingen voor het CRS worden gebruikt tijdens het berekenen van de maten.

Figure Measure 1:

../../../_images/measure_line.png

Afstanden meten

|mArea| Vlak opmeten: U kunt ook oppervlakten meten. In het menu Opmeten komt dan de totale oppervlakte te staan. Ook in dit geval zal het meetgereedschap naar objecten van de geselecteerde vectorlaag proberen te snappen, tenminste wanneer voor die laag een tolerantie voor ‘snappen’ is ingesteld. (Zie Het instellen van de toleranties voor snappen en Zoekradius). Stel, wanneer u nauwkeurig een oppervlakte wil opmeten, dan eerst voor een laag de tolerantie voor ‘snappen’ in en selecteer dan vervolgens die laag. Vervolgens kunt u nu precies oppervlakten inmeten waarbij elke muisklik naar de dichtstbijzijnde hoek of lijn van de geselecteerde laag zal springen, wanneer deze zich binnen de ingestelde tolerantie bevindt.

Figure Measure 2:

../../../_images/measure_area.png

Vlak opmeten

measureAngle Hoek opmeten: U kunt ook hoeken opmeten. De muisaanwijzer verandert in een kruisje. Klik om het eerste segment te tekenen van de hoek die u wilt opmeten, verplaats dan de cursor om de gewenste hoek te tekenen. De meting wordt getoond in een pop-up dialoogvenster.

Figure Measure 3:

../../../_images/measure_angle.png

Hoek opmeten

Selecteren en deselecteren van objecten

De QGIS werkbalk bevat functionaliteit waarmee men objecten kan selecteren in het kaartvenster. Om een of meerdere objecten te selecteren klik op select en kies de gewenste functie voor selecteren:

  • selectRectangle Objecten selecteren per gebied of met een enkele klik om object(en) ofwel met één enkele klik of met een rechthoek te selecteren

  • selectPolygon Objecten met een polygoon selecteren

  • selectFreehand Objecten selecteren door er overheen te tekenen

  • selectRadius Objecten met cirkel selecteren

Klik op deselectAll Objecten uit alle lagen deselecteren om de huidige selectie van geselecteerde objecten ongedaan te maken.

expressionSelect Objecten met een expressie selecteren geeft de mogelijkheid om objecten te selecteren met behulp van een dialoogvenster voor een expressie. Bekijk het hoofdstuk Expressies voor enkele voorbeelden.

Gebruikers kunnen geselecteerde objecten opslaan in een Nieuwe geheugenlaag of een Nieuwe vectorlaag met behulp van Bewerken ‣ Objecten kopiëren ... en Bewerken ‣ Plak objecten als ... waarbij kan worden gekozen uit verschillende methodes.

Data-bepaalde ‘override’ instellen

Naast vele opties in het dialoogvenster Laag-eigenschappen of instellingen in de Printvormgeving, kunt u een pictogram dataDefined Data-bepaalde override zien. Dankzij expressies gebaseerd op attributen van lagen of instellingen van items, vooraf gebouwde of aangepaste functies en variabelen,, stelt dit gereedschap u in staat om een dynamische waarde voor de betrokken parameter in te stellen. Indien ingeschakeld wordt de waarde die wordt teruggegeven door dit widget toegepast op de parameter ongeacht de normale waarde daarvan (keuzevak, tekstvak, schuifbalk...).

Klikken op het pictogram dataDefined Data defined override geeft weer:

  • een Omschrijving ... die aangeeft of het is ingeschakeld, welke invoer verwacht wordt, geldig type voor invoer en de huidige definitie,

  • een item voor de lijst van het beschikbare Veldtype,

  • een item om de beschikbare Variabele te vermelden,

  • knop Bewerken ... om de te gebruiken expressie te maken of te bewerken,

  • knoppen Plakken en Kopiëren,

  • knop Leegmaken om de instellingen te verwijderen.

Tip

Wanneer de optie data-bepaalde override juist is ingesteld is het pictogram geel dataDefineOn of dataDefineExpressionOn; als het verbroken is is het pictogram rood dataDefineError of dataDefineExpressionError.

Parameters die kunnen worden gebruikt met data-bepaalde gereedschappen zijn:

  • Parameters voor stijl en symbolen

  • Parameters voor labels

  • Parameters voor Printvormgeving

Objecten identificeren

Met Objecten identificeren kan men zichtbare objecten op de kaart bevragen waarbij de attributen worden getoond in een resultaatvenster. Gebruik Beeld ‣ Objecten identificeren of druk op Ctrl+Shift+I, of klik op het pictogram identify Objecten identificeren op de werkbalk Attributen om objecten te identificeren.

QGIS biedt twee manieren om objecten te identificeren met het gereedschap identify Objecten identificeren:

  • klik met links zal objecten identificeren overeenkomstig de modus die is ingesteld in het paneel Identificatieresultaten

  • klik met rechts zal alle gevangen objecten ophalen vanaf de zichtbare lagen. Dit zal een contextmenu openen dat de gebruiker in staat zal stellen de objecten nauwkeuriger te identificeren.

Wanneer u meerdere object(en) selecteert, dan zal Identificatieresultaten een overzicht geven van de informatie over de geklikte object(en). De standaard weergave is een boomweergave waarbij het eerste item de naam is van de laag en de kinderen daarvan en de daarvan geïdentificeerde object(en). Elk object wordt beschreven door de naam van een veld met de waarde daarvan. Dit veld is het veld dat is geselecteerd in Eigenschappen ‣ Weergeven. Daarna wordt alle informatie van het object getoond.

Dit venster kan worden aangepast om aangepaste velden te tonen, maar het zal standaard drie soorten informatie weergeven:

  • Acties: acties kunnen worden toegevoegd aan het venster Identificatieresultaten. De actie wordt uitgevoerd door te klikken op het label van de actie. Standaard wordt slechts één actie toegevoegd, namelijk het weergeven van het formulier Object bekijken om te bewerken. U kunt meer acties definiëren in het dialoogvenster Laag-eigenschappen.

  • Afgeleid: Deze informatie wordt berekend of afgeleid van andere informatie. Dit omvat de ID van het object, de lengte of perimeter en het gebied in kaarteenheden, afhankelijk van zijn geometrie, het aantal ruimtelijke delen en het aantal delen waarop geklikt is in het geval van een meervoudige geometrie, het aantal hoekpunten in het object en het aantal dichtstbijzijnden tot het punt waarop geklikt werd. Het rapporteert ook de waarden van de coördinaten X en Y (en Z/M indien beschikbaar) van zowel het punt waarop geklikt werd als het dichtst bij het punt gelegen punt.

  • Attributen gegevens: Dit is de lijst met attribuutvelden en de waarden daarvan voor het object waarop werd geklikt.

Figure Identify 1:

../../../_images/identify_features.png

Dialoogvenster Objecten identificeren

Aan de bovenkant van het venster staan zeven pictogrammen:

  • expandTree Boom uitklappen

  • collapseTree Boom inklappen

  • expandNewTree Standaard gedrag om te definiëren of de volgende informatie over geïdentificeerde objecten moet zijn uit- of ingeklapt

  • propertyItem Formulier Object bekijken

  • deselectAll Resultaat wissen

  • editCopy Geselecteerde rijen naar klembord kopiëren

  • filePrint Geselecteerde HTML antwoord afdrukken

Aan de onderzijde van het venster staan de combinatievakken Modus en Weergave. Met het combinatievak Modus kunt u definiëren van welke lagen objecten zouden moeten worden gedefinieerd:

  • ‘Huidige laag’ : alleen objecten van de geselecteerde laag worden geïdentificeerd. De laag mag niet zichtbaar zijn in het kaartvenster.

  • ‘Van bovenaf, stop bij eerste’: voor alleen objecten vanaf de bovenste zichtbare laag.

  • ‘Van bovenaf’: voor alle objecten uit de zichtbare lagen. De resultaten worden in het paneel weergegeven.

  • en ‘Laagselectie’: opent een contextmenu waar de gebruiker de laag selecteert van waarop de objecten moeten worden geïdentificeerd. Werkt als een klik met rechts. Alleen de gekozen objecten zullen in het paneel met resultaten worden weergegeven.

De Weergave kan worden ingesteld als ‘Boom’, ‘Tabel’ of ‘Grafiek’. Weergaven ‘Tabel’ en ‘Grafiek’ kunnen alleen worden ingesteld voor rasterlagen.

Het gereedschap Objecten identificeren stelt u ook in staat om checkboxAuto openen formulier. Indien geselecteerd zal, elke keer als één enkel object is geïdentificeerd, QGIS een formulier weergeven dat de attributen weergeeft. Dit is een handige manier om snel de attributen van een object te bewerken.

Andere functies kunnen worden gevonden in het contextmenu van het geïdentificeerde item. Vanuit het contextmenu kunt u bijvoorbeeld:

  • Het formulier Object bekijken

  • Naar object inzoomen

  • Kopieer object: Kopieer alle geometrie en attributen van het object

  • Object selecteren aan/uit: Voegt geïdentificeerde object toe aan selectie

  • Attribuutwaarde kopiëren: Kopieert alleen de waarde van het attribuut waar u op klikt

  • Objectattributen kopiëren: Kopieert de attributen van het object

  • Wis resultaat: Het scherm Identificatieresultaten wordt leeggemaakt

  • Wis accentueren: Verwijdert objecten die geaccentueerd waren op de kaart

  • Alles accentueren

  • Laag accentueren

  • Activeer laag: Kies een laag die moet worden geactiveerd

  • Laag-eigenschappen: Opent het menu Laag-eigenschappen

  • Alles uitklappen

  • Alles inklappen

Gereedschappen voor annotatie

Het gereedschap textAnnotation Tekst annotatie op de werkbalk Attributen geeft de mogelijkheid om opgemaakte tekst in een tekstballon ergens in het kaartvenster van QGIS te plaatsen. Gebruik het gereedschap Tekst annotatie en klik ergens in het kaartvenster.

Figure annotation 1:

../../../_images/annotation.png

Dialoogvenster Annotatie tekst

Wanneer u dubbelklikt op de ballontekst heeft u verschillende mogelijkheden om deze aan te passen. Er is een tekstvak waar u de tekst mee kunt aanpassen. U kunt kiezen of de tekst verbonden is aan een kaartlocatie of dat deze steeds op dezelfde plaats blijft staan ook al verschuift u de kaart. U kunt het tekstitem verplaatsen door de markering op de kaart of de ballontekst naar een andere plek te slepen. De gebruikte pictogrammen zijn onderdeel van het thema GIS, maar worden standaard ook in de andere thema’s gebruikt.

Het gereedschap annotation Annotatie verplaatsen stelt u in staat om de annotatie in het kaartvenster te verplaatsen.

HTML-annotaties

De gereedschappen formAnnotation HTML-annotatie op de werkbalk Attributen geven de mogelijkheid om de inhoud van een HTML-bestand in een tekstballon ergens in het kaartvenster van QGIS te plaatsen. Gebruik het gereedschap HTML-annotatie en klik ergens in het kaartvenster en voer in het dialoogvenster een pad in naar het HTML-bestand.

SVG-annotaties

Het gereedschap saveAsSVG SVG-annotatie op de werkbalk Attributen geeft de mogelijkheid om een SVG-symbool in een ballon ergens in het kaartvenster van QGIS te plaatsen. Gebruik het gereedschap SVG-annotatie en klik ergens in het kaartvenster en voeg in het dialoogvenster een pad in naar het SVG-bestand.

Formulier-annotaties

Aanvullend kunt u ook uw eigen formulieren voor annotaties maken en gebruiken. Het gereedschap formAnnotation Formulier-annotatie kan gebruikt worden om de attributen van een vectorlaag te tonen in een speciaal daarvoor door uzelf ontworpen formulier in de QT designer (zie figure_custom_annotation). Dit is een soortgelijk formulier als dat wat wordt gebruikt voor het gereedschap Objecten identificeren, maar weergegeven als annotatie. De volgende video van Tim Sutton https://youtu.be/0pDBuSbQ02o?t=2m25s laat het gebruik ervan zien.

Figure annotation 2:

../../../_images/custom_annotation.png

Aangepast Qt designer formulier voor annotatie

Notitie

Wanneer u de toetsencombinatie Ctrl+T gebruikt terwijl een gereedschap Annotatie actief is (annotatie verplaatsen, tekst-annotatie, formulier-annotatie), dan wisselt het tekstitem van zichtbaar naar onzichtbaar en andersom.

Favoriete plaatsen

De Engelse term ’Spatial Bookmarks’ is vrij vertaald naar ’Favoriete plaatsen’. Zij stellen u in staat een geografische locatie als “Favoriete plaats” te markeren en er later naar terug te keren. Favoriete plaatsen worden bewaard op de computer, wat betekent dat zij beschikbaar zijn voor elk project op die computer.

Favoriete plaats maken

Een favoriete plaats maken:

  1. Zoom in op een gebied naar keuze.

  2. Selecteer de menuoptie Beeld ‣ Nieuwe Favoriete plaats ... of druk op Ctrl-B. Het paneel Favoriete plaatsen opent met de nieuw gemaakte Favoriete plaats.

  3. Geef een beschrijvende naam waaronder u de Favoriete plaats op wilt slaan (tot 255 tekens).

  4. Klik op Enter om de Favoriete plaats toe te voegen of klik ergens anders.

Men kan meerdere favorieten onder dezelfde naam opslaan.

Werken met Favoriete plaatsen

Kies, om een Favoriete plaats te gebruiken of te beheren, de menuoptie Beeld ‣ Favoriete plaatsen tonen. Het paneel Favoriete plaatsen stelt u in staat om:

  • Naar Favoriete plaats te verplaatsen: selecteer de gewenste favoriete plaats en klik dan op:guilabel:Naar Favoriete plaats verplaatsen. U kunt ook naar een Favoriete plaats zoomen door er op te dubbelklikken.

  • Favoriete plaats te verwijderen: selecteer de favoriete plaats en klik op Favoriete plaats verwijderen. Bevestig uw keuze.

  • Favoriete plaatsen te im- of exporteren: U kunt het keuzemenu Favoriete plaatsen im-/exporteren in het dialoogvenster Favoriete plaatsen gebruiken om uw favoriete plaatsen te delen of tussen computers te verplaatsen. Alle Favoriete plaatsen worden verplaatst.

Projecten in een project

Wanneer u de inhoud van een ander project wilt opnemen in een project kunt u kiezen voor Kaartlagen ‣ Kaartlagen en groepen inbedden.

Lagen inbedden

Het volgende dialoogvenster maakt het inbedden van lagen vanuit een ander project mogelijk. Hier volgt een voorbeeld:

  1. Gebruik browseButton om een ander project te selecteren van de gegevensset Alaska.

  2. Selecteer het projectbestand relations.qgs. U kunt de inhoud van het project zien (zie figure_embed_dialog).

  3. Druk op Ctrl en klik op de lagen airports en regions. Druk op [OK]. De geselecteerde lagen zijn nu toegevoegd in de legenda en het kaartvenster.

Figure Nesting 1:

../../../_images/embed_dialog.png

Lagen en groepen selecteren om in te bedden

Alhoewel u de ingebedde lagen kunt bewerken, kunt u eigenschappen als Stijl en Labels van deze lagen niet aanpassen.

Ingebedde lagen verwijderen

Klik met de rechter muisknop op de ingebedde laag en selecteer removeLayer Verwijder.

Decoraties

De kaartdecoraties van QGIS zijn het Grid, het label Copyright, de Noordpijl en de schaalbalk. Ze worden gebruikt om de kaart te ‘decoreren’ door cartografische elementen toe te voegen.

Grid

transformed Grid geeft de mogelijkheid om een coördinatenraster en annotaties van coördinaten toe te voegen aan het kaartvenster.

Figure Decorations 1:

../../../_images/grid_dialog.png

Dialoogvenster Grid

  1. Selecteer via het menu Beeld ‣ Decoraties ‣ Grid. Het dialoogvenster opent (zie figure_decorations_1).

  2. Activeer het keuzevak checkbox Grid activeren en stel de definities voor het raster in, overeenkomstig de geladen lagen in het kaartvenster.

  3. Activeer het keuzevak checkbox Teken labels en stel de definities voor annotatie in overeenkomstig de lagen die geladen zijn in het kaartvenster.

  4. Klik op [Apply] om te verifiëren of het eruit ziet zoals u verwachtte of op [OK] als u tevreden bent.

Noordpijl

northArrow Noordpijl plaatst een simpele Noordpijl op de kaart. Momenteel is er slechts één stijl beschikbaar. U kunt de hoek van de Noordpijl instellen of de richting automatisch laten instellen door QGIS. Wanneer er voor wordt gekozen om QGIS zelf de richting te laten bepalen, zal deze de richting zo goed mogelijk bepalen. Voor het plaatsen van de Noordpijl zijn er vier opties, die overeenkomen met de vier hoeken van het kaartvenster. U kunt de plaatsing van het item verfijnen door een horizontale en/of verticale Marge vanaf rand in te stellen. Deze waarden mogen een afstand zijn in Millimeter of Pixels of ingesteld als Percentage van de breedte of hoogte van het kaartvenster.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

Dialoogvenster Noordpijl

Schaalbalk

scaleBar Schaalbalk plaatst een eenvoudige schaalbalk op de kaart. De stijl en de plaats kan worden aangepast evenals de labels van de Schaalbalk.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

Dialoogvenster Schaalbalk

QGIS ondersteunt alleen het tonen van de schaal in dezelfde eenheid als die van de kaart. Wanneer de eenheid van uw lagen in meters zijn kunt u niet een schaalbalk maken in feet. Zo kunt u ook geen schaalbalk in meters tonen wanneer de gebruikte kaart als eenheid in graden wordt getoond.

Een schaalbalk toevoegen:

  1. Selecteer via het menu Beeld ‣ Decoraties ‣ Schaalbalk. Het dialoogvenster opent (zie figure_decorations_4).

  2. Zorg ervoor dat het keuzevak checkbox Schaalbalk gebruiken is aangevinkt.

  3. Kies de stijl in de keuzelijst Schaalbalkstijl selectString .

  4. Kies de kleur van de balk via het kleurenpalet achter Schaalbalkkleur selectColor of laat deze op de standaard kleur zwart staan

  5. Stel de Grootte van de balk selectNumber in.

  6. Optioneel, selecteer checkbox Klik automatisch naar gehele getallen tijdens het aanpassen van de grootte om waarden weer te geven die gemakkelijk te lezen zijn.

  7. Kies de plaatsing met de keuzelijst Plaatsing selectString.

  8. U kunt de plaatsing van het item verfijnen door een horizontale en/of verticale Marge vanaf rand in te stellen. Deze waarden mogen een afstand zijn in Millimeter of Pixels of ingesteld als Percentage van de breedte of hoogte van het kaartvenster.

  9. Klik op [Apply] om te verifiëren of het eruit ziet zoals u verwachtte of op [OK] als u tevreden bent.

Tip

Decoratie-instellingen

Wanneer u een project van QGIS opslaat, zullen de wijzigingen die u heeft gemaakt aan Grid, Noordpijl, Schaalbalk en Copyright mee worden opgeslagen in het projectbestand en teruggezet worden bij het openen van het project.

Authenticatie

QGIS heeft een faciliteit om gegevens voor authenticatie o een beveiligde manier op te slaan/op te halen. Gebruikers kunnen hun gegevens beveiligd opslaan in configuraties voor authenticatie, die in ene draagbare database worden opgeslagen, kunnen worden toegepast op server- of databaseverbindingen, en waarnaar veilig kan worden verwezen door hun tokens voor ID in project- of instellingsbestanden. Bekijk voor meer informatie Authenticatiesysteem.

Een hoofdwachtwoord moet worden ingesteld bij het initialiseren van het systeem voor authenticatie en de draagbare database daarvan.

Laag in bestand opslaan

Lagen (raster of vector) kunnen in ene andere indeling worden opgeslagen met de mogelijkheid Opslaan als... in het contextmenu van de laag (door met rechts te klikken op de laag in de Lagenboom) of in het menu Laag ‣ Opslaan als....

Het dialoogvenster Opslaan als geeft verscheidene parameters weer om het gedrag te wijzigen bij het opslaan van de laag. Algemene parameters (raster en vector) zijn:

  • Formaat

  • Opslaan als

  • CRS
  • Voeg opgeslagen bestand toe aan de kaart

  • Bereik (mogelijke waarden zijn laag, kaartbereik of aangepast bereik)

  • Opties Maken (voor raster), Laag of Aangepast (voor vector) die u in staat stellen enkele geavanceerde opties te wijzigen. gevorderde gebruikers kunnen de documentatie bekijken in de documentatie van gdal-ogr.

Sommige parameters zijn echter specifiek voor raster- en vectorindelingen:

  • Rasterspecifieke parameters:

    • Resolutie (horizontaal en verticaal)

    • Pyramiden maken

    • Modus uitvoer (ruwe gegevens of gerenderde afbeelding)

  • Vectorspecifieke parameters:

    • Codering

    • Alleen geselecteerde objecten opslaan

    • Geen attributen aanmaken

    • Exporteren van symbologie: kan voornamelijk worden gebruikt voor exporteren naar DXF en voor alle bestandsindelingen die objectstijlen voor OGR beheren (zie opmerking hieronder) zoals DXF, KML, tab-bestandsindelingen:

      • Geen symbologie: standaard stijl van de toepassing die de gegevens leest

      • Objectsymbologie: stijl opslaan met OGR objectstijlen (zie opmerking hieronder)

      • Symboollaagsymbologie: opslaan met OGR objectstijlen (zie opmerking hieronder) maar exporteer dezelfde geometrie meerdere keren als er meerdere symbologie symboollagen worden gebruikt

    • Geometrie:

      • naar multi-geometrie forceren,

      • Z-dimensie toevoegen,

      • een geometriekolom toevoegen of verwijderen met de keuzelijst. Dit is niet gekoppeld aan het huidige type geometrie van de laag. U kunt ene lege geometriekolom toevoegen aan een attributentabel, de geometriekolom van een ruimtelijke laag verwijderen.

Notitie

OGR objectstijlen zijn een manier om ene stijl direct op te slaan in de gegevens als een verborgen attribuut. Slechts sommige indelingen kunnen dit soort informatie afhandelen. KML, DXF en TAB-bestandsindeling zijn dergelijke indelingen. Voor gevorderde gebruikers, u kunt het document OGR Feature Styles specification lezen.

Notitie

Over DXF-bestanden

Vectorlagen kunnen worden geëxporteerd naar DXF-bestanden met behulp van ene ander gereedschap, DXF Export ... in Project. Het venster stelt de gebruiker in staat het laagbestand te kiezen, de modus voor de symbologie (bekijk de opmerking hierboven), de schaal voor de symbologie, de codering, de voorkeuze voor de zichtbaarheid en de lagen die moeten worden opgenomen in het DXF-bestand.

Als een optie kunt u checkbox Titel van laag gebruiken als naam indien ingesteld of Exporteer objecten die overlappen met het huidige kaartbereik gebruiken.

Variabelen gebruiken voor dynamische inhoud

U kunt aangepaste variabelen definiëren om te gebruiken in expressies. Variabelen kunnen worden gedefinieerd op het globale niveau van de toepassing, niveau van het project, niveau van de laag en op het niveau van de lay-out. Net als met gestapelde regels van CSS kunnen variabelen worden overschreven - bijv een variabele op het niveau van het project zal elke variabele die is ingesteld op het niveau van de toepassing overschrijven. U kunt deze variabelen gebruiken om tekenreeksen van tekst of andere aangepaste expressies te bouwen met behulp van het teken @ vóór de naam van de variabele. Bijvoorbeeld in de lay-out een label maken met deze inhoud:

This map was made using QGIS [% @qgis_version %]. The project file for this
map is: [% @project_path %]

Zal het label renderen zoals hier:

This map was made using QGIS 2.14. The project file for this map is:
/gis/qgis-user-conference-2015.qgs

U kunt globale variabelen beheren vanuit het menu Extra ‣ Opties en variabelen op het niveau van het project vanuit Projecteigenschappen (inclusief het toevoegen van uw eigen aangepaste variabelen).

Figure Variables dialog 2:

../../../_images/options_variables.png

Variabele op projectniveau bewerken

Notitie

u kunt meer informatie en voorbeelden hier vinden: Exploring variables in QGIS 2.12, part 1, part 2 en part 3.