Outdated version of the documentation. Find the latest one here.

QGIS Configureren

QGIS is zeer goed te configuren via het menu Extra. Kies tussen Panelen, Werkbalken, Projecteigenschappen, Opties en Aanpassingen.

Notitie

QGIS volgt richtlijnen voor het bureaublad voor de locatie van opties en items voor projecteigenschappen. Als consequentie, gerelateerd aan het door u gebruikte besturingssysteem, zou de locatie van enkele items die hierboven beschreven worden, kunnen liggen in het menu Project of in Extra.

Projectinstellingen

In het venster voor eigenschappen van het project onder nix Instellingen ‣ Projecteigenschappen (kde) of nix osx win Project ‣ Projecteigenschappen (Gnome, OS X of Windows), kunt u projectspecifieke opties instellen.

  • In het menu Algemeen, laten de Algemene instellingen u:

    • een titel opgeven voor het project naast het bestandspad voor het project

    • de te gebruiken kleur kiezen voor objecten als zij geselecteerd zijn

    • de achtergrondkleur kiezen: de kleur die moet worden gebruikt voor het kaartvenster

    • instellen of het pad naar de lagen in het project moet worden opgeslagen als absoluut (volledig) of als relatief ten opzichte van de locatie van het projectbestand. U zou een voorkeur kunnen hebben voor relatieve paden als zowel de lagen als de projectbestanden moeten kunnen worden verplaatst of gedeeld, of als het project toegankelijk is voor computers op verschillende platformen.

    • kiezen voor vermijden van artefacten wanneer project wordt gerenderd als kaarttegels. Onthoud dat het selecteren van deze optie kan leiden tot vertragingen in de uitvoering.

    Berekenen van gebieden en afstanden is een veel voorkomend gebeuren in GIS. Deze waarden zijn echter verbonden aan de onderliggende instellingen voor projectie. Het frame Meten laat u deze parameters beheren. U kunt feitelijk kiezen voor:

    • de te gebruiken ellipsoïde: het mag een bestaande zijn, een aangepaste (u dient de waarden voor de assen semi-major en de semi-minor in te stellen) of None/Planimetric.

    • de Eenheden voor metingen van afstanden voor lengte en omtrek en de Eenheden voor meten van gebied. Deze instellingen, die standaard zijn ingesteld op de eenheden die zijn ingesteld in de Opties van QGIS maar die dan overschrijven voor het huidige project, worden gebruikt in:

      • Balk voor bijwerken van veld Attributentabel

      • Berekeningen in Veldberekening

      • De uit het gereedschap Objecten identificeren afgeleide waarden voor lengte, omtrek en gebied

      • De weergegeven standaard eenheid in het dialoogvenster Meten

    De Weergave coördinaat stelt u in staat de indeling van eenheden te kiezen en aan te passen die worden gebruikt om de muiscoördinaat weer te geven in de Statusbalk en de afgeleide coördinaten die worden weergegeven via het gereedschap Objecten identificeren.

    Tenslotte kunt u een lijst Projectschalen definiëren, die de globale vooraf gedefinieerde schalen overschrijft.

Figure General Menu:

../../../_images/project_general.png

Tab Algemeen van het dialoogvenster Projecteigenschappen

  • Op de tab CRS kunt u het gewenste CRS voor dit project instellen. Daarnaast kunt u instellen dat gelijktijdige CRS transformatie moet worden gebruikt wanneer er lagen aanwezig zijn met een afwijkend CRS.

  • Met het menu Lagen identificeren stelt u in (of uit) welke lagen zullen reageren op het gereedschap Objecten identificeren. Standaard zijn alle lagen te bevragen.

  • Het menu Standaard stijlen laat u standaard stijlen instellen die worden toegekend aan nieuwe toegevoegde lagen die geen .qml-stijlenbestand hebben. U kunt ook de standaard transparantie die moet worden toegekend aan nieuwe lagen instellen en of symbolen willekeurige kleuren toegekend moeten krijgen. Er is ook een aanvullend gedeelte waar u specifieke kleuren voor het lopende project kunt definiëren. U kunt de toegevoegde kleuren vinden in de keuzelijst van het dialoogvenster Kleuren dat aanwezig is in elke renderer.

  • De tab OWS Server geeft de mogelijkheid om informatie in te vullen die meegegeven wordt door de WMS en WFS Capabilities die door QGIS Server terug wordt gegeven plus het bereik, het maximale bereik van de kaart en het beperken van mogelijke Coördinaten ReferentieSystemen.

  • Het menu Macro’s kan worden gebruikt om functies in Python te schrijven die als module mee worden opgeslagen in het projectbestand van QGIS. Momenteel zijn er drie macro’s beschikbaar: “openProject()”, “saveProject()” en “closeProject()”.

Figure Macro Menu:

../../../_images/macro.png

Macro-instellingen in QGIS

  • Het menu Relaties wordt gebruikt om 1:n join relaties mee vast te leggen. Deze relaties worden vastgelegd in het dialoogvenster Projectinstellingen. Wanneer een eigenschap is aangemaakt voor een laag, dan zal het objectformulier een nieuw item bevatten waarmee de gerelateerde objecten zichtbaar getoond worden. Dit biedt een krachtige manier waarmee bijvoorbeeld de onderhoudshistorie van een leiding of een wegdeel kan worden vastgelegd. Lees meer over de ondersteuning van 1:n relaties in Een tot veel-relaties maken.

Opties

options Sommig basisopties voor QGIS kunnen worden geselecteerd met behulp van het dialoogvenster Opties. Selecteer de menuoptie Extra ‣ options Opties. De tabs waar u uw opties kunt aanpassen worden hieronder beschreven.

Menu Algemeen

Applicatie

  • Selecteer Stijl (Herstart QGIS nodig) selectString en kies tussen ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ en ‘Cleanlooks’ (nix).

  • Definieer het Thema UI selectString. Momenteel is alleen ‘standaard’ beschikbaar.

  • Geef de Icoongrootte selectString.

  • Geef het Lettertype. Kies tussen het keuzerondje radioButtonOn Qt standaard of een door de gebruiker gedefinieerd lettertype.

  • Wijzig de Zichtbaarheidstijd voor berichten of dialogen selectString.

  • checkbox Verberg het openingsscherm tijdens opstarten

  • checkbox Tips tonen tijdens het opstarten

  • checkbox Titels groepsvak vet weergeven

  • checkbox Groepsvakken in stijl van QGIS

  • checkbox Eigen dialoogvensters voor kleurkeuze gebruiken

  • checkbox Gebruik direct bijwerken dialoogvenster kleurkeuze

  • checkbox Aangepaste stijl zijbalk

  • checkbox Experimentele ondersteuning roteren kaartvenster (opnieuw starten vereist)

Projectbestanden

  • Open project bij het opstarten selectString (kies tussen ‘Nieuw’. ‘Meest recente’ en ‘Specifiek’). Wanneer men kiest voor ‘Specifiek’ blader naar het project met browseButton waarmee opgestart moet worden.

  • checkbox Maak een nieuw project op basis van het standaardproject. Men heeft de mogelijkheid om het huidige project in te stellen als standaardproject met de knop [Huidige project als standaardproject opslaan] of terug te gaan naar het standaardproject met de knop [Standaard terugzetten]. Men kan een map (Sjabloonmap) instellen waar de sjablonen voor het project komen te staan met de knop [Bladeren]. Er zal een sjabloonproject gekozen kunnen worden bij de menu optie Project ‣ Nieuw van sjabloon, indien eerst het keuzevak checkbox Maak een nieuw project op basis van het standaardproject is geactiveerd en vervolgens het project in de map met sjablonen is opgeslagen.

  • checkbox Geef een waarschuwing om project en gewijzigde gegevensbronnen op te slaan indien nodig

  • checkbox Vraag om bevestiging wanneer een laag wordt verwijderd

  • checkbox Geef een waarschuwing bij het openen van een projecbestand uit een oudere versie van QGIS

  • Macro’s toestaan selectString. U kunt daarbij kiezen tussen ‘Nooit’, ‘Vragen’, ‘Alleen voor deze sessie’ en ‘Altijd (wordt afgeraden)’.

Systeemmenu

Systeem

De systeem-omgevingsvariabelen kunnen nu worden bekeken en deze kunnen ook worden geconfigureerd via het onderdeel systeemvariabelen (zie figuur figure_environment_variables). Dit is erg handig voor besturingssystemen zoals die op de Mac, waarbij voor een grafische applicatie de omgevingsvariabelen zoals men die kan opvragen via de terminal niet dezelfde hoeven te zijn als die door het programma worden gebruikt. Dit kan ook handig zijn om omgevingsvariabelen te zetten die gebruikt worden door externe programma’s die o.a. gebruikt worden door de Toolbox van Processing, bijv. SAGA, GRASS, en die ook gebruikt kan worden zodat bepaalde onderdelen van de broncode meer uitvoer genereren voor het opsporen van fouten (debugging).

  • checkbox Gebruik aangepaste systeemvariabelen (herstart noodzakelijk - voeg scheidingstekens toe). U kunt nieuwe systeemvariabelen [Toevoegen] en met [Verwijderen] deze weer verwijderen. Bestaande omgevingsvariabelen worden getoond met Huidige systeemvariabelen –>, en het is mogelijk om alleen de specifieke systeemvariabelen voor QGIS te tonen met het keuzevak checkbox Alleen QGIS-specifieke variabelen tonen.

Figure System Environment:

../../../_images/sys-env-options.png

Systeem omgevingsvariabelen in QGIS

Plug-in paden

[Toevoegen] of [Verwijderen] Pad(en) om naar aanvullende C++ plug-inbibliotheken te zoeken

Menu Databronnen

Object-attributen en tabel

  • checkbox Open de attributentabel in een ‘dock-window’ (QGIS herstart vereist)

  • checkbox Kopiëer geometrie in WKT formaat van attributen tabel. Wanneer de functie copySelected Kopiëer geselecteerde rijen naar klembord in het dialoogvenster Attributentabel gebruikt wordt, dan zullen ook de coördinaten van de punten of hoekpunten worden gekopieerd naar het klembord.

  • Gedrag attributentabel selectString. Er zijn drie mogelijkheden: ‘Alle attributen tonen’, ‘Geselecteerde objecten tonen’ en ‘Op kaart zichtbare objecten tonen’

  • :guilabel:`Rijcache attributentabel ` selectNumber. Deze rijcache zorgt ervoor dat de laatste geladen aantal N rijen met attributen in de cache (=geheugenruimte) worden opgeslagen, zodat het werken met de attributentabel sneller gaat. De gegevens in de cache worden verwijderd bij het sluiten van de attributentabel.

  • Weergave van waarden NULL Hier kunt u , voor velden die een waarde NULL bevatten, een andere waarde opgeven om te laten zien.

Omgang met databron

  • Zoek naar geldige items in het browser dock selectString. U kunt kiezen tussen ‘Extensie controleren’ en ‘Bestandsinhoud controleren’.

  • Zoek naar de inhoud van gecomprimeerde (.zip) bestanden in het browser-dock selectString. ‘Nee’, ‘Basisscan’ en ‘Volledige scan’ zijn mogelijk.

  • Suggereer raster sublagen tijdens het openen. Enkele rasterformaten ondersteunen sublagen — deze worden subdatasets in GDAL genoemd. Een voorbeeld is het netCDF bestandsformaat - wanneer er veel netCDF-variabelen zijn, dan ziet GDAL elke variabele als een subdataset. De optie wordt gebruikt om controle te krijgen hoe om te gaan, tijdens het laden van, met een rasterbestand dat sublagen bevat. De volgende keuzes zijn mogelijk:

    • ‘Altijd’: Altijd vragen (wanneer er sublagen aanwezig zijn)

    • ‘Indien nodig’: Vragen indien de laag geen bandlagen maar wel sublagen heeft

    • ‘Nooit’: Nooit vragen, laad geen sublagen

    • ‘Laad alles’: Nooit vragen, gewoon alle sublagen laden

  • checkbox Vastgelegde shapefile codering negeren. Als een shapefile informatie over gebruikte karaktercodering bevat, zal die door QGIS worden genegeerd.

  • checkbox PostGIS-lagen toevoegen door dubbelklikken en selectie in uitgebreide modus

  • checkbox PostGIS lagen toevoegen door dubbelklikken en selectie in uitgebreide modus

  • checkbox Expressies aan zijde van de server uitvoeren indien mogelijk

  • checkbox Automatische transactiegroepen maken indien mogelijk (Experimenteel). Als deze modus is ingeschakeld, zullen alle (Postgres) lagen uit dezelfde database worden gesynchroniseerd in hun status Bewerken, d.i. indien één laag in modus Bewerken wordt gezet, worden ze dat allemaal, indien één laag worden bewerkt of indien één laag wordt teruggedraaid, dan zullen alle andere dat ook. Ook worden, in plaats van de wijzigingen van bewerkingen lokaal te bufferen, zij direct verzonden naar een transactie in de database die wordt doorgevoerd als de gebruiker klikt op Laag opslaan.

Verborgen browserpaden

Dit widget vermeldt alle mappen die u wilt verbergen in het paneel Browser. Verwijderen van de naam van een map maakt die beschikbaar in het paneel Browser.

Menu Rendering

Gedrag bij renderen

  • checkbox Standaard zullen nieuwe toegevoegde lagen aan de kaart direct worden afgebeeld

  • checkbox Gebruik de cache voor het tekenen indien mogelijk om het hertekenen te versnellen

  • checkbox Het gelijktijdig renderen van kaartlagen gebruik makende van meerdere CPU’s.

  • checkbox Max. CPU’s om te gebruiken

  • Kaart-update interval (standaard 250 ms)

  • checkbox Objectvereenvoudiging standaard toepassen voor nieuwe lagen

  • Vereenvoudigings-drempelwaarde

  • checkbox Vereenvoudigen bij de bron indien mogelijk

  • Maximale schaal waarbij de laag vereenvoudigd zou moeten worden

Rendering kwaliteit

  • checkbox Maak de lijnen minder rafelig ten koste van de tijd dat het tekenen kost

Rasters

  • met RGB-band selectie kan men het nummer voor de Rode, de Groene en de Blauwe band opgeven.

Contrastverhoging

  • Enkelbands grijs selectString. Een enkelbands grijs kan de waarden hebben ‘Geen Stretch’ ‘Stretch tot MinMax’, ‘Stretch en Clip tot MinMax’ en ook ‘Clip naar MinMax’.

  • Multiband kleur (byte/band) selectString. Mogelijke keuzes zijn ‘Geen Stretch’, ‘Stretch tot MinMax’, ‘Stretch en Clip tot MinMax’ en ‘Clip naar MinMax’.

  • Multiband kleur (>byte/band) selectString. Mogelijke keuzes zijn ‘Geen stretch’, ‘Stretch tot MinMax’, ‘Stretch en Clip tot MinMax’ en ‘Clip naar MinMax’.

  • Bereik (minimum/maximum) selectString. Mogelijke keuzes zijn ‘Cumulatieve telling deel van pixels’, ‘Minimum/Maximum’, ‘Gemiddelde +/- standaardafwijking’

  • Bereik Cumulatieve telling van pixels

  • Vermenigvuldigingsfactor voor standaardafwijking

Debuggen

  • checkbox Kaartvenster update

Menu Kleuren

Dit menu stelt u in staat aangepaste kleuren toe te voegen die u kunt vinden in elk dialoogvenster Kleuren van de renderers. U zult op de tab een aantal vooraf gedefinieerde kleuren zien: u kunt ze allemaal verwijderen of bewerken. Meer nog, u kunt de kleur die u wilt toevoegen en enkele bewerkingen kopiëren en plakken uitvoeren. Tenslotte kunt u de verzameling kleuren exporteren als een gpl-bestand of ze importeren.

Menu Kaartvenster en Legenda

Standaard waarden kaart (worden door projectwaarden overschreven)

  • Wijzig de Selectiekleur en de Achtergrondkleur.

Legenda lagen

  • Dubbelklik actie in legenda selectString. Kies tussen ‘Open laag-eigenschappen’ of ‘Open attributentabel’ voor de dubbelklik actie.

  • De volgende Legenda onderdeel stijlen zijn mogelijk:

    • checkbox Laagnamen in hoofdletters

    • checkbox Laagnamen vet

    • checkbox Groepnamen vet

    • checkbox Toon classificatie-attribuutnamen

    • checkbox Rasterpictogrammen aanmaken (kan langzaam zijn)

Menu Kaartgereedschap

Dit menu biedt enkele opties met betrekking tot het gedrag van het gereedschap Objecten identificeren.

  • Zoekradius voor het identificeren en weergeven van tips op de kaart kan worden opgegeven als percentage van de kaartbreedte. Het percentage bepaalt hoe ver van een object kan worden geklikt waarbij het object nog als resultaat wordt getoond.

  • Accentkleur stelt u in staat op te geven in welke kleur objecten, die worden geïdentificeerd, worden getoond wanneer deze worden geaccentueerd.

  • Buffer bepaalt een bufferafstand die moet worden gerenderd vanaf de omtrek van het geaccentueerde object.

  • Minimale breedte bepaalt hoe dik de rand van een geaccentueerd object moet worden weergegeven.

Meetgereedschap

  • Geef de Rubberband kleur voor het meetgereedschap

  • Zet het aantal te gebruiken Decimale posities

  • checkbox Vasthouden aan basiseenheid om niet automatisch grote getallen te converteren (bijv. meters naar kilometers)

  • Voorkeur eenheden voor afstand radioButtonOn (‘meters’, ‘voet’, ‘zeemijlen’ ‘graden’ of ‘kaarteenheden’ )

  • Voorkeur eenheden voor gebied radioButtonOn (‘vierkante meters’, ‘vierkante voet’, ‘vierkante yards’ ‘hectaren’ of ‘kaarteenheden’ )

  • Voorkeur hoekeenheden radioButtonOn (‘Graden’, ‘Radialen’ of ‘Gon/gradians’, ‘minuten van de boog’)

Schuiven en zoomen

  • Zet het Muiswielgedrag op selectString (‘Zoom’, ‘Zoom en recenter’, ‘Zoom naar muis cursor’, ‘Niets’)

  • Stel de Zoomfactor in voor het muiswiel

Vooraf ingestelde schalen

Hier vindt u een lijst met vooraf gedefinieerde schalen. met de knoppen signPlus en signMinus kunt u uw persoonlijke schalen toevoegen of verwijderen. U kunt ook schalen importeren of exporteren vanuit/naar een .XML-bestand. Onthoud dat u steeds de mogelijkheid heeft om uw wijzigingen te verwijderen en de vooraf gedefinieerde lijst te herstellen.

Printvormgeving

Standaardwaarden opmaak

Hier kunt u het Standaard lettertype definiëren.

Ruitennetweergave

  • Definieer de Ruitennetstijl selectString uit (‘Doorgetrokken’, ‘Stippels’ of ‘Kruisjes’)

  • Definieer de Gridkleur

Standaarden voor raster en hulplijnen

  • Definieer de Rasterafstand selectNumber

  • Definieer de Ruitennetverspringing selectNumber voor x en y

  • Definieer de ‘Snap’ tolerantie selectNumber

Menu Digitaliseren

Objectcreatie

  • checkbox Geen attribuut-popup’s na het maken van elk kaartobject tonen

  • checkbox Laatst ingevoerde attribuutwaarden gebruiken

  • Valideer geometrieën tijdens het bewerken van complexe lijnen/polygonen bestaande uit veel punten kan dat dit het tekenen vertragen. Dit komt omdat de standaard validatie in QGIS veel tijd kan kosten. Om het tekenen te versnellen tijdens het bewerken kan men ook kiezen voor de GEOS geometrie validatie (beschikbaar vanaf GEOS 3.3) of om het valideren uit te zetten. De validatie met GEOS is veel sneller maar het nadeel is dat deze alleen het eerste probleem met geometrie rapporteert.

Rubberband

  • Wijzig de Lijndikte en Lijnkleur van de Rubberband

Snapping

  • checkbox Snapping instellingen openen in een ‘dock-window’ (QGIS herstart vereist)

  • Definieer de Standaard ‘snap’-modus selectString (‘Naar hoekpunt’, Naar segment’, ‘Naar hoekpunt en segment’, ‘Uit’)

  • Stel de Standaard ‘snapping’-tolerantie in kaarteenheden of pixels in

  • Zet de Zoekradius voor aanpassingen hoekpunten in ‘kaarteenheden’ of ‘pixels’

Hoekpunten

  • checkbox Markeringen alleen gebruiken voor geselecteerde objecten heeft betrekking op het tonen ervan

  • Wijzig de Markeringstijl naar selectString (‘Kruis’ (standaard), ‘Semi-transparante cirkel’ of ‘Niets’)

  • Definieer de Grootte markering

Lijnverspring-gereedschap

De volgende 3 opties hebben betrekking op de tool offsetCurve Verspring curve, zie Geavanceerd digitaliseren. Met de verschillende instellingen, is het mogelijk om de vorm van de versprongen lijn te beïnvloeden. Deze opties zijn beschikbaar sinds GEOS 3.3.

  • Verbindingsstijl

  • Segmenten per Kwadrant

  • Maximale puntlengte bij scherpe hoeken

Menu GDAL

GDAL is een functiebibliotheek voor het uitwisselen van rasterbestanden. Op deze tab kunt u Opties bewerken voor maken en Opties bewerken voor piramiden voor de rasterindelingen. U kunt hier ook instellen welke GDAL driver gebruikt moet worden voor welke rasterindeling, aangezien in sommige gevallen er meer dan één GDAL driver beschikbaar is voor een rasterindeling.

Menu CRS

Standaard CRS voor nieuwe projecten

  • radioButtonOff Gelijktijdige herprojectie uitschakelen

  • radioButtonOn Gelijktijdige CRS-transformatie gebruiken wanneer lagen verschillende CRS hebben

  • radioButtonOff Gelijktijdige CRS-transformatie gebruiken

  • Selecteer een CRS voor Altijd dit CRS gebruiken voor nieuwe projecten

CRS voor nieuwe kaartlagen

Dit deel geeft de mogelijkheid om aan te geven of er een actie volgt nadat een nieuwe laag is aangemaakt, of wanneer een laag zonder CRS wordt geladen.

  • radioButtonOff Vraag om CRS

  • radioButtonOff Gebruik huidige project CRS

  • radioButtonOff Standaard CRS gebruiken

Standaard datumtransformaties

  • checkbox Datumtransformatie vragen indien geen standaard is gedefinieerd

  • Wanneer u heeft gewerkt met de gelijktijdige CRS-transformatie kunt u het resultaat in het onderliggende scherm zien. U kunt informatie vinden over ‘Bron CRS’ en ‘Doel CRS’ maar ook over ‘ Bron datumtransformatie’ en ‘Doel datumtransformatie’.

Menu Locale

  • checkbox Systeemlocale negeren en Te gebruiken locale

  • Informatie over actieve systeemlocale

Authenticatie

Op de tab Authenticatie kunt u configuraties voor authenticatie instellen en certficiaten voor PKi beheren. Bekijk Authenticatiesysteem voor meer details.

Menu Netwerk

Algemeen

  • Definieer een WMS zoekadres, het standaardadres is http://geopole.org/wms/search?search=\%1\&type=rss

  • Definieer de Time out voor netwerkaanvragen (ms) - standaard ingesteld op 60000

  • Definieer Standaard verlooptijd van WMSC/WMTS tegels (uur) - standaard is 24

  • Geef Maximaal aantal pogingen bij tile request fouten

  • Geef de User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-instellingen in QGIS

Cache-instellingen

Wijzig de Map en Grootte voor de cache.

  • checkbox Gebruik een proxy voor internettoegang en geef de ‘Host’, ‘Poort’, ‘Gebruiker’ en ‘Wachtwoord’.

  • Stel het Proxy type selectString in naar behoefte.

    • Default proxy: Proxy wordt bepaald gebaseerd op de huidige gebruikte proxy-instellingen van de toepassing

    • Socks5Proxy: Een algemene proxy voor elk soort verbinding. Ondersteunt TCP, UDP, directe verbinding op poort (binnenkomende connecties) en authenticatie.

    • HttpProxy: Gebruikt de “CONNECT” opdracht, ondersteund alleen uitgaande TCP connecties; ondersteund autenticatie.

    • HttpCachingProxy: Gebruikt normale HTTP opdrachten, deze is alleen geschikt bij het gebruik van HTTP requests

    • FtpCachingProxy: Gebruikt een FTP proxy, is alleen goed bruikbaar in de context van FTP requests.

Men kan URL’s uitsluiten door deze toe te voegen aan het tekstinvoervak onder de proxy-instellingen (zie Figure_Network_Tab).

Wanneer u meer gedetailleerde informatie nodig hebt over de verschillende instellingen voor proxy’s, verwijzen we naar de handleiding voor de QT functiebibliotheek documentatie zie http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tip

Proxy’s gebruiken

Het gebruiken van proxy’s kan soms erg lastig zijn. Gebruik de ‘trial and error’ methode om de verschillende typen proxy te testen en controleer of deze voor u werken.

Je kunt de opties wijzigen naar behoefte. Enkele aanpassingen hebben echter een herstart van QGIS nodig voordat deze effectief worden.

  • nix Instellingen worden opgeslagen in een tekstbestand: $HOME/.config/QGIS/QGIS2.conf

  • osx De instellingen worden opgeslagen in: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Instellingen worden opgeslagen in de windows registry onder: HKEY\CURRENT_USER\Software\QGIS\qgis

Aanpassingen

Het dialoogvenster Aanpassingen laat u bijna elk element (de)activeren in de gebruikersinterface van QGIS. Dit kan erg handig zijn u uw eindgebruikers een ‘lichte’ versie van QGIS wilt verschaffen, die alleen bestaat uit de pictogrammen. menu’s en panelen die zij nodig hebben.

Notitie

Vóórdat de wijzigingen worden doorgevoerd, dient u QGIS opnieuw te starten.

Figure Customization 1:

../../../_images/customization.png

Dialoogvenster Aanpassingen

Selecteren van het keuzevak checkbox Aanpassingen toestaan is de eerste stap op weg naar anpassingen in QGIS. Dit schakelt het paneel voor de werkbalken en widgets van waaruit u enkele items voor de GUI kunt deselecteren en dus uitschakelen.

Het te configureren item kan zijn:

  • een Menu of enige van diens sub-menu’s uit de Menubalk

  • een volledig Paneel (bekijk Panelen en werkbalken)

  • de Statusbalk beschreven in Statusbalk of enige van de items daarvan

  • een Werkbalk: de gehele balk of enkele van zijn pictogrammen

  • of enig widget uit enig dialoogvenster in QGIS: label, knop, combinatievak...

Met select Schakel naar widgets in de hoofdapplicatie kunt u klikken op een item in d einterface van QGIS die u wilt verbergen en QGIS deselecteert automatisch het overeenkomende item in het dialoogvenster Aanpassingen.

Als u de configuratie eenmaal heeft ingesteld, klik dan op [Toepassen] of [Ok] om uw wijzigingen te valideren. Deze configuratie wordt die welke standaard wordt gebruikt door QGIS bij de volgende keer opstarten.

De aanpassingen kunnen ook worden opgeslagen in een .ini-bestand met behulp van de knop fileSave Opslaan naar bestand. Dit is ene handige manier om een algemene interface van QGIS te delen met meerdere gebruikers. Klik gewoon op fileOpen Laden uit bestand op de doelcomputer om het .ini-bestand te importeren. U kunt ook gereedschappen voor de opdrachtregel uitvoeren en de verscheidene instellingen voor verschillende gebruiksgevallen ook opslaan.

Tip

Eenvoudig opslaan van vooraf gedefinieerd QGIS

De initiële configuratie voor de QGIS GUI kan worden hersteld op één van de onderstaande manieren:

  • deselecteren van de optie checkbox Aanpassingen toestaan in het dialoogvenster Aanpassingen of klik op de knop selectAllTree Alles selecteren

  • drukken op de knop [Herstellen] in het frame QSettings onder het menu Extra ‣ Opties, tab System

  • starten van QGIS vanaf de opdrachtregel met de volgende regel als opdracht qgis --nocustomization

  • setting to false the value of UI ‣ Customization ‣ Enabled variable under Settings ‣ Options menu, Advanced tab.

In de meeste gevallen dient u QGIS opnieuw te starten om de wijzigingen doorgevoerd te krijgen.