15.3. 편집 작업

QGIS는 OGR, SpatiaLite, PostGIS, MSSQL Spatial 및 Oracle Spatial 벡터 레이어와 테이블을 편집할 수 있는 다양한 기능을 보유하고 있습니다.

참고

GRASS 레이어 편집 과정은 조금 다릅니다. 자세한 내용은 GRASS 벡터 레이어 디지타이즈 및 편집하기 를 참조하세요.

주의

병행 편집

QGIS 이번 버전은 사용자가 피처를 편집하는 도중에 다른 사용자가 동일한 피처를 편집하고 있지는 않은지 추적하지 않습니다. 마지막에 저장하는 변경 사항이 적용될 것입니다.

Validating Edits

Continuous validation can be activated on a layer basis in the Layer Properties ► Digitizing tab. More at 디지타이즈 작업 속성.

15.3.1. Setting the snapping tolerance and search radius

Under the Settings ► Options… ► Digitizing menu, QGIS provides a number of parameters to configure default behaviour of editing tools. More information at 디지타이즈 작업 설정.

For optimal and accurate editing of vector layer geometries, we need to set an appropriate value of snapping tolerance and search radius for features vertices. The Snapping group provides related options, namely handling of the snapping tolerance and the search radius.

  • Snapping tolerance: When you add a new vertex or move an existing one, the snapping tolerance is the distance QGIS uses to search for the closest vertex or segment you are trying to connect to. If you are not within the snapping tolerance, QGIS will leave the vertex where you release the mouse button, instead of snapping it to an existing vertex or segment.

    The tolerance setting affects all tools that work with snapping and applies by default to new layers and projets. It can however be overridden at layer level (see Snapping and Digitizing Options).

  • Search radius: Search radius for vertex edits is the distance QGIS uses to search for the vertex to select when you click on the map. If you are not within the search radius, QGIS will not find and select any vertex for editing.

스냅 허용 오차 및 검색 반경은 map units 또는 pixels 로 설정되기 때문에, 알맞은 설정값을 찾기 위해 시행착오를 거쳐야 할 수도 있습니다. 허용 오차를 너무 길게 설정하면, QGIS가 틀린 꼭짓점에 스냅할 수도 있습니다. 특히 대량의 인접한 꼭짓점들을 다루고 있을 경우엔 말입니다. 검색 반경을 짧게 설정할수록, 사용자가 원하는 꼭짓점을 찾기 힘들어질 것입니다.

15.3.2. Snapping and Digitizing Options

Global snapping and digitizing settings (snapping mode, tolerance value, and units…) can be overridden in the project from the Project ► Snapping Options… menu. In the Snapping and Digitizing Options, you can also configure some other properties (snapping layers, scale limit, topology…) The guilabel:Snapping Toolbar gives access to most of these features.

By default, snapping is disabled in a project until you press the snapping Enable snapping button or press S. The snapping mode, tolerance value, and units can also be configured in this toolbar.

15.3.2.1. Snapping properties

스냅을 활성화할 레이어(들)를 선택하는 데 다음 세 가지 옵션이 있습니다:

  • All layers: 프로젝트에 있는 가시화된 모든 레이어를 선택합니다. 모든 꼭짓점 그리고/또는 선분에 포인터를 스냅시키는 빠르고 간단한 설정입니다. 대부분의 경우 이 스냅 모드를 사용하면 충분하지만, 수많은 벡터 레이어를 가진 프로젝트의 경우 사용에 주의를 요합니다. 성능에 영향을 줄 수도 있기 때문입니다.

  • Current layer: 활성화된 레이어만 선택합니다. 편집 중인 레이어 내부의 위상(topology)의 일관성을 보장할 수 있는 편리한 방법입니다.

  • Advanced Configuration: allows you to enable and adjust snapping mode, tolerance and units, overlaps and scales of snapping on a layer basis (see 그림 15.87). If you need to edit a layer and snap its vertices to another, make sure that the target layer is checked and increase the snapping tolerance to a higher value. Snapping will not occur to a layer that is not checked in the snapping options dialog.

As for snapping mode, you can choose between Vertex, Segment, Area, Centroid, Middle of Segments and Line Endpoints.

QGIS는 스냅 의 유형에 따라 서로 다른 스냅 아이콘을 표시해드립니다:

../../../_images/snap_vertex_icon.png
../../../_images/snap_segment_icon.png
../../../_images/snap_intersection_icon.png

꼭짓점에 스냅하기: 상자 아이콘

선분에 스냅하기: 모래시계 아이콘

교차점에 스냅하기: 가위표 아이콘

Note that it is possible to change the color of these icons in the Digitizing part of the global settings.

허용 오차를 map units 또는 pixels 로 설정할 수 있습니다. pixels 로 설정하면, 맵 축척을 변경하더라도 일정하게 스냅할 수 있다는 장점이 있습니다. 일반적으로 10~12픽셀이면 괜찮은 값이지만, 사용자 스크린의 해상도에 따라 달라집니다. 맵 단위로 설정하면 허용 오차를 실제 지표 거리와 비례하도록 만들 수 있습니다. 예를 들어 요소들 사이에 최소 거리를 두어야 한다면, 꼭짓점들을 서로 너무 가깝지 않게 추가하는 데 이 옵션이 유용할 것입니다.

../../../_images/editProjectSnapping.png

그림 15.87 스냅 옵션 (고급설정 모드)

참고

기본적으로, 가시화된 (레이어 심볼이 “No symbols” 인 경우를 제외하고, 피처 스타일이 표시된) 피처에만 스냅할 수 있습니다. Settings ► Options ► Digitizing 탭에 있는 unchecked Enable snapping on invisible features 옵션을 체크하면 가시화되지 않은 피처에도 스냅할 수 있게 됩니다.

스냅 기본값 활성화

Settings ► Options ► Digitizing 탭에서 모든 새 프로젝트가 기본적으로 스냅을 활성화시키도록 설정할 수 있습니다. 기본 스냅 모드, 허용 오차 값, 그리고 단위도 설정할 수 있습니다. 여기서 설정한 값들이 Snapping Options 대화창에 표시될 것입니다.

15.3.2.2. 교차점 스냅 활성화

또다른 옵션은 snappingIntersection snapping on intersection 을 선택하는 것입니다. 이 옵션은 스냅이 활성화된 레이어의 도형 교차점에 ─ 설령 교차점에 꼭짓점이 없는 경우라도 ─ 스냅할 수 있게 해줍니다.

15.3.2.3. 축척 범위에 따라 스냅 제한하기

몇몇 경우 스냅 작업이 매우 느려질 수도 있습니다. 일부 레이어에 있는 피처의 용량 때문에 계산하고 유지해야 하는 인덱스가 많아지기 때문입니다. 이를 위해 맵 뷰가 적절한 축척 범위일 경우에만 스냅 작업을 활성화시키는 몇몇 파라미터가 존재합니다. 이 파라미터들을 설정하면 그리기 작업에 적절한 축척인 경우에만, 리소스를 많이 소비하더라도 스냅 작업에 관련된 인덱스 계산을 하도록 할 수 있습니다.

Project ► Snapping Options… 메뉴에서 스냅 작업 축척 제한을 환경 설정합니다. 축척에 따른 스냅 작업 제한은 Advanced Configuration 모드에서만 사용할 수 있습니다.

축척 범위에 따라 스냅 작업을 제한하는 데 사용할 수 있는 모드는 세 가지가 있습니다:

  • Disabled: 현재 맵 축척이 어떻게 되든 스냅 작업을 활성화합니다. 기본 모드입니다.

  • Global: 스냅 작업이 제한되며 현재 맵 축척이 전체 수준 최저와 전체 수준 최고 값 사이인 경우에만 활성화됩니다. 이 모드를 선택할 경우 스냅 작업이 활성화되는 축척 범위를 환경 설정할 수 있는 두 위젯을 사용할 수 있습니다.

  • Per layer: 각 레이어에 대해 스냅 작업 축척 범위 제한을 정의합니다. 이 모드를 선택할 경우 각 레이어에 대한 최저 및 최고 축척을 환경 설정할 수 있는 두 열을 사용할 수 있습니다.

이때 최저 및 최고 축척은 QGIS의 관습을 따른다는 점을 기억하십시오: 최저 축척이란 가장 “축소한” 축척이며 최고 축척은 가장 “확대한” 축척입니다. “0” 또는 “설정하지 않음” 으로 설정한 최저 및 최고 축척은 제한이 없는 것으로 간주합니다.

15.3.2.4. Self-snapping

The snappingSelf Self-snapping option allows you to snap to the geometry that is being edited. Combined with the advanced digitizing panel, this provides a handy way to digitize new edges relative to the previous edges or vertices. Self-snapping can cause invalid geometries, use with caution.

../../../_images/self_snapping.gif

그림 15.88 Drawing features with self-snapping

15.3.2.5. Snapping on custom grid

A snapping distance can also be customized on a layer basis in the Digitizing tab of the layer properties dialog. With setting the Geometry precision distance, you enable a dotted grid visible when the map canvas is at a coherent scale for display. Snapping can then be performed on the dots of the grid: an added or modified geometry will have all of its vertices snapped automatically to the closest node of the grid. More information at 디지타이즈 작업 속성.

15.3.3. 위상 편집

이런 스냅 옵션 이외에도, Snapping options… 대화창(Project ► Snapping options) 및 Snapping 툴바에서 몇몇 다른 위상 기능들을 활성화/비활성화할 수 있습니다.

15.3.3.1. 위상 편집 활성화

topologicalEditing Topological editing 버튼은 공통 경계선을 공유하는 피처를 편집하고 유지보수할 수 있게 해줍니다. 이 옵션을 활성화하면, QGIS가 피처들이 공유하는 경계선을 ‘탐지’ 합니다. 공통 꼭짓점/선분을 이동시키면, QGIS가 인접 피처 도형의 꼭짓점/선분도 이동시킬 것입니다.

위상 편집 작업은 서로 다른 레이어들의 피처들과 작동합니다. 해당 레이어들이 가시화되어 있고 편집 모드라면 말이죠.

In layer with Z values, topological editing will interpolate the Z value of the vertex based on the value of the edge used for the connection.

15.3.3.2. Overlapping control

Overlapping prevents you from drawing new features that overlap existing ones in the selected layer, speeding up digitizing of adjacent polygons. It can be controlled by the overlap tool. Three modes are available:

  1. allowIntersections Allow Overlap (default)

  2. avoidIntersectionsCurrentLayer Avoid Overlap on Active Layer: prevents any overlap with other features from the layer being edited. Digitize the new geometries so that they overlap their neighbours and QGIS will cut the overlapping part(s) of the new geometries and snap them to the boundary of the existing features. The advantage is that you don’t have to digitize the common vertices on boundary.

  3. avoidIntersectionsLayers Follow Advanced Configuration: allows the overlapping setting to be set on a layer basis in the Advanced configuration view mode.

참고

기존 도형이 새 도형을 완전히 덮는 경우, 새 도형은 제거되며 QGIS가 오류 메시지를 띄울 것입니다.

경고

Avoid overlap 옵션을 조심해서 사용해야 합니다

이 옵션은 모든 폴리곤 레이어에서 중첩하는 새 도형을 자르기 때문에, 더 이상 이 옵션이 필요하지 않게 되자마자 반드시 체크 해제해야 합니다. 그렇지 않을 경우 기대하지 않은 도형을 얻게 될 수 있습니다.

15.3.3.3. 자동 투사

보통, 캡처 작업 맵 도구(피처 추가, 부분 추가, 고리 추가, 재형성 및 분할) 이용시 사용자가 피처의 각 꼭짓점을 클릭해야 합니다. 자동 투사(automatic tracing) 모드를 사용하면 디지타이즈 작업 과정의 속도를 향상시킬 수 있습니다. 디지타이즈 작업 도중 모든 꼭짓점을 직접 배치해야 할 필요가 없어지기 때문이죠:

  1. (Snapping 툴바에 있는) tracing 아이콘을 클릭하거나 T 키를 눌러 tracing Tracing 도구를 활성화하십시오.

  2. 사용자가 투사하고자 하는 피처의 꼭짓점이나 선분에 스냅 하십시오.

  3. 스냅하고 싶은 또다른 꼭짓점 또는 선분으로 마우스를 가져가면 일반적인 직선이 아니라 디지타이즈 작업 고무줄이 마지막으로 스냅한 포인트에서 현재 위치까지의 경로를 나타냅니다. 이 도구는 만곡 도형에서도 작동합니다.

    QGIS는 사실 기저 피처 위상을 이용해서 두 포인트 사이의 최단 경로를 생성합니다. 투사 기능을 이용하려면 경로를 생성하기 위해 투사가 가능한 레이어의 스냅 기능이 활성화된 상태여야 합니다. 또 디지타이즈 작업 중 기존 꼭짓점 또는 선분에 스냅해야 하며, 두 노드가 기존 피처 경계를 통해 위상적으로 연결될 수 있는지도 확실히 해야 합니다. 그렇지 않으면 QGIS가 두 노드를 연결할 수 없으므로 단일 직선을 투사하게 됩니다.

  4. 클릭하면 QGIS가 표시된 경로를 따라 중간 단계 꼭짓점들을 배치합니다.

피처 경계를 따라 투사하는 것이 아니라 피처 경계와 평행하는 경로를 디지타이즈하려면 tracing Enable Tracing 아이콘을 펼쳐 Offset 옵션을 설정하십시오. 양의 값은 투사 방향의 왼쪽으로 새로 그리도록 이동시키고, 음의 값은 그 반대로 투사 방향의 오른쪽으로 새로 그리게 이동시킵니다.

참고

최적의 투사를 위해 맵 축척 또는 스냅 설정을 조정하기

맵 캔버스에 너무 많은 피처들이 있는 경우, 잠재적으로 너무 긴 투사 구조 준비 및 대용량 메모리 부담을 피하기 위해 투사를 비활성화시킵니다. 맵을 확대하거나 일부 레이어를 비활성화하면 다시 투사를 활성화시킵니다.

참고

위상 포인트를 추가하지 않습니다

이 도구는 Topological editing 옵션을 활성화한 상태이더라도 기존 폴리곤 도형에 포인트를 추가하지 않습니다. 편집 중인 레이어에 도형 정밀도를 활성화한 경우라면, 새로 그린 도형이 기존 도형과 정확하게 일치하지 않을 수도 있습니다.

T 키를 눌러 자동 투사를 빠르게 활성화/비활성화하기

T 키를 누르면, (피처를 디지타이즈하는 도중이라도) 투사를 활성화/비활성화할 수 있습니다. 따라서 투사를 활성화한 상태로 피처의 일부분을 디지타이즈하고 다른 부분은 비활성화한 상태로 디지타이즈할 수도 있습니다. 투사를 비활성화해도 도구들은 아무 일 없이 작동합니다.

만곡 도형으로 투사 변환

Settings ► Options ► Digitizing ► Tracing 메뉴를 사용하면 디지타이즈 작업 도중 만곡 도형을 생성할 수 있습니다. 디지타이즈 작업 옵션 을 참조하세요.

15.3.4. 기존 레이어 디지타이징

기본적으로, QGIS는 레이어를 읽기 전용으로 불러옵니다. 이 습성은 혹시라도 마우스가 미끄러져 레이어를 실수로 편집하는 일을 피하기 위한 예방책입니다. 하지만, 편집을 지원하는 데이터 제공자이며 (데이터 포맷 및 필드 탐구 참조) 기저 데이터소스가 쓰기 가능인 경우 (예: 파일이 읽기 전용이 아닌 경우) 모든 레이어를 편집할 수 있습니다.

프로젝트 내부에서 레이어 편집 권한 제한

Project ► Properties… ► Data Sources ► Layers Capabilities 테이블에서, 제공자의 권한 허가 여부에 상관없이 어떤 레이어든 읽기 전용으로 설정할 수 있습니다. 이것은 다중 사용자 환경에서 승인받지 않은 사용자가 실수로 레이어를 (예: Shapefile을) 편집해서 혹시라도 데이터를 변질시키는 일을 막기 위한 간편한 방법이 될 수 있습니다. 이 설정은 현재 프로젝트 안에서만 적용된다는 사실을 기억하십시오.

일반적으로, 벡터 레이어를 편집하기 위한 도구는 고급 디지타이즈 작업 에서 설명하는 대로 디지타이즈 작업과 고급 디지타이즈 작업 툴바로 나뉘어져 있습니다. View ► Toolbars ► 메뉴에서 둘 다 선택하고 선택 해제할 수 있습니다.

기본 디지타이즈 작업 도구를 사용하면, 다음 기능들을 수행할 수 있습니다:

아이콘

목적

아이콘

목적

allEdits

Access to save, rollback or cancel changes in all or selected layers simultaneously

toggleEditing

Turn on or off edit status of selected layer(s) based on the active layer status

saveEdits

Save edits to the active layer

newTableRow

신규레코드 추가

capturePoint

피처 추가: 포인트 캡처

captureLine

피처 추가: 라인 캡처

capturePolygon

피처 추가: 폴리곤 캡처

vertexTool

꼭짓점 도구 (모든 레이어)

vertexToolActiveLayer

꼭짓점 도구 (현재 레이어)

multiEdit

선택한 모든 피처의 속성을 동시에 수정

deleteSelectedFeatures

Delete Selected features from the active layer

editCut

Cut Features from the active layer

editCopy

Copy selected Features from the active layer

editPaste

Paste Features into the active layer

undo

Undo changes in the active layer

redo

Redo changes in active layer

표: 편집 작업 - 벡터 레이어 기본 편집 툴바

이 모든 디지타이즈 작업 도구를 쓰는 도중에 도구를 비활성화시키지 않고서도 맵 캔버스에서 확대/축소 및 이동 할 수 있다는 사실을 기억하십시오.

All editing sessions start by choosing the toggleEditing Toggle editing option found in the context menu of a given layer, from the attribute table dialog, the digitizing toolbar or the Layer menu.

레이어를 편집 모드로 전환하면, 편집 작업 툴바에 있는 부가 도구 아이콘들이 활성화되며, Settings ► Options… ► Digitizing 탭에 있는 checkbox Show markers only for selected features 옵션을 체크하지 않은 경우 모든 피처의 꼭짓점에 마커가 나타날 것입니다.

정기적으로 저장

saveEdits Save Layer Edits 아이콘으로 주기적으로 편집 내용을 저장하는 것을 잊지 마십시오. 이 아이콘을 클릭하면 사용자의 데이터소스가 모든 수정 사항을 받아들일 수 있는지도 확인할 것입니다.

15.3.4.1. 피처 추가하기

레이어 유형에 따라, 툴바에 있는 newTableRow Add Record, capturePoint Add Point Feature, captureLine Add Line Feature 또는 capturePolygon Add Polygon Feature 아이콘을 통해 현재 레이어에 새 피처를 추가할 수 있습니다.

To add a geometryless feature, click on the newTableRow Add Record button and you can enter attributes in the feature form that opens.

To create features with the spatially enabled tools, you first digitize the geometry then enter its attributes. To digitize the geometry:

  1. Left-click on the map area to create the first point of your new feature. For point features, this should be enough and trigger, if required, the feature form to fill in their attributes.

  2. For line or polygon geometries, keep on left-clicking for each additional point you wish to capture. You can rely on the snapping to features options, the snap-to-grid or the advanced digitizing panel to accurately position each vertex.

    Along with placing nodes clik by click, lines and polygons can be:

    • traced automatically, accelerating the digitization. This will create consecutive straight lines between the vertices you place.

    • free-hand digitized, pressing R or activating streamingDigitize Stream digitizing in the Advanced Digitizing Toolbar.

    참고

    최근 추가한 노드를 되돌리려면 Delete 또는 Backspace 키를 누르십시오.

  3. 포인트 추가 작업을 완료했다면, 맵 영역 어디든 오른쪽 클릭해서 해당 피처의 도형 입력 작업이 끝났다고 확인하십시오.

    참고

    라인 또는 폴리곤 도형을 디지타이즈하는 도중 선형 Add feature 도구와 원호 스트링 도구 사이를 전환해가며 복합 만곡 도형을 생성할 수 있습니다.

    디지타이즈 작업 고무줄을 사용자 지정하기

    폴리곤을 캡처하는 도중에 기본값인 빨강색 고무줄이 아래에 있는 ─ 사용자가 포인트를 캡처하고자 하는 ─ 피처 또는 장소를 가릴 수가 있습니다. Settings ► Options ► Digitizing 대화창에서 고무줄의 Fill Color 에 대한 투명도(또는 알파 채널)를 높이면 이 문제를 해결할 수 있습니다. 또는 Don’t update rubber band during node editing 옵션을 체크해서 고무줄을 사용하지 않을 수도 있습니다.

  4. For line feature pressing Shift + right-click will close the line automatically.

  5. The attribute window will appear, allowing you to enter the information for the new feature. 그림 15.89 shows setting attributes for a fictitious new river. However, in the Digitizing menu under the Settings ► Options menu, you can also:

    • checkbox Suppress attributes pop-up windows after each created feature: 속성 입력 양식 대화창을 열지 않도록 합니다.

    • checkbox Reuse last entered attribute values: 속성 입력 양식 대화창이 열릴 때 가장 최근에 입력한 속성값으로 자동 입력해서 변경할 값만 입력하면 되도록 합니다.

../../../_images/editDigitizing.png

그림 15.89 새 벡터 피처를 디지타이즈한 후의 속성 입력 양식 대화창

15.3.4.2. 꼭짓점 도구

QGIS provides two tools to interact with vector features vertices:

  • vertexToolActiveLayer Vertex Tool (Current Layer): only overlaid features in the active layer (in the Layers panel) are affected

  • vertexTool Vertex Tool (All Layers): any overlaid features in all editable layers are affected. This allows you to edit features without switching the active layer or edit multiple layers at once (e.g., country and their regions boundaries)

For any editable vector layer, the vertex tools provide manipulation capabilities of feature vertices similar to CAD programs. It is possible to select multiple vertices at once and to move, add or delete them altogether. The vertex tools also support the topological editing feature. They are selection persistent, so when some operation is done, selection stays active for this feature and tool.

Settings ► options Options ► Digitizing ► Search Radius: selectNumber 검색 반경 속성을 0보다 큰 숫자로 설정하는 것이 중요합니다. 그러지 않을 경우, QGIS가 현재 어떤 꼭짓점을 편집 중인지 구분하지 못 하고 경고 메시지를 표시할 것입니다.

꼭짓점 마커

QGIS supports different kinds of vertex markers: ‘Semi-transparent circle’, ‘Cross’ and ‘None’. To change the marker style, choose options Options from the Settings menu, click on the Digitizing tab and select the appropriate entry.

기본 작업

Given a layer in edit mode, start by activating the vertex tool. Red circles will appear when hovering vertices.

  • Selecting vertices: You can select vertices by:

    • Clicking on them one at a time holding Shift key pressed

    • Click-and-dragging a rectangle surrounding the target vertices

    • Drawing a polygon surrounding the target vertices: Hold Alt and click using the vertex tool to start digitizing a polygon. Each subsequent click adds a new vertex to the rubberband polygon. Backspace or Delete removes last added rubberband vertex. Esc cancels the polygon selection mode, as also does backspacing/deleting all of the rubberband’s vertices. Right click finalizes the polygon digitizing and selects all vertices within the rubberband polygon.

    When a vertex is selected, its color changes to blue. To add more vertices to the current selection, hold down the Shift key while proceeding as above. To remove vertices from the selection, hold down Ctrl.

    Feature selection bounds vertex tool

    Vertices can be selected accross different features (or layers). If you are looking for vertices of a specific feature in a crowded place, first select that feature. Then draw the rectangle or polygon selector with the vertex tool around the vertices: only the selected feature’s vertices are selected.

    This is also the case if you display the feature in the vertex editor panel.

  • 배치(Batch) 꼭짓점 선택 모드: Shift+R 조합키를 누르면 배치 선택 모드를 활성화시킬 수 있습니다. 한 번 클릭해서 첫 번째 꼭짓점을 선택한 다음, 또다른 꼭짓점에 마우스를 클릭하지 말고 가져가십시오. 이렇게 하면 두 꼭짓점 사이의 모든 꼭짓점을 (폴리곤의 경우) 최단 경로를 사용해서 동적으로 선택할 것입니다.

    ../../../_images/vertex_batch_selection_mode.png

    그림 15.90 Shift+R 로 배치 꼭짓점 선택하기

    Ctrl 키를 누르면 피처 경계선을 따라 최장 경로를 선택해서 선택을 반전할 것입니다. 두 번째 클릭으로 노드 선택을 완료할 수 있고, 또는 Esc 키를 누르면 배치 모드에서 벗어나게 됩니다.

  • Adding vertices: To add a vertex to a line or polygon geometry, hold Shift and double-click the place on the segment.

    When hovering a segment, a virtual new node appears on the center. Click on it, move the cursor to a new location and click again to add a new vertex. For lines, a virtual node is also proposed at both extremities: click on it, do subsequent clicks and finish with a right-click; this allows to easily extend an existing line.

    ../../../_images/vertex_add_node.png

    그림 15.91 꼭짓점을 추가하기 위한 가상 노드

  • 꼭짓점 삭제하기: 꼭짓점을 선택한 다음 Delete 키를 누르십시오. 피처의 모든 꼭짓점을 삭제하면 – 데이터소스와 호환되는 경우 – 도형이 없는 피처를 생성합니다. 피처를 완전히 삭제하는 것이 아니라 도형 부분만 삭제한다는 점을 기억하십시오. 피처를 완전히 삭제하려면 deleteSelectedFeatures Delete Selected 도구를 사용해야 합니다.

  • Moving vertices: Select all the vertices you want to move, click on a selected vertex or edge, and click on the desired new location. You can use the snapping to feature capabilities and the Advanced Digitizing Panel constraints for distance, angles, exact X and Y location before the second click. All the selected vertices will be translated.

    However, if the snap-to-grid option is enabled, selected vertices are snapped to the closest grid intersection to their translated position. Unselected vertices are also moved to their closest grid intersection. There is no simple translation.

    ../../../_images/vertex_snap_to_grid.png

    그림 15.92 Moving the top vertex snaps all the vertices to the grid

Each change made with the vertex tool is stored as a separate entry in the Undo dialog. Remember that all operations support topological editing when this is turned on. On-the-fly projection is also supported.

꼭짓점 편집기 패널

With enabling a vertex tool, you also open the Vertex Editor panel. Right-clicking over a feature fills the panel with the list of all the vertices of the feature with their x, y (z, m if applicable) coordinates and r (for the radius, in case of circular geometry). The feature is also made exclusive for editing, meaning that the edit of any other features is disabled: new vertices can only be added to the bound feature, selecting and moving of vertices and segments by clicking or dragging the map canvas is only possible for that feature. Also, select a row in the table does select the corresponding vertex in the map canvas, and vice versa. Change a coordinate in the table and the vertex position is updated. You can also select multiple rows and delete them altogether.

../../../_images/vertex_editor_panel.png

그림 15.93 선택한 노드를 보여주는 꼭짓점 편집기 패널

15.3.4.3. 피처 잘라내기, 복사 및 붙여넣기

먼저 toggleEditing Toggle editing 을 통해 대상 레이어를 편집 모드로 설정해놓았다면, 동일한 QGIS 프로젝트의 레이어들 사이에서 선택한 피처를 자르고, 복사하고 붙여넣을 수 있습니다.

복사/붙여넣기를 이용해서 폴리곤을 라인으로, 라인을 폴리곤으로 변형하기

라인 피처를 복사해서 폴리곤 레이어에 붙여넣는 경우, QGIS가 대상 레이어에 그 경계가 라인 피처의 닫힌 도형에 대응하는 폴리곤으로 붙여넣습니다. 이는 동일한 데이터를 가진 서로 다른 도형 유형을 빠르게 생성하는 방법입니다.

외부 응용 프로그램에 피처를 텍스트로 붙여넣을 수도 있습니다. 피처가 도형 데이터를 OGC WKT(Well-Known Text) 서식으로 표현한 CSV 포맷인 경우에 말이죠. QGIS 외부의 WKT 및 GeoJSON 객체를 QGIS 내부의 레이어로 붙여넣는 것도 가능합니다.

복사/붙여넣기 기능이 유용한 경우란 어떤 경우일까요? 바로 한 번에 하나 이상의 레이어를 편집하는 중에 레이어들 간에 피처를 복사/붙여넣기하는 경우입니다. 어째서 이런 작업이 필요한 걸까요? QGIS 예시 데이터의 big_lakes 레이어에 있는 호수 5,000개 전부가 아니라 한두 개만 있는 레이어에서 몇몇 작업을 해야 한다고 가정해봅시다. 새 레이어를 생성한 다음 해당 레이어에 필요한 호수만 복사/붙여넣기를 이용해서 넣을 수 있습니다.

새 레이어에 몇몇 호수를 복사해 넣는 다음 예제를 해보겠습니다:

  1. 복사해오려는 레이어(원본 레이어)를 불러옵니다.

  2. 복사해 넣으려는 레이어(대상 레이어)를 불러오거나 생성합니다.

  3. 대상 레이어를 편집 모드로 설정합니다.

  4. 범례에서 원본 레이어를 클릭해서 활성화시킵니다.

  5. selectRectangle Select Features by area or single click 도구를 이용해서 원본 레이어에서 피처(들)을 선택합니다.

  6. editCopy Copy Features 도구를 클릭합니다.

  7. 범례에서 대상 레이어를 클릭해서 활성화시킵니다.

  8. editPaste Paste Features 도구를 클릭합니다.

  9. 편집 모드를 해제하고 변경 사항을 저장합니다.

원본과 대상 레이어가 서로 다른 스키마를 가지고 있다면 (필드명과 유형이 동일하지 않다면) 어떻게 될까요? QGIS는 일치하는 데이터를 붙여넣고 나머지는 무시합니다. 대상 레이어에 속성을 복사해 넣을 필요가 없는 경우, 필드 및 데이터 유형을 어떻게 구성하든 상관없습니다. 하지만 전체를 ─ 피처와 그 속성까지 ─ 복사하고자 하는 경우, 원본과 대상 레이어의 스키마가 일치하는지 확인해야 합니다.

참고

붙여넣은 피처의 합치성

원본과 대상 레이어가 동일한 투영체를 사용하고 있는 경우, 붙여넣은 피처가 원본 레이어와 동일한 도형을 가지게 될 것입니다. 하지만, 대상 레이어의 투영체가 다른 경우, QGIS는 도형이 동일한지 보장할 수 없게 됩니다. 왜냐하면 서로 다른 투영체 간에 변환할 때 자잘한 반올림 오류가 발생하기 때문입니다.

문자열 속성을 또다른 속성으로 복사하기

사용자의 속성 테이블에 문자열 유형의 새 열을 생성했는데, 더 긴 길이를 가진 다른 속성 열로 그 값을 붙여넣으려는 경우, 열의 길이가 대상 열의 길이로 늘어날 것입니다. GDAL/OGR 1.10과 함께 구동되는 GDAL Shapefile 드라이버가 삽입될 데이터의 길이를 동적으로 수용하기 위해 문자열 및 정수형 필드를 자동 확장하기 때문입니다.

15.3.4.4. 선택한 피처 삭제하기

어떤 피처 전체(속성 및 도형)를 삭제하려는 경우, 먼저 표준적인 selectRectangle Select Features by area or single click 도구를 사용해서 도형을 선택할 수 있습니다. 속성 테이블에서 선택할 수도 있습니다. 선택을 마치고 나면, Delete 또는 Backspace 키를 누르거나 deleteSelectedFeatures Delete Selected 도구를 클릭해서 피처를 삭제하십시오. 선택한 피처 여러 개를 한 번에 삭제할 수 있습니다.

피처를 삭제하는 데 디지타이즈 작업 툴바에 있는 editCut Cut Features 도구를 이용할 수도 있습니다. 이 도구는 피처를 사실상 삭제하지만 “공간 클립보드”에 옮겨 놓기도 합니다. 즉, 삭제할 피처를 잘라내는 겁니다. 이후에 editPaste Paste Features 도구를 통해 되돌려 놓을 수 있습니다. 기초 수준의 실행 취소 능력이죠. 잘라내기, 복사 및 붙여넣기는 현재 선택한 피처를 대상으로 작동합니다. 즉 한 번에 하나 이상을 대상으로 작업할 수 있다는 뜻입니다.

15.3.4.5. 실행 취소 및 재실행

undo Undoredo Redo 도구는 벡터 편집 작업을 실행 취소하거나 재실행할 수 있습니다. 실행 취소/재실행 이력에 있는 모든 작업을 보여주는 고정 가능한(dockable) 위젯도 있습니다. (그림 15.94 을 참조하세요.) 이 위젯은 기본적으로 표시되지 않습니다. 이 위젯을 표시하려면 툴바를 오른쪽 클릭한 다음 checkbox Undo/Redo Panel 을 활성화해야 합니다. 하지만 이 위젯이 표시되지 않은 경우에도 실행 취소/재실행 능력은 켜져 있습니다.

../../../_images/redo_undo.png

그림 15.94 실행 취소/재실행 디지타이즈 작업 이력

Undo 버튼을 클릭하거나 Ctrl+Z (또는 |osx| Cmd+Z) 조합키를 누르면, 모든 피처와 속성의 상태가 되돌린 작업 이전의 상태로 돌아갑니다. 일반적인 벡터 편집 작업이 아닌 변경 사항(예: 플러그인을 통한 변경 사항)은 해당 변경 사항이 어떻게 수행됐는지에 따라 되돌릴 수도 있고 되돌리지 못 할 수도 있습니다.

실행 취소/재실행 이력 위젯을 이용하려면, 그냥 이력 목록에 있는 작업을 하나 선택하십시오. 모든 피처가 선택한 작업 직후의 상태로 돌아갈 것입니다.

15.3.4.6. 편집한 레이어 저장하기

레이어가 편집 모드 상태인 경우, 모든 변경 사항이 QGIS의 메모리에 남아 있습니다. 즉 변경 사항이 즉시 데이터소스 또는 디스크에 커밋 또는 저장되는 것이 아닙니다. 현재 레이어에 편집 사항을 저장하고 싶지만 편집 모드를 해제하지 않고 계속 편집 작업을 하고 싶은 경우, saveEdits Save Layer Edits 아이콘을 클릭하면 됩니다. toggleEditing Toggle editing 아이콘으로 편집 모드를 끄는 경우 (또는 QGIS를 종료하는 경우) 사용자의 변경 사항을 저장할 거냐 또는 무시할 거냐를 묻는 대화창이 열립니다.

변경 사항을 저장할 수 없는 경우 (예: 디스크에 남은 공간이 없거나, 범위를 벗어난 속성값이 있는 경우) QGIS의 내부 메모리 상태가 보존됩니다. 사용자가 편집 사항을 조정해서 다시 저장할 수 있게 하기 위해서입니다.

데이터 무결성

편집 작업을 시작하기 전에 항상 사용자 데이터소스를 백업하도록 권장합니다. QGIS 개발자들이 사용자 데이터의 무결성을 보존하기 위해 모든 노력을 다 하고 있지만, 어떤 보장도 해드릴 수 없기 때문입니다.

여러 레이어를 한 번에 저장하기

이 기능은 여러 레이어를 디지타이즈할 수 있게 해줍니다. 사용자가 여러 레이어에서 만든 모든 변경 사항을 저장하려면 fileSaveAs Save for Selected Layers 를 선택하십시오. rollbackEdits Rollback for Selected Layers 를 클릭하면, 선택한 모든 레이어에 대한 디지타이즈 작업을 되돌릴 수도 있습니다. 선택한 레이어에 대한 편집 작업을 종료하려면, cancelEdits Cancel for Selected Layer(s) 를 통해 쉽게 끝낼 수 있습니다.

프로젝트의 모든 레이어 편집 작업에서 동일한 기능들을 사용할 수 있습니다.

여러 레이어 변경 사항을 한 번에 편집, 저장 또는 되돌리는 데 트랜잭션 그룹 이용하기

동일한 PostGreSQL 데이터베이스로부터 나온 레이어들을 작업하는 경우, Project ► Properties… ► Data Sources 메뉴의 Automatically create transaction groups where possible 옵션을 활성화시키면 레이어들의 습성(편집 모드 시작/종료, 변경사항을 동시에 저장 또는 되돌리기)을 동기화합니다.

15.3.5. 고급 디지타이즈 작업

아이콘

목적

아이콘

목적

cad

고급 디지타이즈 작업 도구 활성화

digitizeWithCurve

Digitize with Curve

streamingDigitize

Enable Stream Digitizing

moveFeature moveFeatureLine moveFeaturePoint

피처(들) 이동

moveFeatureCopy moveFeatureCopyLine moveFeatureCopyPoint

피처(들) 복사 및 이동

rotateFeature

피처(들) 회전

simplify

피처 단순화

scaleFeature

Scale Feature

addRing

고리 추가

addPart

부분 추가

fillRing

고리 채우기

reverseLine

방향 바꾸기

deleteRing

고리 삭제

deletePart

부분 삭제

offsetCurve

곡선 오프셋

reshape

피처 재형성

splitParts

부분 분할

splitFeatures

피처 분할

mergeFeatureAttributes

선택한 피처의 속성 병합

mergeFeatures

선택한 피처 병합

rotatePointSymbols

포인트 심볼 회전

offsetPointSymbols

포인트 심볼 오프셋

trimExtend

피처 다듬기(Trim) 또는 연장

표: 고급 편집 작업 - 벡터 레이어 고급 편집 작업 툴바

15.3.5.1. Straight, curve and stream digitizing

The digitizeWithCurve Digitize with Curve tool allows you to draw curves in layers with geometries that support curves. Digitizing a curve requires to provide three points along the curve (start, point along the arc, end) which define it.

The streamingDigitize Stream Digitizing tool allows you to activate and deactivate stream digitizing which allows to create features in freehand mode.

The streaming tolerance affects the spacing between consecutive vertices. Currently, the only supported unit is pixels (px).

15.3.5.2. 피처(들) 이동

moveFeature Move Feature(s) 도구는 기존 피처를 이동시킬 수 있습니다:

  1. 이동시킬 피처(들)를 선택하십시오.

  2. 맵 캔버스 상에서 변위의 원점을 나타내는 위치를 클릭하십시오. 정확한 포인트를 선택하기 위해 스냅 기능을 사용할 수 있습니다.

    원점 좌표를 정확하게 설정하기 위해 고급 디지타이즈 작업 제약조건 을 이용할 수도 있습니다. 이런 경우:

    1. 먼저 cad 버튼을 클릭해서 패널을 활성화시킵니다.

    2. x 를 입력한 다음 사용자가 원하는 원점에 대응하는 값을 입력합니다. 그리고 옵션 옆에 있는 locked 버튼을 눌러 값을 고정시킵니다.

    3. y 좌표도 동일한 방법으로 설정합니다.

    4. 맵 캔버스를 클릭하면 지정한 좌표에 사용자의 원점을 배치합니다.

  3. 맵 캔버스를 이동해서 변위의 대상 포인트를 가리키십시오. 계속 스냅 모드를 사용할 수도 있고, 또는 앞에서 설명한대로 고급 디지타이즈 작업 패널을 사용해서 전이(轉移)의 종단점을 배치하기 위한 상호보완적인 distanceangle 배치 제약조건을 지정할 수도 있습니다.

  4. 맵 캔버스를 클릭하십시오: 전체 피처가 새 위치로 이동합니다.

moveFeatureCopy Copy and Move Feature(s) 도구를 사용하면 피처(들)의 전이된 복사본을 마찬가지로 생성할 수 있습니다.

참고

Move Feature(s) 또는 Copy and Move Feature(s) 도구로 맵 캔버스를 처음 클릭했을 때 어떤 피처도 선택되지 않은 경우, 액션의 영향을 받는 것은 포인터 아래 있는 피처뿐입니다. 따라서 여러 피처를 이동시키려면 먼저 피처들을 선택해야 합니다.

15.3.5.3. 피처(들) 회전

맵 캔버스에 있는 하나 이상의 피처를 기울이려면 rotateFeature Rotate Feature(s) 도구를 사용하십시오:

  1. rotateFeature Rotate Feature(s) 아이콘을 클릭합니다.

  2. 기울이려는 피처를 클릭하십시오. 피처의 중심을 기울기 중심으로 참조하고, 기울인 피처의 미리보기를 표시하며, 현재 Rotation 각도를 표시하는 위젯이 열립니다.

  3. 새 배치에 만족한다면 맵 캔버스를 클릭하십시오. 또는 텍스트란에 기울기 각도를 직접 입력해도 됩니다. Snap to ° 박스를 이용해서 기울기 값에 제약조건을 걸 수도 있습니다.

  4. 여러 피처를 한번에 기울이려면, 먼저 피처들을 선택해야 합니다. 기본적으로 결합된 도형들의 중심을 기준으로 기울어질 것입니다.

기본적인 피처 중심점 대신 고정점(anchor point)을 사용할 수도 있습니다. Ctrl 키를 누른 채 맵 캔버스를 클릭하면, 해당 포인트를 새 기울기 중심점으로 사용할 것입니다.

맵을 클릭하기 전에 Shift 키를 누른 상태인 경우, 45도씩 기울어질 것입니다. 이후 사용자 입력 위젯에서 각도를 수정할 수 있습니다.

피처 기울이기를 끝내려면, ESC 키를 누르거나 다시 rotateFeature Rotate Feature(s) 아이콘을 클릭하면 됩니다.

15.3.5.4. Scale Feature

The scaleFeature Scale Feature tool is similar to the Rotate feature. Though instead of performing a rotation of selected features, it rescales their geometry. The change is performed in relation to the anchor point and the scale ratio can be manually specified in the widget that appears in the upper corner of the canvas.

15.3.5.5. 피처 단순화

simplify Simplify Feature 도구는 도형의 유효성이 유지되는 한 꼭짓점 개수를 줄이거나 밀도를 높여서 라인 또는 폴리곤 도형의 형태를 대화형 작업으로 변형시킬 수 있습니다:

  1. simplify Simplify Feature 도구를 선택하십시오.

  2. 피처를 클릭하거나 피처 위로 직사각형을 드래그하십시오.

  3. 적용할 Method 를 정의할 수 있는 대화창이 열립니다. 다음과 같은 방법을 선택할 수 있습니다:

    • 도형을 단순화 하는, 즉 꼭짓점을 원본보다 줄이는 방법입니다. Simplify by distance, Simplify by snapping to grid 또는 Simplify by area (Visvalingam) 를 사용할 수 있습니다. 그 다음 단순화에 사용할 Tolerance 단위를 Layer units, Pixels 또는 Map units 가운데 하나로 지정해야 합니다. 허용 오차가 클수록 더 많은 꼭짓점을 삭제할 수 있습니다.

    • 또는 Smooth 옵션의 도움으로 새 꼭짓점을 추가해서 도형의 밀도를 높이는 방법도 있습니다. 기존의 각 꼭짓점에서 시작하는 두 선분 상의 선분 길이의 백분율을 나타내는 Offset 거리에 각각 꼭짓점을 배치합니다. Iterations 옵션에서 새 꼭짓점을 배치하는 과정의 반복 횟수도 설정할 수 있습니다. 반복 횟수가 높을수록 꼭짓점도 늘어나서 피처가 더 평탄화됩니다.

    사용자가 사용한 설정은 편집 작업을 또는 프로젝트를 종료해도 저장될 것입니다. 따라서 다음에 피처를 단순화하는 경우에도 동일한 설정을 사용할 수 있습니다.

  4. 대화창 하단에 적용될 수정 사항을 요약해서 (작업 전후의) 피처 및 꼭짓점 개수의 목록과 (변경되는 비율을) 함께 표시합니다. 또 맵 캔버스의 기존 피처 위에 예상 피처를 고무줄 색상으로 표시합니다.

  5. 예상 피처가 사용자의 필요를 만족시킨다면, OK 를 클릭해서 수정 사항을 적용하십시오. 그렇지 않을 경우, Cancel 을 클릭하거나 맵 캔버스를 오른쪽 클릭하면 작업을 중단할 수 있습니다.

참고

렌더링만을 위해 도형을 단순화하는 Settings ► Options ► Rendering 메뉴의 피처 단순화 옵션과는 달리, simplify Simplify Feature 도구는 데이터소스에 있는 피처의 도형을 영구히 변경합니다.

15.3.5.6. 부분 추가

addPart Add Part 도구로 선택한 피처에 부분을 추가해서 멀티포인트, 멀티라인 또는 멀티폴리곤 피처를 생성할 수 있습니다. 기존 피처 외부에서 이 새 부분을 디지타이즈해야만 하는데, 이 기존 피처는 먼저 선택돼 있어야 합니다.

도형이 없는 피처에 도형을 추가하는 경우에도 addPart Add Part 도구를 사용할 수 있습니다. 먼저, 속성 테이블에서 피처를 선택한 다음 addPart Add Part 도구로 새 도형을 디지타이즈하십시오.

15.3.5.7. 부분 삭제

deletePart Delete Part 도구는 다중 피처에서 부분을 삭제할 수 있습니다. (예를 들면 멀티폴리곤 피처에서 폴리곤을 삭제할 수 있습니다.) 이 도구는 포인트, 라인 및 폴리곤 모든 다중 부분 도형에 대해 작동합니다. 더우기, 피처의 도형 요소를 완전히 제거할 수도 있습니다. 부분을 삭제하려면, 그냥 대상 피처 안에 있는 부분을 클릭하면 됩니다.

15.3.5.8. 고리 추가

툴바에 있는 addRing Add Ring 아이콘을 클릭하면 고리 폴리곤을 생성할 수 있습니다. 기존 폴리곤 영역 내부에 ‘구멍’으로 간주되는 내곽 폴리곤을 디지타이즈할 수 있다는 뜻으로, 이 경우 외곽 및 내곽 폴리곤 경계선 사이의 영역만 고리 폴리곤으로 남게 됩니다.

15.3.5.9. 고리 채우기

fillRing Fill Ring 도구는 다른 폴리곤 안에 중첩되는 영역 없이 완전히 들어가는 폴리곤 피처를 생성할 수 있습니다. 즉 기존 피처 안에 있는 구멍을 덮는 새 피처를 말이죠. 이런 피처를 생성하려면:

  1. fillRing Fill Ring 도구를 선택하십시오.

  2. 기존 피처 위로 새 폴리곤을 그리십시오: QGIS가 새 폴리곤 도형에 (addRing Add Ring 도구를 사용하듯이) 고리를 추가한 다음 그 고리와 일치하는 도형을 가진 새 피처를 (capturePolygon Add polygon feature 도구로 내곽 경계선을 투사 하듯이) 생성합니다.

  3. 또는, 고리가 피처에 이미 존재하는 경우 고리 위로 마우스를 가져가 Shift 키를 누른 채 왼쪽 클릭하십시오: 해당 위치에 구멍을 채우는 새 피처가 그려집니다.

    새 피처의 Feature Attributes 양식이 “부모” 피처의 값 그리고/또는 필드 제약조건 과 함께 열립니다.

15.3.5.10. 고리 삭제

deleteRing Delete Ring 도구는 구멍 안쪽을 클릭해서 기존 폴리곤 내부의 고리를 삭제할 수 있습니다. 이 도구는 폴리곤 및 멀티폴리곤 피처에 대해서만 작동합니다. 폴리곤의 외곽 고리에 이 도구를 사용해도 아무것도 변경되지 않습니다.

15.3.5.11. 피처 재형성

툴바에 있는 reshape Reshape Features 도구를 사용해서 라인 및 폴리곤 피처를 재형성할 수 있습니다. 라인의 경우, 원본 라인을 첫 번째 교차점에서 마지막 교차점까지의 라인 부분으로 대체합니다.

../../../_images/reshape_lines.png

그림 15.95 라인 재형성하기

재형성 도구로 라인스트링 도형을 연장시키기

reshape Reshape Features 도구를 이용해서 기존 라인의 첫 번째 또는 마지막 꼭짓점에 스냅한 다음 새 라인을 그리면 기존 라인스트링 도형을 늘릴 수 있습니다. 새 라인을 승인하면 피처 도형이 두 라인의 결합체로 변합니다.

폴리곤의 경우, 이 도구는 폴리곤의 경계선을 재형성합니다. 제대로 동작하려면, 재형성 도구의 라인이 폴리곤 경계선과 최소한 두 번 교차해야만 합니다. 라인을 그리려면, 맵 캔버스를 클릭해서 꼭짓점을 추가하십시오. 그리기를 마치려면, 오른쪽 클릭만 하면 됩니다. 라인의 경우와 마찬가지로, 첫 번째와 마지막 교차점 사이에 있는 선분만 처리됩니다. 폴리곤 내부에 있는 재형성 라인의 선분은 폴리곤을 잘라내고, 외부에 있는 선분은 폴리곤을 확장시킬 것입니다.

../../../_images/reshape_polygon.png

그림 15.96 폴리곤 재형성하기

폴리곤의 경우, 재형성 작업이 때로 의도하지 않은 결과를 낼 수도 있습니다. 이 도구는 폴리곤의 자잘한 부분을 수정하는 데 유용하지, 본체를 수정하기는 힘듭니다. 또 재형성 라인이 여러 폴리곤 고리와 교차해서도 안 됩니다. 그런 경우 유효하지 않은 폴리곤이 생성되기 때문입니다.

참고

재형성 도구는 폴리곤 고리 또는 닫힌 라인의 시작점을 변경시킬 수도 있습니다. 즉, ‘두 번’ 나타나던 포인트가 더 이상 그러지 않을 수도 있다는 뜻입니다. 대부분의 응용 프로그램에서 문제가 없을 수도 있지만, 고려해야 할 사항임에는 틀림없습니다.

15.3.5.12. 곡선 오프셋

offsetCurve Offset Curve 도구는 라인 레이어를 평행하게 이동시킨 객체를 생성합니다. 이 도구를 편집 중인 레이어에 적용하면 도형을 수정하며, 배경 레이어에 적용하면 라인/고리를 복사해서 편집 중인 레이어에 추가합니다. 따라서 이 도구는 거리 라인 레이어를 생성하는 데 적합합니다. 이 도구는 변위 거리를 보여주는 User Input 대화창을 엽니다.

To create a shift of a line layer, you must first go into editing mode and activate the offsetCurve Offset Curve tool. Then click on a feature to shift it. Move the mouse and click where wanted or enter the desired distance in the user input widget. Holding Ctrl during the 2nd click will make an offset copy. Your changes may then be saved with the saveEdits Save Layer Edits tool.

QGIS 옵션 대화창(의 디지타이즈 탭에서 Curve offset tools 부분)에서 Join style, Quadrant segments, Miter limit 과 같은 몇몇 파라미터를 환경 설정할 수 있습니다.

15.3.5.13. 라인 반전

라인 도형의 방향을 변경하는 것은 지도제작 목적 또는 네트워크 분석 준비에 유용할 수 있습니다.

라인 방향을 변경하려면:

  1. reverseLine Reverse line 아이콘을 클릭해서 라인 반전 도구를 활성화하십시오.

  2. 라인을 클릭하십시오. 라인의 방향이 반전됩니다.

15.3.5.14. 피처 분할

splitFeatures Split Features 도구를 사용해서 피처를 두 개 이상의 독립적인 새 피처들로 분할할 수 있습니다. 예를 들면 분할된 각 도형은 속성 테이블의 새 행과 대응합니다.

라인 또는 폴리곤 피처를 분할하려면:

  1. splitFeatures Split Features 도구를 선택하십시오.

  2. 분할하고자 하는 피처(들)를 가로지르는 라인을 그리십시오. 선택 집합이 활성화돼 있다면 선택한 피처들만 분할됩니다. 분할이 되면, 기본 값 또는 절(clause) 이 대응하는 필드에 적용되며 기본적으로 부모 피처의 다른 속성들도 새 피처에 복사됩니다.

  3. 이제 산출되는 모든 피처의 모든 속성을 평소대로 수정할 수 있습니다.

클릭 한 번으로 폴리라인을 새 피처들로 분할하기

splitFeatures Split Features 도구로 폴리라인 피처의 기존 꼭짓점에 스냅하고 클릭하면, 해당 피처를 새 피처 2개로 분할합니다.

15.3.5.15. 부분 분할

QGIS는 다중 부분 피처의 부분을 분할해서 부분의 개수를 늘릴 수 있습니다. splitParts Split Parts 도구를 사용해서 분할하고 싶은 부분을 가로지르는 라인을 그리기만 하면 됩니다.

클릭 한 번으로 폴리라인을 새 부분들로 분할하기

splitParts Split Parts 도구로 폴리라인 피처의 기존 꼭짓점에 스냅하고 클릭하면, 해당 피처를 동일한 피처에 속해 있는 새 폴리라인 2개로 분할합니다.

15.3.5.16. 선택한 피처 병합

mergeFeatures Merge Selected Features 도구는 기존 피처들을 합쳐서 새 피처를 생성할 수 있습니다. 기존 피처의 도형들을 병합해서 새 피처를 생성합니다. 기존 피처들에 공통 경계가 없는 경우, 멀티폴리곤/멀티폴리라인/멀티포인트 피처를 생성합니다.

  1. 먼저, 결합하고자 하는 피처들을 선택하십시오.

  2. 그 다음 mergeFeatures Merge Selected Features 아이콘을 클릭하십시오.

  3. 새 대화창의 테이블 하단에 있는 Merge 행이 산출되는 피처의 속성들을 표시합니다. 이 값들을 다음과 같이 수정할 수 있습니다:

    • 대응하는 셀에서 값을 직접 대체합니다.

    • 테이블에서 행을 선택하고 Take attributes from selected feature 를 클릭하면 선택한 최초 피처의 값을 사용합니다.

    • pressing the Take attributes from the largest geometry to use the attributes from the longest line feature, the largest polygon, or the multipoints with the most parts;

    • Skip all fields 를 클릭하면 빈 속성을 사용합니다.

    • expanding the drop down menu at the top of the table, select any of the above options to apply to the corresponding field only. There, you can also choose to aggregate the initial features attributes (Minimum, Maximum, Median, Sum, Count, Concatenation… depending on the type of the field. see 통계 요약 패널 for the full list of functions).

    참고

    레이어가 필드에 기본값 또는 절을 가지고 있을 경우, 이를 병합된 피처의 초기 값으로 사용합니다.

  4. 수정 사항을 적용시키려면 OK 를 클릭하십시오. 레이어에 이전에 선택한 피처들을 대체하는 단일 [멀티]피처를 생성합니다.

15.3.5.17. 선택한 피처의 속성 병합

mergeFeatureAttributes Merge Attributes of Selected Features 도구는 피처들의 경계를 병합하지 않고서도 피처에 동일한 속성을 적용할 수 있게 해줍니다. 이 도구의 대화창은 Merge Selected Features 도구의 대화창과 동일합니다. 다만 선택한 개체들의 속성은 동일하게 변하지만, 개체 도형은 그대로 유지된다는 점이 다릅니다.

15.3.5.18. 포인트 심볼 회전

rotatePointSymbols Rotate Point Symbols 도구를 통해 맵 캔버스에 있는 포인트 심볼의 기울기를 개별적으로 변경할 수 있습니다.

  1. 먼저, 기울기 값을 저장할 필드를 지정해야 합니다. 심볼 데이터 정의 기울기 속성 에 필드를 할당하면 됩니다:

    1. Layer Properties ► Symbology 대화창에서 심볼 편집기 대화창을 찾으십시오.

    2. 심볼 레이어의 (되도록) 최상위 Marker 심볼의 Rotation 옵션 옆에 있는 dataDefine Data-defined override 위젯을 클릭하십시오.

    3. Field Type 콤보박스에서 필드를 선택하십시오. 이 필드의 값들을 따라 각 피처의 심볼을 기울일 것입니다.

      기울기 값을 제어하기 위해 보조 데이터 저장소 필드를 생성하려면 Store data in project 항목을 체크해도 됩니다.

    참고

    반드시 동일한 필드가 모든 심볼 레이어에 할당되도록 하십시오

    최상위 심볼 트리에서 데이터 정의 기울기 필드를 설정하면 모든 심볼 레이어에 해당 필드를 적용합니다. 이는 Rotate Point Symbols 도구로 그래픽 심볼을 기울이기 위한 전제조건입니다. 실제로, 동일한 필드가 심볼 레이어의 기울기 속성에 첨부되지 않았을 경우, 이 도구는 작동하지 않을 것입니다.

    ../../../_images/rotatepointsymbol.png

    그림 15.97 포인트 심볼 기울이기

  2. 그 다음 맵 캔버스에 있는 포인트 심볼을 rotatePointSymbols Rotate Point Symbols 도구로 클릭하십시오.

  3. 마우스를 주위로 움직여보십시오. 기울기 값을 가진 빨간 화살표가 가시화될 것입니다. (그림 15.97 참조) 마우스를 움직이는 도중 Ctrl 키를 누르면, 기울기가 15도 단계로 바뀔 것입니다.

  4. 원하는 각도 값으로 기울어졌다면, 한번 더 클릭하십시오. 심볼을 이 새 기울기로 렌더링하고 이에 맞춰 관련 필드도 업데이트됩니다.

    심볼을 기울이지 않으려면 오른쪽 클릭하면 됩니다.

15.3.5.19. 포인트 심볼 오프셋

offsetPointSymbols Offset Point Symbols 도구는 포인트 심볼이 맵 캔버스에 렌더링된 위치를 대화형으로 변경할 수 있습니다. 이 도구는 rotatePointSymbols Rotate Point Symbols 도구와 비슷하게 동작합니다만, 심볼의 각 레이어마다 데이터 정의된 Offset (X,Y) 속성에 필드를 연결해야 한다는 점이 다릅니다. 이 필드는 심볼이 맵 캔버스에서 이동한 피처의 오프셋 좌표로 채워질 것입니다.

  1. 심볼의 Offset (X,Y) 속성의 데이터 정의 위젯에 필드를 연결하십시오. 심볼이 다중 레이어로 이루어진 경우, 각 레이어마다 필드를 할당해야 할 수도 있습니다.

  2. offsetPointSymbols Offset Point Symbols 도구를 선택하십시오.

  3. 포인트 심볼을 클릭하십시오.

  4. 새 위치로 이동시키십시오.

  5. 한번 더 클릭하십시오. 심볼이 새 위치로 이동했습니다. 원래 위치로부터의 오프셋 값은 연결된 필드에 저장됩니다.

    심볼을 오프셋시키지 않으려면 오른쪽 클릭하면 됩니다.

참고

offsetPointSymbols Offset Point Symbols 도구는 포인트 심볼 자체를 이동시키지 않습니다. 그러려면 vertexToolActiveLayer Vertex Tool (Current Layer) 또는 moveFeaturePoint Move Feature 도구를 사용해야 합니다.

15.3.5.20. 피처 다듬기/연장하기

디지타이즈한 라인이 또다른 라인에 스냅하기엔 너무 짧거나 너무 긴 경우 (라인이 빠졌거나 라인과 교차하는 경우) 선분을 연장하거나 짧게 만들 수 있어야 합니다.

trimExtend Trim/Extend 도구는 [멀티]라인은 물론 [멀티]폴리곤도 수정할 수 있습니다. 게다가 라인의 종단만 대상으로 삼을 필요도 없습니다. 도형의 어떤 선분도 수정할 수 있습니다.

참고

도형의 유효성이 망가질 수도 있습니다.

참고

이 도구가 작동하려면 선분 스냅 모드를 활성화시켜야만 합니다.

이 도구는 사용자에게 또다른 선분을 연장할지 또는 다듬을지에 대한 제한(선분)을 선택할 것을 요청합니다. 꼭짓점 도구와는 달리, 편집 중인 레이어만 수정하는지 검사합니다.

두 선분 모두 3차원인 경우, 제한 선분이 Z값을 가지도록 보간합니다.

다듬기의 경우, 클릭해서 짧게 만들 부분을 선택해야만 합니다.

15.3.6. 형태 디지타이즈 작업

Shape Digitizing 툴바의 도구들로 정규 형태 및 만곡 도형을 그릴 수 있습니다.

15.3.6.1. 원호 스트링 추가

circularStringCurvePoint Add circular string 또는 circularStringRadius Add circular string by radius 버튼으로 원호 도형을 가진 라인 또는 폴리곤 피처를 추가할 수 있습니다.

이 도구들로 피처를 생성하는 작업은 다른 디지타이즈 작업 도구들과 동일한 규칙을 따릅니다: 꼭짓점을 배치하려면 왼쪽 클릭, 도형을 완료하려면 오른쪽 클릭하십시오. 도형을 그리는 동안, 두 원호 스트링 도구 사이를 전환하는 것은 물론 선형 도형 도구 로도 전환해서 복합 도형을 생성할 수 있습니다.

참고

만곡 도형은 호환되는 데이터 제공자에서만 만곡 도형으로 저장됩니다

QGIS가 모든 편집 가능한 데이터 유형 내에서 만곡 도형을 디지타이즈하는 것을 허용하고 있기는 하지만, 피처를 만곡 도형으로 저장하려면 곡선을 지원하는 (예를 들어 PostGIS, 메모리 레이어, GML 또는 WFS 같은) 데이터 제공자를 사용해야 합니다. 그렇지 않을 경우 QGIS가 원호를 선분화시킬 것입니다.

15.3.6.2. 원 그리기

원을 그릴 수 있는 도구들의 집합이 있습니다. 다음은 그 도구들의 설명입니다.

원은 원호 스트링으로 변환됩니다. 따라서 원호 스트링 추가 에서 설명한대로 데이터 제공자가 허용하는 경우 만곡 도형으로 저장될 것이고, 아닌 경우 QGIS가 원호를 선분화할 것입니다.

  • circle2Points Add circle from 2 points: 포인트 2개로 지름 및 원의 방향을 정의합니다. (왼쪽 클릭, 오른쪽 클릭)

  • circle3Points Add circle from 3 points: 포인트 3개가 원의 경계선 상에 있다고 가정하고 원을 그립니다. (왼쪽 클릭, 왼쪽 클릭, 오른쪽 클릭)

  • circleCenterPoint Add circle from center and a point: 중심 포인트와 원의 경계선 상에 있다고 가정한 포인트로 원을 그립니다. (왼쪽 클릭, 오른쪽 클릭) 고급 디지타이즈 작업 패널 과 함께 사용하는 경우, 첫 번째 클릭 이후 거리값을 설정하고 고정해서 이 도구를 “Add circle from center and radius” 도구로 사용할 수 있습니다.

  • circle3Tangents Add circle from 3 tangents: Draws a circle that is tangential to three segments. Note that you must activate snapping to segments (See Setting the snapping tolerance and search radius). Click on a segment to add a tangent. If two tangents are parallel, the coordinates of the click on the first parallel tangent are used to determine the positioning of the circle. If three tangents are parallel, an error message appears and the input is cleared. (Left-click, left-click, right-click)

  • circle2TangentsPoint Add circle from 2 tangents and a point: 접선 3개로 원을 그리는 도구와 유사하지만, 접선 2개를 선택한 다음 반경을 입력하고 원하는 중심을 선택해야 한다는 점이 다릅니다.

15.3.6.3. 타원 그리기

타원을 그릴 수 있는 도구들의 집합이 있습니다. 다음은 그 도구들의 설명입니다.

타원을 원호(circular string)로 변환할 수 없기 때문에, 타원은 언제나 선분화될 것입니다.

  • ellipseCenter2Points Add Ellipse from center and two points: 지정한 중심(center), 긴 반지름(major axis), 짧은 반지름(minor axis)으로 타원을 그립니다. (왼쪽 클릭, 왼쪽 클릭, 오른쪽 클릭)

  • ellipseCenterPoint Add Ellipse from center and a point: 중심과 모서리를 지정한 경계 상자에 내접하도록 타원을 그립니다. (왼쪽 클릭, 오른쪽 클릭)

  • ellipseExtent Add Ellipse from extent: 서로 바라보는 두 모서리를 지정한 경계 상자에 내접하도록 타원을 그립니다. (왼쪽 클릭, 오른쪽 클릭)

  • ellipseFoci Add Ellipse from foci: 두 초점(foci)을 나타내는 포인트 2개와, 타원 경계선 위에 있는 포인트 1개를 지정해서 타원을 그립니다. (왼쪽 클릭, 왼쪽 클릭, 오른쪽 클릭)

15.3.6.4. 직사각형 그리기

직사각형을 그릴 수 있는 도구들의 집합이 있습니다. 다음은 그 도구들의 설명입니다.

  • rectangleCenter Rectangle from center and a point: 지정한 중심과 모서리로 직사각형을 그립니다. (왼쪽 클릭, 오른쪽 클릭)

  • rectangleExtent Rectangle from extent: 서로 바라보는 두 모서리를 지정해서 직사각형을 그립니다. (왼쪽 클릭, 오른쪽 클릭)

  • rectangle3PointsDistance Rectangle from 3 points (distance): 포인트 3개를 지정해서 방향을 가진 직사각형을 그립니다. 첫 번째와 두 번째 포인트가 첫 변의 길이와 각도를 결정합니다. 세 번째 포인트는 다른 변의 길이를 결정합니다. 변들의 길이를 설정하기 위해 고급 디지타이즈 작업 패널 을 사용할 수 있습니다. (왼쪽 클릭, 왼쪽 클릭, 오른쪽 클릭)

  • rectangle3PointsProjected Rectangle from 3 points (projected): 앞의 도구와 동일하지만, 두 번째 변의 길이를 첫 번째 변 위의 세 번째 포인트의 투영으로부터 계산합니다. (왼쪽 클릭, 왼쪽 클릭, 오른쪽 클릭)

    ../../../_images/draw_rectangles_3_points.png

    그림 15.98 포인트 3개로 직사각형 그리기: 거리(오른쪽)와 투영(왼쪽)

15.3.6.5. 정다각형 그리기

정다각형(regular polygon)을 그리기 위한 도구 집합이 있습니다. 다음은 그 도구들의 설명입니다. 첫 번째 포인트의 위치를 왼쪽 클릭해서 지정합니다. 다각형의 변의 개수를 설정할 수 있는 대화창이 나타납니다. 정다각형을 완성할 위치를 오른쪽 클릭하십시오.

  • regularPolygon2Points Regular polygon from two points: 포인트 2개가 첫 번째 변의 길이 및 각도를 결정하는 정다각형을 그립니다.

  • regularPolygonCenterPoint Regular polygon from center and a point: 지정한 중심 포인트로부터 정다각형을 그립니다. 두 번째 포인트는 변의 중점까지의 각도 및 거리를 결정합니다.

  • regularPolygonCenterCorner Regular polygon from center and a corner: 앞의 도구와 동일하지만, 두 번째 포인트가 꼭짓점까지의 각도 및 거리를 결정합니다.

15.3.7. 고급 디지타이즈 작업 패널

새로운 또는 기존 도형을 캡처, 재형성, 분할하는 경우 고급 디지타이즈 작업 패널을 이용할 수도 있습니다. 라인을 정확히 평행으로 또는 특정 각도에 직각으로 디지타이즈할 수도 있고, 라인을 지정 각도로 고정시킬 수도 있습니다. 게다가, 좌표를 직접 입력해서 사용자의 새 도형을 정밀하게 정의할 수도 있습니다.

../../../_images/advanced_digitizing.png

그림 15.99 고급 디지타이즈 작업 패널

툴바를 오른쪽 클릭하거나, View ► Panels ► 메뉴로부터, 또는 Ctrl+4 키를 누르면 Advanced Digitizing 패널을 열 수 있습니다. 패널이 가시화되고 나면, cad Enable advanced digitizing tools 아이콘을 클릭해서 고급 다지타이즈 작업 도구를 활성화하십시오.

참고

맵 뷰가 지리 좌표인 경우 이 도구들을 활성화할 수 없습니다.

고급 다지타이즈 작업 도구의 목적은 맵 캔버스에서 디지타이즈 작업 도중 마우스를 이동시킬 때 좌표, 길이 그리고 각도를 고정하는 것입니다.

또한 상대 또는 절대 참조로 제약 조건을 생성할 수도 있습니다. 상대 참조란 이전 꼭짓점 또는 선분에 따라 다음 꼭짓점 제약 조건의 값이 변한다는 뜻입니다.

15.3.7.1. The toolbar

At the top of the Digitizing panel, you find the following buttons:

  • cad Enable advanced digitizing tools

  • cadConstruction Construction mode: allows to capture the clicks’ positions to reuse as reference points to lock distance, angle, X, Y, Z or M relative values. More details at 작성 모드.

  • cadParallel Parallel to draw a line parallel to an existing one (more at 평행 및 수직 라인)

  • cadPerpendicular Perpendicular to draw a line perpendicular to an existing one (more at 평행 및 수직 라인)

  • settings Snap to common angles: when moving the cursor, displays a virtual line that you can snap to to add the next vertex. The snapping line is defined by the last added vertex and an (absolute or relative to previous segment) angle from a preset list (following steps of 5°, 10°, 15°, 18°, 22.5°, 30°, 45° or 90°). Choose Do not snap to common angles to disable this feature.

  • floater Floater: displays a live preview of the coordinates right next to the cursor. The values can be accessed and edited using the panel’s shortcuts.

15.3.7.2. 키보드 단축키

고급 디지타이즈 작업 패널의 활용 속도를 높이려면, 다음과 같은 키보드 단축키를 사용할 수 있습니다:

간단한 설명

Ctrl+ 또는 Alt+ 키조합

Shift+ 키조합

D

거리 설정

거리 고정

A

각도 설정

각도 고정

마지막 선분에 상대적인 각도 켜고끄기

X

X 좌표 설정

X 좌표 고정

마지막 꼭짓점에 상대적인 X 켜고끄기

Y

Y 좌표 설정

Y 좌표 고정

최근 꼭짓점에 상대적인 Y 변경

Z

Set Z coordinate

Lock Z coordinate

Toggle relative Z to last vertex

M

Set M value

Lock M value

Toggle relative M to last vertex

C

작성 모드 변경

P

수직 및 평행 모드 변경

참고

Z coordinate and M value options are available only if compatible with the layer geometry dimension.

15.3.7.3. 절대 참조 디지타이즈 작업

아무것도 없는 상태에서 새 도형을 그리는 경우, 지정한 좌표에서 꼭짓점 디지타이즈를 시작할 수 있다면 매우 편리합니다.

For example, to add a new feature to a polygonal layer, click the capturePolygon button. You can enter the exact coordinates where you want to start editing the feature, i.e.:

  1. x 텍스트 란을 클릭합니다. (또는 X 단축키를 누릅니다.)

  2. 원하는 X 좌표를 입력한 다음 Enter 키를 누르거나 오른쪽에 있는 locked 아이콘을 클릭하면 맵 캔버스 상의 X 좌표의 축에 마우스가 고정됩니다.

  3. y 텍스트 란을 클릭합니다. (또는 Y 단축키를 누릅니다.)

  4. 원하는 Y 좌표를 입력한 다음 Enter 키를 누르거나 오른쪽에 있는 locked 아이콘을 클릭하면 맵 캔버스 상의 Y 좌표의 축에 마우스가 고정됩니다.

  5. If available and relevant, proceed as above to add the Z coordinate and M value (respectively z or m text box).

    Two blue dotted lines and a green cross identify the exact coordinates you entered.

  6. Start digitizing by clicking on the map canvas; a vertex is added at the green cross position.

    ../../../_images/advanced_digitizing_coordinates.png

    그림 15.100 지정 좌표에서 그리기 시작

  7. You can continue digitizing by free hand, adding a new set of coordinates, or you can type the segment’s length (distance) and angle.

  8. If you want to draw a segment of a given length:

    1. Click the d (distance) text box (keyboard shortcut D)

    2. Type the distance value (in map units)

    3. Press Enter or click the locked button on the right to lock the mouse in the map canvas to the length of the segment. In the map canvas, the latest vertex is surrounded by a circle whose radius is the value entered in the distance text box. A cross on the circle shows the position of the next vertex if you click.

    ../../../_images/advanced_digitizing_distance.png

    그림 15.101 고정 길이 선분

  9. You can also constrain the vertex position, setting the angle of the segment. As described before:

    1. Click the a (angle) text box (keyboard shortcut A)

    2. Type the angle value (in degrees)

    3. Press Enter or click the locked button on the right to lock it. A line going through the latest vertex and rotated based on the set angle appears in the map canvas and a cross on it shows the next vertex position if you click.

    ../../../_images/advanced_digitizing_angle.png

    그림 15.102 고정 각도 선분

힌트

Pressing Ctrl+<key> or Alt+<key> automatically locks the target property and puts its value into edit. Modify, press Enter and you are done. Combined with the floater Toggle floater, this can be a real time saver, with keyboard digitizing.

15.3.7.4. 상대 참조 디지타이즈 작업

각도 또는 좌표의 절대값을 사용하는 대신, 직전에 디지타이즈한 꼭짓점 또는 선분에 상대적인 값을 사용할 수도 있습니다.

각도의 경우, a 텍스트란 왼쪽에 있는 delta 버튼을 클릭해서 (또는 Shift+A 조합키를 눌러서) 이전 선분에 상대적인 각도를 켜고 끌 수 있습니다. 이 옵션을 켜면, 직전 선분과 마우스 포인터 사이의 각도를 측정합니다.

For coordinates, click the delta buttons to the left of the x, y, z or m text boxes (or press Shift+<key>) to toggle relative coordinates to the previous vertex. With these options on, coordinates measurement will consider the last vertex to be the origin of the set coordinates.

15.3.7.5. 지속 고정

Both in absolute or relative reference digitizing, angle, distance, X, Y, Z and M constraints can be locked continuously by clicking the lockRepeating Continuous lock buttons. Using continuous lock allows you to digitize several points or vertexes using the same constraints.

15.3.7.6. 평행 및 수직 라인

All the tools described above can be combined with the cadPerpendicular Perpendicular and cadParallel Parallel tools. These two tools allow drawing segments perfectly perpendicular or parallel to another segment. The target segment can be on another layer, another feature within the layer or the feature being digitized (requires self-snapping option).

To draw a perpendicular segment:

  1. First add one of the segment vertices.

  2. Click the cadPerpendicular Perpendicular icon (keyboard shortcut P) to activate it.

  3. Click on the segment that you want to be perpendicular to.

  4. A virtual dotted line perpendicular to the segment through the previous vertex appears. The angle property is locked, constraining the next vertex on that line and, a cross indicates the projected position of the cursor on the line. Click to place the new vertex.

    ../../../_images/advanced_digitizing_perpendicular.png

    그림 15.103 수직 디지타이즈 작업

To draw a parallel segment, the steps are the same except that you need to click on the cadParallel Parallel icon (keyboard shortcut P twice).

../../../_images/advanced_digitizing_parallel.png

그림 15.104 평행 디지타이즈 작업

These two tools just find the right angle of the perpendicular and parallel angle and lock this parameter during your editing. Unlock the angle parameter to cancel their use in the middle of the process.

15.3.7.7. 작성 모드

You can enable and disable construction mode by clicking on the cadConstruction Construction mode icon or with the C keyboard shortcut. While in construction mode, clicking the map canvas won’t add new vertexes, but will capture the clicks’ positions so that you can use them as reference points to then lock distance, angle or X, Y, Z, M relative values.

예를 들어, 기존 포인트에서 정확히 동일한 거리에 있는 포인트를 몇 개 그리는 데 작성 모드를 사용할 수 있습니다.

With an existing point in the map canvas and the snapping mode correctly activated, you can easily draw other points at given distances and angles from it. In addition to the cad button, you have to activate also the construction mode by clicking the cadConstruction Construction mode icon or with the C keyboard shortcut.

사용자가 해당 포인트로부터 거리를 계산하고자 하는 포인트 옆을 클릭하고 d 텍스트란을 클릭한 다음 (또는 D 단축키를 누른 다음) 원하는 거리를 입력하고 Enter 키를 눌러 다음과 같이 맵 캔버스에 마우스 위치를 고정하십시오:

../../../_images/advanced_digitizing_distance_point.png

그림 15.105 점거리

새 포인트를 추가하기 전에, C 단축키를 눌러 작성 모드를 끄십시오. 이제 맵 캔버스를 클릭하면, 입력한 거리에 포인트가 배치될 것입니다.

You can also use the angle constraint to, for example, create another point at the same distance of the original one, but at a particular angle from the newly added point. Click the cadConstruction Construction mode icon or with the C keyboard shortcut to enter construction mode. Click the recently added point, and then the other one to set a direction segment. Then, click on the d text box (D shortcut) type the desired distance and press Enter. Click the a text box (A shortcut) type the angle you want and press Enter. The mouse position will be locked both in distance and angle.

../../../_images/advanced_digitizing_distance_angle_point.png

그림 15.106 포인트들로부터의 거리 및 각도

새 포인트를 추가하기 전에, C 단축키를 눌러 작성 모드를 끄십시오. 이제 맵 캔버스를 클릭하면, 입력한 거리에 포인트가 배치될 것입니다. 이 과정을 반복하면 여러 포인트를 추가할 수 있습니다.

../../../_images/advanced_digitizing_distance_point_final.png

그림 15.107 지정 거리 및 각도에 있는 포인트들

15.3.8. 제자리(in-place) 공간 처리 레이어 수정자

공간 처리 메뉴 는 입력 피처 또는 입력 피처와 (동일 레이어 안에 있을 수도 있고 아닐 수도 있는) 다른 피처의 관계의 속성을 기반으로 새 피처를 생성하고 분석할 수 있는 수많은 도구를 제공합니다. 새 레이어를 산출물로 생성하는 것이 공통된 습성이지만, 몇몇 알고리즘은 입력 레이어를 수정할 수도 있습니다. 이를 사용하면 고급의 복잡한 작업을 통해 다중 피처 수정을 간편하게 자동화할 수 있습니다.

피처를 제자리에서 편집하려면:

  1. Layers 패널에서 편집할 레이어를 선택하십시오.

  2. 관심이 있는 피처를 선택하십시오. 이 단계를 건너뛰어도 되는데, 그럴 경우 레이어 전체에 수정 사항을 적용할 것입니다.

  3. 공간 처리 툴박스 상단에 있는 processSelected Edit Features In-Place 버튼을 클릭하십시오. 알고리즘 목록을 필터링해서 제자리 수정을 지원하는 알고리즘만 표시할 것입니다. 예를 들면:

    • 레이어 수준에서가 아니라 피처 소스 수준에서 작동하는 알고리즘

    • 필드를 추가하거나 제거하는 등 레이어 구조를 변경하지 않는 알고리즘

    • 라인 레이어를 포인트 레이어로 바꾸는 등 도형 유형을 변경하지 않는 알고리즘

    ../../../_images/edit_inplace_algorithms.png

    그림 15.108 공간 처리 알고리즘: 전체(왼쪽) 대 제자리 폴리곤 편집기(오른쪽)

  4. 사용자가 실행하려는 알고리즘을 찾아 더블클릭하십시오.

    참고

    알고리즘이 (일반적인 입력/산출 레이어 파라미터를 제외하면) 사용자가 설정한 어떤 파라미터도 필요로 하지 않는 경우, 어떤 대화창도 열리지 않고 알고리즘이 즉시 실행됩니다.

    1. 일반적인 입력/산출 레이어 파라미터가 아닌 다른 파라미터가 필요한 경우, 알고리즘 대화창이 열립니다. 필요한 정보를 입력하십시오.

    2. 활성화된 선택 집합이 있는지 여부에 따라 Modify Selected Features 또는 Modify All Features 를 클릭하십시오.

    변경 사항을 레이어에 적용하고 편집 버퍼에 저장합니다. 레이어는 자동으로 편집 모드로 넘어가며, 레이어명 옆에 표시되는 editableEdits 아이콘은 저장하지 않은 수정 사항이 있다는 사실을 나타냅니다.

  5. 다른 작업과 마찬가지로, saveEdits Save layer edits 버튼을 클릭하면 레이어에 변경 사항을 저장합니다. 물론 undo Undo 버튼을 클릭해서 모든 수정 사항을 되돌릴 수도 있습니다.