6. 프로젝트 파일 작업

6.1. QGIS 프로젝트 소개

프로젝트란 사용자의 QGIS 세션 상태를 말합니다. QGIS는 한 번에 프로젝트 하나에서만 작업 가능합니다. 설정은 프로젝트 별로 관리되며 새 프로젝트의 경우 기본 설정(옵션 참조)을 따릅니다. QGIS 는 메뉴 옵션 Project ► fileSave Save 또는 Project ► fileSaveAs Save As… 를 통해 사용자의 작업 공간(workspace)을 QGIS 프로젝트 파일 로 저장할 수 있습니다.

참고

프로젝트가 작업 중 변경됐다면 창의 제목 막대에 * 심볼이 나타나고, QGIS가 기본적으로 프로젝트 파일에 변경 사항을 덮어 쓸지 물어볼 것입니다. Settings ► Options ► General 메뉴 아래에 있는 checkbox Prompt to save project and data source changes when required 를 체크해서 이 옵션을 활성화 할 수 있습니다.

기존 프로젝트를 QGIS로 불러오려면 탐색기 패널에서 프로젝트 파일을 선택하거나, Project ► fileOpen Open…, Project ► New from template or Project ► Open Recent ► 메뉴를 이용하면 됩니다.

QGIS 구동 시, Project TemplatesRecent Projects 가 표시됩니다. 최근 프로젝트 10개까지의 스크린샷, 프로젝트 이름 및 파일 경로를 포함합니다. Recent Projects 목록을 통해 최근 사용한 프로젝트에 쉽게 접근할 수 있습니다. 프로젝트를 열려면 이 목록의 항목 하나를 더블클릭하거나 프로젝트 템플릿을 더블클릭하십시오. 목록의 항목을 오른쪽 클릭하면 Pin to List, Open Directory… 또는 Remove from List 메뉴가 나타납니다. 새 프로젝트를 자동으로 생성하려면 레이어를 추가하면 됩니다. 그러면 목록이 사라지고 맵 캔버스가 보일 것입니다.

사용자 세션을 정리하고 새롭게 시작하고 싶다면, 메뉴에서 Project ► fileNew New 를 선택하십시오. 기존 프로젝트를 불러온 후 또는 마지막으로 저장한 후에 변경 사항이 발생했을 경우, 이 메뉴는 사용자에게 기존 프로젝트를 저장할 것인지 물어볼 것입니다.

새 프로젝트를 열었다면, 사용자가 프로젝트를 저장하기 전까지 제목 막대에 제목 없는 프로젝트 라고 표시될 것입니다.

../../../_images/new_project.png

그림 6.1 QGIS에서 새 프로젝트 시작

프로젝트 파일이 저장하는 정보는 다음을 포함합니다:

  • 추가된 레이어

  • 레이어 별 쿼리 가능 여부

  • 심볼 및 스타일을 포함한 레이어 속성

  • Layer notes

  • 맵 뷰의 투영법

  • 마지막 뷰의 영역

  • 인쇄 조판

  • 설정을 포함한 인쇄 조판의 구성요소들

  • 인쇄 조판의 지도 설정

  • 디지타이즈 작업 설정

  • 테이블 관계

  • 프로젝트 매크로

  • 프로젝트 기본 스타일

  • 플러그인 설정

  • 프로젝트 속성의 OWS 설정 탭에서 지정한 QGIS 서버 설정

  • DB 관리자에 저장된 쿼리들

프로젝트 파일은 XML 유형(QGS/QGZ ─ QGIS 프로젝트 파일 포맷 참조)으로 저장되기 때문에, 사용자가 방법만 안다면 QGIS 외부에서 파일을 편집할 수 있습니다. 프로젝트 파일 포맷은 여러 번 업데이트됐습니다. QGIS 과거 버전에서 저장된 프로젝트 파일은 더 이상 제대로 동작하지 않을 수도 있습니다.

참고

QGIS는 기본적으로 사용자에게 버전이 다르다는 사실을 경고할 것입니다. Settings ► Options 메뉴의 General 탭에서 해당 옵션을 끄거나 켤 수 있습니다. (checkbox Warn when opening a project file saved with an older version of QGIS)

QGIS에서 .qgs 프로젝트 파일을 저장할 때마다 동일 디렉터리에 .qgs~ 확장자를 가진 프로젝트 파일의 백업을 생성합니다.

QGIS 프로젝트 파일의 확장자는 .qgs 이지만, 기본적으로 .qgz 확장자를 가진 압축 포맷으로 저장됩니다. .qgz 파일(ZIP 압축 파일)은 .qgs 파일과 함께 보조 데이터 용 연관 SQLite 데이터베이스(.qgd)를 담고 있습니다. .qgz 파일의 압축을 해제하면 이 파일들이 나옵니다.

참고

보조 저장소 속성 메커니즘은 프로젝트 파일을 압축하는 효용성을 크게 높여줍니다. 압축 파일이 보조 데이터를 담고 있기 때문입니다.

다음 프로젝트 메뉴 항목들을 사용하면 PostgreSQL 데이터베이스에 프로젝트를 저장하거나 불러올 수 있습니다:

  • Project ► Open from

  • Project ► Save to

이 메뉴 항목들에는 추가적인 프로젝트 저장 시행(PostgreSQL 및 GeoPackage) 목록을 가진 하위 메뉴가 있습니다. 각각을 클릭하면 GeoPackage 연결과 프로젝트를, 또는 PostgreSQL 연결과 스키마와 프로젝트를 선택할 수 있는 대화창이 열릴 것입니다.

QGIS 탐색기 패널에서 GeoPackage 또는 PostgreSQL에 저장된 프로젝트를 불러올 수도 있습니다. 탐색기 패널에서 해당 항목을 더블클릭하거나 맵 캔버스로 드래그하면 됩니다.

6.2. 엉터리 파일 경로 처리

프로젝트를 열 때, 더 이상 사용할 수 없는 서비스/데이터베이스 또는 재명명되었거나 이동된 파일 때문에 QGIS가 일부 데이터소스에 접근할 수 없을 수도 있습니다. 이런 경우 QGIS는 찾을 수 없는 레이어의 참조 정보를 표시하는 Handle Unavailable Layers 대화창을 엽니다. 이 창에서:

  • Datasource 필드를 더블클릭하고, 각 레이어의 경로를 수정한 다음 Apply changes 버튼을 클릭하면 됩니다.

  • 한 행을 선택하고, Browse 버튼을 눌러 정확한 위치를 찾아낸 다음 Apply changes 버튼을 클릭하면 됩니다.

  • Press Auto-Find to browse the folders and try to automatically fix all or selected broken path(s). Be aware that the browsing may take some time. Then click Apply changes.

  • Keep Unavailable Layers 버튼을 누르면 대화창을 무시하고 엉터리 경로(들)를 가진 채로 사용자 프로젝트를 엽니다. 이 경우 사용자 레이어가 Layers 패널에 표시는 되지만, Layers 패널에서 사용자 레이어 옆에 있는 indicatorBadLayer Unavailable layer! 아이콘 또는 해당 레이어의 컨텍스트 메뉴 가운데 Repair Data Source… 항목을 사용해서 경로를 고치기 전에는 어떤 데이터도 없습니다.

    Repair Data Source… 도구로 레이어 경로를 수정하고 나면, QGIS가 다른 모든 엉터리 경로를 스캔해서 동일한 엉터리 파일 경로를 가진 레이어를 자동으로 고치려 시도합니다.

  • deleteSelected Remove Unavailable Layers 아이콘을 클릭하면 사용할 수 없는 레이어를 프로젝트에서 삭제할 수 있습니다.

6.3. 산출물 생성

사용자의 QGIS 세션에서 산출물을 생성하는 방법이 몇 가지 있습니다. 이미 QGIS 프로젝트 소개 에서 프로젝트 파일로 저장한다는 한 가지 방법을 설명했습니다. 다음은 산출물 파일을 생성하는 다른 방법들의 예시입니다:

  • 이미지 생성하기: Project ► Import/Export ► saveMapAsImage Export Map to Image… 메뉴는 맵 캔버스를 사용자가 지정한 축척, 해상도, 크기 등으로 렌더링한 이미지 포맷(PNG, JPG, TIFF…)으로 생성합니다. 이미지를 지리참조시킬 수도 있습니다. 더 자세한 내용은 맵 뷰 내보내기 를 참조하세요.

  • PDF 파일로 내보내기: Project ► Import/Export ► Export Map to PDF… 메뉴는 맵 캔버스를 사용자 지정 축척, 해상도 그리고 여러 고급 설정(단순화, 지리참조 등)으로 렌더링한 PDF 파일을 생성합니다. 더 자세한 내용은 맵 뷰 내보내기 를 참조하세요.

  • DXF 파일로 내보내기: Project ► Import/Export ► Export Project to DXF… 메뉴는 사용자가 DXF 파일로 내보내고자 하는 ‘심볼 모드’, ‘심볼 축척’ 그리고 벡터 레이어를 정의할 수 있는 대화창을 엽니다. ‘심볼 모드’ 를 통해 QGIS 심볼을 원본에 충실하게 내보낼 수 있습니다. (새 DXF 파일 생성하기 참조)

  • 맵 디자인: Project ► newLayout New Print Layout… 메뉴는 사용자가 현재 맵 캔버스를 조판하고 인쇄할 수 있는 대화창을 엽니다. (맵 조판 작업 참조)