14.4. 편집 작업

QGIS는 OGR, SpatiaLite, PostGIS, MSSQL Spatial 및 Oracle Spatial 벡터 레이어와 테이블을 편집할 수 있는 다양한 기능을 보유하고 있습니다.

참고

GRASS 레이어 편집 과정은 조금 다릅니다. 자세한 내용은 GRASS 벡터 레이어 디지타이즈 및 편집하기 을 참조하세요.

병행 편집

QGIS 이번 버전은 사용자가 피처를 편집하는 도중에 다른 사용자가 동일한 피처를 편집하고 있지는 않은지 추적하지 않습니다. 마지막에 저장하는 변경 사항이 적용될 것입니다.

14.4.1. 스냅 허용 오차 및 검색 반경 설정

벡터 레이어 도형을 정확하게, 최적으로 편집하기 위해 피처 꼭짓점에 대한 스냅 허용오차 및 검색 반경을 적절한 값으로 설정해야 합니다.

14.4.1.1. 스냅 허용오차

스냅 허용 오차란 사용자가 새 꼭짓점을 설정하거나 또는 기존 꼭짓점을 이동시킬 때 연결하려는 가장 가까운 꼭짓점 또는 선분을 검색하기 위해 QGIS가 사용하는 거리를 말합니다. 스냅 허용 오차 안이 아닌 경우, QGIS는 기존 꼭짓점 또는 선분에 스냅시키는 대신 사용자가 마우스 버튼을 놓은 위치에 꼭짓점을 둘 것입니다.

스냅 허용 오차 설정은 허용 오차를 사용하는 모든 도구에 적용됩니다.

Snapping Toolbar 에 있는 snapping Enable snapping 버튼을 클릭하거나 s 키를 누르면 스냅 모드를 활성화/비활성화할 수 있습니다. 이 툴바에서 스냅 모드, 허용 오차 값, 단위도 환경 설정할 수 있습니다.

Project ▶ Snapping Options… 에서도 스냅 모드 환경을 설정할 수 있습니다.

스냅을 활성화할 레이어(들)를 선택하는 데 다음 세 가지 옵션이 있습니다:

  • All layers: 프로젝트에 있는 가시화된 모든 레이어를 선택합니다. 모든 꼭짓점 그리고/또는 선분에 포인터를 스냅시키는 빠르고 간단한 설정입니다. 대부분의 경우 이 스냅 모드를 사용하면 충분하지만, 수많은 벡터 레이어를 가진 프로젝트의 경우 사용에 주의를 요합니다. 성능에 영향을 줄 수도 있기 때문입니다.

  • Current layer: 활성화된 레이어만 선택합니다. 편집 중인 레이어 내부의 위상(topology)의 일관성을 보장할 수 있는 편리한 방법입니다.

  • Advanced Configuration: 스냅 모드 및 허용 오차를 레이어 기반으로 활성화하고 조정할 수 있습니다. (스냅 옵션 (고급설정 모드) 그림을 참조하세요.) 어떤 레이어를 편집하고 있는데 다른 레이어에 꼭짓점을 스냅시켜야 하는 경우, 대상 레이어가 체크된 상태인지 확인하고 스냅 허용 오차를 훨씬 큰 값으로 올리십시오. 스냅 옵션 대화창에서 체크되지 않은 레이어에서는 스냅이 결코 일어나지 않을 것입니다.

스냅 모드를 To vertex, To segment, 그리고 To vertex and segment 가운데 하나로 선택할 수 있습니다.

허용 오차를 map units 또는 pixels 로 설정할 수 있습니다. pixels 로 설정하면, 맵 축척을 변경하더라도 일정하게 스냅할 수 있다는 장점이 있습니다. 일반적으로 10~12픽셀이면 괜찮은 값이지만, 사용자 스크린의 해상도에 따라 달라집니다. 맵 단위로 설정하면 허용 오차를 실제 지표 거리와 비례하도록 만들 수 있습니다. 예를 들어 요소들 사이에 최소 거리를 두어야 한다면, 꼭짓점들을 서로 너무 가깝지 않게 추가하는 데 이 옵션이 유용할 것입니다.

../../../_images/editProjectSnapping.png

그림 14.85 스냅 옵션 (고급설정 모드)

참고

기본적으로, 가시화된 (레이어 심볼이 《No symbols》 인 경우를 제외하고, 피처 스타일이 표시된) 피처에만 스냅할 수 있습니다. Settings ▶ Options ▶ Digitizing 탭에 있는 unchecked Enable snapping on invisible features 옵션을 체크하면 가시화되지 않은 피처에도 스냅할 수 있게 됩니다.

스냅 기본값 활성화

Settings ▶ Options ▶ Digitizing 탭에서 모든 새 프로젝트가 기본적으로 스냅을 활성화시키도록 설정할 수 있습니다. 기본 스냅 모드, 허용 오차 값, 그리고 단위도 설정할 수 있습니다. 여기서 설정한 값들이 Snapping Options 대화창에 표시될 것입니다.

14.4.1.2. 교차점 스냅 활성화

또다른 옵션은 snappingIntersection snapping on intersection 을 선택하는 것입니다. 이 옵션은 스냅이 활성화된 레이어의 도형 교차점에 ─ 설령 교차점에 꼭짓점이 없는 경우라도 ─ 스냅할 수 있게 해줍니다.

14.4.1.3. 검색 반경

Search radius for vertex edits 는 맵을 클릭했을 때 사용자가 선택하려는 가장 가까운 꼭짓점을 《검색》하기 위해 QGIS가 사용하는 거리를 말합니다. 검색 반경 안이 아닌 경우, QGIS가 아무것도 찾지 못 하고 편집 작업을 위한 어떤 꼭짓점도 선택하지 못 할 것입니다. Settings ▶ options Options ▶ Digitizing 탭에서 꼭짓점 편집 용 검색 반경을 정의할 수 있습니다. (이 탭이 스냅 기본 값을 정의하는 곳입니다.)

스냅 허용 오차 및 검색 반경은 map units 또는 pixels 로 설정되기 때문에, 알맞은 설정값을 찾기 위해 시행착오를 거쳐야 할 수도 있습니다. 허용 오차를 너무 길게 설정하면, QGIS가 틀린 꼭짓점에 스냅할 수도 있습니다. 특히 대량의 인접한 꼭짓점들을 다루고 있을 경우엔 말입니다. 검색 반경을 짧게 설정할수록, 사용자가 원하는 꼭짓점을 찾기 힘들어질 것입니다.

14.4.2. 위상 편집

이런 스냅 옵션 이외에도, Snapping options… 대화창(Project ▶ Snapping options) 및 Snapping 툴바에서 몇몇 다른 위상 기능들을 활성화/비활성화할 수 있습니다.

14.4.2.1. 위상 편집 활성화

topopologicalEditing Topological editing 버튼은 공통 경계선을 공유하는 피처를 편집하고 유지보수할 수 있게 해줍니다. 이 옵션을 활성화하면, QGIS가 피처들이 공유하는 경계선을 〈탐지〉 합니다. 공통 꼭짓점/선분을 이동시키면, QGIS가 인접 피처 도형의 꼭짓점/선분도 이동시킬 것입니다.

위상 편집 작업은 서로 다른 레이어들의 피처들과 작동합니다. 해당 레이어들이 가시화되어 있고 편집 모드라면 말이죠.

14.4.2.2. 새 폴리곤의 중첩을 피하기

스냅 모드를 Advanced configuration 으로 설정했을 때, 폴리곤 레이어의 경우 checkbox Avoid overlap 이라는 옵션이 존재합니다. 이 옵션은 선택한 레이어에서 기존 피처에 중첩하는 새 피처를 그리지 못 하도록 막습니다. 다른 폴리곤과 인접한 폴리곤을 디지타이징할 때 속도를 향상시키는 효과가 있습니다.

이미 폴리곤이 하나 있는 경우, 이 옵션을 활성화한 상태로 두 번째 폴리곤을 기존 폴리곤과 서로 교차하도록 디지타이즈할 수 있는데, 이때 QGIS가 두 번째 폴리곤을 기존 폴리곤의 경계선에 맞춰 자를 것입니다. 공통 경계선의 꼭짓점을 모두 디지타이즈하지 않아도 된다는 장점이 있습니다.

참고

기존 도형이 새 도형을 완전히 덮는 경우, 새 도형은 제거되며 QGIS가 오류 메시지를 띄울 것입니다.

경고

Avoid overlap 옵션을 조심해서 사용해야 합니다

이 옵션은 모든 폴리곤 레이어에서 중첩하는 새 도형을 자르기 때문에, 더 이상 이 옵션이 필요하지 않게 되자마자 반드시 체크 해제해야 합니다. 그렇지 않을 경우 기대하지 않은 도형을 얻게 될 수 있습니다.

14.4.2.3. 도형 점검기

이 핵심 플러그인으로 도형의 유효성을 확인할 수 있습니다. 도형 점검기 플러그인 에서 이 플러그인에 관한 자세한 정보를 찾아볼 수 있습니다.

14.4.2.4. 자동 투사

보통, 캡처 작업 맵 도구(피처 추가, 부분 추가, 고리 추가, 재형성 및 분할) 이용시 사용자가 피처의 각 꼭짓점을 클릭해야 합니다. 자동 투사(automatic tracing) 모드를 사용하면 디지타이즈 작업 과정의 속도를 향상시킬 수 있습니다. 디지타이즈 작업 도중 모든 꼭짓점을 직접 배치해야 할 필요가 없어지기 때문이죠:

  1. (Snapping 툴바에 있는) tracing 아이콘을 클릭하거나 T 키를 눌러 tracing Tracing 도구를 활성화하십시오.

  2. 사용자가 투사하고자 하는 피처의 꼭짓점이나 선분에 스냅 하십시오.

  3. 스냅하고 싶은 또다른 꼭짓점 또는 선분으로 마우스를 가져가면 일반적인 직선이 아니라 디지타이즈 작업 고무줄이 마지막으로 스냅한 포인트에서 현재 위치까지의 경로를 나타냅니다.

    QGIS는 사실 기저 피처 위상을 이용해서 두 포인트 사이의 최단 경로를 생성합니다. 투사 기능을 이용하려면 경로를 생성하기 위해 투사가 가능한 레이어의 스냅 기능이 활성화된 상태여야 합니다. 또 디지타이즈 작업 중 기존 꼭짓점 또는 선분에 스냅해야 하며, 두 노드가 기존 피처 경계를 통해 위상적으로 연결될 수 있는지도 확실히 해야 합니다. 그렇지 않으면 QGIS가 두 노드를 연결할 수 없으므로 단일 직선을 투사하게 됩니다.

  4. 클릭하면 QGIS가 표시된 경로를 따라 중간 단계 꼭짓점들을 배치합니다.

피처 경계를 따라 투사하는 것이 아니라 피처 경계와 평행하는 경로를 디지타이즈하려면 tracing Enable Tracing 아이콘을 펼쳐 Offset 옵션을 설정하십시오. 양의 값은 투사 방향의 왼쪽으로 새로 그리도록 이동시키고, 음의 값은 그 반대로 투사 방향의 오른쪽으로 새로 그리게 이동시킵니다.

참고

최적의 투사를 위해 맵 축척 또는 스냅 설정을 조정하기

맵 캔버스에 너무 많은 피처들이 있는 경우, 잠재적으로 너무 긴 투사 구조 준비 및 대용량 메모리 부담을 피하기 위해 투사를 비활성화시킵니다. 맵을 확대하거나 일부 레이어를 비활성화하면 다시 투사를 활성화시킵니다.

참고

위상 포인트를 추가하지 않습니다

이 도구는 Topological editing 옵션을 활성화한 상태이더라도 기존 폴리곤 도형에 포인트를 추가하지 않습니다. 편집 중인 레이어에 도형 정밀도를 활성화한 경우라면, 새로 그린 도형이 기존 도형과 정확하게 일치하지 않을 수도 있습니다.

T 키를 눌러 자동 투사를 빠르게 활성화/비활성화하기

T 키를 누르면, (피처를 디지타이즈하는 도중이라도) 투사를 활성화/비활성화할 수 있습니다. 따라서 투사를 활성화한 상태로 피처의 일부분을 디지타이즈하고 다른 부분은 비활성화한 상태로 디지타이즈할 수도 있습니다. 투사를 비활성화해도 도구들은 아무 일 없이 작동합니다.

14.4.3. 기존 레이어 디지타이징

기본적으로, QGIS는 레이어를 읽기 전용으로 불러옵니다. 이 습성은 혹시라도 마우스가 미끄러져 레이어를 실수로 편집하는 일을 피하기 위한 예방책입니다. 하지만, 편집을 지원하는 데이터 제공자이며 (데이터 포맷 및 필드 탐구 참조) 기저 데이터소스가 쓰기 가능인 경우 (예: 파일이 읽기 전용이 아닌 경우) 모든 레이어를 편집할 수 있습니다.

프로젝트 내부에서 레이어 편집 권한 제한

Project ▶ Properties… ▶ Data Sources ▶ Layers Capabilities 테이블에서, 제공자의 권한 허가 여부에 상관없이 어떤 레이어든 읽기 전용으로 설정할 수 있습니다. 이것은 다중 사용자 환경에서 승인받지 않은 사용자가 실수로 레이어를 (예: Shapefile을) 편집해서 혹시라도 데이터를 변질시키는 일을 막기 위한 간편한 방법이 될 수 있습니다. 이 설정은 현재 프로젝트 안에서만 적용된다는 사실을 기억하십시오.

일반적으로, 벡터 레이어를 편집하기 위한 도구는 고급 디지타이즈 작업 에서 설명하는 대로 디지타이즈 작업과 고급 디지타이즈 작업 툴바로 나뉘어져 있습니다. View ▶ Toolbars ▶ 메뉴에서 둘 다 선택하고 선택 해제할 수 있습니다.

기본 디지타이즈 작업 도구를 사용하면, 다음 기능들을 수행할 수 있습니다:

아이콘

목적

아이콘

목적

allEdits

현재 편집 내용

toggleEditing

편집 변경

saveEdits

레이어 편집 내용 저장

newTableRow

신규레코드 추가

capturePoint

피처 추가: 포인트 캡처

captureLine

피처 추가: 라인 캡처

capturePolygon

피처 추가: 폴리곤 캡처

vertexTool

꼭짓점 도구 (모든 레이어)

vertexToolActiveLayer

꼭짓점 도구 (현재 레이어)

multiEdit

선택한 모든 피처의 속성을 동시에 수정

deleteSelectedFeatures

선택 항목 삭제

editCut

피쳐 자르기

editCopy

피쳐 복사

editPaste

피쳐 붙여넣기

undo

실행 취소

redo

재실행

표: 편집 작업 - 벡터 레이어 기본 편집 툴바

이 모든 디지타이즈 작업 도구를 쓰는 도중에 도구를 비활성화시키지 않고서도 맵 캔버스에서 zoom_pan 할 수 있다는 사실을 기억하십시오.

모든 편집 세션은 선택한 레이어의 컨텍스트 메뉴, 속성 테이블 대화창, 디지타이즈 작업 툴바, 또는 Edit 메뉴에 있는 toggleEditing Toggle editing 옵션을 선택해서 시작됩니다.

레이어를 편집 모드로 전환하면, 편집 작업 툴바에 있는 부가 도구 아이콘들이 활성화되며, Settings ▶ Options… ▶ Digitizing 탭에 있는 checkbox Show markers only for selected features 옵션을 체크하지 않은 경우 모든 피처의 꼭짓점에 마커가 나타날 것입니다.

정기적으로 저장

saveEdits Save Layer Edits 아이콘으로 주기적으로 편집 내용을 저장하는 것을 잊지 마십시오. 이 아이콘을 클릭하면 사용자의 데이터소스가 모든 수정 사항을 받아들일 수 있는지도 확인할 것입니다.

14.4.3.1. 피처 추가하기

레이어 유형에 따라, 툴바에 있는 newTableRow Add Record, capturePoint Add Point Feature, captureLine Add Line Feature 또는 capturePolygon Add Polygon Feature 아이콘을 통해 현재 레이어에 새 피처를 추가할 수 있습니다.

비도형 피처를 추가하려면, newTableRow Add Record 버튼을 클릭하면 열리는 피처 양식에 속성을 입력할 수 있습니다. 공간 활성화된 도구로 피처를 생성하려면, 먼저 도형을 디지타이즈한 다음 그 속성을 입력해야 합니다. 도형을 디지타이즈하려면:

  1. 맵 영역을 왼쪽 클릭해서 사용자의 새 피처의 첫 번째 포인트를 생성하십시오. 포인트 피처의 경우 이것만으로 충분하며, 필요한 경우 피처 속성을 입력할 수 있는 피처 양식이 열릴 것입니다. 레이어 속성에서 도형 정밀도 를 설정했다면 정규 거리를 기반으로 피처를 생성하는 그리드에 스냅 기능을 사용할 수 있습니다.

  2. 라인 또는 폴리곤 도형의 경우, 사용자가 캡처하려는 각 추가 포인트를 왼쪽 클릭하거나 또는 자동 투사 기능을 이용해서 디지타이즈 작업 속도를 올릴 수 있습니다. 이렇게 하면 사용자가 배치한 꼭짓점들 사이에 연속적인 직선을 생성할 것입니다.

    참고

    최근 추가한 노드를 되돌리려면 Delete 또는 Backspace 키를 누르십시오.

  3. 포인트 추가 작업을 완료했다면, 맵 영역 어디든 오른쪽 클릭해서 해당 피처의 도형 입력 작업이 끝났다고 확인하십시오.

    참고

    라인 또는 폴리곤 도형을 디지타이즈하는 도중 선형 Add feature 도구와 원호 스트링 도구 사이를 전환해가며 복합 만곡 도형을 생성할 수 있습니다.

    디지타이즈 작업 고무줄을 사용자 지정하기

    폴리곤을 캡처하는 도중에 기본값인 빨강색 고무줄이 아래에 있는 ─ 사용자가 포인트를 캡처하고자 하는 ─ 피처 또는 장소를 가릴 수가 있습니다. Settings ▶ Options ▶ Digitizing 대화창에서 고무줄의 Fill Color 에 대한 투명도(또는 알파 채널)를 높이면 이 문제를 해결할 수 있습니다. 또는 Don’t update rubber band during node editing 옵션을 체크해서 고무줄을 사용하지 않을 수도 있습니다.

  4. 디지타이즈 작업을 완료하면 새 피처를 위한 정보를 입력할 수 있는 속성 대화창이 열립니다. 새 벡터 피처를 디지타이즈한 후의 속성 입력 양식 대화창 그림은 알래스카에 있는 가상의 새 강을 위한 속성을 설정하는 예시입니다. 하지만, Settings ▶ Options 메뉴의 Digitizing 대화창에서 다음 옵션들을 활성화시킬 수도 있습니다:

    • checkbox Suppress attributes pop-up windows after each created feature: 속성 입력 양식 대화창을 열지 않도록 합니다.

    • checkbox Reuse last entered attribute values: 속성 입력 양식 대화창이 열릴 때 가장 최근에 입력한 속성값으로 자동 입력해서 변경할 값만 입력하면 되도록 합니다.

../../../_images/editDigitizing.png

그림 14.86 새 벡터 피처를 디지타이즈한 후의 속성 입력 양식 대화창

14.4.3.2. 꼭짓점 도구

참고

QGIS 3 버전의 주요 변경사항

QGIS 3 버전에서, 노드 도구를 완전히 새로 설계하고 꼭짓점 도구 로 명칭을 변경했습니다. 이전에는 《클릭&드래그》 인간공학(ergonomy)으로 작동했지만, 지금은 《클릭-클릭》 워크플로(workflow)를 사용합니다. 이렇게 해서 여러 레이어의 객체들을 동시에 디지타이즈하거나 편집하는 동안 꼭짓점 도구가 있는 고급 디지타이즈 작업 패널의 장점을 취하는 것과 같은 중요한 개선을 이룰 수 있었습니다.

편집 가능 상태의 모든 벡터 레이어에 대해, vertexToolActiveLayer Vertex tool (Current Layer) 은 CAD 소프트웨어와 유사한 피처 꼭짓점 수정 기능을 제공합니다. 그냥 한 번에 여러 꼭짓점을 선택해서 한꺼번에 이동, 추가 또는 삭제할 수 있습니다. 꼭짓점 도구는 피처 위상 편집 작업도 지원합니다. 이 도구는 선택 지속적이기 때문에 일부 작업이 완료된 후에도 해당 피처 및 도구에 대한 선택 집합의 활성화 상태가 유지됩니다.

Settings ▶ options Options ▶ Digitizing ▶ Search Radius: selectNumber 검색 반경 속성을 0보다 큰 숫자로 설정하는 것이 중요합니다. 그러지 않을 경우, QGIS가 현재 어떤 꼭짓점을 편집 중인지 구분하지 못 하고 경고 메시지를 표시할 것입니다.

꼭짓점 마커

QGIS 이번 버전은 〈Semi-transparent circle〉, 〈Cross〉 및 〈None〉 세 종류의 꼭짓점 마커를 지원하고 있습니다. 마커 스타일을 변경하려면, Settings 메뉴에서 options Options 를 선택한 다음, Digitizing 탭에서 적절한 항목을 선택하십시오.

14.4.3.2.1. 기본 작업

먼저 vertexToolActiveLayer Vertex Tool (Current Layer) 를 활성화하십시오. 꼭짓점에 마우스를 가져가면 빨간색 원이 표시될 것입니다.

  • 꼭짓점 선택하기: Shift 키를 누른 채 한 번에 하나씩 클릭하거나, 여러 꼭짓점을 감싸는 직사각형을 클릭&드래그해서 꼭짓점을 선택할 수 있습니다. 꼭짓점을 선택하면, 그 색상이 파란색으로 변합니다. 현재 선택 집합에 더 많은 꼭짓점을 추가하려면, Shift 키를 누른 채 클릭하십시오. Ctrl 키를 누른 채 클릭하면 선택 집합에서 꼭짓점을 제거할 수 있습니다.

  • 배치(Batch) 꼭짓점 선택 모드: Shift+R 조합키를 누르면 배치 선택 모드를 활성화시킬 수 있습니다. 한 번 클릭해서 첫 번째 꼭짓점을 선택한 다음, 또다른 꼭짓점에 마우스를 클릭하지 말고 가져가십시오. 이렇게 하면 두 꼭짓점 사이의 모든 꼭짓점을 (폴리곤의 경우) 최단 경로를 사용해서 동적으로 선택할 것입니다.

    ../../../_images/vertex_batch_selection_mode.png

    그림 14.87 Shift+R 로 배치 꼭짓점 선택하기

    Ctrl 키를 누르면 피처 경계선을 따라 최장 경로를 선택해서 선택을 반전할 것입니다. 두 번째 클릭으로 노드 선택을 완료할 수 있고, 또는 Esc 키를 누르면 배치 모드에서 벗어나게 됩니다.

  • 꼭짓점 추가하기: 꼭짓점을 추가하려 할 때, 선분 중앙에 새 가상 노드가 나타납니다. 그냥 이 노드를 잡아 새 꼭짓점을 추가하십시오. 경계선 상의 어느 위치를 더블클릭해도 새 노드를 생성합니다. 라인 도형의 경우, 양극단에 라인을 연장할 수 있는 가상 노드가 나타납니다.

    ../../../_images/vertex_add_node.png

    그림 14.88 꼭짓점을 추가하기 위한 가상 노드

  • 꼭짓점 삭제하기: 꼭짓점을 선택한 다음 Delete 키를 누르십시오. 피처의 모든 꼭짓점을 삭제하면 – 데이터소스와 호환되는 경우 – 도형이 없는 피처를 생성합니다. 피처를 완전히 삭제하는 것이 아니라 도형 부분만 삭제한다는 점을 기억하십시오. 피처를 완전히 삭제하려면 deleteSelectedFeatures Delete Selected 도구를 사용해야 합니다.

  • 꼭짓점 이동하기: 이동시키고자 하는 모든 꼭짓점을 선택한 다음, 선택한 꼭짓점 또는 경계를 클릭하고 다시 이동하려는 위치를 클릭하십시오. 선택한 모든 꼭짓점이 함께 움직일 것입니다. 스냅이 활성화돼 있는 경우, 전체 집합을 가장 가까운 꼭짓점 또는 라인으로 점프시킬 수 있습니다. 두 번째로 클릭하기 전에 거리, 각도, 정확한 X, Y 위치를 위한 고급 디지타이즈 작업 패널의 제약조건을 이용할 수 있습니다.

    이때 그리드에 스냅 기능을 사용할 수 있습니다. 레이어 속성에서 도형 정밀도 용 값을 설정했다면, 도형 정밀도를 따르는 확대/축소 수준에서 그리드가 나타납니다.

    ../../../_images/vertex_snap_to_grid.png

    그림 14.89 꼭짓점을 선택해서 그리드로 이동시키기

꼭짓점의 각 변경 사항은 Undo 대화창에 개별 항목으로 각각 저장됩니다. 이 설정이 켜져 있는 동안 모든 작업이 위상 편집을 지원한다는 사실을 기억하십시오. 실시간 재투영도 지원합니다. 포인터를 꼭짓점 위에 가져가면 꼭짓점 도구가 꼭짓점을 식별할 수 있는 도움말 말풍선(tooltip)을 표시합니다.

14.4.3.2.2. 꼭짓점 편집기 패널

피처에 Vertex tool 을 사용할 때, 꼭짓점을 오른쪽 클릭하면 QGIS가 피처의 모든 꼭짓점과 각 꼭짓점의 x, y (존재하는 경우 z, m) 좌표 및 (원호 도형의 경우 반경을 나타내는) r 목록을 담은 Vertex Editor 패널을 엽니다. 이 테이블에서 어느 행을 선택하기만 하면 맵 캔버스에 있는 해당 꼭짓점이 선택되며, 그 반대의 경우도 가능합니다. 테이블에서 좌표를 변경하기만 하면 해당 꼭짓점의 위치가 업데이트됩니다. 여러 행을 선택해서 한꺼번에 삭제할 수도 있습니다.

참고

QGIS 3.4에서 변경된 내용

피처를 오른쪽 클릭하는 즉시 꼭짓점 편집기를 열고 해당 피처를 잠급니다. 즉 다른 모든 피처의 편집 모드를 비활성화시킵니다. 이렇게 잠겨 있는 동안, 해당 피처만 편집할 수 있습니다: 이 피처의 꼭짓점 및 선분만 클릭 또는 드래그해서 선택하거나 이동시킬 수 있습니다. 이 잠긴 피처에만 새 꼭짓점을 추가할 수 있습니다. 또한 이제 꼭짓점 도구를 활성화시킬 때 자동적으로 꼭짓점 편집기 패널이 스스로 열리고, 꼭짓점 편집기를 사용할 때마다 그 위치/도킹 상태를 기억합니다.

../../../_images/vertex_editor_panel.png

그림 14.90 선택한 노드를 보여주는 꼭짓점 편집기 패널

14.4.3.3. 피처 잘라내기, 복사 및 붙여넣기

먼저 toggleEditing Toggle editing 을 통해 대상 레이어를 편집 모드로 설정해놓았다면, 동일한 QGIS 프로젝트의 레이어들 사이에서 선택한 피처를 자르고, 복사하고 붙여넣을 수 있습니다.

복사/붙여넣기를 이용해서 폴리곤을 라인으로, 라인을 폴리곤으로 변형하기

라인 피처를 복사해서 폴리곤 레이어에 붙여넣는 경우, QGIS가 대상 레이어에 그 경계가 라인 피처의 닫힌 도형에 대응하는 폴리곤으로 붙여넣습니다. 이는 동일한 데이터를 가진 서로 다른 도형 유형을 빠르게 생성하는 방법입니다.

외부 응용 프로그램에 피처를 텍스트로 붙여넣을 수도 있습니다. 피처가 도형 데이터를 OGC WKT(Well-Known Text) 서식으로 표현한 CSV 포맷인 경우에 말이죠. QGIS 외부의 WKT 및 GeoJSON 객체를 QGIS 내부의 레이어로 붙여넣는 것도 가능합니다.

복사/붙여넣기 기능이 유용한 경우란 어떤 경우일까요? 바로 한 번에 하나 이상의 레이어를 편집하는 중에 레이어들 간에 피처를 복사/붙여넣기하는 경우입니다. 어째서 이런 작업이 필요한 걸까요? QGIS 예시 데이터의 big_lakes 레이어에 있는 호수 5,000개 전부가 아니라 한두 개만 있는 레이어에서 몇몇 작업을 해야 한다고 가정해봅시다. 새 레이어를 생성한 다음 해당 레이어에 필요한 호수만 복사/붙여넣기를 이용해서 넣을 수 있습니다.

새 레이어에 몇몇 호수를 복사해 넣는 다음 예제를 해보겠습니다:

  1. 복사해오려는 레이어(원본 레이어)를 불러옵니다.

  2. 복사해 넣으려는 레이어(대상 레이어)를 불러오거나 생성합니다.

  3. 대상 레이어를 편집 모드로 설정합니다.

  4. 범례에서 원본 레이어를 클릭해서 활성화시킵니다.

  5. selectRectangle Select Features by area or single click 도구를 이용해서 원본 레이어에서 피처(들)을 선택합니다.

  6. editCopy Copy Features 도구를 클릭합니다.

  7. 범례에서 대상 레이어를 클릭해서 활성화시킵니다.

  8. editPaste Paste Features 도구를 클릭합니다.

  9. 편집 모드를 해제하고 변경 사항을 저장합니다.

원본과 대상 레이어가 서로 다른 스키마를 가지고 있다면 (필드명과 유형이 동일하지 않다면) 어떻게 될까요? QGIS는 일치하는 데이터를 붙여넣고 나머지는 무시합니다. 대상 레이어에 속성을 복사해 넣을 필요가 없는 경우, 필드 및 데이터 유형을 어떻게 구성하든 상관없습니다. 하지만 전체를 ─ 피처와 그 속성까지 ─ 복사하고자 하는 경우, 원본과 대상 레이어의 스키마가 일치하는지 확인해야 합니다.

참고

붙여넣은 피처의 합치성

원본과 대상 레이어가 동일한 투영체를 사용하고 있는 경우, 붙여넣은 피처가 원본 레이어와 동일한 도형을 가지게 될 것입니다. 하지만, 대상 레이어의 투영체가 다른 경우, QGIS는 도형이 동일한지 보장할 수 없게 됩니다. 왜냐하면 서로 다른 투영체 간에 변환할 때 자잘한 반올림 오류가 발생하기 때문입니다.

문자열 속성을 또다른 속성으로 복사하기

사용자의 속성 테이블에 문자열 유형의 새 열을 생성했는데, 더 긴 길이를 가진 다른 속성 열로 그 값을 붙여넣으려는 경우, 열의 길이가 대상 열의 길이로 늘어날 것입니다. GDAL/OGR 1.10과 함께 구동되는 GDAL Shapefile 드라이버가 삽입될 데이터의 길이를 동적으로 수용하기 위해 문자열 및 정수형 필드를 자동 확장하기 때문입니다.

14.4.3.4. 선택한 피처 삭제하기

어떤 피처 전체(속성 및 도형)를 삭제하려는 경우, 먼저 표준적인 selectRectangle Select Features by area or single click 도구를 사용해서 도형을 선택할 수 있습니다. 속성 테이블에서 선택할 수도 있습니다. 선택을 마치고 나면, Delete 또는 Backspace 키를 누르거나 deleteSelectedFeatures Delete Selected 도구를 클릭해서 피처를 삭제하십시오. 선택한 피처 여러 개를 한 번에 삭제할 수 있습니다.

피처를 삭제하는 데 디지타이즈 작업 툴바에 있는 editCut Cut Features 도구를 이용할 수도 있습니다. 이 도구는 피처를 사실상 삭제하지만 《공간 클립보드》에 옮겨 놓기도 합니다. 즉, 삭제할 피처를 잘라내는 겁니다. 이후에 editPaste Paste Features 도구를 통해 되돌려 놓을 수 있습니다. 기초 수준의 실행 취소 능력이죠. 잘라내기, 복사 및 붙여넣기는 현재 선택한 피처를 대상으로 작동합니다. 즉 한 번에 하나 이상을 대상으로 작업할 수 있다는 뜻입니다.

14.4.3.5. 실행 취소 및 재실행

undo Undoredo Redo 도구는 벡터 편집 작업을 실행 취소하거나 재실행할 수 있습니다. 실행 취소/재실행 이력에 있는 모든 작업을 보여주는 고정 가능한(dockable) 위젯도 있습니다. (실행 취소/재실행 디지타이즈 작업 이력 그림을 참조하세요.) 이 위젯은 기본적으로 표시되지 않습니다. 이 위젯을 표시하려면 툴바를 오른쪽 클릭한 다음 checkbox Undo/Redo Panel 을 활성화해야 합니다. 하지만 이 위젯이 표시되지 않은 경우에도 실행 취소/재실행 능력은 켜져 있습니다.

../../../_images/redo_undo.png

그림 14.91 실행 취소/재실행 디지타이즈 작업 이력

Undo 버튼을 클릭하거나 Ctrl+Z (또는 |osx| Cmd+Z) 조합키를 누르면, 모든 피처와 속성의 상태가 되돌린 작업 이전의 상태로 돌아갑니다. 일반적인 벡터 편집 작업이 아닌 변경 사항(예: 플러그인을 통한 변경 사항)은 해당 변경 사항이 어떻게 수행됐는지에 따라 되돌릴 수도 있고 되돌리지 못 할 수도 있습니다.

실행 취소/재실행 이력 위젯을 이용하려면, 그냥 이력 목록에 있는 작업을 하나 선택하십시오. 모든 피처가 선택한 작업 직후의 상태로 돌아갈 것입니다.

14.4.3.6. 편집한 레이어 저장하기

레이어가 편집 모드 상태인 경우, 모든 변경 사항이 QGIS의 메모리에 남아 있습니다. 즉 변경 사항이 즉시 데이터소스 또는 디스크에 커밋 또는 저장되는 것이 아닙니다. 현재 레이어에 편집 사항을 저장하고 싶지만 편집 모드를 해제하지 않고 계속 편집 작업을 하고 싶은 경우, saveEdits Save Layer Edits 아이콘을 클릭하면 됩니다. toggleEditing Toggle editing 아이콘으로 편집 모드를 끄는 경우 (또는 QGIS를 종료하는 경우) 사용자의 변경 사항을 저장할 거냐 또는 무시할 거냐를 묻는 대화창이 열립니다.

변경 사항을 저장할 수 없는 경우 (예: 디스크에 남은 공간이 없거나, 범위를 벗어난 속성값이 있는 경우) QGIS의 내부 메모리 상태가 보존됩니다. 사용자가 편집 사항을 조정해서 다시 저장할 수 있게 하기 위해서입니다.

데이터 무결성

편집 작업을 시작하기 전에 항상 사용자 데이터소스를 백업하도록 권장합니다. QGIS 개발자들이 사용자 데이터의 무결성을 보존하기 위해 모든 노력을 다 하고 있지만, 어떤 보장도 해드릴 수 없기 때문입니다.

14.4.3.6.1. 여러 레이어를 한 번에 저장하기

이 기능은 여러 레이어를 디지타이즈할 수 있게 해줍니다. 사용자가 여러 레이어에서 만든 모든 변경 사항을 저장하려면 fileSaveAs Save for Selected Layers 를 선택하십시오. rollbackEdits Rollback for Selected Layers 를 클릭하면, 선택한 모든 레이어에 대한 디지타이즈 작업을 되돌릴 수도 있습니다. 선택한 레이어에 대한 편집 작업을 종료하려면, cancelEdits Cancel for Selected Layer(s) 를 통해 쉽게 끝낼 수 있습니다.

프로젝트의 모든 레이어 편집 작업에서 동일한 기능들을 사용할 수 있습니다.

여러 레이어 변경 사항을 한 번에 편집, 저장 또는 되돌리는 데 트랜잭션 그룹 이용하기

동일한 PostGreSQL 데이터베이스로부터 나온 레이어들을 작업하는 경우, Project ▶ Properties… ▶ Data Sources 메뉴의 Automatically create transaction groups where possible 옵션을 활성화시키면 레이어들의 습성(편집 모드 시작/종료, 변경사항을 동시에 저장 또는 되돌리기)을 동기화합니다.

14.4.4. 고급 디지타이즈 작업

아이콘

목적

아이콘

목적

cad

고급 디지타이즈 작업 도구 활성화

tracing

투사 활성화

moveFeature moveFeatureLine moveFeaturePoint

피처(들) 이동

moveFeatureCopy moveFeatureCopyLine moveFeatureCopyPoint

피처(들) 복사 및 이동

rotateFeature

피처(들) 회전

simplifyFeatures

피처 단순화

addRing

고리 추가

addPart

부분 추가

fillRing

고리 채우기

reverseLine

방향 바꾸기

deleteRing

고리 삭제

deletePart

부분 삭제

offsetCurve

곡선 오프셋

reshape

피처 재형성

splitParts

부분 분할

splitFeatures

피처 분할

mergeFeatAttributes

선택한 피처의 속성 병합

mergeFeatures

선택한 피처 병합

rotatePointSymbols

포인트 심볼 회전

offsetPointSymbols

오프셋 포인트 심볼

trimExtend

피처 다듬기(Trim) 또는 연장

표: 고급 편집 작업 - 벡터 레이어 고급 편집 작업 툴바

14.4.4.1. 피처(들) 이동

moveFeature Move Feature(s) 도구는 기존 피처를 이동시킬 수 있습니다:

  1. 이동시킬 피처(들)를 선택하십시오.

  2. 맵 캔버스 상에서 변위의 원점을 나타내는 위치를 클릭하십시오. 정확한 포인트를 선택하기 위해 스냅 기능을 사용할 수 있습니다.

    원점 좌표를 정확하게 설정하기 위해 고급 디지타이즈 작업 제약조건 을 이용할 수도 있습니다. 이런 경우:

    1. 먼저 cad 버튼을 클릭해서 패널을 활성화시킵니다.

    2. x 를 입력한 다음 사용자가 원하는 원점에 대응하는 값을 입력합니다. 그리고 옵션 옆에 있는 locked 버튼을 눌러 값을 고정시킵니다.

    3. y 좌표도 동일한 방법으로 설정합니다.

    4. 맵 캔버스를 클릭하면 지정한 좌표에 사용자의 원점을 배치합니다.

  3. 맵 캔버스를 이동해서 변위의 대상 포인트를 가리키십시오. 계속 스냅 모드를 사용할 수도 있고, 또는 앞에서 설명한대로 고급 디지타이즈 작업 패널을 사용해서 전이(轉移)의 종단점을 배치하기 위한 상호보완적인 distanceangle 배치 제약조건을 지정할 수도 있습니다.

  4. 맵 캔버스를 클릭하십시오: 전체 피처가 새 위치로 이동합니다.

moveFeatureCopy Copy and Move Feature(s) 도구를 사용하면 피처(들)의 전이된 복사본을 마찬가지로 생성할 수 있습니다.

참고

Move Feature(s) 또는 Copy and Move Feature(s) 도구로 맵 캔버스를 처음 클릭했을 때 어떤 피처도 선택되지 않은 경우, 액션의 영향을 받는 것은 포인터 아래 있는 피처뿐입니다. 따라서 여러 피처를 이동시키려면 먼저 피처들을 선택해야 합니다.

14.4.4.2. 피처(들) 회전

맵 캔버스에 있는 하나 이상의 피처를 기울이려면 rotateFeature Rotate Feature(s) 도구를 사용하십시오:

  1. rotateFeature Rotate Feature(s) 아이콘을 클릭합니다.

  2. 기울이려는 피처를 클릭하십시오. 피처의 중심을 기울기 중심으로 참조하고, 기울인 피처의 미리보기를 표시하며, 현재 Rotation 각도를 표시하는 위젯이 열립니다.

  3. 새 배치에 만족한다면 맵 캔버스를 클릭하십시오. 또는 텍스트란에 기울기 각도를 직접 입력해도 됩니다. Snap to ° 박스를 이용해서 기울기 값에 제약조건을 걸 수도 있습니다.

  4. 여러 피처를 한번에 기울이려면, 먼저 피처들을 선택해야 합니다. 기본적으로 결합된 도형들의 중심을 기준으로 기울어질 것입니다.

기본적인 피처 중심점 대신 고정점(anchor point)을 사용할 수도 있습니다. Ctrl 키를 누른 채 맵 캔버스를 클릭하면, 해당 포인트를 새 기울기 중심점으로 사용할 것입니다.

맵을 클릭하기 전에 Shift 키를 누른 상태인 경우, 45도씩 기울어질 것입니다. 이후 사용자 입력 위젯에서 각도를 수정할 수 있습니다.

피처 기울이기를 끝내려면, ESC 키를 누르거나 다시 rotateFeature Rotate Feature(s) 아이콘을 클릭하면 됩니다.

14.4.4.3. 피처 단순화

simplifyFeatures Simplify Feature 도구는 도형의 유효성이 유지되는 한 꼭짓점 개수를 줄이거나 밀도를 높여서 라인 또는 폴리곤 도형의 형태를 대화형 작업으로 변형시킬 수 있습니다:

  1. simplifyFeatures Simplify Feature 도구를 선택하십시오.

  2. 피처를 클릭하거나 피처 위로 직사각형을 드래그하십시오.

  3. 적용할 Method 를 정의할 수 있는 대화창이 열립니다. 다음과 같은 방법을 선택할 수 있습니다:

    • 도형을 단순화 하는, 즉 꼭짓점을 원본보다 줄이는 방법입니다. Simplify by distance, Simplify by snapping to grid 또는 Simplify by area (Visvalingam) 를 사용할 수 있습니다. 그 다음 단순화에 사용할 Tolerance 단위를 Layer units, Pixels 또는 Map units 가운데 하나로 지정해야 합니다. 허용 오차가 클수록 더 많은 꼭짓점을 삭제할 수 있습니다.

    • 또는 Smooth 옵션의 도움으로 새 꼭짓점을 추가해서 도형의 밀도를 높이는 방법도 있습니다. 기존의 각 꼭짓점에서 시작하는 두 선분 상의 선분 길이의 백분율을 나타내는 Offset 거리에 각각 꼭짓점을 배치합니다. Iterations 옵션에서 새 꼭짓점을 배치하는 과정의 반복 횟수도 설정할 수 있습니다. 반복 횟수가 높을수록 꼭짓점도 늘어나서 피처가 더 평탄화됩니다.

    사용자가 사용한 설정은 편집 작업을 또는 프로젝트를 종료해도 저장될 것입니다. 따라서 다음에 피처를 단순화하는 경우에도 동일한 설정을 사용할 수 있습니다.

  4. 대화창 하단에 적용될 수정 사항을 요약해서 (작업 전후의) 피처 및 꼭짓점 개수의 목록과 (변경되는 비율을) 함께 표시합니다. 또 맵 캔버스의 기존 피처 위에 예상 피처를 고무줄 색상으로 표시합니다.

  5. 예상 피처가 사용자의 필요를 만족시킨다면, OK 를 클릭해서 수정 사항을 적용하십시오. 그렇지 않을 경우, Cancel 을 클릭하거나 맵 캔버스를 오른쪽 클릭하면 작업을 중단할 수 있습니다.

참고

렌더링만을 위해 도형을 단순화하는 Settings ▶ Options ▶ Rendering 메뉴의 피처 단순화 옵션과는 달리, simplifyFeatures Simplify Feature 도구는 데이터소스에 있는 피처의 도형을 영구히 변경합니다.

14.4.4.4. 부분 추가

addPart Add Part 도구로 선택한 피처에 부분을 추가해서 멀티포인트, 멀티라인 또는 멀티폴리곤 피처를 생성할 수 있습니다. 기존 피처 외부에서 이 새 부분을 디지타이즈해야만 하는데, 이 기존 피처는 먼저 선택돼 있어야 합니다.

도형이 없는 피처에 도형을 추가하는 경우에도 addPart Add Part 도구를 사용할 수 있습니다. 먼저, 속성 테이블에서 피처를 선택한 다음 addPart Add Part 도구로 새 도형을 디지타이즈하십시오.

14.4.4.5. 부분 삭제

deletePart Delete Part 도구는 다중 피처에서 부분을 삭제할 수 있습니다. (예를 들면 멀티폴리곤 피처에서 폴리곤을 삭제할 수 있습니다.) 이 도구는 포인트, 라인 및 폴리곤 모든 다중 부분 도형에 대해 작동합니다. 더우기, 피처의 도형 요소를 완전히 제거할 수도 있습니다. 부분을 삭제하려면, 그냥 대상 피처 안에 있는 부분을 클릭하면 됩니다.

14.4.4.6. 고리 추가

툴바에 있는 addRing Add Ring 아이콘을 클릭하면 고리 폴리곤을 생성할 수 있습니다. 기존 폴리곤 영역 내부에 〈구멍’으로 간주되는 내곽 폴리곤을 디지타이즈할 수 있다는 뜻으로, 이 경우 외곽 및 내곽 폴리곤 경계선 사이의 영역만 고리 폴리곤으로 남게 됩니다.

14.4.4.7. 고리 채우기

fillRing Fill Ring 도구는 다른 폴리곤 안에 중첩되는 영역 없이 완전히 들어가는 폴리곤 피처를 생성할 수 있습니다. 즉 기존 피처 안에 있는 구멍을 덮는 새 피처를 말이죠. 이런 피처를 생성하려면:

  1. fillRing Fill Ring 도구를 선택하십시오.

  2. 기존 피처 위로 새 폴리곤을 그리십시오: QGIS가 새 폴리곤 도형에 (addRing Add Ring 도구를 사용하듯이) 고리를 추가한 다음 그 고리와 일치하는 도형을 가진 새 피처를 (capturePolygon Add polygon feature 도구로 내곽 경계선을 투사 하듯이) 생성합니다.

  3. 또는, 고리가 피처에 이미 존재하는 경우 고리 위로 마우스를 가져가 Shift 키를 누른 채 왼쪽 클릭하십시오: 해당 위치에 구멍을 채우는 새 피처가 그려집니다.

    새 피처의 Feature Attributes 양식이 《부모》 피처의 값 그리고/또는 필드 제약조건 과 함께 열립니다.

14.4.4.8. 고리 삭제

deleteRing Delete Ring 도구는 구멍 안쪽을 클릭해서 기존 폴리곤 내부의 고리를 삭제할 수 있습니다. 이 도구는 폴리곤 및 멀티폴리곤 피처에 대해서만 작동합니다. 폴리곤의 외곽 고리에 이 도구를 사용해도 아무것도 변경되지 않습니다.

14.4.4.9. 피처 재형성

툴바에 있는 reshape Reshape Features 도구를 사용해서 라인 및 폴리곤 피처를 재형성할 수 있습니다. 라인의 경우, 원본 라인을 첫 번째 교차점에서 마지막 교차점까지의 라인 부분으로 대체합니다.

../../../_images/reshape_lines.png

그림 14.92 라인 재형성하기

재형성 도구로 라인스트링 도형을 연장시키기

reshape Reshape Features 도구를 이용해서 기존 라인의 첫 번째 또는 마지막 꼭짓점에 스냅한 다음 새 라인을 그리면 기존 라인스트링 도형을 늘릴 수 있습니다. 새 라인을 승인하면 피처 도형이 두 라인의 결합체로 변합니다.

폴리곤의 경우, 이 도구는 폴리곤의 경계선을 재형성합니다. 제대로 동작하려면, 재형성 도구의 라인이 폴리곤 경계선과 최소한 두 번 교차해야만 합니다. 라인을 그리려면, 맵 캔버스를 클릭해서 꼭짓점을 추가하십시오. 그리기를 마치려면, 오른쪽 클릭만 하면 됩니다. 라인의 경우와 마찬가지로, 첫 번째와 마지막 교차점 사이에 있는 선분만 처리됩니다. 폴리곤 내부에 있는 재형성 라인의 선분은 폴리곤을 잘라내고, 외부에 있는 선분은 폴리곤을 확장시킬 것입니다.

../../../_images/reshape_polygon.png

그림 14.93 폴리곤 재형성하기

폴리곤의 경우, 재형성 작업이 때로 의도하지 않은 결과를 낼 수도 있습니다. 이 도구는 폴리곤의 자잘한 부분을 수정하는 데 유용하지, 본체를 수정하기는 힘듭니다. 또 재형성 라인이 여러 폴리곤 고리와 교차해서도 안 됩니다. 그런 경우 유효하지 않은 폴리곤이 생성되기 때문입니다.

참고

재형성 도구는 폴리곤 고리 또는 닫힌 라인의 시작점을 변경시킬 수도 있습니다. 즉, 〈두 번〉 나타나던 포인트가 더 이상 그러지 않을 수도 있다는 뜻입니다. 대부분의 응용 프로그램에서 문제가 없을 수도 있지만, 고려해야 할 사항임에는 틀림없습니다.

14.4.4.10. 곡선 오프셋

offsetCurve Offset Curve 도구는 라인 레이어를 평행하게 이동시킨 객체를 생성합니다. 이 도구를 편집 중인 레이어에 적용하면 도형을 수정하며, 배경 레이어에 적용하면 라인/고리를 복사해서 편집 중인 레이어에 추가합니다. 따라서 이 도구는 거리 라인 레이어를 생성하는 데 적합합니다. 이 도구는 변위 거리를 보여주는 User Input 대화창을 엽니다.

라인 레이어를 이동시킨 객체를 생성하려면, 먼저 편집 모드를 켠 다음 offsetCurve Offset Curve 도구를 활성화시켜야 합니다. 그 다음 피처를 클릭해서 이동시킵니다. 마우스를 움직여 원하는 곳을 클릭하거나 또는 사용자 입력 위젯에 원하는 거리를 입력하십시오. 이동 후에 saveEdits Save Layer Edits 도구로 사용자 변경 사항을 저장할 수도 있습니다.

QGIS 옵션 대화창(의 디지타이즈 탭에서 Curve offset tools 부분)에서 Join style, Quadrant segments, Miter limit 과 같은 몇몇 파라미터를 환경 설정할 수 있습니다.

14.4.4.11. 라인 반전

라인 도형의 방향을 변경하는 것은 지도제작 목적 또는 네트워크 분석 준비에 유용할 수 있습니다.

라인 방향을 변경하려면:

  1. reverseLine Reverse line 아이콘을 클릭해서 라인 반전 도구를 활성화하십시오.

  2. 라인을 클릭하십시오. 라인의 방향이 반전됩니다.

14.4.4.12. 피처 분할

splitFeatures Split Features 도구를 사용해서 피처를 두 개 이상의 독립적인 새 피처들로 분할할 수 있습니다. 예를 들면 분할된 각 도형은 속성 테이블의 새 행과 대응합니다.

라인 또는 폴리곤 피처를 분할하려면:

  1. splitFeatures Split Features 도구를 선택하십시오.

  2. 분할하고자 하는 피처(들)를 가로지르는 라인을 그리십시오. 선택 집합이 활성화돼 있다면 선택한 피처들만 분할됩니다. 분할이 되면, 기본 값 또는 절(clause) 이 대응하는 필드에 적용되며 기본적으로 부모 피처의 다른 속성들도 새 피처에 복사됩니다.

  3. 이제 산출되는 모든 피처의 모든 속성을 평소대로 수정할 수 있습니다.

클릭 한 번으로 폴리라인을 새 피처들로 분할하기

splitFeatures Split Features 도구로 폴리라인 피처의 기존 꼭짓점에 스냅하고 클릭하면, 해당 피처를 새 피처 2개로 분할합니다.

14.4.4.13. 부분 분할

QGIS는 다중 부분 피처의 부분을 분할해서 부분의 개수를 늘릴 수 있습니다. splitParts Split Parts 도구를 사용해서 분할하고 싶은 부분을 가로지르는 라인을 그리기만 하면 됩니다.

클릭 한 번으로 폴리라인을 새 부분들로 분할하기

splitParts Split Parts 도구로 폴리라인 피처의 기존 꼭짓점에 스냅하고 클릭하면, 해당 피처를 동일한 피처에 속해 있는 새 폴리라인 2개로 분할합니다.

14.4.4.14. 선택한 피처 병합

mergeFeatures Merge Selected Features 도구는 기존 피처들을 합쳐서 새 피처를 생성할 수 있습니다. 기존 피처의 도형들을 병합해서 새 피처를 생성합니다. 기존 피처들에 공통 경계가 없는 경우, 멀티폴리곤/멀티폴리라인/멀티포인트 피처를 생성합니다.

  1. 먼저, 결합하고자 하는 피처들을 선택하십시오.

  2. 그 다음 mergeFeatures Merge Selected Features 아이콘을 클릭하십시오.

  3. 새 대화창의 테이블 하단에 있는 Merge 행이 산출되는 피처의 속성들을 표시합니다. 이 값들을 다음과 같이 수정할 수 있습니다:

    • 대응하는 셀에서 값을 직접 대체합니다.

    • 테이블에서 행을 선택하고 Take attributes from selected feature 를 클릭하면 선택한 최초 피처의 값을 사용합니다.

    • Skip all fields 를 클릭하면 빈 속성을 사용합니다.

    • 또는, 테이블 상단에 있는 드롭다운 메뉴를 펼쳐 앞의 옵션들 가운데 하나를 선택하면 대응하는 필드에만 적용됩니다. 또 최초 피처들의 속성을 집계하도록 (필드 유형에 따라 최소, 최대, 평균, 합계, 개수, 연결 등등) 선택할 수도 있습니다. (함수들의 완전한 목록은 통계 요약 패널 을 참조하세요.)

    참고

    레이어가 필드에 기본값 또는 절을 가지고 있을 경우, 이를 병합된 피처의 초기 값으로 사용합니다.

  4. 수정 사항을 적용시키려면 OK 를 클릭하십시오. 레이어에 이전에 선택한 피처들을 대체하는 단일 [멀티]피처를 생성합니다.

14.4.4.15. 선택한 피처의 속성 병합

mergeFeatAttributes Merge Attributes of Selected Features 도구는 피처들의 경계를 병합하지 않고서도 피처에 동일한 속성을 적용할 수 있게 해줍니다. 이 도구의 대화창은 Merge Selected Features 도구의 대화창과 동일합니다. 다만 선택한 개체들의 속성은 동일하게 변하지만, 개체 도형은 그대로 유지된다는 점이 다릅니다.

14.4.4.16. 포인트 심볼 회전

rotatePointSymbols Rotate Point Symbols 도구를 통해 맵 캔버스에 있는 포인트 심볼의 기울기를 변경할 수 있습니다.

  1. 먼저, 심볼에 데이터 정의 기울기를 적용하십시오:

    1. Layer Properties ▶ Symbology 대화창에서 심볼 편집기 대화창을 찾으십시오.

    2. 심볼 레이어의 (되도록) 최상위 Marker 심볼의 Rotation 옵션 옆에 있는 dataDefined Data-defined override 위젯을 클릭하십시오.

    3. Field Type 콤보박스에서 필드를 선택하십시오. 이 필드의 값들을 따라 각 피처의 심볼을 기울일 것입니다.

    참고

    반드시 동일한 필드가 모든 심볼 레이어에 할당되도록 하십시오

    최상위 심볼 트리에서 데이터 정의 기울기 필드를 설정하면 모든 심볼 레이어에 해당 필드를 적용합니다. 이는 Rotate Point Symbols 도구로 그래픽 심볼을 기울이기 위한 전제조건입니다. 실제로, 동일한 필드가 심볼 레이어의 기울기 속성에 첨부되지 않았을 경우, 이 도구는 작동하지 않을 것입니다.

    ../../../_images/rotatepointsymbol.png

    그림 14.94 포인트 심볼 기울이기

  2. 그 다음 rotatePointSymbols Rotate Point Symbols 도구로 맵 캔버스에 있는 포인트 피처를 클릭하고 왼쪽 마우스 버튼을 누른 채 이리저리 움직여보십시오. 빨간색 화살표가 기울기 값과 함께 가시화될 것입니다. (포인트 심볼 기울이기 그림 참조)

  3. 왼쪽 마우스 버튼을 떼면, 심볼을 이 새 기울기로 설정하고 레이어의 속성 테이블에서도 기울기 필드가 업데이트됩니다.

Ctrl 키를 누르고 있을 경우, 15도씩 기울어질 것입니다.

14.4.4.17. 오프셋 포인트 심볼

offsetPointSymbols Offset Point Symbols 도구는 포인트 심볼이 맵 캔버스에 렌더링된 위치를 대화형으로 변경할 수 있습니다. 이 도구는 rotatePointSymbols Rotate Point Symbols 도구와 비슷하게 동작합니다만, 심볼의 데이터로 정의된 Offset (X,Y) 속성에 연결해야 한다는 점이 다릅니다. 이 오프셋 필드에 연결하면, 포인트 심볼의 좌표가 오프셋 좌표로 변경돼 맵 캔버스에 있는 심볼도 이동합니다.

참고

offsetPointSymbols Offset Point Symbols 도구는 포인트 심볼 자체를 이동시키지 않습니다. 그러려면 vertexToolActiveLayer Vertex Tool (Current Layer) 또는 moveFeaturePoint Move Feature 도구를 사용해야 합니다.

14.4.4.18. 피처 다듬기/연장하기

디지타이즈한 라인이 또다른 라인에 스냅하기엔 너무 짧거나 너무 긴 경우 (라인이 빠졌거나 라인과 교차하는 경우) 선분을 연장하거나 짧게 만들 수 있어야 합니다.

trimExtend Trim/Extend 도구는 [멀티]라인은 물론 [멀티]폴리곤도 수정할 수 있습니다. 게다가 라인의 종단만 대상으로 삼을 필요도 없습니다. 도형의 어떤 선분도 수정할 수 있습니다.

참고

도형의 유효성이 망가질 수도 있습니다.

참고

이 도구가 작동하려면 선분 스냅 모드를 활성화시켜야만 합니다.

이 도구는 사용자에게 또다른 선분을 연장할지 또는 다듬을지에 대한 제한(선분)을 선택할 것을 요청합니다. 꼭짓점 도구와는 달리, 편집 중인 레이어만 수정하는지 검사합니다.

두 선분 모두 3차원인 경우, 제한 선분이 Z값을 가지도록 보간합니다.

다듬기의 경우, 클릭해서 짧게 만들 부분을 선택해야만 합니다.

14.4.5. 형태 디지타이즈 작업

Shape Digitizing 툴바의 도구들로 정규 형태 및 만곡 도형을 그릴 수 있습니다.

14.4.5.1. 원호 스트링 추가

circularStringCurvePoint Add circular string 또는 circularStringRadius Add circular string by radius 버튼으로 원호 도형을 가진 라인 또는 폴리곤 피처를 추가할 수 있습니다.

이 도구들로 피처를 생성하는 작업은 다른 디지타이즈 작업 도구들과 동일한 규칙을 따릅니다: 꼭짓점을 배치하려면 왼쪽 클릭, 도형을 완료하려면 오른쪽 클릭하십시오. 도형을 그리는 동안, 두 원호 스트링 도구 사이를 전환하는 것은 물론 선형 도형 도구 로도 전환해서 복합 도형을 생성할 수 있습니다.

참고

만곡 도형은 호환되는 데이터 제공자에서만 만곡 도형으로 저장됩니다

QGIS가 모든 편집 가능한 데이터 유형 내에서 만곡 도형을 디지타이즈하는 것을 허용하고 있기는 하지만, 피처를 만곡 도형으로 저장하려면 곡선을 지원하는 (예를 들어 PostGIS, 메모리 레이어, GML 또는 WFS 같은) 데이터 제공자를 사용해야 합니다. 그렇지 않을 경우 QGIS가 원호를 선분화시킬 것입니다.

14.4.5.2. 원 그리기

원을 그릴 수 있는 도구들의 집합이 있습니다. 다음은 그 도구들의 설명입니다.

원은 원호 스트링으로 변환됩니다. 따라서 원호 스트링 추가 에서 설명한대로 데이터 제공자가 허용하는 경우 만곡 도형으로 저장될 것이고, 아닌 경우 QGIS가 원호를 선분화할 것입니다.

  • circle2Points Add circle from 2 points: 포인트 2개로 지름 및 원의 방향을 정의합니다. (왼쪽 클릭, 오른쪽 클릭)

  • circle3Points Add circle from 3 points: 포인트 3개가 원의 경계선 상에 있다고 가정하고 원을 그립니다. (왼쪽 클릭, 왼쪽 클릭, 오른쪽 클릭)

  • circleCenterPoint Add circle from center and a point: 중심 포인트와 원의 경계선 상에 있다고 가정한 포인트로 원을 그립니다. (왼쪽 클릭, 오른쪽 클릭) 고급 디지타이즈 작업 패널 과 함께 사용하는 경우, 첫 번째 클릭 이후 거리값을 설정하고 고정해서 이 도구를 《Add circle from center and radius》 도구로 사용할 수 있습니다.

  • circle3Tangents Add circle from 3 tangents: 선분 3개를 접선으로 하는 원을 그립니다. 선분 스냅 모드를 활성화해야만 한다는 사실을 기억하십시오. (스냅 허용 오차 및 검색 반경 설정 을 참조하세요.) 접선으로 추가할 선분을 클릭하십시오. 접선 2개가 평행하는 경우, 오류 메시지를 표시하고 입력을 초기화합니다. (왼쪽 클릭, 왼쪽 클릭, 오른쪽 클릭)

  • circle2TangentsPoint Add circle from 2 tangents and a point: 접선 3개로 원을 그리는 도구와 유사하지만, 접선 2개를 선택한 다음 반경을 입력하고 원하는 중심을 선택해야 한다는 점이 다릅니다.

14.4.5.3. Draw Ellipses

There is a set of tools for drawing ellipses. The tools are described below.

Ellipses cannot be converted as circular strings, so they will always be segmented.

  • ellipseCenter2Points Add Ellipse from center and two points: Draws an ellipse with a given center, major axis and minor axis. (Left-click, left-click, right-click)

  • ellipseCenterPoint Add Ellipse from center and a point: Draws an ellipse into a bounding box with the center and a corner. (Left-click, right-click)

  • ellipseExtent Add Ellipse from extent: Draws an ellipse into a bounding box with two opposite corners. (Left-click, right-click)

  • ellipseFoci Add Ellipse from foci: Draws an ellipse by 2 points for foci and a point on the ellipse. (Left-click, left-click, right-click)

14.4.5.3.1. Draw Rectangles

There is a set of tools for drawing rectangles. The tools are described below.

  • rectangleCenter Rectangle from center and a point: Draws a rectangle from the center and a corner. (Left-click, right-click)

  • rectangleExtent Rectangle from extent: Draws a rectangle from two opposite corners. (Left-click, right-click)

  • rectangle3PointsDistance Rectangle from 3 points (distance): Draws an oriented rectangle from three points. The first and second points determine the length and angle of the first edge. The third point determines the length of the other edge. (Left-click, left-click, right-click)

  • rectangle3PointsProjected Rectangle from 3 points (projected): Same as the preceding tool, but the length of the second edge is computed from the projection of the third point on the first edge. (Left-click, left-click, right-click)

    ../../../_images/draw_rectangles_3_points.png

    그림 14.95 Draw rectangle from 3 points using distance (right) and projected (left)

14.4.5.3.2. Draw Regular Polygons

There is a set of tools for drawing regular polygons. The tools are described below. Left-click to place the first point. A dialog appears, where you can set the number of polygon edges. Right-click to finish the regular polygon.

  • regularPolygon2Points Regular polygon from two points: Draws a regular polygon where the two points determine the length and angle of the first edge.

  • regularPolygonCenterPoint Regular polygon from center and a point: Draws a regular polygon from the provided center point. The second point determines the angle and distance to the middle of an edge.

  • regularPolygonCenterCorner Regular polygon from center and a corner: Same as the preceding tool, but the second point determines the angle and distante to a vertex.

14.4.6. 고급 디지타이즈 작업 패널

새로운 또는 기존 도형을 캡처, 재형성, 분할하는 경우 고급 디지타이즈 작업 패널을 이용할 수도 있습니다. 라인을 정확히 평행으로 또는 특정 각도에 직각으로 디지타이즈할 수도 있고, 라인을 지정 각도로 고정시킬 수도 있습니다. 게다가, 좌표를 직접 입력해서 사용자의 새 도형을 정밀하게 정의할 수도 있습니다.

../../../_images/advanced_digitizing.png

그림 14.96 고급 디지타이즈 작업 패널

툴바를 오른쪽 클릭하거나, View ▶ Panels ▶ 메뉴로부터, 또는 Ctrl+4 키를 누르면 Advanced Digitizing 패널을 열 수 있습니다. 패널이 가시화되고 나면, cad Enable advanced digitizing tools 아이콘을 클릭해서 고급 다지타이즈 작업 도구를 활성화하십시오.

참고

맵 뷰가 지리 좌표인 경우 이 도구들을 활성화할 수 없습니다.

14.4.6.1. 개념

고급 다지타이즈 작업 도구의 목적은 맵 캔버스에서 디지타이즈 작업 도중 마우스를 이동시킬 때 좌표, 길이 그리고 각도를 고정하는 것입니다.

또한 상대 또는 절대 참조로 제약 조건을 생성할 수도 있습니다. 상대 참조란 이전 꼭짓점 또는 선분에 따라 다음 꼭짓점 제약 조건의 값이 변한다는 뜻입니다.

14.4.6.2. 스냅 설정

고급 디지타이즈 작업 도구의 스냅 환경을 설정하려면 settings 아이콘을 클릭하십시오. 이 도구가 공통 각도로 스냅하도록 할 수 있습니다. 옵션은 다음과 같습니다:

  • Do not snap to common angles

  • Snap to 30º angles

  • Snap to 45º angles

  • Snap to 90º angles

피처에 어떻게 스냅할지도 설정할 수 있습니다. 옵션은 다음과 같습니다:

  • Do not snap to vertices or segments

  • Snap according to project configuration

  • Snap to all layers

14.4.6.3. 키보드 단축키

고급 디지타이즈 작업 패널의 활용 속도를 높이려면, 다음과 같은 키보드 단축키를 사용할 수 있습니다:

간단한 설명

Ctrl+ 또는 Alt+ 키조합

Shift+ 키조합

D

거리 설정

거리 고정

A

각도 설정

각도 고정

마지막 선분에 상대적인 각도 켜고끄기

X

X 좌표 설정

X 좌표 고정

마지막 꼭짓점에 상대적인 X 켜고끄기

Y

Y 좌표 설정

Y 좌표 고정

최근 꼭짓점에 상대적인 Y 변경

C

작성 모드 변경

P

수직 및 평행 모드 변경

14.4.6.4. 절대 참조 디지타이즈 작업

아무것도 없는 상태에서 새 도형을 그리는 경우, 지정한 좌표에서 꼭짓점 디지타이즈를 시작할 수 있다면 매우 편리합니다.

예를 들면 폴리곤 레이어에 새 피처를 추가하려면, capturePolygon 아이콘을 클릭하십시오. 피처 편집을 시작하길 바라는 X 및 Y 좌표를 다음과 같이 선택할 수 있습니다:

  • x 텍스트 란을 클릭합니다. (또는 X 단축키를 누릅니다.)

  • 원하는 X 좌표를 입력한 다음 Enter 키를 누르거나 오른쪽에 있는 locked 아이콘을 클릭하면 맵 캔버스 상의 X 좌표의 축에 마우스가 고정됩니다.

  • y 텍스트 란을 클릭합니다. (또는 Y 단축키를 누릅니다.)

  • 원하는 Y 좌표를 입력한 다음 Enter 키를 누르거나 오른쪽에 있는 locked 아이콘을 클릭하면 맵 캔버스 상의 Y 좌표의 축에 마우스가 고정됩니다.

파랑색 점선 2개와 초록색 가위표가 사용자가 입력한 좌표를 정확히 가리키고 있습니다. 마우스 위치는 초록색 가위표에 고정돼 있습니다. 맵 캔버스를 클릭해서 디지타이즈 작업을 시작하십시오.

../../../_images/advanced_digitizing_coordinates.png

그림 14.97 지정 좌표에서 그리기 시작

사용자의 손으로 직접 디지타이즈를 계속해서 좌표 몇 쌍을 추가할 수도 있고, 또는 선분의 길이 (거리) 및 각도 를 입력할 수도 있습니다.

지정 길이로 선분을 그리고 싶다면, d (distance) 텍스트란을 클릭하고 (또는 D 단축키를 누르고) 거리 값을 (맵 단위로) 입력한 다음 Enter 키를 누르거나 오른쪽에 있는 locked 아이콘을 클릭하면 맵 캔버스에 있는 마우스를 선분의 길이로 고정시킵니다. 맵 캔버스에서는, 거리 텍스트란에 입력한 값이 반경인 원이 클릭한 포인트를 둘러싸고 있습니다.

../../../_images/advanced_digitizing_distance.png

그림 14.98 고정 길이 선분

마지막으로, 선분의 각도도 설정할 수 있습니다. 앞에서 설명한 바와 마찬가지로, a (angle) 텍스트란을 클릭하고 (또는 A 단축키를 누르고) 각도 값을 (도 단위로) 입력한 다음 Enter 키를 누르거나 오른쪽에 있는 locked 아이콘을 클릭하면 각도가 고정됩니다. 이렇게 하면 선분이 원하는 각도대로 꺾일 것입니다.

../../../_images/advanced_digitizing_angle.png

그림 14.99 고정 각도 선분

14.4.6.5. 상대 참조 디지타이즈 작업

각도 또는 좌표의 절대값을 사용하는 대신, 직전에 디지타이즈한 꼭짓점 또는 선분에 상대적인 값을 사용할 수도 있습니다.

각도의 경우, a 텍스트란 왼쪽에 있는 delta 버튼을 클릭해서 (또는 Shift+A 조합키를 눌러서) 이전 선분에 상대적인 각도를 켜고 끌 수 있습니다. 이 옵션을 켜면, 직전 선분과 마우스 포인터 사이의 각도를 측정합니다.

좌표의 경우, x 또는 y 텍스트란 왼쪽에 있는 delta 아이콘을 클릭해서 (혹은 Shift+X 또는 Shift+Y 조합키를 눌러서) 이전 꼭짓점에 상대적인 좌표를 켜고 끌 수 있습니다. 이 옵션을 켜면, 직전 꼭짓점을 원점으로 삼아 X 및 Y 좌표를 측정합니다.

14.4.6.6. 지속 고정

lockedRepeat Continuous lock 버튼을 클릭하면 디지타이즈 작업, 각도, 거리, X 및 Y 좌표에 대한 절대 또는 상대 참조 제약 조건 모두 지속적으로 고정시킬 수 있습니다. 지속 고정을 사용하면 여러 포인트 또는 꼭짓점을 동일한 제약 조건으로 디지타이즈할 수 있습니다.

14.4.6.7. 평행 및 수직 라인

앞에서 설명한 모든 도구들은 cadPerpendicular PerpendicularcadParallel Parallel 도구와 결합해서 사용할 수 있습니다. 이 두 도구는 선분을 또다른 선분에 완벽히 직각으로 또는 평행하게 그릴 수 있습니다.

수직 선분을 그리려면, 편집 도중에 cadPerpendicular Perpendicular 아이콘을 클릭해서 (또는 P 단축키를 눌러서) 활성화시키십시오. 수직 라인을 그리기 전에, 직각의 기준이 될 기존 피처의 선분을 클릭하십시오. (기존 피처의 라인이 밝은 주황색으로 강조될 것입니다.) 사용자의 라인이 스냅될 위치에 다음과 같이 파랑색 점선이 보일 겁니다:

../../../_images/advanced_digitizing_perpendicular.png

그림 14.100 수직 디지타이즈 작업

평행 라인을 그리는 방법도 동일합니다. cadParallel Parallel 아이콘을 클릭해서 (또는 P 단축키를 두 번 눌러서) 활성화한 다음, 참조 라인으로 사용하려는 선분을 클릭하고 사용자 피처를 다음과 같이 그리십시오:

../../../_images/advanced_digitizing_parallel.png

그림 14.101 평행 디지타이즈 작업

이 두 도구는 수직 및 평행 각도에 딱 맞는 각도를 찾아서 편집 작업 중에 해당 파라미터를 고정시킵니다.

14.4.6.8. 작성 모드

cadConstruction Construction 아이콘을 클릭하거나 또는 C 단축키를 누르면 작성 모드를 활성화/비활성화할 수 있습니다. 작성 모드 상태에서 맵 캔버스를 클릭하면 새 꼭짓점을 추가하지는 않지만, 클릭한 위치를 캡처해서 이후 거리, 각도, 또는 X 및 Y 좌표의 상대값을 고정시킬 참조 포인트로 이용할 수 있습니다.

예를 들어, 기존 포인트에서 정확히 동일한 거리에 있는 포인트를 몇 개 그리는 데 작성 모드를 사용할 수 있습니다.

맵 캔버스에 있는 기존 포인트와 올바르게 활성화된 스냅 모드를 통해, 기존 포인트에서 지정 거리 및 각도에 있는 다른 포인트를 쉽게 그릴 수 있습니다. cad 버튼을 클릭한 다음, cadConstruction Construction 아이콘을 클릭하거나 C 단축키를 눌러서 작성 모드도 활성화시켜야 합니다.

사용자가 해당 포인트로부터 거리를 계산하고자 하는 포인트 옆을 클릭하고 d 텍스트란을 클릭한 다음 (또는 D 단축키를 누른 다음) 원하는 거리를 입력하고 Enter 키를 눌러 다음과 같이 맵 캔버스에 마우스 위치를 고정하십시오:

../../../_images/advanced_digitizing_distance_point.png

그림 14.102 점거리

새 포인트를 추가하기 전에, C 단축키를 눌러 작성 모드를 끄십시오. 이제 맵 캔버스를 클릭하면, 입력한 거리에 포인트가 배치될 것입니다.

예를 들자면 원점 포인트로부터 동일한 거리에 있지만, 새로 추가한 포인트에서 특정 각도에 있는 다른 포인트를 생성하는 데 각도 제약조건을 사용할 수도 있습니다. cadConstruction Construction 아이콘을 클릭하거나 C 단축키를 눌러서 작성 모드를 켜십시오. 새로 추가한 포인트를 클릭한 다음 다른 포인트도 클릭해서 방향 선분을 설정하십시오. 다음으로 d 텍스트란을 클릭하고 (또는 D 단축키를 누르고) 원하는 거리를 입력한 다음 Enter 키를 누르십시오. a 텍스트란을 클릭하고 (또는 A 단축키를 누르고) 원하는 각도를 입력한 다음 Enter 키를 누르십시오. 마우스 위치의 거리 및 각도 둘 다 고정될 것입니다.

../../../_images/advanced_digitizing_distance_angle_point.png

그림 14.103 포인트들로부터의 거리 및 각도

새 포인트를 추가하기 전에, C 단축키를 눌러 작성 모드를 끄십시오. 이제 맵 캔버스를 클릭하면, 입력한 거리에 포인트가 배치될 것입니다. 이 과정을 반복하면 여러 포인트를 추가할 수 있습니다.

../../../_images/advanced_digitizing_distance_point_final.png

그림 14.104 지정 거리 및 각도에 있는 포인트들

14.4.7. 제자리(in-place) 공간 처리 레이어 수정자

공간 처리 메뉴 는 입력 피처 또는 입력 피처와 (동일 레이어 안에 있을 수도 있고 아닐 수도 있는) 다른 피처의 관계의 속성을 기반으로 새 피처를 생성하고 분석할 수 있는 수많은 도구를 제공합니다. 새 레이어를 산출물로 생성하는 것이 공통된 습성이지만, 몇몇 알고리즘은 입력 레이어를 수정할 수도 있습니다. 이를 사용하면 고급의 복잡한 작업을 통해 다중 피처 수정을 간편하게 자동화할 수 있습니다.

피처를 제자리에서 편집하려면:

  1. Layers 패널에서 편집할 레이어를 선택하십시오.

  2. 관심이 있는 피처를 선택하십시오. 이 단계를 건너뛰어도 되는데, 그럴 경우 레이어 전체에 수정 사항을 적용할 것입니다.

  3. 공간 처리 툴박스 상단에 있는 processSelected Edit Features In-Place 버튼을 클릭하십시오. 알고리즘 목록을 필터링해서 제자리 수정을 지원하는 알고리즘만 표시할 것입니다. 예를 들면:

    • 레이어 수준에서가 아니라 피처 소스 수준에서 작동하는 알고리즘

    • 필드를 추가하거나 제거하는 등 레이어 구조를 변경하지 않는 알고리즘

    • 라인 레이어를 포인트 레이어로 바꾸는 등 도형 유형을 변경하지 않는 알고리즘

    ../../../_images/edit_inplace_algorithms.png

    그림 14.105 공간 처리 알고리즘: 전체(왼쪽) 대 제자리 폴리곤 편집기(오른쪽)

  4. 사용자가 실행하려는 알고리즘을 찾아 더블클릭하십시오.

    참고

    알고리즘이 (일반적인 입력/산출 레이어 파라미터를 제외하면) 사용자가 설정한 어떤 파라미터도 필요로 하지 않는 경우, 어떤 대화창도 열리지 않고 알고리즘이 즉시 실행됩니다.

    1. 일반적인 입력/산출 레이어 파라미터가 아닌 다른 파라미터가 필요한 경우, 알고리즘 대화창이 열립니다. 필요한 정보를 입력하십시오.

    2. 활성화된 선택 집합이 있는지 여부에 따라 Modify Selected Features 또는 Modify All Features 를 클릭하십시오.

    변경 사항을 레이어에 적용하고 편집 버퍼에 저장합니다. 레이어는 자동으로 편집 모드로 넘어가며, 레이어명 옆에 표시되는 editableEdits 아이콘은 저장하지 않은 수정 사항이 있다는 사실을 나타냅니다.

  5. 다른 작업과 마찬가지로, saveEdits Save layer edits 버튼을 클릭하면 레이어에 변경 사항을 저장합니다. 물론 undo Undo 버튼을 클릭해서 모든 수정 사항을 되돌릴 수도 있습니다.