9. QGIS 환경 설정

Settings 메뉴를 통해 QGIS 환경을 다음과 같이 매우 자세하게 설정할 수 있습니다:

  • styleManager Style Manager…: 심볼, 스타일 및 색상표 를 생성하고 관리합니다.

  • customProjection Custom Projections…: 사용자 자신만의 좌표계 를 생성합니다.

  • keyboardShortcuts Keyboard Shortcuts…: 사용자 자신만의 키보드 단축키 모음을 정의합니다. 그리고 각 QGIS 세션마다 (Project 메뉴 아래 있는) 프로젝트 속성 으로 이 단축키 정의를 무시할 수도 있습니다.

  • interfaceCustomization Interface Customization…: 사용자가 필요로 하지 않는 대화창이나 도구를 숨기는 등, 응용 프로그램 인터페이스 를 설정합니다.

  • options Options…: 소프트웨어의 서로 다른 영역들에 적용할 전체 수준 옵션 을 설정합니다. 설정한 옵션들은 활성화된 사용자 프로파일 설정에 저장되어, 해당 프로파일과 함께 새로 프로젝트를 열 때마다 기본적으로 적용됩니다.

9.1. 옵션

options Options 대화창을 통해 QGIS에 대한 몇몇 기본 옵션을 선택할 수 있습니다. Settings ‣ options Options 메뉴 옵션을 선택하십시오. 사용자의 필요에 따라 옵션을 수정할 수 있습니다. 일부 변경 사항은 적용되기 전에 QGIS 재시작이 필요할 수도 있습니다.

사용자 고유 옵션을 사용자 지정할 수 있는 탭들에 대해 다음 항에서 설명하고 있습니다.

참고

플러그인 설정을 옵션 대화창에 내장시킬 수 있습니다.

여기에서는 핵심 설정만 설명하지만, 설치된 플러그인 이 표준 옵션 대화창에 고유 옵션을 삽입하여 해당 목록을 확장시킬 수 있다는 사실을 기억하십시오. 이렇게 해서 각 플러그인이 각각 자신만의 추가 메뉴 항목을 가진 설정 대화창을 여는 것을 막을 수 있습니다.

9.1.1. 일반 설정

시스템 로케일 무시

QGIS는 기본적으로 사용자의 운영체제 설정에 의존해서 언어를 설정하고 수치(numerical value)를 처리합니다. 이 옵션 그룹을 활성화하면 사용자가 이런 로케일 습성을 사용자 지정할 수 있습니다.

  • User interface translation 에서 GUI에 적용할 언어를 선택합니다.

  • Locale (number, date and currency formats) 에서 날짜 및 수치를 입력하고 렌더링하는 체계를 선택합니다.

  • checkbox Show group (thousand) separator : 천단위 구분자를 활성화합니다.

사용자가 선택한 설정 및 해당 설정이 어떻게 해석되는지에 대한 요약 설명이 대화창 프레임의 하단에 표시됩니다.

응용 프로그램

  • 대화창에 표시되는 위젯의 모양 및 위치 등을 설정하려면 Style (QGIS restart required) 을 선택하십시오. 사용자의 운영체제에 따라 선택할 수 있는 옵션값이 달라집니다.

  • UI theme (QGIS restart required) selectString 에서 UI 테마를 정의하십시오. 〈default〉, 〈Night Mapping〉, 또는 〈Blend of Gray〉 가운데 하나를 선택할 수 있습니다.

  • Icon size selectString 에서 아이콘 크기를 정의하십시오.

  • FontSize 에서 글꼴 및 그 크기를 정의하십시오. 글꼴은 radioButtonOn Qt default 일 수도 있고, 사용자가 글꼴을 선택할 수도 있습니다.

  • Timeout for timed messages or dialogs 에서 시한이 정해진 메시지 또는 대화창의 시한을 정의하십시오.

  • unchecked Hide splash screen at startup 에서 QGIS 실행 시 로딩 이미지 표시 여부를 설정하십시오.

  • checkbox Show QGIS news feed on welcome page: 환영 페이지에 사용자가 직접 프로젝트 소식(사용자/개발자 모임 날짜 및 요약, 커뮤니티 설문조사, 배포판 발표, 다양한 팁들 등등)을 볼 수 있는 기획된 QGIS 뉴스피드를 표시할지 여부를 설정하십시오.

  • checkbox Check QGIS version at startup 를 체크하면 새 버전이 출시됐는지에 대한 소식을 놓치지 않을 수 있습니다.

  • unchecked Use native color chooser dialogs : 내장된 색상 선택 대화창 사용 여부를 설정합니다. (색상 선택기 참조)

  • unchecked Modeless data source manager dialog : 프로젝트에 레이어를 추가하는 동안 데이터소스 관리자 대화창을 열어둔 채 QGIS 인터페이스와 상호작용시킬지 여부를 설정합니다.

프로젝트 파일

  • Open project on launch

    • 〈환영 페이지〉 (기본값): 《뉴스》 피드, 프로젝트 템플릿(들), 그리고 사용자 프로파일 의 (썸네일로 표시된) 최근 프로젝트들을 표시할 수 있습니다. 기본적으로 어떤 프로젝트도 열지 않습니다.

    • 〈새 프로젝트〉: 기본 템플릿에 기반한 새 프로젝트를 엽니다.

    • 〈최근 프로젝트〉: 마지막으로 저장했던 프로젝트를 다시 엽니다.

    • 〈특정 프로젝트〉: 특정 프로젝트를 엽니다. 버튼을 통해 기본값으로 사용할 프로젝트를 정의합니다.

  • checkbox Create new project from default project 를 선택하면 Set current project as default 또는 Reset default 가운데 하나를 클릭할 수 있습니다. 사용자 파일을 탐색하고 사용자가 직접 정의한 프로젝트 템플릿이 있는 디렉터리를 정의할 수 있습니다. 해당 템플릿은 Project ‣ New From Template 메뉴에 추가됩니다. 먼저 checkbox Create new project from default project 를 활성화한 경우, 프로젝트 템플릿 폴더에 프로젝트를 저장하십시오.

  • checkbox Prompt to save project and data source changes when required: 사용자의 변경 사항을 잃지 않으려면 이 옵션을 체크하십시오.

  • checkbox Prompt for confirmation when a layer is to be removed: 실수로 레이어를 삭제하는 일이 없으려면 이 옵션을 체크하십시오.

  • checkbox Warn when opening a project file saved with an older version of QGIS: QGIS 구 버전의 프로젝트 파일을 열려고 할 때 경고창을 엽니다. QGIS 신 버전은 언제나 구 버전에서 생성된 프로젝트를 열 수 있지만, 신 버전의 프로젝트를 구 버전으로 열려고 할 경우 해당 버전에서 지원하지 않는 피처가 있을 수 있기 때문에 실패할 수도 있습니다.

  • Enable macros selectString 옵션은 프로젝트 이벤트에 대한 액션을 수행하기 위해 작성된 매크로를 처리하기 위해 만들어졌습니다. 〈Never〉, 〈Ask〉, 〈For this session only〉 그리고 〈Always (not recommended)〉 가운데 선택할 수 있습니다.

9.1.2. 시스템 설정

SVG 경로

Path(s) to search for Scalable Vector Graphic (SVG) symbols 를 추가하거나 삭제합니다. 피처 심볼 또는 라벨을 적용하거나, 사용자 맵 조판을 장식하는 데 이 SVG 파일을 쓸 수 있습니다.

심볼 또는 라벨에 SVG 파일을 사용할 경우, QGIS는 다음과 같은 작업을 할 수 있습니다:

  • 파일 시스템에서 파일 불러오기: 파일 경로를 통해 파일을 식별하는데, QGIS는 대응하는 이미지를 표시하기 위해 경로를 분해해야 합니다.

  • 원격 URL에서 파일 불러오기: 마찬가지로, 원격 리소스에서 성공적으로 검색되어야 이미지를 불러올 것입니다.

  • 항목 내에 SVG 파일 내장시키기: 현재 프로젝트, 스타일 데이터베이스, 또는 인쇄 조판 템플릿 안에 파일을 내장시킵니다. 그러면 언제나 SVG 파일을 항목의 일부로 렌더링할 것입니다. 이 방법으로 사용자 지정 SVG 심볼을 내장한 프로젝트를 서로 다른 사용자와 QGIS 설치판 사이에서 쉽게 공유할 수 있도록 간편하게 생성할 수 있습니다.

    심볼 또는 라벨에서 내장 SVG 파일을 추출해서 디스크에 저장할 수도 있습니다.

참고

앞에서 언급한 프로젝트에 SVG 파일을 불러오거나 저장하는 옵션을, 사용자 지정려고 하는 심볼, 라벨, 장식에 사용할 래스터 이미지에도 적용할 수 있습니다.

플러그인 경로

Path(s) to search for additional C++ plugin libraries 를 추가하거나 삭제합니다.

문서 경로

QGIS 도움말에 사용할 Documentation Path(s) 를 추가하거나 삭제합니다. 사용 중인 QGIS 버전에 대응하는 공식 온라인 사용자 지침서를 가리키는 링크가 기본값으로 추가됩니다. 하지만 다른 링크들을 추가하고 위에서 아래로 우선순위를 정할 수 있습니다. 사용자가 대화창에서 Help 버튼을 클릭할 때마다, 가장 위에 있는 링크를 검색하고 만약 해당 페이지를 찾을 수 없다면 그 다음 링크, 다시 그 다음 링크를 검색할 것입니다.

참고

QGIS LTR(Long Term Release) 버전에 대해서만 문서의 버전을 붙이고 번역합니다. 즉 사용자가 (QGIS 3.0 같은) 일반 배포판을 실행하는 경우, 도움말 버튼을 클릭하면 기본적으로 다음 (QGIS 3.4 LTR 같은) LTR 버전 사용자 지침서 페이지를 열 것입니다. 이 사용자 지침서는 (3.2 및 3.4 같은) 신 배포판의 기능 설명을 포함하고 있을 수도 있습니다. LTR 버전 문서를 사용할 수 없을 경우, 최신 개발 중인 버전의 기능을 설명하는 시험용 문서로 연결합니다.

QSettings

사용자가 어떤 사용자 지정 사항이라도 만들었을 경우 Reset user interface to default settings (restart required) 옵션을 통해 초기화할 수 있습니다.

환경

../../../_images/sys-env-options.png

그림 9.1 QGIS의 시스템 환경 변수

Environment 그룹에서 시스템 환경 변수를 살펴볼 수 있고, 많은 변수를 설정할 수 있습니다. 이 옵션은 맥OS처럼 GUI 응용 프로그램이 사용자의 셸 환경을 반드시 상속하지는 않는 플랫폼에서 유용합니다. SAGA, GRASS 같은 공간 처리 툴박스가 제어하는 외부 도구 모음을 위한 환경 변수들을 설정하고 살펴보는 데에도, 그리고 소스 코드의 특정 부분에 대해 산출물을 디버그하는 작업을 활성화시키는 데에도 유용합니다.

checkbox Use custom variables (restart required - include separators) 를 활성화하면 변수들을 AddRemove 할 수 있습니다. Current environment variables 에 이미 정의된 환경 변수를 표시하며, checkbox Show only QGIS-specific variables 를 활성화해서 환경 변수를 필터링할 수도 있습니다.

9.1.3. 좌표계 설정

참고

QGIS가 레이어 투영체를 어떻게 처리하는지 자세히 알고 싶다면, 투영 작업 에서 전문적으로 설명하고 있습니다.

../../../_images/options_crs.png

그림 9.2 QGIS에서 좌표계 설정하기

새 프로젝트 용 좌표계

새 프로젝트의 좌표계를 자동적으로 설정하는 옵션이 있습니다:

  • radioButtonOnUse CRS from first layer added: 프로젝트의 좌표계를 처음 불러온 레이어의 좌표계로 설정할 것입니다.

  • radioButtonOffUse a default CRS: 모든 새 프로젝트에 미리 설정해둔 좌표계를 적용하며, 프로젝트에 어느 레이어를 추가해도 변경하지 않습니다.

사용자가 어떤 옵션을 선택하든, 선택한 옵션을 차후 QGIS 세션에도 사용하도록 저장할 것입니다. 하지만 언제든지 Project ‣ Properties… ‣ CRS 탭에서 프로젝트의 기존 좌표계를 무시하고 새로 적용할 수 있습니다.

레이어 용 좌표계

Default CRS for layers: 새 레이어를 생성할 때 사용할 좌표계를 선택합니다.

새 레이어를 생성하거나 좌표계가 정의되지 않은 레이어를 불러올 때 수행할 액션을 정의할 수도 있습니다.

  • radioButtonOn Leave as unknown CRS (take no action)

  • radioButtonOff Prompt for CRS

  • radioButtonOff Use project CRS

  • radioButtonOff Use a default CRS

기본 데이터 변환

이 그룹에서는 레이어 좌표계를 또다른 좌표계로 재투영하는 작업을 다음과 같이 제어할 수 있습니다:

  • QGIS 기본 변환 설정을 사용해서 자동적으로 공간 처리

  • 그리고/또는 사용자 지정 선호도를 통해 다음과 같이 더 자세히 조정:

    • checkbox Ask for datum transformation if several are available

    • 기본으로 적용할 미리 정의된 데이터 변환 목록. 자세한 내용은 데이터 변환 을 참조하세요.

  • unchecked Planimetric measurements: 새로 생성한 프로젝트 용 《평면 측정(planimetric measurements)》 속성 기본값을 설정합니다.

9.1.4. 데이터소스 설정

../../../_images/options_data_sources.png

그림 9.3 QGIS에서 데이터소스 설정하기

피처 속성 및 테이블

  • checkbox Open new attribute tables as docked windows

  • 다른 응용 프로그램의 피처를 붙여넣을 경우 Copy features as 옵션으로 〈Plain text, no geometry〉, 〈Plain text, WKT geometry〉, 또는 〈GeoJSON〉 가운데 하나를 선택합니다.

  • Attribute table behavior selectString: 속성 테이블을 열 때의 필터를 설정합니다. 〈Show all features〉, 〈Show selected features〉 그리고 〈Show features visible on map〉 가운데 하나를 선택할 수 있습니다.

  • Default view: 속성 테이블을 열 때의 뷰 모드를 정의합니다. 〈Remember last view〉, 〈Table view〉 또는 〈Form view〉 가운데 하나를 선택할 수 있습니다.

  • Attribute table row cache selectNumber 에서 속성 테이블 관련 작업을 빠르게 처리할 수 있도록 최근 속성 행을 몇 개나 행 캐시에 저장할지 설정할 수 있습니다. 속성 테이블을 닫으면 캐시를 삭제합니다.

  • Representation for NULL values 을 통해 NULL 값을 포함하는 데이터 항목을 위한 값을 정의할 수 있습니다.

대용량 속성 테이블 열기를 향상시키기

대용량 레코드를 보유한 레이어를 작업하는 경우, 대화창이 레이어에 있는 모든 행을 요구하기 때문에 속성 테이블을 여는 데 시간이 많이 걸릴 수도 있습니다. Attribute table behaviorShow Features Visible On Map 으로 설정하면, QGIS가 테이블을 열 때 현재 맵 캔버스에 있는 피처만 요구하므로 데이터를 빨리 불러올 수 있습니다.

이 속성 테이블 인스턴스에 있는 데이터가 언제나 테이블을 열 당시의 캔버스 범위에 구속된다는 사실을 기억하십시오. 즉 해당 테이블에서 Show All Features 를 선택해도 새 피처들을 표시하지 않을 것이라는 뜻입니다. 하지만 속성 테이블에서 Show Features Visible On Map 옵션을 선택하고 캔버스 범위를 변경하면 화면에 표시된 피처 집합을 업데이트할 수 있습니다.

데이터소스 처리

  • Scan for valid items in the browser dock selectString 을 통해 〈Check extension〉 과 〈Check file contents〉 가운데 하나를 선택할 수 있습니다.

  • Scan for contents of compressed files (.zip) in browser dock selectString 을 통해 .zip 압축 파일을 쿼리할 경우 탐색기 패널 하단의 위젯 정보를 얼마나 자세히 표시할지 정의합니다. 〈No〉, 〈Basic scan〉 그리고 〈Full scan〉 가운데 하나를 선택할 수 있습니다.

  • Prompt for raster sublayers when opening: 일부 래스터는 GDAL에서 하위 데이터셋이라고 부르는 하위 레이어를 지원합니다. netCDF 파일이 한 예입니다. netCDF 변수가 여러 개 있을 경우, GDAL은 모든 변수를 하위 데이터셋으로 간주합니다. 이 옵션은 하위 레이어를 보유한 파일을 열었을 때 하위 레이어를 어떻게 처리할지를 제어할 수 있게 해줍니다. 다음 가운데 하나를 선택할 수 있습니다:

    • ‘Always’: (하위 레이어가 존재할 경우) 항상 물어봅니다.

    • ‘If needed’: 레이어에 밴드는 없지만 하위 레이어는 있을 경우 물어봅니다.

    • ‘Never’: 물어보지 않고, 아무것도 불러오지 않습니다.

    • ‘Load all’: 물어보지 않지만, 모든 하위 레이어를 불러옵니다.

  • checkbox Ignore shapefile encoding declaration 을 체크하면 shapefile에 인코딩 정보가 있더라도 QGIS가 무시할 것입니다.

  • checkbox Execute expressions on server-side if possible: 데이터소스에서 피처를 요청할 경우, QGIS는 서버에 직접 필터링 기준을 전송해서 기준에 맞는 피처만 다운로드하는 방법으로 요청을 최적화하려 할 것입니다. 예를 들어 사용자 인터페이스 상의 목록에 베른에 사는 농부들만 표시돼야 할 경우, QGIS는 데이터베이스에 WHERE "hometown" = 'Bern' 을 전송할 것입니다. 어떤 경우에는 필터 기준이 너무 복잡해서 QGIS 표현식을 데이터베이스 호환 SQL로 번역할 수 없을 수도 있습니다. 이런 경우 QGIS는, 작업 효율은 많이 떨어지겠지만, 안전한 작업을 위해 전체 데이터를 다운로드해서 사용자 시스템 상에서 필터링할 것입니다.

    이 옵션을 비활성화하면 성능 저하를 감수하더라도 언제나 전체 데이터를 다운로드해서 사용자 시스템 상에서 필터링 작업을 하도록 QGIS를 강제할 수 있습니다. 이 옵션은 안전차단기(safety break)라는 의미를 가지며, 사용자가 QGIS 표현식 번역 엔진의 오류를 식별한 경우에만 비활성화해야 합니다.

  • checkbox Evaluate default values: 이 옵션은 변경 사항을 저장하는 경우 또는 (체크한 상태라면) 새 피처를 디지타이즈하는 경우 데이터베이스 제공자가 제공한 기본값들을 계산해야 하는지 여부를 정의합니다.

숨겨진 탐색기 경로

이 위젯은 사용자가 탐색기 패널 에서 숨기기로 선택한 모든 폴더 목록을 표시합니다. 이 목록에서 폴더를 제거하면 Browser 패널에 표시될 것입니다.

9.1.5. 렌더링 설정

../../../_images/rendering_menu.png

그림 9.4 프로젝트 속성 대화창의 렌더링 탭

렌더링 습성

  • checkbox By default new layers added to the map should be displayed: 이 옵션을 체크 해제하는 것은 여러 레이어를 동시에 불러오는 경우 캔버스에 새 레이어들 각각을 동시에 렌더링해서 처리 속도가 느려지는 상황을 피하고자 할 때 유용합니다.

  • checkbox Use render caching where possible to speed up redraws

  • checkbox Render layers in parallel using many CPU cores

  • checkbox Max cores to use

  • Map update interval (default to 250 ms)

  • checkbox Enable feature simplification by default for newly added layers

  • Simplification threshold

  • Simplification algorithm: 이 옵션은 로컬에서 피처를 《실시간(on-the-fly)》으로 단순화시켜 도형 렌더링 속도를 향상시킵니다. 데이터 제공자에서 불러온 도형을 변경하지는 않습니다. 사용자가 피처 도형을 사용하는 표현식을 사용할 경우 (예를 들어 면적을 계산할 경우) 이 옵션은 중요합니다. 단순화된 도형이 아니라 원본 도형에 대해 계산이 이루어진다는 것을 보장하기 때문입니다. 이를 위해 QGIS는 〈Distance〉(기본값), 〈SnapToGrid〉 그리고 〈Visvalingam〉 세 가지 알고리즘을 제공합니다.

  • unchecked Simplify on provider side if possible: PostGIS, Oracle 등의 제공자 단에서 도형을 단순화하며, 로컬 단의 단순화와는 달리 도형 기반 계산에 영향을 줄 수도 있습니다.

  • Maximum scale at which the layer should be simplified

  • doubleSpinBox Magnification level (확대경 참조)

참고

전체 수준 설정 이외에도, 특정 레이어의 Layer properties ‣ Rendering 메뉴를 통해서도 피처 단순화를 설정할 수 있습니다.

렌더링 품질

  • checkbox Make lines appear less jagged at the expense of some drawing performance

곡선 선분

  • Segmentation tolerance: 이 설정은 원호(circular arc)를 렌더링하는 방식을 제어합니다. (연속된 꼭짓점 2개와 곡선 중점 사이의, 도 단위의) 최대 각도 또는 (두 꼭짓점의 선분과 곡선 사이의, 맵 단위의) 최대 거리 가운데 더 작은 쪽, 그리고 더 직선에 가까운 선분을 이용해서 렌더링할 것입니다.

  • Tolerance type: 근사치와 곡선 사이에서 최대 각도(Maximum angle) 또는 최대 거리(Maximum difference) 가운데 선택할 수 있습니다.

래스터

  • RGB band selection 을 이용해서 적색, 녹색, 청색 밴드의 번호를 정의할 수 있습니다.

  • Zoomed in resamplingZoomed out resampling 을 정의할 수 있습니다. Zoomed in resampling 의 경우 다음 〈Nearest Neighbour〉, 〈Bilinear〉 와 〈Cubic〉 세 가지 리샘플링 메소드 가운데 하나를 선택할 수 있습니다. Zoomed out resampling 의 경우 〈Nearest Neighbour〉 와 〈Average〉 가운데 하나를 선택할 수 있습니다. Oversampling 값도 설정할 수 있습니다. (0.0 ~ 99.99 - 값이 커질수록 QGIS 작업량이 많아집니다. 기본값은 2.0입니다.)

대비 향상(Contrast enhancement)

Single band gray, Multi band color (byte/band) 또는 Multi band color (>byte/band) 에 대비 향상 옵션을 적용할 수 있습니다. 각 항목에 대해 다음 옵션을 설정할 수 있습니다:

  • Algorithm: 사용할 알고리즘을 설정합니다. 〈No stretch〉, 〈Stretch to MinMax〉, 〈Stretch and Clip to MinMax〉 또는 〈Clip to MinMax〉 가운데 하나를 선택할 수 있습니다.

  • Limits (minimum/maximum): 적용할 제한을 설정합니다. 〈Cumulative pixel count cut〉, 〈Minimum/Maximum〉, 〈Mean +/- standard deviation〉 가운데 하나를 선택할 수 있습니다.

래스터 렌더링의 경우, 다음 옵션도 정의할 수 있습니다:

  • Cumulative pixel count cut limits

  • Standard deviation multiplier

디버그

  • checkbox Map canvas refresh: 렌더링에 걸리는 시간을 Log Messages 패널에서 디버그합니다.

9.1.6. 캔버스 및 범례 설정

../../../_images/options_canvas_legend.png

그림 9.5 캔버스 및 범례 설정

다음 속성을 설정할 수 있습니다:

  • (프로젝트 속성으로 무시되는) 기본 맵 모양: Selection colorBackground color 를 정의합니다.

  • 레이어 범례 상호작용:

    • Double click action in legend selectString: 더블 클릭을 하면 〈Open layer properties〉 를 할지 〈Open attribute table〉 을 할지 또는 〈Open layer styling dock〉 을 할지 선택할 수 있습니다.

    • checkbox Display classification attribute names: 예를 들어 범주화 또는 규칙 기반 렌더링 작업자를 적용할 경우 레이어 패널에 범주 속성 명칭을 표시할지 여부를 정의합니다. (자세한 내용은 심볼 속성 을 참조하세요.)

    • WMS getLegendGraphic Resolution 을 설정할 수 있습니다.

  • Delay: 레이어의 맵 팁 표시를 1,000분의 1초 단위로 지연시킬 수 있습니다.

9.1.7. 맵 도구 설정

../../../_images/options_map_tools.png

그림 9.6 QGIS에서 맵 도구 설정하기

이 탭은 식별 도구 의 습성과 관련된 여러 옵션을 제공합니다.

  • Search radius for identifying features and displaying map tips 는 사용자가 해당 허용 오차 내에서 클릭하는 한 식별 도구가 결과를 표시하게 될 허용 오차 거리입니다.

  • Highlight color 에서 식별된 피처를 어떤 색상으로 강조할지 선택할 수 있습니다.

  • Buffer 에서 식별 강조 윤곽선을 어느 정도의 버퍼 거리로 렌더링할지 설정합니다.

  • Minimum width 에서 강조된 객체의 윤곽선을 얼마나 굵게 할지 설정합니다.

측정 도구

  • 측정 도구 용 Rubberband color 를 정의합니다.

  • Decimal places 를 정의합니다.

  • checkbox Keep base unit 을 체크하면 자동적으로 큰 숫자로 (예를 들어 미터를 킬로미터로) 변환하는 걸 막아줍니다.

  • Preferred distance units: 〈미터〉, 〈킬로미터〉, 〈피트〉, 〈야드〉, 〈마일〉, 〈해리(Nautical Miles)〉, 〈센티미터〉, 〈밀리미터〉, 〈도(Degrees)〉 또는 〈맵 단위〉 가운데 하나를 선택합니다.

  • Preferred area units: 〈제곱미터〉, 〈제곱킬로미터〉, 〈제곱피트〉, 〈제곱야드〉, 〈제곱마일〉, 〈헥타르〉, 〈에이커(Acres)〉, 〈제곱해리〉, 〈제곱센티미터〉, 〈제곱밀리미터〉, 〈제곱도〉 또는 〈맵 단위〉 가운데 하나를 선택합니다.

  • Preferred angle units: 〈도〉, 〈라디안〉, 〈곤/그라디안(Gon/gradians)〉, 〈Minutes of arc〉, 〈Seconds of arc〉, 〈Turns/revolutions〉, 밀리라디안(milliradian, SI 정의) 또는 밀(mil, NATO/군사 정의) 가운데 하나를 선택합니다.

이동 및 확대/축소

  • 확대/축소 도구 또는 마우스 휠 용 Zoom factor 를 정의합니다.

사전 정의 축척

여기에서 사전 정의된 축척 목록을 볼 수 있습니다. signPlussignMinus 버튼으로 사용자 지정 축척을 추가하거나 제거할 수 있습니다. 또 축척을 .XML 파일 포맷으로 내보내거나 불러올 수 있습니다. 사용자 변경 사항을 제거하고 사전 정의 목록으로 초기화할 수 있다는 사실을 기억하십시오.

9.1.8. 색상 설정

../../../_images/options_colors.png

그림 9.7 색상 설정

이 메뉴는 색상 선택기 위젯 을 통해 응용 프로그램 전반에 걸쳐 사용되는 색상표를 생성하거나 업데이트할 수 있게 해줍니다. 다음과 같은 색상표들을 선택할 수 있습니다:

  • 최근 사용한 색상들을 보여주는 Recent colors

  • 기본 색상표인 Standard colors

  • 현재 프로젝트에 특정해 사용되는 색상표인 Project colors (자세한 내용은 기본 스타일 속성 참조)

  • QGIS에 새 레이어를 추가할 경우 기본적으로 사용되는 색상표인 New layer colors

  • 또는 색상표 콤보박스 옆의 버튼으로 생성하거나 가져올 수 있는 사용자 지정 색상표(들)

기본적으로, Recent colors, Standard colorsProject colors 색상표는 색상 버튼 드롭다운 목록에 표시되도록 설정돼 있으며 이들을 삭제할 수는 없습니다. Show in Color Buttons 옵션을 통해 사용자 지정 색상표도 이 위젯에 추가할 수 있습니다.

프레임 옆의 다음과 같은 도구 모음을 사용해서, 모든 색상표의 색상 목록을 관리할 수 있습니다:

  • signPlus Add 또는 signMinus Remove: 색상을 추가하거나 삭제합니다.

  • editCopy Copy 또는 editPaste Paste: 색상을 복사하거나 붙여넣습니다.

  • fileOpen Import 또는 fileSave Export: 색상 모음을 .gpl 파일로부터 가져오거나, .gpl 파일로 내보냅니다.

목록에 있는 색상을 더블클릭하면 색상 선택기 대화창의 해당 색상을 조정하거나 대체할 수 있습니다. Label 열을 더블클릭하면 해당 색상의 명칭을 변경할 수도 있습니다.

9.1.9. 디지타이즈 작업 설정

../../../_images/options_digitizing.png

그림 9.8 QGIS에서 디지타이즈 작업 설정하기

이 탭에서 벡터 레이어 편집 시 (속성 및 도형) 이용할 수 있는 일반 설정의 환경을 설정할 수 있습니다.

피처 생성

  • checkbox Suppress attribute form pop-up after feature creation: 이 옵션을 활성화하더라도, 각 레이어의 속성 대화창에서 무시할 수 있습니다.

  • checkbox Reuse last entered attribute values: 마지막으로 입력한 속성값들을 다시 사용할지 여부를 선택합니다.

  • Validate geometries. 많은 노드를 보유한 복잡한 라인 및 폴리곤을 편집하는 작업 시 렌더링이 아주 느려질 수 있습니다. QGIS의 기본 유효성 확인 과정에 시간이 오래 걸릴 수 있기 때문입니다. GEOS 도형 유효성 확인을 (GEOS 3.3 버전부터 사용 가능) 활성화하거나, 도형 유효성 확인 과정을 비활성화해서 렌더링 속도를 높일 수 있습니다. GEOS 도형 유효성 확인은 훨씬 빠르지만, 첫 도형 문제점만 보고한다는 단점이 있습니다.

    선택 집합에 따라 도형 오류에 대한 보고도 달라질 수 있다는 점을 기억하십시오. (오류 메시지의 유형 및 그 의미 참조)

  • Default Z value: 새 3D 피처를 생성할 때 사용할 기본 Z값을 정의합니다.

고무줄

  • 고무줄의 Line width, Line colorFill color 를 정의합니다.

  • Don’t update rubberband during vertex editing: 꼭짓점 편집 시 고무줄을 표시하지 않습니다.

스냅

  • checkbox Enable snapping by default: 프로젝트를 열 때부터 스냅 작업을 활성화합니다.

  • Default snap mode selectString 를 정의합니다. 〈Vertex〉, 〈Vertex and segment〉, 〈Segment〉 가운데 하나를 선택할 수 있습니다.

  • Default snapping tolerance 를 정의합니다. 맵 단위 또는 픽셀 개수로 설정할 수 있습니다.

  • Search radius for vertex edits 을 정의합니다. 맵 단위 또는 픽셀 개수로 설정할 수 있습니다.

  • Display main dialog as (restart required): 고급 스냅 작업 대화창을 〈대화창〉 또는 〈독〉 가운데 어느쪽으로 표시할지 설정합니다.

  • Snapping marker color: 스냅 작업 마커의 색상을 설정합니다.

  • checkbox Show snapping tooltips: 예를 들어 사용자가 스냅하고자 하는 피처의 레이어명을 보여주는 툴팁의 표시 여부를 설정합니다. 여러 피처가 중첩돼 있을 경우 유용합니다.

  • checkbox Enable snapping on invisible features (not shown on the map canvas): 이 설정을 활성화하면 맵 캔버스 상에 표시되지 않는 가시화되지 않은 피처에도 스냅 작업을 할 수 있게 해줍니다.

꼭짓점 마커

  • checkbox Show markers only for selected features: 선택한 피처에만 마커를 표시합니다.

  • 꼭짓점 Marker style selectString 을 정의합니다. 〈Cross〉 (기본값), 〈Semi transparent circle〉 또는 〈None〉 가운데 하나를 선택할 수 있습니다.

  • 꼭짓점 Marker size (in millimeter) 를 밀리미터 단위로 정의합니다.

곡선 오프셋 도구

다음 세 가지 옵션은 고급 디지타이즈 작업offsetCurve Offset Curve 에서 쓰입니다. 다양한 설정을 통해, 라인 오프셋의 형태를 변경할 수 있습니다. GEOS 3.3 버전부터 이 옵션들을 사용할 수 있습니다.

  • Join style 로 〈Round〉, 〈Mitre〉 또는 〈Bevel〉 가운데 하나를 선택할 수 있습니다.

  • Quadrant segments

  • Miter limit

9.1.10. 조판기 설정

../../../_images/options_layouts.png

그림 9.9 QGIS에서 조판기 설정하기

조판 기본값

인쇄 조판기 내부에서 사용되는 Default font 를 정의할 수 있습니다.

그리드 모양

  • Grid style selectString 에서 〈Solid〉, 〈Dots〉, 〈Crosses〉 가운데 하나를 선택합니다.

  • Grid color 를 정의합니다.

그리드 및 가이드 기본값

  • Grid spacing selectNumber 을 정의합니다.

  • Grid offset selectNumber: X축 및 Y축에 대한 그리드 오프셋을 정의합니다.

  • Snap tolerance selectNumber 를 정의합니다.

조판기 경로

  • Path(s) to search for extra print templates: 추가 인쇄 템플릿을 검색할 경로를 정의합니다. 새 인쇄 템플릿 생성 시 사용자 정의 조판 템플릿을 담은 폴더 목록을 사용할 수 있습니다.

9.1.11. GDAL 설정

GDAL 은 벡터 및 래스터 파일 용 데이터 교환 라이브러리입니다. GDAL 라이브러리는 데이터를 서로 다른 포맷들로 읽기 그리고/또는 쓰기 할 수 있는 드라이버들을 제공합니다. 현재의 GDAL 탭은 래스터 포맷 용 드라이버를 그 기능과 함께 보여줍니다.

9.1.11.1. GDAL 드라이버 옵션

이 프레임은 읽기 및 쓰기 권한 접근을 지원하는 드라이버들의 습성을 사용자 지정할 수 있는 방법을 제공합니다:

  • Edit create options: 사용자가 래스터 파일을 산출할 때 사용할 서로 다른 파일 변환 프로파일 ─ 예를 들면 미리 정의된 파라미터들의 조합(압축 유형 및 수준, 블록 크기, 오버뷰, 색채분석(colorimetry), 투명도 등등) ─ 을 편집하거나 추가할 수 있습니다. 정의할 수 있는 파라미터는 드라이버에 따라 달라집니다.

    ../../../_images/gdalCreateOptions.png

    그림 9.10 옵션 프로파일 생성 (GeoTiff 용) 예시

    대화창의 상단 부분은 현재 프로파일 목록을 표시하며, 사용자가 프로파일을 새로 추가하거나 목록에서 제거할 수 있습니다. 사용자가 프로파일의 파라미터를 변경했다면 파라미터의 기본값으로 프로파일을 초기화할 수도 있습니다. GeoTiff 같은 몇몇 드라이버는 사용자가 작업할 수 있는 예시 프로파일을 제공합니다.

    대화창 하단 부분에서는:

    • signPlus 버튼으로 파라미터명과 그 값을 입력해서 행을 추가할 수 있습니다.

    • signMinus 버튼으로 선택한 파라미터를 삭제할 수 있습니다.

    • Validate 버튼을 클릭하면 해당 포맷에 대해 입력한 생성 옵션이 유효한지를 검사합니다.

    • 사용할 파라미터를 찾으려면 Help 버튼을 클릭하거나, GDAL 래스터 드라이버 문서 를 참조하십시오.

  • Edit Pyramids Options

    ../../../_images/gdalPyramidsOptions.png

    그림 9.11 피라미드 프로파일 예시

9.1.11.2. GDAL 드라이버

이 프레임에서는 어떤 파일 포맷을 읽기 그리고/또는 쓰기 위해 사용할 GDAL 드라이버를 정의할 수 있습니다. 몇몇 경우 GDAL 드라이버 하나 이상을 사용할 수 있기 때문입니다.

../../../_images/options_gdal.png

그림 9.12 QGIS에서 GDAL 설정하기

읽기와 쓰기 권한(rw+(v))에 접근할 수 있는 드라이버를 더블클릭하면 드라이버를 사용자 지정할 수 있는 생성 옵션 편집 대화창이 열립니다.

9.1.12. 변수 설정

Variables 탭은 전체 수준에서 쓸 수 있는 모든 변수들의 목록을 표시합니다.

또한 사용자가 전체 수준 변수를 관리할 수도 있습니다. signPlus 버튼을 클릭해서 새 사용자 지정 전체 수준 변수를 추가합니다. 마찬가지로, 목록에서 사용자 지정 전체 수준 변수를 선택한 다음 signMinus 버튼을 클릭해서 제거합니다.

값을 변수로 저장 에서 변수에 대한 더 자세한 정보를 살펴볼 수 있습니다.

../../../_images/options_variables_global.png

그림 9.13 QGIS에서 변수 설정하기

9.1.13. 인증 설정

Authentication 탭에서 인증 환경을 설정하고 PKI 인증서를 관리할 수 있습니다. 더 자세한 내용은 인증 시스템 을 참조하세요.

../../../_images/auth-editor-configs21.png

그림 9.14 QGIS에서 인증 설정하기

9.1.14. 네트워크 설정

일반

  • WMS search address 를 정의합니다. 기본값은 http://geopole.org/wms/search?search=\%1\&type=rss 입니다.

  • Timeout for network requests (ms) 를 정의합니다. 기본값은 60,000입니다.

  • Default expiration period for WMS Capabilities (hours) 를 정의합니다. 기본값은 24입니다.

  • Default expiration period for WMSC/WMTS tiles (hours) 를 정의합니다. 기본값은 24입니다.

  • Max retry in case of tile or feature request errors 를 정의합니다.

  • User-Agent 를 정의합니다.

../../../_images/proxy-settings.png

그림 9.15 QGIS에서 프록시 설정하기

캐시 설정

캐시 용 DirectorySize 를 정의합니다. 또 automatically clear the connection authentication cache on SSL errors (recommended) 옵션은 SLL 오류 시 연결 인증 캐시를 자동으로 삭제하는 도구를 제공합니다.

웹 접근 용 프록시

  • checkbox Use proxy for web access

  • 사용자의 필요에 따라 Proxy type selectString 을 설정하고 〈Host〉 와 〈Port〉 를 정의하십시오. 다음과 같은 프록시 유형을 선택할 수 있습니다:

    • Default Proxy: 시스템의 프록시를 기반으로 프록시를 결정합니다.

    • Socks5Proxy: 모든 종류의 연결에 쓸 수 있는 일반 프록시입니다. TCP, UDP, 지정 포트(들어오는 연결) 그리고 인증을 지원합니다.

    • HttpProxy: 《CONNECT》 명령어로 시행되며, 나가는 TCP 연결만 지원하고, 인증을 지원합니다.

    • HttpCachingProxy: 통상적인 HTTP 명령어로 시행되며, HTTP 요청이라는 맥락 안에서만 유용합니다.

    • FtpCachingProxy: FTP 프록시를 이용해서 시행되며, FTP 요청이라는 맥락 안에서만 유용합니다.

프록시의 인증 정보(credential)는 인증 위젯 을 사용해서 설정합니다.

프록시 설정 아래에 있는 텍스트 상자에 제외시킬 URL을 추가할 수 있습니다. (QGIS에서 프록시 설정하기 그림 참조) 목표 URL이 텍스트 상자 목록에 있는 문자열 가운데 하나로 시작된다면 어떤 프록시도 사용하지 않을 것입니다.

서로 다른 프록시 설정들에 대한 자세한 정보가 필요한 경우, https://doc.qt.io/qt-5.9/qnetworkproxy.html#ProxyType-enum 에 있는 기저 Qt 라이브러리 문서를 참조하십시오.

프록시 사용

프록시 사용은 때로 까다로울 수 있습니다. 앞에서 설명한 프록시 유형들을 〈시행착오〉 를 거쳐 가며 사용자의 환경에서 어떤 유형이 작동하는지 확인하는 편이 좋습니다.

9.1.15. 위치 탐색 설정

search The Locator 탭에서 위치 탐색란 의 환경을 설정할 수 있습니다. 위치 탐색란이란 상태 바에서 사용할 수 있는 빠른 검색 위젯으로, 응용 프로그램 내 어디에서든 검색 작업을 수행할 수 있도록 해줍니다. 다음과 같은 (접두어를 가진) 기본 필터를 제공합니다:

  • 프로젝트 레이어 (l): Layers 패널에 있는 레이어를 찾아서 선택합니다.

  • 프로젝트 조판기 (pl): 인쇄 조판을 찾아서 엽니다.

  • 액션 (.): QGIS 액션을 찾아서 실행합니다. 액션이란 QGIS에 있는 어떤 도구나 메뉴도 될 수 있고, 패널을 열 수도 있고, …

  • 활성 레이어 피처 (f): 현재 활성화된 레이어의 어느 항목에서건 일치하는 속성을 검색해서 선택된 피처로 확대/축소합니다.

  • 모든 레이어의 피처 (af): 각 검색 가능한 레이어표시 명칭 에서 일치하는 속성을 검색해서 선택된 피처로 확대/축소합니다.

  • 계산기 (=): 모든 QGIS 표현식을 검증할 수 있고, 표현식이 유효한 경우 결과물을 클립보드로 복사할 수 있습니다.

  • 공간 북마크 (b): 북마크를 찾아서 북마크의 범위로 확대/축소합니다.

  • 설정 (set): 프로젝트를 탐색해서 연 다음, 응용 프로그램 수준의 속성 대화창을 엽니다.

  • 공간 처리 (a): 공간 처리 알고리즘을 검색해서 공간 처리 알고리즘 대화창을 엽니다.

  • 선택한 피처 편집 (ef): 빠른 접근을 허용해서 활성 레이어에 호환되는 제자리 수정 공간 처리 알고리즘을 실행합니다.

사용자는 각 필터를 사용자 지정할 수 있으며, 기본적으로 활성화시킬지 여부를 설정할 수 있고, 플러그인으로 기본 위치 탐색 필터 모음을 확장시킬 수 있습니다. 예를 들어 OSM Nominatim 검색, 데이터베이스 직접 검색, 레이어 카탈로그 검색 플러그인을 사용할 수 있습니다.

Ctrl+K 단축키를 누르면 위치 탐색란을 활성화시킬 수 있습니다. 텍스트를 입력해서 검색을 수행해보십시오. 기본적으로 활성화된 모든 위치 탐색 필터에 대해 검색 결과를 반환하지만, 사용자의 텍스트 앞에 위치 탐색 필터 접두어를 입력하면 특정 필터로 검색을 제한할 수 있습니다. 예를 들어 l cad 라고 입력하면 레이어명에 cad 가 들어간 레이어만 반환할 것입니다. 검색 결과를 클릭하면 항목의 유형에 따라 대응하는 액션을 실행합니다.

검색은 스레드를 통해 처리되기 때문에 어떤 느린 검색 필터를 설치했어도 그에 상관없이 가장 빠른 속도로 검색 결과를 반환합니다. 또 각각의 필터에 걸리자마자 각각의 결과값을 반환하기 때문에, 예를 들면 파일 검색 필터는 파일 트리를 스캔하는 과정에서 검색 결과를 하나씩 표시하게 됩니다. 즉 아주 느린 (예를 들어 온라인 서비스를 사용하는) 검색 필터인 경우에도 사용자 인터페이스가 멈추는 일은 없을 것입니다.

위치 탐색 환경 설정에 빠르게 접근하기

상태 바에 있는 위치 탐색 위젯의 search 아이콘을 클릭하면 사용할 수 있는 필터 목록을 표시하는데, 이 목록에서 Configure 항목을 클릭하면 Settings ‣ Options… 메뉴의 Locator 탭을 엽니다.

../../../_images/options_locator.png

그림 9.16 QGIS에서 위치 탐색 설정하기

9.1.16. 고급 설정

../../../_images/options_advanced.png

그림 9.17 QGIS의 고급 설정 탭

QGIS와 관련된 모든 설정은 (UI, 도구, 데이터 제공자, 공간 처리 환경 설정, 기본값 및 기본 경로, 플러그인 옵션, 표현식, 도형 검사 등등) 활성화된 사용자 프로파일 디렉터리 아래 QGIS/QGIS3.ini 파일로 저장됩니다. 이 파일을 다른 설치본으로 복사하면 환경 설정을 공유할 수 있습니다.

QGIS 내에서라면, Advanced 탭은 Advanced Settings Editor 를 통해 이런 설정들을 관리할 수 있는 방법을 제공합니다. 사용자가 조심하겠다는 확인을 하고 나면, 해당 위젯은 존재하는 모든 설정들의 트리로 채워지고 그 값을 편집할 수 있게 됩니다. 어떤 설정이나 그룹을 오른쪽 클릭하면 해당 항목을 삭제할 수 있습니다. (설정 또는 그룹을 추가하려면, QGIS3.ini 파일을 편집해야 합니다.) 변경 사항은 QGIS3.ini 파일에 자동적으로 저장됩니다.

경고

고급 설정 탭을 무턱대고 이용하지 말 것

이 대화창에서 항목을 수정할 때 조심해야 합니다. 변경 사항이 자동적으로 적용되기 때문입니다. 자세한 내용을 모른 채 설정을 수정하면 사용자의 QGIS 설치본이 여러 방식으로 고장날 수 있습니다.

9.1.17. 가속 설정

OpenCL 가속을 설정합니다.

../../../_images/acceleration_menu.png

그림 9.18 가속 탭

Depending on your hardware and software, you may have to install additional libraries to enable OpenCL acceleration.

9.1.18. 공간 처리 설정

processing Processing 탭은 QGIS 공간 처리 프레임워크가 사용하는 도구와 데이터 제공자의 일반 설정을 제공합니다. 자세한 내용은 QGIS 공간 처리 프레임워크 를 참조하세요.

../../../_images/options_processing.png

그림 9.19 QGIS의 공간 처리 설정 탭

9.2. 사용자 프로파일 작업

Settings ‣ User Profiles 메뉴는 사용자 프로파일을 설정하고 프로파일에 접근하는 기능을 제공합니다. 사용자 프로파일이란 통합 응용 프로그램 환경 설정으로, 단일 폴더 안에 저장할 수 있습니다:

QGIS 설치본은 기본적으로 default 라는 단일 사용자 프로파일을 담고 있습니다. 하지만 사용자가 원하는만큼 많은 사용자 프로파일을 생성할 수 있습니다:

  1. New profile… 항목을 클릭하십시오.

  2. 프로파일 명칭을 입력해야 하는데, 명칭을 입력하면 ~/<UserProfiles>/ 아래 동일 명칭의 폴더를 생성합니다. 이때:

    • ~HOME 디렉터리를 나타냅니다. win 윈도우에서는 보통 C:\Users\(user) 같은 디렉터리입니다.

    • <UserProfiles> 는 주 프로파일 폴더를 나타냅니다. 예를 들면:

      • nix .local/share/QGIS/QGIS3/profiles/

      • win AppData\Roaming\QGIS\QGIS3\profiles\

      • osx Library/Application Support/QGIS/QGIS3/profiles/

    Open Active Profile Folder 메뉴를 클릭하면 QGIS에서 사용자 프로파일 폴더를 열 수 있습니다.

  3. 새 QGIS 인스턴스를 시작하면, 초기화된 환경 설정을 사용합니다. 그러면 환경을 사용자 지정 설정할 수 있습니다.

사용자의 QGIS 설치본이 프로파일을 하나 이상 가지고 있을 경우, 활성화된 프로파일의 이름이 응용 프로그램 제목 막대에 대괄호로 감싸여 표시됩니다.

각 사용자 프로파일이 독립된 설정, 플러그인, 이력을 담고 있으므로, 서로 다른 워크플로나 데모, 동일 머신의 서로 다른 사용자들, 또는 테스트용 설정 등에 매우 유용할 수 있습니다. Settings ‣ User Profiles 메뉴에서 프로파일을 선택하면 한 프로파일에서 다른 프로파일로 전환할 수 있습니다. 또 명령 줄 에서 특정 사용자 프로파일로 QGIS를 실행할 수도 있습니다.

일부러 변경하지 않는 한, 마지막으로 닫은 QGIS 세션의 사용자 프로파일을 다음 QGIS 세션에서 사용할 것입니다.

버그 지속성 검사를 위해 새 사용자 프로파일로 QGIS 실행하기

QGIS의 어떤 기능에서 이상한 습성을 발견한 경우, 새 사용자 프로파일을 생성한 다음 해당 명령을 다시 실행해보십시오. 버그는 때때로 현재 사용자 프로파일에 있는 어떤 잔존물 때문에 발생하기도 합니다. 사용자 프로파일을 새로 생성하면 새 (초기화된) 프로파일로 QGIS를 재시작하기 때문에 버그가 사라지는 경우도 있습니다.

9.3. 프로젝트 속성

Project ‣ Project Properties 메뉴를 클릭하면 열리는 프로젝트 용 속성 창에서 프로젝트에 특화된 옵션들을 설정할 수 있습니다. 이 프로젝트 특화 옵션은 위에서 설명하는 Options 대화창의 대응하는 옵션을 덮어씁니다(무시하고 재설정합니다).

9.3.1. 일반 속성

General 탭에 있는 General settings 부분에서:

  • 프로젝트 파일의 위치를 볼 수 있고

  • 프로젝트 홈 용 폴더를 (탐색기에 있는 Project Home 항목에서) 설정할 수 있습니다. 프로젝트 파일이 있는 폴더에 대한 상대 경로일 수도 있고 (직접 입력) 또는 절대 경로일 수도 있습니다. 프로젝트 홈은 프로젝트에 유용한 데이터와 기타 콘텐츠를 저장하는 데 쓰일 수 있습니다.

  • 프로젝트 파일 경로 옆에 프로젝트 제목을 부여할 수 있고

  • 피처 선택 시 피처에 적용할 색상을 선택할 수 있고

  • 맵 캔버스에 적용할 배경색을 선택할 수 있으며

  • 프로젝트 내부의 레이어를 가리키는 경로를 절대 경로(전체 경로)로 저장할지 프로젝트 파일 위치에 상대적인 상대 경로로 저장할지 설정할 수 있습니다. 레이어 및 프로젝트 파일이 이동 또는 공유될 가능성이 있거나, 다른 플랫폼을 이용하는 컴퓨터에서 프로젝트에 접근하는 경우, 상대 경로가 더 적합할 수도 있습니다.

  • 프로젝트를 맵 타일로 렌더링할 때 오류(artifact)를 회피하도록 선택할 수 있습니다. 이 옵션을 체크하면 성능이 저하될 수도 있다는 점을 주의하십시오.

면적 및 거리 계산은 GIS에서 흔히 필요로 하는 작업입니다. 하지만, 이 값들은 기저 투영체 설정과 떼려야 뗄 수 없는 관계입니다. Measurements 프레임에서 다음과 같은 파라미터들을 선택하고 조정할 수 있습니다:

  • Ellipsoid: 거리 및 면적 계산이 완전히 의존하는 타원체입니다. 다음 가운데 하나를 선택할 수 있습니다:

    • None/Planimetric: 이 타원체를 선택하면 데카르트 도량법으로 된 값을 반환합니다.

    • Custom: 이 타원체를 선택하면 긴반지름(semi-major)과 짧은반지름(semi-minor)의 값을 설정해야 합니다.

    • 또는 미리 정의된 목록에서 기존 타원체 가운데 하나를 선택할 수도 있습니다. (Clarke 1866, Clarke 1880 IGN, New International 1967, WGS 84, …)

  • 길이 및 둘레에 대한 units for distance measurements 및 면적에 대한 units for area measurements 를 설정하면 현재 프로젝트에서 QGIS 옵션에 설정된 기본 단위를 무시하게 만들며, 다음에 쓰입니다:

    • 속성 테이블 필드 업데이트 바

    • 필드 계산기 계산

    • 식별 도구에서 파생되는 길이, 둘레 및 면적 값

    • 측정 대화창에 표시되는 기본 단위

Coordinate display 에서 상태 바에 표시되는 마우스 좌표 및 식별 도구에 표시되는 파생 좌표에 쓰이는 단위의 유형을 선택하고 사용자 지정할 수 있습니다.

마지막으로, 전체 수준에서 사전 정의된 축척을 무시하는 Project predefined scales 목록을 설정할 수 있습니다.

../../../_images/project_general.png

그림 9.20 프로젝트 속성 대화창의 일반 탭

9.3.2. 메타데이터 속성

Metadata 탭에서 다음과 같은 자세한 메타데이터를 (이외에도 있지만) 정의할 수 있습니다: 작성자(author), 생성일, 언어, 개요(abstract), 카테고리, 키워드, 연락처 정보, 링크, 이력. 특정 항목이 입력됐는지 확인하는 유효성 확인 기능도 있지만, 강제 사항은 아닙니다. 더 자세한 내용은 벡터 레이어 메타데이터 속성 을 참조하세요.

9.3.3. 좌표계 속성

참고

QGIS가 어떻게 프로젝트 투영체를 처리하는지 더 자세히 알고 싶다면, 투영 작업 에서 심도 있게 다루고 있습니다.

crs CRS 탭에서 현재 프로젝트에 사용할 좌표계를 설정할 수 있습니다. 다음 가운데 하나를 선택할 수 있습니다:

  • checkbox No projection (or unknown/non-Earth projection): 레이어의 가공되지 않은(raw) 좌표를 기반으로 레이어를 렌더링합니다.

  • 또는 기존 좌표계에서 지리(geographic), 투영(projected) 이나 사용자 정의(user-defined) 좌표계 가운데 하나를 선택할 수도 있습니다. 프로젝트에 추가한 레이어를, 원래 좌표계와 상관없이 중첩시키기 위해, 선택한 좌표계로 실시간(on-the-fly) 재투영합니다.

crs CRS 탭에서는 현재 프로젝트에 적용할 데이터 변환 선호도의 환경을 설정해서 레이어 재투영 설정을 조정할 수도 있습니다. 이런 설정들은 마찬가지로 대응하는 전체 수준 설정을 무시합니다. 자세한 내용은 데이터 변환 을 참조하세요.

9.3.4. 기본 스타일 속성

Default Styles 탭에서 기존에 정의된 .qml 스타일이 없는 새 레이어를 어떻게 렌더링할지 제어할 수 있습니다. 다음과 같은 작업을 할 수 있습니다:

  • 레이어 도형 유형은 물론 기본 Color Ramp 에 따라 적용할 기본 심볼(Marker, Line, Fill)을 설정할 수 있습니다.

  • Opacity: 새 레이어에 적용할 기본 투명도를 설정할 수 있습니다.

  • checkbox Assign random colors to symbols: 심볼에 랜덤한 채우기 색상을 할당해서, 모든 레이어가 동일하게 렌더링되는 결과를 피할 수 있습니다.

../../../_images/project_default_styles.png

그림 9.21 기본 스타일 탭

styleManager Style Manager 버튼을 클릭하면 스타일 관리자 대화창에 바로 접근해서 심볼 및 색상표의 환경을 설정할 수 있습니다.

실행 중인 프로젝트에 대해 특정 색상들을 정의할 수 있는 추가 옵션도 있습니다. 예를 들어 전체 수준 색상 이라면, 다음과 같은 작업을 할 수 있습니다:

  • signPlus Add 또는 signMinus Remove: 색상을 추가하거나 삭제합니다.

  • editCopy Copy 또는 editPaste Paste: 색상을 복사하거나 붙여넣습니다.

  • fileOpen Import 또는 fileSave Export: 색상 모음을 .gpl 파일로부터 가져오거나, .gpl 파일로 내보냅니다.

목록에 있는 색상을 더블클릭하면 색상 선택기 대화창의 해당 색상을 조정하거나 대체할 수 있습니다. Label 열을 더블클릭하면 해당 색상의 명칭을 변경할 수도 있습니다.

이 색상들은 Project colors 로 식별되어, 색상 위젯 의 한 부분으로 목록화됩니다.

색상 위젯에 바로 적용하고 업데이트할 수 있는 프로젝트 색상 이용하기

프로젝트 색상의 라벨을 이용해서 프로젝트 색상을 참조할 수 있는데, 프로젝트 색상을 사용하는 색상 위젯은 프로젝트 색상과 묶이게 됩니다. 즉 수많은 속성에 대해 동일한 색상을 반복 설정하면서 느리고 긴 업데이트 과정을 겪는 대신, 다음과 같은 작업을 할 수 있다는 뜻입니다:

  1. 어떤 색상을 프로젝트 색상으로 정의하려면

  2. 사용자가 설정하고자 하는 색상 속성 옆에 있는 데이터 정의 무시 위젯 을 클릭한 다음

  3. Color 메뉴에 마우스를 가져가서 프로젝트 색상을 선택합니다. 그러면 속성이 표현식 project_color('color_label') 에 할당되어 색상 위젯이 해당 색상을 반영합니다.

  4. 필요한만큼 두 번째와 세 번째 단계를 반복합니다.

  5. 프로젝트 색상을 한 번 업데이트해주면, 프로젝트 색상이 사용되는 모든 곳에 변경 사항을 반영할 것입니다.

9.3.5. 데이터소스 속성

Data Sources 탭에서 다음 설정을 할 수 있습니다:

  • unchecked Automatically create transaction groups where possible: 이 모드를 활성화한 경우, 동일 데이터베이스로부터 나온 모든 (PostgreSQL) 레이어의 편집 상태를 동기화합니다. 예를 들어, 레이어 하나를 편집 상태로 만들면 모든 레이어가 편집 상태로 바뀝니다. 레이어 하나를 커밋하거나 롤백하면, 다른 레이어들도 그렇게 됩니다. 또한 편집 변경 사항을 로컬에서 버퍼링하는 대신, 사용자가 레이어 저장을 클릭할 때 커밋되는 데이터베이스의 트랜잭션(transaction)으로 직접 전송합니다. 프로젝트에 있는 어떤 레이어도 편집 중이 아닐 경우에만 이 옵션을 (비)활성화할 수 있다는 것을 기억하십시오.

  • unchecked Evaluate default values on provider side: PostgreSQL 테이블에 새 피처를 추가할 때, 기본값 제약조건을 가진 필드를 평가한 다음 커밋할 때가 아니라 양식을 열 때 표시합니다. 즉 Add Feature 양식에 있는 필드가 nextval('serial') 같은 표현식 대신 기대한 값을 (예를 들어 25 를) 표시할 것이라는 뜻입니다.

  • unchecked Trust project when data source has no metadata: 데이터 검사를 하지 않고 프로젝트를 불러오는 속도를 높이려면 이 옵션을 활성화하십시오. QGIS 서버 환경 또는 대용량 데이터베이스 뷰/구체화 뷰(materialized view)를 가진 프로젝트에서 유용한 옵션입니다. 레이어 범위를 (데이터소스 대신) QGIS 프로젝트 파일에서 읽어올 것입니다. 또 PostgreSQL 제공자를 사용하는 경우, 뷰 및 구체화 뷰에 대해 기본 키(primary key)의 단일성(unicity)을 검사하지 않을 것입니다.

  • Layers Capabilities 를 다음과 같이 환경 설정할 수 있습니다:

    • 어떤 레이어가 identifiable 한지, 즉 식별 도구 에 반응할지 설정합니다. 기본적으로 모든 레이어는 쿼리 가능하도록 설정돼 있습니다.

    • 어떤 레이어가 read-only 로 나타나야 하는지, 즉 데이터소스 제공자의 성능에 상관없이 사용자가 편집할 수 없는지를 설정합니다. 낮은 수준의 보호 정책이기는 해도, 파일 기반 레이어를 작업하는 경우 최종 사용자가 데이터를 수정하는 일을 막을 수 있는 간편한 환경 설정인 것은 틀림없습니다.

    • 어떤 레이어가 searchable 한지, 즉 위치 탐색 위젯 을 통해 쿼리할 수 있을지 설정합니다. 기본적으로 모든 레이어는 검색 가능하도록 설정돼 있습니다.

    • 어떤 레이어가 required 상태로 정의돼 있는지 설정합니다. 목록에서 체크된 레이어들은 프로젝트에서 우연히 제거되는 일이 없도록 보호됩니다.

    Layers Capabilities 테이블은 다음과 같은 작업을 할 수 있는 편리한 도구를 제공합니다:

    • 셀을 여러 개 선택한 다음 Toggle Selection 을 클릭하면 한꺼번에 체크박스의 체크 상태를 바꿀 수 있습니다.

    • unchecked Show spatial layers only: 레이어 목록에서 비공간 레이어를 필터링해서 빼버립니다.

    • search Filter layers…: 환경 설정할 특정 레이어를 빨리 찾을 수 있습니다.

../../../_images/project_datasources.png

그림 9.22 데이터소스 탭

9.3.6. 관계 속성

Relations 탭은 일대다(1:n) 관계를 정의하는 데 쓰입니다. 프로젝트 속성 대화창에서 이 관계를 정의합니다. 어떤 레이어에 관계가 존재하는 경우, 양식 뷰에 있는 새 사용자 인터페이스 요소가 (예를 들어 피처를 식별하고 그 양식을 열 때) 관련 요소들의 목록을 표시할 것입니다. 이렇게 되면, 예를 들어 어떤 파이프라인 또는 도로 구간의 점검 이력을 보여줄 수 있는 강력한 방법이 생기는 겁니다. 일대다 또는 다대다 관계 생성 에서 일대다 관계에 대한 더 자세한 내용을 찾아볼 수 있습니다.

../../../_images/project_relations.png

그림 9.23 관계 탭

9.3.7. 변수 속성

Variables 탭은 (모든 전체 수준 변수를 포함하는) 프로젝트 수준에서 사용할 수 있는 모든 변수 목록을 표시합니다. 게다가, 사용자가 프로젝트 수준 변수를 관리할 수도 있습니다. signPlus 버튼을 클릭해서 새 사용자 지정 프로젝트 수준 변수를 추가합니다. 마찬가지로, 목록에서 사용자 지정 프로젝트 수준 변수를 선택한 다음 signMinus 버튼을 클릭해서 제거합니다. 일반 도구 장의 값을 변수로 저장 절에서 변수 사용법에 대한 자세한 정보를 살펴볼 수 있습니다.

9.3.8. 매크로 속성

Macros 탭은 프로젝트를 위한 파이썬 매크로를 편집하는 데 쓰입니다. 현재, openProject(), saveProject() 그리고 closeProject() 세 가지 매크로만 사용할 수 있습니다.

../../../_images/macro.png

그림 9.24 QGIS의 매크로 설정

9.3.9. QGIS 서버 속성

QGIS Server 탭은 사용자 프로젝트를 온라인 상에 퍼블리싱하기 위해 환경 설정할 수 있습니다. 이 탭에서 QGIS 서버의 WMS 및 WFS 성능, 범위, 그리고 좌표계 제약 조건에 관한 정보를 정의할 수 있습니다. 사용자 프로젝트 환경 설정하기 와 이어지는 부분에서 더 자세한 내용을 다루고 있습니다.

../../../_images/project_qgisserver.png

그림 9.25 QGIS 서버 설정 탭

9.4. 사용자 지정

사용자 지정 작업 대화창을 통해 QGIS 사용자 인터페이스의 거의 모든 요소를 (비)활성화할 수 있습니다. 최종 사용자가 필요로 하는 아이콘, 메뉴 또는 패널만 있는 〈가벼운〉 QGIS 버전을 제공하고자 할 때 매우 유용합니다.

참고

사용자 변경 사항을 적용하려면 QGIS를 재시작해야 합니다.

../../../_images/customization.png

그림 9.26 사용자 지정 작업 대화창

checkbox Enable customization 체크박스를 체크하는 일이 QGIS 사용자 지정 작업의 첫 번째 단계입니다. 툴바 및 위젯 패널을 활성화하는데, 이 패널에서 몇몇 GUI 항목을 체크 해제해서 쓸 수 없게 만들 수 있습니다.

환경을 설정할 수 있는 항목은 다음과 같습니다:

  • 메뉴 또는 메뉴 바 에 있는 몇몇 하위 메뉴

  • 패널 전체 (패널 및 툴바 참조)

  • 상태 바 에서 설명한 상태 바 또는 상태 바의 몇몇 항목들

  • 툴바 전체 또는 툴바의 일부 아이콘들

  • 라벨, 버튼, 콤보박스 등 QGIS의 모든 대화창의 모든 위젯

select Switch to catching widgets in main application 을 사용해서 QGIS 인터페이스에서 사용자가 숨기고 싶은 항목을 클릭할 수 있습니다. 그러면 QGIS 가 사용자 지정 작업 대화창에서 대응 항목을 자동적으로 체크 해제할 것입니다. Search 란에 항목의 명칭이나 라벨을 입력해서 항목을 찾을 수도 있습니다.

사용자 환경 설정을 마친 다음, 사용자가 변경한 사항을 확인하려면 Apply 또는 OK 를 클릭하십시오. 다음번에 QGIS를 시작할 때 이 환경 설정을 기본값으로 이용할 것입니다.

fileSave Save To File 버튼을 클릭하면 변경 사항들을 .ini 파일로도 저장할 수 있습니다. 사용자 여러 명이 QGIS 인터페이스를 공유할 수 있는 간편한 방법입니다. 다른 컴퓨터에서 이 .ini 파일을 불러오려면 fileOpen Load from File 만 클릭하면 됩니다. 또 명령어 도구 를 실행해서 서로 다른 사용 목적을 위한 다양한 설정을 저장할 수도 있습니다.

사전 정의된 QGIS를 손쉽게 복구

다음 방법들 가운데 하나를 통해 초기 QGIS GUI 환경 설정을 복구할 수 있습니다:

  • 사용자 지정 작업 대화창에서 checkbox Enable customization 을 체크 해제하거나 selectAllTree Check All 버튼을 클릭합니다.

  • Settings ‣ Options 메뉴의 System 탭의 QSettings 프레임에 있는 Reset 버튼을 클릭합니다.

  • 명령 프롬프트에서 QGIS를 다음 명령어 qgis --nocustomization 로 실행합니다.

  • Settings ‣ Options 메뉴의 Advanced 탭에 있는 UI ‣ Customization ‣ Enabled 변수의 값을 false 로 설정합니다. (경고 참조)

대부분의 경우, 이 변경 사항을 적용하려면 QGIS를 재시작해야 합니다.

9.5. 키보드 단축키

QGIS는 많은 기능에 대해 기본 키보드 단축키를 제공합니다. 메뉴 바 에서 기본 단축키를 찾아볼 수 있습니다. 또한 Settings ‣ keyboardShortcuts Keyboard Shortcuts… 메뉴 옵션에서 기본 키보드 단축키를 변경하고 QGIS 기능에 새 키보드 단축키를 추가할 수도 있습니다.

../../../_images/shortcuts.png

그림 9.27 단축키 옵션 정의

설정 방법은 아주 간단합니다. 대화창 상단에 있는 검색란을 통해 특정 기능을 찾은 다음 목록에서 기능을 선택하고 다음을 클릭하십시오:

  • Change 를 클릭하고 새 단축키로 할당할 키 조합을 입력하십시오.

  • 할당된 단축키를 삭제하려면 Set None 을 클릭하십시오.

  • 또는 단축키를 원래 기본값으로 되돌리려면 Set default 를 클릭하십시오.

사용자가 지정하려는 다른 모든 도구에 대해서도 이와 같이 진행하십시오. 사용자 환경 설정을 마치고 나서, 대화창의 Close 버튼을 누르기만 하면 변경 사항이 적용됩니다. 또 Save 버튼을 눌러 변경 사항을 .XML 파일로 저장한 다음 또다른 QGIS 설치본에서 Load 버튼을 눌러 불러올 수도 있습니다.

9.6. 고급 설정으로 QGIS 실행

9.6.1. 명령 줄과 환경 변수

사용자의 OS 상에서 다른 응용 프로그램과 마찬가지로 QGIS를 실행 해보았습니다. QGIS는 좀 더 고급의 사용 환경 설정을 위한 명령 줄 옵션을 제공합니다. (몇몇 경우 명령 줄 옵션 대신 환경 변수를 사용할 수도 있습니다.) 옵션 목록을 보려면 명령 줄에 qgis --help 라고 입력하십시오. 다음 목록을 반환합니다:

QGIS is a user friendly Open Source Geographic Information System.
Usage: /usr/bin/qgis.bin [OPTION] [FILE]
  OPTION:
        [--version]     display version information and exit
        [--snapshot filename]   emit snapshot of loaded datasets to given file
        [--width width] width of snapshot to emit
        [--height height]       height of snapshot to emit
        [--lang language]       use language for interface text (changes existing override)
        [--project projectfile] load the given QGIS project
        [--extent xmin,ymin,xmax,ymax]  set initial map extent
        [--nologo]      hide splash screen
        [--noversioncheck]      don't check for new version of QGIS at startup
        [--noplugins]   don't restore plugins on startup
        [--nocustomization]     don't apply GUI customization
        [--customizationfile path]      use the given ini file as GUI customization
        [--globalsettingsfile path]     use the given ini file as Global Settings (defaults)
        [--authdbdirectory path] use the given directory for authentication database
        [--code path]   run the given python file on load
        [--defaultui]   start by resetting user ui settings to default
        [--hide-browser]        hide the browser widget
        [--dxf-export filename.dxf]     emit dxf output of loaded datasets to given file
        [--dxf-extent xmin,ymin,xmax,ymax]      set extent to export to dxf
        [--dxf-symbology-mode none|symbollayer|feature] symbology mode for dxf output
        [--dxf-scale-denom scale]       scale for dxf output
        [--dxf-encoding encoding]       encoding to use for dxf output
        [--dxf-map-theme maptheme]      map theme to use for dxf output
        [--take-screenshots output_path]        take screen shots for the user documentation
        [--screenshots-categories categories]   specify the categories of screenshot to be used (see QgsAppScreenShots::Categories).
        [--profile name]        load a named profile from the user's profiles folder.
        [--profiles-path path]  path to store user profile folders. Will create profiles inside a {path}\profiles folder
        [--version-migration]   force the settings migration from older version if found
        [--openclprogramfolder]         path to the folder containing the sources for OpenCL programs.
        [--help]                this text
        [--]            treat all following arguments as FILEs

  FILE:
    Files specified on the command line can include rasters,
    vectors, and QGIS project files (.qgs and .qgz):
     1. Rasters - supported formats include GeoTiff, DEM
        and others supported by GDAL
     2. Vectors - supported formats include ESRI Shapefiles
        and others supported by OGR and PostgreSQL layers using
        the PostGIS extension

명령 줄 인자 사용 예시

명령 줄에서 하나 이상의 데이터 파일을 지정해서 QGIS를 실행할 수 있습니다. 예를 들어 지금 qgis_sample_data 디렉터리에 있다면, 다음 명령어를 사용해서 QGIS 실행 시 벡터 레이어와 래스터 파일을 불러오도록 할 수 있습니다: qgis ./raster/landcover.img ./gml/lakes.gml

9.6.1.1. --version

이 옵션은 QGIS 버전 정보를 반환합니다.

9.6.1.2. --snapshot

이 옵션은 현재 뷰의 스냅샷을 PNG 포맷으로 생성할 수 있게 해줍니다. 사용자가 수많은 프로젝트를 가지고 있어서 사용자 데이터로부터 스냅샷을 생성하고자 하거나, 동일 프로젝트에서 데이터가 업데이트되어 스냅샷을 생성해야 할 때 유용합니다.

현재 이 옵션은 800x600 픽셀 해상도의 PNG 파일을 생성합니다. 이 크기는 --width--height 인자를 사용해 조정할 수 있습니다. 또 --snapshot 인자 뒤에 파일명을 추가할 수도 있습니다. 다음은 그 예시입니다:

qgis --snapshot my_image.png --width 1000 --height 600 --project my_project.qgs

9.6.1.3. --width

이 옵션은 생성될 스냅샷의 너비를 반환합니다. (--snapshot 과 함께 사용)

9.6.1.4. --height

이 옵션은 생성될 스냅샷의 높이를 반환합니다. (--snapshot 과 함께 사용)

9.6.1.5. --lang

QGIS는 사용자 로케일을 기반으로 정확한 현지화 언어를 선택합니다. 만약 사용자 언어를 변경하고자 한다면, 언어 코드를 지정할 수 있습니다. 예를 들어, qgis --lang it 명령어는 QGIS를 이탈리아 현지화 설정으로 실행할 것입니다.

9.6.1.6. --project

QGIS를 기존 프로젝트 파일과 함께 실행할 수도 있습니다. 명령 줄 옵션 --project 뒤에 사용자의 프로젝트 명칭만 추가하면 불러온 프로젝트에 있는 모든 레이어와 함께 QGIS를 실행할 것입니다.

9.6.1.7. --extent

QGIS를 특정한 맵 범위로 실행하려면 이 옵션을 사용하십시오. 사용자가 지정한 범위 상자를 쉼표로 구분된 다음 순서로 추가해야 합니다:

--extent xmin,ymin,xmax,ymax

이 옵션은 특정 프로젝트를 원하는 범위로 열기 위해 --project 옵션과 함께 사용해야 의미가 있을 수도 있습니다.

9.6.1.9. --noversioncheck

QGIS 실행 시 새 버전을 검색하지 않습니다.

9.6.1.10. --noplugins

실행 시 플러그인 관련 오류가 생기는 경우, 이 옵션을 사용하면 플러그인을 불러오지 않습니다. 실행 후 플러그인 관리자에서 플러그인을 불러올 수 있습니다.

9.6.1.11. --nocustomization

이 옵션을 사용하면, 실행 시 모든 기존 사용자 지정 GUI 를 무시할 것입니다. 즉 사용자가 숨겼던 모든 버튼, 메뉴 항목, 툴바 등등이 QGIS 실행 시 나타날 것입니다. 이 변경 사항은 자동적으로 저장되지 않습니다. QGIS를 이 옵션 없이 다시 시작하면, 사용자 지정 GUI가 다시 적용될 것입니다.

이 옵션은 사용자가 제거했던 도구들에 일시적으로 접근하고자 할 때 유용합니다.

9.6.1.12. --customizationfile

이 옵션을 사용하면, 사용자가 사용자 지정 UI 파일을 지정해서 QGIS 실행 시 사용할 수 있습니다.

9.6.1.13. --globalsettingsfile

이 옵션을 사용하면 기본 설정이라고도 하는 전체 수준 설정 파일(.ini)을 가리키는 경로를 지정할 수 있습니다. 지정한 파일에 있는 설정이 원래 기본 설정을 대체하지만, 사용자 프로파일의 설정이 최우선 순위를 가질 것입니다. 기본 전체 수준 설정의 위치는 your_QGIS_PKG_path/resources/qgis_global_settings.ini 파일입니다.

현재로서는 설정을 기록할 파일을 지정할 방법이 없습니다. 따라서 원래 설정 파일을 복사해서, 재명명한 다음, 수정하는 방법을 쓸 수 있습니다.

qgis_global_setting.ini 파일의 경로를 네트워크 공유 폴더로 설정하면, 시스템 관리자가 파일 하나를 편집해서 여러 시스템의 전체 수준 설정 및 기본값을 변경할 수 있습니다.

이에 대응하는 환경 변수는 QGIS_GLOBAL_SETTINGS_FILE 입니다.

9.6.1.14. --authdbdirectory

이 옵션은 --globalsettingsfile 과 비슷하지만, 인증 데이터베이스를 저장하고 불러올 디렉터리를 가리키는 경로를 정의합니다.

9.6.1.15. --code

이 옵션을 사용하면 QGIS를 실행한 직후 지정한 파이썬 파일을 실행할 수 있습니다.

예를 들어, 다음과 같은 내용의 load_alaska.py 라는 파이썬 파일을 가지고 있을 때:

from qgis.utils import iface
raster_file = "/home/gisadmin/Documents/qgis_sample_data/raster/landcover.img"
layer_name = "Alaska"
iface.addRasterLayer(raster_file, layer_name)

사용자의 현재 위치가 load_alaska.py 파일이 있는 디렉터리라고 가정하면, 다음 명령어를 사용해서 QGIS를 실행한 다음 래스터 파일 landcover.img 를 불러와서 해당 레이어를 〈Alaska〉 로 명명할 수 있습니다:

qgis --code load_alaska.py

9.6.1.16. --defaultui

QGIS를 이 옵션으로 실행하면, UI를 기본 설정으로 항구적으로 재설정 합니다. 이 옵션은 패널 및 툴바의 가시성, 위치 및 크기를 복구할 것입니다. UI 설정을 다시 변경하지 않는 이상, 다음 세션에서도 기본 UI 설정을 사용할 것입니다.

이 옵션이 사용자 지정 GUI 에는 어떤 영향도 끼치지 않는다는 사실을 기억하십시오. --defaultui 옵션을 사용하더라도 GUI 환경을 사용자 지정해서 숨겨진 (상태 바 같은) 항목들은 숨겨진 채로 남을 것입니다. --nocustomization 옵션도 참조하세요.

9.6.1.17. --hide-browser

실행 시 사용자 인터페이스에서 Browser 패널을 숨깁니다. 툴바의 공백 부분에 오른쪽 클릭을 하거나 View ‣ Panels 메뉴를 클릭해서 탐색기 패널을 활성화시킬 수 있습니다. (kde Linux KDE 설치본에서는 Settings ‣ Panels 메뉴로 접근합니다.)

다시 활성화시키지 않는 이상, 탐색기 패널은 다음 세션에서도 숨겨진 채일 것입니다.

9.6.1.18. --dxf-*

QGIS 프로젝트를 DXF 파일로 내보내고자 할 때 이 옵션을 사용할 수 있습니다. 몇 가지 옵션을 사용할 수 있습니다:

  • –dxf-export: 레이어를 내보낼 DXF 파일명

  • –dxf-extent: 최종 DXF 파일의 범위

  • –dxf-symbology-mode: 몇 가지 값을 사용할 수 있습니다 ─ none (심볼 없음), symbollayer (심볼 레이어의 심볼), feature (피처 심볼)

  • –dxf-scale-denom: 심볼의 축척 분모

  • –dxf-encoding: 파일 인코딩

  • –dxf-map-theme: 레이어 트리 환경 설정에서 맵 테마 를 선택

9.6.1.19. --take-screenshots

사용자 문서 용 스크린샷을 찍습니다. 문서 스크린샷을 어느 카테고리/단락으로 생성해야 할지를 필터링하기 위한 --screenshots-categories 옵션과 함께 사용할 수 있습니다. (QgsAppScreenShots::Categories 참조)

9.6.1.20. --profile

사용자의 프로파일 폴더에서 특정 프로파일을 사용해서 QGIS를 실행합니다. 일부러 변경하지 않는 한, 선택한 사용자 프로파일을 다음 QGIS 세션에서 사용할 것입니다.

9.6.1.21. --profiles-path

이 옵션은 프로파일(사용자 설정)을 저장하고 불러올 경로를 선택할 수 있게 해줍니다. {path}\profiles 폴더에 프로파일을 생성하는데, 이 프로파일은 설정, 설치한 플러그인, 공간 처리 모델 및 스크립트 등을 담고 있습니다.

예를 들자면 이 옵션을 사용해서 USB 저장 장치에 사용자의 모든 플러그인과 설정을 담아 가지고 다니 거나, 파일 공유 서비스를 통해 서로 다른 컴퓨터들끼리 설정을 공유할 수 있습니다.

이에 대응하는 환경 변수는 QGIS_CUSTOM_CONFIG_PATH 입니다.

9.6.1.22. --version-migration

구 버전의 설정을 찾았을 경우 (예를 들어 QGIS 2.18 버전의 .qgis2 폴더) 이 옵션은 해당 설정을 기본 QGIS 프로파일로 가져올 것입니다.

9.6.1.23. --openclprogramfolder

이 옵션을 사용하면 사용자의 OpenCL 프로그램을 가리키는 대안 경로를 지정할 수 있습니다. 개발자가 기존 프로그램을 대체할 필요없이 새 버전을 테스트하는 데 유용합니다.

이에 대응하는 환경 변수는 QGIS_OPENCL_PROGRAM_FOLDER 입니다.

9.6.2. 조직 내에서 QGIS 활용하기

사용자가 조직 내에서 사용자 지정 환경 설정 파일과 함께 QGIS를 활용해야 하는 경우, 먼저 your_QGIS_PKG_path/resources/qgis_global_settings.ini 위치에 있는 기본 설정 파일을 복사/붙여넣기 해야 합니다. 이 파일은 이미 [] 로 시작하는 블록으로 식별되는 몇몇 기본 단락을 담고 있습니다. 이런 기본값들을 유지하면서 파일 하단에 사용자 고유의 단락을 추가하는 방법을 추천합니다. 파일 안에서 단락을 복사한 경우, QGIS는 위에서 아래 방향으로 마지막 단락을 사용할 것입니다.

QGIS 버전 확인을 비활성화하려면 allowVersionCheck=false 로 변경하면 됩니다.

QGIS를 새로 설치한 다음 마이그레이션 창(migration window)이 나타나지 않기를 원한다면, 다음 단락이 필요할 것입니다:

[migration]
fileVersion=2
settings=true

전체 수준 범위(global scope)에서 사용자 지정 변수를 추가하려면:

[variables]
organisation="Your organization"

설정 INI 파일의 가능성을 살펴보려면, QGIS 데스크탑에서 사용자가 원하는 환경 설정을 변경한 다음 텍스트 편집기를 통해 사용자 프로파일 폴더에 위치한 INI 파일에서 변경 사항을 찾아보는 것이 좋습니다. WMS/WMTS, PostGIS 연결, 프록시 설정, 맵 팁 등과 같은 수많은 설정을 INI 파일을 사용해서 설정할 수 있습니다.

마지막으로, 사용자 지정 파일의 경로를 가리키는 환경 변수 QGIS_GLOBAL_SETTINGS_FILE 을 설정해야 합니다.

또한 QGIS 시스템 디렉터리나 QGIS 사용자 프로파일 폴더에 있는 파이썬 매크로, 색상표, 조판기 템플릿, 프로젝트 템플릿 등과 같은 파일들도 활용할 수 있습니다.

  • 조판기 템플릿은 composer_templates 디렉터리에서 활용해야만 합니다.

  • 프로젝트 템플릿은 project_templates 디렉터리에서 활용해야만 합니다.

  • 사용자 지정 파이썬 매크로는 python 디렉터리에서 활용해야만 합니다.